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1 Rail Moudule
The following outlines the main tools and functionality within the SCC Rails Modules.

1.1 Rail Traverse

The following outlines the steps to process a Rail traverse.  Error checking, the application of
Centre Error Correction and the introduction of Known Stations are examined. 

Creating A Project Directory

From the Main Screen, select 'DATA tab > New'’

Enter in a Project/Job name 'Rail_Traverse'

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’

Download Raw Data

 From the Main Screen, select 'DATA tab > Download'

Set up the following:

Press 'Ok'

Select raw file '\RailData\Traverse\Rail-day.GSI'

Within the Leica data input (1100/1200/Wildsoft/LisCADD) dialog, pick 'Rail-day.
GSIConfig' file and Press 'Ok'

Note: this file is within the SCC folder, as a result, available on the drop down menu
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Error Checking

Go to the 'TRAVERSE tab > Adjust > Reduce'

Set up the following:

Press 'Ok'

Reduction Report

From the Pick A Report dialog, select 'SCC Traverse reduction (All).rpt' and Press 'Ok'
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Examine Report:

There is a notable Slope Distance Error:
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Removing Error from Traverse:

Select 'No' within 'Use Obs' column for record 15 At Stn CST02 To Stn CST03

Re-run Reduction:

Go to the 'TRAVERSE tab > Adjust > Reduce'

Set up the following:

Press 'Ok'

Reduction Report

From the Pick A Report dialog, select 'SCC Traverse reduction (All).rpt' and Press 'Ok'

Review Results.  Note how the Stand Deviation for Slope Distance is now 0.00

Remove Stations From the Project 

Go to Project View, remove stations that have been downloaded from raw file

Select ''EDIT tab > Delete Records' set up the following:
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Adjust Traverse Based on Fixed Base Line

Go to 'TRAVERSE tab', Select 'Setup'

Set opening set up as shown below, allowing SCC to generate a RO values:

Press 'OK'

Select 'Adjust', set up the following and Press 'Ok'
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Review Results and select 'Yes, to use provisional coordinates'

Applying Corrections:  Centring Error

Go to 'TRAVERSE tab', Select 'Adjust drop down > Corrections'

Set up Centring Errors as shown below and Press 'Ok':

Re-adjust and review report

Level Data

Open 'Levels.Traverse'
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Go to 'TRAVERSE tab', Select 'Adjust'

Set up the following:

Select 'OK' and Review report

Select 'Yes, to use Adjusted Coordinates'

Known Station Values

Close existing project and open 'GPSCoords.Project'

Note: Coordinates are constrained based on information from the GPS report (rE/X, rN.Y,
rHt/Z)

Run Adjustment

Go to 'TRAVERSE tab', Select 'Adjust'
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Press 'Ok' and Review Report

Select 'Yes, Use Adjustment Values'

1.2 Rail Analysis

SCC can be used for analysis and reporting of Rail data. 

1.2.1 Rail Overlap

String comparison and overlap processing option are available within the model view under 
'DESIGN tab > Rail button > Compare strings and remove overlaps'.  This requires a model with
one or more overlapping strings, and an alignment for reference purposes.  The following is an
example of the usage of this function based around the sample data provided;

Creating A Project Directory

From the Main Screen, select 'DATA tab > New'’

Enter in a Project/Job name 'Overlap'

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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Create Model

Go to 'DATA tab > Model drop down > SCC Dataset'

Go to \RailData\Model\Biggin.Survey'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'

Select 'Ok' to model attribute dialog

Select RR String Information

Right click the mouse to bring up the Data Selection Dialog

Select 'All points on selected string' and 'Ok'

Left click mouse on RR line strings

 String Overlap

Go to 'DESIGN tab > Overlaps' button

Set up the following:
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Press 'Alignment>>', set up the following and Press 'OK':

Pick 'String Overlap (Diff).rpt' and Press 'OK'

Review Report
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Repeat String Overlap

Go to 'DESIGN tab > Overlaps' button

Set up the following and Press 'Ok':

This time ensure that 'Report only, do not change model' is not selected and 'Use active
alignment for reference' is selected

On completion note the RR string is one complete string
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1.2.2 Cant & Gauge Reporting

Using the opened data a Cant & Gauge report can be generated.

Reporting Cant & Gauge

Go to 'DESIGN tab > Rail drop down menu > Report cant and gauge'

Note there must be an active alignment present

Set up the following and Press 'OK'

Pick 'Rail guage and cant.rpt'

Review Report 
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1.2.3 Lift & Slue Reporting

Using the opened data a Lift & Slue report can be generated.

Remove Existing Alignment

Go to 'DESIGN tab > Attach'

Highlight attached alignment, select 'Detach All' and 'Ok'

Attach Design Alignment

Go to 'DESIGN tab > Attach drop down menu > Alignment'

Select ' \rail-day\Lift & Slue\MC02.Alignment'

Reporting Lift & Slue

Go to 'DESIGN tab > Rail drop down menu > Report Lift and Slue

Review Report

1.3 2nd Rail

Using Parallel offset options within SCC, a 2nd rail string can be generated.

Go to 'DATA tab > Model drop down > SCC Dataset'

Go to '\rail-day\2nd Rail\Rail2.Survey'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'
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Select 'Ok' to model attribute dialog

Additional String

Go to 'ADD tab > Parallel'

Set up the following Copy Parallel Options

Pick RD string on screen and then 'CheckCantAndGauge.rpt' from dialog.  Press 'Ok' 

Review Report

Select Yes to 'Create rail string' and click on screen to position string

1.4 Import Amberg Data

An input routine to support the Amberg Trolley data provided. This creates two points per line,
one for left rail, one for right rail, using the station for string number and ident for point number.
D1,D2, and D3 are used to store odometer, gauge, and super-elevation in the input file, such
that they can be annotated as required. The rail features are named LRAIL and RRAIL. 

Close all dataset and models.  Leave existing Project file open

Importing Amberg Trolley Data

Go to 'DATA tab > Import drop down menu > Amberg GRPWin'
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Pick 'DN Branch.asc', set up the following and then Press 'OK'

The dataset is present whereby the D1 is Dist, D2 is Gauge and D3 is Cant

Create Model

Go to 'DATA tab > Model drop down > SCC Dataset'

Pick 'DN Branch.Survey'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'
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Note the Chainage/Offset system present is been read from the dataset not an active
Alignment

1.5 Design From XML

The following describes how to create different surfaces in SCC from a given design and export
to XML for Machine Guidance.  

- Design data will be provided as an XML file with a given centreline string including cant and
gauge

- Three design surfaces are generated: Rails (including gauge and cant), Ballast and Formation

- The Ballast layer will ramp down at chainage 380m and ramp up at chainage 480m

- A 0.300m gap will be maintained from the lowest sleeper end to formation

1.5.1 Create A Project Directory

From the Main Screen, select 'DATA tab > New'

Enter in a Project/Job name 'Design from XML

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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1.5.2 Modelling LandXML file

Within the 'DATA tab > Model drop down > LandXML file'

Go to '\rail-day\Design XML\Biggins v1.1.xml' and Press 'Open'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'

Select 'Ok' to model attribute dialog

Set up the following and press 'Ok'

Select 'Home' within Model to Zoom Extent 

1.5.3 Attach Design Alignment

Within Model, go to 'DESIGN tab > Attach drop down menu > Alignment'

Select 'Prop CL copy.Alignment
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1.5.4 View Design Information

Within the 'DESIGN tab > View > Vertical Entities'

Within the 'DESIGN tab > View > Rail Cant'
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NOTE:  If no Cant values where present in the XML file, values can be entered manually
by viewing Rail Cant and then selecting 'DESIGN tab > Insert Records'.  Cant is entered
in mm.  CW is Clockwise / CCW is Counter Clockwise.

Save Alignment

1.5.5 Creating Design Gauge & Cant

Go to 'DESIGN tab > Template button'

Then 'DESIGN tab > Tools > Enter gauge and compute cant'

Set up the following:



20

©2017 Atlas Computers Ltd

NOTE:  

The dialog uses values from the input XML file

Enter the Cant Base

Apply cant will apply cant form Cant Station (Cant entered is mm)

Report Cant by Chainage will give a report file showing cant, gauge and rail levels before
continuing

Add Sleepers to template will include sleepers on the rail surface

Apply cant from edge of sleeper will apply cant from edge of sleeper

Select 'Create Template' which will use setting to create a section template

Press 'OK' to create a report 

A Section Template is created.
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1.5.6 Applying Sleeper Vertical & Horizontal Offset

Within Template Design, select 'EDIT' 

Left click mouse on 'SLPL' on screen

Set up SLPL: Horz. Offset -1.20 / Vert. Offset -0.3 (300mm lower than rails) as shown

Press 'Apply'

Left click mouse on 'SLPL' on screen

Set up SLPR: Horz. Offset 1.20 / Vert. Offset -0.3 (300mm lower than rails) as shown

Press 'Apply'
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1.5.7 Add Ballast Layer

Select 'New Surface' 

Set up the following and Press 'OK'
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1.5.8 Removing Sleepers From Ballast Surface

Select 'Delete' 

Left click mouse on 'SLPL' and then select 'Delete Point'

Left click mouse on 'SLPR' and then select 'Delete Point'

1.5.9 Editing Ballast Surface

Select 'Edit'

Left click mouse on 'BL' point

Enter Horz, Offset -0.2 and Vert. Offset -0.3

Press 'Edit Point'
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Left click mouse on 'BR' point

Enter Horz, Offset 0.2 and Vert. Offset -0.3

Press 'Edit Point'

1.5.10 Add Formation Layer

Select 'New Surface' 

Set up the following and Press 'OK'
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1.5.11 Removing Sleepers From Formation Surface

Select 'Delete' 

Left click mouse on 'SLPL' and then select 'Delete Point'

Left click mouse on 'SLPR' and then select 'Delete Point'
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1.5.12 Editing Formation Surface

Need to change Feature Codes on Formation surface and apply offset and grade change

Select 'Edit'

Left click on 'RL' on Formation Surface

Enter New feature code 'FL'

Horz, Offset -2 and Gradient +1:30

Press 'Edit Point'

Left click on 'RR' on Formation Surface

Enter New feature code 'FR'

Horz, Offset 2 and Gradient -1:30

Press 'Edit Point'

1.5.13 Adding Ramp at Chainage 380 to 480

Ramp down at Chainage 380 and ramp up at Chainage 480

Select 'New Section'

Enter Starting chainage for new template of 380 and press 'OK'
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Select 'New Section'

Enter Starting chainage for new template of 400 and press 'OK'

1.5.14 Inputting Ramp Design on Ballast layer

Section 3 Chainage 400

Select 'Edit'

Left click on 'BL' on Ballast Surface

Horz, Offset -2 and Vert. Offset -0.9

Press 'Edit Point'

Left click on 'BR' on Ballast Surface

Horz, Offset 2 and Vert. Offset -0.9
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Press 'Edit Point'

Select 'New Section'

Enter Starting chainage for new template of 480 and press 'OK'

Select 'New Section'

Enter Starting chainage for new template of 500 and press 'OK'

Section 5 Chainage 500



29

©2017 Atlas Computers Ltd

Select 'Edit'

Left click on 'BL' on Ballast Surface

Horz, Offset -2 and Vert. Offset -0.3

Press 'Edit Point'

Left click on 'BL' on Ballast Surface

Horz, Offset 2 and Vert. Offset -0.3

Press 'Edit Point'

Save Alignment

Template is visible on the model displaying the alignment
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1.5.15 Export Rail Design

Go to 'DESIGN tab > Model' Export

Set up the following and press 'Ok':

Press 'Ok' to model attribute dialog

1.5.16 Triangulate Rail Model

Within 'MODEL tab > Edit'

Using 'All triangles intersecting line' as the Selection Method and 'Remove triangle' as the
'Action', edit the TIN
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Select 'Apply'

Select 'Yes' to 'Store model boundary as a string'

Save Model as 'RAIL.Model'

1.5.17 Long Section With Cursor

Go to 'ANALYSIS tab > L. Sect button'

Left click mouse to pick first point of section and then again to pick second

Right click mouse to finish

A profile of the Rail surface is created
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1.5.18 Export Ballast Design

Go to 'DESIGN tab > Model' Export

Set up the following and press 'Ok':

Press 'Ok' to model attribute dialog

1.5.19 Triangulate Ballast Model

Within 'MODEL tab > Edit'

Using 'All triangles intersecting line' as the Selection Method and 'Remove triangle' as the
'Action', edit the TIN
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Select 'Apply'

Select 'Yes' to 'Store model boundary as a string'

Save Model as 'BALLAST.Model'

1.5.20 Export Formation Design

Go to 'DESIGN tab > Model' Export

Set up the following and press 'Ok':

Note: Cant is not applied on Formation Level.  Untick 'Apply Super-Elevation /Cant'
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1.5.21 Triangulate Formation Model

Within 'MODEL tab > Edit'

Using 'All triangles intersecting line' as the Selection Method and 'Remove triangle' as the
'Action', edit the TIN

Select 'Apply'

Select 'Yes' to 'Store model boundary as a string'

Save Model as 'FORMATION.Model'

Three Triangulated Model have been created.

1.5.22 Check & Adjust Formation Levels

In order to maintain fixed depth levels between low rail and Formation, the 'Check and
adjust formation levels' tool can be utilised.

Go to 'DESIGN tab > Rail > Check and adjust formation levels'

Set up the following including required vertical seperation and press 'Ok'

Select 'Ok' to model attribute dialog

Pick 'Formation adjustment.rpt' file and press 'Ok'

The report details the Level adjustment, the exact difference in height between formation
and low rail, and the chainage is note
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The report can be exported to various formats

A new Adjusted Formation Model has been created.  

Edit the TIN as above. 

Save as 'AdjustedFormation.Model'

1.5.23 Combining Models & Alignment for QA puposes

As a QA check, models can be combined and section generated.

Within 'RAILS.Model', go to 'DESIGN tab > Attach drop down > Model'

Select 'BALLAST.Model' and then repeat, to select 'AdjustedFormation.Model'

Go to 'DESIGN tab > Attach drop down > Alignment' and select Alignment file



36

©2017 Atlas Computers Ltd

Go to 'ANALYSIS tab > L.Sect drop down > Live Section'

Set 'Cross section along alignment' and offset left/right 5.

Move cursor along along alignment, left click to generate live section in sub divided screen

Close without saving

Go to 'DESIGN tab > Attach drop down > Edit/Detach' 

Highlight Ballast and Formation Model, select 'Detach' and 'Ok'
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1.5.24 Exporting XML For Machine Control

Within the 'Rails.Model' which has the Alignment file attached, go to 'DATA tab > Export
drop down > LandXML'

Set up the following and press 'Ok'

Select 'Ok' to model export dialog

Close 'Rails.Model' and open 'BALLAST.Model', attach alignment file and repeat export
steps

Similarly, repeat for 'AdjustedFormation.Model'

1.6 Computing Platform Edge Using Bance Gauge

The following outlines the steps to compute platform edge using Bance Gauge.

Open Existing Project & Dataset

From the Main Screen, SCC button 'Open'

Go to 'C:\SCC\rail-day\Bance Gauge' 
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Open 'Platform.Project' and 'Bance Gauge test1.Survey'

Compute Platform Position from Bance Gauge

Go to 'SURVEY tab > Tools > Compute Platform Position From Bance Gauge'

Set up the following and press 'Ok'

Select 'OK' to 'Extra Title Fields' dialog 

Select 'PlatformGaugeSurvey.rpt' from Pick a Report dialog and press 'Ok'

Review report
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1.7 Wriggle Survey Processing

Wriggle survey functionality which can be accessed as follows;

'DATA tab >  Import >  ASCII Wriggle Survey' from a project

'SURVEY tab  > Tools >  Compute Wriggle Survey' from the survey coordinates view'

''SURVEY tab  > Tools >   String using Chainage > Offset from the survey coordinates
view'

This is used in conjunction with an alignment to group point data into rings.

To process the sample files  9961065.ASC, 200_UPLINE-.CAN, 200_UPLINE-.HOR and ,
200_UPLINE-.VER do the following;

Creating A Project Directory

From the Main Screen, select 'DATA tab > New'

Enter in a Project/Job name 'Wriggle'

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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Create an alignment from the 200_UPLINE files

'DATA tab >  New drop down >  New document > SCC Alignment'

'DATA tab > Import drop down >  ACT horizontal entity file, picking
'200_UPLINE-.HOR' 

'DATA tab > Import drop down >  ACT vertical entity file, picking '200_UPLINE-.VER'

'DATA tab > Import drop down >  ACT cant file, picking '200_UPLINE-.CAN'

From the Main Screen, SCC button 'Save As' 200_UPLINE.Alignment'

'SCC button > Close'

Import the ASCII survey file

'DATA tab > Import drop down >  ASCII Wriggle Survey, picking '9961065.ASC'

SCC button 'Save'

Compute the wriggle survey

'SURVEY tab > Tools > Compute Wriggle Survey', using parameters shown and pick
'WriggleSurvey.RPT' as the report file
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This will compute the wriggle survey and show the following report.  

Note:

· that with bearing and gradient computed from ring data, the alignment is not used in the
computations.  It is still used in the report to show the difference between bearing and
gradient values computed via linear regression and those computed for the alignment.

· Bearing and gradient computation determine whether the tunnel bearing and gradient is
based on the alignment or the connected ring circles generated in processing

· Export options control whether in addition to the report you get a section file, model
and/or survey data set on output, and whether they include the surveyed points, design
circle radius and/or best fit circle radius.

· The design radius is the nominal radius of the tunnel

· The outlier distance is the distance from the design radius at which points are rejected
as noise / not on the tunnel surface.  The wriggle process is actually computed twice,
first to remove outliers, second to get a clean result.

· The radial offset is a prism constant from observed point to tunnel face

· The deformation tolerance is the distance above which points in the survey are flagged
as out of range / build tolerance / potential obstructions

· Adding an extra rail model to the output shows the rail position with respect to the tunnel

· the contact details in the report are taken from 'General Options >  Module Licenses >
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Edit user details'.  The layout and content of the report can be modified to suit individual
client needs independently of SCC using Crystal reports XI or later.  Results from the
SCC viewer can be saved into Microsoft Excel for further analysis by pressing the
export button on the top left of the viewer.  This also supports a wide range of other
formats included Word, PDF and ODBC database tables.

When comparing the results with the output file provided, 9961065.out, SCC is producing
identical radii, and horizontal and vertical offsets that agree to within 1mm.  The easting
and northing of the centres deviate by ~10mm to 30mm but looking at the radial residuals,
e.g. the difference between the final computed radius and distance from computed centre
to each point, which would imply that the SCC result is more accurate because the sum of
the residuals in the SCC report is smaller than those in the output report provided,
indicating a slightly better circle fit.  For example on ring 1, both routines agree a radius of
3.574, and the residuals are as follows;

9961065.out SCC

Point Radius Residual Radius Residual

1099601 3.578 0.004 3.579 0.005

1099602 3.584 0.010 3.584 0.010

1099603 3.567 -0.007 3.567 -0.007

1099604 3.565 -0.009 3.566 -0.008

1099605 3.579 0.005 3.579 0.005

1099606 3.579 0.005 3.579 0.005

1099607 3.577 0.003 3.577 0.003

1099608 3.561 -0.013 3.571 -0.003

Sum of square of residuals

0.056 0.046

We can see from this that the SCC centre is a slightly better fit for the data provided.

Case Study Data

To process ascii compiler-1.csv, 300DOWNLINE-.HOR, 300DOWNLINE-.VER, and
300DOWNLINE-.CAN do the following

Downloading & Importing Data

Create a new project as described previously

Import the ACT alignment files into SCC as described previously

'DATA tab >  Download' picking 'ascii compiler-1.csv' using the parameters shown below
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Computing Chainage Offset from X,Y

To group the data into rings, select 'SURVEY tab > Tools  > Compute Chainage,Offset
from X,Y'

String using Chainage Offset 

Select 'SURVEY tab > Tools  >String using Chainage & Offset'

'SCC button >  Save'

Compute the wriggle survey

'SURVEY tab > Tools > Compute Wriggle Survey', using parameters shown and pick
'WriggleSurvey.RPT' as the report file

Compute the wriggle survey as described previously, picking the 300 downline alignment
file to get the following report
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Notes from the results;

The computed bearing and gradient shown by SCC are ~180 degrees off the alignment
value for the same section.  This could be corrected using the alignment if required. 
Without an alignment the orientation of the section is arbitrary and can flip by 180
degrees, which also reverses the gradient.  

It doesn’t affect the centre, radius or offset values.

Comparing the results to those supplied in 320 wriggle analysis.xls all the radii in SCC are
exactly 50mm smaller which appears to correspond to the BFC from DTA radial value and
Lining radial value in the xls file.  Horizontal and vertical offsets appear to agree to with
about 2mm but centres are differ by ~50-60mm.  This could possibly be related to radial
offsets.  Re-computing using alignment bearing and gradients does not appear to make a
significant difference to this, though further investigation is probably required.

The xls provided appears to have a limit of size points per ring, though this could just be a
reporting anomaly.
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