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1 Introduction

1.1 SCC Training Manual

The following document outlines the main principles, concepts and tools within SCC
Survey,Volumes and Section Modules during an SCC Training day.

On-line help

In addition to the printed documentation, additional help is available in the form of on-line context
sensitive help from within SCC.  The on-line help is likely to contain more up to date information
than the printed manuals, and additionally will contain extra multi-media content such as video
examples covering the use of different program options.  For the very latest documentation and
program updates, visit the SCC web site at www.atlascomputers.ie 

Documentation Conventions

NOTES are something of special interest.  They should be remembered.  If
not,  at least  they  will  be  easy  to  find  in  the  future  when  surrounded  by  a
double border.

All menu and command options will be in inverted commas, with the main menu title appearing in
CAPITAL LETTERS. 

All actions required by you, will be indented and appear in italics. 

There will be a heading at the top right of the instructions describing the aim of the exercise. 

Follow these exact instructions to achieve the proper results.

An example might be:

Action Identifier Table Heading

From 'MODEL Tab > Join str'

Pick the two strings from the graphic model

1.2 Installation and set-up

SCC installation is available on DVD or from links to the Atlas ftp site.  Full installations or
upgrade files are available for installation. If you have a previous version of SCC installed the user
can choose to update current version using an update file

If you have a previous version of SCC installed the user can choose to update current version
using an update file. 

To Install/Update SCC from link

If you have SCC already installed on your computer, backup your existing SCC directory and
any sub-directories off it. 

Plug the SCC hardware lock (dongle) into  USB port

Download file from link

Once downloaded, right click on file and select 'Run As Administrator'

Follow prompts installing in the default location
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The hardware lock driver will also install.

Select Finish

Run SCC, either by double clicking on the SCC icon or by selecting SCC from the Windows
program menu.

Before performing any operations in SCC, it is important to ensure directories and external
links are setup correctly.  It is sufficient to set up these links once.

Directories & Files:File Structures

Setting up SCC Directories and Files:

SCC can have direct links to a text editor, CAD and/or MX.  Having a link to a CAD system or MX
will mean that when exporting a model, the CAD system or MX will open automatically and the
drawing will be generated in that program.

The Executable files, Projects and Temporary files directory will be filled in automatically during
installation.  If the default settings differ from yours ensure you change them to correspond to
your specific directory structure.

The Windows WordPad is used as the default Text Editor.  No path directory has to be
entered in this option, simply type the word NOTEPAD.  Any time any reports are edited
they will be presented in the Text Editor.  Having a link to a CAD system or MX will mean
that when exporting an SCC model or section, to either CAD or MX, they will be
automatically opened and the drawing generated in that system.

Go to ‘DATA tab > Settings >  General Options > Directories and Files’ panel

Check and see that the executable files directory is correct. 

If you have installed SCC in a directory other than the default, type in the correct path to this
directory.

Check and see that the projects directory is correct. This should normally be the same
directory as the executable file directory.

Make sure that the temporary directory stated exists.  If not create this directory. 

Select the path to your CAD executable file.

Identify the text editor you wish to use for SCC generated reports. 
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SCC uses the Windows Wordpad as its default Text Editor. This link will be automatically set
during installation. SCC generates reports for some functions it carries out, such as traverse
reduction, adjustment and volume calculation. If you choose to edit/view these reports while SCC
is running the selected editor will display the report.

It is also possible to change the background colour of SCC from this panel as well as the screen
colours themselves as colours that are visible on a white background may be less visible on a
black background.

Module Licences

Maintenance codes will be specific to your dongle number/node lock number and the expiry date.
10 days before your maintenance is due to expire, a reminder message will be displayed on
opening the program. This message will be displayed until the maintenance has been renewed.

Go to  ‘DATA tab > Settings >  General Options’

Select the ‘Module Licenses’ panel 

Ensure you have the entered the correct maintenance code and maintenance expiry date.
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To install Maintenance Codes and Expiry Date:

Go to ‘DATA tab > Settings >  General Options’

Within the 'System Variables' dialog box go to 'Module Licenses' 

Enter Maintenance Code 2 and Maintenance Expiry Date 

Select 'Purchase Maintenance' 

A black correct symbol should appear in the box beside 'Maintenance Enabled'

Units & Data Checking

During the download procedure, SCC also range checks every field against a user definable
range of values. Any exceptions are reported to the log file, and optionally to screen during the
download process. The log file also includes any other potential errors relating to the input data,
reduction, adjustment and subsequent analysis.  

The level of detail included in the log file is also user definable, ranging from minimal to full
diagnostic. When run in diagnostic mode, SCC will also log all intermediate computational
results to the log file for QA purposes, such as matrix dumps in least squares analysis or
transformation, triangulation computations during modelling, etc…  This can prove an invaluable
tool both for support, and when attempting to track down a complex data related error or query.

Go to ‘DATA tab > Settings >  General Options> Units & Data Checking’ panel 

Select the type of ‘Input Range Checking’, ‘Error Reporting Method’ and ‘Error Reporting
Detail’ options you prefer.

You may also set the ‘Undo’ facility in this panel but remember that the more undo levels you
select, the more memory taken.
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1.3 32 bit & 64 bit SCC Versions

SCC now includes separate native 32 bit and 64 bit versions of SCC.  The 64 bit version of SCC
requires Windows 7 (64 bit) with 2GB or more of RAM. 

2 Basic Concepts

This section deals with the basic concepts and terms used within SCC.  It aims to explain how
SCC generates maps and surfaces from observed survey data, and what mechanisms are used
to transfer the information generated into other CAD and design packages such as AutoCAD,
MicroStation and MX. 

2.1 Data storage and user interface

Data Storage

SCC uses the Microsoft document/view architecture to store and edit all its information.  A
document is a file on your computer used to store one or more pieces of related information in a
self contained format, that is recognisable by the Windows operating system.  Examples of
documents include Word documents, Excel spreadsheets, etc..  Each of these document types
have corresponding disk files and are registered with the operating system for use with other
programs, such as explorer.

When using SCC, all the documents relating to a given survey project, including SCC documents
and other data such as CAD drawings, will be stored in a project folder.  This folder is created
when the 'New Project' option is selected, taking its name from the project name.  The location of
this folder is set-up in the  'General Options > Directories and Files' dialog, by default it will be
'C:\SCC'.  When we create a new project, a new SCC project document is opened in the project
folder, based on a selected project template.  All data downloaded or imported, and models and
sections generated in this project are stored in this new folder.  While you can enter names for
all documents, file extensions are controlled by SCC.  As with other document based Windows
software, when closing a file within SCC you will be prompted to save this file if it has been
modified.  If you are carrying out a lot of editing on any document, and you are not using a
version control system to manage your revisions, we recommend that you regularly save your
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changes, given each saved version a revision based file name.  For example, if you create a
model called MyModel, the first time you save it you might call it MyModel01.Model. 
Intermediate edits might be saved as MyModel02.Model, MyModel03.Model, etc.., and the final
model saved as MyModel-Final.Model.  In this way, if you make any errors during the editing
process, you can always revert to a previous version.  Alternatively, you can use an automated
back software, such as Active Backup (www.ajcsoft.com),  to do this for you.

SCC versions and updating

Please note the following with regards to SCC versions and version compatibility.  The SCC
version is made up of three digits; the release number, the major version, and the minor version. 
For example, SCC 11.4.8 is SCC release 11, version 4, sub version 8.  The release number
typically changes on an annual basis, when all users with a current maintenance contract are
issued with new full installation CDs and supporting documentation.  The major version changes
when a modification is made that necessitates a file format change, that may in turn lead to
backward incompatibility with previous versions.  For example, SCC 11.0.0 may not be able to
fully read all files created with 11.1.0.  A minor version change indicates a software modification
that has no bearing on file format compatibility, for example SCC 11.4.2 can read files created in
11.4.8 as all data created in SCC 11.4.x has the same file format.  Therefore, for a group of SCC
users wishing to ensure that they will be fully data compatible, they should all be on the same
release of SCC and the same major version.  Note that like most commercial software, such as
AutoCAD, MS Office, etc.., all versions of SCC can always read all files created from any
previous version.  Compatibility issues only arise when attempting to read files created by a later
version than the version in use.

XML Support

SCC also supports loading and saving of all of its document files in the industry standard XML
format, in addition to its native formats.  XML (extensible mark-up language) is an ASCII format
widely used in Internet and database applications for the exchange and archiving of data.  It has
the following advantages; Data saved by SCC in XML format is both backward and forward
compatible with any XML enabled version of SCC.  XML is an open data format, thus SCC XML
data may be translated into other formats by third party software where required.  Note that XML
has the disadvantages that it is much slower to save and load, and is much larger in size than
native SCC binary formats.  SCC XML options are available from the File / XML menus throughout
the program.

User Interface

The view is the principal graphical interface to a document.  Some documents have a single view,
for example in Word, the view is the area on screen where you type in your text.  Other programs
will have multiple views, for example in Excel, you might have a single spreadsheet that contains
many pages, though each page belongs to the same .XLS document.  SCC documents typically
have multiple views, for example in a survey data set, detail observations and reduced
coordinates are presented in separate spreadsheet views.   All of the views in SCC are either
spread sheet views, or interactive graphical views, and have a unique name and graphical icon,
displayed in a tab at the bottom of the view.  The simplest way to switch between views is to left
click on this tab with the mouse.

Documents

SCC creates and works with the following document types: Projects, Survey Datasets,
Traverses, Models, Sections, Transformations, Alignments and Program modules.  A brief
description of each document is given below, along with the views available and icons used.

http://www.ajcsoft.com
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2.1.1 Project

A project document is used to share station coordinates between other SCC documents in
the project folder, and to determine drawing and modelling conventions used.  It contains
four sheet views

Station coordinates, used to establish and maintain the grid system used in this
project.

Feature Library, used to control naming conventions, drawing standards and
modelling defaults.

Ground Type Library, used to break down different parts of the surface model
into various ground types for viewing and analysis purposes.

Advanced Survey Coding, used to control how coding in the field is interpreted
into features and reduction options.

In addition to this the project file stores copies of all ancillary drawing support items such as
symbols, line-styles, sheet layouts, text styles, and bitmaps that are used in model and
section drawing.

Project - Station Coordinate Sheet

Project - Feature Library Sheet
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Project - Feature Wizard

2.1.2 Traverse

The traverse document is used to store observations relating to traverse and network
adjustments.  Within the Traverse document you can reduce and edit setups, apply relevant
corrections and perform adjustments.  The traverse document includes three sheet views

The traverse observation view, including observed angles and distances, reduced
values, and computed residuals

The traverse coordinates view, including provisional and adjusted station
coordinates, and computed error ellipse axes
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Station coordinates, a back-up of the station coordinates used in this traverse,
such that the traverse document is fully self contained.

Traverse Sheet

Corrections



10

©2018 Atlas Computers Ltd

Traverse - Setup Dialogs

2.1.3 Dataset

The survey document is used to store raw detail observations and reduced detail
coordinates in a normalised format.  Survey datasets can be created by downloading data
from a survey instrument, or importing reduced data from another file.  Depending on the
data source, they may or may not contain any observation data.  The survey document is
made of the following five sheet views;

The detail observation spreadsheet contains all of the observations in any given
survey. Note that these observations can be total station angles and distances, GPS
latitude, longitude, height, or X, Y, Z.  These different observation types may be also freely
mixed in a given job. From the observation view, we can also specify various reduction
parameters and defaults including corrections, mapping projections and GPS datum and
transformation. Any changes made in the Detail Observation view will require the detail
co-ordinates to be rebuilt in order to reflect the new changes.  If the co-ordinates were not
formed from a detail survey then this sheet will be blank.



11

©2018 Atlas Computers Ltd

Instrument Set-ups, containing observed back-sights, used to orient the
horizontal circle whenever the total station is moved.  The instrument set-up sheet also
contains distance and coordinate misclosures, along with other QA fields.  Each instrument
set-up is numbered, and each detail observation contains a corresponding set-up number.  
Modifying the station set-up details will require the associated survey to be re-coordinated
and the model to be rebuilt.  If the co-ordinates were not formed from a detail survey then
this sheet will be blank.

Text Notes, used to store text data and placement details.

Extra Measurements, used to store measurements other than direct
observations, such as tape measurements and copied strings.  If the co-ordinates were not
formed from a detail survey then this sheet will be blank.
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Detail Coordinate Sheet, used to store reduced topographic coordinates, sorted
alphabetically by feature name and string number.  Note that the detail coordinates sheet
may contain interpolated data, such as curve fit points, in addition to reduced observations
or imported coordinates. 

Station coordinates, a back-up of the station coordinates used in this survey,
such that the survey document is fully self contained.  In addition to the above sheet views,
the survey document also includes a copy of the downloaded survey data as a text file in its
native format, such that the other spreadsheets can be reconstructed in their originally
downloaded state at any time.

2.1.4 Model

Models are used to display and manipulate survey data graphically as plan drawings, in a
similar manner to CAD. Models can contain a mixture of 2d and 3d information, and will
typically include a triangulated surface model or TIN.  The surface model is used to
interpolate elevations that have not been directly observed, for analysis purposes such as
contouring and volume calculation.  Models can be formed either directly from coordinates
sources, such as CAD or MX GENIO, or from reduced survey datasets.  SCC includes an
extensive range of graphic editing tools that enable simultaneous editing of the planimetry
and 3d surface.  In addition to graphic editing, the model may also be edited as a
spread-sheet using a split screen editor.  SCC models contain the following views;

Plan view, used for all graphical display and editing

Station coordinates, copied from the surveys used when creating the model.
You may also cut and paste in additional unreferenced stations from the project as required.
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Feature Library, copied from the project, used to control naming conventions,
drawing standards and modelling defaults.

Ground Type Library, copied from the project, used to break down different parts
of the surface model into various ground types for viewing and analysis purposes.

ZVI station coordinate, used for ZVI station positions in visual intrusion analysis

As with the project, the model also stores copies of all referenced symbols, line styles, text
styles, bitmaps, and sheet layouts, such that it forms a fully self contained document. 
Additional SCC documents, including traverses, alignments, sections and even other
models may also be attached to a model for graphical display purposes.

Model 

Model - Split View option which allows the user to browse the dataset table whilst the cursor
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interactively moves to the chosen x, y, z

2.1.5 Section

A section document is used to graphically represent profiles, long sections and cross
sections.  Sections can either be cut from a model or generated directly from coordinate or
chainage / offset data, can include any number of surfaces per section, and can be drawn to
user defined standards.  A section document contains the following views;

Section view, used for all graphical display and editing

Feature Library, copied from the project, used to control naming conventions,
drawing standards and modelling defaults

As with the project, the model also stores copies of all referenced symbols, line styles, text
styles, bitmaps, and sheet layouts, such that it forms a fully self contained document. 
Section style files can also saved and loaded from section views to simplify the process of
applying standard drawing styles and sheet layouts to different types of section drawings. 
Sections can also be attached to ground models, to show their plan position, and annotated
with chainage and offset.
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Section – Long Section from An Existing String

Section – Cross Section from An Existing String
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Section – Cross Section File Attached to Model 

2.1.6 Transformation

The transformation document has a single spreadsheet view consisting of pairs
of control co-ordinates used to move datasets between coordinate systems.  SCC includes
2D affine plus level shift,  2D / 3D conformal, 2D / 3D scale free and 2D / 3D best fit (2 or
more points) transformations. Furthermore, SCC supports national grid transfromations
between ITM, Irish Grid, OSGB36 and ETRS89.  These transformations utilise Grid Inquest
software provided by Quest Geo Solutions. Transformations may be applied to project
stations, reduced coordinates and models.

Transformation - Local Grid to National Grid

2.1.7 Alignment

The alignment document stores all information relating to horizontal, vertical, and section
template design data.  SCC enables you to create linear and polygonal designs, using both
interactive graphics and spreadsheets.  Designs can include surfaces and multiple section
templates for different chainage ranges.  Linear designs can be created either from
horizontal and vertical intersection points, or directly from entities.  Designs may also be
imported from MX GENIO geometry and master alignment strings, and from other design
packages.  The SCC alignment document contains the following views;

Horizontal intersection points
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Vertical intersection points

Horizontal entities

Vertical entities

Section template points

Super-elevation nodes

Interactive section template design

Interactive vertical design

Interactive horizontal design is carried out in plan in the model view.  As with the project, the
model also stores copies of all referenced symbols, line styles, text styles, bitmaps, and
sheet layouts, such that it forms a fully self contained document.  Alignment documents
can also include attached models representing non-alignment related strings in the design,
and a model for level reference.

Alignment - Horizontal Geometry Entities

Alignment - Vertical Geometry Entities
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Alignment Attached to Model

2.1.8 Using SCC with Microsoft Office and other Windows Applications

Any SCC documents may be transferred to other Windows programs by cutting or copying
data to the clipboard and pasting it into the target location.  SCC supports standard ‘Cut’, ‘
Copy’, ‘Paste’ ‘Paste Special’ and ‘OLE’ commands.  You may also cut and paste data
from other packages into SCC.  SCC spreadsheets support text and Microsoft Excel
clipboard formats.  SCC models additionally support cut, copy and paste of graphical data
between any other OLE compliant software.

Cutting or Copying Data within SCC

Spreadsheet data may be cut or copied between spreadsheets.

Highlight the cells to be cut or copied.  Go to ‘EDIT tab > Cut/Copy’.  

Highlight the cell where you wish to place the data.  Go to ‘EDIT tab > Paste’.

Data within models may be selected for cutting or pasting using the Data Selection dialog. 

Copying a model to a new dataset or to a new model is different than exporting models, in
that, only the survey points selected are copied. Model data may also be copied to the
clipboard in its native format or as a bitmap.  When data is copied to the clipboard it may be
pasted or inserted into any other Windows program. When copied in its native format in
may be inserted into another document as an OLE object.

OLE 

An object created in another application that supports OLE may be inserted into SCC.  To
insert objects such as Microsoft Excel worksheet objects, use the 'Insert New Object'
command or the 'Paste Special' command, both found under the Edit menu.

Similarly objects created in SCC may be input into any other Windows application.  Objects
are created in SCC by using the ‘Copy to Clipboard’ option.

Send

Send attaches the current file to a new blank e-mail message.  Select the recipient and
type your message. 
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2.1.9 Backup Strategies

We recommend that in addition to saving your documents using a revision number based file
naming convention, that you include your main SCC folder in you backup plan.  Good practice is
to keep any important data in at least two physical locations at any given time.

In addition, several options are available within ‘DATA tab > Settings >  General Options > D
irectories and Files’ to allow the user to select auto save options but also to create backup files
automatically.

2.2 Feature Names Conventions  & The Feature Library

A feature name is the name given to one or more similar surveyed objects used to group strings
and points of the same type.  Examples of feature names include TREE, ROADEDGE, DITCH,
WALL, MANHOLE and shortened or mnemonic versions such as TE, RE, DH, WL, MH.  In SCC,
a feature name can be up to eight characters long although it is common to use shorter
abbreviations.  In SCC, feature names are used to determine how survey data is drawn and
modelled.  This is controlled by the feature library, which is essentially a spreadsheet containing
a large number of fields against each feature determining how it will be interpreted for modelling,
mapping, and export purposes.  These fields include colour, line-style, annotation defaults,
symbology, MX label, and CAD layer.

Many large organisations will have there own naming conventions,  whether it be based on string
labelling conventions for MX users, layer naming conventions for AutoCAD users, or both.

The feature library controls the application of a feature, layer, and string naming conventions
when generating SCC models and sections, AutoCAD and Microstation drawings or MX models.
The key field in the feature library is the feature name.

Most survey data collectors will include a feature name or point code field that can either be
directly used as a feature name, or mapped onto a feature name using the advanced field coding
sheet.  When transferring data from a MX SURVEY or GENIO file, the feature may be the first
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few characters of the string label that define the object.  For example, the SW from the MX string
label SW01 might indicate the string is a sidewalk.  The numeric 01 part of the label indicates
string number or occurrence of this feature in the current model.  When transferring from
AutoCAD or Microstation to SCC, the layer name, entity type, colour and line-style can all be
used to determine the SCC feature.

In SCC, the method of matching survey features with feature names in the feature library is
determined in SCC by a parameter within General Options. ('‘DATA tab > Settings >  General
Options > Directories and Files’).

The variable name is 'Add new features' and its value will be one of the following;

· No, warn about new feature name

· No, use nearest feature name

· Yes, all new features

· Yes, using first character

· Yes, using first 2 characters

· Yes, using first 3 characters

· Yes, using first 4 characters

· Yes, using alpha characters only

Feature Wizard

The feature library contains a very large number of fields, approximately four hundred per feature,
that allow for a very fine degree of control on how any given feature is drawn and annotated. 
While this allows for a very high degree of field to finish automation, it can be quite daunting to
edit and maintain.

The solution to this dilemma is the ‘Feature Wizard’, which can be accessed using ‘Data tab >
Feature Wizard’ from the feature library spreadsheet.  This displays the dialog shown below;
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The feature wizard is an automation tool that helps you generate and maintain feature libraries
with the minimum of effort.  It offers the following facilities;

· All of the fields for a given feature are displayed in a single dialog, with a preview panel that
shows a sample string or point for that feature, including annotation and symbology.  This
preview panel is updated when any field is changed.

· Feature styles may be saved and re-used.  For example, if you set up a manhole with a
circular symbol, and the plot name and cover level to the left of the symbol, you might save
this as a man hole feature style.  If you then wish to set-up a similarly drawn feature, such as
a gas valve, you simply re-select the man-hole feature style, and the gas valve will inherit the
man holes symbology and annotation settings. 

· The feature wizard also allows you to create and edit text styles, which consist of font
selection and display attributes, such as italicisation, and underlining.
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2.3 Strings

In order to form a surface model and map from a survey, it is necessary to create a number of
distinct geometric entities from the observed points.  These include points, lines, curves, and
combinations of lines and curves.   In SCC, these entities are referred to as strings.  An example
of a string might be the edge of a road.  This string would include sections of straight lines,
curves and possibly gaps or discontinuities.  A string can be two or three-dimensional and can
have varying significance to the surface depending on how it is defined.  An example of a two
dimensional string might be an overhead telecommunications line which is displayed in plan for
cartographic purposes. An example of a non DTM three dimensional line might be an overhead
transmission line where the conductor cable could be represented as a three dimensional line in
CAD and not influence the formation of the surface model. An example of a three dimensional
string might be the edge of an embankment which is fully represented as a 3 dimensional line
which significantly influences the surface model formation since it delineates a characteristic fold
in the physical terrain.

String Number

The string number field, available in detail coordinates view of the survey data set, indicates the
instance of a given feature within a survey.  All points in a survey with the same feature name and
string number will be sequentially joined to form a single string.  It is therefore used to distinguish
multiple occurrences of the same feature.  For example, if there are two distinct buildings in the
survey both having the feature name BUILDING, all the points on the first BUILDING would have a
string number of 1, and all the points on the second have a string number of 2.  This makes it
possible to survey part of Building 1 and move on to BUILDING 2.  It would then be possible to
subsequently come back to continue the first building by picking up the next sequential point on
BUILDING 1.  A string number of 0 is used to denote a point feature (unconnected point) such as
a spot level, bus stop, traffic signal etc.

Tags

The tag code determines the connective geometry and specifies how the current point on the
string will be connected to the next point on the string.  This can be used to specify straight
lines, curves, arcs, and squared up pieces of geometry in a string.

DTM Code

The DTM (Digital Terrain Model) status code determines the significance of the point of the
surface model / digital terrain model being generated.  

2.4 Models

Models within SCC are formed from a variety of co-ordinate files, such as reduced survey, DXF
and GENIO.  A model in SCC consists of the plan drawing and the feature library.  If a SCC
dataset is used to create a model then the feature library from that project will be copied as the
feature library for the model file.  If the model is generated directly from a co-ordinate file, new
features encountered will be added to the default feature library (depending on the setting defined
within General Options).  A model comprises of cartographic map detail formed from the strings
and a surface or TIN model used to form contours.  TIN stands for Triangular Irregular Network. 
Put simply, this means that points adjacent to one another are connected to form triangular
facets.  These facets can be considered as oblique planes for the express purpose of
interpolating contours, profiles, cross sections, volumes, and other surface analysis tasks. 
Strings are paramount in the creation of TIN as they are used to form breaklines, that is, linear
areas of the surface, such as banks, ditches, and walls, where there is a sharp or marked
discontinuity of the terrain surface.  See diagram below:
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The picture below shows the effect of not creating a breakline from a string where one was
required. Compare this picture to the previous one of the same model.  The dataset in terms of
spatial co-ordinates remains the same but the formation of the triangulation has been deformed
because the correct DTM code has not been selected.  The selection of sufficient point density
and the delineation of the physical surface characteristics for the purposes of intended use are
prime requirements during the surveying process.

Models, which were created from SCC datasets, have links back to their original co-ordinate and
survey observations files.  As such they may also be used to graphically query all aspects of the
detail survey database.  Thus recovery from measurement errors, mistakes in DTM definition,
feature object dimensions etc. may be achieved interactively.  Data may be combined from a
variety of sources for model creation.
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2.5 Field Practice Applicable to SCC

Field Practice for Topographic Surveying

SCC models are formed from point or line string information. Point strings are discrete points
such as trees and spot heights whereas line strings are connected features such as roads, walls
and hedges. In order for strings to appear in the model, the surveyor must record string
information when surveying. This involves recording one or more fields that tell the software the
type of feature being surveyed, e.g. Wall, Tree, Road, and optionally additional geometric
information to specify the string number or instance of that feature, for example, WALL 02 might
be the second wall surveyed.

The coding of string information in the field is dependent on the data collector being used.  Data
collectors, such as PocketDTM and AutoGRAD/MSMM, include distinct feature name and string
number fields. This has the advantage that points on a string do not have to appear in sequential
and unbroken order within the survey. For example, we could observe points on a road in
sectional format from a number of different set-up stations yet they would appear as strings in the
model. This can greatly reduce the overall amount of fieldwork.  Modern total stations allow a
high degree of customization, allowing us to collect as many or as few fields as required.

We can also collect geometric codes that allow us to specify the geometry connecting string
sections, such as straights, curves, arcs, and rectangles, dimensional information, and various
offsets.

On data logging systems without explicit fields for feature code, string number, tag code, etc...
we can use the advanced field coding sheet to achieve most of the same results given a single
point code field.  This sheet determines whether a field code represents a feature code or a
control code, and what to do with numeric values within a point code.  For example, we might
say that KB represents a KERB feature, connected by straights, whereas KBC might be a KERB
feature connected by curves.  Thus KB and KBC would lie on the same string.  Similarly, we can
say that for KB and KBC, any numerics in the point code represent the string number, such that
KB02 and KBC02 represent straight line and curved segments of KERB string 2.  We can also
use control codes, for example ST might be used to start a new string with the current feature. 
Individual observations may also have more than one code when surveyed in this manner, for
example HE01 GA might represent the junction point between HEDGE string 1 and a GATE. 
This type of coding allows us to replicate topographic field surveying techniques used in many
popular legacy systems such as SDRMap, Panterra, LandScape and NRG.

Field Practice for Traversing

SCC supports both traverse and network adjustment.  As with topographic surveying, the method
of collecting a traverse will vary between data loggers and instruments used.  When surveying
combined topographic detail and traverse data in a single job, observations with a specified
feature code can be extracted into the traverse sheet for adjustment purposes.

A traverse connects chains of straight lines with measured lengths and angles.  A traverse is one
means of providing 2 or 3 dimensional control in which position is determined by a combination of
angle and distance measurements between successive lines joining control stations. SCC allows
closed and open traversing with several methods of traverse adjustment computed. The
calculations will generate co-ordinates based on the error adjustment selected and it is the
surveyor’s responsibility to assess the accuracy of the calculated co-ordinates.

It is always good survey practice to record more information than necessary. When observing
traverse information, sight to all possible stations. If extra measurements are observed to form a
network the Least Squares traverse adjustment should be carried out. This adjustment can also
be computed in PocketDTM prior to using SCC.

When observing an open traverse no adjustment may be selected and provisional co-ordinates
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used.

Where possible ensure the RO is part of the traverse and not an external observation.

The accuracy of the traverse is governed largely by the observation and measurement techniques
applied and by the type of equipment used.

Field Practice for Setting Out

SCC allows uploading of data from co-ordinate files to a number of dataloggers. Sections, strings
or contours may be uploaded to the logger.

Generally design data will be imported into SCC from MX, DOER or CAD. This data would be
uploaded to the datalogger to set out positions of proposed buildings or structures.  

Road alignments are usually set out in section. It is important that the stringing is correct before
uploading sections for setting out. When you have created the sections you wish to set out,
export the section file to a survey dataset (co-ordinate file) and upload the dataset.

The zero contour line on an isopachyte model may be set out on the ground to determine the
extent of boundary between the cut and fill on the ground.  The position of the cut or fill contours
from the isopachyte model may be uploaded to set out the position of the excavations.

3 Getting Started

3.1 Creating A New Project

A new project should be created before data may be downloaded into SCC or models formed.
The project file stores the co-ordinates of stations used in the surveys which are stored in the
current directory.

It is important that there is only one project file open at a time.

Creating a New Project

Two options are available when SCC is opened, either open an existing project or start a new
project.

When using SCC for the first time, it is necessary to start a new project.

Starting the Software

Double click the SCC Icon

From the 'DATA tab > New'

If a project from the New drop down menu at this point, no directory will be
set up for the project directory.  This option will simply create a project file in
the  'C:\SCC\'  directory,  and  associated  files  will  be  placed  there  as  well.
This  will  make  it  difficult  to  track  project  work  files.   Selecting  the  'New'
button  gives  the  user  the  option  to  select  a  Project  Template  (Feature
Library).
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Creating A Project Directory

From the Main Screen, select 'DATA tab > New'’

Enter in a Project/Job name

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’

The project template contains all the feature coding, layering, string labelling, modelling,
symbology and annotation standards that will be applied to the project. 

The project itself consists of a spreadsheet containing the control stations used in the
project, along with a feature library spreadsheet.

Project Folder

Use default SCC project folder

This option creates a directory under the SCC root level directory/Project Directory ('General
Options > Directories and Files'), and creates a project file in that directory.  The name of
the new directory is taken from the project name.
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For example, within the General Options the user has the Project Directory set to 'C:
\SCCProjects\' as shown below:

Therefore, a new project folder will be created called Test ('C:\SCCProjects\Test\') and
associated files will be downloaded/saved and exported to this directory.

Select an alternative folder

This option allows the user to specify a specific project directory different to the directory
specified within the General Options in which the project file is placed.

3.2 The Feature Library

The feature library controls how survey spreadsheets are translated into graphical SCC models,
CAD drawings, and MX models.  It includes a large number of fields for each survey feature that
control how it is drawn, annotated, modelled, and output.  Each project in SCC should have its
own feature library. 

To set-up a new feature it is often easiest to use the feature wizard as follows;

Type the feature name and description into the boxes at the top right of the dialog.

Pick a base style that most closely matches the feature you are creating.  Scrolling through the
base styles is a good way of looking at how different features can be drawn.

Change the CAD layer, MX label, and any other fields as required.

To change any annotators, select the annotator in question from drop down menu, e.g. Level, and
then modify the other annotation fields.

If you wish to create a number of other features with a similar look, type in a new base style and
press ‘Save’.

When you have finished, press OK

Select 'SCC button > Save'  or 'SCC button > Save As' to save the project.

If you wish to change a field value for a large number of  features,  it  will  be
quicker to do this directly in the feature library spreadsheet using the search
and replace function.

3.2.1 Using the Feature Library

This section describes how to record specific features in the field and then set up SCC so as it
will automatically draw these specific features when they are downloaded. 
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3.2.1.1 Creating Rectangles (Using the Feature Library)

The rectangle option speeds up the process of surveying rectangular features such as
inspection covers, road gullies or simple buildings.  The surveyor need only record two
successive points while moving in a clockwise direction around the feature.  The breadth of
the feature must then be entered in the dimension field of the data logger.

To generate rectangles in SCC the switch Create squares and rectangles in the Co-ordinate
Reduction options must be turned on, and the symbology field for that particular feature
name must be set to Rectangle in the Feature Library.

Note that if any feature is inadvertently surveyed in an anti-clockwise direction then the
rectangle will be generated on the wrong side of the surveyed line.  This can be corrected by
reversing the string direction using the global editor.

3.2.1.2 Creating Strip Levels (Using the Feature Library)

Surveying the centre-line of a linear feature such as a track, ditch or wall generates a
strip-level.  As the surveyor progresses along the centre-line the width of the feature must
be entered into the dimensional field in the survey data recorder. 

When the survey data is processed in SCC the feature will be displayed as a strip of the
appropriate width.  The centre-line will not be displayed.  In order to have specific features
treated as strip-levels,   turn on the switch to Create `Strip levels' within the co-ordinate
reduction options and in the Feature Library the symbology field for that particular feature
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name must be set to Strip level.  Note that all instances of that feature will now be treated
as a strip-level.

SCC provides the option to model three-dimensional strip-levels.  Thus, features such as
streams, ditches or walls may be surveyed as a series of points along the centre-line with
an associated width for the top and the base; the height or depth of the feature at each
surveyed point should also be recorded.  In the case of a stream the rod will typically be
placed on the stream bed, the strip-level dimensions should be entered into the data
logger's dimensional fields as indicated in the diagram.

Note that the depth of the stream course will be positive if the rod is placed on the bed.  To
have all streams treated as strip-levels set the options within SCC as described above.

In the case of a wall, the dimensions should be entered into the survey data recorder
dimension fields as illustrated in figure below.  Note that because the top of the wall has
been observed the height should be entered into the second dimensional field as a negative
value.  In order to have walls treated as strip-levels in the SCC model, follow the procedure
described above.  The second width (that is the third dimensional field) must always be less
than the first width as over-hangs cannot be triangulated.  If the first and second dimensions
are recorded, but the third field is omitted SCC will supply a default width for the third field
(the value for the first dimension will be copied into the third dimension).

3.2.1.3 Creating Trees (Using the Feature Library)

SCC places two symbols for trees; one representing the canopy and the other the trunk.
The process of surveying a tree is illustrated in the diagram.  Generally, the reflector is first
placed to the side of the trunk such that the observer can measure the distance from the
instrument to the centre of the trunk.  The centre-line of the trunk - relative to the instrument
- is then indicated so that the instrument operator may hold the observed distance fixed
whilst observing the correct horizontal angle;  these are then downloaded to the data
recorder as a pair.  Finally, the assistant will measure the mean canopy and trunk
diameters; these will be entered in the D (1) and D (2) fields of the data logger respectively. 
In order to have trees appear as scaled symbols in the model the following options must be
set within the SCC feature library;  you must enter the symbol name Tree in the Symbol
field for the feature TREE and symbology field must be set to Scaled Point.
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3.2.1.4 Inaccessible Linear Features

The diagram illustrates the process of surveying an inaccessible linear feature; in this
instance a wall, which is obscured by a hedge. The feature is recorded as an offset; an
offset right in this example, as the wall lies to the right of the line of progress.  A series of
points are observed in convenient positions and the offset distance to the wall is entered
into the dimensional field of the data recorder.  SCC treats offsets to the right as positive
and those to the left as negative.  To have offsets processed you must set the Parallel
feature offsets switch in the co-ordinate reduction options dialog to Apply in the X-Y Plane. 
This option may be found in the File menu of the Detail Observations and Detail Co-ordinate
spreadsheets.  The other settings within this option are used when processing building
facade surveys

3.3 Import & Downloading Files Into SCC

Having created the project, it is necessary either to import data into a dataset or to download
traverse and detail information. SCC must be told what survey instrument/logger format to use,
what type of data is being downloaded and what type of media it is being downloaded from.

For training purposes, the download process from some of the common survey instruments and
logging formats are discussed.
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3.3.1 Importing Data Into SCC

SCC can import files from various other systems.  All imported files are co-ordinate files and are
displayed in the co-ordinate spreadsheet.  Because only co-ordinate information was input it is
not possible to access detail observations, instrument set-ups or extra measurements
information. 

Select 'DATA tab > Import drop down' and select file type from given list.

3.3.2 Downloading & Processing Traverse  Data

From the 'DATA tab > Download Survey Data' dialog, it is possible to select the type of
datalogger used (Detail Topography, Traverse, As Set Out or Levelling) and the input device being
used. It important to specify which type of data is being input. 

3.3.2.1 Processing A Complex Traverse

The following worked example shows how to process a complex control project in SCC that
includes interlinked traverses, cross braces and additional side-shots.  This includes processing
the complete observation set as an unconstrained network via least squares, extracting separate
traverses for Bowditch adjustment, and fixing the primary stations for constrained least squares
adjustment.  The steps to achieve this are given below;

Project Creation & Download

'DATA tab > New’ to create a new project based around the default template.  

Into this project use ‘DATA tab > Download ’ to download the Trimble / Geodimeter UDS file,
\SCC\Tutorials\ComplexTrav.DAT, using the parameters shown.
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This results in the traverse spread-sheet given below;

Adjustment of Traverse

Adjust the control in its entirety, using a least squares adjustment with minimal constraints.  

Select ‘TRAVERSE tab > Set-up’, and enter an opening setup as shown in the dialog below.  

Note that only the closing station and RO should be left ‘Free’.  

Select ‘TRAVERSE tab > Adjust’ and adjust this data by least squares.  

When prompted, save the adjusted values to the project station sheet.
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Review report
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Initial Plot & Annotation of Network

Select ‘TRAVERSE tab > Model’ 

Annotate the station names using the Traverse Annotation dialog as shown below:

This will result in the following traverse diagram, that we will use to select potential Bowditch

adjustable loops.
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Save this model as ‘ComplexTrav.Model’

Extract Primary Loop Traverse

Go back to the traverse view  and select ‘TRAVERSE tab > Set-up’,

In our set-up screen now enter the opening and closing stations and references objects for the
loop we wish to extract, in this case opening ‘SH03-SH02’, closing ‘SH02-SH03’.
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Select 'TOOLS drop down menu > Extract new route’ to search for any potential routes through
the control network using these opening and closing conditions.

In this case, SCC can find nine possible routes that would meet these conditions, which are
outline in the route selection dialog.

The route details panel in this dialog shows the set-up sequence for each potential route.  This
is in the form S#<Setup number> <From Station> - <At Station> - <To Station>, for each set-up.
It is useful to refer to our previously generated traverse diagram, to confirm the desired route.  

In this case, we will pick the second possible route.

We can now adjust this traverse, using ‘TRAVERSE tab > Adjust’, via a Bowditch method to
give the following results.  
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Given that these results are acceptable, we will save this traverse as ‘Outer-loop.Traverse’.    

When prompted, save the adjusted values to the project stations sheet.    We can now change the
values of all or some of these stations from ‘Free’ to ‘Fixed’ or ‘Fixed XY’ in the project stations
sheet, and repeat the least squares adjustment on ‘ComplexTrav.Traverse’.  This will re-adjust
all the remaining stations using the fixed values from this primary loop.

To generate a graphic of our primary loop, go back to our model (Stns.Model), select ‘FILE >
Attach/Detach > Edit/Detach > Detach All’, followed by ‘FILE > Attach/Detach > Attach traverse
’ and select ‘Outer-Loop.Traverse’.  Save the result using ‘FILE > Save As’ giving the name ‘
Outer-Loop.Model’
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Repeat the above exercise on the inner loop, with opening set-up ‘SH01-SH02’, closing set-up ‘
SH02-SH01’, to yield the  results

We can extract as many loops or linked segments for this type of analysis as required.  Note
that the route extraction module may use side-shots as fore-sights, and reverse set-up
sequences in order to establish potential routes.  This allows us to swap opening and closing
setups to reverse a traverse.

If we wish to exclude any observations from this, or any other analysis, change the ‘Use Obs’
flag on those observations from ‘Yes’ to ‘No’.

3.3.2.2 Processing A Resection Network

The following tutorial covers the processing of the Leica GSI control network provided in the file
‘Resection-Network.GSI’ (available in \SCC\Tutorials).  The job consists of a large number of total
station measurements from primary unknown stations to other secondary unknown stations.  The
network can be computed as there are enough common target points between each set-up to
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allow computation of provisional values of all primary stations by resection (or free-station), and
secondary stations by direct trigonometry.   Due to the interdependency of the stations, the
computation of provisional coordinates is iterative, whereby new station coordinates are
generated with each iteration thus providing base information for successive iterations.  Having
computed all of the provisional station coordinates, the network can then be adjusted using a
least squares variation of coordinates method, which provides the best and most consistent final
station values for the observed data.

The steps taken to process this job are as follows:

Project Creation & Download

'DATA tab > New’ to create a new project based around the default template.

Into this project use ‘DATA tab > Download ’ to download the 'Leica GSI 8/16',
\SCC\Tutorials\Resection-Network.gsi, using the parameters shown.
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Traverse Reduction Processing of Traverse Data

Given the size of the job, 1076 observations to 321 stations, it is advisable to reduce the
data prior to adjustment.

Select 'TRAVERSE tab > Tools drop down menu > Reduce' to reduce the data.

The reduction creates mean forward measured angles and distances for multiple similar
observations, in this case reducing the number of input observations from 1076 to 538.  The
reason for doing this is primarily processing time.  Many of the matrix manipulation routines
in the least squares adjustment are making a number of computations based on the square
of number of observations times the number of unknown stations, i.e. (1076x1076x320 =
370,488,320 for unreduced data, or 538x538x320 = 92,622,080 for reduced data).  Using the
reduced data also provides better initial provisional coordinates, such that fewer iterations of
the transformation are required to get a final result.  The net effect is that on a 1.5Ghz
machine, adjusting the data without first reducing it will take about 110 minutes, whereas
adjusting the reduced data takes about 7 minutes.  If individual observation residuals, as
opposed to residuals on averaged measurements, are required, you should not reduce the
data prior to the adjustment.
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Processing of Traverse Data

Enter the opening and closing set-ups.  

Select ‘TRAVERSE tab > Set-up’ and enter the setups as shown below.

As we have no known station values, we are using the minimum allowable constraints which
are one known station to provide position, and one known bearing, to provide orientation.

Adjustment of Traverse

From Select ‘TRAVERSE tab > Adjust’  and enter the parameters shown.  
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This will create the report shown at the end of this document.  When prompted, update the
project station values with the adjusted results, and save the traverse and project

Annotation of Traverse 

Create a model of the data, showing the stations, network, and error ellipses.  

From 'TRAVERSE tab > Model' as dataset.   Set up the following:

 

This will generate the picture shown below.
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3.3.3 Downloading & Processing Detail Topography Data

Once station coordinates have been computed, detail topography can be downloaded.

It is important to remember that only the survey file  is  automatically  saved
on download. All other files must be saved by the user.

Sample download proceeds for specific data formats are examined as follows:

3.3.3.1 Downloading Leica Data

SCC includes a number of different Leica interfaces to support correspondingly different data
collection strategies.  The simplest of these is the TPS series interface which maps user
definable fields on the instrument directly onto SCC observation fields.

Leica GSI 8/16

Downloading Leica Data
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Select 'DATA tab > Download Survey Data’

Set Survey Data Logger to 'Leica GS1 8/16'

Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk', 'RS323 port (cable)' or 'Atlas communications controller' as
required

Select ‘OK’

Select the file you require and ‘OK’

In this case, for example, field 41 on the instrument will be used to store the SCC feature
name.  Any SCC fields that are not being recorded in the field should be set to 99.

Note that these settings will become the defaults for all future downloads from the Leica and
do not have to be entered with each download.

An alternative method is to use the LisCADD or WildSoft style coding (Leica 1100/1200
(GSI config)) which will be more familiar to LisCadd users. In this case field 41 on the
instrument is always used to determine what is stored in other instrument fields.  For
example, in the dialog shown below, if field 41 contains the word ‘FEATCODE’ the feature
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code is expected in field 42, whereas if it contains ‘Remark’ a survey remark is expected in
field 42.

Note that in both cases, a traverse feature code may be provided to determine that
subsequent observations are to be included in the traverse spreadsheet.  This is provided to
facilitate combined detail topography and traverse surveys.

SCC Settings for Leica coding using Leica TPS1200 Instruments 

Open SCC and set up Project 

Select ‘Data tab > Download Survey’

Select ‘Leica 1100/1200 (GSI Config)’ as Survey Data Logger

Select the required ‘Data Type’

Select ‘Data logger input Device’

Select ‘OK’
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Pick raw file

Select ‘Leica1200.GSIConfig’ Format File 

Set up additional settings as shown below:

Select ‘OK’

Traverse Observation Feature Code

Traverse Observation Feature Code field should be filled with the user’s individual code i.e.
PSSA or STN etc.

If this is not filled in, no stations file will be produced. 
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Leica HexML Data

The SCC HexML interface to Leica Captivate includes supports for embedded photography within
observation files and models.  Model points that include embedded photos will be highlighted
using an extra marker controlled by the ~OBSPIC feature.  Observation photographs can be
previewed and edited under the observation tag using the Query & edit functions.  When
exporting to AutoCAD DWG and DXF, embedded photographs are available as hyper-links
attached to the survey point.

The SCC HexML interface supports advanced coding through both point codes and free codes,
which can be used in conjunction with Captivate curve and arc codes.

  

3.3.3.2 Downloading Trimble Data

Trimble ACU Output

SCC support downloading files from the Trimble ACU, running Tsce software, using the
SDR33 output format.  These attributes can be used to describe dimensions, offsets,
parallel features, and all other items available through the SCC extended coding library.  We
will demonstrate the use of this facility through the sample file 060228D.DAT.  Note that in
this file, Tsce attributes are stored in 13AT records, see extract below for an example;

2NM        9020   

308417.642000000231995.58500000051.33300000000001.50000000000000              

07NM        9020            9021    27.900185437685727.9001854376857

03NM1.70000000000000

09F1        9020            9021   

12.874430000000088.109739263113027.9001854376857STN           

09F1        9020            1001   

18.593340000000088.669171829746923.1694290000000BG            

13ATOffset              0.30000000000000                        

09F1        9020            1002   

17.165240000000088.759832243491514.1117367500000BG    
          

To process this file in SCC, do the following:

Create a new project, based on a 'Trimble_TSCE_ALPHA.Project'

Select 'DATA tab > Features drop down menu > Advanced Survey Coding'

Record for each attribute type present in the Tsce format being used has been entered. 
For example, for the OFFSET attribute, we add a new record with the name and code of
OFFSET,  type of ‘Control Code with Parameter (CCP)’, and SDR Control type of ‘Par Ofs
L/R’.  This means that when SCC encounters an attribute called OFFSET, it will take the
attribute value and store it in the parallel offset field in SCC.  For this job, the rest of the
records will be as follows;
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Note that regular features that contain embedded string numbers should also appear in this
sheet with a type of ‘PC’ and a PntInFtr setting of ‘String’.  This sheet can also be used to
control default tag and DTM codes for these features.

Once you have completed editing this translation table, you should save the project as a
new template in the SCC folder, such that you do not have to repeat this exercise.

Select 'DATA tab > Download’

Set Survey Data logger to 'Trimble TSC/TSCe (DC)' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk'

Select 'OK'

Select '060228D.Dat' from '\SCC\Tutorials' directory

Select 'Open'

Select 'OK'
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Set 'SDRMap Coding Extensions' and 'Search remarks for dimensions'

Select 'OK'

This will generate the following detail survey file;

*.DC files from TSCE containing observations in DC formats as defined in DC10.70 or DC7.5
are also supported.  Observations must be in HA,Va,Sd or X,Y,Z formats.  SCC does not
currently read GPS vectors, or GPS lat,long, height records from this format.

Combined Total Station & GPS Files Trimble Data

SCC supports the download of combined Total Station and GPS information contained
within one complete file.  

Total Station Detail

08PD        1853    240109.491174308230536.45323307880.5785407722807CONC2       

  

08PD        1854    240106.941616718230533.14415286880.4446191824330CONC2       

  

08PD        1855    240106.934895243230533.12155861780.4350418868451K2          

  

08PD        1856    240103.591644851230535.66377808680.3671757765827K2          

  

08PD        1857    240102.973759388230536.67287284980.3818527249702K2          

  



50

©2018 Atlas Computers Ltd

08PD        1858    240102.946912372230537.66137346080.3672869395576K2          

  

08PD        1859    240108.024260067230544.61543070080.4062528838890K2          
    

GPS Data

09F1        S4              1871   

19.485780000000086.2995339500897308.269300500000SL            

09F1        S4              1872   

20.122220000000086.2101823251036306.161937000000HE3           

13NMOFFSET HE3 2.0M LEFT                                        

09F1        S4              1873   

26.350400000000086.0417014778084314.111125500000HE3           

09F1        S4              1874   

36.881090000000086.4799984710826316.234896000000HE3           

09F1        S4              1875   

45.070550000000086.8506673231004318.345708000000HE3           

09F1        S4              1876   

56.991010000000087.4670758972154318.269134018868HE3           

09F1        S4              1877   

58.376750000000087.5556657440944316.922418000000EP            

09F1        S4              1878   

60.863180000000087.5235304357424318.604251600000B10           

09F1        S4              1879   

60.548220000000087.5381532946088326.509790400000B10   

        
Select 'DATA tab > Download’

Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk' 

Select 'OK'

Select 'RAWsdr33dc.dc' from '\SCC\Tutorials' directory

Select 'Open'

Select 'OK'
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Set 'Search remarks for dimensions'

Select 'OK'

Note that the option to strip string numbers from field codes has bee selected with the
'Coordinate Reduction Options'.

Trimble DC Format

SCC also supports the direct download of DC format as follows:

D2NM1021.70000000000                0.14200000000000                

69FD        S22     137412.769000000253513.23000000046.1450000000000CON 

          11

E0NM        S22     1.620000000000001.000000000000001

E1NM        S22             S21                     190.187083794199    

          

 77NM1.500000000000002.000000000000000.00000000000000

D9F1        S22             S21   

91.250749347157591.8136377610403190.187083794199CON             

50.003182501540000.001388888888890.00138888888889

A6F1                -0.00090101528280.00846784874555

D9F1        S22             1     

90.790027562819091.9271004383258190.244880000000S               

10.010181580100000.001388888888890.00138888888889

D9F1        S22             2     

90.795487574480291.9263806245318190.249560000000S               

10.010181591020000.001388888888890.00138888888889

 77NM2.000000000000002.000000000000000.00000000000000

  10.010192322360000.001388888888890.00138888888889

D9F1        S22             8001  

86.761130395951992.3277570859462213.880050000000HEC1            

10.010173522320000.001388888888890.00138888888889

D9F1        S22             8002  

77.753634782899292.0915956056461219.797010000000HEC1           

10.010155507320000.001388888888890.00138888888889

 77NM1.500000000000002.000000000000000.00000000000000

D9F1        S22             8003  

73.815260826027192.3056179106150224.597520000000HEC1            

10.010147630580000.001388888888890.00138888888889

D9F1        S22             8004  

68.620739011095391.8354586405055234.321300000000HEC1            

10.010137241520000.001388888888890.00138888888889
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D9F1        S22             8005  

64.289547497628291.1620741098151249.494310000000HEC1            

 10.010128579120000.001388888888890.00138888888889

Select 'DATA tab > Download’’

Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk' 

Select 'OK'

Select File

Select 'Open'

Select 'OK'

Set 'Search remarks for dimensions'

Select 'OK'

Trimble/Geodimeter UDS

SCC supports Trimble/Geodimeter format and can be processed as follows:

Select 'DATA tab > Download’

Set Survey Data Logger  to 'Trimble/Geodimeter UDS'

Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type
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Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required

Select ‘OK’

Select the file you require and ‘OK’

Additional settings may be checked at this stage that relate to the field coding standards
used that are particular to a given instrument. Note that these settings will become the
defaults for all future downloads from the Geodimeter and do not have to be entered with
each download.

Codes 90 through to 99 in the Geodimeter are user definable and may be used log extra
dimensions in SCC. For existing ‘Landscape’ users, the first time we download into SCC,
we will also have to set up the coding options as shown above. The LandScape coding
options determine how the numeric field codes entered in the instrument will be translated
into SCC tag codes, DTM codes, and ancillary measurements based on existing ‘
Landscape’ techniques.
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SCC lets us freely mix data from a range of different instrument manufacturers and
instrument types within a given project. The LandScape processing options are currently
enabled for the Geodimeter and Leica instruments.

Trimble ExchangeTrimble Exchange

The user can download using Trimble JXL, Trimble DC, SDR33, Geodimeter UDS or GPS X,Y,Z
formats using the Trimble Link Engine.

To download from using Trimble Link Engine in SCC, use the following steps;

Go to 'DATA tab > Download survey'

If this is the first time using TLE, and downloading from file, press the 'Create New Device'
icon

Create a Survey Data Card device for the folder containing your raw Trimble data.
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Select the device, select the job and press Open to begin downloading.

General SCC download steps can be implemented from this stage.

The TLE interface can be configured under 'Data tab > Settings > General options >
Communications > Trimble options'
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Zone may need to be changed to reduce RTK to coordinates, but most of the other defaults
should be ok.

3.3.3.3 Downloading X,Y,Z coordinates from GPS

The following examines downloading coordinate files into SCC using ‘GPS XYZ’ Download
option.  Note that in this case the coordinates are initially placed in the observation sheet,
such that they can be processed by the survey reduction.  This allows for curve fitting,
squaring up strings, and completion of any other survey geometry.

Setting up Project

Set up Project

Open SCC

’From the 'DATA tab > New'

Enter the Project Name and attach the ‘Default(v6-9 Complex).Project’ template.

Download & Model Creation

Downloading the sample detail file
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Go to 'DATA tab > Download Survey’

Select ‘GPS X, Y, Z’ as the survey data logger

Select ‘Detail Topography’ as the data type and set the datalogger input device to ‘disk’

Select ‘OK’

Select ‘GPSTEST.txt’

Extract of ‘GPSTEST.txt’

121,936.4463,1078.9469,42.5348,WL,BRICK

122,935.3751,1076.8353,42.6115,WL,BRICK

123,932.9097,1072.0190,42.5418,WL,BRICK

124,932.2931,1070.8306,42.6371,WL,BRICK

125,931.0534,1068.3674,42.5873,WL,BRICK

126,927.4137,1062.1438,42.5386,TE,OAK

127,925.6250,1059.3698,42.5524,TE,ASH

Select ‘Point No., X, Y, Z, Feature, Remark

Select 'OK'

This method has the advantage of the ‘Detail Observation’ Sheet being available for editing.  
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3.4 Creating A Model

A SCC model can now be generated using the survey dataset files.

3.4.1 Topographic Model Creation & Editing

A model in SCC is a visual representation of one or more surveys that includes all the
annotated planimetry and a TIN surface model which in turn generates contours, slope
lines, relief mapping, etc..  Note that all of the colours used within SCC, both foreground
and background, are fully user definable to suit the users preference, and the media in use.

Before becoming a visual graphic representation, each model starts out as text in one form
or another. The most common form of data files are SCC Datasets, DXF files, MX Genio and
X,Y,Z ASCII files. These sources can be mixed and matched. SCC will keep track of where
the data comes from. Your responsibility rests in choosing the right data to combine into
your model.

Creating the Model

To create the model, go to ‘DATA tab > Model >  select all 4 downloaded datasets from C:\SCC\
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by holding down the CTRL key and picking 'FGL1.Survey', 'FGL2.Survey', 'FGL3.Survey' and
'FGL4.Survey' files 

Select ‘Create the model and triangulation’ and set Intial Plot Scale of 200

Select  ‘OK’ to Attributes summary dialog

Your model should like the image below

3.4.2 Creating A Model from An External File

SCC can also create models from existing SCC data or directly from external files.  The external
co-ordinate files are files, which are imported into SCC.

3.4.2.1 Modelling A DXF File

The following examines the direct modelling of a DXF file 

Select ‘DATA tab > Model  drop down menu > DWF, DXF or DGN file'

A dialog will be presented requiring the external file to be selected.

When querying the model using the Query and Edit Points (Model tab) option from the
Model tab only feature information will be available.  If the file was imported, saved as a SCC
dataset and then a model created feature and co-ordinate information would be available.  

The option to Edit String Details  under the Edit menu allows access to global editing
without having to import the file.

Select ‘DATA tab > Model >  DWG/DXF File'

Using the Pick button on the Import DXF file dialog, go to the \SCC\TUTORIAL\ directory and
select the file OGL.
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Select 'OK'

Select 'Create model and triangulation and set the Initial Plot Scale '200'

Select 'OK' for the SCCW window which summarises model attributes

The model OGL will be drawn:

3.4.2.2 Modelling A GENIO File

The following examines the direct modelling of a GENIO file 

Go to ‘DATA tab >  Model drop down> MX GENIO file ’. 

Select the file ‘GROUND.CRD’ from the TUTORIALS directory 

Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely and
GENIO L-string processing to ‘Treat as points’.
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Select 'OK'

Set the Initial Plot Scale as '200'

Select 'Create the model and triangulation'

Go to ‘SCC button > Save’  

Save the model as ‘Ground.Model’

3.5 Editing A Model

The following outlines the tools to edit a model.

3.5.1 Model Navigation & Shortcuts

The mouse can be used to navigate the model.  Such options are controlled within the General
Options
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General Options

Go to 'DATA tab > Settings drop down > General Options > Communications'

Review 'Mouse Navigation' options

For example, to rotate data using the mouse, simply

Press Mouse Wheel at rotate origin point

Press Right Mouse Button down and move cursor to pivot model

Note the cursor is moved around in the cloud, either in plan or another view, the x,y,z position of
the cursor in the cloud is shown, and the user can snap to cloud positions.  

Keyboard Shortcuts

In addition to mouse controls, keyboard shortcuts can be used, such as ‘P’ and ‘E’ when moving
between plan and elevation view. 

This coincides with other general SCC keyboard zoom controls such as Home (Zoom Extent),
Page Up/ Page Down (Zoom In/Zoom Out), Space Bar (Pan).

Other keyboard options are + and – to widen or narrow the area of interest, and L and X to move
between long section and cross section related view when selection a sectional area relative to
an alignment.

When a horizontal section / area of interest is in use the arrow keys may be used to raise or low
the elevation of the section.

Other general controls are noted as:

Esc Quits any of the interactive editing options

Home Zoom Extents

End Zoom Previous
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Page Up Zoom Out

Page Down Zoom In

Space Bar Zoom Centre (Pan)

TAB Pan to the next crossing breakline, next duplicate point, or next
potential model error.  This option will only pan to crossing
breaklines and / or duplicate points if they are currently being
displayed.  This is controlled using `View / Triangulation options'. 
Other potential model errors that are detected with this option
include links between 2d and 3d points, duplicate 3d points with
different elevations, and polygons with less than three points.  This
key press is very useful when correcting survey errors interactively.

F2 Pressing this key pans to the next selected point.  This option
should be used in conjunction with the data selection dialog, and is
very useful for finding specific points in the model.  For example, to
find a specific point in the model, use the advanced section of the
data select dialog to highlight the point (or point range), and press
F2 to pan to that point.

s Pressing ‘s’ toggles between the available snap lock modes,
including nearest point, nearest DTM point, nearest 2D point, gird
position, midpoint, perpendicular (to string), perpendicular (current
string) and design grid (chainage/offset).

n Pressing ‘n’ turns snap lock off.

g Pressing ‘g’ enables snap to grid mode.

m Pressing ‘m’ enables multiple point selection mode.  This is useful
when selecting a point, or piece of text that overlaps other items.  If
multiple point selection is enabled, and a position on screen is
selected where there are multiple overlapping points, a dialog will
be presented that allows you to select the desired point from a list
of points within a specified range from the cursor.

\ Use of ‘\’ and ‘*’ keyboard shortcuts can be used to the create text
function, as per other text editing functions. Note that when
creating new free form text, the drop down feature list in the tool
bar may be used to set the texts feature and hence colour and
CAD layer.

H or V Pressing 'H' or 'V' will snap vertically or horizontally.  The base
point used will be the last point on the string if you're already
creating a string, or the cursor position if not, so you can extend
from an existing point using snap point and then press 'H' or 'V' for
subsequent points.

O Pressing 'O' snaps perpendicular from the last two points, or
horizontal if no points have been entered.  The default behaviour
after picking a point with snap horizontal or vertical is switch to
snap perpendicular from the last two points.  This can be turned on
or off in the snap points dialog.

Q Pressing 'Q' closes the string and updates the model using the
Link Square tag.  This creates a new point by intersecting a line at
right angles from the last two points selected with another line at
right angles to the first two points.  Thus if you have entered three
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points, pressing 'Q' will square off by creating a fourth point to from
a quadrilateral.

L Pressing 'L' closes the string and updates the model using the
normal Link tag.  Thus if you have entered three points, pressing 'L'
will give you a triangle.

You can also use the mouse wheel to zoom in and out of the current position, and to pan
around the model by moving the mouse with the wheel pressed down.

Snap Controls 

The snap control option available from the 'VIEW' menu has the following options:

This dialog allows you to force the cursor to always lock onto a specific point or grid
co-ordinate while editing the model. It is particularly useful when positioning points exactly
on top of survey points, for example, when generating a boundary string.

Pressing ‘s’ on the keyboard toggles through the snap options. The current snap option is
displayed on the bottom right of the status bar. 

The snap control dialog is also used in the selection of overlapping points. If you highlight
the ‘Enable search for multiple points’ option, a list of all points within the prescribed radius
is displayed whenever you have to select a point in the editing options. This is particularly
useful when querying points that overlap or join strings at the junction point of other strings.

The snap selection may be changed in the middle of a command.  For example, if adding
points the user snaps to grid and in the middle the user wishes to snap to a feature, the
snap control can be changed to ‘Nearest point’ and allow the user to continue with the
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previous command, ‘adding strings with cursor’.

Pressing ‘m’ on the keyboard enables a shortcut key to ‘Enable search for multiple points’.

There are three methods of editing a model within SCC.

Point editing allows you to query a point in the model and modify any information relating
to that point.

String editing allows you to identify string lines in the model. Field errors relating to
connectivity can be edited here.

Triangle editing allows you to identify which triangles you will use in modelling
applications.

3.5.2 Probable Modelling Errors

SCC graphically highlights probable modelling errors such as crossing strings and duplicate
points. Crossing strings are indicated by red crosses and by pressing the TAB key, the screen
will be re-centred over each one, allowing them to be easily located and therefore easily resolved.

While crossing strings do not necessarily pose a problem in themselves, they are often indicative
of a survey or modelling error that could have more serious implications.  For example, where a
kerb top and kerb channels are surveyed as two separate 3d strings.  These strings are very
close to one another in plan, and may actually cross in a number of places.  While this makes
very little difference to the plan, it has a serious effect on the 3d model as shown in the section
below.
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Using the ‘move points’ option to shift the offending point by a few millimetres in plan quickly
resolves this problem, as shown in the second section drawing.

3.5.3 Correcting Survey Errors

In a model the most easily recognisable survey errors are crossing breaklines.  Crossing
breaklines are identified by the Breakline Intersection Point (~BRK_INT) feature.  This is a
standard SCC feature.  The symbol for this feature is a red X.  Look around this model there a
few red Xs.  When editing the model the operator should aim to remove all crossing breakline
from a model.  Depending on the strings and how they overlap different editing tools may be used
to rectify the errors.

3.5.3.1 Determining The Height Value of Crossing Breakline

New Project

Go to 'DATA tab > New'

Enter Project Name 'Crossing Breaklines' and attach Project Template 'Default (v10).Project'
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Model DXF

Within the 'DATA tab > Model drop down menu >  DWG, DXF or DGN file'

Using 'Pick>>' button select 'DUMP.dxf' from the SCC\Tutorials directory

Select 'OK'

Select Initial Plot Scale of 250 

Select 'Create the model and triangulation'

Select 'Ok' to Model Attributes dialog

Zoom in and then select 'VIEW tab > Position button' and enter 1878.360, 3275.959'
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Note the drainage line running perpendicular to the top and bottom of bank.  Where the
drainage lines meets the bank a crossing breakline symbol is generated.  What we are
going to do is insert a point onto both strings at each point where they cross. The height of
the new points will be taken from the height of the point interpolated.

Set the snap lock to snap point by pressing the ‘s’ key.  On the right of the status bar the
current snap setting is displayed.

3.5.4 Point Editing

The 'Query and Edits points’ option from the 'Model tab' allows the user to select a point of
interest for which a number of different detail tabs are displayed.



69

©2018 Atlas Computers Ltd

We have already mentioned the feature library tab and how it is used to set up or make changes
to the characteristics of the point. Any changes made to the library using this tab, will present
you with the option to update the project file.

The other four tabs are extracts from the survey file or SCC dataset used to create the model.
The Detail Co-ordinate and Detail Observation tabs are nearly identical. The main difference
relates to which dataset is being changed.

· If the Detail Observation tab is changed, the survey co-ordinates will be rebuilt to reflect the
change.

· If the Detail Co-ordinate tab is changed, the detail observations are not affected.

A copy of the original survey file is kept so the coordinate files may be rebuilt from raw
observations at any time you require them.

When querying a model that was created from multiple datasets, the dataset from which the
queried point originated is displayed at the top of the dialog. In this example the queried point is
taken from the ‘FGL3’ dataset. 

Another item of particular interest is the Instrument Setup tab. This tab displays what station
you were set up on for the point in question and also what station was backsighted to.
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In the Station Coordinates menu, you can determine the position of each station that was set
up upon. Sometimes the wrong station name is entered in the field, resulting in a disorientation of
part of the survey. This can be easily tracked and corrected.

Editing models with the ‘Query and Edit Points’ option will undo any local string editing carried
out on your model for the queried dataset.  For this reason, it is advisable to do any query based
editing prior to carrying out interactive string editing.

As changes are made to the model using the ‘Query and Edit Points’ option
the survey file will be automatically updated.

3.5.5 String Editing

Add Tab

SCC has an extensive set of string editing tools, similar to CAD tools, to interactively edit the
model.  This editing always occurs simultaneously in plan and 3d.  String editing tools include
trim, extend, move, copy, rotate, copy parallel, join, split, partial delete, reverse string, change
geometry, change feature, and change DTM status can all be located under the Add tab.

All tools work both interactively and with pre-selected data, such that they can be used to carry
out a given operation on a large amount of points as a single operation. To access the ‘Data
Selection Dialog’, you must press the right mouse button once when in the model.
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Display String Direction & Point Numbers on a String

Press Escape to clear any active editing operation

Press the right mouse button to access the‘Data Selection Dialog’

Select ‘All points on selected string’

Select ‘Mark selected points’

Press 'OK'

Pick the string you wish to annotate

Go to the ‘ANNOTATION tab > Annotate points' 

Turn on ‘Display point numbers’ and ‘Display segment direction’ 

‘All points on selected string’ will remain the default data selection method now until you
change it, such that to similarly annotate subsequent strings you only have to go through
the last three stages.

Model tab

Additional Tools can be accessed from the Model tab such as Copy, Join Points / String, Move
Points, Break Links, etc.
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3.5.6 Survey Error Detection & Correction

There are various facilities available in SCC to rectify survey errors depending on how they were
formed. Apart from red crosses, which highlight probable errors in your model, contours also play
a part in highlighting possible height errors in the model. Selecting a small contour interval will
draw your attention to any discrepancies in the survey.

Changing The Contour Interval

Activate the window FGL.model

From Model tab, go to 'Contour > Contour Options' 

Change the Regular Contour Interval to 0.5 and the Index to 2.0. 

Set the Linear contour type to ‘Quick Screen’ and the Solid Relief Contours to ‘None’. 

Select ‘OK’

You should immediately be able to see if there are any height discrepancies in the model.

3.5.7 Using SCC Editing Facilities to Rectify Survey Errors

The following examines specific editing tools to correct survey errors in the model.
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3.5.7.1 Delete Points & Strings

At the bottom of the model along the road there are three crossing breakline symbols. If you
look closely at this area you will see that there are four short lines running in the direction of
the road. It seems that the surveyor began surveying the road with these short lines, but
they were never finished. The road was surveyed using different strings. It may have been
surveyed on a different day and/or by a different surveyor.

We want to delete the short intersecting lines. Select these lines by drawing a polygon
around them. All points along these short lines will be selected as shown in the picture
below.  When the option to delete points is selected a dialog will be presented as to
whether or not you want to delete the selected points. Choose Yes.

Selecting Points By Creating A Polygon

To view the Breakline Intersection Points more easily turn off the contours.  

Zoom into an area where extra unnecessary points have been generated.  

The co-ordinate of the top corner is 194140E, 374888N and the bottom right co-ordinate is
194166E, 374868N.

You will see that there are four short lines running in the direction of the road.  It seems that
the surveyor began surveying the road with these short lines, but they were never used to
finish it.  The road was surveyed using different strings.  It may have been surveyed on a
different day and/or by a different surveyor.

Left click mouse to bring up 'Data Selection Dialog'.

Select 'Create A Polygon'

This automatically selects 'All points in selected polygon string' and 'Mark selected points'

The option can also be used to 'Clear selected points' from an area where points have already
been selected. 
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Draw a polygon around the four short lines by right clicking mouse to form 3 sides of the
polygon and left clicking mouse button to close the polygon.  All points along these short lines
will be selected.

Delete Points and Strings 

Go to 'MODEL tab > Points button > Delete Points'

Select 'Yes' to 'Delete Selected Points'
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If  you  delete  information  that  you  do  not  intend  to  delete,  or  perform  any
other  editing operation that has undesired results,  select  the  ‘Undo’  option
from the edit menu or press Ctrl-Z

3.5.7.2 Breaking String Links

While the previous option allowed us to delete entire strings or points, we will often want to
simply break a string into two separate parts by removing an undesired connecting link.
Breaking string links may be achieved by selecting the above button or the ‘Break Strings’
option in the ‘MODEL tab > Links button'. 

Zoom into the top left area to see the unwanted crossing strings.

As you move the cursor on screen you will see a thick blue line that you can align to
potentially unwanted string links. When this line lands on the correct link, press the left
mouse button and the link will be removed.  Alternatively you can use the ‘Individual Points’
options from the data selection dialog to mark the end points of the unwanted link and then
select the ‘Break Links’ option. 
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Breaking A String 

Zoom into the top of the model.  There are two lines crossing.  

If a segment of one of the lines were deleted, there would be no crossing breaklines.

Go to ‘MODEL tab > Links button'.

Align the cursor along the string segment you wish to break and click the left mouse button.

Place cursor over line segment.  

This option inserts a gap into the string.  The line tag of the point at the start of the segment is
changed to GAP.  

Note:

To move to the next set of crossing breaklines hit the Tab key.  SCC will retain the current
view size and move to the nearest set of crossing breaklines.  This facility saves zooming in
and out of the model looking for crossing breaklines.
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3.5.7.3 Partial Delete

This option may be accessed from the ‘MODEL tab > Links button > Delete Partial'. ‘Partial
Delete’ allows any segment of a string to be deleted. It differs from the ‘Break Links’ option
in that, the segment being deleted does not have to be between two surveyed points, it may
be anywhere along the string.

Deleting Any Part Of A String

Go to ‘MODEL tab > Links button > Delete Partial'

Select the string you wish to delete – a blue bar appears perpendicular to the chosen string 

Select a point on this string where you wish to delete from by left clicking mouse, and then the
point you wish to delete to by left clicking mouse again.

3.5.7.4 Annotating Strings

In the last few examples, the string errors in the model were very easy to identify, but in
many cases the error can be quite subtle and it helps to annotate the strings in order to
figure out what is going on. Panning down and to the right on the model we see another
area, where there are many crossing breaklines.

It appears to be an unwanted string link but we will do some more investigation to be sure.

Using the 'Data Selection Dialog' select the string of interest.  Go to ‘EDIT’ and ‘Edit text
annotation’ and display the point numbers and segment direction.  

Zoom into an area at the bottom of the model where the end of one string seems to be joined to
the beginning of another.

The co-ordinate of the top corner is 194054E, 374987N and the bottom right co-ordinate is
194178E, 374919N.



78

©2018 Atlas Computers Ltd

Note: The string of interest has been highlighted in the diagram.

Left click mouse to bring up 'Data Selection Dialog'.

Select 'All points on selected string' and 'OK'

Left click on string, all points on the string are highlighted in blue nodes
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Display Point Numbers & Segment Direction

Go to the ‘ANNOTATION tab > Annotate points' 

Turn on ‘Display point numbers’ and ‘Display segment direction

Note that highlighting boxes in this dialog will  turn  the  associated  text  on,
clearing boxes will turn text  off,  and leaving boxes grayed out will  not  effect
associated text at all. 

Select 'OK'
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You will notice one long segment going from point number 392 to 397 over which all the
crossing breaklines lie.  If this segment is deleted or removed then there will be no crossing
breaklines.

Go to 'MODEL tab > Details'

Left click on string, which will bring up a coordinate spreadsheet containing the coordinates of
each point.

Change Point 392 tag code from 'Straight' to 'Gap'

Select 'Update string in model'

The annotated string appears as shown in the figure to the left. From this we can see that
the string runs from point 383 to point 398 with a gap most probable required between after
point 382.  We could use the break strings option to establish this gap but in this case we
are going to use the string editor instead. Please note that the ‘Break Strings’ option is not
suitable for non-DTM strings, and it may sometimes be preferable to re-label one half of the
string rather than simply breaking the link. In these cases we use the string editor.
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3.5.7.5 Using The String Editor

Selecting the 'MODEL tab > Details'’ option in the model view accesses the string editor. To
select a string simply press the left mouse button over any point on the string we wish to
edit. A spreadsheet containing the co-ordinate details of the select string, is displayed.

The string editor is the most versatile of the editing tools and can be used to add and
remove points, change the direction of parts of a string, re-label a string etc.  If you can’t
find another way of performing a string editing operation, you will usually be able to do it in
the string editor.

3.5.7.6 Moving Points On A String

We are now going to look at a crossing breakline problem caused by two strings
overlapping. Using the ‘Move Points’ option best solves this type of problem. First go to the
area of interest.

Zooming to specific coordinates

Press 'Page Down' to zoom in quite close 

Select ‘VIEW tab > Position button’

On the dialog, enter coordinates of 194156.253, 374916.680
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Select the ‘Move’ option from the MODEL tab to move the point on the dashed string (Point
598) to the far side of the string it crosses, hence removing the overlap and the crossing
break lines.

Moving Point

Select 'MODEL tab > Move'  

Left click on the dashed string (Point 598) and  drag to the far side of the string it crosses,
hence removing the overlap and the crossing breaklines.

The ‘Move’ option should be used in conjunction with the snap controls where the ends of
two strings that meet, overlap slightly. It is better used free hand when fixing problems such
as the one above, and re-aligning tops and bottoms of kerbs for example.

Below is the result of using the ‘move’ option.
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3.5.7.7 Extending Strings To Intersect

Apart from breaking string links there is often a requirement to join strings together. This
typically occurs on larger jobs where several crews may be surveying the same string,
either at different times or from different directions. This will often leave a string in many
separate sections that needs to be connected.

If we zoom back up to the area where we were using the string editor we can see a few
strings that may need to be joined up.  

The ‘Join Str’ option  may be used to join two strings together with a single line which
is available from the MODEL tab. Alternatively the ‘Extend to Intersect’ option may be used
to extend the two strings until they meet which is available from the ADD tab.

The ‘Join Stri’ option will convert the two separate strings into a single string if they both are
of the same type. If they are not the same type an extra segment will be added to the end
of the first string to make it meet the second string, in this case they will remain separate
strings.

Select the ‘Extend to Intersect’ option and press the left button first on point 398 and then
on point 305 to join up the outer fence string. 

Extend Lines To Intersect

Go to ‘ADD tab > Extend drop down > Extend To Intersect’  

Select point 398 and then select point 305

Both lines will be extended until they intersect
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3.5.7.8 Trim Lines

Strings may sometimes extend further than they should.  If this happens use the ‘Trim’
command to trim the strings back to a cutting edge. 

Trim A Line

Select ‘VIEW > Position’

Type in the X and Y co-ordinates 193782.717 and 375066.203 respectively

Select 'Ok'
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Go to ‘ADD tab > Trim button’ or 

Pick 'TB' as the cutting string for trim – once selected, the cutting edge will turn to red

Select 'FL', as string to trim

Press 'ESC' quit this command

3.5.7.9 Copying/Moving Strings

Copy / Move strings and parallel strings is available from the ADD tab.

Consider due to an error in the original survey, it may be necessary to offset a string a
certain distance, or copy a string parallel. For example, if a hedge has been offset 2.0m to
the left instead of 2.0m to the right, then, by using the above command, you can offset the
hedge string 4.0m to the correct position.
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Copy A String Parallel

Select ‘ADD tab > Parallel button’ 

Enter the horizontal distance of 2m in the relevant box and turn on  the ‘Lock Horizontal
Distance’ and ‘Remove loops from new string’ options.

Using Drop Down Feature Menu select 'FE' as the new feature name

Left click on existing string and move/drag cursor in correct offset direction

Left click to place new string
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Select 'Close'

A vertical offset may also be entered though the new string will assume the levels of the
original string if the box is left at 0.000. If a horizontal distance is not specified and the ‘lock
horizontal distance’ box left blank, then the string selected can be moved automatically with
the cursor and the distance is shown in the ‘horizontal distance’ display.

3.5.7.10 Adding Slope Lines To A Model

As well as adding text to the model, you may wish to add a feature such as a slope string,
which indicates the slope of a selected area and the direction in which it is falling. Slope
strings can be added using two methods:

· Slope lines between strings or

· Slope lines using reference string

The first method allows you to pick two strings and generates the slope lines between the
two from the lowest to the highest. 

The second method is more likely to be used when the two strings are more curved or
jagged and in this case, the first method will not work. To add the slope strings between
strings of this nature, you need to add a reference string first. When the reference string has
been added, the slope string can be drawn, by selecting, in order, the first string, the
second string and finally the new reference string.

Add Slope Strings Using A Reference String

Add the reference string by selecting the  icon from the toolbar. Right click mouse to
update the string in the model.

Select ‘ADD tab > Hachure > Hatch with reference string’

A blue cross will appear at the end of the cursor.
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Select the First String and then second string by left clicking mouse on each respectively

Select the reference string

Enter in your own values 

OR

Accept the defaults

Select ‘OK’

3.5.7.11 Adding Hatching To A Model

SCC also gives you the option to add hatching to a model. The two options available are:

· ‘Hatch Polygon’ assumes a closed link between the first and last points on the string
regardless of whether it is displayed in the model. 

· ‘Hatch Strings’ will hatch between any two strings selected by the user. The strings must
be selected prior to using this option. This can be done using the ‘Data Selection Dialog’.
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Hatch A Polygon

‘ADD tab > Hatch  > Hatch a polygon’

Left click mouse on polygon you wish to hatch

Enter in the values for angle and spacing and select whether you want simple or cross hatching
displayed.

Select ‘OK’

3.5.8 Editing Pre-selected Data

Using the data selection dialog allows various methods of point and string selection. If points
have been pre-selected and then an editing option chosen, you will be asked if you wish to
perform this task on the selected points.

The following editing options may be used with pre-selected: 

§ Move points

§ Delete points and strings

§ Break Strings

§ Unlock Text

§ 3Pts Arc

§ Fillet Arc

§ Arc 2Pts + Radius

§ Arc 2Pts + Tangent
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§ 2Pts Circle

§ 3Pts Circle

§ Circle, Radius + Arc

§ 2Pt Rectangle

§ 3Pts Rectangle

Creating A 3Pts Arc From Pre-selected Data

Open the FGL model

Zoom into the south east of the model as shown in the diagram below

Click the right mouse button to access the 'Data Selection Dialog'

Set the selection method to ‘Individual Points’

Select OK

Select the points shown below

Go to the ADD tab

Set the Change Radius to 0.1

Select 'Arcs drop down button > 3 point arc

Select 'Yes' to ‘Convert selected points’

The result should look as below.
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3.5.8.1 Surveying Circular and Curved Objects

The following examines tag codes (Curve, Arc Fit & Circle Fit) assigned to man made circular
structure.

It must be considers that circular object on site have been designed with a specific defined
radius.  As the radius is unknown the surveyor must implement geometry tag codes between
survey points to best represent the structure on the ground.

It is important to note that curve fitting in plan is merely a plan fit in 3D and therefore not
recommended for man made structures on an incline/decline i.e. sloping ground.

In conclusion, circle fit is shown to give the best representation of man made object.

Curve / Curve Fitting Within SCC:

Extra curve points are generated in between surveyed curve points.  The type of curves used
is 'Splines under tension'.  Curve generation parameters may be further defined by tension
and point density parameters.  Points used to define curves should be surveyed at even
intervals apart.  The number of points required for accurate delineation of a curve depends
on the accuracy requirements.  As a guide on tight curves on road belmouths, points for
engineering accuracy requirements may be as close as 1 -2 meters - very tight curves on
traffic islands may be at 0.1 to 0.2 meters centres depending on the tightness of the curve -
main highway curves may be as far apart as 10 to 20 meter centres depending again on
requirements.

Curve Type

The following curve-fitting algorithm can be assigned;

Default

The curve fitting settings will be the default one found in the coordinate reduction options
dialog.

Catmull-Rom (Tight)

A Catmull-Rom curve will be fit through the survey points.  This curve type stays very close
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to the survey line and has user definable tension and tangent weights.

Tspline (Circular)

A trigonometric spline curve will be fit through the survey points.  This curve is suitable for
more circular features that are not true circles.  A T-Spline curve through an equilateral
triangle will result in a circle.  When collecting points on this type of curve, it helps if they
are reasonably evenly spaced.  Failure to do so may result in a curve that billows away from
the surveyed line.

Circle fit

This option creates a best fit circle through all the points on the surveyed polgon.  It is
usefull when dealing with circular tanks, small roundabouts, and other man-made circular
features.

Curve point density

This is the ratio of curve fit points to surveyed points.  For example, a value of 10 would
result in ten extra 3d curve fit points being generated for every survey point.

Curve tension

This applies to Catmull-Rom curves only, and defines the closeness of the surveyed line to
the curve.  The default value of 0.5 rarley needs to be changed.  A value of 0 results in a
straight line.  A value of greater than 0.5 allows the curve to billow further from the line, (i.e.
it loosens the curve).

Curve tangent weight

This applies to Catmull-Rom curves only, and defines the effect of the incoming and
outgoing tangents on the curve.  The default value of 1.0 rarely needs to be modified.

Coordinate Reduction Option 

The Coordinate Reduction option allows the user to edit configurable parameters relevant to
the generation of the detail co-ordinate information.  These parameters are used when
creating detail co-ordinates from the detail observation spread sheet.

Go to 'DATA tab > Settings drop down > Coordinate Reduction Options'
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Feature Library

Also specific settings may be assigned to individual features within the Feature Library –
Feature Wizard as shown below.

Go to 'DATA tab > Feature Wizard button'

Case Study:

Consider the Man Made Object with a defined radius denoted in each scenario in red.  Ten
survey points have been pick up in the field.

Scenario 1: Curve ‘C’ Tag Code
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In the field, the surveyor has pick up 10 points and assigned the relevant ‘C’ tag code to
each.  Extra curve points are generated in between surveyed curve points.

Note the influence of the point spacing in area A and B.  In area C, points have been
surveyed closer together and as a result the curve is a better representation of what is on
the ground. 

Scenario 2: Arc Fit Tag Code

An Arc Fit Tag Code assigns a best-fit circular arc to the surveyed points.  

When more than 3 points are used to generate the arc, the additional points are used only
to influence the arc.  That is, the arc will not intersect or pass through all points, as shown
below:
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The position and spacing of survey points is important.

Scenario 3: Circle Fit Tag Code

This option creates a best-fit circle.  It is useful when dealing with circular tanks, small
roundabouts, and other man-made circular features.
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Like Arc fit, not all survey points are intersected but rather influence the position of the
circle.

When generating a circle fit use the snap point command to pick up each survey point.

As shown below, the circle fit is the best representation of the man made object.

Note:

Additional Tag Codes have been added to the tag code drop down menu within 'ADD tab'’
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3.6 Triangle Editing

SCC supports two methods of triangulation: 'Delaunay' or '3D Nearest Neighbour'. Either of these
may be selected depending on the requirements of the dataset under consideration. Generally
the final model produced by either method for a given dataset will be almost identical. 

Delaunay triangulation forms the set of most equilateral triangles for a set of points. As
such it is deciding the final triangulation based on a purely 2 dimensional criterion and then
adding elevations to form a surface. As a rule it normally gives the most even spread of triangles,
and hence interpolation results, particularly in areas where data is sparse.  

3D nearest neighbour joins every point to all its nearest neighbours while not allowing any
edges to cross. While not providing as even a spread of triangles as Delaunay, the triangulation
is being weighted on a 3D criterion. This may often be more suitable for surfaces where strings
have not been surveyed and points are being selected randomly from the surface, e.g. for
bathymetric work. This is because triangle edges will form more along contours than across
them, hence finding the equivalent of natural strings. 

The triangulation is derived from the strings and points in the model. Therefore, all efforts should
be made to edit the strings before editing the triangulation.  Editing the triangulation allows further
control over the final model surface and its boundaries. 

Triangle Weeding

The simplest way of triangle editing is to ‘Weed the Triangulation’.

Weeding Model Triangles

From select 'MODEL tab > Edit drop down > Weed the Triangulation’
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Select OK to accept the defaults 'Use mean edge lengths and areas'

The weeding factor determines how many standard deviations from the normal will be
required to eliminate the triangle. A higher number will eliminate fewer triangles.

Weeding cycles determine how many times the system will run through this process.

Adding And Removing Triangles

The weeding defaults work reasonably well on most models but it is possible that some
triangles may be eliminated from the interior of the model that you wish to keep. The ‘A
dd/Remove’ option will allow you to replace any of those triangles. 

Additionally, there may be triangles the weeding did not remove, that are invalid. These may
be close to equilateral triangles crossing a concave area, or triangles interior to a building or
other flat surface. The above option also allow you to remove any of these unwanted
triangles.

By selecting 'MODEL tab > Edit button’, you will activate the triangle editor. You know when
this editor is active because the colour of the triangles in your model will be filled in either
green or blue. Triangles may be interactively selected or by using previously selected
points. The invalid or removed triangles are shown in blue and the valid triangles are shown
in green.

When you select this option a dialog will be displayed. This dialog allows you to control how
the triangles are selected and the action you wish to apply to them. 

By selecting points in advance, for example all points on a road center line, it is very easy
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to set triangles by feature or string. In this case, selecting ‘All triangles with any points
selected’ will usually refer to any triangle in contact with a road centre line.  This will be
much quicker than selecting triangles manually.

Triangle Editing

From  'MODEL tab > Edit button’

Highlight ‘All triangles intersecting line’

Highlight ‘Remove triangles’

Click OK

Select the triangles shown in blue in the image below by left click mouse to start the
intersecting line, move the cursor across triangle you wish to remove and then left click mouse
to end intersecting line.

Select Close (or press ESC) when finished

SCC then gives you the option of storing the boundary you have created using the ‘
Add/Remove Triangles’ option, as a boundary string. If you say ‘Yes’ to this, a boundary
string called '~BNDRY' is created and stored in your model. This is very useful especially
when volume calculations may be needed.

Click 'Yes' to 'Store model boundary as a string'
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The ‘Add/Remove Triangles’ option also allows you to disable contours in a given area, but
keeping the triangles active. For example, on a road, you may not want to display contours
across the hard surface but will wish to generate profiles and cross sections of the road at a
later stage. Removing the triangles from this area will mean that no sections can be
generated at all so therefore you would use the ‘Disable contours’ option instead.

Flip Triangle Edges

This option allows you to switch the connecting edge between two adjacent triangles. If you
have proper breakline strings defined, this will not be necessary, whereas models made up
mostly of points, will require this option more.

When the flip triangle edges option is active, the triangulation will be drawn.  As you move
the cursor around the model, the triangle edges to be flipped will be highlighted. The left

mouse button will switch the connecting points.

This option will normally only be used on models  made primarily of points. 
Using correct stringing will usually give a better result.

Triangle Edge Flipping

Select ‘ MODEL tab > Flip button’

The link to be changed will be highlighted

Select a link (Choose a large triangle)

Left click mouse

Click on  to exit the option or Esc

3.6.1 Generation Of Boundaries

Boundaries are important for volume calculations.  If the surface used in volume calculation is not
clearly defined the result of the volume calculation will be ambiguous. If a boundary has not been
surveyed in the field for whatever reason, one must be generated in SCC.  

We have already discussed how to use the ‘Add/Remove Triangles’ option to create a boundary
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in the model.

Here we will describe how to use the ‘Add String With Cursor’ option to generate a new string in
your model. If your model already contains strings that may form part of the surface boundary,
they may be used to generate the new boundary. The most common way to generate boundary
strings is to select the outmost surveyed points in the model.  It is important therefore that the
snap control is set to nearest point. 

Adding A New String To The Model

It is possible to add strings to a model using the ADD tab tools.

Using the field boxes above, set the feature code to ‘boundary’ and the tag code to ‘straight. The
DTM code is set to ‘clip polygon’ because we wish to use this string as a boundary where all
contours and triangles outside of the polygon are clipped out of the DTM.

Pick Polygon from 'ADD tab > Lines drop down'

Click the left mouse button once for each point you wish to add, and right click mouse to ‘Update
String In Model’ button.

A very useful technique on this menu is the option to ‘Save Co-ordinates As Dataset’. This
allows the new boundary co-ordinates that you have created to be saved as a separate
dataset that can then be used as a boundary for multiple sub-surfaces.

3.7 Annotation In The Model

In terms of text placement, SCC has eighteen automatically annotatable fields per point.  For
each of these fields it is possible to specify text size, width, position relative to the point,
justification relative to the point, alignment relative to string, grid and sheet, suffix and prefix,
output layer, font and style.  Additionally you can specify whether to annotate all or selected
points for this feature and field, and what the relative priority of this field is when automatically
deleting overwriting text. This can all be set up in the feature library prior to download, thereby
reducing the amount of work that needs to be done to produce the final plot.

Once in the model, these settings can be viewed through the ‘Query & Edit Points’ option.
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However, it is recommended that any further editing of text should be done using one of the
following options:

Text Node Editing

 Create Text

This option allows you to add free form text and text macros to your model.  Selecting it
presents the ‘Create / Edit Text’ dialog shown below.

Type in the text you wish to add to the model.  Then click on the model where you wish to
insert the text.  You may set the height, width, rotation and justification of the text in the
dialog or interactively when the text is inserted into the model.  Font information for the text
will be determined by the current text style.

There is also the option of adding X,Y and Z co-ordinates (in text form) to the model using
the nearest and interpolation macros available. To do this, select X,Y or Z from either ‘Get
from nearest point’ or ‘Interpolate from model’ and hit the 'APPLY' button. As you move the
cursor about the model, the text will be automatically updated, giving you either the
interpolated co-ordinates of the point at the end of the cursor of the co-ordinates of the
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nearest point, depending on the option selected. Ticking the ‘Enable dynamic update’ option
means that if at a later stage you have to move the text, it will be updated automatically to
display the co-ordinates of the new position.

Edit Existing Text

This option allows you to edit existing text in the model.  The option works in a similar
manner to the create edit text option, but in this case you must initially select the text with
the mouse, rather than entering it in the dialog.

Delete Text

This option allows you to delete existing text.  Select this option and then select the text
you wish to delete.  To select the text, click on it with the mouse.  Use the 'Data Selection
Dialog' prior to selecting this option to delete a large amount of text at the same time.

Move Text

This option allows you to move existing text.  Select the text by clicking on it and then
moving it with the mouse to its position.  Use the 'Data Selection dialog' prior to selecting
this option to delete a large amount of text at the same time.  Pressing the ‘*’key in move or
rotate text changes the mode between moving and rotating the selected text item.

Rotate Text

This option allows you to rotate existing text graphically about the insertion point of the text.
The insertion point of text is to the bottom left of the text.  Use the 'Data Selection dialog'
prior to selecting this option to rotate a large amount of text at the same time.  This will give
you an option to either set a fixed angle for all the selected text or add a relative rotation to
that text.

Move and rotate text

This option combines the move and rotate function into one button.  After selecting this
option you can move text and then left click to change to rotate function. 

Resize Text

This option allows you to resize exiting text interactively on the screen.  Use the 'Data
Selection Dialog' prior to selecting this option to resize a large amount of text at the same
time.

Copy Text

This option allows the user to copy text and paste the text multiply. 

Text Style

The text style controls the font and effects for model text.  To set the style of text nodes in
the model, first use the 'Data Selection Dialog' to select the text nodes you wish to modify,
then select the desired text style from the list given in this control.

Edit Text Style

This option allows you to create or edit a text style, using the standard Windows Font
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dialog. To create a text style, enter the name of the style and press this button. To edit an
existing text style, select the name of the style and press this button.  Apart from being
displayed and plotted in SCC, text styles may be exported to CAD.

 Unlock Text

This allows you to convert associative dimension text into literal text, in order to make it
editable.  Once dimensional text has been unlocked it is converted into remarks text for the
purposes of the model annotation dialog. Use the 'Data Selection Dialog' prior to selecting
this option to unlock a large amount of text at the same time.  This option is only applicable
for annotation items that have an feature library ‘Insert Method’ set to ‘Associative
Dimension’.  This will typically only be the case when working with very large models.

Show / Hide Macro Text

This option shows or hides text macro details, in order to let you see how various text items
have been created, and what they represent.  Text macros are typically used for annotating
point dimensions, such as elevation and point number.  All feature library text macros will
appear as ‘[VTX]’ with any appropriate prefixed and / or suffixes.   A complete list of text
macros currently in use in SCC is given below

Macro Name Description

[VTX] Any point annotation generated by the feature library

[Name] The file title of the current model

[Path] The full file name and folder location of the current model

[Scale] The plot scale

[Client] The client name, entered in the ‘Scales, titles and grids’ dialog.

[Date] The date, entered in the ‘Scales, titles and grids’ dialog.

[Surveyor] The surveyor name, entered in the ‘Scales, titles and grids’
dialog.

[ProjectTitle] The project title, entered in the ‘Scales, titles and grids’ dialog.

[Project] The SCC project name.

[Operator] The operator name, entered in the ‘Scales, titles and grids’
dialog.

[Time] The current system date and time.

[Version] The SCC version number

[Page] The number of sheets in the model

[Pages] The sheet number currently being plotted or displayed.

[ContourScale] A graphic representing the colour contour scale for relief
contours

[ModelX] The X ordinate of the text node

[ModelY] The Y ordinate of the text node

[ModelZ] The Z ordinate of the text node, interpolated from the
triangulation



105

©2018 Atlas Computers Ltd

[ModelChainage] The chainage of the text node, interpolated from the active
alignment

[ModelOffset] The offset of the text node, interpolated from the active
alignment

[NearestX] The X ordinate of the nearest model point to the macro text
node

[NearestY] The Y ordinate of the nearest model point to the macro text
node

[NearestZ] The Z ordinate of the nearest model point to the macro text
node

[NearestChainage] The chainage, generated from the active alignment, of the
nearest model point to the macro text node

[NearestOffset] The offset , generated from the active alignment, of the nearest
model point to the macro text node

[NearestD1] The first dimension of the nearest model point to the macro text
node

[NearestD2] The second dimension of the nearest model point to the macro
text node

[NearestD3] The third dimension of the nearest model point to the macro text
node

[NearestPoint] The point number of the nearest model point to the macro text
node

[NearestFeature] The feature name of the nearest model point to the macro text
node

[Stn <n> Name] The name of the <n>th station in the model, normally used for
creating station schedules in sheet layouts.

[Stn <n>X] The X ordinate of the <n>th station in the model

[Stn <n>Y] The Y ordinate of the <n>th station in the model

[Stn <n>Z] The Z ordinate of the <n>th station in the model

[Stn <n>] The name X,Y and Z of the <n>th station in the model

[Ftr <n> Name] The name of the <n>th feature in the model,normally used for
creating legends in sheet layouts.

[Ftr <n> Layer] The layer name of the <n>th feature in the model

[Ftr <n> Title] The description of the <n>th feature in the model

[Ftr <n>] The name, layer name and description of the <n>th feature in
the model

[DrawFtr <n>] A graphic sample of the <nth> feature in the model

[Fcode <n> Name] The name of the feature, with feature named <n>in the model,
normally used for creating fixed coded legends in sheet layouts.

[Fcode <n> Layer] The layer name of the feature named <n>in the model
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[Fcode <n> Title] The description of the feature named <n> in the model

[Fcode <n>] The name, layer name and description of the feature named <n>
in the model

[DrawFcode <n>] A graphic sample of the feature named <n> in the model

[Signature] A graphic of the surveyor’s signature, created by the
PocketDTM ADC module.  Used for signed models.

Toggle Text On/Off

This option turns on or off all the text associated with a given point and is provided as an
alternative to manually deleting text, or using the delete overlapping text option.

Align Text To A String

This option aligns text to a given reference string, either interactively or by pre-selecting a
number of text nodes.

Delete Overlapping Text

This option allows SCC to delete any overlapping text based on the number entered in the ‘
Priority’ field of the text attributes in the feature library. Each piece of associated text is
given a number and the higher the number, the higher the priority. Therefore, if there are two
pieces of text overlapping where the point number has a priority of 3 and the elevation has a
priority of 6, then, the point number will be deleted. This option can be used in conjunction
with the 'Data Selection Dialog' to highlight either certain areas, features or strings.

Delete Overlapping Text Using The Data Selection Dialog

First, press the ‘Escape’ button. This will cancel any active editing process.

Press the right mouse button and the ‘Data Selection Dialog’ should appear.

Select ‘All point in a window’ 

Select ‘OK’

In the model, draw a window around the area in question.

All points within this area should be highlighted blue.

Go to 'MODEL tab > Delete Overlapping Text button'

SCC will then inform you of how many pieces of text were deleted during the process.

Any remaining text can then be interactively moved, rotated, resized, deleted or edited. 
Text that has been deleted can also easily be restored using the ‘Annotate Strings’ tool,
which again works best in combination with the data selection tool.

Feature Annotation

The feature annotation option is similar to the string annotation option except that it allows
the user to add annotation to the model by feature rather than selected points or strings. 
Remember that a feature refers to all strings of the same type, such as all hedges, all walls
etc.  Group information set up within the feature library is also displayed within the Feature
Annotation dialog.  This allowing the user to modify, select and display data based on their
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defined group. 

Viewing Feature Annotation

Select ‘MODEL tab > Feature Annotation button’

Note that Feature Annotation option modifies the models  feature library,  and
re-annotates all  strings  for  any  features  that  are  altered.   This  is  liable  to
undo other text editing and should be used with caution.  
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4 Import & Export From Model

SCC includes a wide range of methods for communicating with other software packages and
survey devices.  These comprise of general purpose data exchange methods and functions that
are specifically for communication with a given package. The general purpose methods include
cut & paste, full OLE (object linking and embedding) client, server and automation support and
user defined ASCII import and export. The cut and paste routines support cut and paste in text
format, Microsoft Excel and Access format, bitmap format, OLE object format, and internal SCC
coordinate exchange format.  This means that cut and paste can be freely used both internally
within SCC and to transfer information between most other Windows software.

The specific functions include highly configurable bi-directional CAD and MX/MX interfaces.

4.1 Importing Additional Model Data

There may be instances where you have recorded a survey, downloaded it into SCC, created and
edited the model and then you are required to take more survey information. To add this extra
survey information to your existing model, you will need to download the new survey into SCC,
using the original project file, save this file as a dataset (survey file) and add it to the existing
model. The ‘Add Strings from File’ option, under the ‘TOOLS’ menu allows you to do this.

Data can be added to the model from files other than SCC datasets. SCC is capable of accepting
additional information from DXF files, ASCII files and MX (Moss) Genio files.

Create a model using the existing survey files, FGL1, FGL2 and FGL3 and then add the Survey
file FGL4 to the model.

Adding More Survey Information to an Existing Model

Go to ‘DATA tab > Model’

Highlight the files, ‘FGL1.Survey’, ‘FGL2.Survey’ & ‘FGL3.Survey’.

Select ‘Create the model and Triangulation’ as before 

Select OK

Save the model as ‘FGL123.model’

Go to ‘TOOLS tab > Tools drop down > Add Strings from File > SCC datasets’

Highlight the file ‘FGL4.survey’

Select Open

Select ‘Normal Topographic Data’

Select OK

Selecting ‘Normal Topographic Data’ means that SCC uses the elevation/height detail from
the SCC dataset you are adding. If you select ‘2D boundary strings’, SCC will drape the X
and Y co-ordinates on to the model and add the elevation/height information from the
existing ground surface. This is more commonly selected when adding boundary strings.

4.2 Export Data from SCC to CAD

The CAD interface supports a wide variety of CAD packages, and where the CAD system is
available on the same computer as SCC, SCC will automatically run the model into CAD. The
CAD export also includes user definable colour matching for Microstation, and nearest colour
palette mapping where relief mapping is in use. Note the Microstation DGN output supports
alpha-numeric layer names.
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The key thing to remember in exporting model data to CAD is 'what you see on screen is what
will be transferred'. That includes grids, text contours and triangles, etc.The feature library is
used to control MX labelling and CAD layering such that it is entirely independent of the field
coding in use.

SCC will create AutoCAD line styles and text styles to match the SCC drawing with the
minimum number of entities.  Note that when exporting in 3d, all polylines will appear as
continuous lines.  This is a restriction in AutoCAD rather than SCC. 

Export Model To Cad Drawing

Go to ‘DATA tab > Export drop down > CAD’

Enter in a file name

Select ‘Advanced Options’

Select the host Cad system you are using

Select whether you want 2D or 3D information and other required settings 

Select ‘OK’

 Direct links (within General Options) may be created from SCC to Windows based CAD
systems.

4.3 Export Data from SCC to MX

The MX Interface

The MX interface includes support for transfer of model, section, alignment and drawing
data, using GENIO and other MX formats.  Output of model data can be in 3d or 4d, where
the fourth dimension is the survey point number, and includes support for non-DTM 3d data
such as invert levels and overhead features. The ‘Export to Moss’ option can be located
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under the 'DATA tab > Export drop down > MX GENIO' .

Export Model To Moss Model

Go to 'DATA tab > Export drop down > MX GENIO' ’

Enter in a file name

Select the options 'Do not output any DRAW information', 'Export non-DTM elevations as null
levels (-999) and 'Collate point strings'

Select ‘OK’

The input file will be saved in your current working directory

MX String Labelling

The feature library controls the conversion of SCC survey data sets into MX models.  Part of this
process is the automatic allocation of MX string labels.  This may be either totally automatic, or
where required, full MX string labels may be coded in field.

In the feature library, the 'LBL' field is used to determine the label of any MX string generated for a
given feature.  For example, if coniferous tree is coded as TCONIF,  the 'LBL' field might have a
value of 'TC', hence point strings for this feature would be labelled PTC0 to PTCZ, and line strings
coded TC00 to TCZZ.

In MX SURVEY based data collectors, the surveyor may code strings with a full four character
MX string label.  If the initial characters of the string label agree with the 'LBL' field of the
matching feature in the feature library, the surveyed string label will be carried through.  For
example, say the centre line of the road being surveyed is given a feature name of CL05.  SCC is
set up to use the nearest matching feature in the feature library, which in this case might be CL.
The feature CL also has CL set in its 'LBL' field, thus the feature name CL05 will be created as
string CL05 in the MX model.  If a MX SURVEY file contains a feature of less than four characters
in length this is treated the same as any other feature, in MX this is referred to as a partial string
label.

The characters M (Master alignment string) or G (Geometry string) should be avoided as the first
character in the 'LBL' field as they denote strings of special significance in MX.

5 Typical QA Procedures for Survey Models

Before delivering the model you should check the following:

There are no crossing breaklines. Crossing breaklines are identified in SCC as a red cross, and
indicate that the elevation at that point in the model is either incorrect or ambiguous. They
typically highlight string linkage errors, inaccurate surveying, or string naming and hence DTM
coding errors.
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· Strings representing single continuous features on the ground should consist of a single
continuous string in the model. This can be checked using the ‘All points on string’ option with
the 'Data Selection' dialog and picking any point on the string. If the string is continuous all
points on it will have a selection highlight. For example, if the survey contains a road
centerline, that centerline should be a single string, such that you can use it to generate long
sections and cross sections for the length of the road. The same is true of boundary strings
and other closed strings, where the software is dependent on the polygonal nature of the string
for certain calculations.

· Strings should not contain two or more consecutive gaps.  While SCC allows this, if exporting
your model to MX, this will cause the GENIO file generated to fail in MX.  This can be checked
using the ‘Report String Details’ under the ‘TOOLS’ menu and checking the right hand side of
the report for consecutive gaps. These gaps can be removed either using the string editor or
the ‘Delete points’ option.  

· Strings should not contain more than one closing link. Such errors will automatically be fixed
by SCC and noted in the log file.

· Strings with less than 3 points should not contain a closing link. Such errors will automatically
be fixed by SCC and noted in the log file.

· Point strings should not contain gaps or closing links. Such errors will automatically be fixed
by SCC and noted in the log file.

· Strings, particularly road strings, should not contain duplicate points or double back on
themselves. An example of what this looks like and how to rectify it is shown in the section on
point deletion.

· Gaps should not be used to break up separate strings. It is a common survey mistake to end
each string with a gap such that the same string label can be re-used. SCC provides an END
tag for this purpose. Using a gap means that many options such as copying and offsetting the
string will not work correctly, as the option will be applied to too many points. It also means
that if such a string is closed with a link, the link will probably join back the wrong point. Gaps,
and MX DISC codes, should only be used to represent a gap in a given string that corresponds
to an actual gap on the ground, for example a gap in a fence for a gate, or a gap in a major
road for a junction with a minor road.

· String editing can be the most time consuming part of model editing. It can generally be
minimized by good field practice.

Checking The Accuracy Of The DTM

Checking the accuracy of the DTM is usually very simple and involves checking there are no
spurious elevations in the model and no features that have been included in the DTM that are not
part of the ground surface.  Checking for spurious elevations is achieved by looking for obvious
anomalies in the contours. The relief contours tend to highlight such problems.  Generally, if a
single point or a single point on a string causes a significant change in the contours, shown as a
series of circular contours around that point, the point is suspect and should be investigated
further.

It is good survey practice to survey in strings rather than discrete points.  While discrete points
can be used to adequately describe smooth and reasonably flat surfaces, they are unsuitable for
describing irregular surfaces containing significant grade changes such as embankments, spoil
heaps, pits & hollows, etc.  Strings are used as breaklines and as such, constrain the
triangulation around irregular areas, the net effect of not using strings where they are required is
that embankments, pit edges, etc. may appear to spill.  Note that the only difference in survey
procedure is to enter a unique non-zero string number for any string being surveyed. Not providing
strings where they are required can often lead to serious volumetric errors.

Another method, applicable to road and similar surveys, is to take a series of cross sections
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down the center of the road and check for anomalies on the sections. 

Where high accuracy is required and must be proven, the usual method is to abstract either a
grid or sections from the model, get an independent crew to stake them out on the ground and
compare elevations using a level.  This is a time consuming job and would normally only be
required where elevation accuracy is of primary importance.

QA Tools in SCC

 In order to speed up the process of QA checking in a model, SCC provides an extensive range of
tools to rapidly identify and correct all of the potential modelling problems outlined.  Please read
the topics listed below for details on these tools.

6 Volumetric Analysis & QA

Overview of Different Methods of Volumetric Analysis

In SCC there are 3 methods by which volumes may be calculated.

1. Cross Sectional End Areas method

2. Prismoidal / Isopachyte method

3. Grid method

All three methods of volume calculation should be performed when calculating volumes, as each
method is mathematically independent of the other and hence each provides a check on the
other. Differences of more than one or two percent indicate possible errors.

When calculating volumes it is important that there is a common boundary between the two
surfaces, defining a common plan area over which volumes will be measured. Accurate volumes
can usually not be calculated between two surfaces where a common boundary is not defined,
due to the ambiguous nature of the area over which the measurement is taken. Poor boundary
definitions are probably the most common cause of gross error in volume calculations. 

6.1 Creating Profiles & Sections

Before volumes are calculated we will take a brief look at creating profiles and sections which are
available within the ANALYSIS tab. 

Profiles

Profiles can be taken through any number of models, using existing strings or selecting
points with the cursor. In either case, a SCC section file will be created containing the
profile information.

With A Cursor

To create a profile with the cursor, using the left mouse button, simply select points on the
model where you want the profile to run.  When you are finished with the profile and are
ready to view the section, click your right mouse button. Your profile will be displayed and
can be saved as a ‘.Section’ file. If you wish, you can continue adding points to the profile
by using the left mouse button again.

Using Existing Strings
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Select ‘Long Section From Existing String’, and then in the model, select any point on the
string you wish to generate a long section from. Again, your profile will be displayed
automatically and can be saved appropriately.

From Coordinate Data

This option allows you to use the X, Y co-ordinates of another file to define the plan path of
the profile. The elevations will be derived from your current model. The data can come in
many formats, datasets, DXF and ASCII being the most common.

Cross Sections

From Existing String

For this option you will be asked to provide the left and right offset distances. You can
choose to have sections taken at regular intervals, at the survey points, or both.

From Coordinate Data

This option is used where you have previously created a long section using one of the profile
options under the ‘SECTION’ menu. After choosing this option you will select the file to
generate the cross sections from and then proceed as using an existing string above.

To get some experience with sections, open the example project and the FGL model.
Create a profile along the center of the length of this model and save the section file as ‘FGL
long.Section’.

Opening An Existing Model

Open the Project Example.project

Go to ‘FILE > Open’ 

Change the Files of Type to SCC Models (*.Model)

Select the model 'FGL.Model'

After opening the Example project and the FGL model:

Creating A Profile

Go to 'ANALYSIS > L.Sect'

Select three or four points with the left mouse button following the center of the FGL model

When finished, click the right mouse button

View the profile

Select ‘SCC button  > Save As’ and call the file' FGL long.Section'

 Close

Now let’s create the cross sections 

Creating Cross Sections

Go to 'ANALYSIS > X.Sect'

Set the Chainage Interval to 10
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Set Offsets to 100 (should go beyond required area)

Leave the option to ‘Add Sections at Regular Interval’ on

Select OK 

Left click on road center line string 

View the cross sections

Select ‘FILE  > Save As’ and save as FGL Cross.Section

Have the file FGL cross.section file open:

Adding a Second Surface to the Sections

Within Section file, select ‘EDIT tab > Append button’

Select OGL.Model from tutorials directory

Data from the OGL surface is now added to the FGL sections.  This only occurs where the
two models overlap.
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When displaying sections in SCC it is important to  select  a  datum  that  is
lower or equal to the lowest point of any of the models being analysed.

6.2 Calculation Of Volumes Using Different Methods

Using the models FGL and OGL we will calculate volumes using prismoidal, grid and cross
sectional methods.  Both these models have been previously created. However no boundary has
been defined on either model. We will define a boundary on the smaller model, OGL. This model
already contains a boundary string, probably surveyed in the field, however the DTM extends
beyond this string (look at the contours). We need to change the DTM status of this string to
'Clip Polygon', which means that no information outside this line will be included in the DTM.

Changing the DTM status of an existing string can be done in two ways, by using the string
editor (that is, 'MODEL tab > Details’) or using the DTM list boxes on the ‘ADD tab’. The method
below describes the latter.

Creating A Boundary From An Existing String

Open the model OGL

Click on the right mouse button to bring up the ‘Data Selection Dialog’

Select ‘All points on selected string’

Press OK

In the model, select a point on the outermost string (the boundary string)

Once it has been highlighted, go to the DTM list boxes on the 'ADD tab’ and change the code in
the DTM status box to ‘Clip Polygon’.

You will be asked ‘Do you wish to convert all points to Clip polygon’, press OK

Save the model

6.3 Average End Area Method

To calculate volumes using this method, you must first create sections that contain all the
surfaces being considered. The reference string can be an existing string or a profile you created
using the ‘L.Sect’ option. In either case, the following procedure is the same.

1. Create section set

2. Append surface of additional models

3. Calculate volumes between surfaces of interest

Having the model FGL active:

Opening Existing Edited Models from Tutorials 

Select 'SCC button > Open'

Select 'FGL.Model'

Repeating the same steps, select 'SCC button > Open' and select 'OGL.Model'

Both models have been triangulated correctly and the relevant boundaries formed prior to
calculating volumes.

Generation of Cross Sections

Within 'FGL.Model',  go to 'ANALYSIS > X.Sect'’

Set the Chainage Interval to 10



116

©2018 Atlas Computers Ltd

Set Offsets to 100 (should go beyond required area)

Leave the option to ‘add sections at regular interval’ on

Select OK 

Left click on the road center line

View the cross sections

Select ‘Save’ and save as FGL cross.section

Append Surface

Within Section file, select ‘EDIT tab > Append button’

Select OGL.Model from tutorials directory

End Area Volumes

Within Section file, select ‘EDIT tab > Append drop down > Volumes ’

Select Existing Surface and Proposed Surface

Select to 'Annotate Volumes' and to 'Highlight cut and fill'

Examine report and results
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6.3.1 Exporting User Defined ASCII file From Sections

The following examines the exporting of a user-defined file from a Section file.  

Case considers the export of a *.txt file containing Chainage, Offset, X, Y, Z, Feature of all
ground points within the Section File.  

Section File

Open Project File 

Open Section File

In this instance, Cross Section have been generated along a string at Chainage Intervals of
10.00m .

Output Ground Points

The User is required to output a *.txt file of Chainage, Offset, X, Y, Z, Feature of all ground
points: 

Annotation Settings:
Within Section, go to ‘VIEW > Descender’

Assign the following
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Exporting User Defined File

Within the Section File, select ‘DATA tab > Export drop down > User Defined ASCII File’
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Select ‘Section Details’ and place cursor in the box below

Select required ‘Field’ from drop down menu with the ‘Add Field to Macros’

For example, ‘Chainage’ and select ‘ADD’

Manually enter a comma ‘,’ between each macro field added to construct a csv file
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Enter a Format Name within Field Details ‘Section_Test’ and select ‘Save’

This saves the format to allow the user to output other files using same Section Details.  The
Format should be available from the drop down ‘Format’ Menu in future.

Enter ‘Output File’.  ‘Ch0-1100.txt’

Select ‘OK’

Select 'No' to 'Output surface intersection points only'

Extract of File Shown below: 

      0.000,    -100.000,  193692.647,  375479.004,      19.584,0
       0.000,     -99.014,  193691.675,  375479.167,      19.552,0

       0.000,     -98.382,  193691.051,  375479.271,      19.522,0

       0.000,     -94.799,  193687.517,  375479.861,      19.380,0

       0.000,     -93.068,  193685.810,  375480.146,      19.296,FL

       0.000,     -81.994,  193674.888,  375481.970,      18.813,0

       0.000,     -73.145,  193666.159,  375483.428,      18.057,0

       0.000,     -67.501,  193660.592,  375484.358,      17.606,0

       0.000,     -61.539,  193654.711,  375485.340,      16.907,FL

       0.000,     -52.869,  193646.160,  375486.768,      16.667,0

       0.000,     -46.577,  193639.954,  375487.805,      16.385,0

       0.000,     -33.948,  193627.497,  375489.885,      16.033,0

       0.000,     -27.429,  193621.067,  375490.959,      15.902,0

       0.000,     -17.478,  193611.253,  375492.598,      15.818,0

       0.000,     -14.144,  193607.964,  375493.147,      15.970,0

       0.000,     -12.891,  193606.728,  375493.354,      16.100,0

       0.000,      -9.593,  193603.475,  375493.897,      16.260,0

       0.000,      -4.925,  193598.872,  375494.666,      16.394,RL

       0.000,      -1.074,  193595.073,  375495.300,      16.517,0

       0.000,       0.000,  193594.013,  375495.477,      16.543,RL

       0.000,       1.135,  193592.894,  375495.664,      16.521,0

       0.000,       4.983,  193589.099,  375496.298,      16.471,RL

      10.000,    -100.000,  193691.000,  375469.177,      20.680,0

      10.000,     -92.998,  193684.094,  375470.328,      20.342,0

      10.000,     -89.331,  193680.476,  375470.931,      20.131,0

      10.000,     -88.681,  193679.835,  375471.037,      20.087,0

      10.000,     -84.014,  193675.231,  375471.805,      19.833,0

      10.000,     -79.447,  193670.727,  375472.555,      19.502,FL

      10.000,     -72.407,  193663.782,  375473.713,      18.940,0

   

Note:
The user defined output from the Section Screen, is unaffected by the Annotations Settings.
 

For instance, if the user turns all descenders off as shown below and outputs using ‘
SectionTest.SCCOutput’ the *.txt file will remain the same.  
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6.4 Prismoidal Method

The first and most accurate method of computing volumes is the Prismodial projection method.

This method involves the creation of an isopachyte or thickness model from the two surfaces
under consideration. This is achieved by calculating differences in elevation from all surveyed
points, and along all surveyed strings, in both models, and triangulating the result. Once the
isopachyte model has been formed, prismoidal volumes are calculated by adding the volume of
each triangular prism generated by projecting the isopachyte triangle to a datum of zero.  Note
that individual triangular prisms may contain both cut and fill with this type of measurement.

The volume calculation report generated from the volume computation shows us the plan and
surface areas under consideration as well as the total cut and fill volumes. It also gives us
average material depth and calculates the effect of survey elevation accuracy on the volume.

Volume options are available within 'ANALYSIS tab'.

To calculate prismoidal volumes you must have a model window active.

Calculating Prismoidal Volumes

Select ‘ANALYSIS > Prism Surf.'

Fill in the dialog box with the existing surface and the proposed surface

Since  SCC  provides  the  default  name  of  VOLUMES.REP  to  all  volume
reports, you may want to use a specific file name to avoid  having  the  data
overwritten

Select 'OK'

Isopachyte Surface Model

Select 'Create the model and triangulation' and set the Inital Plot Scale as 200

Select 'OK' to the Model Attributes Dialog

Examine Report

Once we have created an isopachyte model, we can colour it according to depth of material and
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calculate material volumes by depth. Note that this is using an end areas method based on
horizontal sections whose accuracy is dependent on the vertical interval.

6.5 Grid Method

This option is similar to the prismoidal method, except that the volumes are derived from a
regular grid of rectangular prisms. Each prism is generated by calculating height differences for
the four grid points that make up its vertical edges. The total volume is computed as the sum of
the volumes of the individual prisms.  You can use the default grid sizes, or fill in different values
on the dialog box.

The main disadvantage of using this technique to compute your volumes is that it does not
provide graphical representation of the results. It does have the advantage though that it does not
require any additional memory resource to compute the volumes, other than required by the input
models. This is useful when using larger models and computer resource limitations are an issue.

Volume options are available within 'ANALYSIS tab'.

Volumes Calculations

Select ‘ANALYSIS > Grid Surf.'

Fill in the dialog box with the existing surface and the proposed surface

Using the 'Pick>>' button select the existing and proposed surfaces

Enter  report filename

Both prismoidal and grid volumes also report the plan areas for which there is no overlap and
compute the probable and worst case effects this is likely to have on the result.  Also reported is
the effect that elevation accuracy will have on the measurements. This can prove useful in
dictating appropriate survey methods, and overall confidence in the measure. 

6.6 Calculating Spoil Heap Volumes

Often when calculating spoil heap volumes the original ground surface is not available. Therefore,
the original surface has to be estimated from the surveyed surface. The base of spoil heap or the
top of a quarry site would be taken as the original ground surface. 

We are going to use the model DUMP.

Create the model ‘DUMP’ from DXF file

Go to ‘DATA tab > Model > DWG, DXF or DGN file’

Select Pick button
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Select the file DUMP.DXF from the directory \SCC\Tutorials\

Select Open

Select OK

Select ‘Create Model and Triangulation’

Select OK

Save model as DUMP.Model

There is a spoil heap in the bottom half of this model.  Using the Data Selection Dialog
(right click mouse), highlight all points on the base string of the spoil heap and from the
DTM list box, convert the string to ‘Clip Polygon’. 

Creating The Boundary String

Zoom into the area of the spoil heap

Click the right mouse button to access the Data Selection Dialog

Set the selection method to ‘All points on selected string’

Select OK

Select the string indicating the base of the spoil heap (See image below)

Go to 'ADD tab', from the DTM list boxes, select ‘Clip Polygon’ from the DTM status box.

Select ‘Yes’ to convert the string

Save the model
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From the ‘ANALYSIS tab', selecting the ‘Heaps/Pits’ option will calculate the volumes of
any spoilheap or pit so long as there is a clip polygon string around it. This option also
allows multiple clip polygons in the model. SCC copies the boundary string to a second
model and then computes volumes between the two using the prismodial method. It does
this in one step and gives you the option of keeping the intermediate boundary model, the
isopachyte model and report file and whether you wish to annotate the volumes on the
model.

Computing Spoil Heap Volumes

Select ‘ANALYSIS > Heaps/Pits’

Enter in a new or accept the default report name

Select the options you require, if the options to ‘Keep intermediate isopachtye models’ and ‘K
eep intermediate boundary models’ are not turned on, these two models will be stored in your
current working directory regardless.

Select ‘OK’

Review Report
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6.7 Identification of Potential Errors In Volumes

Before volume calculations are carried out both models should be checked for the following
points.

Define Topography Using Strings Not Entirely Discrete Points

Ensure that the models are defined using strings and not entirely of discrete points (spot
elevations).  While discrete points can be used to adequately describe smooth and reasonably
flat surfaces, they are unsuitable for describing irregular surfaces containing significant grade
changes such as embankments, spoil heaps, pits & hollows, etc.  Strings are used as
breaklines and as such constrain the triangulation around irregular areas, the net effect of not
using strings where they are required is that embankments, pit edges, etc. may appear to spill
as illustrated in the diagram below;
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The error shown above is corrected by connecting the discrete points defining the embankment /
grade change with a string to produce the results shown in the following picture.

Note that the only difference in survey procedure is to enter a unique non-zero string number for
any string being surveyed.  Not providing strings where they are required can often lead to
serious volumetric errors.

When calculating prismoidal volume between models that contain only point information, there is
an option to ‘Add Surface Intersections’ to ‘Triangle Edges’. Make sure that this is set before
computing the volumes. 
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Boundary

The survey model should always extend beyond the design area to facilitate side slope design,
and the side slopes should be recomputed whenever the survey model is modified. For accurate
volumetric analysis, a common boundary string, normally generated from the side slope intercept
points, should be included in both models.  

Accurate Volumes

Accurate volumes cannot be calculated between two surfaces where a common boundary is not
defined. Poor boundary definitions are probably the most common cause of gross error in volume
calculations. The boundary string should always have a DTM status of clip polygon and will
normally take the form of an existing string line, one generated by interface design, or one added
manually to the model in SCC. If a boundary is not provided, most modeling packages, including
SCC, will automatically determine a boundary, using a convex hull or similar algorithm. Such
boundaries rarely reflect conditions on site, as can be seen in many cases, by contours
appearing outside the surveyed areas. In any case, such a boundary is ambiguous, as it is
dependent on the algorithm selected by the software package rather than the judgement/
agreement of the engineers and surveyors on site. Weeding and the adding/removing of traingles
may also be used to define plan areas although use of a boundary string is far superior.

Visual Verification

Both models, that is, the survey and design or OGL and FGL, should always be visually verified
prior to computing volumes, as if there are any discrepancies in either model the result is liable
to be a gross error in the results. To verify a model, increase the contour interval, say to 0.2m
and visually check the contours. It is also wise to generate a number of profiles and cross
sections, with vertical exaggeration of say 5:1, through the model to further check for anomalies. 

Volume Verification

Having verified all models you may then proceed with volume calculations.  When calculating
volumes, it is advisable to use all three methods, i.e. prismoidal, grid and cross sectional, and
compare the results. Each method is mathematically independent of the other, and hence each
provides a check on the other. Differences of any greater than approx. 0.5% indicate ambiguities
in either the surface or boundary conditions. Of the three methods, cross-sections are most
prone to error, particularly when dealing with survey models in rough terrain. The reason for this is
that cross sectional volumes assume that data along the cross section is typical of data between
cross sections, which is often not the case. If you have errors in your data, cross sectional
volumes are liable to magnify their effect.

Cross sectional volumes may also contain errors due to curvature.  The end-areas method of
calculation also assumes that cross sections being used are parallel to one another.  This may
not be the case where cross sections are being taken along a curved centre line, such as a road
centre line.  In this case, small errors can occur where there is fill on one side of the centre line
and cut on the other side, or vice-versa.  This is another reason to measure your volume using
more than one method, prismoidal and grid volumes do not suffer from this error.

Using Cross Sections To Verify Design

In many measurements, including road and building footprint design, it is the case that the
design and survey surfaces meet at the boundary string.  This will normally be carried out
through a process of interface design, either in SCC, or using another specific design package
such as MX or DOER.  If this is the case, it is necessary to check that the two models do
actually meet at the boundary.  The simplest way of doing this is to take a regular set of cross
sections through both models and check that there are no vertical side slopes visible, as shown
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in the following figure.

This can be caused by a number of different factors. The most common reasons are that the
survey model does not cover a large enough area to accommodate the interface design, or that
one or both models have been altered after the interface has been designed and the design has
not been updated. In either case, the result is liable to be a gross error in the volumes.

Contours

When verifying the contours in a design model where interface strings are being employed with
fixed side slopes, the contours along those side slopes should be parallel to one another.  In the
case of a flat building footprint, they should also be parallel to the edge of the design model. If
this is not the case, there is probably an error in the interface design that will lead to errors in
sections and volumes.

7 Interface Design Using The Alignment Module

SCC’s Alignment module allows simple and straightforward interface design.  

Create a model from a MX GENIO file.  Design a simple building interface which can then be
moved about the model until the amount of cut and fill indicated is roughly equaled.

Creating A Model From A GENIO file

Close all open windows except the Project Window

Go to ‘FILE > Model > MX GENIO file'

Select Pick

Go to the directory \SCC\Tutorials\

Select the file 'GROUND.CRD'

Select Open

Set the GENIO L-string processing to Treat as points
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Save the model as GROUND.model

Designing A Building Interface

Fill in the list boxes as required.

Enter 50.0 into the Level Control box

Go to ‘EDIT > Add Strings with cursor’

Click on the right mouse button

Select ‘New > Polygon’

Draw a simple building 

When you are finished, click the right mouse button 

Select ‘Save string as interface’

Set the Fillet Radius to 0.15

Select OK

The option Move/Edit Alignment is automatically activated and the design can be moved about
the model until the correct amounts of cut and fill are indicated.
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The design can then be exported to a model and used for calculating volumes as before.

Export Design To A Model

Go to the ‘DESIGN > Export Design as a Model’

The dialog below will be displayed

Enter the relevant details

Select Ok to create the model

The model can be saved and volumes calculated between the design and the survey.

7.1 Simple Football Pitch Design

The following outlines designs steps with SCC to design a football football pitch (130m * 80m)
with 1:2 side slopes and in turn to balance cut and fill. Specific parameters may be changes
where appropriate to achieve the desired design
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Open Existing Data

Select ‘FILE > Open’

Open Project and Model

Construct Pitch 

Turn On Grid as show below so that we can snap to grid points when drawing in pitch

Select ‘VIEW > Titles & Grids’

Pick feature from the drop down menu ‘KERB’ or ‘PITCH’ for example

Set the DTM status as ‘Approx Elevation’

Turn snap grid on and Left click mouse at corner points of pitch

Right Click mouse, select 'Update string in model' to end string

With the grid points turned on the user can easily set out 130m*80m 
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Create Alignment String

We can use the alignment module to apply side slope to the pitch boundary string

Pick feature from the drop down menu ‘KERB’ or ‘PITCH’ for example

Set the DTM status as ‘DTM’

Set the elevation to 90 (In this instance, 90 is the average height)

Turn snap grid on and Left click mouse at corner points of pitch

Right Click mouse, select 'Save As Interface String'  

Set up the following:
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Revert to model

As can be seen in the model above, the pitch with 1:2 side slope does not currently fit
(bottom side slopes not shown).  We can manually move the alignment as follows:

Left click mouse on model, move cursor and a blue line will appear which will allow you to move
the alignment in the line direction.
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To check design parameters, select ‘DESIGN > Section Template’

Turn on side slope of 1:2 for left side (String was drawn in a clockwise direction so we want the
slope outside so therefore left must be selected)

Balance Cut & Fill

In order to allow the optimise cut and fill function to work the surface/model needs to be
larger.  

Draw in an arbitrary string around the field boundary at height of 90 for instance.

Pick feature from the drop down menu ‘0’ for example

Set the DTM status as ‘DTM’ and height of ‘90’ in the elevation box (circled in image below)

Left click mouse to place point 

Right click mouse to select ‘Update String in model’
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Select ‘DESIGN > Balance Cut and Fill’

Select ‘Ok’ to except default ‘Balance Cut and Fill’ settings

Remove arbitrary string (delete points command)

Export Design

Select ‘DESIGN > Interface & Export parameters

Set up the following and ensure that original model is set as the ground surface

Select ‘OK’
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Sections

To verify a design generate cross sections:

Within Design Model, select ‘SECTIONS > Long Section with Cursor’

Left click on first point of section and left click on last point

Right click to finish section

A good check is to also append the original surface:

Within the section, select ‘VOLUMES > Append Surface’

Pick original surface

See sample section below:
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7.2 River Section: Sections From A Bandwidth

The following tutorial outlines the steps to generate River Sections from a centreline using a
bandwidth.

‘Section From A Bandwidth’ method is typically used when creating river sections, where the
surveyed section line is greater than the actual river width.  The section is created using the

surveyed elevations snapped, at right angles, onto the user-defined centreline.

Open Existing Data

Open ‘RIVER.Project’ and ‘RIVER_Strung.Model’ from '\SCC\Tutorials'
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Creating Centreline Alignment

Select ‘DESIGN > Create Alignment from String’

Left click on centreline of river

Enter Alignment Name
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Generation of Sections

Select ‘SECTIONS > Sections from a Bandwidth’

Set the desired bandwidth ‘0.500’ for example

Set ‘Output survey feature names’ and ‘Use current alignment as cross section centre line’ as
outlined below:
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And secondly, all point within the set bandwidth are highlighted (in blue) for inclusion 

Right click mouse to produce Section 
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By reverting to the model view without dropping the ‘Sections from a bandwidth’ command,
that is, without selecting ‘Esc’, the user can move to the next cross section position and
create a section.

Select ‘FILE > Save As > River.Sections’
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Skew Angle

Skew Angle is the angle of deviation from the normal to the centre line, that is, a skew
angle of 0° implies that the cross section is at normal, right angle to the centre line.

A large skew angle means that the area of the cross section will be significantly larger than
the cross section area at the river at that point.

Dividing the offsets of the cross section (the width of the cross section) by the Cosine of the
skew angle may be used to normalise the cross section.

y = xCosA

Annotation of Skew Angle

Select ‘View > Scales, Titles & Grids’

Select ‘Add’ within the ‘Section Graph Titles’ Area

Within the Title Column, select ‘Skew Angle’ from drop down menu
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Attaching Sections

Select ‘FILE > Attach/Detach > Attach Section File’

Select ‘River.Sections’
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8 Reports Within SCC

SCC produces high quality reports from all SCC documents using the industry acclaimed Crystal
reports engine. These reports can include data, charts, bitmaps and other rich content, and can
be output to printers, PDF, Excel, HTML and Word files.

Sample reports are available within the SCC directory.  These templates can be used to
regenerate project specific report data directly from SCC. The Crystal reports also have the
advantages that they allow the report layout to be readily changed without affecting the content,
they allow automatic highlighting of out of spec values such that they can be easily picked up by
anyone reading the report, and they can be readily exported to a range of formats including
Word, PDF, Excel and HTML.

Note that while creation of new report formats requires a Crystal reports license, creation,
viewing, printing and export of reports is included within the SCC license. To view a report, click 
'FILE > Reports' and select sample report.
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Extract from sample files provides can be viewed below:

Sample Feature Library Report:
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Sample Traverse Report:
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Sample Check Survey Report:

9 Plotting From SCC

There are plotting facilities in SCC for creating and editing sheet layouts. These facilities work
with all Windows compatible plotters and printers, with full print preview.

Sheet layouts can be imported from DXF or created in SCC as a model file. This file can then be
added to the feature library within a project or attached to a model using the ‘Attach/Detach’
option under the ‘FILE’ menu. To create a new sheet template, go to ‘FILE > Sheet Layout >
Create new sheet template’ and select the paper size and orientation.
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Title blocks, legends and station co-ordinate boxes can be added to the template and it is then
saved to the current project file.

When you have added a title block to the sheet, a dialog will be displayed. This option allows the
user to add and design title blocks for a sheet template.

The box is positioned using the right mouse button; the first click should be used to position the
top left corner of the data box and the second click to denote the bottom right corner of the box. 
When the box is drawn the following dialog is presented:

Selecting one of the options on this dialog will determine the type of data displayed. The options
are as follows:

Empty Title Box 

This option allows the user to add an empty rectangular box to the sheet model, which can
be used for data entry, borders etc.

Grid 

When selecting this option, the user also needs to enter a value for the amount of rows or
columns required in the grid.  The grid may be used for entering data such as 'Project
Name', 'Scale' or 'Date' etc..

Feature Library Legend 

To select this option the user must enter a value in the rows box.  This value indicates the
total amount of feature library entries the user would like to display in the legend when the
sheet is inserted into the model.  This works by taking each entry in the model in sequential
record number and displaying the description and the linetype or symbol in the feature
library legend.  Features that are not used in the model, do not count.

Station Co-Ordinates 

The user must also enter a value in the rows box.  The value entered is the total amount of
station coordinates that the user wishes to display on the sheet, where STN 1 is the first
record number in the station coordinates spreadsheet.

The images below show how the station coordinate box appears both in the sheet template
and in the model.
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You can design the sheet template by adding your own company logo, the company feature
library and legend and also additional information about stations, bench level values and
location.

Below is a list of macros that can be used to create the sheet template. When the sheet is
inserted into a model or section these macros will be automatically updated with the
relevant job data, either from the operating system that is being used or from the data
entered into the ‘Titles & Grids’ dialog.

Sheet Creation Macros

Operating System
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[Name} Model / Section Name

[Path Full Model/Section path

[Project] Project Name

[Time] Current time

[Version SCC Version & Dongle Number

[Scale Plot Scale

[Page] Sheet Number

[Pages] Number of Pages

Titles & Grids Dialog

[ProjectTitle] Job Name / Title

[Client Client Name

[Date] Date

[Surveyor] Username

[Operator] Operator

See the images below for an example of how  the macros use the data entered in the ‘Titles
& Grids’ dialog. The first grid box displays the macros typed in sheet creation. The second
grid box show how the macros are used when inserted into the model.
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Create A New Sheet Layout

Start with a blank screen

Go to ‘FILE > Open’

Change FILES OF TYPE to ‘Project’

Select ‘Default.project’.

Go to ‘FILE > Sheet Layout > create New Sheet Template’

Select the paper size and orientation.

Select OK

Select OK to view the model

Remember,  when  creating  a  new sheet  template,  to  allow  enough  margin
space  to  accommodate  the  printer  rollers  on  your  selected  printer.  These
may vary across printers and though the sheet size will  be  correct,  it  may
stop the print process if the margin size is not large enough.

Saving The Template

To save the sheet template, go to ‘FILE > Sheet Layout > Save Sheet Template’

Enter a name for your sheet (it is good to contain the size of the sheet in the name)

Select Ok

Close the model

Go into the project file

Select ‘FILE > Save’

Save the project file
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Inserting Sheet Into Model

Once the template has been saved to a project file, any model created with this project will
store the new sheet in the feature library. This sheet can then be inserted into the model
and viewed either within the model view or by print preview. Remember, to view the layout in
print preview, you must have the correct sheet size selected in the print set-up!

Inserting the sheet into the model

Open the FGL. Model file

Go to ‘FILE > Sheet Layout > Insert Sheet’

Select the sheet you wish to insert, from the list

Set the correct orientation and plot scale

Note that the plot scale effects the size of the sheet relevant to the model.

Then drag the sheet and place it over the model

Pressing the left mouse button once will secure the sheet in position

Once the sheet is in the model, it can be rotated, moved and the plot scale changed. If
there is more than one sheet in the model, it is possible to view each sheet individually by
changing the view number in the control box on the Sheet Layout menu bar.

Sections

Once the sheet layouts have been saved to the feature library, these can then be used to
plot sections and profiles. The method of inserting sheets into section drawings differs
slightly from that of the model. Once a section has been generated, a sheet can be inserted
by going to the ‘VIEW’ menu and selecting ‘Section Sheet Layout’. You can then select the
sheet of your choice and also set the way in which you sections appear on the sheet.
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9.1 Creating Sheets in SCC

The following outlines the creation of a SCC Sheet Layout:

A.Set Up Project

Open a ‘New Project’ and attach the ‘Default(v7-0 Complex).Project’ template.

Call the project ‘Sheet’

B.Creating Sheet Layout

Go to 'FILE > Sheet Layout > Create Sheet'

A dialog is displayed with a selection of sheet sizes and orientations. Select a sheet.

A model of the selected sheet is generated. The user can add text to the title blocks,
creating an individual sheet style for the company. Symbols can also be added to the
models. These symbols can be created from dxf files and are especially useful for inserting
north arrows or company logos. See Symbols.

C.Save Model

Save the model 'FILE > Save As'

This means that the sheet can be edited at a later date and the previous template
overwritten.

D.Save Sheet Layout

To add the template to the feature library, go to 'FILE > Sheet Layout > Save Sheet Template’
and give the template a name. This template will be automatically saved to the current project
library.
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E.Export Sheet & Import Sheet into Default Project

In order to make this sheet available to use within other project, it is necessary to output
the sheet layout and import the file into the necessary project.

Go to ‘EDIT > Sheet Layout > Export Symbols to File’

Select ‘No’ to ‘Do you want to overwrite it’

The sheet can then be importing into the default library as follows:

Open Default Project

Select ‘EDIT > Symbols > Import Symbols from File’

Select Sheet Layout to import 

Select ‘Import’

9.2 Creating a SCC Sheet Layout From a DXF/DWG file

The following outlines the creation of an SCC Sheet Layout from a given dxf file.

A.Set Up Project

Open a ‘New Project’ and attach the ‘Default (v7-0 Complex).Project’ template.

Call the project ‘Sheet’

B.Model DXF Sheet

Go to ‘Model > DXF file’

Select ‘ATLAS_A1_4006.dwg’
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C.Creation of New Sheet Layout

Go to ‘File > Sheet Layout > Create a New Sheet Layout’ 

Select ‘ISO A1’ and enter the relevant border settings as follows:

To easily identify the sheet edge and the border (clipping frame) use the ‘Query and Edit’
function to change the colour of each.
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Go to ‘Atlas_A4_4006.Model’, right click to access ‘Data Selection Dialog Box’ and select ‘
Mark or clear all points in the model highlight all points
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Select ‘Edit > Copy to Clip Board’ 

Go to Sheet Layout ‘ISO A1’Model and select ‘Edit > Paste’

Note that the Sheet Edges coincide.

Delete the unnecessary Sheet Edge point (grey) leaving behind one Sheet Edge String
(magenta)

Where necessary use the string edit command, for example, Move Points, Trim, Extend

D.Adding Text & Text Macros

Text can be added to the Sheet Layout with the Text Tools

Either using the Text Toolbar or ‘EDIT > Text > Add Text’
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Text Macros are available within the ‘Add Text’ function

Select the Macro from the drop down menu

Select ‘Add’ and place the text in the required position
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E.Bitmaps

SCC bitmap option inserts a windows bitmap (.BMP) file into the model in a given location
and allows you to define its size and aspect ration.  This option can be used when creating

sheet layouts, where bitmap information, such as company logo, are required on the sheet.

Go to ‘EDIT > Bitmaps > Insert Bitmap’

Select bitmap using ‘>>’ option

The height and width can be defined within the window or manually on screen

The bitmap can be resized, moved and deleted using the commands within ‘EDIT > Bitmaps’



160

©2018 Atlas Computers Ltd

F.Save Sheet Layout

Go to ‘FILE > Sheet Layout > Save Sheet Layout’

Enter Sheet Name

G.Export Sheet & Import Sheet into Default Project

In order to make this sheet available to use within other project, it is necessary to output
the sheet layout and import the file into the necessary project.

Go to ‘EDIT > Sheet Layout > Export Symbols to File’

Select ‘No’ to ‘Do you want to overwrite it’

The sheet can then be importing into the default library as follows:

Open Default Project

Select ‘EDIT > Symbols > Import Symbols from File’

Select Sheet Layout to import 
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Select ‘Import’

H.Inserting Sheet Layout Within A Model

Within a Model, go to ‘FILE > Sheet Layout > Insert Sheet’

Select Sheet from list

Select Plot Scale and Insertion Method

Right click mouse to place sheet

Note: Rotation and Placement can be interactively choose on screen
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10 Transformations

SCC allows the user to create or edit a transformation from one co-ordinate system to another.
The transformation editor lets the user enter any number of co-ordinates in both systems and
calculates a transformation that will convert data between these systems.  

It is for example possible to take a survey where the control stations have been destroyed and by
surveying series of well-defined points of local detail, match up the common co-ordinates and
transform the newly established stations into the old survey grid system.

Likewise, it would be possible to transform from a local or assumed grid system into the National
Grid.  

It is advisable to take a large number of mutual points and to have these spread over the extent of
the survey.  The system uses a least squares best-fit technique so that a large number of points
may be used to provide the strongest transformation.

10.1 Performing A Transformation

In this specific example SCC uses an affine two-dimensional transformation with elevation datum
shift.  This transformation allows for rotation, translation and scaling in plan along with translation
of levels.  

Go into SCC.  

Go to 'FILE > New Project'.  

Call the project Transformation Tutorial and attach the project template Default.Project.

Go to 'FILE > Open'.  

Go to the directory '\SCC\Tutorials\'.  

At the bottom of the Open dialog and change the Files of Type to SCC Datasets (*.Survey) by
clicking the down arrow.  

Select the dataset 'Square.Survey'.  The Detail Co-ordinates window.

Go to 'TOOLS > Transform Co-ordinates'.

When you are creating a new transformation, just click on the New transformation option.  A
blank transformation spreadsheet is opened.
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Type in the co-ordinates of the points, which you know in both grid systems.

Insert a blank record for each point known in both co-ordinate systems.  

Go to 'EDIT > Insert Records'.  Insert 3 new records.

Type in the co-ordinates of the points in the first grid system (Ea/Xa,Na/Ya and Ht/Za) and then
their co-ordinates in the second grid system (Eb/Xb,Nb/Yb and Ht/Zb).
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Save the Transformation as 'SQ.Transformation'.

Close the transformation spreadsheet and returned to Detail Co-ordinates window.

Go to 'TOOLS >Transform Co-ordinates'.  

Pick the Transformation file 'SQ.Transformation'.  

Apply the transformation.
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When the transformation is performed a report is generated.  You will be asked whether or not
you wish to view this report.  Choose Yes to view the report .  The following report will be
presented in Wordpad  (or whichever Text Editor you have specified in the Directories and Files
section of the General Options.).

In the previous example, the points were known exactly in both co-ordinate systems therefore
there were no residuals listed in the report. 

SCC for Windows v7.8.11 (C) 1990 - 2005 Atlas Computers Ltd

   Transformation report

   Transformation name  SQ

   Date                 Wed Dec 06 09:24:02 2006

   Transformation parameters are

    a  = 0.000000

    b  = 2.000000

    c1 = 400.0000

    c2 = -500.0000

 Where  x' = ax - by + c1

        y' = bx + ay + c2

Pt   Name                 E/X(a)      N/Y(a)      E/X(b)      N/Y(b)     rE/X  

rN/Y

--   ----                 ------      ------      ------      ------     ----  

----

0    STNA                300.000     150.000     100.000     100.000   0.0000  

0.0000

0    STNB                400.000     150.000     100.000     300.000   0.0000  

0.0000

0    STNC                400.000     100.000     200.000     300.000   0.0000  
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0.0000

0    STND                300.000     100.000     200.000     100.000   0.0000  

0.0000

     Block shifting parameters

     (0,0) -> (400.00000,-500.00000)

     (0,1) -> (400.00000,-498.00000)

     (1,0) -> (398.00000,-500.00000)

     Block creation point 150.00000,200.000000

     Insertion point 0.00000,-200.000000

     Scale  = 2.00000

     Rotation = 090 00 00  (Counter Clockwise)

     Typical shift applied -150.00000,-400.00000

 In the following example the co-ordinates of the points were not known exactly in the second
system.  Apply the following changes to the transformation.

Save the transformation and then Apply it.  The following transformation report is generated.

Note the residuals at each of the Easting and Northings.  The residuals are differences between
the given co-ordinate values for the point and the co-ordinate values calculated using the
transformation parameters.

Calculating the residual at the Easting of point no.1.

SCC for Windows v7.8.11 (C) 1990 - 2005 Atlas Computers Ltd

   Transformation report

   Transformation name  SQ_2

   Date                 Wed Dec 06 09:33:10 2006

   Transformation parameters are

    a  = 0.003859

    b  = 1.998523

    c1 = 398.7149

    c2 = -499.9900

 Where  x' = ax - by + c1

        y' = bx + ay + c2

Pt   Name                 E/X(a)      N/Y(a)      E/X(b)      N/Y(b)     rE/X  

rN/Y

--   ----                 ------      ------      ------      ------     ----  

----

0    STNA                300.000     150.000      99.968      99.897   0.1262  

0.2489

0    STNB                400.000     150.000     101.010     300.000  -0.5299  -

0.0018

0    STNC                400.000     100.000     200.000     300.005   0.4063  -

0.2001

0    STND                300.000     100.000     200.023     100.000  -0.0026  -

0.0471

     Block shifting parameters

     (0,0) -> (398.71486,-499.98997)

     (0,1) -> (398.71872,-497.99145)
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     (1,0) -> (396.71634,-499.98611)

     Block creation point 150.25025,199.975575

     Insertion point -0.36109,-198.939574

     Scale  = 1.99853

     Rotation = 089 53 22  (Counter Clockwise)

     Typical shift applied -150.61134,-398.91515

Calculating the residuals of Easting of STND Point No. 4:
where x' = ax - by + c1

x'=200.023

a =0.003764

x =300.000

b =1.998714

y =100.000

c1=398.7721

x'= (0.003764 x 300.000) - (1.998714 x 100.000) + 398.7721

x'= 1.1292 - 199.8714 + 398.7721

x'= 200.0299

The difference between the computed (200.0299) and the given (200.023) answer is 0.0069,
which is displayed in the transformation spreadsheet as the residual (rE/X).

10.2 Applying A Transformation

If a drawing has been exported to CAD and subsequently requires transformation a block may be
made of the original drawing.  The block creation, insertion, scaling and rotation values given in
the report may be used to apply the transformation to a CAD drawing.

Note:

If a significant inappropriate scale, or large residual values, is generated, check your input data. 
If you have a large number of points in both systems, try replacing points with large residuals
with other matched points that are near to those points.

10.3 Transformation Report

Sample Tranformation Reports:

2D Affine:

SCC for Windows v7.8.11 (C) 1990 - 2005 Atlas Computers Ltd

   Transformation report

   Transformation name  SQ_2

   Date                 Wed Dec 06 09:38:21 2006

   Transformation parameters are

    a  = 0.003859

    b  = 1.998523

    c1 = 398.7149

    c2 = -499.9900

 Where  x' = ax - by + c1

        y' = bx + ay + c2

Pt   Name                 E/X(a)      N/Y(a)      E/X(b)      N/Y(b)     rE/X  

rN/Y

--   ----                 ------      ------      ------      ------     ----  

----
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0    STND                300.000     100.000     200.023     100.000  -0.0026  -

0.0471

0    STNC                400.000     100.000     200.000     300.005   0.4063  -

0.2000

0    STNB                400.000     150.000     101.010     300.000  -0.5299  -

0.0018

0    STNA                300.000     150.000      99.968      99.897   0.1262  

0.2489

     Block shifting parameters

     (0,0) -> (398.71486,-499.98997)

     (0,1) -> (398.71872,-497.99145)

     (1,0) -> (396.71634,-499.98611)

     Block creation point 150.25025,199.975575

     Insertion point -0.36109,-198.939574

     Scale  = 1.99853

     Rotation = 089 53 22  (Counter Clockwise)

     Typical shift applied -150.61134,-398.91515

SCC for Windows v7.8.11  7 Parameter Transformation report

No  Station  Obs     aX          aY        aZ         bX          bY        bZ 

  

--- -------- --- ----------- ----------- -------- ----------- -----------

-------- 

  0 STND       0     300.000     100.000   10.000     200.023     100.000  

20.000

  1 STNC       0     400.000     100.000   10.000     200.000     300.005  

25.000

  2 STNB       0     400.000     150.000   15.000     101.010     300.000  

30.000

  3 STNA       0     300.000     150.000   15.000      99.968      99.897  

25.000

Coordinate residuals

No  Station  Obs     dX          dY        dZ      dDist(2d)   dDist(3d)

--- -------- --- ----------- ----------- -------- ----------- -----------

  0 STND       0      0.1334      0.0846  -0.0173      0.1579      0.1589

  1 STNC       0      0.5918     -0.2313  -0.0228      0.6354      0.6358

  2 STNB       0     -0.6659     -0.1335   0.0173      0.6791      0.6793

  3 STNA       0     -0.0593      0.2802   0.0228      0.2864      0.2873

Shifts  X:399.345  Y:-499.168  Z:-5.081

Rotation X:002 49 53  Y:001 25 58  Z:089 52 30 

Scale:0.50061033

10.4 National Grid Transformations

Support has been added for national grid transformations between ITM, Irish Grid, OSGB36
and ETRS89.  These transformations utilise Grid Inquest software provided by Quest Geo
Solutions.
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11 Alignments

11.1 Entering & Importing Data Into An Alignment

The following briefly examines some of the features within SCC Alignment Module.

In short, SCC Alignment Modules allows for:

· the importing of alignment information from MX

· the importing of horizontal and vertical geometry information from MX 

· the importing of horizontal and vertical intersection points from DOER 

· the generation of intersection point information from the horizontal and vertical geometry 

11.1.1 Getting Alignment Data From MFW into SCC

Import MX GENIO Geometry strings

Set up Project

Open a ‘New Project’ and attach the ‘Default(v9-0-Complex).Project’ template.  

Call the project ‘Test Align’.

Import MX Alignment
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Open a blank Alignment file 

Go to ‘File > New > SCC Alignment’

A blank horizontal intersection sheet is opened.  The alignment information is
imported into this SCC alignment file.  

Go to ‘FILE > Import > MX GENIO Geometry strings’

Go to the Tutorials directory and select the GENIO file ‘SIMPLE.CRD’

This file contains horizontal and vertical geometry information.  

The 'Select Alignments' dialog allows the user to select a specific alignment
present in the input file

Select ' GAST' and 'OK'

The horizontal entities sheet is opened and the imported information displayed.
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Go to ‘VIEW > Vertical Entities’

Save the alignment as ‘GAST.ALIGNMENT’.

11.1.2 Attaching an Alignment To A Model

Create the MX Model

Go to ‘FILE > Model > MX GENIO file’. 

Select the file ‘GROUND.CRD’ from the TUTORIALS directory 

Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely and
GENIO L-string processing to ‘Treat as points’.

Select 'OK'

Set the Initial Plot Scale as '200'

Select 'Create the model and triangulation'
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Go to ‘File > Save’  

Save the model as ‘Ground.Model’

Attaching MX Alignment

Within the ground model, 'select 'FILE > Attach/Detach > Attach Alignment File'

Select ‘GAST.ALIGNMENT’
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11.1.3 Interactively Editing The Alignment

Within ‘SIMPLE.Alignment’, select ‘DESIGN > Move Alignment'

Click on alignment string with the left mouse button and interactively move the alignment.
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11.1.4 Typing Horizontal Intersection Points

Open 'FGL.Model' from the tutorials directory.

Horizontal Intersection Points

Go to ‘Design > Horizontal Alignment’ 

Call the new alignment ‘RoadDesign.Alignment’.
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The horizontal intersection point information is in a text file.  This text file, ‘HIPs.txt’ can be
found in the ‘\SCC\Tutorials\’ directory.  Open it in the  text editor and print it.

Horizontal Intersection Points

Transition Lengths

E/X N/Y Radius 1 Incoming Outgoing

193606.497 375687.288 0 0 0

193612.146 375437.006 400 100 100

193769.208 375136.441 300 100 100

194053.388 375030.792 0 0 0

There are 4 intersection points in this file.  The Easting, Northing, and chainage of each
point are defined along with the length of the radius and incoming and outgoing transitions. 

Set the Horizontal Design Action to ‘Add IPs’ 

Turn Off ‘Create Complex Curves’ option 

Type in the information for each of the four intersection points.

(E/X value, N/Y value, Radius 1, Incoming and Outgoing Transition Lengths) 

After each point is entered select ‘Add HIP’ at the bottom of the dialog to add the intersection
point to the alignment.

Select ‘Close’ after last intersection point

(By pressing the tab button, the cursor will jump to each entry box in order). 



177

©2018 Atlas Computers Ltd

To view the horizontal intersection points, 

Go to ‘Design >View design sheet’, then select ‘Horizontal Intersection Points’. 

Save the alignment as ‘RoadDesign.Alignment’

The finished horizontal alignment is shown in the diagram below.
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11.1.5 Typing Vertical Intersection Points

Before creating the vertical alignment, ensure that the horizontal alignment has been
created.

The vertical intersection point data can be found in the ‘\SCC\Tutorials’ directory. 

The file ‘VIPs.txt’ can be printed using Word or Notepad and contains all the necessary
information to define a vertical alignment.

Vertical Intersection Points

Chainage ElevationN/Y Length

0 15.00 0

245 17.00 100

422 23.00 100

734 25.00 100

872 24.00 0

Continuing from the Design above:

Select ‘RoadDesign.Alignment’ created in the earlier tutorial

From the model window, go to ‘DESIGN >Vertical Alignment’

On the top menu bar set the ‘V.E’ or ‘vertical exaggeration’ to 10
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Set the ‘Vertical Design Action’ to ‘Add IPs’

Select ‘Chainage’ as the ‘Horizontal Component’

Select ‘Elevation’ as the ‘Vertical Component’

Select the ‘Defaults>>’ option 

Ensure that the method is set to ‘length’

Enter ‘100.00’ as the default values  

Turn off the option to ‘use values entered in vertical design dialog’

Press ‘OK’

Select ‘Length’ as the ‘Curve Parameter’.

Type in the ‘Chainage’, ‘Elevation’ of each vertical intersection point

Select ‘Add VIP’ at the bottom of the dialog after each vertical intersection point
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The default length value of ‘100.00’ will be used to calculate the curve parameters.  

The finished vertical design is displayed in the diagram below.

11.1.6 Creating Mulit-Surface Section

Applying a Second Surface to a Section Template

Having designed a horizontal and vertical alignment and a standard section template, one
can now add additional surfaces to a section template.

Open the existing section template from the model ‘Design > Section template’

Select ‘New Surface’ from bottom of the side menu bar 

Set up the following surfaces:

45mm Hot Rolled Asphalt Wearing Course to cl. s905

55mm Dense Bitumen Macadam Base Course to cl. s902

120mm Dense Bitument Macadam Road Base to cl. s812

150mm Minimum Granular Material Type B Sub-Base to cl 804

Within Create New Surface dialog enter surface Name ‘c1 s804’

Set ‘000 Top Surface’ as Copy from Surface

Select ‘Do not copy Cut/Fill specific elements’

Accept default ‘From Left Offset’ and ‘To Right Offset’

Enter the relevant ‘Vertical Shift’

Select ‘OK’

Repeat the above steps for ‘c1 s902’, ‘c1 s812’ and ‘c1 905’

Use the Zoom Functions to see the additional new surfaces.
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11.2 Section Template Design On A MX Alignment

The following examines importing and modelling of MX GENIO strings into SCC.  In turn allowing
for the attachment of alignment data and subsequent section template design.  Long Sections
and Cross Sections are considered as a quality assurance means of examining the Section
Template.

MX GENIO Alignment

Opening Project

Select ‘FILE > Open’

Select ‘Genio-S.Project

Modeling MX GENIO File

Go to ‘FILE > Model > MX GENIO file’

Select the file ‘GENIO_DESIGN.txt’ 

Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely and
GENIO L-string processing to ‘Treat as points’.

Select ‘Create the model and triangulation’

Select ‘OK’
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Go to ‘FILE > Save As > GENIO_DESIGN.Model’

Taking MfW Geometry strings into SCC

Go to ‘FILE > New > SCC Alignment’

A blank horizontal intersection sheet is opened.  The alignment information is imported into
this SCC alignment file.  

Go to ‘FILE > Import > MX GENIO Geometry strings’
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Select the file ‘GENIO_DESIGN.txt’ 

Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely and
GENIO L-string processing to ‘Treat as points’.

Select 'GC52.Alignment'

Alignment files contain horizontal and vertical geometry information.  The horizontal entities
sheet is opened and the imported information displayed.
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Save As 'GC52.Alignment'.

Attaching an Alignment to a Model

Go to ‘GENIO_DESIGN.Model’

Select ‘FILE > Attach/Detach > Attach an alignment file’  

Select the alignment'GC52.Alignment

Note by holding the ‘Ctrl’ key allows the user to select several alignment files together 
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If we examine ‘GC52.Alignment’ note that the chainage system is available on the bottom
toolbar as the cursor is moved along the alignment.

The option to Move/Edit Alignment under the ‘Design Menu’ is automatically activated.  

Within ‘GENIO_DESIGN.Model’, select ‘DESIGN > Move Alignment'

Click on alignment string with the left mouse button and interactively move the alignment.
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Original Horizontal Entities

Automatically updated Horizontal Entities after Alignment was moved within Model

Typing in Section Template Points

The section template design for this tutorial is ‘SectionTemplate.Model’.
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It contains the width and cross fall of each element in the template

Revert back to ‘GENIO_DESIGN.Model’ which has the unedited ‘GC52.Alignment’ attached.

Go to ‘Design > Section Templates’.

Set the ‘Template Design Action’ to ‘Add Points’.

Set Apply to ‘Cut and Fill’

Set the ‘Horizontal Component’ to ‘Width’ and the ‘Vertical Component’ to ‘Gradient’.

Set the Units of measurement for gradients to Percentage %

Ensure that the ‘Unit for Gradients’ is set to ‘percentage %’ within ‘FILE >General Options >
Units and Data Checking’ section.

Centre Line:

Set the ‘Surface’ to ‘TopSurface’ and the Feature ‘CL’

Enter a value of ‘0.00’ for the ‘horizontal and vertical component.  

Leave the ‘interface side slopes’ turned ‘off’ 

Select ‘Add Point’

All horizontal components to the right of the centre line are positive, while all the horizontal
components to the left are negative.  

RHS001:

Select ‘Feature > RHS001’ 

Set the ‘width > 2.00’ and the ‘gradient > –3’.

‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

R-EDGE:

Select ‘Feature > R-EDGE’ 
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Set the ‘width > 1.00’ and the ‘gradient > –3’.

‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

LHS001:

Select ‘Feature > LHS001’ 

Set the ‘width > -2.00’ and the ‘gradient > –3’.

‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

L-EDGE:

Select ‘Feature > L-EDGE’ 

Set the ‘width > -1.00’ and the ‘gradient > –3’.

‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

The Section Template should be automatically updated within the Model ‘
GENIO_DESIGN.Model’ which has the alignment attached.

However, in this instance no such update take places.  Therefore further investigation of the
Vertical Alignment is necessary.

Within ‘GENIO_DESIGN.Model’ which has the ‘GC52.Alignment’ attached.

Go to ‘Design > Vertical Alignment’
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Select ‘DESIGN > Interface And Export Parameters…’

Set up the parameters as follows:

It is clear that one single Section Template is not satisfactory for this Road.  

As the Road incorporates a Bridge Crossing it is perhaps more feasible to have a Section
Template specifically for this area.  In other words a section template, which does not have
any side slopes.

Note also that from the contours one can deduce there is a need for string editing.  
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New Section Templates

Within ‘GENIO_DESIGN.Model’ place the cursor over the bridge edges in order to obtain
Chainage Values (bottom toolbar) to begin Second and Third Section Templates

Go to ‘Design > Section Templates’.

As before Set the ‘Template Design Action’ to ‘Add Points’.

Set Apply to ‘Cut and Fill’

Set the ‘Horizontal Component’ to ‘Width’ and the ‘Vertical Component’ to ‘Gradient’.

Set the Units of measurement for gradients to Percentage %

Select ‘New Surface’ from the bottom left of the screen

Enter the new template starting chainage ’48.00’

Unselect ‘Left Interface Side Slope’ and ‘Right Interface Side Slope’



191

©2018 Atlas Computers Ltd

Select ‘New Surface’ from the bottom left of the screen

Enter the new template starting chainage ’65.00’

Select ‘Left Interface Side Slope’ and ‘Right Interface Side Slope’ of 50%
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Once the section Template has been created further editing can be carried out with the
Design Sheet.

For instance, editing the starting chainage of a Section Template can be carried out as
follows:

Editing Section Template Points
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Within ‘GENIO_DESIGN.Model’ select ‘DESIGN > View Design Sheet > Section Template
Points’

Changing Section Template 2 starting point from 48.00 to 43.00:

Select ‘EDIT > Replace’

Within the Search Parameters, enter ‘Field to Search’ as ‘Chainage 1’

Enter existing value Lower and Upper Limit Values ’48.00’

Within the ‘Replacement Parameters’ enter the ‘Field to modify as ‘Chainage 1’

Enter ‘New Value’ as ‘43.00’4

The above commands are repeated to changing Section Template 3 starting point from
65.00 to 71.00:
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Applying a Second Surface to a Section Template

Having a horizontal and vertical alignment and a standard section template, the user can
now add additional surface to the section template.

The follow surfaces will be added to the Section Template:

45mm Hot Rolled Asphalt Wearing Course to cl. s905

55mm Dense Bitumen Macadam Base Course to cl. s902
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120mm Dense Bitument Macadam Road Base to cl. s812

150mm Minimum Granular Material Type B Sub-Base to cl 804

Revert to the 'Section Template Design'

Select 'New Surface'

Within Create New Surface dialog enter surface Name ‘c1 s804’

Set ‘000 Top Surface’ as Copy from Surface

Select ‘Do not copy Cut/Fill specific elements’

Accept default ‘From Left Offset’ and ‘To Right Offset’

Enter the relevant ‘Vertical Shift’

Select ‘OK’

Repeat the above steps for ‘c1 s902’, ‘c1 s812’ and ‘c1 905’
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Use the Zoom Functions to see the additional new surfaces.

Exporting Surfaces from Section Template

Surface created within a Section Template can be export as dataset or as model.

Within ‘GENIO_DESIGN.Model’ which has the ‘GC52.Alignment’ attached.

Select ‘DESIGN > Export design as model’

Set up the follow:
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Set ‘GENIO_DESIGN.Model’ as the ‘Existing Ground Surface’

Select surface from the ‘Design Surface to export’ Drop Down Menu

Save the Model

Repeat this step until all Surfaces are exported 

‘c1 804.Model’, ‘c1 s812.Model’, ‘c1s902.Model’ and ‘c1 s905.Model’

Sections

Sections can be used as a QA procedure when using the Section Templates.

Within ‘GENIO_DESIGN.Model’ which has the ‘GC52.Alignment’ attached.

Select ‘SECTIONS > Long Section by cursor’

Left click the model to select first point of section, left click the mouse to select end point and
right click mouse to finish.

A more extensive examination of surfaces can be carried out as follows:

Cross Section From Alignment

Within ‘GENIO_DESIGN.Model’ which has the alignment file attached.

Select ‘SECTIONS > Cross Section from An Alignment

Set up the following:

‘Save As > CrossSection GC52.Section’

Please note the Section Annotation and Scale can be assigned within ‘VIEW > Scale, Titles
& Grids’ and ‘VIEW > Annotation Settings’

Appending Surfaces to Sections

Within ‘CrossSection GC52.Section’ select ‘EDIT > Append Surface’

Select ‘c1 804.Model’, ‘c1 s812.Model’, ‘c1s902.Model’ and ‘c1 s905.Model’ by holding ‘Ctrl’
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Furthermore this allows for volumes by Cross Section to be carried out:

Volumes by Cross Section

Within ‘CrossSection GC52.Section’ select ‘EDIT > Volumes’

Enter a ‘Volume Report File’ ‘c1 s902.txt’

Select ‘Existing Surface’ ‘Top Surface’ and the ‘Proposed Surface’ ‘c1 s902’

Select to ‘Annotate Volumes’ and ‘Highlight Cut and Fill’

Select ‘OK’
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11.3 Getting Intersection Points from DOER

SCC can import alignment information from DOER (the Irish Department of Environment Road
Design package). 

11.3.1 Getting Horizontal Intersection Points from DOER

SCC imports horizontal and vertical intersection point information from DOER.  Intersection
point information may not be generated from geometric entities.

There is a DOER alignment file (BigRoad.A01) in the \SCC\Tutorials directory.  

Exporting Alignment from DOER

Copy this file from this directory into the DOER directory.

From DOS or from a DOS window in NT open DOER.

From the Opening Menu of DOER select the first option ;1 to DESIGN/edit/PRINT alignments,
ground or survey point data.
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The Opening menu of the Design Module is opened.  

Select option 2 to edit, process or print an existing alignment via menu “B”.

You will be required to select an existing DOER alignment file.  Select the file BigRoad.A01
from the current directory.
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Once the alignment has been selected the Main Menu for the alignment is opened.  Select
option 1 to setup/edit the horizontal alignment via Menu “E”.

Choose option 8 to write ALL horizontal alignment IP data to diskfile DOERHIP.DAT.

The DOER HIP file will be processed and saved in the DOER working directory.  Type in 99, to
return to the opening menu.
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Exit from DOER by again typing in 99.

Importing DOER Alignment into SCC

Set up Project

Open a ‘New Project’ and attach the ‘Default(v6).Project’ template.  

Call the project ‘DOER HIPS_VIPS’.

Import DOER Alignment
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Open a blank Alignment file 

Go to ‘FILE > New > SCC Alignment’

A blank horizontal intersection sheet is opened.  The alignment information is
imported into this SCC alignment file.  

From the File menu, select Import DOER HIPS.  

From the DOER directory select the file 'DOERHIP.dat'.  The data will be downloaded directly
into this spreadsheet.

11.3.2 Typing Section Template Points

Once a horizontal and vertical alignment has been created, it is then possible to design a
section template.

The section template design for this tutorial may be found as a DXF file in the
\SCC\Tutorials directory.  

Import the ‘Section Template.DXF’ file into SCC or CAD and print it.  

It contains the width and crossfall of each element in the template.

Revert back to ‘‘FGL.Model’ which has the unedited ‘RoadDesign.Alignment’ attached.

Go to ‘Design > Section Templates’.

Set the ‘Template Design Action’ to ‘Add Points’.

Set Apply to ‘Cut and Fill’
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Set the ‘Horizontal Component’ to ‘Width’ and the ‘Vertical Component’ to ‘Gradient’.

Set the Units of measurement for gradients to Percentage %

Ensure that the ‘Unit for Gradients’ is set to ‘percentage %’ within ‘FILE >General Options >
Units and Data Checking’ section

Centre Line:

Set the ‘Surface’ to ‘TopSurface’ and the Feature ‘CL’

Enter a value of ‘0.00’ for the ‘horizontal and vertical component.  

Leave the ‘interface side slopes’ turned ‘off’ 

Select ‘Add Point’

All horizontal components to the right of the centre line are positive, while all the horizontal
components to the left are negative.  

RHS001:

Select ‘Feature > RHS001’ 

Set the ‘width > 3.75’ and the ‘gradient > –3’.

‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

R-EDGE:

Select ‘Feature > R-EDGE’ 

Set the ‘width > 3.00’ and the ‘gradient > –3’.

‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

LHS001:

Select ‘Feature > LHS001’ 

Set the ‘width > -3.75’ and the ‘gradient > –3’.

‘Turn on’ ‘Left Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

L-EDGE:

Select ‘Feature > L-EDGE’ 

Set the ‘width > -3.00’ and the ‘gradient > –3’.

‘Turn on’ ‘Left Interface slope’ and set the ‘Gradient > 50%’.

Select ‘Add Point’

The following Section Template has been designed.
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The Section Template should be automatically updated within the Model ‘FGL.Model’ which
has the alignment attached.
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11.4 Designing A Fixed Gradient Interface

The following examines the creation of a design interface with 1:3 gradient for given pond data.

Consider that the ‘CL.Model’ contains the pond boundary (‘WATERLINE’ String) and subsequent
pond islands.

A design interface is required to produce a 1:3 gradient from the water edge (boundary string) to
the pond bed (96.1m).

Open Existing Files

Go to ‘FILE > Open’

Open ‘CL.Project’ and ‘CL.Model’

Create Pond Bed Model

Select ‘O’ from the Feature Drop Down Menu

Go to ‘EDIT > Add String with Cursor’ 

Set the Elevation to ’96.1’

Using ‘Snap Point’ draw a boundary string 

Right click mouse, select ‘Drape Coordinates on Surface’

Right click mouse, select ‘Update String in model’
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Select ‘Esc’ to unselect command

Right click mouse, to bring ‘Data Selection Dialog’

Select ‘All points on selected string’

Select ‘OK’

Left click on newly created ‘0’ string

Note selected points highlighted in blue, as shown above.

Go to ‘EDIT > Copy > Copy to New Model’

Save Model as ’96-1.Model’

This string will act as a guide boundary string

Select ‘O’ from the Feature Drop Down Menu

Select to draw a ‘Polygon’ from Toolbar

Draw a Polygon around the boundary string

Set the Elevation to ’96.1’

Right click mouse, select ‘Drape Coordinates on Surface’

Right click mouse, select ‘Update String in model’
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This creates a plan at the water level of 96.1 

Save Model

Create Alignment From Pond Boundary (Waterline String)

Within ‘CL.Model’, go to ‘DESIGN > Create Alignment from String’

Enter file name ‘Interface0008’ with a fillet radius of 1.000

Enter the desired gradient

Select ‘OK’

Left click mouse on pond boundary ‘WATERLINE’  string

Save Alignment

Go to ‘FILE > Attach/Detach > Edit/Detach > Detach All’

Select ‘OK’

Open ’96-1.Model’

Go to ‘FILE > Attach/Detach > Edit/Detach > Attach Alignment File’

Select ‘Interface0008.Alignment’
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Go to ‘DESIGN > Export design as model’

Select ‘Chainage Interval’ as 1.000

Select ‘Generate interface strings’, ‘Create boundary from interface string’ and ‘Create slope
signature strings (tadpoles)

Select ‘Design’ as the surface to export

Select ’96-1.Model’ as the existing ground surface using ‘Pick>>’

Set the ‘Chainage Range’ as ‘Entire Alignment’ 

Select ‘OK’

Save As ‘Design.Model’
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Once the design has been exported, tadpoles can be edited using ‘String Edit’ commands,
for example, Move Points, Delete Points

Merge Model

Open ‘CL.Model’

Go to ‘TOOLS > Merge two model

Using ‘Pick>>’ select the Survey and Design Model

Enter a name for Merged Model

Select ‘OK’
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Note:

Separate Designs should be carried out for the islands in the pond, if required.

12 Flow Lines

This functionality allows the user to generate and display flow lines associate sink points from
any 3d model.  A flow line is a line that follows the path of steepest descent from a given source
point until it either reaches a local low point or the edge of the model.   Source points for flow
lines can either be specified using a regular grid across the model, a coordinate file, or
interactively with the cursor.  In addition to generating the flow lines, SCC also identifies all the
confluence points between flow lines, and counts the number of sources meeting at each
junction and arriving at each sink point.  This is useful for identifying natural drainage across a
model and designing additional drainage.  An example of flow lines based on a regular grid of
source points is shown below;



212

©2018 Atlas Computers Ltd

Thinner lines illustrate simple flow lines connected to a source point, whereas lines of increasing
thickness show the confluence of multiple flow lines culminating in a sink point. Note that in this
example, slope vectors are also shown to illustrate the downhill direction.

If we zoom into a given sink point we will see it is annotated with an index and count of the
number of input flow lines arrive at this sink.

Flow line functions are available from the ZVI & Flow menu, and include the following options;

Flow lines with cursor This allows you to select flow line source points interactively
with the mouse

Flow lines from grid This creates a regular grid of flow line source points across
the entire model.

Flow lines from data set This creates flow line source points from a SCC coordinate
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file.

Flow line options This allows you to control the features used to control flow
lines based on the number of incoming flow lines.  It is also
used to specify the grid interval used when creating flow
lines from a grid, and control whether sink points are
annotated.

The flow line options are as follows;

Flow grid interval The grid interval used when creating flow line source points at
a regular interval.

Compute cumulative flows This controls whether the number of lines that pass through a
given point are counted.  This is required is compound flow
lines are to be drawn using different features, but is slower
when generating flow lines.

Local sink feature The feature code used to draw flow line sink points.

Annotate sinks This controls whether sink points are annotated with an index
number and counter.

Minimum line count to
display

Flow lines that have less than this number of input lines
passing through them will not be displayed.

Minimum sink count to
display

Sink points that have less than this number of input lines
reaching them will not be displayed

13 River Sections

The river sections module is designed to offer efficient stream-lined processing steps for surveyed
river data and provides for:

· simultaneous annotation and output of sections with offsets relative to the left most point of the
section, the lowest (or highest) point on the section, and the alignment centre line.

· data output to multiple modelling systems includes ISIS, MIKE, and HECRAS without having
to repeat processing of the sections

The river module functionality assumes that rivers are processed as a series of sections, which
can be collected as a single string per section or as discrete feature coded points.  The module
has been designed around the following criteria:

Ease of Use:SCC incorporates the principles river sections settings within a single dialog in
order to limit the number of processing steps required to generate each river section.  The single
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river section dialog allows for: 

· ground, water and silt surface names to be
defined easily

· sections generation either from points with
similar chainage or using surveyed strings

· section orientation based on surveyed end
points, best fit line through all points or normal
to a defined alignment

· section feature text to be defined as feature
name or remarks from the field

· section ID, left bank and right bank feature
name search options

· water and silt line search options which can be
used to annotation and/or display such
surfaces

· options to extend water and silt line surfaces
to the nearest banks automatically

· automatic surveyed section string direction
correction 

· quality controls, reporting and check options

· the selection of predefined cross section and
profile drawing styles

Flexible:

New Section Coding Table allows the user the flexibility to implement existing coding systems
currently in use in the field. 

Specific remark codes used in the field can be set up to allow for the automatic generation of
labels / text within the river sections.  

Importantly, left bank and right bank can be included to control the extent of the automatic
creation of water level and silt level surfaces on each river section.

Specific String Correction Options:

Automatic correction of string errors from the field provides time saving advantages during
processing. Options allow for the removal of loops from surveyed section strings and/or to set a
preferred string direction at a global level across all sections.

Simple River Centreline Definition:

An existing predefined river centreline or a new centreline reference string can be generated from
which a chainage / offset system can be created easily. The reference string controls section
orientation, section annotation on individual sections and within plan drawings and acts as an
integral part of the required output to modelling systems. 

Automatic Water and Silt Surface:

Search options provide for the extraction of water and silt levels which can be used to extrapolate
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water edges, silt edges and the ground profile.

Annotation of water and silt levels can be automatically set up and applied to all sections
together with date and time stamp.

Global Section Text Annotation:

Section Annotation can be globally applied to all sections offering time saving advantages and
limiting user errors.

Text can be customised to suit deliverables. 

Simple Drawing Style Applications:

Section presentation can be customised to meet client needs and applied globally with the
application of a drawing style reducing repetitive steps and ensuring continuity throughout a large
project.

Advanced Quality Checks & Reporting:

Quality assurance checks provide invaluable tools to support consistent qualitative section files
and subsequent exported deliverables.  Search options for missing text within each section detail
missing text elements whilst survey errors are reported for review and correction.  Output of water
levels differences by chainage offers further checks for blunders and gross errors. 

Structure Display on Sections:

Surveyed structures can be easily selected from plan and attached to individual sections to meet
specification using simple copy and paste tools.  

Specific annotation and text can be inserted manually allowing for customisations.

Advanced Output of Sections to Multiple Modelling Systems:

Sections can be easily output to modelling systems includes ISIS, MIKE, and HECRAS in a
single step.  

13.1 Creating Project

A new project should be created before data may be downloaded into SCC or models
formed.

SCC  button, select 'Open’

Go to \SCC\Tutorials\River_Survey\River_Sections.Project 

Select ‘OK’

Note: 'River_Sections.Project' template has been set up to demonstrate the river section
functionality.

Feature Library

Select 'DATA tab > Features button'

Specific feature codes have been set up in the library which coincide with codes used in the
field.
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Section Coding

Select 'DATA tab > Features drop down button > Edit Section Coding'

In this instance, specific remark codes used in the field have been set up to allow for the
automatic generation of labels / text within the river sections.  Importantly, left bank and
right bank have been included to control the extent of the automatic creation of water level
and silt level surfaces but also required for HECRAS, ISIS and MIKE formats.

It should be noted that the 'Type' column controls the placement of text on a section /
profile:

· Default - places text as a descender on the section

· Surface - places text on the surface line of the section

· Water - used to annotation the water surface within a section

13.2 Creating River Centreline Model

In order to generate the river section it is necessary to have a defined river centreline.  The
centreline can be generated within SCC using string creation tools or can be input from a
CAD, ASCII or MX file.

SCC  button, select 'Open’

Go to '\SCC\Tutorials\River_Survey\RiverCentreline.Model'
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13.3 River Centreline Alignment

The river section functionality requires a horizontal alignment representing the river centre
line and hence a full SCC design license.   Alignments can be created as follows;

Creating Alignment from existing string

Within 'RiverCentreline.Model', 'DESIGN tab > String button'

Left click on string and enter the following:

Click 'Ok'

Chainage and offset system is generated and is visible on the base toolbar on the bottom of the
screen

To save alignment, select 'DESIGN tab > View drop down button > Horizontal Entities'

Within the Horizontal Entities sheet, pick SCC button 'Save As' and enter name

'RC.Alignment' is a sample alignment file for use within this tutorial.
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Creating Alignment from CAD file or MX file

Existing alignments can be imported as follows:

Imported from a design or CAD package, 'DATA tab > New button drop down > New document >
SCC Alignment'

Go to 'DATA tab > Import drop down > MOSS GENIO geometry strings', or 'DATA tab > Import
drop down >  Entities from DXF'

or 'DATA tab > Import drop down >  LandXML'

13.4 Examination of Dataset

This tutorial provides a sample model.  However, it is important to consider on downloading
the raw file, the dataset should be examined to ensure attribute and text information has
been downloaded correctly.  For instance, checks should be carried out to ensure that
specific section codes surveyed in the field have been downloaded in the Text Notes Sheet
and match the codes set up within the Section Coding table, part of the Project file. 

Concatenate Multiple Remarks

It should be noted that SCC can concatenate multiple remarks on the same survey point
using the Concatenate multiple remarks tool.  For example, observation 123 has two
remarks noted as WALL and STONE within the text notes sheet.  To concatenate the
multiple text after download:

Select 'DATA tab > Settings drop down >  Coordinate Reduction Options'

Tick Concatenate Multiple Remarks and Press 'OK'
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If changes have been made to the dataset, go to 'SURVEY tab > Obs drop down button > Rebuild
Coordinates'

Multiple remarks are text concatenated as shown below:

Note that the feature field on sections is limited to a total of 16 characters.

13.5 Creating Surveyed Section Data Model

The dataset containing the surveyed sections is model as follows:

SCC  button, select 'Open’

Go to '\SCC\Tutorials\River_Survey\River_Section_Sample.Model'
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13.6 Attaching River Centreline Alignment to Survey Model

Prior to creating the river section the alignment file should be attached to the surveyed data
model:

Go to 'DESIGN tab > Attach drop down > Alignment'

Pick river centreline alignment file

13.7 Setting Preferred String Direction

If the sections have been surveyed as strings, they can be re-aligned to match the centre
line direction using 'TOOLS tab > Tools drop down > Set preferred string direction', although
this is not necessary for the river sections to be created.
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This option can be run directly from the River Sections dialog using 'Correct reversed
strings'.

13.8 River Section Creation

Before creating the river sections, it is necessary to select all section data.  For example, if
one or more feature names have been used the data selection dialog with 'All similar strings
(Same feature)' option selected should be selected.

Within 'River_Section.Model' with the alignment attached, right click the mouse to bring up
the 'Data Selection Dialog'

Pick 'All similar strings (Same feature)' and left click 'SURFACE' feature

Note that data that is not representative of the ground surface, such as water levels and any
structures surveyed, should not be selected.  As such, selecting all points in the model will
typically not be appropriate when using this option.  To create river sections:

'ANALYSIS > River button', set up the following options:
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Specific settings are outlined as follows:

Surface Name for ground surface

This is the name displayed on the section title block for the profile line associated with the
main ground surface.

Surface name for water surface

This is the name displayed on the section title block for the profile line associated with the
water level and extrapolated water surface.

Create sections using points with similar chainage

This option is used when points on surveyed river sections are not collected as strings
defining the section line.  In this case, all points within a specified chainage range are
grouped to form a section, and the points on each section are sorted by offset from the river
centre line.  This option has the advantage that it allows the user to collect feature names in
the field, e.g. TOPBANK, BOTBANK, etc.. which will automatically be annotated on the
section.  It has the disadvantage that section lines should not overlap, as points may get
placed on the wrong section.

Maximum chainage difference between points

This option is the maximum chainage separation allowed between points for them to be
placed on the same section.  For example, a value of 2m would indicate that all points on a
section must be within a 2 meter chainage of one another.  Note that for skew sections, i.e.
sections not perpendicular to the centre line, this value should be increased to allow for the
skewing effect.  This value should never be greater than half the distance between adjacent
section, e.g. if your sections are 10m apart, this value should not exceed 5.  
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Create sections using surveyed strings

This option should be used where sections have been collected as complete strings.  It has
the advantage that sections can overlap, which can be useful on sharp changes of direction
and small radii in the river centre line.

String corrections

These only apply where the above option has been selected, and relate to automatic
correction of certain survey errors.

Leave strings as surveyed 

Do not make any corrections.

Re-string sections based on offset from centre line

This option re-orders the points in the string based on their offset from the centre-line.  This
will correct any overlaps, loops and doubling back in the section.

Remove loops from sections

This option removes any loops that occur in plan in the section.

Section Orientation

These options refers to how the section centre lines are formed from the surveyed points for
a given section, which due to the natural constraints of river surveying, will rarely form an
exact straight line.  

Skew, based on surveyed end points

The section centre line is formed by joining the leftmost and rightmost survey points.  The
survey points are then snapped onto this line when forming the section.  This line will
typically not be at exact right angles to the river centre line.

Skew, based on best fit line through all points

The section centre line is formed by creating a best fit line through all the survey points. 
The survey points are then snapped onto this line when forming the section.  This line will
typically not be at exact right angles to the river centre line.

Normal to alignment, based on mean chainage

The section centre line is formed by computing a mean chainage from all the survey points,
and going at right angles to the left and right of centre-line at that chainage to meet the
leftmost and rightmost offsets of the survey points. The survey points are then snapped onto
this line when forming the section.  This line will be at exact right angles to the river centre
line.  Note that if the surveyed section is not roughly at right angles to river centre line,
points are liable to be moved significant distances when snapped onto the centre line, and
the section line may be significantly shorter than the surveyed line.

Use Alignment for section offsets

The sections are formed using the offset value of the alignment.

Section Feature Text

This controls how the feature name field in the sections is populated.
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Use feature name

Use the feature name as entered in the survey.

Use remark 

Use the remark from the associated survey observation.  This is useful when surveying
sections as strings, where all the points on the section have the same feature name for
stringing purposes, but may refer to different items on the section, e.g. Top of bank, edge of
water, etc…

Water line

This group of options refer to the extraction of water level points and extrapolation of a water
surface in the sections produced.  Typically this will be a single water level point per section
where the water surface is being automatically extracted, or a string where water surface
has been surveyed directly.

Search for water level near section

Select this option to search for water level points near the surveyed section.

Water level feature

This is the unique feature name, e.g. WLEV, used to denote water levels.

Extend water level on section to nearest bank

When a single water level has been surveyed per section, this option will extend the level
left and right from the surveyed point to the ground profile on the section to form a water
surface.

Silt line

This group of options refer to the extraction of silt level points and extrapolation of a silt
surface in the sections produced.  Typically this will be a several silt level points per section
where the silt surface is being automatically extracted, or a string where silt surface has
been surveyed directly.

Search for silt level near section

Select this option to search for silt level points near the surveyed section.

Silt level feature

This is the unique feature name, e.g. SILT, used to denote silt levels.

Extend silt level on section to nearest bank

When silt level points have been surveyed per section, this option will extend the levels left
and right from the surveyed point to the ground profile on the section to form a silt surface.

Search distance for IDs, water and silt levels

This is the maximum allowable distance from the IDs, water and silt levels to the section it
will be placed on.

Section ID feature

Section ID picked up the field are extracted and used to label individual sections.
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Section Type feature

Section Type picked up in the field are extracted and used for annotation and export
purposes.

Left Bank Feature

Left Bank feature is used for annotation and export purpose.  It is also used to control the
extent of the Water and Silt level surfaces.

Right Bank Feature

Right Bank feature is used for annotation and export purpose.  It is also used to control the
extent of the Water and Silt level surfaces.

Search all text in model for missing IDs and types

This quality check examines each section for missing IDs and types.  Errors are reported in
a text file.

Check and report for survey errors in sections

This quality check examines each section for survey errors.  Errors are reported in a text
file.

Correct reversed sections

This option re-aligned sections to match the centre line direction.  This option overcomes
issues relating to section having been surveyed in a 'zig-zag' fashion and also address
problems arising from left and right bank being incorrectly surveyed.

Report water level differences by chainage

This quality check option allows the water level difference to be reported based on chainage
values.

Cross Section drawing style

This option allows the user to select a predefined section style.

Profile drawing style 

This option allows the user to select a predefined section style.

Feature >>

This option links to the Extended Field Code table.

The cross section and profiles are generated as shown below:
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Cross Sections:
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Profile:

13.9 Displaying Structure On Sections

Structures and other detail can be copied from plan into section as shown below:

Select the required points to copy onto a given section using the data selection tools

Select 'EDIT > Copy > Copy to clipboard'

Switch to your section view
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Select 'EDIT > Paste'

When prompted enter the surface name that the data will be associated with, e.g. structures, and
whether or not the points will be annotated. 

Click on the section you would like the data drawn on.

Note that data copied from plan to section in this manner is projected onto the section. 
Therefore if a line is copied that is not parallel to the section from plan, it will appear shorter
in the section as it is the projected distance on view.  The active alignment can be used to
match offsets between plan and section where required, if not, the distance from the
leftmost edge of the section will be used.
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13.10 River Section Annotation

Section Annotation can be controlled within 'VIEW tab > Descender':

Specific settings can be selected within the Type drop down menu to suit the required
output.
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13.11 River Section Scale Titles & Grids

The following notes common annotator for river section.  Such annotator can be selected
from 'VIEW tab > Titles button'

Chainage

The alignment chainage at the point where the river section, i.e best fit line through the
survey points, cuts the alignment centre line.

River Chainage

The alignment chainage at the point where the surveyed section string cuts the alignment
centre line

Diff Ch

The difference in chainage between this section and the next section (e.g. chainage value
used in ISIS output)

Offset

The distance on the section from the leftmost point.  Note that river sections are always
displayed such that the left bank is on the left of the right bank regardless of the alignment
direction or order in which the section string was surveyed.  These values are always
positive and always start from zero.

River offset 

The distance from the current point on the section to the lowest point in the river bed, which
is calculated as the point of lowest elevation between the left and right banks.  Points to the
left of the lowest point in the river bed have negative offsets, whereas those to the right have
positive offsets.

Skew angle 

The angle at which the section deviates from the alignment normal.  

13.12 Editing Sections Using Query & Edit Function

Sections can be manually edited using the 'EDIT tab > 'Query button'.  This allows the user
to set bank positions, and ISIS / MIKE & HECRAS specific values within any given section
and to correct survey errors.  

For example, specific users may require the option to define the lowest point between
banks on a specific section at processing stages.
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13.13 Exporting to Modelling Packages: ISIS, MIKE and HECRAS

To export data:

Go to 'DATA tab > Export drop down button' and select export format

HEC-RAS

BEGIN STREAM NETWORK:

  ENDPOINT: 11755.013,10465.386,0.000,1
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  ENDPOINT: 11767.636,10212.144,0.000,2

REACH:
  STREAM Id: River_Section_Sample (River sections)

  REACH Id: Reach 1
  FROM POINT: 1
  TO POINT: 2
  CENTERLINE:
    11755.013,10465.386
    11534.492,10066.627
    11909.390,10161.459
    11828.978,10191.503
    11767.636,10212.144
  END:
END STREAM NETWORK:
BEGIN CROSS-SECTIONS:

CROSS-SECTION:
  STREAM ID: River_Section_Sample (River sections)
  REACH ID: Reach 1
  STATION: 0.000
  BANK POSITIONS:  0.341,0.351
  CUT LINE:
    11561.147,9726.411
    11948.879,11204.361
  SURFACE LINE:
       11561.147,    9726.411,    72.681
       11563.967,    9737.158,    72.397
       11566.441,    9746.592,    71.924
       11568.995,    9756.324,    71.616
       11571.392,    9765.463,    71.246
       11573.691,    9774.226,    71.088
       11576.402,    9784.561,    71.129
       11578.921,    9794.161,    71.132
       11581.472,    9803.885,    71.176
       11583.843,    9812.923,    71.254
       11586.344,    9822.457,    71.204
       11588.795,    9831.798,    71.034
       11591.409,    9841.761,    71.015
       11593.867,    9851.132,    70.816
       11596.305,    9860.426,    70.542
       11598.788,    9869.891,    70.612
       11601.506,    9880.251,    70.509
       11604.352,    9891.098,    70.350
.........

END   CROSS-SECTIONS:

ISIS

River_Section_Sample (River sections)
#REVISION#1
         5     0.750     0.900     0.100     0.001        12
    20.000     0.010     0.010     0.700     0.100     0.700     0.000
RAD FILE



233

©2018 Atlas Computers Ltd

END GENERAL
COMMENT
0
RIVER [VTX]
SECTION
10:00:00 2011-09-09
     0.000              0.0001
       175
     0.000    72.681     0.060     1.000            11561.15   9726.41
    11.111    72.397     0.060     1.000            11563.97   9737.16
    20.864    71.924     0.060     1.000            11566.44   9746.59
    30.925    71.616     0.060     1.000            11568.99   9756.32
    40.374    71.246     0.060     1.000            11571.39   9765.46
    49.434    71.088     0.060     1.000            11573.69   9774.23
    60.118    71.129     0.060     1.000            11576.40   9784.56
    70.044    71.132     0.060     1.000            11578.92   9794.16
    80.096    71.176     0.060     1.000            11581.47   9803.89
    89.440    71.254     0.060     1.000            11583.84   9812.92
    99.297    71.204     0.060     1.000            11586.34   9822.46
   108.954    71.034     0.060     1.000            11588.79   9831.80
   119.254    71.015     0.060     1.000            11591.41   9841.76
   128.941    70.816     0.060     1.000            11593.87   9851.13
   138.550    70.542     0.060     1.000            11596.31   9860.43
   148.336    70.612     0.060     1.000            11598.79   9869.89
   159.047    70.509     0.060     1.000            11601.51   9880.25
   170.261    70.350     0.060     1.000            11604.35   9891.10
   179.585    70.266     0.060     1.000            11606.72   9900.12
   182.300    70.203     0.060     1.000            11607.41   9902.74
   184.773    70.556     0.060     1.000            11608.03   9905.14
   186.689    70.598     0.060     1.000            11608.52   9906.99
   197.906    70.169     0.060     1.000            11611.37   9917.84
   210.304    69.970     0.060     1.000            11614.51   9929.83
   224.846    69.930     0.060     1.000            11618.20   9943.90
   245.081    69.969     0.060     1.000            11623.34   9963.47
   260.986    69.956     0.060     1.000            11627.37   9978.85
   273.086    70.223     0.060     1.000            11630.44   9990.56
   284.540    70.240     0.060     1.000            11633.35  10001.64
   295.899    70.253     0.060     1.000            11636.23  10012.62
   305.817    70.147     0.060     1.000            11638.75  10022.22
   316.464    70.066     0.060     1.000            11641.45  10032.52
   327.493    70.064     0.060     1.000            11644.25  10043.18
   338.876    70.058     0.060     1.000            11647.14  10054.19
   349.581    69.904     0.060     1.000            11649.86  10064.55
   360.443    69.990     0.060     1.000            11652.61  10075.06
   370.113    69.984     0.060     1.000            11655.07  10084.41
   380.416    69.885     0.060     1.000            11657.68  10094.37
   391.959    69.892     0.060     1.000            11660.61  10105.54
   402.808    70.217     0.060     1.000            11663.36  10116.03
   413.339    70.461     0.060     1.000            11666.03  10126.22
   426.395    70.087     0.060     1.000            11669.35  10138.85
   438.595    69.909     0.060     1.000            11672.44  10150.65
   449.370    69.705     0.060     1.000            11675.18  10161.07
   458.598    69.650     0.060     1.000            11677.52  10170.00
   461.879    69.629     0.060     1.000            11678.35  10173.17
   461.942    69.626     0.060     1.000            11678.37  10173.23
   467.823    69.740     0.060     1.000            11679.86  10178.92
   480.240    69.537     0.060     1.000            11683.01  10190.93
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   480.300    69.542     0.060     1.000            11683.03  10190.99
   494.073    69.588     0.060     1.000            11686.52  10204.31
   500.383    69.825     0.060     1.000            11688.12  10210.42
   505.572    70.214     0.060     1.000            11689.44  10215.43
   510.106    70.580     0.060     1.000            11690.59  10219.82
   514.510    70.764     0.060     1.000            11691.71  10224.08
   518.624    70.701     0.060     1.000            11692.75  10228.06
   519.500    70.619     0.060     1.000            11692.97  10228.91
   520.462    70.578     0.040*    1.000LEFT        11693.22  10229.84
   521.208    70.448     0.040     1.000            11693.41  10230.56
   521.830    70.206     0.040     1.000            11693.57  10231.16
   522.891    69.554     0.040     1.000            11693.83  10232.19
   523.734    69.268     0.040     1.000            11694.05  10233.00
   524.297    68.702     0.040     1.000            11694.19  10233.55
   525.189    67.409     0.040     1.000            11694.42  10234.41
   526.726    66.910     0.040     1.000            11694.81  10235.90
   528.660    66.972     0.040     1.000            11695.30  10237.77
   530.829    67.304     0.040     1.000            11695.85  10239.86
   532.337    67.828     0.040     1.000            11696.23  10241.32
   533.681    68.119     0.040     1.000            11696.57  10242.62
   534.604    68.574     0.040     1.000            11696.81  10243.52
   536.045    69.934     0.040     1.000            11697.17  10244.91
   536.780    70.030     0.060*    1.000RIGHT       11697.36  10245.62
   538.266    70.013     0.060     1.000            11697.74  10247.06
   539.823    69.939     0.060     1.000            11698.13  10248.56
   540.979    70.420     0.060     1.000            11698.42  10249.68
   544.788    71.830     0.060     1.000            11699.39  10253.37
   547.940    71.198     0.060     1.000            11700.19  10256.42
   549.442    70.649     0.060     1.000            11700.57  10257.87
   550.911    70.173     0.060     1.000            11700.94  10259.29
   551.918    69.765     0.060     1.000            11701.20  10260.26
   554.661    69.715     0.060     1.000            11701.90  10262.92
........

INITIAL CONDITIONS
 label   ?      flow     stage froude no  velocity     umode    ustate
       z
10:00:00 2011-09-09 y     0.000     0.000     0.000     0.000    
0.000     0.000     0.000
123456       y     0.000     0.000     0.000     0.000     0.000    
0.000     0.000
13123        y     0.000     0.000     0.000     0.000     0.000    
0.000     0.000
123456       y     0.000     0.000     0.000     0.000     0.000    
0.000     0.000
10:00:00 2011-09-09 y     0.000     0.000     0.000     0.000    
0.000     0.000     0.000

MIKE

River_Section_Sample (River sections)
River_Section_Sample (River sections)
               0.000
COORDINATES
    0
FLOW DIRECTION
    0      
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DATUM
      0.00
RADIUS TYPE
    2
DIVIDE X-Section
0
SECTION ID
10:00:00 2011-09-09
INTERPOLATED
    0
ANGLE
    0.00   0
RESISTANCE NUMBERS
   2  1     1.000     1.000     1.000    1.000    1.000
PROFILE        175
 -526.726    72.681     0.060     <#0>
 -515.614    72.397     0.060     <#0>
 -505.861    71.924     0.060     <#0>
 -495.800    71.616     0.060     <#0>
 -486.351    71.246     0.060     <#0>
 -477.292    71.088     0.060     <#0>
 -466.608    71.129     0.060     <#0>
 -456.682    71.132     0.060     <#0>
 -446.629    71.176     0.060     <#0>
 -437.286    71.254     0.060     <#0>
 -427.429    71.204     0.060     <#0>
 -417.772    71.034     0.060     <#0>
 -407.471    71.015     0.060     <#0>
 -397.784    70.816     0.060     <#0>
 -388.175    70.542     0.060     <#0>
 -378.390    70.612     0.060     <#0>
 -367.679    70.509     0.060     <#0>
 -356.465    70.350     0.060     <#0>
 -347.140    70.266     0.060     <#0>
 -344.426    70.203     0.060     <#0>
 -341.952    70.556     0.060     <#0>
 -340.037    70.598     0.060     <#0>
 -328.820    70.169     0.060     <#0>
 -316.422    69.970     0.060     <#0>
 -301.880    69.930     0.060     <#0>
 -281.645    69.969     0.060     <#0>
......

13.14 Exporting Text To GIS Attributes: Shape Files

River IDs can be converted into GIS attributes which can be exported to shape files.  The
steps to do this are as follows;

Set up your GIS layer for features which are required for export, for example, set the GIS layer
for SURFACE to RIVERS.

Process the river sections as normal

Select all river sections and all ID points

'ANNOTATION tab > Tools drop down > Copy text to GIS attributes' 
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Go to 'DATA tab > Export drop down button > Shape File'

13.15 River Section Displayed on Model

To display the position of section lines in plan:

In the model, go to 'DESIGN tab > Attach drop down button >  Section' and pick saved section.  

Chainage can be annotated in plan by modifying the Chainage annotator on the ‘~SECT_T’
feature.

Go to 'VIEW tab > List button' 

Pick ‘~SECT_T'

Press 'Edit Feature>>'

Press 'Text Annotation>>'

Set the value of Display, Remark and Chainage to Text On.  

Alternatively, this can be set up in your feature library template, such that it is the default
behaviour when attaching sections.
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14 Blunder Detection And Analysis

SCC supports blunder detection and analysis in traverses and networks.  This works in three
stages as follows;

· Observed values, including angles and distances, are compared to computed values between
known stations.  For example, where you have an observed distance between two known
stations, and a join distance computed from coordinates between the same stations, a
difference in distance is calculated.  If this difference exceeds a user defined tolerance a
measurement blunder is considered to have occurred.
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· Multiple observed values, including angles and distances, are compared for similarity.  This
could be the same observation, for example two observations from STNA to STNB, or a reverse
observation, for example one from STNA to STNB and the other from STNB to STNA.  Where
differences between similar observations exceed a user defined tolerance a measurement
blunder is considered to have occurred.

· Provisional values for unknown stations are computed, and differences between observed
values and computed values are calculated for these provisional stations.

Where blunders are detected, you have three options to deal with how they are processed as
follows;

· Take no action, simply highlight the blunder observations such that they can be edited
manually.

· Mark the blunder observations to be excluded from the adjustment.  In the case of networks or
traverses with significant redundancy, this allows for the adjustment to be completed with
minimal editing required.

· Rename the sighted station using a suffix, such that you will have multiple adjusted station
values for blunder observations, e.g STNA, STNA(1), STNA(2), etc...  This can be useful in
situations where the sighted station name has inadvertently been re-used for more than one
physical station.  

There is also an option to automatically correct probable station naming errors, which account for
a large proportion of typical blunders.  This is done by comparing similar observations for a likely
match, and failing that, calculating a provisional coordinate for the sighted station and comparing
it to known stations.

The blunder analysis routines are available in the traverse observation view, under Edit / Blunder
detection.  The parameters are as described above, and on running the blunder detection and
analysis, you’ll be given the option to view a detailed report of the results.
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The report is broken down into a summary, comparison between observations and known
coordinates, comparisons between similar observations, and comparison between
observations and computed provisional coordinates.
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Where the option to fix station naming errors has been selected, fixed observations will be
highlighted in green.  In all other cases, the differences will be written back to the traverse
observation sheet in the residual columns, and the traverse observation sheet layout will be
changed to show these values.

Pressing F4 in this view moves you to the next blunder detected, and pressing F5 brings you
back to the default observation layout and may be used to cycle through other layouts.  Note that
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each stage of the blunder detection and analysis clears down the residual values, so if you wish
the view the results from any given stage, maek sure that subsequent stages are not enabled.

The blunder detection also checks that provisional values can be calculated for all sighted
stations.  If this is the case, it should be possible to successfully adjust the traverse, although
careful attention should be paid to the output report, as a significant amount of information may
have been removed.  

When updating the station coordinates, you now also have the option to store the resultant
stations as free, provisional, or fixed.  This is useful when working with a traverse spanning
multiple jobs, where you wish to carry out the blunder analysis seperately on each job, but need
to carry coordinates between jobs in order to be able compute the results.  The traverse report
now also details how each provisional coordinate was computed, which can be either by direct
trigonometry, resection, or intersecting rays.

An additional option to use high performance matrix processing libraries for working with very
large networks is available.  This is available under File / General options / Use high performance
matrix libraries.  Note that for very large networks, memory is also likely to be a limitation, as
calculation involves matrices based on the square of the size of the number of observations. 
Thus 8,000 total station sightings would give us 8000 distances and a slightly smaller number of
angles, resulting in matrix sizes of ~ 15,000 x 15,000 or ~1.8gb of memory.  This would need to
be either reduced or broken down into a number of smaller jobs.  Networks including < 2,000
observations should be accomodated by most 32 bit PCs, and < 4,000 is advised for 64 bit PCs.

15 Rail Moudule

The following outlines the main tools and functionality within the SCC Rails Modules.

15.1 Rail Traverse

The following outlines the steps to process a Rail traverse.  Error checking, the application of
Centre Error Correction and the introduction of Known Stations are examined. 

Creating A Project Directory

From the Main Screen, select 'DATA tab > New'’

Enter in a Project/Job name 'Rail_Traverse'

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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Download Raw Data

 From the Main Screen, select 'DATA tab > Download'

Set up the following:

Press 'Ok'

Select raw file '\RailData\Traverse\Rail-day.GSI'

Within the Leica data input (1100/1200/Wildsoft/LisCADD) dialog, pick 'Rail-day.GSIConfig'
file and Press 'Ok'

Note: this file is within the SCC folder, as a result, available on the drop down menu
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Error Checking

Go to the 'TRAVERSE tab > Adjust > Reduce'

Set up the following:

Press 'Ok'

Reduction Report

From the Pick A Report dialog, select 'SCC Traverse reduction (All).rpt' and Press 'Ok'
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Examine Report:

There is a notable Slope Distance Error:
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Removing Error from Traverse:

Select 'No' within 'Use Obs' column for record 15 At Stn CST02 To Stn CST03

Re-run Reduction:

Go to the 'TRAVERSE tab > Adjust > Reduce'

Set up the following:

Press 'Ok'

Reduction Report

From the Pick A Report dialog, select 'SCC Traverse reduction (All).rpt' and Press 'Ok'

Review Results.  Note how the Stand Deviation for Slope Distance is now 0.00

Remove Stations From the Project 

Go to Project View, remove stations that have been downloaded from raw file

Select ''EDIT tab > Delete Records' set up the following:
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Adjust Traverse Based on Fixed Base Line

Go to 'TRAVERSE tab', Select 'Setup'

Set opening set up as shown below, allowing SCC to generate a RO values:

Press 'OK'

Select 'Adjust', set up the following and Press 'Ok'
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Review Results and select 'Yes, to use provisional coordinates'

Applying Corrections:  Centring Error

Go to 'TRAVERSE tab', Select 'Adjust drop down > Corrections'

Set up Centring Errors as shown below and Press 'Ok':

Re-adjust and review report

Level Data

Open 'Levels.Traverse'
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Go to 'TRAVERSE tab', Select 'Adjust'

Set up the following:

Select 'OK' and Review report

Select 'Yes, to use Adjusted Coordinates'

Known Station Values

Close existing project and open 'GPSCoords.Project'

Note: Coordinates are constrained based on information from the GPS report (rE/X, rN.Y, rHt/
Z)

Run Adjustment

Go to 'TRAVERSE tab', Select 'Adjust'
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Press 'Ok' and Review Report

Select 'Yes, Use Adjustment Values'

15.2 Rail Analysis

SCC can be used for analysis and reporting of Rail data. 

15.2.1 Rail Overlap

String comparison and overlap processing option are available within the model view under 
'DESIGN tab > Rail button > Compare strings and remove overlaps'.  This requires a model with one
or more overlapping strings, and an alignment for reference purposes.  The following is an
example of the usage of this function based around the sample data provided;

Creating A Project Directory

From the Main Screen, select 'DATA tab > New'’

Enter in a Project/Job name 'Overlap'

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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Create Model

Go to 'DATA tab > Model drop down > SCC Dataset'

Go to \RailData\Model\Biggin.Survey'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'

Select 'Ok' to model attribute dialog

Select RR String Information

Right click the mouse to bring up the Data Selection Dialog

Select 'All points on selected string' and 'Ok'

Left click mouse on RR line strings

 String Overlap

Go to 'DESIGN tab > Overlaps' button

Set up the following:
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Press 'Alignment>>', set up the following and Press 'OK':

Pick 'String Overlap (Diff).rpt' and Press 'OK'

Review Report
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Repeat String Overlap

Go to 'DESIGN tab > Overlaps' button

Set up the following and Press 'Ok':

This time ensure that 'Report only, do not change model' is not selected and 'Use active
alignment for reference' is selected

On completion note the RR string is one complete string



253

©2018 Atlas Computers Ltd

15.2.2 Cant & Gauge Reporting

Using the opened data a Cant & Gauge report can be generated.

Reporting Cant & Gauge

Go to 'DESIGN tab > Rail drop down menu > Report cant and gauge'

Note there must be an active alignment present

Set up the following and Press 'OK'

Pick 'Rail guage and cant.rpt'

Review Report 
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15.2.3 Lift & Slue Reporting

Using the opened data a Lift & Slue report can be generated.

Remove Existing Alignment

Go to 'DESIGN tab > Attach'

Highlight attached alignment, select 'Detach All' and 'Ok'

Attach Design Alignment

Go to 'DESIGN tab > Attach drop down menu > Alignment'

Select ' \rail-day\Lift & Slue\MC02.Alignment'

Reporting Lift & Slue

Go to 'DESIGN tab > Rail drop down menu > Report Lift and Slue

Review Report

15.3 2nd Rail

Using Parallel offset options within SCC, a 2nd rail string can be generated.

Go to 'DATA tab > Model drop down > SCC Dataset'

Go to '\rail-day\2nd Rail\Rail2.Survey'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'
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Select 'Ok' to model attribute dialog

Additional String

Go to 'ADD tab > Parallel'

Set up the following Copy Parallel Options

Pick RD string on screen and then 'CheckCantAndGauge.rpt' from dialog.  Press 'Ok' 

Review Report

Select Yes to 'Create rail string' and click on screen to position string

15.4 Import Amberg Data

An input routine to support the Amberg Trolley data provided. This creates two points per line,
one for left rail, one for right rail, using the station for string number and ident for point number.
D1,D2, and D3 are used to store odometer, gauge, and super-elevation in the input file, such that
they can be annotated as required. The rail features are named LRAIL and RRAIL. 

Close all dataset and models.  Leave existing Project file open

Importing Amberg Trolley Data

Go to 'DATA tab > Import drop down menu > Amberg GRPWin'
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Pick 'DN Branch.asc', set up the following and then Press 'OK'

The dataset is present whereby the D1 is Dist, D2 is Gauge and D3 is Cant

Create Model

Go to 'DATA tab > Model drop down > SCC Dataset'

Pick 'DN Branch.Survey'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'
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Note the Chainage/Offset system present is been read from the dataset not an active Alignment

15.5 Design From XML

The following describes how to create different surfaces in SCC from a given design and export to
XML for Machine Guidance.  

- Design data will be provided as an XML file with a given centreline string including cant and
gauge

- Three design surfaces are generated: Rails (including gauge and cant), Ballast and Formation

- The Ballast layer will ramp down at chainage 380m and ramp up at chainage 480m

- A 0.300m gap will be maintained from the lowest sleeper end to formation

15.5.1 Create A Project Directory

From the Main Screen, select 'DATA tab > New'

Enter in a Project/Job name 'Design from XML

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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15.5.2 Modelling LandXML file

Within the 'DATA tab > Model drop down > LandXML file'

Go to '\rail-day\Design XML\Biggins v1.1.xml' and Press 'Open'

Select Initial Plot Scale of 250 and 'Create the model and triangulation'

Select 'Ok' to model attribute dialog

Set up the following and press 'Ok'

Select 'Home' within Model to Zoom Extent 

15.5.3 Attach Design Alignment

Within Model, go to 'DESIGN tab > Attach drop down menu > Alignment'

Select 'Prop CL copy.Alignment
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15.5.4 View Design Information

Within the 'DESIGN tab > View > Vertical Entities'

Within the 'DESIGN tab > View > Rail Cant'
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NOTE:  If no Cant values where present in the XML file, values can be entered manually by
viewing Rail Cant and then selecting 'DESIGN tab > Insert Records'.  Cant is entered in mm. 
CW is Clockwise / CCW is Counter Clockwise.

Save Alignment

15.5.5 Creating Design Gauge & Cant

Go to 'DESIGN tab > Template button'

Then 'DESIGN tab > Tools > Enter gauge and compute cant'

Set up the following:
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NOTE:  

The dialog uses values from the input XML file

Enter the Cant Base

Apply cant will apply cant form Cant Station (Cant entered is mm)

Report Cant by Chainage will give a report file showing cant, gauge and rail levels before
continuing

Add Sleepers to template will include sleepers on the rail surface

Apply cant from edge of sleeper will apply cant from edge of sleeper

Select 'Create Template' which will use setting to create a section template

Press 'OK' to create a report 

A Section Template is created.
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15.5.6 Applying Sleeper Vertical & Horizontal Offset

Within Template Design, select 'EDIT' 

Left click mouse on 'SLPL' on screen

Set up SLPL: Horz. Offset -1.20 / Vert. Offset -0.3 (300mm lower than rails) as shown

Press 'Apply'

Left click mouse on 'SLPL' on screen

Set up SLPR: Horz. Offset 1.20 / Vert. Offset -0.3 (300mm lower than rails) as shown

Press 'Apply'
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15.5.7 Add Ballast Layer

Select 'New Surface' 

Set up the following and Press 'OK'
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15.5.8 Removing Sleepers From Ballast Surface

Select 'Delete' 

Left click mouse on 'SLPL' and then select 'Delete Point'

Left click mouse on 'SLPR' and then select 'Delete Point'

15.5.9 Editing Ballast Surface

Select 'Edit'

Left click mouse on 'BL' point

Enter Horz, Offset -0.2 and Vert. Offset -0.3

Press 'Edit Point'
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Left click mouse on 'BR' point

Enter Horz, Offset 0.2 and Vert. Offset -0.3

Press 'Edit Point'

15.5.10 Add Formation Layer

Select 'New Surface' 

Set up the following and Press 'OK'
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15.5.11 Removing Sleepers From Formation Surface

Select 'Delete' 

Left click mouse on 'SLPL' and then select 'Delete Point'

Left click mouse on 'SLPR' and then select 'Delete Point'
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15.5.12 Editing Formation Surface

Need to change Feature Codes on Formation surface and apply offset and grade change

Select 'Edit'

Left click on 'RL' on Formation Surface

Enter New feature code 'FL'

Horz, Offset -2 and Gradient +1:30

Press 'Edit Point'

Left click on 'RR' on Formation Surface

Enter New feature code 'FR'

Horz, Offset 2 and Gradient -1:30

Press 'Edit Point'

15.5.13 Adding Ramp at Chainage 380 to 480

Ramp down at Chainage 380 and ramp up at Chainage 480

Select 'New Section'

Enter Starting chainage for new template of 380 and press 'OK'



268

©2018 Atlas Computers Ltd

Select 'New Section'

Enter Starting chainage for new template of 400 and press 'OK'

15.5.14 Inputting Ramp Design on Ballast layer

Section 3 Chainage 400

Select 'Edit'

Left click on 'BL' on Ballast Surface

Horz, Offset -2 and Vert. Offset -0.9

Press 'Edit Point'

Left click on 'BR' on Ballast Surface

Horz, Offset 2 and Vert. Offset -0.9
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Press 'Edit Point'

Select 'New Section'

Enter Starting chainage for new template of 480 and press 'OK'

Select 'New Section'

Enter Starting chainage for new template of 500 and press 'OK'

Section 5 Chainage 500
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Select 'Edit'

Left click on 'BL' on Ballast Surface

Horz, Offset -2 and Vert. Offset -0.3

Press 'Edit Point'

Left click on 'BL' on Ballast Surface

Horz, Offset 2 and Vert. Offset -0.3

Press 'Edit Point'

Save Alignment

Template is visible on the model displaying the alignment
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15.5.15 Export Rail Design

Go to 'DESIGN tab > Model' Export

Set up the following and press 'Ok':

Press 'Ok' to model attribute dialog

15.5.16 Triangulate Rail Model

Within 'MODEL tab > Edit'

Using 'All triangles intersecting line' as the Selection Method and 'Remove triangle' as the
'Action', edit the TIN
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Select 'Apply'

Select 'Yes' to 'Store model boundary as a string'

Save Model as 'RAIL.Model'

15.5.17 Long Section With Cursor

Go to 'ANALYSIS tab > L. Sect button'

Left click mouse to pick first point of section and then again to pick second

Right click mouse to finish

A profile of the Rail surface is created
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15.5.18 Export Ballast Design

Go to 'DESIGN tab > Model' Export

Set up the following and press 'Ok':

Press 'Ok' to model attribute dialog

15.5.19 Triangulate Ballast Model

Within 'MODEL tab > Edit'

Using 'All triangles intersecting line' as the Selection Method and 'Remove triangle' as the
'Action', edit the TIN
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Select 'Apply'

Select 'Yes' to 'Store model boundary as a string'

Save Model as 'BALLAST.Model'

15.5.20 Export Formation Design

Go to 'DESIGN tab > Model' Export

Set up the following and press 'Ok':

Note: Cant is not applied on Formation Level.  Untick 'Apply Super-Elevation /Cant'
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15.5.21 Triangulate Formation Model

Within 'MODEL tab > Edit'

Using 'All triangles intersecting line' as the Selection Method and 'Remove triangle' as the
'Action', edit the TIN

Select 'Apply'

Select 'Yes' to 'Store model boundary as a string'

Save Model as 'FORMATION.Model'

Three Triangulated Model have been created.

15.5.22 Check & Adjust Formation Levels

In order to maintain fixed depth levels between low rail and Formation, the 'Check and adjust
formation levels' tool can be utilised.

Go to 'DESIGN tab > Rail > Check and adjust formation levels'

Set up the following including required vertical seperation and press 'Ok'

Select 'Ok' to model attribute dialog

Pick 'Formation adjustment.rpt' file and press 'Ok'

The report details the Level adjustment, the exact difference in height between formation
and low rail, and the chainage is note
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The report can be exported to various formats

A new Adjusted Formation Model has been created.  

Edit the TIN as above. 

Save as 'AdjustedFormation.Model'

15.5.23 Combining Models & Alignment for QA puposes

As a QA check, models can be combined and section generated.

Within 'RAILS.Model', go to 'DESIGN tab > Attach drop down > Model'

Select 'BALLAST.Model' and then repeat, to select 'AdjustedFormation.Model'

Go to 'DESIGN tab > Attach drop down > Alignment' and select Alignment file
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Go to 'ANALYSIS tab > L.Sect drop down > Live Section'

Set 'Cross section along alignment' and offset left/right 5.

Move cursor along along alignment, left click to generate live section in sub divided screen

Close without saving

Go to 'DESIGN tab > Attach drop down > Edit/Detach' 

Highlight Ballast and Formation Model, select 'Detach' and 'Ok'



278

©2018 Atlas Computers Ltd

15.5.24 Exporting XML For Machine Control

Within the 'Rails.Model' which has the Alignment file attached, go to 'DATA tab > Export drop
down > LandXML'

Set up the following and press 'Ok'

Select 'Ok' to model export dialog

Close 'Rails.Model' and open 'BALLAST.Model', attach alignment file and repeat export steps

Similarly, repeat for 'AdjustedFormation.Model'

15.6 Computing Platform Edge Using Bance Gauge

The following outlines the steps to compute platform edge using Bance Gauge.

Open Existing Project & Dataset

From the Main Screen, SCC button 'Open'

Go to 'C:\SCC\rail-day\Bance Gauge' 

Open 'Platform.Project' and 'Bance Gauge test1.Survey'
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Compute Platform Position from Bance Gauge

Go to 'SURVEY tab > Tools > Compute Platform Position From Bance Gauge'

Set up the following and press 'Ok'

Select 'OK' to 'Extra Title Fields' dialog 

Select 'PlatformGaugeSurvey.rpt' from Pick a Report dialog and press 'Ok'

Review report
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15.7 Wriggle Survey Processing

Wriggle survey functionality which can be accessed as follows;

'DATA tab >  Import >  ASCII Wriggle Survey' from a project

'SURVEY tab  > Tools >  Compute Wriggle Survey' from the survey coordinates view'

''SURVEY tab  > Tools >   String using Chainage > Offset from the survey coordinates view'

This is used in conjunction with an alignment to group point data into rings.

To process the sample files  9961065.ASC, 200_UPLINE-.CAN, 200_UPLINE-.HOR and ,
200_UPLINE-.VER do the following;

Creating A Project Directory

From the Main Screen, select 'DATA tab > New'

Enter in a Project/Job name 'Wriggle'

Select a Project Template from the list 'Default v11 Complex.Project'

Select ‘OK’
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Create an alignment from the 200_UPLINE files

'DATA tab >  New drop down >  New document > SCC Alignment'

'DATA tab > Import drop down >  ACT horizontal entity file, picking '200_UPLINE-.HOR' 

'DATA tab > Import drop down >  ACT vertical entity file, picking '200_UPLINE-.VER'

'DATA tab > Import drop down >  ACT cant file, picking '200_UPLINE-.CAN'

From the Main Screen, SCC button 'Save As' 200_UPLINE.Alignment'

'SCC button > Close'

Import the ASCII survey file

'DATA tab > Import drop down >  ASCII Wriggle Survey, picking '9961065.ASC'

SCC button 'Save'

Compute the wriggle survey

'SURVEY tab > Tools > Compute Wriggle Survey', using parameters shown and pick
'WriggleSurvey.RPT' as the report file
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This will compute the wriggle survey and show the following report.  

Note:

· that with bearing and gradient computed from ring data, the alignment is not used in the
computations.  It is still used in the report to show the difference between bearing and
gradient values computed via linear regression and those computed for the alignment.

· Bearing and gradient computation determine whether the tunnel bearing and gradient is
based on the alignment or the connected ring circles generated in processing

· Export options control whether in addition to the report you get a section file, model
and/or survey data set on output, and whether they include the surveyed points, design
circle radius and/or best fit circle radius.

· The design radius is the nominal radius of the tunnel

· The outlier distance is the distance from the design radius at which points are rejected as
noise / not on the tunnel surface.  The wriggle process is actually computed twice, first to
remove outliers, second to get a clean result.

· The radial offset is a prism constant from observed point to tunnel face

· The deformation tolerance is the distance above which points in the survey are flagged as
out of range / build tolerance / potential obstructions

· Adding an extra rail model to the output shows the rail position with respect to the tunnel
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· the contact details in the report are taken from 'General Options >  Module Licenses >  Edit
user details'.  The layout and content of the report can be modified to suit individual client
needs independently of SCC using Crystal reports XI or later.  Results from the SCC
viewer can be saved into Microsoft Excel for further analysis by pressing the export button
on the top left of the viewer.  This also supports a wide range of other formats included
Word, PDF and ODBC database tables.

When comparing the results with the output file provided, 9961065.out, SCC is producing
identical radii, and horizontal and vertical offsets that agree to within 1mm.  The easting and
northing of the centres deviate by ~10mm to 30mm but looking at the radial residuals, e.g.
the difference between the final computed radius and distance from computed centre to
each point, which would imply that the SCC result is more accurate because the sum of the
residuals in the SCC report is smaller than those in the output report provided, indicating a
slightly better circle fit.  For example on ring 1, both routines agree a radius of 3.574, and
the residuals are as follows;

9961065.out SCC

Point Radius Residual Radius Residual

1099601 3.578 0.004 3.579 0.005

1099602 3.584 0.010 3.584 0.010

1099603 3.567 -0.007 3.567 -0.007

1099604 3.565 -0.009 3.566 -0.008

1099605 3.579 0.005 3.579 0.005

1099606 3.579 0.005 3.579 0.005

1099607 3.577 0.003 3.577 0.003

1099608 3.561 -0.013 3.571 -0.003

Sum of square of residuals

0.056 0.046

We can see from this that the SCC centre is a slightly better fit for the data provided.

Case Study Data

To process ascii compiler-1.csv, 300DOWNLINE-.HOR, 300DOWNLINE-.VER, and
300DOWNLINE-.CAN do the following

Downloading & Importing Data

Create a new project as described previously

Import the ACT alignment files into SCC as described previously

'DATA tab >  Download' picking 'ascii compiler-1.csv' using the parameters shown below
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Computing Chainage Offset from X,Y

To group the data into rings, select 'SURVEY tab > Tools  > Compute Chainage,Offset from
X,Y'

String using Chainage Offset 

Select 'SURVEY tab > Tools  >String using Chainage & Offset'

'SCC button >  Save'

Compute the wriggle survey

'SURVEY tab > Tools > Compute Wriggle Survey', using parameters shown and pick
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'WriggleSurvey.RPT' as the report file

Compute the wriggle survey as described previously, picking the 300 downline alignment file to
get the following report

Notes from the results;

The computed bearing and gradient shown by SCC are ~180 degrees off the alignment value
for the same section.  This could be corrected using the alignment if required.  Without an
alignment the orientation of the section is arbitrary and can flip by 180 degrees, which also
reverses the gradient.  

It doesn’t affect the centre, radius or offset values.

Comparing the results to those supplied in 320 wriggle analysis.xls all the radii in SCC are
exactly 50mm smaller which appears to correspond to the BFC from DTA radial value and
Lining radial value in the xls file.  Horizontal and vertical offsets appear to agree to with
about 2mm but centres are differ by ~50-60mm.  This could possibly be related to radial
offsets.  Re-computing using alignment bearing and gradients does not appear to make a
significant difference to this, though further investigation is probably required.

The xls provided appears to have a limit of size points per ring, though this could just be a
reporting anomaly.
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16 Lift And Slue Reporting

This tutorial gives an example of how to use the lift and slue reporting functionality.  This
involves comparison of a design model with a survey model for left (vertical separation) and
slue (lateral separation) on nominated left and right rails.  It also computes cant a gauge
between left and right rails, and reports any failures to meet tolerance in cant.  To
demonstrate this functionality, do the following; 

Import GENIO files to create a design model, a survey model, and an
alignment. 

'FILE > Model  > MOSS GENIO file'  picking C:\SCC\Lift and Slue\Example1 - DESIGN.TXT

'FILE >  Save > Design.Model'

'FILE >  Model > MOSS GENIO file' picking C:\SCC\Lift and Slue\Example1 - SURVEY.crd

'FILE >  Save > Survey.Model'

'FILE >  New > SCC Alignment'

'FILE >  Import > MOSS GENIO geometry strings' picking C:\SCC\Lift and Slue\Example1 -
DESIGN.TXT

Pick MC02 as the alignment string to import

'FILE >  Save >  MC02.Alignment'

Rail Lift And Slue Analysis

Open the design model, 

Pick 'DESIGN > Report rail lift and slue'

Select the files which have just been created and the design and survey strings to analyse.

Reporting Rail Lift And Slue

When prompted, pick 'Rail lift and slue.rpt' from the reports list. 
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This will produce a report as shown below.  The report is broken down into separate
sections for lift and slue values between survey and design for left and right rails, cant and
gauge between rails with any values outside tolerance highlighted in red, and surveyed 6/10
foot.

17 Rail Cant Computations

Separate design sheet views for road super elevation and rail cant are available, and includes low
rail cant calculations based on curve directions.  This can be demonstrated using the a LandXML
file including rail cant, such as readings.pax.land.xml.  To process this file and check the results,
do the following;

Create A New Project

Create a new SCC project

Import LandXML Files

'FILE >  Import >  LandXML' and pick readings.pax.land.xml as the input file.
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To view the cant stations, select VIEW >  Rail Cant, which will show the following, which agrees
with the LandXML values.

Checking Gauge And Cant

To check the gauge and cant, select 'DESIGN >  Enter Gauge and compute Cant'.  The gauge
will have been read in from the LandXML file in this case, so you simply enter the feature
names and offsets for left and right rails, as shown in the dialog below.

  

This option will also produce a report listing the cant stations, and applied cant values on
either rail at a regular chainage interval.  The chainage interval can be specified using  '
DESIGN >  Interface and export parameters'.

Rail cant check report

Date: Wed Aug 11 11:54:32 2010

Alignment: base readings.pax

Gauge: 1.500  Left Rail:LRAIL Offset 0.000  Right Rail:RRAIL Offset 1.500

Chainage    CL Height   L.Cant   R.Cant   L.Height    R.Height    Direction

----------  ----------  -------  -------  ----------  ---------- 

----------

  9860.000      99.169   +0.000   +9.844      99.169      99.178  Left

(CCW)

  9870.000      99.126   +0.000   +8.111      99.126      99.134  Left

(CCW)

  9880.000      99.077   +0.000   +3.156      99.077      99.080  Left

(CCW)

  9890.000      99.013   +6.547   +0.000      99.020      99.013  Right

(CW)
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  9900.000      98.938  +18.707   +0.000      98.957      98.938  Right

(CW)

  9910.000      98.873  +16.969   +0.000      98.890      98.873  Right

(CW)

  9920.000      98.828  +19.726   +0.000      98.848      98.828  Right

(CW)

  9930.000      98.778  +20.626   +0.000      98.799      98.778  Right

(CW)

  9940.000      98.707  +21.350   +0.000      98.728      98.707  Right

(CW)

  9950.000      98.642  +18.360   +0.000      98.660      98.642  Right

(CW)

  9960.000      98.598  +21.790   +0.000      98.620      98.598  Right

(CW)

  9970.000      98.532  +23.403   +0.000      98.556      98.532  Right

(CW)

  9980.000      98.500  +30.983   +0.000      98.531      98.500  Right

(CW)

  9990.000      98.482  +34.832   +0.000      98.517      98.482  Right

(CW)

 10000.000      98.438  +33.475   +0.000      98.472      98.438  Right

(CW)

Cant Stations

Chainage    Cant     Direction

----------  -------  ---------

  9857.035  +10.669  Left (CCW)

  9864.255   +8.661  Left (CCW)

  9871.057   +8.010  Left (CCW)

  9884.879   +0.508  Right (CW)

  9892.152   +9.086  Right (CW)

  9898.901  +19.766  Right (CW)

  9905.943  +12.978  Right (CW)

  9912.923  +19.845  Right (CW)

  9926.657  +19.614  Right (CW)

  9933.803  +21.776  Right (CW)

  9940.840  +21.292  Right (CW)

  9954.909  +16.788  Right (CW)

  9961.805  +23.564  Right (CW)

  9968.853  +22.139  Right (CW)

  9975.754  +29.744  Right (CW)

  9982.833  +31.809  Right (CW)

  9989.718  +34.964  Right (CW)
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  9996.593  +31.754  Right (CW)

  9999.818  +33.451  Right (CW)

 10004.996  +34.120  Right (CW)

SCC for Windows v9.10.0  (C) 1990 - 2010 Atlas Computers Ltd

Pressing the create template, will create a simple design template consisting of just the two
rails.    This can be viewed as a spreadsheet using 'VIEW >  Section template points'

or graphically via 'DESIGN >  Section templates'

A cant graph can also be viewed with the profile using 'DESIGN > Vertical design'.  

N.B. use the V/ E controls to change the vertical exaggeration.
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On the vertical design view, the status bar shows instantaneous cant at the cursor position,
along with chainage, profile height, gradient and curve direction.

The cant at a given chainage is linearly interpolated based on the surrounding cant stations.
For a given chainage and horizontal offset, if the cant direction is right >  clockwise, the
cant is given as

G = Interpolated cant >  gauge

C = (Right rail offset – horizontal offset)*G

If the cant direction is left >  ant-clockwise, the cant is given as

G = Interpolated cant >  gauge

C = (horizontal offset  - Left rail offset)*G

The design height for that chainage and offset is calculated as sum of the profile height at
that chainage, the vertical offset in the template string point (e.g. 0 for the rails), and the
cant as computed above.    This is the same for all surfaces in the alignment.

18 String Comparison & Overlap Processing

String comparison and overlap processing option are available within the model view under 
'DESIGN > Compare strings and remove overlaps'.  This requires a model with one or more
overlapping strings, and an alignment for reference purposes.  The following is an example of the
usage of this function based around the sample data provided;

Create Project And Import Data

Create a new project, via 'FILE >  New Project, or open an existing project

Create a model from the DXF files provide
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'FILE >  Model >  DWG> DXF file' and select 'DM with compensation.dxf'

'TOOLS > Add strings from file DWG > DXF file', and select 'DM without compensation.dxf'

Create Alignment

Create a new alignment from existing centreline for analysis purposes

'DESIGN > Create alignment from existing string'

Pick LINTRACK, string 1

Select Create alignment from straights and fillet arcs and press Ok

String Analysis

Select strings for analysis

Zoom into area 1009,1356

Right click to bring up data selection dialog

Select All points on selected string, Ok

Pick the three strings as shown

Select 'DESIGN > Compare strings and remove overlaps', using the parameters shown.  

These parameters work as follows;
· Horizontal and vertical tolerances are used to determine the scope of the search.  

· Points that are further away from each other that this are not considered for comparison.

· Report only is used to generate a comparison report, but will not change the model.

· Interpolate all points on all strings is use to generate additional comparison points at
chainages where a point exists on one string under analysis but not others.  It is typically
useful where the same part of the same string has been surveyed more than once, but
the surveyed points are at different locations.
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Press Ok to perform the analysis and pick a report.

Note that two standard reports have been added to SCC to support this option as
follows;

String Overlaps (all).rpt shows all points used in the comparison alongside their
generated average positions.  Any differences greater than 1mm in horizontal or vertical are
highlighted in red.
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String Overlaps (Diffs).rpt only shows points where the difference exceeds either 1mm in
the horizontal or vertical.

Following on from the analysis, we can see that the overlapping strings have been replaced
with a single averaged string. 

Note: 

Report titles and logo relating to user details can be controlled throughout SCC using 'FILE
>  General options >  module licenses >  user details.

19 Wriggle Survey From Point Cloud Data

This note covers the steps required to create a wriggle survey from a scanned tunnel in order to
ascertain the circularity of the tunnel and produce an accurate best fit alignment through the
tunnel.  The stages are as follows;

19.1 Setting Analysis Of Data

Open the tunnel project and model, and use the point cloud editing tools to separate tunnel wall
data other scanned data within the tunnel.  Set the analysis of data that is not part of the tunnel
wall to Display only.

Open Existing Project & Dataset

Open 'Project' and '.Survey'

Right click to bring up the point cloud data selection dialogue, and select option to isolate an
area 10 metres either side of the selected centre line.  Set the section offset interval to 20m and
press Isolate points
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Select two points either side of tunnel roughly 90 degrees to the tunnel wall.

This will show an elevation through the tunnel, with a depth 10 metres either side of the
centre line.  The up and down arrows can be used to move the area displayed up and down
the tunnel, and pressing 'P' or 'E' can be used to flip between plan and elevation.
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Right click the mouse button to bring the data select dialog up again, and this time select 'All
points in a polygon' and press the Select points button.

Left click to place points on a polygon that encloses the points we want to exclude from the
wriggle analysis.  

Right click to close the polygon and highlight the selected points

Use 'CLOUD > Edit selected points' to change the feature of the selected points to 'OTHER'. 
Repeat this to separate out all other points on the inside of the tunnel.

Use 'CLOUD >  Point cloud features' to set the analysis type of 'OTHER' to be 'Display only',



297

©2018 Atlas Computers Ltd

such that these points will not be included when creating sections.

 Use 'FILE > Save' to save this model under the new name of  'XXX (edit 1).Model'

19.2 Setting Arbitary Centreline

Create an arbitrary centreline through the tunnel.  This will be used to cut sections through the
tunnel and should roughly follow the tunnels plan position and gradient.

Select 'VIEW > Coordinate computations'

Isolate a vertical section through the tunnel at one end of the tunnel as described previously, but
make the area narrower by specifying a minimum offset of -1 and a maximum offset of 1.

Select 'TOOLS > Measure > Triangle, areas, centres and gradient'

Pick three well separated points on the tunnel wall to generate a circumcircle as shown.
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The coordinates for the triangle and circumcentre will be shown in a coordinate computations
spreadsheet at the bottom of the screen.

Repeat these steps for another circle at the middle of the tunnel, and a further one at the far
end.

Press escape to close the triangle measurement dialog, and P to return to plan view.

Right click to bring up the data selection dialog, select All points in cloud and press Enable
points to turn all the points back on again.

Select 'EDIT > Add strings with cursor'

Select the first CIRCUMCENTRE point from the computed coordinates and press Output. 
Repeat for the other two CIRCUMCENTRE points

Right click and select Save string as interface from the pop-up menu.  This create a 3d
alignment that passes through the three points.
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19.3 Cutting Sections

Cut sections at the desired interval through the tunnel, such that there is a section at every
position where the tunnel changes direction or gradient.  If the tunnel is not horizontal, these can
be oblique sections rather than vertical cross sections

Select 'SECTIONS > Cross sections from an alignment'.  

In this case, we're cutting sections every 1.4m on the basis that the tunnel direction can
vary at any keystone on the tiled wall.

Visually check that the sections don't include any data that does not relate to the tunnel
wall.

Use right click to use a window to select unwanted points, followed by 'EDIT > Delete / Delete
points' to get rid of those points.

Use 'EDIT > Delete / Delete sections' to remove any sections that do not include enough data to
contribute meaningful results to the wriggle survey.  

This will typically be areas that do not include enough scan data to create a section or
areas where the tunnel is not circular.
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Export the sections sections to a survey data set, which will be used as the input to the
wriggle analysis.

Select 'FILE > Export sections > Survey data set'

In the coordinate spreadsheet, select 'TOOLS > String using chainage and offset', such that
the wriggle survey will have all the contents of a single section as input for each ring.

'FILE > Save As' Wriggle input

19.4 Wriggle Analysis

Run the wriggle analysis to produce a report, sections and new alignment.

Select 'TOOLS > Compute wriggle survey' using the parameters shown.  If we do not know the
initial design radius, we can enter the mean value from the circumcircles computed previously.

Providing an outlier distance means that once the analysis is initially carried out, any
outliers with a distance outside the the value specified will be removed and the analysis
repeated.

The deformation tolerance is used for reporting purposes, where any points with a distance
outside of this range are considered out of tolerance.  For scanned data with a huge number
of input points we can then elect to only report out of tolerance points to provide a more
manageable report.
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If the difference between the design radius and computed radius is similar for each ring, and
we're working off a provisional design radius, we can repeat the analysis based on a new
radius.
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In our section view, use 'FILE > Load Save' section style and pick the Wriggle from scan style to
set-up appropriate annotation and scales for wriggle survey from a scanned tunnel.

This shows us the difference between design and fit radius at each chainage, along with the
worst of the out of tolerance points for each area of the section.

Zooming in we can see the scanned section overlaid with the design and best fit circles,
with whatever annotators we've specified.  Annotation is limited such that where it would
overlap, only the annotator with the largest error is added.
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The wriggle analysis will also output a model and alignment which can be saved and
attached to our original scanned model for verification purposes.

20 Processing LandXML File In SCC For Machine Control

The following text gives the steps required to import your 3d LandXML alignment into SCC, enter
a type section including bottom ballast and formation surface details, and export those surfaces
to Scanlaser via LandXML.  The steps are as follows;
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Create A New Project

Select 'FILE >  New project' in SCC and enter a project name and template as shown below.

Import LandXML Files

Import the alignment from LandXML and enter cant

Select 'FILE >  Model >  LandXML file' and pick the file DES UPT - FINAL temporary interface
(18.556m - 2641.176m).xml

This will create a 3d alignment containing the horizontal and vertical entities in the XML
file and 3d string model of the same.  The initial view will be of the 3d string model in
plan.

To view the horizontal entities, click the highlighted tab
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To view the vertical entities, select 'VIEW >  Vertical Entities'

You can change gradient units between ratios, e.g. 1:2, to percentages using 'FILE >
General Options >  Units and data checking'

Note that in the data provided, the horizontal alignment is slightly shorter than the vertical
alignment, so you may wish to edit the length of final horizontal entity.  Once you are happy
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with the alignments, select 'FILE >  Save to' save the alignment file.

To view the horizontal entities in plan, switch back to plan view and select 

'FILE >  Attach> Detach >  Attach Alignment File, picking the file DES DR CL - 644.Alignment

You will see the alignment drawn with straights in yellow, transitions in red, and circular
arcs in blue.  As you move around the screen you will also see the chainage and offset of
the cursor position being updated.

If you have any cant, you can enter this in using 'VIEW >  Super-elevation > Cant'.  Selecting
'DESIGN >  Compute super-elevation > Cant' will place cant nodes at transitions, allowing you
to enter cant values and run-off for each node.

To inspect the vertical profile graphically, this can be done from plan view by selecting 
'DESIGN > Vertical Alignment'.  Vertical straights are shown in yellow and parabolic curves
in blue.  The positions of horizontal changes are shown as yellow, red or blue vertical lines. 
As you move the mouse on screen, the chainage and height of the current cursor position is
displayed.
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Below the vertical profile you will also see a diagram showing application of cant > 
super-elevation by chainage.  This is also interpolated and updated in the status bar for the
current cursor position as you move the mouse.

Cross Section Templates

Select 'DESIGN >  Section Templates' to bring up the template design screen as shown.
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Enter the following points to build the section templates as shown

Surface Feature Hz.Offset Vt.Offset

BALLAST LEFT -1.000 -1.000

BALLAST LRAIL 0.000 -1.000

BALLAST RRAIL 1.500 -1.000

BALLAST RIGHT 2.500 -1.000

FORMATION LEFT -2.000 -1.200

FORMATION RIGHT 3.500 -1.736

The values given here are arbitrary intended to illustrate the process.  You can enter real
values either using horizontal and vertical offsets, or any combination of offsets, height
differences, widths and gradients.  The small blue circle on the template indicates the
position of the centerline.

Once you have entered the template points, select 'FILE >  Save to' save your work.  You
can also view, enter and edit these points in spreadsheet fashion by selecting 'VIEW >
Section template points'

Create the surface models

From the section template view, select 'Design >  Export design as model', and enter the
following parameters to export the formation model.

Note that the chainage interval controls the number of points that will be output to the
triangulated surface.  A higher number can give better representation of horizontal and
vertical curves in the triangulated surface, at the expense of a larger model.

If you do not wish to apply cant to this surface your can also disable it at this point.

To remove any spurious triangles around the model boundary, use the Add / Remove
triangles tool.  Use the options to remove all triangles to the left of the left edge and to the
right of the right edge (lower on screen).
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The final triangulated surface will appear as follows.  Select 'FILE >  Save' once your are
done, giving a name of Formation.Model

To export the bottom ballast surface, go back to the section template view and select 
'DESIGN >  Export design as model' using the following parameters;

Note that we have picked the formation model as our existing ground surface and instructed
SCC to generate an interface between these surfaces using the side slopes entered in the
section template.  When you zoom into the resulting model you will see red tadpoles
connecting the edge of the ballast surface down to the formation surface. 
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To verify the correctness of the surfaces generated we will cut some cross-sections through
them.  

Select 'FILE >  Attach/Detach >  Attach Alignment File', picking the file DES UPT - FINAL
temporary interface.Alignment and then pick 'Sections >  Cross sections' from an alignment
using the parameters shown;

From the section view, select 'EDIT >  Append surfaces' and pick the formation model.  

This will result in sections as shown below:

To get an animated run through of the sections, use 'VIEW >  Sheet layout' with the parameters
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shown below;

Press + to move up the chainages and – to move back down.  It is valuable to use this to check

chainages where cant changes around transitions.

Note:  If you want to apply a template position to points after cant has been applied, this
can be done as follows;

· Exporting the surface with cant

· In plan view use 'Design >  Create an alignment from an existing string' to create a new
alignment

Add the second template to this alignment and proceed as described above.

Export LandXML files

To export a LandXML file for a given model, open the model and select 'FILE >  Export > 
LandXML.'  

Doing this for Ballast.Model and Formation.Model will result in the files
Ballast.Model.Land.XML and Formation.Model.Land.XML.  

These files can be opened in Internet explorer as shown below.

Examining the XML files shows they contain points, strings, breaklines and the triangulated
surface

Note: Widening or narrowing at a given chainage

To widen or narrow an alignment between given chainages we need to create extra
templates.  For example say we wished to widen the formation surface between chainages
380 and 420, we would do the following;
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§ In section template view, press the New section button and create a new section at
chainage 380.

§ Press the New section button again, and create another section at chainage 420.

§ Edit the right formation edge to have a new offset and/ or height as required

§ Export to a model as described previously.

Viewing the section template points shows we now have three sections, each containing all
the strings for both surfaces.  The first and second sections, starting at chainages 0 and
380, are the same indicating there is no change between these chainages.  The third
section, at chainage 420, has a modified height and offset values for the right formation
level.  This means that there will be a linear change of height and offsets between chainages
380 and 420.  As there are no further sections after chainage 420, the section template at
420 will be carried to the end of the alignment.
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21 Working With AutoCAD Civil3D Files

21.1 Exporting TIN models from SCC to Civil 3d

The following examines how to export a triangulated surface from SCC to Civil 3d using the
LandXML format.  It is based around SCC 10.0.6 and Civil 3d 2013.  The steps are as
follows:

Open your model in SCC

Select 'FILE > Export > LandXML' using the following parameters

Open Civil3d and start a new blank drawing

Select 'Insert > LandXML'
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Pick the LandXML file created in SCC, the file contains a large number of points and one
surface that corresponds to the TIN surface

When drawn initially in Civil3d it may not show the TIN, depending on the default surface
style set in use.
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To display the TIN, first create a style set with triangles turned on as follows:

Click New in the Surfaces section of the Settings pane in the Toolspace.

Give your new surface style a name, e.g. Display TIN

In the Display tab, turn on the triangles

Press Ok to close the dialog
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To apply the style set to the surface:

Click 'MODIFY > Surface'

Click 'SURFACE > Properties'

Select the appropriate style e.g. Display TIN, as the surface style

Press Ok
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Triangles are now displayed and can be used for analysis.

21.2 Importing AutoCAD Civil3D files into SCC

The following details the exporting of specific design entities from AutoCAD Civil3D 2013 which
are then imported and modelled in SCC.

Exporting Specific Entities from AutoCAD Civil3D

Open the drawing file in AutoCAD.

Note in some instance a message as shown below will detail that the drawing may be
missing some shape files and xrefs.  For the purpose of the demo this message is ignored.
The error message will not appear if the file is opened on a PC where the files are available
locally.

In the sample shown, the missing references appear as huge text in the drawing, where the
area of interest to be exported is at the bottom right of the word Tin.
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Zoom into the area of interest, and type in SAVEAS to save a copy of the file under a new name.

Type EXPLODE and select the corridor, to convert the entire C3D corridor object into an
AutoCAD block.

Type EXPLODE again to convert the block into simple entities.

Type DXFOUT to save these entities to a DXF file.

On the Tools menu of the Save Drawing As dialog, pick Select Entities, as this option allows for
just the road corridor entities.  

Enter a name and press Save.  

Use the mouse to drag a window around the area of interest, and press Enter.
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Close Civil 3d

Importing Entities from AutoCAD Civil3D into SCC

Open SCC

'FILE > New Project', to create a new project, or open an existing project

'FILE > Model > DXF or DWG' and pick the file  just created
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The data from Civil3d is all line segments, use 'TOOLS > Join adjacent strings (Same feature)'
to convert them back to polylines. 

Right click to select all the points in the model, and pick a DTM code of DTM elevation to
ensure all points are triangulated for contouring, sectioning, etc...

Use 'EDIT > Add/Remove triangles' to limit the extents of the triangulation and form a boundary
.

Use 'EDIT > Query & edit points' to set feature colours and line styles as required.  

When prompted save the changes to the feature library, such that the feature library can be
used as a template for future imports, such that this step is not necessary in future.
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Notes:

If specific design lines are required out of Civil3d you can export the data as polylines, as
described below.  This is fine for a few lines but would become cumbersome on a large
design as each line has to be done individually.

The TIN and alignments can be exported from Civil3d in LandXML as required, but this
doesn't appear to create line work, so the above method give a better result.

22 Using Adjustment Constraints

Additional fields to enter coordinate constraints against station coordinates, and to include some
extra adjustment options to deal with these have been added.  Specifically, when you use 'VIEW
> Station Coordinates', you will see three extra constraint fields, rE/X, rN/Y and rHt/Z, which
correspond to the known accuracies >  standard errors of the stations.  You will also notice that
the Type field has been broken down into two separate fields for X,Y Type and  Z Type, and that
a new type of Constrained has been added.
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Entering a value into a constraint field, and setting the corresponding type to constrained will
allow the station to be modified slightly during the course of a least squares adjustment to the
limits of the constraint entered.  For example, in the above spreadsheet, the X,Y, and Z
coordinates have standard errors of 5mm, and hence may be adjusted by an amount that will
normally be less than this value.  Note that in networks with blunders and unusually large
residuals, the adjustment may be greater than the standard error entered.

Open Existing Files

To illustrate the use of constraints, open 3d-example.project and 3d-example.traverse 

Traverse Adjustment

Select 'EDIT > Adjust' with the following parameters.

This yields the report shown below.  Note the report layout has been improved in SCC 9.9.0
to combine residual values and standard errors in with original observations and provisional
coordinates, and similarly adjustments with adjusted coordinates.  Note that the
coordinates and elevation of STN1 and STN2 have been modified slightly in accordance with
the constraints given.

SCC for Windows v9.9.0 (C) 1990 - 2009 Atlas Computers Ltd

   Traverse adjustment report

   Title   3d-EXAMPLE.Traverse
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   Date    Thu Jun 03 08:48:43 2010

   Coordinate adjustment method  Variation of Co-ordinates

   Height adjustment method  Least Squares (Default weighting)

   Corrections applied

   -------------------

   Local scale factor : No local scale factor

   Earth curvature and refraction : Curvature only  (Earth Radius

6380000.000)

   Temperature and pressure : No 

   Mean sea level correction : No 

    Default Standard Errors

    Angles (secs)            : 3.000

    Distances (constant mm)  : 5.000

    Distances (ppm mm)       : 2.000

    Heights (mm)             : 3.000

    Provisional coordinates

    Name                    E> X       StdErr        N> Y       StdErr 

Type       Ht> Z       StdErr  Type

    ----------------  --------------  ------  --------------  ------  ---- 

--------------  ------  ----

    STN1                  1166.19500  0.0050      1100.00000  0.0050  Cons 

     54.31100  0.0030  Cons

    STN2                  1100.00000  0.0050      1100.00000  0.0050  Cons 

     55.68500  0.0030  Cons

    STN4                  1099.88478  0.0000      1125.34510  0.0000  Free 

     53.02486  0.0000  Free

    STN5                  1141.22028  0.0000      1122.19111  0.0000  Free 

     52.35902  0.0000  Free

    STN6                  1202.08301  0.0000      1098.41752  0.0000  Free 

     51.47829  0.0000  Free

    STN7                  1225.12102  0.0000      1097.61346  0.0000  Free 

     50.76723  0.0000  Free

    STN8                  1220.29787  0.0000      1075.01497  0.0000  Free 

     58.79736  0.0000  Free

    STN9                  1215.15799  0.0000      1142.77027  0.0000  Free 

     40.62047  0.0000  Free

    TEM1                  1101.17775  0.0000      1143.46424  0.0000  Free 

     52.22092  0.0000  Free

    TEM2                  1105.95935  0.0000      1132.62374  0.0000  Free 

     52.25085  0.0000  Free

    Adjusted coordinates

    Name                    E> X         Adj         N> Y         Adj      

Ht> Z         Adj

    ----------------  --------------  -------  --------------  ------- 
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--------------  -------

    STN1                  1166.19517  +0.0002      1100.00000  +0.0000     

 54.30905  -0.0019

    STN2                  1099.99983  -0.0002      1100.00000  +0.0000     

 55.68695  +0.0019

    STN4                  1099.88673  +0.0019      1125.33990  -0.0052     

 53.01638  -0.0085

    STN5                  1141.22332  +0.0030      1122.18748  -0.0036     

 52.35103  -0.0080

    STN6                  1202.08386  +0.0008      1098.41665  -0.0009     

 51.47357  -0.0047

    STN7                  1225.12161  +0.0006      1097.61285  -0.0006     

 50.76387  -0.0034

    STN8                  1220.29869  +0.0008      1075.01485  -0.0001     

 58.79446  -0.0029

    STN9                  1215.15749  -0.0005      1142.77221  +0.0019     

 40.61866  -0.0018

    TEM1                  1101.17898  +0.0012      1143.45910  -0.0051     

 52.21244  -0.0085

    TEM2                  1105.96101  +0.0017      1132.61879  -0.0050     

 52.24236  -0.0085

    Bearings

    At Station    To Station     Bearing    StdErr   Residual      StdRes

    ------------  ------------  ----------  ------  -------------  ------

    STN1          STN2          270 00 00.0   0.000  -000 00 00.00   1.000 

(Fixed)

    STN2          STN1          090 00 00.0   0.000  -000 00 00.00   1.000 

(Fixed)

    Angles

    At Station    To Station      Angle     StdErr   Residual      StdRes

    ------------  ------------  ----------  ------  -------------  ------

    STN1          STN8          204 47 16.0   3.000  -000 00 00.56   0.190 

 

    STN1          STN8          204 47 17.9   3.000  -000 00 02.56   0.857 

 

    STN8          STN7          077 15 36.0   3.000  -000 00 00.61   0.206 

 

    STN8          STN7          077 15 38.0   3.000  -000 00 02.61   0.872 

 

    STN7          STN9          155 30 36.9   3.000  -000 00 01.07   0.358 

 

    STN7          STN9          155 30 35.0   3.000  +000 00 00.92  -0.309 

 

    STN7          STN6          079 57 03.9   3.000  -000 00 01.05   0.351 

 

    STN7          STN6          079 57 05.0   3.000  -000 00 02.05   0.684 
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    STN6          STN9          284 25 27.0   3.000  +000 00 00.90  -0.301 

 

    STN6          STN9          284 25 29.0   3.000  -000 00 01.09   0.365 

 

    STN6          STN5          199 20 14.0   3.000  -000 00 03.36   1.121 

 

    STN6          STN5          199 20 10.0   3.000  +000 00 00.63  -0.213 

 

    STN5          STN9          323 06 25.0   3.000  +000 00 00.91  -0.303 

 

    STN5          STN9          323 06 26.0   3.000  -000 00 00.08   0.030 

 

    STN5          STN4          163 01 38.0   3.000  -000 00 02.54   0.850 

 

    STN5          STN4          163 01 35.9   3.000  -000 00 00.54   0.183 

 

    STN4          TEM2          305 29 03.0   3.000  -000 00 00.00   0.000 

 

    STN4          TEM1          269 43 06.0   3.000  -000 00 00.00   0.000 

 

    STN4          TEM1          269 43 06.0   3.000  -000 00 00.00   0.000 

 

    STN4          TEM2          305 29 03.0   3.000  -000 00 00.00   0.000 

 

    STN4          STN2          085 23 01.0   3.000  -000 00 01.50   0.502 

 

    STN4          STN2          085 23 01.0   3.000  -000 00 01.50   0.502 

 

    STN2          STN4          269 44 39.0   3.000  +000 00 00.34  -0.115 

 

    STN2          STN1          090 15 21.0   3.000  -000 00 00.34   0.115 

 

    STN2          STN1          090 15 23.0   3.000  -000 00 02.34   0.781 

 

    Horizontal Distances

    At Station    To Station    Distance    StdErr   Residual   StdRes

    ------------  ------------  ----------  ------  ----------  ------

    STN1          STN8              59.593   0.005    0.000692  -0.135   

    STN1          STN8              59.594   0.005   -0.000348   0.068   

    STN8          STN1              59.593   0.005    0.000649  -0.127   

    STN8          STN7              23.107   0.005   -0.000509   0.101   

    STN8          STN7              23.107   0.005    0.000358  -0.071   

    STN8          STN1              59.594   0.005   -0.000283   0.055   

    STN7          STN8              23.106   0.005    0.000475  -0.094   
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    STN7          STN9              46.243   0.005    0.002698  -0.530   

    STN7          STN9              46.244   0.005    0.001672  -0.328   

    STN7          STN6              23.052   0.005   -0.000284   0.056   

    STN7          STN6              23.052   0.005   -0.000277   0.055   

    STN7          STN8              23.108   0.005   -0.001375   0.272   

    STN6          STN7              23.052   0.005   -0.000291   0.058   

    STN6          STN9              46.241   0.005    0.000829  -0.163   

    STN6          STN9              46.242   0.005   -0.000144   0.028   

    STN6          STN5              65.341   0.005   -0.003070   0.598   

    STN6          STN5              65.339   0.005   -0.001065   0.208   

    STN6          STN7              23.054   0.005   -0.002290   0.454   

    STN5          STN6              65.339   0.005   -0.001078   0.210   

    STN5          STN9              76.745   0.005    0.001273  -0.247   

    STN5          STN9              76.744   0.005    0.002205  -0.428   

    STN5          STN4              41.456   0.005    0.000916  -0.180   

    STN5          STN4              41.458   0.005   -0.001084   0.213   

    STN5          STN6              65.340   0.005   -0.002070   0.403   

    STN4          STN5              41.457   0.005   -0.000081   0.016   

    STN4          TEM2               9.480   0.005    0.000000  -0.000   

    STN4          TEM1              18.165   0.005    0.000000  -0.000   

    STN4          TEM1              18.165   0.005    0.000000  -0.000   

    STN4          TEM2               9.480   0.005    0.000000  -0.000   

    STN4          STN2              25.340   0.005    0.000528  -0.104   

    STN4          STN2              25.340   0.005    0.000528  -0.104   

    STN4          STN5              41.457   0.005   -0.000081   0.016   

    STN2          STN4              25.339   0.005    0.001509  -0.299   

    STN2          STN4              25.342   0.005   -0.001435   0.284   

  Number of observations : 65

  Number of unknowns : 20

  Number of redundant obs : 45

  Reference variance : 0.15305

  Reference standard deviation So : 0.41621

Failed Chi-Square test at 95% level; exceeded lower bound (0.00)

     Error ellipses

                          Standard         At 90% conf.      At 95% conf.  

  At 99% conf.

Station    Angle (t)     Su       Sv       Su       Sv       Su       Sv   

  Su       Sv     

--------  -----------  -------  -------  -------  -------  -------  -------
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-------  -------

STN1      090 00 00.0  0.00165  0.00147  0.00362  0.00324  0.00416  0.00373

0.00526  0.00470

STN2      090 00 00.0  0.00165  0.00147  0.00362  0.00324  0.00416  0.00373

0.00526  0.00470

STN4      153 35 55.0  0.00169  0.00164  0.00372  0.00360  0.00428  0.00414

0.00540  0.00523

STN5      122 51 06.3  0.00172  0.00165  0.00379  0.00363  0.00436  0.00417

0.00551  0.00527

STN6      141 06 05.8  0.00171  0.00165  0.00377  0.00363  0.00433  0.00417

0.00547  0.00527

STN7      136 49 35.9  0.00174  0.00166  0.00382  0.00366  0.00440  0.00421

0.00555  0.00532

STN8      109 06 07.7  0.00172  0.00152  0.00378  0.00335  0.00435  0.00385

0.00549  0.00486

STN9      173 25 53.7  0.00175  0.00169  0.00385  0.00372  0.00442  0.00428

0.00558  0.00540

TEM1      002 32 44.1  0.00224  0.00166  0.00493  0.00365  0.00567  0.00420

0.00715  0.00530

TEM2      038 17 50.0  0.00221  0.00168  0.00487  0.00370  0.00560  0.00425

0.00707  0.00537

    Height residuals

    At Station    To Station      HtDiff    StdErr   Residual   StdRes

    ------------  ------------  ----------  ------  ----------  ------

    STN1          STN8               4.486   0.003    0.000000   0.000   

    STN1          STN8               4.486   0.003    0.000945   0.315   

    STN8          STN1              -4.485   0.003    0.000442   0.147   

    STN8          STN7              -8.030   0.003    0.000000   0.000   

    STN8          STN7              -8.030   0.003    0.000190   0.063   

    STN8          STN1              -4.486   0.003    0.000475   0.158   

    STN7          STN8               8.030   0.003    0.001027   0.342   

    STN7          STN9             -10.147   0.003   -0.000752  -0.251   

    STN7          STN9             -10.147   0.003   -0.000607  -0.202   

    STN7          STN6               0.711   0.003   -0.001565  -0.522   

    STN7          STN6               0.711   0.003   -0.001555  -0.518   

    STN7          STN8               8.031   0.003    0.001349   0.450   

    STN6          STN7              -0.711   0.003    0.001573   0.524   

    STN6          STN9             -10.858   0.003    0.000161   0.054   

    STN6          STN9             -10.858   0.003   -0.001042  -0.347   

    STN6          STN5               0.881   0.003   -0.003018  -1.006   

    STN6          STN5               0.881   0.003   -0.003247  -1.082   

    STN6          STN7              -0.711   0.003    0.003264   1.088   
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    STN5          STN6              -0.879   0.003    0.003554   1.185   

    STN5          STN9             -11.728   0.003   -0.001104  -0.368   

    STN5          STN9             -11.727   0.003   -0.001934  -0.645   

    STN5          STN4               0.666   0.003    0.004431   1.477   

    STN5          STN4               0.666   0.003    0.004954   1.651   

    STN5          STN6              -0.880   0.003    0.000505   0.168   

    STN4          STN5              -0.666   0.003    0.000537   0.179   

    STN4          TEM2              -0.774   0.003   -0.002581  -0.860   

    STN4          TEM1              -0.804   0.003   -0.000453  -0.151   

    STN4          TEM1              -0.804   0.003    0.000000   0.000   

    STN4          TEM2              -0.774   0.003    0.000000   0.000   

    STN4          STN2               2.671   0.003   -0.000000  -0.000   

    STN4          STN2               2.671   0.003   -0.000000  -0.000   

    STN4          STN5              -0.666   0.003    0.000480   0.160   

    STN2          STN4              -2.671   0.003    0.000480   0.160   

    STN2          STN4              -2.671   0.003   -0.000453  -0.151   

Network contains 11 legs

From     To         Comp Length  Meas.Length  Difference  Comp dHt  Meas

dHt  Diff dHt  Obs  Type    Bearing

----     --         -----------  -----------  ----------  -------- 

--------  --------  ---  ----    -------

STN8     STN1           59.594        59.594      0.0001    4.4854   

4.4859   -0.0005  4    Loose   294 47 15.4

STN8     STN7           23.107        23.107     -0.0003    8.0306   

8.0301    0.0005  4    Loose   012 02 50.8

STN7     STN9           46.246        46.243      0.0022   10.1452  

10.1468   -0.0016  2    Closed  347 33 26.7

STN7     STN6           23.052        23.053     -0.0008    0.7097   

0.7110   -0.0013  4    Closed  271 59 53.7

STN6     STN9           46.242        46.242      0.0004   10.8549  

10.8580   -0.0031  2    Closed  016 25 21.6

STN6     STN5           65.338        65.340     -0.0018    0.8775   

0.8803   -0.0028  4    Closed  291 20 04.3

STN5     STN9           76.746        76.745      0.0018   11.7324  

11.7277    0.0047  2    Closed  074 26 30.3

STN5     STN4           41.457        41.457     -0.0000    0.6653   

0.6658   -0.0005  4    Closed  274 21 39.8

STN4     TEM2            9.480         9.480     -0.0000    0.7740   

0.7740    0.0000  2    Closed  039 50 42.8

STN4     TEM1           18.165        18.165     -0.0000    0.8039   

0.8039    0.0000  2    Closed  004 04 45.8

STN4     STN2           25.340        25.340      0.0003    2.6706   

2.6711   -0.0005  4    Loose   179 44 39.3
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Total length 434.767, total length misclosure 0.008, total height

misclosure 0.0154

Length after removing fixed legs 434.767, misclosure 0.008, height

misclosure 0.0154

Length after removing fixed and loose legs 326.726, misclosure 0.007,

height misclosure 0.0140, equivalent linear accuracy 1:47115.3

(This result only takes into account closed loops, and legs on sections

that lie between fixed stations,

 It provides the best equivalent to a Bowditch adjusted result)

     Relative Error ellipses and standard errors of computed quantities

between points

                                     Ellipse details              Std

Errors

From Station  To Station       Angle (t)     Su       Sv       Direction   

Dist.

------------  ------------  -------------  -------  -------  ------------- 

-----

STN1          STN2           090 00 00.0  0.00353  0.00000   000 00 00.0 

0.00353

STN1          STN4           005 25 09.0  0.00355  0.00192   000 00 06.0 

0.00346

STN1          STN5           010 13 44.7  0.00300  0.00185   000 00 13.7 

0.00274

STN1          STN6           014 47 45.8  0.00244  0.00194   000 00 11.2 

0.00242

STN1          STN7           027 32 06.8  0.00236  0.00197   000 00 07.1 

0.00229

STN1          STN8           024 41 58.0  0.00237  0.00056   000 00 01.9 

0.00237

STN1          STN9           035 05 42.3  0.00253  0.00210   000 00 07.9 

0.00213

STN1          TEM1           272 15 29.8  0.00405  0.00358   000 00 10.3 

0.00371

STN1          TEM2           060 51 30.2  0.00456  0.00286   000 00 12.4 

0.00343

STN2          STN4           270 30 28.2  0.00194  0.00020   000 00 01.6 

0.00194

STN2          STN5           009 08 21.5  0.00243  0.00188   000 00 09.2 

0.00224

STN2          STN6           009 12 31.4  0.00280  0.00195   000 00 03.9 

0.00279

STN2          STN7           008 05 48.0  0.00307  0.00203   000 00 03.3 

0.00306

STN2          STN8           001 45 45.0  0.00314  0.00111   000 00 02.0 

0.00310

STN2          STN9           079 07 27.9  0.00294  0.00223   000 00 03.7 

0.00292



331

©2018 Atlas Computers Ltd

STN2          TEM1           273 35 01.4  0.00406  0.00040   000 00 02.0 

0.00405

STN2          TEM2           302 20 09.0  0.00389  0.00113   000 00 11.1 

0.00363

STN4          STN5           004 19 34.1  0.00242  0.00046   000 00 02.2 

0.00242

STN4          STN6           008 08 05.1  0.00281  0.00122   000 00 02.4 

0.00280

STN4          STN7           008 55 15.8  0.00309  0.00141   000 00 02.2 

0.00308

STN4          STN8           001 36 05.7  0.00314  0.00204   000 00 03.4 

0.00302

STN4          STN9           087 59 51.4  0.00291  0.00159   000 00 02.8 

0.00290

STN4          TEM1           274 04 45.8  0.00356  0.00027   000 00 03.1 

0.00356

STN4          TEM2           309 50 42.8  0.00355  0.00014   000 00 03.1 

0.00355

STN5          STN6           020 55 55.7  0.00171  0.00081   000 00 02.5 

0.00171

STN5          STN7           016 13 45.1  0.00220  0.00103   000 00 02.4 

0.00220

STN5          STN8           088 14 48.6  0.00225  0.00194   000 00 04.5 

0.00216

STN5          STN9           071 16 18.2  0.00193  0.00120   000 00 03.2 

0.00193

STN5          TEM1           274 38 14.7  0.00359  0.00243   000 00 15.6 

0.00265

STN5          TEM2           053 07 57.5  0.00392  0.00181   000 00 18.6 

0.00275

STN6          STN7           005 32 45.6  0.00096  0.00029   000 00 02.6 

0.00096

STN6          STN8           287 31 10.2  0.00195  0.00100   000 00 11.8 

0.00138

STN6          STN9           287 13 53.2  0.00129  0.00075   000 00 03.3 

0.00129

STN6          TEM1           271 42 35.4  0.00377  0.00283   000 00 06.8 

0.00299

STN6          TEM2           055 26 04.4  0.00409  0.00229   000 00 07.2 

0.00303

STN7          STN8           281 15 12.8  0.00195  0.00028   000 00 02.4 

0.00195

STN7          STN9           167 20 09.1  0.00128  0.00072   000 00 03.2 

0.00128

STN7          TEM1           179 29 50.3  0.00384  0.00310   000 00 05.8 

0.00320

STN7          TEM2           058 21 22.6  0.00421  0.00251   000 00 05.8 

0.00338
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STN8          STN9           275 28 07.0  0.00222  0.00101   000 00 03.2 

0.00219

STN8          TEM1           277 14 23.0  0.00411  0.00316   000 00 05.9 

0.00332

STN8          TEM2           053 10 54.9  0.00443  0.00264   000 00 06.6 

0.00308

STN9          TEM1           281 05 10.2  0.00392  0.00289   000 00 07.0 

0.00293

STN9          TEM2           053 15 00.4  0.00430  0.00223   000 00 05.5 

0.00385

TEM1          TEM2           291 56 08.9  0.00479  0.00156   000 01 02.6 

0.00352

Traverse Observation Spreadsheet

You will also notice that on the View menu in the traverse observations spreadsheet, there
are additional commands to better organize the spreadsheet for specific tasks.  These are
as follows;

'VIEW >  Layout >  All observed and reduced data (3d)

'VIEW >  Layout >  All observed and reduced data (2d)'

'VIEW >  Layout >  Reduced observations (3d)'

'VIEW >  Layout >  Reduced observations (2d)'
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'VIEW >  Layout >  Reduced levels only'

The observed options correspond to the layout available in previous versions of SCC, where
the 2d option removes the instrument height, rod height and height difference fields.  The
reduced observations options show forward measured angles, horizontal distances, height
differences, known bearings, and their corresponding standard errors.  The reduced level
option only shows height and distance information, again with standard errors, where
distances may be used to calculate relative weights as an alternative to entering standard
errors.

Constraint Adjustment

Standard errors in any of these views correspond to observation weights or accuracies, thus
if I know a height difference is good to +> - 3mm I enter 3.0 in the –Err- field that follows the
 –Ht Diff- field.  I can also use the modify the Obs. Type field to fix a height difference,
horizontal distance, angle or bearing to further constrain the adjustment.  For example, in
the report above, you will notice a fixed bearing between STN1 and STN2 of 270 degrees,
such if the coordinates are moved during the adjustment, the bearing between them will be
fixed at 270 degrees.
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The content of the report will also be modified by the type of adjustment selected.  For
example, if we open 2d-example.project and 2d-example.traverse, and adjust using the
parameters given, we get the report shown below.

SCC for Windows v9.9.0 (C) 1990 - 2009 Atlas Computers Ltd

   Traverse adjustment report

   Title   2d-EXAMPLE.Traverse

   Date    Thu Jun 03 10:25:59 2010

   Coordinate adjustment method  Variation of Co-ordinates

   Corrections applied

   -------------------

   Local scale factor : No local scale factor

   Earth curvature and refraction : Curvature only  (Earth Radius

6380000.000)

   Temperature and pressure : No 

   Mean sea level correction : No 

    Default Standard Errors

    Angles (secs)            : 3.000

    Distances (constant mm)  : 5.000

    Distances (ppm mm)       : 2.000

    Heights (mm)             : 3.000

    Provisional coordinates

    Name                    E> X       StdErr        N> Y       StdErr 

Type

    ----------------  --------------  ------  --------------  ------  ----

    1A                   10000.00000  0.1800     10000.00000  0.1800  Cons

    2C                   12487.08000  0.1800     10528.65000  0.1800  Cons
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    3B                   10862.48000  0.0000     11103.93000  0.0000  Prov

    4D                   11990.88000  0.0000      9387.46000  0.0000  Prov

    5E                   10948.55000  0.0000      9461.90000  0.0000  Prov

    6F                   11595.22000  0.0000     10131.56000  0.0000  Prov

    Adjusted coordinates

    Name                    E> X         Adj         N> Y         Adj

    ----------------  --------------  -------  --------------  -------

    1A                    9999.99844  -0.0016      9999.99967  -0.0003

    2C                   12487.08156  +0.0016     10528.65033  +0.0003

    3B                   10862.48289  +0.0029     11103.93327  +0.0033

    4D                   11990.88203  +0.0020      9387.46189  +0.0019

    5E                   10948.54878  -0.0012      9461.89972  -0.0003

    6F                   11595.22309  +0.0031     10131.56264  +0.0026

    Horizontal Distances

    At Station    To Station    Distance    StdErr   Residual   StdRes

    ------------  ------------  ----------  ------  ----------  ------

    1A            3B              1400.910   0.023    0.000000  -0.000   

    1A            5E              1090.550   0.022   -0.000030   0.001   

    3B            2C              1723.450   0.023   -0.002524   0.110   

    2C            6F               976.260   0.022    0.003354  -0.152   

    2C            4D              1244.400   0.023   -0.002556   0.111   

    3B            5E              1644.290   0.023   -0.002432   0.106   

    3B            6F              1217.540   0.022    0.003779  -0.172   

    4D            6F               842.750   0.022    0.002603  -0.118   

    4D            5E              1044.990   0.022   -0.002160   0.098   

    5E            6F               930.930   0.022    0.002896  -0.132   

  Number of observations : 14

  Number of unknowns : 12

  Number of redundant obs : 2

  Reference variance : 0.00995

  Reference standard deviation So : 0.25426

Failed Chi-Square test at 95% level; exceeded lower bound (0.99)

     Error ellipses

                          Standard         At 90% conf.      At 95% conf.  

  At 99% conf.

Station    Angle (t)     Su       Sv       Su       Sv       Su       Sv   

  Su       Sv     

--------  -----------  -------  -------  -------  -------  -------  -------

-------  -------
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1A        168 00 00.0  0.04577  0.03262  0.19417  0.13841  0.28212  0.20111

0.64398  0.45906

2C        168 00 00.0  0.04577  0.03262  0.19417  0.13841  0.28212  0.20111

0.64398  0.45906

3B        065 31 18.2  0.04029  0.03284  0.17093  0.13931  0.24835  0.20241

0.56690  0.46203

4D        049 54 36.3  0.04407  0.03298  0.18696  0.13993  0.27164  0.20331

0.62006  0.46410

5E        110 24 33.2  0.03931  0.03297  0.16680  0.13986  0.24235  0.20321

0.55321  0.46386

6F        017 58 02.5  0.03427  0.03289  0.14538  0.13956  0.21123  0.20277

0.48217  0.46286

Network contains 10 legs

From     To         Comp Length  Meas.Length  Difference  Comp dHt  Meas

dHt  Diff dHt  Obs  Type    Bearing

----     --         -----------  -----------  ----------  -------- 

--------  --------  ---  ----    -------

1A       3B           1400.910      1400.910     -0.0000    0.0000   

0.1538   -0.1538  1    Closed  038 00 00.0

1A       5E           1090.550      1090.550     -0.0000    0.0000   

0.0932   -0.0932  1    Closed  119 33 56.3

3B       2C           1723.448      1723.450     -0.0025    0.0000   

0.2328   -0.2328  1    Closed  109 29 58.0

2C       6F            976.263       976.260      0.0034    0.0000   

0.0747   -0.0747  1    Closed  245 59 58.7

2C       4D           1244.397      1244.400     -0.0025    0.0000   

0.1214   -0.1214  1    Closed  203 30 00.0

3B       5E           1644.288      1644.290     -0.0025    0.0000   

0.2119   -0.2119  1    Closed  176 59 58.6

3B       6F           1217.544      1217.540      0.0038    0.0000   

0.1162   -0.1162  1    Closed  143 00 00.0

4D       6F            842.753       842.750      0.0026    0.0000   

0.0557   -0.0557  1    Closed  331 59 57.0

4D       5E           1044.988      1044.990     -0.0021    0.0000   

0.0856   -0.0856  1    Closed  274 05 05.3

5E       6F            930.933       930.930      0.0029    0.0000   

0.0679   -0.0679  1    Closed  043 59 58.1

Total length 12116.073, total length misclosure 0.022, total height

misclosure 1.2131

Length after removing fixed legs 12116.073, misclosure 0.022, height

misclosure 1.2131

Length after removing fixed and loose legs 12116.073, misclosure 0.022,

height misclosure 1.2131, equivalent linear accuracy 1:543380.1

(This result only takes into account closed loops, and legs on sections

that lie between fixed stations,

 It provides the best equivalent to a Bowditch adjusted result)

     Relative Error ellipses and standard errors of computed quantities
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between points

                                     Ellipse details              Std

Errors

From Station  To Station       Angle (t)     Su       Sv       Direction   

Dist.

------------  ------------  -------------  -------  -------  ------------- 

-----

1A            2C             168 00 00.0  0.25456  0.03248   000 00 20.6 

0.03248

1A            3B             037 35 51.5  0.14265  0.02294   000 00 21.0 

0.02296

1A            4D             287 21 04.3  0.21004  0.03043   000 00 20.7 

0.03045

1A            5E             299 58 18.0  0.11276  0.02195   000 00 21.3 

0.02197

1A            6F             175 23 29.0  0.16214  0.03288   000 00 20.8 

0.03289

2C            3B             289 39 00.5  0.17420  0.02189   000 00 20.8 

0.02190

2C            4D             023 17 43.6  0.12781  0.02187   000 00 21.1 

0.02188

2C            5E             145 13 31.4  0.18896  0.02576   000 00 20.8 

0.02576

2C            6F             156 01 43.1  0.10082  0.01989   000 00 21.3 

0.01989

3B            4D             056 44 21.1  0.20791  0.02565   000 00 20.8 

0.02565

3B            5E             086 56 01.1  0.16688  0.02192   000 00 20.9 

0.02192

3B            6F             053 02 37.5  0.12493  0.01934   000 00 21.1 

0.01934

4D            5E             274 15 14.6  0.10831  0.02117   000 00 21.3 

0.02117

4D            6F             062 14 51.0  0.08875  0.02078   000 00 21.7 

0.02078

5E            6F             043 47 19.3  0.09675  0.02043   000 00 21.4 

0.02044

Similarly, to adjust a level network we can turn off the horizontal adjustment.  For example,
if we open Level-example.project and Level-example.traverse, and adjust using the
parameters given, we get the report shown below.

SCC for Windows v9.9.0 (C) 1990 - 2009 Atlas Computers Ltd

   Traverse adjustment report

   Title   LevelAdjust.Traverse

   Date    Thu Jun 03 10:30:03 2010

   Height adjustment method  Least Squares (Default weighting)

   Corrections applied
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   -------------------

   Local scale factor : No local scale factor

   Earth curvature and refraction : Curvature only  (Earth Radius

6380000.000)

   Temperature and pressure : No 

   Mean sea level correction : No 

    Default Standard Errors

    Heights (mm)             : 2.000

    Provisional heights

    Name                   Ht> Z       StdErr  Type

    ----------------  --------------  ------  ----

    BMX                    100.00000  0.0050  Cons

    BMY                    107.50000  0.0000  Fix 

    A                      105.10000  0.0000  Prov

    C                      106.25000  0.0000  Prov

    B                      104.42000  0.0000  Prov

    Adjusted heights

    Name                   Ht> Z         Adj

    ----------------  --------------  -------

    BMX                    100.07566  +0.0757

    BMY                    107.50000  +0.0000

    A                      105.17338  +0.0734

    C                      106.22004  -0.0300

    B                      104.50447  +0.0845

    Height residuals

    At Station    To Station      HtDiff    StdErr   Residual   StdRes

    ------------  ------------  ----------  ------  ----------  ------

    BMX           A                  5.100   0.002    0.002282   1.141   

    A             BMY                2.340   0.002    0.013378   6.689*  

    BMY           C                 -1.250   0.002    0.029957  14.978*  

    C             BMX               -6.130   0.002    0.014387   7.193*  

    A             B                 -0.680   0.002   -0.011096  -5.548*  

    BMY           B                 -3.000   0.002   -0.004473  -2.237   

    B             C                  1.700   0.002   -0.015570  -7.785*  

In all of the least square adjustment reports, we will see equations listed in the form
Stations used, observed value, standard error, observation residual, and standard residual. 
The standard error equates to how accurate you thought the observation was (e.g. a-priori
value), whereas the residual corresponds to how much the observation was actually
changed to reflect the adjusted station values (e.g. a-posteriori value).  The standard
residual is obtained by dividing the standard error by the observation residual, and as such
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should be close to one if the standard errors given match the residuals produced.  High
values for the standard residual are flagged with an asterisk, indicating lack of agreement
between observations and standard errors given.  Fixed observations will be marked as
(Fixed) in the report and the standard residual forced to one.

If the average value of the standard residuals is more than 1, your observations are not as
accurate as stated.  If one observation has a particularly high standard residual, it should be
checked.  If the average values of all standard residuals are much less than one, the
standard errors entered are two high, which in turn means the adjustment has been given
too much freedom to move the stations.  Either of these events will tend to trigger a failure
to pass the chi-squared test, which is essentially a statistical analysis of the standard
residuals.

Traverse And Error Ellipse Annotation

'VIEW >  Station coordinates'

'FILE >  Export >  Station Coordinates as dataset'

'FILE >  Save As', and give the stations a name, typically corresponding to the project name

'FILE >  Model >  SCC dataset', picking the dataset produced

'FILE >  Attach> Detach >  Attach traverse'

'EDIT >  Text >  Annotate traverse', to add annotation for stations and legs as required.  You will
need to use this command twice if you wish to annotate both station and traverse leg information

The following features are used to control display of ellipses

~RELELLI Corresponds to relative ellipses drawn along legs

~ERRELLI Corresponds to error ellipses at stations

Ellipse scale and relative ellipse content can be set using 'FILE >  Attach/ Detach'
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23 Working With Trimble Data

The following tutorial provides information relating to the downloading and processing of Trimble
data within SCC.

23.1 Create A Project

A new project should be created before data may be downloaded into SCC or models
formed.

From the Main Menu Bar, select ‘FILE >New Project’

Enter in a Project/Job name

Select a Project Template from the list 

Select ‘OK’

23.2 Download Trimble Data from ACU

Trimble ACU Output

SCC support downloading files from the Trimble ACU, running Tsce software, using the
SDR33 output format.  These attributes can be used to describe dimensions, offsets,
parallel features, and all other items available through the SCC extended coding library.  We
will demonstrate the use of this facility through the sample file 060228D.DAT.  Note that in
this file, Tsce attributes are stored in 13AT records, see extract below for an example;

2NM        9020   

308417.642000000231995.58500000051.33300000000001.50000000000000              

07NM        9020            9021    27.900185437685727.9001854376857

03NM1.70000000000000

09F1        9020            9021   

12.874430000000088.109739263113027.9001854376857STN           

09F1        9020            1001   

18.593340000000088.669171829746923.1694290000000BG            

13ATOffset              0.30000000000000                        

09F1        9020            1002   

17.165240000000088.759832243491514.1117367500000BG    
          

To process this file in SCC,  amendments must be made to the default project template as
follows;

From within the Project, select Import / View SDR translation table

Add a record for each attribute type present in the Tsce format being used.  For example,
for the OFFSET attribute, we add a new record with the name and code of OFFSET,  type
of ‘Control Code with Parameter (CCP)’, and SDR Control type of ‘Par Ofs L/R’.  This means
that when SCC encounters an attribute called OFFSET, it will take the attribute value and
store it in the parallel offset field in SCC.  For this job, the rest of the records will be as
follows;
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Note that regular features that contain embedded string numbers should also appear in this
sheet with a type of ‘PC’ and a PntInFtr setting of ‘String’.  This sheet can also be used to
control default tag and DTM codes for these features.

Once you have completed editing this translation table, you should save the project as a
new template in the SCC folder, such that you do not have to repeat this exercise.

From the Main Menu Bar, select ‘FILE > Download Survey Data’

Set Survey Data logger to 'Trimble TSC/TSCe (DC)' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk' 

Select 'OK'

Select '060228D.Dat' from '\SCC\Tutorials' directory

Select 'Open'

Select 'OK'
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Set 'SDRMap Coding Extensions' and 'Search remarks for dimensions'

Select 'OK'

This will generate the following detail survey file;

*.DC files from TSCE containing observations in DC formats as defined in DC10.70 or DC7.5
are also supported.  Observations must be in HA,Va,Sd or X,Y,Z formats.  SCC does not
currently read GPS vectors, or GPS lat,long, height records from this format.

Combined Total Station & GPS Files Trimble Data

SCC supports the download of combined Total Station and GPS information contained
within one complete file.  

Total Station Detail

08PD        1853    240109.491174308230536.45323307880.5785407722807CONC2       

  

08PD        1854    240106.941616718230533.14415286880.4446191824330CONC2       

  

08PD        1855    240106.934895243230533.12155861780.4350418868451K2          

  

08PD        1856    240103.591644851230535.66377808680.3671757765827K2          

  

08PD        1857    240102.973759388230536.67287284980.3818527249702K2          
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08PD        1858    240102.946912372230537.66137346080.3672869395576K2          

  

08PD        1859    240108.024260067230544.61543070080.4062528838890K2          
    

GPS Data

09F1        S4              1871   

19.485780000000086.2995339500897308.269300500000SL            

09F1        S4              1872   

20.122220000000086.2101823251036306.161937000000HE3           

13NMOFFSET HE3 2.0M LEFT                                        

09F1        S4              1873   

26.350400000000086.0417014778084314.111125500000HE3           

09F1        S4              1874   

36.881090000000086.4799984710826316.234896000000HE3           

09F1        S4              1875   

45.070550000000086.8506673231004318.345708000000HE3           

09F1        S4              1876   

56.991010000000087.4670758972154318.269134018868HE3           

09F1        S4              1877   

58.376750000000087.5556657440944316.922418000000EP            

09F1        S4              1878   

60.863180000000087.5235304357424318.604251600000B10           

09F1        S4              1879   

60.548220000000087.5381532946088326.509790400000B10   

        
From the Main Menu Bar, select ‘FILE > Download Survey Data’

Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk' 

Select 'OK'

Select 'RAWsdr33dc.dc' from '\SCC\Tutorials' directory

Select 'Open'

Select 'OK'
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Set 'Search remarks for dimensions'

Select 'OK'

Note that the option to strip string numbers from field codes has bee selected with the
'Coordinate Reduction Options'.

Trimble DC Format

SCC also supports the direct download of DC format as follows:

D2NM1021.70000000000                0.14200000000000                

69FD        S22     137412.769000000253513.23000000046.1450000000000CON 

          11

E0NM        S22     1.620000000000001.000000000000001

E1NM        S22             S21                     190.187083794199    



345

©2018 Atlas Computers Ltd

          

 77NM1.500000000000002.000000000000000.00000000000000

D9F1        S22             S21   

91.250749347157591.8136377610403190.187083794199CON             

50.003182501540000.001388888888890.00138888888889

A6F1                -0.00090101528280.00846784874555

D9F1        S22             1     

90.790027562819091.9271004383258190.244880000000S               

10.010181580100000.001388888888890.00138888888889

D9F1        S22             2     

90.795487574480291.9263806245318190.249560000000S               

10.010181591020000.001388888888890.00138888888889

 77NM2.000000000000002.000000000000000.00000000000000

  10.010192322360000.001388888888890.00138888888889

D9F1        S22             8001  

86.761130395951992.3277570859462213.880050000000HEC1            

10.010173522320000.001388888888890.00138888888889

D9F1        S22             8002  

77.753634782899292.0915956056461219.797010000000HEC1           

10.010155507320000.001388888888890.00138888888889

 77NM1.500000000000002.000000000000000.00000000000000

D9F1        S22             8003  

73.815260826027192.3056179106150224.597520000000HEC1            

10.010147630580000.001388888888890.00138888888889

D9F1        S22             8004  

68.620739011095391.8354586405055234.321300000000HEC1            

10.010137241520000.001388888888890.00138888888889

D9F1        S22             8005  

64.289547497628291.1620741098151249.494310000000HEC1            

 10.010128579120000.001388888888890.00138888888889

From the Main Menu Bar, select ‘FILE > Download Survey Data’

Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk' 

Select 'OK'

Select File

Select 'Open'

Select 'OK'
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Set 'Search remarks for dimensions'

Select 'OK'

Trimble/Geodimeter UDS

SCC supports Trimble/Geodimeter format and can be processed as follows:

From the Main Menu Bar, select ‘FILE > Download Survey Data’

Set Survey Data Logger  to 'Trimble/Geodimeter UDS'

Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type

Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required

Select ‘OK’

Select the file you require and ‘OK’

Additional settings may be checked at this stage that relate to the field coding standards
used that are particular to a given instrument. Note that these settings will become the
defaults for all future downloads from the Geodimeter and do not have to be entered with
each download.
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Codes 90 through to 99 in the Geodimeter are user definable and may be used log extra
dimensions in SCC. For existing ‘Landscape’ users, the first time we download into SCC,
we will also have to set up the coding options as shown above. The LandScape coding
options determine how the numeric field codes entered in the instrument will be translated
into SCC tag codes, DTM codes, and ancillary measurements based on existing ‘
Landscape’ techniques.

SCC lets us freely mix data from a range of different instrument manufacturers and
instrument types within a given project. The LandScape processing options are currently
enabled for the Geodimeter and Leica instruments.
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Transferring survey data from a Geodimeter CU

Connect the Geodimeter instrument/keyboard to the PC with the appropriate cable and through
the correct communications port. Enter program 54, for data transfer.

Choose from which device the data will be transferred from Internal memory (2. Imem) or
Serial (3. Serial).  Select internal memory (2. Imem).

Select the file type for transfer from 1. Job (file), 2. Area (file), 3. U.D.S.  Choose option number
1 -  Job file, and type in the job file number in which the observed data is stored.

Choose destination device for the job file from 2. Imem (internal memory) and 3. Serial (serial
device - PC).  Select 3 - Serial and accept or enter the correct serial parameters, which are
Com=1.8.0.9600.  Prepare SCC(PC) before accepting the serial parameters because once the
serial parameters have been accepted then the data will be transferred.

The display on the Geodimeter/keyboard shows ‘Wait’ during the data transfer. When the data
transfer is finished the Geodimeter/keyboard will exit from program 54 and return to program
0.

Transferring Setting Out and Control data to a Geodimeter CU

Connect the Geodimeter instrument/keyboard to the PC with the appropriate cable and through
the correct communications port.  Enter program 54, for data transfer.

Choose from which device the data will be transferred from Internal memory (2. Imem) or
Serial (3. Serial).  Select  Serial  (3. Serial) and accept or enter correct serial parameters,
which are Com=1.8.0.9600 

Select file type for the data to be saved as  from 1. Job (file), 2. Area (file),  3. U.D.S.  Choose
option number 2 -  Area file, and type in the area file number in which the data is to be stored. 

The display on the Geodimeter/keyboard shows "Wait" and is now ready to receive data.  Start
the data transfer from SCC.  When the data has been transferred the Geodimeter/keyboard will
exit from program 54 and return to program 0.

23.3 Examination of Sample Code List For Trimble Unit

A sample feature code list 'ATLAS_AM_DCC_ALPHA.fal' is availalbe for use with Survey Pro
onboard software.  This codelist contains attributes such as dimensions, offsets, parallel
features.  The 'ATLAS_AM_DCC_ALPHA.fal' codelist should be used in conjunction
'Trimble_TSCE_ALPHA.Project' feature library in which all features coincide.

The following examines the feature library 'ATLAS_AM_DCC_ALPHA.fcl' within Trimble
Geomatics Office:

Open Trimble Geomatics Office Software, select 'Utilities > Feature and Attribute Editor'

Within the Feature and Attribute Editor' dialog, select 'FILE > Open'

Select 'ATLAS_AM_DCC_ALPHA.fcl' 
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Template Features

5 specific template features have been set up within Trimble Geomatics Office which all
other features are based.  As a result, the library can be quickly edited by amending or
changing the 5 main features on which all other features are based.

The following outlines each and details the attributes assigned:

'SO' Spot Height Feature set up as a 1pt Feature:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

SO Spot Height LINETAG G

DTM D

DIM1

REMARK

LOSLR

LOSFB

ZOFSUD

NOTE:

LINETAG - Line Connection Tag, DTM - DTM Status, DIM1 - Dimension 1, LOSLR - Line Of
Sight Offset Left / Right, LOSFB - Line Of Sight Offset Forward / Back, ZOFSUD - Elevation
Offest Up / Down
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All other 1 point Features have been set up based on 'SO'.

Therefore, if you double click on a 1 point feature in the Feature and Attribute Editor or right
click mouse on 1 point feature and then select 'Properties' you can see the 'Uses actions of
another feature' is set to 'SO'.  In the example below, Sign 1 point 'SGO' uses 'SO' :
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The following diagram demonstrates the relationship of the attributes within Trimble
Geomatics Office 'Feature and Attribute Editor' dialog and the actually screens from the
instrument showing the attribute: 

To globally edit all 1 point feature the feature 'SO' can be modified.

For instance, if you do not wish to have specific attributes assigned to a 1 point feature, the
feature 'SO' can be edited and in turn, all 1 point features based on 'SO' will be modified.
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'KT' Kerb Top Feature set up as a String:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

KT Kerb Top STRING 1

LINETAG S

DTM D

REMARK

DIM1

LOSLR

LOSFB

ZOFSUD

PARLR

PARFB

TAPELR

TAPEFB

COPYFEAT

COPYLR

COPYUD

NOTE:

STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK -
Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB -
Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR -
Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape Offset
Left / Right, TAPEFB - Tape Offset Forward / Back, COPYFEAT - Copy Feature, COPYLR -
Copy Feature Left / Right Offset, COPYFB - Copy Feature Forward / Back Offset
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All other strings have been set up based on 'KT'.

Therefore, if you double click on a string feature in the Feature and Attribute Editor or right
click mouse on string feature and then select 'Properties' you can see the 'Uses actions of
another feature' is set to 'KT'.  In the example below, Bottom of Bank string 'BB' uses 'KT' :
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The following diagram demonstrates the relationship of the attributes within Trimble
Geomatics Office 'Feature and Attribute Editor' dialog and the actually screens from the
instrument showing the attribute: 

To globally edit all string features, the feature 'KT' can be modified.

For instance, if you do not wish to have specific attributes assigned to a string, the feature
'KT' can be edited and in turn, all stings based on 'KT' will be modified.
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'MHRT' Manhole Feature set up as a 3 Point Rectangular:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

MHRT Manhole 3pt Rec LINETAG Rec3

DTM D

REMARK

DIM1

LOSLR

LOSFB

ZOFSUD

PARLR

PARFB

TAPELR

TAPEFB

NOTE:

STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK -
Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB -
Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR -
Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape Offset
Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 3 point rectangles have been set up based on 'MHRT'.

Therefore, if you double click on a 3 point rectangles feature in the Feature and Attribute
Editor or right click mouse on a 3 point rectangles feature and then select 'Properties' you
can see the 'Uses actions of another feature' is set to 'MHRT'.  In the example below,
Recycle Bin 3 point rectangle 'RBT' uses 'MHRT' :

To globally edit all 3 point rectangles features, the feature 'MHRT' can be
modified.
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'MHRW' Manhole Feature set up as a 2 Points plus Width:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

MHRT Manhole 3pt Rec LINETAG Rec2

DTM D

REMARK

DIM1

LOSLR

LOSFB

ZOFSUD

PARLR

PARFB

TAPELR

TAPEFB

NOTE:

STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK -
Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB -
Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR -
Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape Offset
Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 2 point plus width have been set up based on 'MHRW'.

Therefore, if you double click on a 2 point plus width feature  in the Feature and Attribute
Editor or right click mouse on 2 point plus width feature and then select 'Properties' you can
see the 'Uses actions of another feature' is set to 'MHRW'.  In the example below, Recycle
Bin 3 point rectangle 'RBW' uses 'MHRW' :

To globally edit all 2 point plus width features, the feature 'MHRW' can be
modified.
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'ARAHL' Arrow Ahead Left Feature set up as a 3 Points:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

ARAHL Arrow Ahead Left STRING 1

LINETAG S

DTM D

REMARK

DIM1

LOSLR

LOSFB

ZOFSUD

PARLR

PARFB

TAPELR

TAPEFB

COPYFEAT

COPYLR

COPYUD

NOTE:

STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK -
Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB -
Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR -
Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape Offset
Left / Right, TAPEFB - Tape Offset Forward / Back, COPYFEAT - Copy Feature, COPYLR -
Copy Feature Left / Right Offset, COPYFB - Copy Feature Forward / Back Offset
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All other 3 point features have been set up based on 'MHRW'.

Therefore, if you double click on a 3 point feature  in the Feature and Attribute Editor or right
click mouse on a 3 point feature and then select 'Properties' you can see the 'Uses actions
of another feature' is set to 'ARAHL'.  In the example below, Arrow Ahead Right 3 point
rectangle 'ARAHR' uses 'ARAHL :
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To globally edit all 3 point features, the feature 'ARAHL' can be modified.

'OE' Line Eircom Overhead Feature set up as a 2D (Approx Elevation)
String:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

OE Eircom Overhead STRING 1

LINETAG S

DTM A

REMARK

DIM1

LOSLR

LOSFB

ZOFSUD

PARLR

PARFB

TAPELR

TAPEFB

NOTE:

STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK -
Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB -
Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR -
Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape Offset
Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 2D string features have been set up based on 'OE'.

Therefore, if you double click on a 2D string feature in the Feature and Attribute Editor or
right click mouse on a 2D string feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'OESB'.  In the example below, ESB Overhead 'OESB'
uses 'OE' :
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To globally edit all 2D string features, the feature 'OE' can be modified.

 'TO' Tree Feature set up as a 2D (Approx Elevation) 1 point feature with
specific Dimension Attributes for Canopy and Trunk Size:

FEATURE DESCRIPTION ATTRIBUTES DEFAULT VALUES

TO Tree LINETAG G

DTM A

DIM1

DIM2

DIM3

REMARK

LOSLR

LOSFB

ZOFSUD

NOTE:

LINETAG - Line Connection Tag, DTM - DTM Status, DIM1 - Dimension 1, DIM2 -
Dimension 2, DIM3 - Dimension 3, REMARK - Remark / Note, LOSLR - Line Of Sight Offset
Left / Right, LOSFB - Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up /
Down
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Examination of Feature File and Raw Data within SurveyPro software

The following screenshots have been captured from Survey Pro to demonstrate the attributes set
up in 'ATLAS_AM_DCC_ALPHA.fal'.  Three common survey field codes have been examined 'BB'
Bottom of Bank, 'SO' Spot Height and 'TO' Tree.  In turn, extracts from raw survey data are
displayed.  Note that, Tsce attributes are stored in 13AT records.

The drop down code list can be accessed within the main 'Measure Top' screen
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'BB' Bottom Of Bank String Feature and Attributes:

09F10003100034.698000090.7002777159.380833BB
13ATSTRING              1.00000000000000 
13ATLINETAG             S                                       
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13ATDTM                 A                                             
                           
13ATREMARK                                                      
13ATDIM1                0.00000000000000                        
13ATLOSLR               0.00000000000000                        
13ATLOSFB               0.00000000000000                        
13ATZOFSUD              0.00000000000000                              
        
13ATPARLR               0.00000000000000                        
13ATPARFB               0.00000000000000                        
13ATTAPELR              0.00000000000000                        
13ATTAPEFB              0.00000000000000                        
13ATCOPYFEAT                                                    
13ATCOPYLR              0.00000000000000                        
13ATCOPYUD              0.00000000000000 

'SO' Spot Height Point Feature and Attributes:

09F10450106819.867000090.5027777255.889444SO
13ATLINETAG             G                                       
13ATDTM                 E                                       
13ATDIM1                0.00000000000000                        
13ATREMARK                                                      
13ATLOSLR               0.00000000000000                        
13ATLOSFB               0.00000000000000                        
13ATZOFSUD              0.00000000000000  

'

TO' Tree Point Feature and Attributes:
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09F10450106738.205000090.0836111263.203611TO
13ATLINETAG             G                                       
13ATDTM                 A 
13ATREMARK              OAK                                           
                              
13ATDIM1                10.0000000000000                        
13ATDIM2                0.75000000000000                        
13ATDIM3                1.00000000000000                        
13ATLOSLR               0.00000000000000                        
13ATLOSFB               0.00000000000000                        
13ATZOFSUD              0.00000000000000 

Note:

Many attributes contain drop down menus.  For instance, several line connection tags
(tabulated below) which determines the connective geometry and specifies how the current
point on the string will be connected to the next point on the string are included as a drop
down menu. 

Alpha Code Description 

S Straight

C Curve

A Arc

G Gap

L Link Back To First Point on the String

DC Discontinuous Curve (Non-Tangential Incoming
Tangent from Straight to Curve)

DS Discontinuous Straight (Non-Tangential
Outcoming Tangent from Straight to Curve)

Ar3 Three Point Arc

Cr3 Three Point Circle

Cr2 Two Point Circle

C1R Radius and Centre Circle

Rec3 Three Point Rectangle

Rec2 Two Point and Width Rectangle
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In the same manner, common DTM (Digital Terrain Model) status code which determines
the significance of the point of the surface model / digital terrain model are set up (tabulated
below).  As such DTM controls whether the point is 2D or 3D, whether it should be used in
surface model generation and subsequent contouring and other surface analysis, and
whether it lies on a string forming the model boundary.

Alpha Code Description 

D DTM Elevation

A Approximate Elevation (2D Point)

E Non DTM Elevation 

I Ignore

X DTM Elevation with text turned off on download

23.4 Download Trimble Data with Specific Attributes

Processing & Download Steps:

To process a file containing information based 'ATLAS_AM_DCC_ALPHA.fal' within SCC:

From the Main Menu Bar, select ‘FILE >New Project’

Enter in a Project/Job name

Select a Project Template from the list 'Trimble_TSCE_ALPHA.Project'

Select ‘OK’

From the Main Menu Bar, select ‘FILE > Download Survey Data’

Set Survey Data logger to 'Trimble TSC/TSCe (DC)' 

Highlight ‘Detail Topography’ as the Data Type

Set Input Device to 'Disk' 
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Select 'OK'

Select file

Select 'Open'

Select 'OK'

Select 'View>>' beside 'SDRMap Coding Extensions'

Note:

The default library 'Trimble_TSCE_ALPHA.Project' already contains existing field codes
within the Extended field coding table.  

The dataset will be presented.

23.5 Creating A Model

Go to ‘FILE  > Model  > SCC Dataset'

Select ‘Create the model and triangulation’ and set Initial Plot Scale of 250

Select 'FILE > Save As'
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24 Working With Leica Data

The following tutorial provides information relating to the downloading and processing of Leica
data within SCC.

24.1 Create A Project

A new project should be created before data may be downloaded into SCC or models
formed.

From the Main Menu Bar, select ‘FILE >New Project’

Enter in a Project/Job name

Select a Project Template from the list 

Select ‘OK’

24.2 Download Leica Data

SCC includes a number of different Leica interfaces to support correspondingly different data
collection strategies.  The simplest of these is the TPS series interface which maps user
definable fields on the instrument directly onto SCC observation fields.

Downloading Leica Data

From the Main Menu Bar, select ‘FILE > Download Survey Data’

Set Survey Data Logger to 'Leica GS1 8/16'

Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type

Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required

Select ‘OK’

Select the file you require and ‘OK’
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In this case, for example, field 41 on the instrument will be used to store the SCC feature
name.  Any SCC fields that are not being recorded in the field should be set to 99.

Note that these settings will become the defaults for all future downloads from the Leica and
do not have to be entered with each download.

An alternative method is to use the LisCADD or WildSoft style coding (Leica 1100/1200
(GSI config)) which will be more familiar to LisCadd users. In this case field 41 on the
instrument is always used to determine what is stored in other instrument fields.  For
example, in the dialog shown below, if field 41 contains the word ‘FEATCODE’ the feature
code is expected in field 42, whereas if it contains ‘Remark’ a survey remark is expected in
field 42.
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Note that in both cases, a traverse feature code may be provided to determine that
subsequent observations are to be included in the traverse spreadsheet.  This is provided to
facilitate combined detail topography and traverse surveys.

Leica 1200 Data Input 

The following outlines the transfer of format files on to a Leica1200 system and the use of
the 'SCC Sys1200.FRT' file.  Download steps into SCC are noted.  The use of extra
measurements such as 'Line of Sight offsets, Tape Offsets, Parallel Offsets, Dimensions
and Remarks are examined.

A. Files for SCC Coding on Leica TPS1200 Series instruments: 

SCCSys1200.FRT Format File (*.FRT) generated in Leica GEO
Office to a System 1200 sensor

badleyt_0405_211712.xcf

badleyt_0405_211712.x23

badleyt_0405_211712.x06

Parameter Files

B. Setting up Coding on the TPS1200: 

a)Transfer of Format Files on PC:

· Copy Format Files to the Convert Directory on the Compact Flash [CF] Card

· Copy the *.xcf, *.x23 and *.x06 files into the Code Directory on the Compact Flash [CF] card
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Note:

The Compact Flash card must always be “Stopped” before removing it from your computer.
The System 1200 sensor must always be switched off before removing the Compact Flash.

b)PC Card in the instrument – Format File:

· Select option 6 Tools… from the Main Menu

This option can be selected by pressing the number 6 key, or by navigating to 6 Tools...
and pressing the Enter key, or by touching the Tools… icon when using an active touch
screen

· Select option 2 Transfer Objects… from the Tools Menu.

· Select option 6 Format Files from the Transfer Objects Menu

· Select the Format File (SCCSys1200.FRT)  you wish to transfer, from the CF Card, to the
SystemRAM, in the Transfer Format Files screen.

· Select CONT [F1]

The System 1200 sensor will return to the Main Menu once the Format File transfer is
completed.

c)PC Card in the instrument – Transfer Configuration Sets:

· Select option 6 Tools… from the Main Menu

· Select option 2 Transfer Objects from the Tools Menu

· Select option 2 Configuration Sets from the Transfer Objects Menu
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· Set up appropriately (TC, TCRP RCS etc.):

 

· Select ‘F3 – ALL’

d)PC Card in the instrument – Configuration:

· Select option 5 Configuration… from the Main Menu

· Select option 4 Interfaces from the Configuration: TC Menu

· Select GSI Output 

· Select ‘F1 – CONT’

C. Setting up Survey

a)PC Card in the instrument – Management:

Select option 3 Management… from the Main Menu

Select 1 Job from Management Menu
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· Select F2 New from Job (CF Card) Menu

· Within General Tab enter relevant details:

· Tab to Codelist and ensure that the setting assigned in Step C d

(Transfer Codelist) have been attained

· Within Tab Coord System select None
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· Within Avge Tab select Off

· Select F1 Store

· Within Main Job Screen select F1 CONT with TEST highlighted

D. Setting up Stations within 1200 Series:

(Known Azimuth)

· Select option 1 Survey… from the Main Menu

· Set up the appropriate Reflector

· Set Method to Known BS

· Select Frm Fixpoint Job as Station Coord

· Select F1 CONT to access the Station Setup Panel

· With Station ID highlighted select Enter (or Tap on Station ID focus)
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· Select F2 NEW

· Enter Coords

· Within Code Tab
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· Select F1 STORE

· Select F1 CONT twice to return to Select Station Dialog

· Select Station ID and enter Instrument Height

· Select F1 CONT

· Enter A Backsight ID and set Azmuith

E. Surveying Detail with SCC Codelist:

Leica TPS1200 Coding 

· After Station Set up select 1 Survey from Main Menu

· 4 tabs are available

· For Example 

Go to Code tab:Enter Reflector Ht.

Assign Point Code either using arrows or double click to view Code and Code
Description Dialog

· Assign String, Line Tag and DTM Status appropriately

Offsets are available from either the offset Tab or by within the Free Codes ‘F7’.

Extra Measurements have also been set up within the Free Codes ‘F7’.

F. SCC Settings for Leica coding using Leica TPS1200 Instruments 

Open SCC and set up Project 
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Select ‘FILE > Download Survey’

Select ‘Leica 1100/1200 (GSI Config)’ as Survey Data Logger

Select the required ‘Data Type’

Select ‘Data logger input Device’

Select ‘OK’

Select ‘Leica1200.GSIConfig’ Format File 

Set up additional settings as shown below:

Select ‘OK’

Traverse Observation Feature Code

Traverse Observation Feature Code field should be filled with the user’s individual code i.e.
PSSA or STN etc.

If this is not filled in, no stations file will be produced. 
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Always include the decimal point when inputting any number so that SCC knows the units

i.e. 12.0 or 0.25 

G. Tag Codes

The tag code determines the connective geometry and specifies how the current point on
the string will be connected to the next point on the string.  This can be used to specify
straight lines, curves, arcs, and squared up pieces of geometry in a string.  The tag codes
may be entered either in numeric or alpha-numeric format.

H. DTM Tag Code

The DTM (Digital Terrain Model) status code determines the significance of the point of the
surface model / digital terrain model being generated.  The DTM codes may be entered
either in numeric or alpha-numeric format

I. Extra measurement fields 

Extra user defined GSI fields may be used to collect extra measurement information
corresponding to the SCC extra measurement sheet.

Several offsets are available as part of the main interface:
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The Offsets are as follows:

Offset Cross: Line Of Sight L/R (Radial Offset)

Offset Length: Line Of Sight F/B (Lateral Offset) 

Offset Height: Elevation offset.  

Additional Extra Measurements have been set up as part of the Free Codes (F7):

Free Code:

Line OF Sight 

The ‘-Left+Right’ offset corresponds to the distance left or right along the line of sight
between the instrument and the target. 

The ’–Forward+Back’ offset corresponds to the distance forward or back along the line of
sight between the instrument and the target. 

The ‘–Up+Down’ offset corresponds to the elevation offset.

Point 101: Line of Sight Offset to the left –3.500
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*110017+0000000000000101 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410018+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+0000000000-3.500
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000 

Point 102: Line of Sight Offset to the Forward -6.500

*110019+0000000000000102 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500 
71....+00000000000000PS 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410020+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+000000000000.000 
46....+0000000000-6.500 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000 

Point 103: Line of Sight Offset to the Down +10.00

*110021+0000000000000103 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410022+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+000000000000.000 46....+000000000000.000
47....+000000000010.000 48....+0000000000000000 49....+0000000000000000 

Tape 
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The’–Forward+Back’ offset corresponds to the distance forward or back along the line
(Baseline) connecting the last two survey points.  

The ‘-Left+Right’ offset corresponds to the distance left or right along the line (Baseline)
connecting the last two survey points.  

The ‘–Up+Down’ offset corresponds to the elevation offset.

Point 201: Tape Offset to the Back  +2.300

*110026+0000000000000201 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410027+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+000000000002.300
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000 

Point 202: Tape Offset to the Right  +4.500

*110028+0000000000000202 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410029+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+0000000000000000 
46....+000000000004.500 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000 

Point 203: Tape Offset to the Up  -8.000
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*110030+0000000000000203 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500 
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410031+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000-8.000 48....+0000000000000000
49....+0000000000000000 

Parallel Offset

‘Dist Offset’ corresponds to the distance between the observed feature line and the
generated feature line (Feature?).

‘Elev Offset’ corresponds to the elevation offset.

Point 302: Parallel Offset – Offsetting HE Left  -2.500 from TB Feature
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*110035+0000000000000302 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500 
71....+00000000000000TB 72....+0000000000000056 73....+000000000000000S
74....+000000000000000D *410036+00000000Parallel 42....+0000000000000000
43....+0000000000000003 44....+00000000000000HE 45....+0000000000-2.500
46....+000000000000.000 47....+0000000000000000 48....+0000000000000000 49....+0000000000000000 

Point 302: Parallel Height Offset – Offsetting  HE in Z +2.500 from TB Feature

*110037+0000000000000303 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TB 72....+0000000000000056 73....+000000000000000S
74....+000000000000000D *410038+00000000Parallel 42....+0000000000000000
43....+0000000000000003 44....+00000000000000HE 45....+000000000000.000
46....+000000000003.200 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000 

Dimension

This option allows the user to manually input a Dimension 1 and Dimension 2 value.
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Point 401: TC feature with assigned D1 of 5.0 and D2 of 0.500

*110040+0000000000000401 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500 
71....+00000000000000TC 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410041+000000Dimensions 42....+0000000000000000
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000 46....+0000000000000000
47....+0000000000000000 48....+000000000005.000 49....+000000000000.500 

For example, Feature ‘Tree’ may have a Dimension 1 value denoting the Canopy size and
also a Dimension 2 referring to Tree Trunk size.

Remarks

Additional annotation can be assigned to a specific point with ‘Remarks’.

Point 95: WALL feature with assigned Remark ‘BRICK’
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*110043+0000000000000095 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+000000000000WALL 72....+0000000000000001 73....+000000000000000S
74....+000000000000000D *410044+0000000000Remark 42....+00000000000BRICK
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000 46....+0000000000000000
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000 

Point 376: TC feature with assigned Remark ‘OAK’

*110045+0000000000000376 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TC 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410046+0000000000Remark 42....+0000000000000OAK
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000 46....+0000000000000000
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000 
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J. Traverse observation feature code (not specific to 1200)

An extra user defined feature code may be used to signify a control observation.  This
observation will be used as a reference observation in the instrument set-up sheet and as a
traverse observation in the traverse sheet.  This facilitates combined detail and traverse
surveys using the GSI format.  If this field is left blank, and tag codes are not being
collected, all observations will be output to the traverse sheet.  If this field is left blank and
tag codes are being collected, observations with tag codes of FS, BS, and SS will be output
to the traverse sheet. 

K. Store Station co-ordinates (not specific to 1200)

Tick this field if you want to store station coordinates present in the input file, in fields 84 to
86, in the SCC project control file. 

L. Codes precede observations (not specific to 1200)

This option controls whether a code block is associate with the preceding observation, or
the following observation. For example, in the input below the code block precedes the data
block 

410006+000000KB 48....+0000000S 47....+0000000D 49....+00000002 110007+00000169
21.304+12359530 22.304+09515230 31...0+00003502 

M. Use Topo X,Y,Z in preference to HA,Va,Sd (not specific to 1200)

This option allows the computed X,Y,Z positions in the GSI input file to be stored in the
SCC observation sheet rather than the Ha,Va,Sd values, where both occur in a single data
line. This is useful if the GSI file does not include all of the survey observations, such as
observed back-sights, as shown in the example below; 

*110001+000000000000GR0A 84..10+0000000320728329 

85..10+0000000376869559 86..10+0000000000099259 
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*110002+000000000000GR01 81..00+0000000320715339 

82..00+0000000376754428 83..00+0000000000100000 

*110003+000000000000GR0A 84..10+0000000320728329 

85..10+0000000376869559 86..10+0000000000099259 

87..10+0000000000001500 88..10+0000000000001602 

79....+000000000000GR01 

*110004+0000000000000066 21.324+0000000018626250 

22.324+0000000008940550 31..00+0000000000115851 

87..10+0000000000001500 71....+0000000000000000 

72....+0000000000000000 73....+0000000000000000 

74....+0000000000000000 81..00+0000000320715334 

82..00+0000000376754441 83..00+0000000000100005 

*110005+0000000000000067 21.324+0000000015216010 

22.324+0000000008744130 31..00+0000000000074790 

87..10+0000000000001500 71....+0000000000000OSC 

72....+0000000000000000 73....+0000000000000000 

74....+0000000000000000 81..00+0000000320763106 

 82..00+0000000376803412 83..00+0000000000102315

Case Study 

Case 1: Tape Offset 

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D 

*110015+000000000000002 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D

*110016+000000000000003 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D 

*410017+000000000000003 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+0000000000000000 46....+000000000002.250
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000

*410017+000000000000004 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+000000000004.760 46.... +000000000000000
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000



390

©2018 Atlas Computers Ltd

*410017+000000000000005 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+0000000000000000 46....-000000000000.700
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000

Tape Offset Pt. 3: Longitudinal Offset of +2.250

New Baseline is now Pt. 2- Pt. 3

Tape Offset Pt. 4:  Lateral Offset of +4.760m (+Right)

Baseline now Pt. 3 – Pt. 4

Tape Offset Pt. 5:  Lateral Offset of  -0.700m (-Left)

Case 2: 2 Point Symbol OR 2 Point + Width 

2 Point Symbol

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000030 73....+000000000000000S 74....+000000000000000D 

*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000030 73....+000000000000000S 74....+000000000000000D 

Within the Project File assign ‘2Point Symbol (Side)’ Symbology and select a Dimension 1
symbol which has side intersection points.

Within the Project select ‘EDIT > Symbols > Edit symbols insert point’
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Case 3: 2 Point + Width 

Manhole / Utility Cover

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000020 73....+0000000000000R2W 74....+000000000000000D 

*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000020 73....+0000000000000R2W 74....+000000000000000D

*410041+000000Dimensions 42....+0000000000000000 43....+0000000000000000
44....+0000000000000000 45....+0000000000000000 46....+0000000000000000
47....+0000000000000000 48....+000000000002.000 49....+0000000000000000 

Case 4: 2 Point Circle

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
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31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+00000000000000C2 74....+000000000000000D 

*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+00000000000000C2 74....+000000000000000D

24.3 Creating A Model

Go to ‘FILE  > Model  > SCC Dataset'

Select ‘Create the model and triangulation’ and set Initial Plot Scale of 250

Select 'FILE > Save As'

25 Point Cloud Module

The following outlines some of the tools and functionality available within SCC Point Cloud
Module.

To start using this functionality the user must have the point cloud module licensed.

Tutorials are based on sample files available within the SCC folder.

Point cloud functionality is accessed in the model via the CLOUD tab.

25.1 Cloud Mouse Navigation & Settings

The mouse can be used to navigate the cloud data.  Such options are controlled within the
General Options

General Options

Go to 'DATA tab > Settings drop down > General Options > Communications'

Review 'Mouse Navigation' options
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For example, to rotate data using the mouse, simply

Press Mouse Wheel at rotate origin point

Press Right Mouse Button down and move cursor to pivot model

Note the cursor is moved around in the cloud, either in plan or another view, the x,y,z position of
the cursor in the cloud is shown, and the user can snap to cloud positions.  

Keyboard Shortcuts

In addition to mouse controls, keyboard shortcuts can be used, such as ‘P’ and ‘E’ when moving
between plan and elevation view. 

This coincides with other general SCC keyboard zoom controls such as Home (Zoom Extent),
Page Up/ Page Down (Zoom In/Zoom Out), Space Bar (Pan).

Other keyboard options are + and – to widen or narrow the area of interest, and L and X to move
between long section and cross section related view when selection a sectional area relative to
an alignment.

When a horizontal section / area of interest is in use the arrow keys may be used to raise or low
the elevation of the section.

Settings

The control settings are available within 'Cloud tab > Settings' and controls how the cloud is
treated as a surface for section and volume analysis.
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Note that only active points are used for snapping, and other operations such as data selection,
and export.  This allows the user to first select an area of interest for analysis purposes and hide
all other parts of the cloud, and then select further points from that area of interest for editing.  

Using The Cloud with other SCC Model Options

Most SCC options can interact with the cloud in a similar manner to the TIN surface generated
from a traditional total station or GPS survey.  This is largely controlled by use of the point
snapping and sections mechanisms in 'Cloud tab > Setting'.  The following snaps are available;

· Do not snap to cloud – The cloud is not used with other SCC string creation functions.

· Snap to cloud for levels only – The cloud is used in plan view for interpolating elevations only.

· Snap to cloud in 3d – The cloud is snapped to in full 3d, regardless of the viewpoint.

When using could snaps, and interpolating from the cloud as a surface in general, a search
radius is used.  If a cloud point is not found within this radius, the cloud snap fails.  When
interpolating levels, the underlying TIN is used in place of the cloud in this circumstance.  This
allows us to seamlessly mix TIN and cloud interpolation in a single model.

Given that we’re searching for cloud points in a given radius, we can also control how the
selected point or points are determined and used as follows;

· Nearest point – The nearest point to the desired position, e.g. mouse cursor position, is used

· Lowest point – The point with the lowest elevation of the points in range is used.  This can be
very useful for manually tracing lines such as bottom of kerb, where bottom of kerb and top of
kerb are very close and difficult to distinguish.  If is also very useful for extracting grids of
elevations over ground that may include vegetation and other spurious high points on the
ground such as lamp posts.  Note that this option is best selected with small search radii, and
used judiciously. 

· High point - The point with the lowest elevation of the points in range is used.  This can be very
useful for manually tracing lines such as top of kerb.

· Median point – The point nearest the mean position of all the points in the selection radius is
picked.  This can be useful for drawing strings represented by dense linear groups of points in
the cloud, such as walls shown in the slice taken from the cathedral model previously.

· Mean point - The mean position of all the points in the selection radius is picked.  This will not
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correspond to any one point.

· Nearest 2d (Screen) – The point drawn on screen nearest the mouse cursor is picked.

For options such as sectioning, volumes, extraction of grids, draping of 2d data to extract levels,
etc… the option to Cut sections through the point cloud must be selected.  This allows the cloud to
be used in a similar manner to a TIN surface for most SCC surface analysis operations. 
Interpolation is limited to points with a feature Analysis set to Ground, so it is very important to
change the feature of all other cloud data, such as vegetation, buildings and overhead lines, prior
to interpolating from the cloud in this manner.

For sectional analysis, we can also specify a level tolerance for smoothing, and horizontal and
vertical tolerances for removing spikes from the section.  This is necessary as cloud data is far
denser than conventional survey data and is prone to include a significant amount of noise. 
Smoothing and spike removal also greatly reduces the size of the data extracted, which is also
typically beneficial.

Other options on the same dialog control how the point cloud is visualized.  These control
whether the display is clipped behind and in front of the viewing plane, typically when using two
point elevations, and how isolated points are displayed.  Note that clipping the view has no effect
on point selection in the way that isolating or disabling points would.  Displaying Inactive points
allows you to see where your active points are in relation to the rest of the cloud.  Inactive points
are always transparent and typically drawn in a lighter colour.  Displaying a reduced number or
outline of isolated points will reduce display clutter and improve display speed on larger clouds.

25.2 Point Cloud Feature Library

The point cloud feature library is used to break down the cloud into groups of points on similar
feature, for example, all points corresponding to vegetation, all points corresponding to the road
surface.  This allows the user to fine tune how analysis operations work, as this will change
significantly based on the type of feature.  For instance, how sections are cut through the ground
will be different to how sections are cut through more complex 3d features such as buildings.

The point cloud feature fields are as follows;

· Feature – The name of the feature

· Surface – The surface on which the feature is placed.  Note that you can have multiple features
placed on the same surface, e.g. trees and bushes might both go on a vegetation surface
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· Analysis – This controls how SCC interprets these points for surface analysis purposes.
Options are

o Display only – The points are displayed only, but not subject to analysis

o Ground – The points are treated in the same way as the triangulation surface in a normal

SCC model, from the point of view of sections, volumes, draping points, extracting levels,
etc…

o Other surface – The points are treated in a similar manner as an additional triangular

surface, such as a reference model.

o Other 3d – The points are treated as a non-mappable 3d surface, not suitable for surface

analysis operations.  Sectioning through 3d surfaces will be considerably slower than ground
/ mappable surfaces.

· Colour – The default colour of this feature when not coloured by point

· Colur by point – Whether points on this feature have individual colours or the same colour

· Visibility – Controls whether or not these points are displayed, and if they are displayed
whether they are considered opaque or transparent.

· Lock – Whether or not these points are included in analysis

· Size – The size of displayed points

· Sect. Width – The search corridor width used when cutting sections through this feature.  Note
this will typically be small for ground surfaces, e.g. 10mm, and larger for 3d surfaces, e.g.
100mm – 500mm.  The larger this value, the more 3d data will get projected onto a section and
analysed.  This in turn can slow down processing and significantly increase the size of
sections produced.

· Max Dist. – For 3d features, the maximum distance to which points will be connected.

· Trace Dist. – For 2d features extracted by tracing selected points, the maximum distance
between adjacent points

· Min. Length – For all traced output, the minimum total string length allowed for a string to be
included in the output.

The cathedral and topo models (from the SCC tutorials folder) already have some features
applied.  Thus is a sections is cut through the data, the varies features will appear.

.  For example, select 'ANALYSIS tab > L.Sect' and generate a section through  'Topo.Model'
taking in the tree:

And similarly for the Cathedral.Model;
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The feature library is also very useful for quickly colouring and analysing monochrome point
clouds, as shown in the model below (Tunnel 950-1050 (edited).Model)

By selecting and isolating appropriate elevation and sectional areas, the user can quickly
differentiate the tunnel, cabling, rails, and foliage.  This in turn allows the user to cut complex
sections, develop a ground surface and isolate features of interest.
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25.3 Selecting And Isolating Parts of the Cloud

Data Selection Dialog

The most commonly used option will be data selection, which shows the point cloud selection
dialog.  The allows the user to control how data is selected (i.e. points in a window, points in a
polygon, using a horizontal or vertical section / slice, relative to an alignment,  points similar to a
given reference point, points close to another SCC surface) and what to do with picked data.

This includes selecting and deselecting data as per typical SCC usage, locking and unlocking
data which hides the data and prohibits it from being used in future operations, and isolating data
which is the same as locking everything except the picked points.

This option is available by Right Clicking mouse within a point cloud or within 'Cloud tab >
Select' button

Additional Tools can be used to control selected data from the Cloud Toolbar

Isolating Data

Open Sample file 'Cathedral. Model' from tutorials folder

Right click mouse to bring up 'Data Selection Dialog'

Select 'All points close to a line (Vertical section), set Min Offset -2 and Max Offset 2

Tick 'Show selected section in elevation'
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Pick 'Isolate Data' and the dialog closes

Left click on model to pick first point on centreline and a second time to pick last point

This highlights the area of interest as an elevation and switches the colour of all the locked
points to light gray.  

Pressing ‘P’ and ‘E’ we can move between plan and elevation view to get a better idea of what has
just happened.

Alternatively use the toolbar to change selection as shown below:
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The up, down, left and right arrows to advance and move the section relative to the direction
of view.  

The distance here is based on the Section offset increment in the data selection dialog,
which can also be brought up using the right mouse button.  

From plan view use the mouse at any stage to pick an alternate section as shown below;
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Other keyboard options are + and – to widen or narrow the area of interest, and L and X to
move between long section and cross section related view when selection a sectional area
relative to an alignment.

When a horizontal section / area of interest is in use the arrow keys may be used to raise
or low the elevation of the section.

25.4 Tracing Sections and Slices

In addition to cutting sections there are a number of other ways to extract linear data and
analyse cloud surfaces.  The simplest of these is via 'CLOUD tab > Trace  drop down > Trace
outlines from slice', which will draw outlines based on an isolated sectional area.  This can be
either from plan, elevation or based on an oblique viewpoint.
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The results can then be exported to other packages, such as CAD, in 2d or 3d, and multiple
slices can be used to build-up a wire frame model from your cloud.  The cloud feature library
determines how the data is analyses, where the centre of the displayed section or slice is used
as the centre-line for sectioning.

25.5 Extracting A TIN Surface From The Cloud

Within 'Topo.Model' available from SCC\Tutorials directory, a selected area can be triangulated
for further analysis and export to a software that does not support point clouds.  

In this case, a small alignment is created and selected points in an area 7.4m either side of the
centre line is isolated and used to generate a TIN, as shown below.

Set up Project

Open 'Topo.Model' from SCC\Tutorials folder

Go to 'ADD tab > New'

Left click mouse on screen to begin centre line, change the geometry as the line process to Arc
tag and then finishing with Straight

Right click mouse on screen, select 'Save string as an Alignment' 
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Select 'TOOLS tab > Line' button and measure from centreline to edge of road

Approx 7.233m

Right click mouse to bring up 'Data Selection Dialog' set up the following 'All point close to an
alignment', then select 'Isolate Points'

Re-enter and then, select 'Select Points'
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To triangulate, select 'CLOUD tab > Mesh' button and set up the following:

Note, this option can be slow depending on the parameters and the number of points selected. 
To improve performance and final result remove or isolate noisy features such as grass, trees,
cars, street furniture and overhead cables prior to running this option.  Only selected points
whose features have an analysis type of Ground are considered when running this option, so
simply changing the feature of such points to any other feature will accomplish this. 
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Other options relating to point cloud processing include linear feature extraction, density based
feature extraction (stringing clumps of points), tracing string manually in conjunction with cloud
snap, and use of other surface based tools in conjunction with the point cloud ground surface
rather than the TIN.

To add further information to our TIN model, from coarser areas of the model that may have lower
accuracy requirements,  Extract a grid of levels can be used, and add the generated data to the
TIN created above, along with traced linear features such as kerbs described earlier.  Note that
when extracting a grid of levels, it is best to select the option to snap to the level of lowest point
in the defined snap search radius, as this will tend to generate a more uniform surface, skipping
small vegetation and similar items.  

25.6 Tracing 2D Features Such As Road Markings

SCC point cloud module can be used to trace outlines of features using a combination of colour /
intensity difference, height difference and distance from a reference point.  For example, road
markings.

Open 'Topo.Model' from SCC\Tutorials folder

Zoom to Road Markings of interest

Right click mouse to bring up 'Data Selection Dialog'

Select 'All similar points' set up the following:
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Press 'Pick>>' button and then left click on select a reference point for colour and position

Within the 'Data Selection Dialog' pick 'Select points' to highlight all the points that are
similar to that reference point.  

Note that if we were trying to pick up road markings we could first isolate the road area using a
chainage / offset or polygon selection first.

The selected data will appear as shown below

Additional reference points can be selected to add more data, and polygon based
de-selection of any areas that were included but not required.  Removing points in this many
will also speed up the tracing process, and reduce the size of the output model.  

Selecting 'CLOUD tab > Trace drop down menu > Trace selected points' set the following;
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Which produces:

25.7 Extracting Line Work & DTM from Mobile Lidar Data

The following tutorial explores the extract of linear features from Mobile Lidar Data using an
alignment and the generation of a TIN.  Tools to highlight non ground points by Height are
examined and finally, addition of point features are created in the model.

25.7.1 Create New Project

From the Main Screen, select 'DATA tab > New'’

Enter in a Project/Job name 'MobileData'

Select a Project Template from the list 'Road_Cloud.Project'

Select ‘OK’
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25.7.2 Importing Sample Data

To start, select 'Model Tab > Point clouds and LIDAR > LAS or LAZ file' and pick the
appropriate input format.  

Pick 'M5_000001.las' from Tutorials directory and set up the following;

Press 'Ok'

Select 'Ok' to Model Creation and Raw cloud creation dialog
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25.7.3 Create A Simple Alignment

Go to 'ADD tab > New  > Arc'

Left click mouse on screen to begin centre line, change the geometry as the line process to Arc
tag and then finishing with Straight

Right click mouse on screen, select 'Save string as an Alignment' 

Set up the following and press 'Ok'
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An alignment is now present, note Chainage/Offset system 
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25.7.4 Settings

Go to 'Cloud tab > Settings', set up the following and press 'Ok'

25.7.5 Trace Linear Features: Road Edge, Batter Rail and Channel

First pick template points: Road Edge, Batter Rail and Channel

Left click on model to position at a given chainage, for example 0.767

Pick first point RE on Trace Linear Feature screen by left clicking on section

New Pt is listed below.  Change Feature to RE and then continue to pick additional points on
section

Set up the following: RE, RE, BR, CH, SL, SL, CH, BR, RE, RE as shown below

Click 'Store Section'
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Set the chainage interval to 50

Select Chainage '>' button to move to chainage 50 

Begin to pick points at chainage 50 by left clicking on section at the position of each feature

Each time select 'Store Section' to save and then move to the next chainage interval

The user can pan back through the model using the chaiange button to check if additional
points are required

Select 'Update Model' and pick 'No' to 'Model updated, clear current template and reference
line'
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Enter Template Name 'RD' and pick 'Save'

Then press 'Delete All'

25.7.6 Trace Linear Features: White Lines

Left click on model to position at a given chainage, for example 0.767

Pick first point WL on Model by left clicking on section

New Pt is listed below.  Change Feature to WLD and then continue to pick additional points on
section

Set up the following: WL, WLD, WLD, WL, WL, WLD, WLD, WL as shown below

Click 'Store Section'

Set the chainage interval to 50

Select Chainage '>' button to move to chainage 50 

Begin to pick points at chainage 50 by left clicking on Model at the position of each feature

Each time select 'Store Section' to save and then move to the next chainage interval
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The user can pan back through the model using the chaiange button to check if additional
points are required

Within the 'CLOUD tab > Display'

Select 'Update Model' and pick 'Yes' to 'Model updated, clear current template and reference
line'

Select 'Close' on the Trace Linear Feature dialog

25.7.7 Detach Alignment

Go to 'DESIGN tab > Attach button'

Select 'Detach All' and 'Ok'
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25.7.8 Check Model

Go to 'MODEL tab > Model Button'

Check Triangulation
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25.7.9 Rotate Model

Rotate model, press Mouse Wheel at rotate origin point

Press Right Mouse Button down and move cursor to pivot model

25.7.10 Remove White Lines From TIN

Go to 'MODEL tab > String > Remove Strings'

Left click mouse on WL and WLD strings to remove from TIN

Having remove strings from TIN, select 'Display' from 'CLOUD tab'
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25.7.11 Filter the Ground to Identify Lamp Posts , Trees etc. from Main Ground

Go to 'CLOUD tab > Tools > Filter Ground' set up the following and pick 'OK'

Go to 'CLOUD tab > Library' button

Set 'OBJ' visibility to 'Hidden' and pick 'OK'
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Notice the difference when OBJ is set to Opaque and Hidden
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25.7.12 Create TIN

To triangulate, select 'CLOUD tab > Mesh' button and set up the following:

Press 'Ok'

Go to 'MODEL tab > Model button' to turn on TIN

Rotate model, press Mouse Wheel at rotate origin point

Press Right Mouse Button down and move cursor to pivot model

Within the 'CLOUD tab > Display' to turn off cloud data 

Go to 'MODEL tab > Model button' to turn off TIN

Go to 'MODEL tab > Contour button' to turn on contours
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25.7.13 Highlight Non-Ground Points By Height

Go to 'CLOUD tab > Library' button

Pick 'Height' as the Relief Colour Palettes

Set up the following 'Add Elevation/color range' for 0 -5 range

Set up the following 'Add Elevation/color range' for 5-10 range
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Select 'OK'

Set By as 'Height' for OBJ and Visibility to 'Opaque', then press 'OK'

Rotate model, press Mouse Wheel at rotate origin point
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Press Right Mouse Button down and move cursor to pivot model

Pick 'OBJ' within Selection toolbar from 'CLOUD tab'

25.7.14 Add Features

Go to 'Cloud tab > Settings', set up the following and press 'Ok'

Ensure that 'Lowest point' is selected
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Go to 'ADD tab' set LP as feature and pick 'Point'

Left click on model, to place lamp post

Right click mouse and select 'Update string in model'

Select 'CLOUD tab > Display' to turn on cloud

LP is visible
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25.8 Cloud Volumes

This tutorial examines sample data 'Topo.Model' in order to calculate volumes of the roundabout
island.

25.8.1 Open Existing Project & Model

Open 'Cloud.Project' from SCC\Tutorials\PointClouds folder

Open 'Topo.Model' from SCC\Tutorials\PointClouds folder

25.8.2 Rotating Viewpoints

The most important step computing volumes from point clouds is to ensure the cloud model
is free from data not related to the measurement such as vegetation, street furniture, etc..

Select such data en-masse and change its feature.  

Go to 'CLOUD tab > 2pt Elevation'
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Select a line running through the area of interest, left click mouse on screen to pick first point
and then left click on last point to finish

25.8.3 Cloud Data Selection & Editing

To select data, right click to bring up the Data selection dialog, followed by picking 'All points
in a polygon' and press Select data

On the model to select points for exclusion from the measure, press left click on mouse to pick
points on the polygon followed by right click to close it. 

Go to 'CLOUD tab > Edit'

Set up the following and press 'Ok'

For volumes one feature in addition to GROUND will suffice.  For more complex analysis
this method can be use in conjunction with the isolate points option to break a model down
into multiple features as has been done on the TOPO model.
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25.8.4 Check Cloud Surface Data

Select 'CLOUD tab > Library button', and change the analysis type for excluded features TREE
to 'Display only', and the Visibility to 'Hidden'.

Select 'P' to change to Plan view

To check the surface is as intend, select ' ANALYSIS tab > L. Section button' and take a
section through a vegetated area of the traffic island

Left click mouse on model for first point, then again for second and right click to finish
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Use 'FILE > Save As' to save a copy of our edited model.

25.8.5 Creating Base Model

On order to compute volumes,  a base model is needed.  The easiest way to create one is
to simply draw a polygon around the area of interest, interpolating levels from the cloud, and
saving it as a new surface.  This can be done as follows;

'CLOUD tab > Settings' set up the following

Ensure 'Lowest point' is selected.  

This has the effect that levels will be taken based on the lowest point within the given radius
of the plan point, thus avoiding any noise than may have been left in the model during the
editing process.

Go to 'ADD tab > New  > Lines'

Left click mouse on screen to begin line and continue to place points 

Change geometry from Straights to  Arc when required

Finish by using Link tag to join end to start point

Right click mouse on screen select 'Drape All points on surface'
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Right click mouse on screen select 'Save coordinates as dataset' to save the 3d outline of the
base model 

Save Dataset as 'TOPO_Base.Survey'

Go to 'MODEL tab > Model button' pick 'TOPO_Base.Survey'

Model at 1:250
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25.8.6 Volumes By Average End Method

Go to 'ADD tab > New  > Lines'

Create a new string along the centre of the traffic island with a DTM code of Approximate that
can be used as a base line.  

Select 'ANALYSIS tab > X.Sect button, set up the following and press 'Ok' 

Pick the selected centre line

In the sections, select 'EDIT tab > Append button' and pick the base model

Select 'EDIT tab > Append drop down > Volumes' to compute the volumes
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25.8.7 Volumes By Prismoidal Method

To compute the volume using an isopachyte method, do the following;

Go to 'MODEL tab > Edit button' to turn off any triangles in the TOPO model.  

Select 'No' to Store Model Boundary

The reason for this is that SCC allows combined TIN and point cloud surface models, where
levels will be interpolated from the TIN model if they are not found in the point cloud.  
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Select 'DESIGN tab > Attach button > Model', and attach the base model to the point cloud.  

As the cursor is moved over the traffic island, x,Y,Z and dZ can be seen to the base surface.

Right click to bring up the data selection dialog and isloate all the points in the cloud relative to
the base model as shown;
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Select 'TOOLS tab > Tools drop down > Extract a grid of levels' to take a 0.5m grid across the
island, and save the resultant data set.

Save Dataset 'GRID.Survey'

Go to 'MODEL tab > Model button' pick 'GRID.Survey'

Model at 1:250
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Save Model

Save Model

Select 'ANALYSIS tab > Prism Surf.' to compute the volume between the base and island

Set up the following and press 'Ok'

Model at 1:250

Review Report



435

©2018 Atlas Computers Ltd

By applying a relief scheme in plan via our contouring options the cut and fill can be visualised.

Using 'ANNOTATION tab > Add button' set up the following:

A scale to the relied scheme can be added to show how depths are coloured.

25.8.8 Export To Google Earth

If the model is in national grid, which will typically be the case using the MS50 with GPS, a
quick visualise of result can be viewed in Google earth by selecting 'DATA tab > Export >
Google Earth KML'
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26 Transforming A Cloud To Show Differences To A
Template Or Cylinder

This note covers the steps required in importing a scanned tunnel job in LAS format into SCC
and developing it into a plan model showing separation from a template design or cylinder.

The steps are as follows;

'FILE > New Project' entering a name for the new project and selecting a default template.

The project template contains the naming conventions, symbols, and drawing conventions
that will be used when creating models.

Creating a new project also creates a folder in which all project items, such as models and
drawings will be stored.
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'FILE > Model > Point clouds & LIDAR > file', picking the sample file provided,  followed by
creating the model at 1:100 scale when prompted.

This creates the following model, containing ~145 million points from the 657mb LAS file
and resulted in a 100mb SCC model using 64 intensity levels.  On an 8 core AMD
processor at 4ghz this takes ~37mins.  The 64 features + intensity layout is both compact
and quite flexible in terms of what you can do.

The default rendering for the library used is by intensity, where a palette has been selected
that corresponds the height range in the scan.  Turning the mouse wheel can be used to
zoom in and out, and holding the wheel down and moving the mouse to pan.  Alternatively,
the PgUp and PgDn buttons can be used to zoom, and space bar to centre around the
cursor.  We can also rotate the view in 3d, using 'VIEW > Rotate ViewPoint'
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In order to unwrap the model, i.e. transform it such that x,y,z model coordinates become
chainage (distance along a centreline), offset (lateral distance away from a centre line) and
separation (perpendicular distance from a design surface), we need a design centreline, and
one or more section templates.  The centre line can be be imported from LandXML, DXF or
Bentley MX, or manually created.

In this case we have a design centreline and templates which can be attached to our
scanned model using 'FILE > Attach/Detach > Attach Alignment' and picking CL with
Template.Alignment.  Details on how this alignment was created are given further on in this
tutorial.

We can limit the area of the model being processed by right clicking to bring up the point
cloud selection dialog, selecting 'All points in a polygon', followed by Isolate Points.  Left
click to pick points on the polygon, and right click to close the polygon and isolate an area
of interest.

To unwrap the selected area, use 'TOOLS > Transform Coordinates' with the following
parameters.  This is computation intensive operation that takes approx 4 minutes on this
model, where the time taken is based on the total number of points being processed, to
number points on the centreline, the number of section templates, and the number of points
on each template.
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If we were working with a circular tunnel, we would not need a section template and could
select either Cylinder from Alignment or Cylinder from string along with a design radius to
create a model based on cylindrical separation rather than template separation.

Rotating this model we can see the effect of the transformation more clearly.



441

©2018 Atlas Computers Ltd

To render out model based on separation distance, select 'CLOUD > Point Cloud' features, and
change the By field to Elevation for the GROUND feature.  Specific colours and ranges can be
changed by pressing the Elevation Colours button.
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26.1 Creating A Centreline Template

If we do not have a design centreline and template for our model we can create them as follows:

Right click to bring up the point cloud selection dialog.  Select 'All points close to a line
(Vertical section)' and press 'Isolate points'.

Click two points in plan to draw a line at right angles to the tunnel close to the start of the
tunnel.  This will show an isolated section of the start of the tunnel in elevation.

Select 'TOOLS > Measure > Intersect lines', and pick four points to create two intersecting
diagonals at the edge of the tunnel.
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Select Close, press P to move from elevation back to plan, and repeat the above steps to create
additional centreline points.

Select 'VIEW > Coordinate computations', to get a list off all generated intersection points.

Select 'EDIT > Add strings with cursor' to start creating a new string.  For each intersection
point, select it, and press Output to add it to the new string.

Right click the mouse, and select 'Save string as interface'.
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Select 'CLOUD > Trace linear features > Manual', which will show the split screen view below

As we move the mouse in plan, we will see a section of scan at the current cursor position. 
In this case, we're tracing from the raw scan based on a 0.2m extract of points, which
doesn't require any editing of the scan prior to using it.  We've also selected to display a
section for the current chainage 5m either side of the centre line.  We can use the zoom in /
out and extents keys to navigate the section, as well as changing the vertical exaggeration
to allow for more accurate selection of levels, and dragging with the mouse wheel.
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To start creating a design template, left click on points in section or plan, edit point details such
as feature name and string number, and repeat for the number of template points required.  In
this case, we'll pick five points representing the tunnel walls where the last point is the same as
the first.  If we know exact horizontal and vertical offsets to the design centreline we can enter
them here.

To create section templates at specific chainages, select Pick Points, and select the highlighted
point in plan or section for each point on the template.  This allows us to vary the template by
chainage, to accommodate changes in width of the tunnel and possible inaccuracies in the
centreline.

Once enough sections have been entered, you can investigate the behaviour of the interpolated
strings between chainages, by pressing the Chainage button.  As you move the mouse around
screen in plan, you will see the interpolated section along with the scanned points in the section
view.  Pressing the left mouse button locks the chainage and lets you enter an additional section
where required.

Selecting 'DESIGN > View Design sheet > Section template points' shows us the points created.

SCC uses linear interpolation between sections templates to calculate horizontal and vertical
offsets for arbitrary chainages.  We can save our design for re-use simply by selecting 'FILE >
Save As' from this view.
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27 Importing Point Cloud Data

To create a new point cloud model you need data in either PTS, LAS, LAZ, or ESRI ASC format.

Importing PTS file

To start, select 'Model Tab > Point clouds and LIDAR > LAS or LAZ file' and pick the
appropriate input format.  

Pick 'road-25mm.pts' from Tutorials directory. This will show the following screen;

Colour Usage

The colour usage option controls how much space is used per point, where RGB12 allows
about 100 million points on a system with 1GB available memory.  Palette colouring is
slower to import data, but more efficient at the loss of some colour resolution.  

Create Palette

Selecting the Create palette option builds a palette and cloud feature library, based on
paramers selected.  This can be an optimized palette from the cloud RGB data, a colour
range corresponding to intensities, or the standard AutoCAD 256 colour or VGA 16 colour
palettes.

Edit>>

Pressing the Edit button allows the user to make further edits to the point cloud feature
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library, and save it for re-use on other point clouds.  

28 Cutting Sections From MS50 Data

This tutorial examines the use of the SCC survey, point cloud and sections modules to model
scanned using the Leica MS50, and cut sections from it.

28.1 Create New Project

'FILE > New Project' as shown below:

28.2 Downloading Control Data

'FILE > Download Survey'

Pick the Leica 1100/1200 logger and DBX as the input device.
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When the DBX translation dialog is shown change the DBX folder to point to the location in
which the MS50 scan data is stored and press 'Refresh' to update the dialog.

Select 'SCC-TPS2GSI-v4.frt' as the format file, click on the job file name and press 'OK'

Select 'MS50Trav.GSICONFIG' in the Leica data input dialog and press 'OK' to download and
import the survey data into SCC.
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This will download control observations into the traverse spreadsheet, and any known
entered station coordinates into the project station coordinates sheet.

28.3 Processing Traverse

Switch to the station coordinates sheet, and change the type of any known coordinates to either
'Fixed' or 'Constrained 'in both XY and Z, and edit any changes to position or elevation as
required.

Switch back to the traverse observation view, and select 'EDIT > Adjust'.  

If  initial occupied stations are unknown (i.e. computed by resection or free station) make sure
the option to exclude fixed bearings for opening and closing set-ups is ticked, as the opening
orientation will not be known.  Instrument accuracies for height, angle and distance should be
entered based in the stated accuracy of the instrument in use, number of rounds of
measurement taken, and anticipated standard errors.
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Check the traverse report to ensure that the errors reported and station positions and
heights are all within an acceptable tolerance.  Specific attention should be paid to
chi-squared pass/fail results, error ellipses and height errors, and observation residuals. 
Where scanning is being carried out at the same time as control measurement, the
absolute accuracy of  any scanned point will be based around the station accuracy and
standard error of the scanner EDM.

If the adjustment results are acceptable, update the project station values.

28.4 Reprocessing Scan Data Based On New Station Values

To reprocess the scan data based on the updated station values, select 'FILE > Model > Point
Clouds & LIDAR > Leica MS50'.

Pick the scanned project file

Pick 'Recompute scan positions based on stations in SCC project'

Note that 'only recompute scanner orientation' is selected when moving between grid
systems, as any transformation residuals are liable to reduce rather than improve overall
accuracy.

Press 'OK' on the point cloud, and create the model.
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28.5 Creating Cross Sections For Comparison

To create cross sections for a comparison, an alignment centre line is needed.  This can be
imported from DXF/DWG, LandXML, or GENIO as requied.  In this case, a centre line manually is
manually drawn.

Press the curve button on the tool bar and left click on all three or more points representing
your centre line.  

Press the right mouse button to bring up a pop-up menu.  

Select 'Save string as interface' and enter new alignment name
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A chainage, offset and centre line height for the tunnel is drawn as a yellow line in the
model.  As the mouse is moved around the screen, a chainage and offset is reported in the
status bar in addition to X,Y,Z.

To cut some cross sections, select 'SECTIONS > Cross sections from an alignment' using the
values given.
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Save sections, 'FILE > Save As'

Sections can be displayed in plan:

'FILE > Attach/Detach > Attach sections'

28.6 Editing Scan Data Using Sections

In the event of the sections containing unwanted data, such as structures, overhead lines,
noise from vegetation, etc. the scan can be edited as required and the sections re-cut.  For
example, at chainage 100 there is an obvious spike as shown below;
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To edit sections, select  'FILE > Attach/Detach > Edit detach', pick section file.  

Right click to bring up the cloud selection dialog, and isolate all points in the chainage 90-110
range as shown.

This highlights the area of the scan in elevation as shown.

Press 'P' or 'E' to move between plan and elevation, and use the up and down arrows to move
between chainages for the area isolated.
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Move back to elevation view, press right click to bring up the 'Data Selection Dialog', tick 'All
points in a polygon' and press 'Select points'.   Use the left click button on mouse to draw a
polygon around the area of the scan to exclude from the sections as shown, and right click to
close the polygon.

Select 'CLOUD > Edit selected points', and change the feature of the selected points to NOISE,
TREES, etc. as appropriate.  

Repeat this process throughout the model, and re-cut the sections. 

A tidier surface line is achieved with any additional features outlined in 3d.

29 Tracing Linear Features On A Point Cloud

The option 'CLOUD tab > Trace drop down > Trace Linear Features' allows the user to trace linear
features contained in a point cloud by matching points on a section template to points in the
cloud at regular chainages along an alignment.  This is done in a split screen view, with the
template details shown below the model, updated in real time as the template is developed.
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The stages involved are as follows;

29.1 Select Or Create A Reference Alignment

This is a design line running roughly parallel to the features you want to extract.  If you
already have a suitable alignment attached, you can pick it using the Ref Line drop down. 
You can also interactively draw a new alignment as follows;

· Select an active tag code of Curve or Straight as require.

· Zoom into the area of interest in the model.

· Press New to create a new reference string. 

· Left click on two or more points on the desired reference string. 

· Right click to finish creating the reference string and start creating the template.

· The reference line will be saved such that it can be re-used later as required.
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29.2 Enter Template Size & Parameters

Before creating our template we need to enter its width and height in reference to the centre
line.  We can also enter a vertical exaggeration to make it easir to find features such as
kerbs.

Having entered width, height, and vertical exaggeration, as we move the mouse along the
alignment in plan, we see a section cut through the cloud at the chainage corresponding to
the mouse position.  Pressing the left mouse button will lock the chainage to the current
position, in order to allow us to create template points, pressing the right button unlocks the
chainage to examine sections at other chainages.  It is important that the widths specified
are large enough to encompass the features being sought at all required chainages.

29.3 Creating Points On The Template

Once we have locked the section at a given chainage position, we can add points to the
template either by left clicking on the section or the plan.  This has the effect of adding
points to the section template overlaying the cut section, and showing the details of those
points in the accompanying spreadsheet to the right of the section drawing.
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Newly created points are given a feature name and type based on values entered.  The
types are as follows;

· String – A string line will be output to the model based on this section template point.
For any given chainage, a point in the cloud corresponding to this point on the template
must be found for the template to valid.

· Point – A point will be output at each chainage to the model based on this section
template point.  As per the string, this point is required for the template to be valid.

· Reference – Nothing is output to the model, but a point corresponding to this point is
required for the template to be valid.

· String (Opt) – A string line will be output to the model based on this section template
point, but it is not required for the template to be valid.

· Point (Opt) – A point will be output to the model based on this section template point, but
it is not required for the template to be valid.

Once the template points have been entered, right clicking the mouse allows us to unlock
the chainage and test how well the template matches the points in the cloud at differing
positions along the alignment.  
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If the template is not valid at the current chainage, it is drawn in bright red.  For example, in
the case above the left and right road edges don't exist so a match to the template is not
found.  If those template points were optional, i.e. They had a type of String (Opt), the
section would still be valid.

We can also save our template to file once created, such that it can be re-used elsewhere
in this point cloud and future point clouds, simple by entering a template name and pressing
Save.

29.4 Creating Strings

Once we have created our template, we can generate our model by entering a chainage
range and interval, and pressing Create strings.  To pick a From or To chainage simply lock
the section at the desired chainage by pressing the left mouse button and then clicking on
the required From or To chainage button.

Created strings seen here with the cloud turned on
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And below with the cloud turned off.  Note the gaps in the strings at certain positions where
an acceptable match to the template could not be found.  This will typically be due to an
interference factor, such as a car on the road obscuring the required point, or a required
template point not existing on the ground at a given chainage.

29.5 Linear Feature Extraction Parameters

Pressing the options button from the linear feature extraction dialog brings up an additional
parameters dialog that allows us to fine tune how the extraction process works.  These
parameters are as follows;
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Maximum horizontal template shift from C/L 

This controls how far the entire template can be shifted from the design centre line and still
remain valid.  Larger values enable the same template to be used over a wider range of
conditions, but can also introduce incorrect data into the output.

Vertical tolerance for valid fit

This value, typically a few centimetres, is how close the relative height difference between points
on the ground and points on the template must be to be considered valid.

Horizontal search interval

This value, typically a few millimetres, is the search interval used when matching template
sections to cloud sections.  The smaller the value, the better the probability of finding a fit, and
the improved accuracy of the fit, at a cost of processing speed.

Maximum chainage to join missed points

When the template does not match the ground at a given chainage no points are output.  Where
the chainage distance between successive points on the same string fall above this value, a gap
is introduced into the string.

Allow stretch between left and right sides

This switch allows the left and right points on the template to be treated as separate templates. 
This allows horizontal and vertical shift between left and right hand sides, while still holding the
template valid.  It also allows strings on one side of the template to be valid, even if the other side
is not valid.

Hold horizontal offset (Force template value)

This forces the horizontal section template position to be held for all chainages

Hold vertical offset (Force template value)

This forces the height difference between section template points to be held for all chainages. 
The default is that the output height is based on the cloud values where other tolerances are met.
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Process all 3d surface features

This controls whether analysis is limited to cloud points on the primary ground feature, or
whether all 3d feartures are analysed as in the example above.  Analysing all features is
significantly slower than limiting the analysis to ground features.

Grid colour 

The colour of grid lines in the section display

Ground line colour

The colour of the interpolated ground line at the current chainage in the section display.  Note
that other 3d features take their colours from their point cloud feature library entries.

In range section colour

The colour used to draw the template as fitted to the ground at the current chainage, when the fit
produces valid output based on the tolerances given.

Out of range section colour

The colour used to draw the template as fitted to the ground at the current chainage, when the fit
does not produce valid output based on the tolerances given.  The details drawn are based on the
best fit found.

Template colour

The template line, not fitted to the ground, as it was originally entered

Grid interval

The horizontal and vertical grid interval on the section.

30 PTS Point Cloud Data

PTS data can be reduce, processed and compared within SCC.  Additional options are also
available to extract linear features such as kerb lines from the data. 

30.1 Extracting Linear Features From PTS Point Clouds

SCC can reduce, process and extract linear features such as kerb lines from PTS cloud data. 
The steps are as follows:

Create a new project, or open an existing one

'FILE > Open > SCC Project' and pick 'PM-Clouds.Project'

Model PTS File

Select 'FILE > Model > Point clouds & LIDAR > PTS file' which will show the following dialog:



463

©2018 Atlas Computers Ltd

The default options shown above stream in a RGB file which is mapped to a palette of 256
colours to an accuracy of 10mm.  The fields are used as follows;

Stream and optimize for TIN modelling

Selecting this option inputs processes the point cloud in smaller sections such that SCC
can handle very large point clouds relatively quickly.  As data is input it is optimized to the
specified vertical tolerance, and any points that would not make a change to the final
surface are discarded.  This eliminates vast number of co-planar points where they exist,
leading to a much smaller, faster and more efficient TIN model without sacrificing any
accuracy as would be the case with simpler decimation techniques.

Accuracy Tolerance

This is the vertical accuracy to which the TIN model is optimized.  All points that would not
affect the final surface by more than this amount are removed.

Maximum Iterations

This specifies the maximum number of times the optimization process is repeated.  If no
changes are made on any given iteration, the optimization is halted.  

Optimization interval

This is the number of points at any given time that are held in memory when streaming and
optimizing.

Colour and intensity mapping

These fields control how the RGB colours and intensities in the input data are mapped onto
SCC features.  Default colour mappings are No colour matching, 16 Colours, and 256
Colours.

Intensity Matching
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Intensity matching is either off (No intensity matching), or grouped into a number of equal
ranges (Group by intensity), controlled by the Groups, From and To fields.

Create

Pressing Create will generate a list of features for the number of colours multiplied by the
number of intensity ranges.  Each feature is mapped to the nearest SCC palette colour and
named based on colour and intensity.  The scheme also includes a DTM field to allow
certain points to be either excluded from the surface or removed entirely.  For example,
setting the DTM code to IGNORE for all colours that represent a shade of green would strip
most vegetation from the input data.  Similarly points with low intensity values could be
easily excluded.

Scheme Name

File name, Save, New

Feature Mapping

These fields allow colour and intensity schemes to be saved and loaded to and from file
such that they can be re-used.

Using the 2.6 million point file available from the SCC Tutorials folder, 'ROAD-0mm.PTS'
yielded the following results on an older 2ghz Athlon based PC under XP with 2GB of
memory.

Vertical tolerance set to 10mm, 256 colour processing took 7 minutes and resulted in an
optimized TIN model of 47 thousand points taking  12mb on disk.  The model is shown
below in plan, where we can see that the bulk of the points relate to the grass, the kerb
edges, and the instrument box and tripod.
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Using 'VIEW > Rotate viewpoint' the model can be viewed in perspective, as shown below;

By re-running to input with all colours except blacks and greys and very dark shades filtered
out as shown, we further automatically reduce the base model size to slightly over 27
thousand points. 
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This corresponds to automatic elimination of 99% of the input points to create a model with
a vertical accuracy of within 10mm of the original data.

To start creating strings, select 'TOOLS > Point Cloud  Trace linear features' which will split
the screen with a new dialog on the bottom as shown.  Tracing linear features is broken
down into two stages; 

· Creating a reference line which involves drawing a polyline roughly parallel to the features
you wish to extract.  For example on the drawing below, we created a reference line by
left clicking on the road beside kerb bottom at the top left hand corner of the drawing and
again at the bottom left hand corner of the drawing.  Right clicking closes the reference
line, and switches to string selection mode.  You can also change geometry when
creating curved or angled reference lines by picking the appropriate tag code or geometry
icon.  So for example, the quickest way to create a reference line for the curved sections
in the model is to use a 3 point arc.  All points on the reference string should lie on the
model, as this is a 3d entity corresponding to a simple alignment string.

To start a new reference line, simply press the New ref line button, which is also useful if
you have made a mistake on your current reference line.  Note that the reference line should
lie entirely on one side or another of the set of features we wish to extract.

· Selecting strings to extract.  Once you right click when creating a reference line, you can
start selecting strings.  As you move the mouse around the screen, you’ll notice a
sample section line in plan and in section on the bottom of the screen.  The width of this
section is controlled by the Left Ofs and  Right Ofs fields.   Pressing the left button again
locks the chainage of the section, and as you move the mouse you will now see a vertical
line in on the section corresponding to the mouse offset position in plan.  Pressing the left
mouse button again creates a point at the current offset, and adds it to the spreadsheet
beside the section.  The feature name and position can be edited in this sheet.
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Pressing the right mouse button unlocks the chainage and allows you to move the section
along the reference line, showing the selected points with the cut surface at varying
chainages.

Pressing the create button creates the selected strings based on the parameters given. 
These are as follows;

Ch. Int.

This is the interval at which points will be created on the new string

Horiz. Tol.

This is the horizontal search distance that will be used to find a point from the cloud data to
add to the new string at the current chainage.  The distance is an offset distance from the
reference point, and all points are searched within this distance and half the chainage
interval along the line.

Vert. Tol.

This is the vertical search distance that will be used to find a point from the cloud data to
add to the new string at the current chainage.  The distance is a height difference from the
reference point, and all points are within the defined horizontal tolerance are search.  Where
multiple points are found, the nearest point is selected.

Hold Hz Offset

If this option is selected, the new point is placed at the specified horizontal offset rather
than the offset of the nearest point found.  The effects of this can be seen on the pictures
below
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Hold Vt Offset  

If this option is selected, the new point is placed at the specified vertical offset rather than
the offset of the nearest point found.
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Hold regular chainage

If this option is selected, the new point is placed at the current chainage rather than the
chainage of the nearest point found.

Delete all points in hz offset range  

This option deletes all the point cloud data within the specified horizontal distance of the
points created for the chainage ranges along the alignment where new points are added.

Break string links over given length

This option forces the output strings to be broken between chainages over the specified
length where not suitable cloud points are found for the new strings.  In this case, extra spot
levels are added at the chainage interval and offset with heights interpolated from the model,
thus allowing deletion of extra unwanted points while maintaining the shape of the surface. 
This can be seen in the drop kerbs in the circular sections of the example below.

Extracting the linear features using the parameters given, and using the polygon selection
options to delete the unnecessary grass points, tripod and instrument box, further reduces
the final model down to approx two thousand point.  This string model is now usable in most
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CAD, engineering, and visualisation packages with very little overhead, and represents a
reduction in size by a factor of over a thousand from the original input data.

30.2 Processing PTS Point Clouds

SCC can reduce, process and compare point clouds in PTS format using SCC. The steps are as
follows;

Create a new project, or open an existing one

'FILE > Open > SCC Project' and pick 'PM-Clouds.Project'

Model PTS File

Select 'FILE > Model > Point clouds & LIDAR > PTS file' which will show the following dialog;
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The default options shown above stream in a file in monochrome to an accuracy of 10mm. 
The fields are used as follows;

Stream and optimize for TIN modelling

Selecting this option inputs processes the point cloud in smaller sections such that SCC
can handle very large point clouds relatively quickly.  As data is input it is optimized to the
specified vertical tolerance, and any points that would not make a change to the final
surface are discarded.  This eliminates vast number of co-planar points where they exist,
leading to a much smaller, faster and more efficient TIN model without sacrificing any
accuracy as would be the case with simpler decimation techniques.

Accuracy Tolerance

This is the vertical accuracy to which the TIN model is optimized.  All points that would not
affect the final surface by more than this amount are removed.

Maximum Iterations

This specifies the maximum number of times the optimization process is repeated.  If no
changes are made on any given iteration, the optimization is halted.

Optimization interval

This is the number of points at any given time that are held in memory when streaming and
optimizing.

Colour and intensity mapping

These fields control how the RGB colours and intensities in the input data are mapped onto
SCC features.  Default colour mappings are No colour matching, 16 Colours, and 256
Colours.

Intensity Matching

Intensity matching is either off (No intensity matching), or grouped into a number of equal
ranges (Group by intensity), controlled by the Groups, From and To fields.

Create



472

©2018 Atlas Computers Ltd

Pressing Create will generate a list of features for the number of colours multiplied by the
number of intensity ranges.  Each feature is mapped to the nearest SCC palette colour and
named based on colour and intensity.  The scheme also includes a DTM field to allow
certain points to be either excluded from the surface or removed entirely.  For example,
setting the DTM code to IGNORE for all colours that represent a shade of green would strip
most vegetation from the input data.  Similarly points with low intensity values could be
easily excluded.

Scheme Name

File name, Save, New

Feature Mapping

These fields allow colour and intensity schemes to be saved and loaded to and from file
such that they can be re-used.

Using the 16 million point file available from the SCC tutorials folder, 'CHECK1.PTS' yielded
the following results on an older 2ghz Athlon based PC under XP with 2GB of memory.

Vertical tolerance set to 10mm, monochrome, processing took 29 minutes and resulted in
an optimized TIN model of 32 thousand points taking 4.6mb on disk.  The model is shown
below with 0.1 meter contours;

Vertical tolerance set to 5mm, monochrome, processing took 42 minutes and resulted in an
optimized TIN model of 242 thousand points taking 25.5mb on disk.  The model is shown
below with 0.1 meter contours;

While contours and sections from these models look almost identical, the higher resolution
model shows up line work relating to very shallow (<10mm) depressions in the surface that
may be of value to the client.  There is also a dark patch near the centre of the model,
which is not present in the 10mm model, which correlates to the scanner position.  This
suggests that the scanner is slightly less accurate or prone to interference at very close
ranges (e.g. ~5mm of noise at less than 10 meters range in this case).
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Vertical tolerance set to 2mm, monochrome, processing took just under 4 hours and
resulted in an optimized TIN model of 2.3 million points taking 362mb on disk.

For the purposes of this exercise a 5mm vertical tolerance was used throughout.  The same
process was applied to BASE1.PTS which yielded a 48 thousand point model based on
5mm optimization as shown below.

To compare the base and check models, use 'VOLUMES > Volumes between surfaces
(prismoidal)' using the default values, as shown below;

This generated an isopachyte (height difference) model shown below, which can be coloured
using relief contours as shown.

To take the test points in select 'FILE > Import > ASCII X,Y,Z' and pick the text file provided,
Laser Scan Pointstxt.txt.  
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The file will initially have the levels in the text file.

Select 'FILE > Save' to save this to disk as an SCC dataset.

To extract height differences for the points in the text file, go back to the isopachyte model and
select 'TOOLS > Add ground levels to a dataset picking the dataset just saved and the
parameters shown.

Going back to the dataset view, it can be seen that any points that overlaid the two models
now have a height difference in the Z column.

To remove all the other points, select 'EDIT > Replace' with the values shown below, followed by
'TOOLS > Delete ignored points'

Columns can then be copied and pasted to other programs such as Excel, Word, Notepad,
etc… as required.  The values below have been copied from SCC;

Extract of file:

    95      654.559     3009.412    -0.1127

    99      655.153     3011.322    -0.0074

   103      655.748     3013.231    -0.0017

   107      656.342     3015.141    -0.0027

   109      656.468     3008.818    -0.1453

   112      656.937     3017.051    -0.0076

   114      657.063     3010.727    -0.0060

   117      657.531     3018.960    -0.0106

31 Radial Comparison From Point Cloud Data

Support has been added for radial analysis of point clouds based on alignment, for the purpose of
creating tunnel sections directly from scanned data with no additional interpolation.

This tutorial covers the use of the SCC survey, point cloud and sections modules to compare
tunnels models, scanned using the Leica MS50, for deformation monitoring purpose.

Control and scan information for the tunnel is collected using the MS50. Control Observations
from the MS50 is downloaded SCC using DBX.

31.1 Project Creation & Data Download

Create New Project

'FILE > New Project' 
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Pick a appropriate project name and template

Download Survey Data

'FILE > Download Survey', pick the Leica 1100/1200 logger and DBX as the input device.  

When the DBX translation dialog is shown change the DBX folder to point to location in which
your MS50 scan data is stored and press Refresh to update the dialog.

Select SCC-TPS2GSI-v4.frt as your format file, click on your job file name (e.g. M4PIER82 in
this case) and press OK.
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Select MS50Trav.GSICONFIG in the Leica data input dialog and press Ok to download and
import the survey data into SCC.

This will download control observations into the traverse spreadsheet, and any known
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entered station coordinates into the project station coordinates sheet.

31.2 Traverse Adjustment

Switch to the station coordinates sheet, and change the type of any known coordinates to either
Fixed or Constrained in both XY and Z as required.

Switch back to the traverse observation view, and select 'EDIT > Adjust' 

If the initial occupied stations are unknown (i.e. computed by resection or free station) make
sure to have the option to exclude fixed bearings for opening and closing set-ups ticked, as
the opening orientation will not be known.  Instrument accuracies for height, angle and
distance should be entered based in the stated accuracy of the instrument in use, number
of rounds of measurement taken, and anticipated standard errors.
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Check the traverse report to ensure that the errors reported and station positions and
heights are all within an acceptable tolerance.  Specific attention should be paid to
chi-squared pass/fail results, error ellipses and height errors, and observation residuals. 
Where scanning is being carried out at the same time as control measurement, the
absolute accuracy of  any scanned point will be based around the station accuracy and
standard error of the scanner EDM.

If the adjustment results are acceptable, update the project station values as shown.

31.3 Reprocessing Scan Data

To reprocess the scan data based on the updated station values, select 'FILE >  Model > Point
Clouds & LIDAR > Leica MS50'. 

Pick your scanned project file, and tell SCC to recompute the scan positions based on the SCC
stations. 

Note that we only recompute scanner orientation when moving between grid systems, as
any transformation residuals are liable to reduce rather than improve overall accuracy.

Press OK on the point cloud, and create the model.

 You will need to repeat this process for each survey.
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Once we have two models created of the same tunnel in the same grid system we can
compare them as follows



481

©2018 Atlas Computers Ltd

31.4 Comparison of Two Models

Open your base survey model 'Tunnel (Edited).Model' from \SCC\Tutorials\Point Clouds\

For the purposes of this tutorial, we're only interested in the tunnel itself.

Press right click to bring up the point cloud data selection dialog, select 'All points in polygon'
and press 'Isolate points'.
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Left click on four or more points to form a polygon around the tunnel, and right click to turn off
all points not inside that polygon.
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Select 'CLOUD > Point cloud features', and change the Analysis of Tunnel from Other 3D to
Other Radial. 

This means that section points on this feature will be connected radially from the alignment
centre line.

Select 'VIEW >  Rotate Viewpoint, followed by Two point elevation to create a view point that
looks down the tunnel.  

Note that by changing the angle in the rotation side bar dialog to a small value, e.g. 1
degree, we can make fine adjustments to this view as required.
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To set the feature of any group of points, right click to bring up the point cloud data selection
dialog, select 'All points in a polygon' and press 'Select points'.  

Left click on all the polygon points, and right click to select / highlight all the scanned points
inside that polygon.

Select 'CLOUD > Edit Selected points', and change the feature of the selected points as
required.  Repeat this process to edit the cloud such that tunnel walls and ground are separated,
and any spurious information is set to another feature such that it can be easily identified in
section.

Press 'P' to return to a plan view, and 'SECTIONS >Long section with cursor' to verify the
model is correct.  

To create the section left click on two points, one on each side of the tunnel, and right click to
finish.
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To create cross sections for a comparison, an alignment centre line is needed.  

This can be imported from DXF/DWG, LandXML, or GENIO as requied.  In this case, draw
the centre line manually.

Select 'EDIT > Add strings with cursor'.  

Place the mouse over the centre of the tunnel in plan and press enter.  This will show a dialog
with the current mouse position.  Enter a height of 116 for this point and press ok.  Repeat for a
point at the other end of the tunnel, and press the right mouse button to bring up a pop-up menu. 
On this menu, select Save string as interface, as give this new alignment a name as shown.
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A chainage, offset and centre line height for the tunnel have been achieved, which are draw
as a yellow line in the model.  As the mouse cursor is moved around the screen, the
chainage and offset is reported in the status bar in addition to X,Y,Z.

To cut some cross sections, select 'SECTIONS > Cross sections from an alignment' using the
values given.
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To add another survey model onto these sections, use 'EDIT >  Append surfaces' and pick your
second model.
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Select View / Radial annotation to show the radial separation between the two surfaces.  

In this case, the radius of the base model is annotated and the difference in radius at offsets
-1 and 1 and at every 20 degrees from the centre line.

Separate features are used to show radial lines, differences and out of tolerance points.  

A sample section style is also available to highlight these features, which can be loaded using
'FILE > Load save section style', and picking MS50-Tunnels.SectionStyle
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To export the differences in report format, select 'FILE > Reports' and pick 'Section radial
comparisons.rpt'.

Pressing the top left button in the report viewer can be used to export  the report to other
formats such as Excel or PDF for analysis and archive purposes.
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31.5 Additional Radial Reports

Additonal Reports are available such as 'Section radial comparisons (with X,Y).rpt'  which will
produce the following;
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Note that you can also use File / Export / Export sections to a survey dataset, and model
this dataset to get a further visual, e.g.
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31.6 Further Visualisations

Note that using 'FILE > Export > Export sections to a survey dataset', and then modelling
this dataset further visualisations can be achieved:
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In addition the original point cloud can be attached.

32 Point Cloud Volumes By Area

This tutorial can be implemented using either the user own point cloud models or the samples
provided (Cathedral, Topo, and Bridge).  To create a new point cloud model you need data in
either PTS, LAS, LAZ, or ESRI ASC format.  LAS and LAZ are significantly quicker to import
than the ASCII based PTS format.

32.1 Importing Point Cloud Data

To start select 'FILE > Model > Point Clouds & LiDAR' and pick the appropriate input format.
This will show the following screen;
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The colour usage option controls how much space is used per point, where RGB12 allows
about 100 million points on a system with 1GB available memory.  Palette and grey scale
systems are slower to import data, but more efficient at the loss of some colour resolution. 
Selecting the Create palette option builds a palette and cloud feature library, based on
paramers selected.  This can be an optimized palette from the cloud RGB data, a colour
range corresponding to intensities, or the standard AutoCAD 256 colour or VGA 16 colour
palettes.

32.2 Point Cloud Data Selection

Pressing the edit button allows the user to make further edits to the point cloud feature
library, and save it for re-use on other point clouds.

Point cloud functionality is accessed in the model via the 'Cloud menu' and / or 'Point Cloud'
tool bar.

The most commonly used option will be data selection, which shows the point cloud
selection dialog.  The allows you to control how you are going to pick data (i.e. points in a
window, points in a polygon, using a horizontal or vertical section / slice, relative to an
alignment,  points similar to a given reference point, points close to another SCC surface)
and what to do with picked data.  This includes selecting and de-selecting data as per
typical SCC usage, locking and unlocking data which hides the data and prohibits it from
being used in future operations, and isolating data which is the same as locking everything
except the picked points.
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32.3 Isolating Area Of Interest

Open the Cathedral model from the tutorials directory

Isolate an area of interest by right clicking the mouse to bring up the Data Selection dialog.

Set up the following parameters:
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After pressing 'All points close to a line' and 'Isolate Data', select 'Close'

Draw the centre line of the section line of interest by left click on the model (first point and last
point of line).

This highlights the area of interest as an elevation and switches the colour of all the locked
points to light gray.  Pressing ‘P’ and ‘E’ will move between plan and elevation view to get a
better idea of what has just happened.

the up, down, left and right arrows are used to advance and move the section relative to the
direction of view.  The distance here is based on the Section offset increment in the data
selection dialog, which can also be brought up using the right mouse button.  From plan
view we can also use the mouse at any stage to pick an alternate section as shown below;
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Other keyboard options are + and – to widen or narrow the area of interest, and L and X to
move between long section and cross section related view when selection a sectional area
relative to an alignment.

When a horizontal section / area of interest is in use the arrow keys may be used to raise
or low the elevation of the section.
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Note that as the cursor is moved around in the cloud, either in plan or another view, the
x,y,z position of the cursor in the cloud can be seen, and cloud positions can be snapped
to as in any other survey point.  

How this works is controlled via Cloud Options, which also helps control how the cloud is
treated as a surface for section and volume analysis.  

Note that only active points are used for snapping, and other operations such as data
selection, and export.  This allows the user to first select an area of interest for analysis
purposes and hide all other parts of the cloud, and then select further points from that area
of interest for editing.  To illustrate this better TOPO.Model from the SCC tutorials directory.
When viewed in elevation the model can be seen to contain a lot of trees and street furniture
that can be exclude from any surface analysis such as sections, volume, and contours. 
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32.4 Rotating Viewpoint

To get an elevation of the entire cloud, select 'VIEW > Rotate Viewpoint > Two point elevation',
picking points at either end of the road.  

All of the upper foliage can be obtained using a polygon selection method, trimming the
trunks closer to the ground is more problematic, as some are hidden behind hills, fences or
in dips in the ground.

The solution here is to first isolate an area of interest, and then select from within that area,
e.g.
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Note:

The option to allow setting a view point origin and orientation using the mouse and keyboard
has been made optional, such that those primarily working in plan can't inadvertently
change their viewpoint.  This is controlled within 'FILE > General Options > Units & Data
Checking > Allow mouse to be used to rotate'
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32.5 Analysis Of Surfaces

Note that one of the quickest ways of carrying out this type of analysis on a large
topographic model is to develop a rough SCC TIN model based on a sample of spot levels
taken from the cloud, and selecting all the points a set distance above this model, by
ticking Height relative to selected surface in the data selection dialog.

Once data is selected, it can be copied, deleted, re-coloured, and most importantly grouped
by feature using Cloud / Edit selected points.   

When features are assigned to groups of points, the groups can then be processed and
different types of analysis applied.  This is done using Cloud / Point cloud features, which
shows the following dialog.  The point feature fields are as follows;

· Feature – The name of the feature

· Surface – The surface on which the feature is placed.  Note that you can have multiple
features placed on the same surface, e.g. trees and bushes might both go on a
vegetation surface

· Analysis – This controls how SCC interprets these points for surface analysis purposes.
Options are

· Display only – The points are displayed only, but not subject to analysis

· Ground – The points are treated in the same way as the triangulation surface in a
normal SCC model, from the point of view of sections, volumes, draping points,
extracting levels, etc…

· Other surface – The points are treated in a similar manner as an additional triangular
surface, such as a reference model.

· Other 3d – The points are treated as a non-mappable 3d surface, not suitable for surface
analysis operations.  Sectioning through 3d surfaces will be considerably slower than
ground / mappable surfaces.

· Colour – The default colour of this feature when not coloured by point

· Colour by point – Whether points on this feature have individual colours or the same
colour

· Visibility – Controls whether or not these points are displayed, and if they are displayed
whether they are considered opaque or transparent.

· Lock – Whether or not these points are included in analysis

· Size – The size of displayed points

· Sect. Width – The search corridor width used when cutting sections through this feature.
Note this will typically be small for ground surfaces, e.g. 10mm, and larger for 3d
surfaces, e.g. 100mm – 500mm.  The larger this value, the more 3d data will get
projected onto a section and analysed.  This in turn can slow down processing and
significantly increase the size of sections produced.
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· Max Dist. – For 3d features, the maximum distance to which points will be connected.

The sample models 'Cathedral.Model' and 'Topo.Model' already have some features applied. 
Different items appearing when displayed in section. As shown in the examples below:

The feature library is also very useful for quickly colouring and analysing monochrome point
clouds, as shown in the model below (Tunnel 950-1050 (edited).Model)
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By selecting and isloting appropriate elevation and sectional areas, data can be quickly
differentiated the tunnel, cabling, rails, and foliage.  This in turn allows the user to cut
complex sections, develop a ground surface and isolate features of interest.
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32.6 Trace Outline From Slice

In addition to cutting sections there are a number of other ways to extract linear data and
analyse cloud surfaces.  The simplest of these is via 'CLOUD > Trace outlines from slice',
which will draw outlines based on an isolated sectional area.  This can be either from plan,
elevation or based on an oblique viewpoint.
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The results can then be exported to other packages, such as CAD, in 2d or 3d, and multiple
slices can be used to build-up a wire frame model from the cloud.  The cloud feature library
determines how the data is analyses, where the centre of the displayed section or slice is
used as the centre-line for sectioning.

To extract linear features, sure as kerb lines, from the cloud, use 'CLOUD > Trace linear
features'.  This function allows the user to create or select a reference line, which is a line
running roughly parallel to the desired features, and create strings based on similarity to a
given section template.  To demonstrate this, do the following;

· Select an active tag code of Curve

· Zoom into the area of Topo.Model shown below

· Left click on three or more points within half a metre of the kerb to generate our reference
string.  Right clicking finishes the reference string and start analysing the data.  Select
any other active alignment to use as our reference string, or press New to create a new
reference string.

· Once a reference string is defined, moving the mouse in the model cuts a cross section
through the cloud at the chainage nearest the cursror, which is shown on the bottom left
of the screen.

· Left clicking again freezes the position of this section, and further left clicks let us to pick
sample template points.  Pressing right click unfreezes the section position.
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· Once points are selected, change the feature names and adjust the position in the
section template sheet at the bottom of the screen.

· Pressing create, generates strings based on this template, with points at the specified
chainage interval.

The horizontal tolerance controls how much the template can move along the section, from
chainage to chainage, to find a best fit with points from the cloud.  The vertical tolerance
controls the maximum difference in relative vertical separation between points on the
template and corresponding points on the cloud for the cloud points to be considered
acceptable as string points.  Where the vertical tolerance is not met, spot level points are
out in place of string points at the correct horizontal position and cloud elevation.  This
helps identify areas such as drop kerbs, and positions where the feature has been occluded
from the scanners line of sight.

The user can also triangulate selected areas of interest for further analysis and export to
software that does not support point clouds.  In this case create a small alignment and
select points in an area 7.5M either side of the centre line as shown below.
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32.7 Triangulate Points

To triangulate the data, select 'CLOUD > Triangulate points', which gives the option of producing
an optimized triangulation of the selected data.  

This reduces the amount of points used from the selected points in the cloud to just those
required to achieve the stated vertical tolerance, in this case 10mm.  Note, this option can
be slow depending on the parameters and the number of points selected.  To improve
performance and final result remove or isolate noisy features such as grass, trees, cars,
street furniture and overhead cables prior to running this option.  Only selected points
whose features have an analysis type of Ground are considered when running this option,
so simply changing the feature of such points to any other feature will accomplish this. 
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Other options relating to point cloud processing include linear feature extraction, density
based feature extraction (stringing clumps of points), tracing string manually in conjunction
with cloud snap, and use of other surface based tools in conjunction with the point cloud
ground surface rather than the TIN.

To add further information to our TIN model, from coarser areas of the model that may have
lower accuracy requirements, use 'TOOLS > Extract a grid of levels', and add the generated
data to the TIN created above, along with traced linear features such as kerbs described
earlier.  

Note that when extracting a grid of levels, it is best to select the option to snap to the level
of lowest point in the defined snap search radius, as this will tend to generate a more
uniform surface, skipping small vegetation and similar items.  This is set under 'CLOUD >
Point cloud options'.

33 Tree Survey

This tutorial covers the steps required in processing a tree survey in ADB format in SCC and
producing CAD drawings.

33.1 Create New Project

'FILE > New Project', entering a name for the new project and selecting 'Trees.Project' as the
template.

The project template contains the naming conventions, symbols, and drawing conventions
that will be used when creating models.  Creating a new project also creates a folder in
which all project items, such as models and drawings will be stored.
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33.2 Model ADB Tree

'FILE > Model > ADB tree file'

Pick the sample

Select Initial Plot Scale 250 and press 'Create the model and triangulation'

This creates the following model;
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33.3 Exporting To CAD

To create an AutoCAD drawing of this model, select 'FILE > Export model > CAD drawing',
using the settings as given below.

33.4 Tree Symbols

Note that tree symbols taken in ADB format are represented by five points, corresponding to
a point at the trunk, and four points on the edge of the canopy.  Colour, symbols and
annotation are determined by feature name, which corresponds to the category field in the
ADB file.

To examine this a bit further, select 'EDIT > Query and edit points' and click on tree T021.

The feature B2 is set up to draw a five point symbol using tree-sol for the canopy and
trunk-sol for the canopy, with draw blue used the outline and trunk, and light blue for the fill. 
The layer on which data will be exported can also be entered with the Query Model Feature
Library Entry screen.

To illustrate how this works, change symbol 1 TREE_0, the colours to brown and green,
and press ok.  When prompted do not update the project library with these changes.
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To create a new tree, or any other feature, select the feature name in the drop down box in the
top left of the screen, and use 'EDIT > Add strings with cursor', and click five times on the
screen on points corresponding to the trunk and four canopy points.  Note that the four canopy
points do not have to correspond to compass positions and can also be used to align the tree
canopy, such that they form a rough kite shape as shown below.

'EDIT >  Edit Strings > Move points can also be used to change any point on an existing string.
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