SCC Help

Atlas Computers Ltd
15 Moyville Lawns
Taylors Lane
Rathfarnham
Dublin 16
Republic of Ireland
Ph: +353(0) 1 4958714/5/6
Fax: +353(0) 1 4958717
Email: sales@atlascomputers.ie
support@atlascomputers.ie
www.atlascomputers.ie

All rights reserved. No parts of this work may be reproduced in any form or by any means graphic, electronic, or mechanical, including photocopying, recording, taping, or information
storage and retrieval systems - without the written permission of the publisher.
Products that are referred to in this document may be either trademarks and/or registered
trademarks of the respective owners. The publisher and the author make no claim to these
trademarks.
While every precaution has been taken in the preparation of this document, the publisher and the
author assume no responsibility for errors or omissions, or for damages resulting from the use of
information contained in this document or from the use of programs and source code that may
accompany it. In no event shall the publisher and the author be liable for any loss of profit or any
other commercial damage caused or alleged to have been caused directly or indirectly by this
document.
Printed: September 2015

SCC created by
Atlas Computers Ltd
Document written by
Atlas Computers Ltd
Date
16/09/2015
Reference Number
101
Revision Number
1
SCC Version
11

(C)Copyright2015,AtlasComputersLtd

The content of this document is provided for guidance
purposes only. While every effort is made in ensuring the
correctness of information presented, the document is
provided ‘as is’, without representation, condition, or
warranty of any kind, either express or implied, including,
but not limited to, fitness for use or a particular purpose.
Atlas Computers Ltd shall not be responsible under any
circumstances for any indirect consequential loss or
damage (including but not limited to loss of contracts or
profits) however caused or arising.

Table of Contents
1
Introduction

1

1.1
1.2
1.3

SCC Manual Overview
Installation and set-up
32 bit & 64 bit SCC Versions

1
2
6

2

Basic Concepts

6

2.1

Data storage and user interface

6

2.1.1
2.1.2
2.1.3
2.1.4
2.1.5
2.1.6
2.1.7
2.1.8
2.1.9
2.1.10

Project
Traverse
Dataset
Model
Section
Transformation
Alignment
Program Module
Using SCC with Microsoft Office and other
Windows Applications
Backup Strategies

8
10
12
14
15
16
17
18
18
19

2.2
2.3
2.4
2.5

Feature Names Conventions & The Feature Library
Strings
Models
Field Practice Applicable to SCC

19
21
22
24

3

Getting Started

25

3.1
3.2

Creating A New Project
Import & Downloading Files Into SCC

25
27

3.2.1

28

3.2.1.1
3.2.1.2

3.2.2
3.2.2.1
3.2.2.2
3.2.2.3
3.2.2.4

3.2.3
3.2.3.1
3.2.3.2
3.2.3.3
3.2.3.4
3.2.3.5

3.2.3.6
3.2.3.7
3.2.3.8
3.2.3.9

3.3

Importing Data Into SCC
Importing User Defined ASCII file
Importing Models From Landscape

Downloading & Processing Traverse Data
Displaying & Annotating the Traverse
Processing A Complex Traverse
Processing A Resection Network
Traverse Reduction & STAR*NET Export options

Downloading & Processing Detail Topography
Data
Downloading PocketDTM Data
Downloading Leica Data
Downloading Leica HexML Data
Downloading Panterra Data
Downloading Trimble Data
Downloading Trimble DC With Specific Attributes
Examination Of Feature Library
Trimble Exchange
Downloading TopCon Data
Downloading Sokkia Data
Downloading Sokkia SRX/SDR33/SDR22
Downloading MOSS Site Module Data
Downloading X,Y,Z coordinates from GPS

29
32

33
38
40
42
45

48
48
48
70
70
71
78
84
100
102
111
112
116
117

Creating A Model

118

3.3.1

119

Topographic Model Creation & Editing

©2015 Atlas Computers Ltd

3.3.2

Creating A Model from An External File

3.3.2.1
3.3.2.2

Modelling A DXF File
Modelling A GENIO File

120
120
121

3.4
3.5

Triangle Editing
Annotation In The Model

122
125

4

The Feature Library

132

4.1

Using the Feature Library

133

4.1.1
4.1.2
4.1.3
4.1.4
4.1.5
4.1.6

133
133
135
135
136
143

Creating Rectangles (Using the Feature Library)
Creating Strip Levels (Using the Feature Library)
Creating Trees (Using the Feature Library)
Inaccessible Linear Features
Developing SCC Feature Library for use with MX
Symbol Creation & Insertion

4.1.6.1
4.1.6.2

Creating a Circle Symbol (Using the Feature Library)
Creating symbols from DXF or DWG (Using the
Feature Library)
Creating Symbol and redefining baseline

4.1.6.3

146
149
152

5

Editing A Model

158

5.1
5.2

Probable Modelling Errors
Correcting Survey Errors

161
162

5.2.1
5.2.2
5.2.3
5.2.4
5.2.5

Control Orientation Error
Control Shift In Plan
Control Station Datum Error
Surface Model Errors
Determining The Height Value of Crossing
Breakline

162
163
164
165

String Errors
Point Editing
String Editing
Survey Error Detection & Correction
Using SCC Editing Facilities to Rectify Survey
Errors

171
172
173
175

5.7.1
5.7.2
5.7.3
5.7.4
5.7.5
5.7.6
5.7.7
5.7.8
5.7.9
5.7.10
5.7.11

176
179
181
181
185
186
187
188
190
191
192

5.3
5.4
5.5
5.6
5.7

5.8

Delete Points & Strings
Breaking String Links
Partial Delete
Annotating Strings
Using The String Editor
Moving Points On A String
Extending Strings To Intersect
Trim Lines
Copying/Moving Strings
Adding Slope Lines To A Model
Adding Hatching To A Model

169

176

Editing Pre-selected Data

193

5.8.1

195

Surveying Circular and Curved Objects

6

Generation Of Boundaries

202

6.1

Additional Samples of Creating A Boundary String

203

7

Import & Export From Model

208

©2015 Atlas Computers Ltd

7.1
7.2

Importing Additional Model Data
Export Data from SCC to CAD

7.3
7.4
7.5

Export Data from SCC to MX
Extracting An Elevation From A Model
Viewpoint

210
211
212

8

Typical QA Procedures for Survey Models

214

9

Volumetric Analysis & QA

215

9.1
9.2
9.3

Creating Profiles & Sections
Calculation Of Volumes Using Different Methods
Average End Area Method

216
219
219

9.3.1

221

7.2.1

Using SCC Text Styles with AutoCAD

Exporting User Defined ASCII file From Sections

208
209
210

9.4
9.5
9.6
9.7

Prismoidal Method
Grid Method
Calculating Spoil Heap Volumes
Identification of Potential Errors In Volumes

227
228
229
231

10

Section Editing

234

10.1
10.2
10.3

Section Snap Controls & Data Selection Options
Section Editing Of Surface & Non-Surface Strings
Adding Surface String & Point Data To An Existing
Section
10.4 Delete Points (Section Edit Menu)
10.5 Move Points (Section Edit Menu)
10.6 Text (Section Edit Menu)
10.7 Symbol (Section Edit Menu)
10.8 Hatching Between Strings (Section Edit Menu)
10.9 Query Points (Section Edit Menu)
10.10 Removal of Specific Points from Section
10.11 Optimised Volumes

11

235
236
240
242
243
244
245
245
248
249
252

Interface Design Using The Alignment
Module

256

11.1
11.2

Simple Football Pitch Design
River Section: Sections From A Bandwidth

258
264

12

Presentation & Archiving of Measurment
Results

271

13

Reports Within SCC

273

14

Plotting From SCC

276

14.1
14.2

Creating Sheets in SCC
Creating a SCC Sheet Layout From a DXF/DWG file

282
283

15

Transformations

292
©2015 Atlas Computers Ltd

15.1
15.2
15.3
15.4

Performing A Transformation
Applying A Transformation
Transformation Report
National Grid Transformations

292
297
297
298

16

Alignments

298

16.1

Entering & Importing Data Into An Alignment

298

16.1.1
16.1.2
16.1.3
16.1.4
16.1.5
16.1.6

298
300
302
303
306
308

16.2
16.3

Getting Alignment Data From MFW into SCC
Attaching an Alignment To A Model
Interactively Editing The Alignment
Typing Horizontal Intersection Points
Typing Vertical Intersection Points
Creating Mulit-Surface Section

Section Template Design On A MX Alignment
Getting Intersection Points from DOER

309
327

16.3.1
16.3.2

327
331

Getting Horizontal Intersection Points from DOER
Typing Section Template Points

16.4

Designing A Fixed Gradient Interface

334

17

Flow Lines

339

18

River Sections

341

18.1
18.2
18.3
18.4
18.5
18.6
18.7

343
344
345
346
346
347

18.15
18.16

Creating Project
Creating River Centreline Model
River Centreline Alignment
Downloading Surveyed Section Data
Examination of Dataset
Creating Surveyed Section Data Model
Attaching River Centreline Alignment to Survey
Model
Setting Preferred String Direction
River Section Creation
Displaying Structure On Sections
River Section Annotation
River Section Scale Titles & Grids
Editing Sections Using Query & Edit Function
Exporting to Modelling Packages: ISIS, MIKE and
HECRAS
Exporting Text To GIS Attributes: Shape Files
River Section Displayed on Model

19

Blunder Detection And Analysis

365

20

Rail

369

20.1
20.2
20.3
20.4

Wriggle Survey Processing
String Comparison & Overlap Processing
Lift And Slue Reporting
Rail Cant Computations

369
373
376
378

18.8
18.9
18.10
18.11
18.12
18.13
18.14

©2015 Atlas Computers Ltd

348
348
349
355
357
358
359
359
363
364

20.5
20.6

21

Amberg Trolley Data
Wriggle Survey From Point Cloud Data

382
382

20.6.1
20.6.2
20.6.3
20.6.4

382
385
387
388

Setting Analysis Of Data
Setting Arbitary Centreline
Cutting Sections
Wriggle Analysis

Processing LandXML File In SCC For
Machine Control

391

22

Working With AutoCAD Civil3D Files

401

22.1
22.2

Exporting TIN models from SCC to Civil 3d
Importing AutoCAD Civil3D files into SCC

401
406

23

Using Adjustment Constraints

410

24

Working With Trimble Data

424

24.1
24.2
24.3
24.4
24.5

Create A Project
Download Trimble Data from ACU
Examination of Sample Code List For Trimble Unit
Download Trimble Data with Specific Attributes
Creating A Model

424
424
431
450
452

25

Working With Leica Data

452

25.1
25.2
25.3

Create A Project
Download Leica Data
Creating A Model

452
452
474

26

Point Cloud Module

474

26.1
26.2
26.3
26.4
26.5

Importing Point Cloud Data
Selecting And Isolating Parts of the Cloud
Point Cloud Feature Library
Tracing Sections and Slices
Tracing Linear Features On A Point Cloud

474
475
481
483
484

26.5.1
26.5.2
26.5.3
26.5.4
26.5.5

485
486
486
488
489

26.6
26.7
26.8
26.9

Select Or Create A Reference Alignment
Enter Template Size & Parameters
Creating Points On The Template
Creating Strings
Linear Feature Extraction Parameters

Extracting A TIN Surface From The Cloud
Tracing 2D Features Such As Road Markings
Using The Cloud With Other SCC Model Options
PTS Point Cloud Data
26.9.1
26.9.2

Extracting Linear Features From PTS Point
Clouds
Processing PTS Point Clouds

26.10 Cloud Volumes
26.10.1
26.10.2
26.10.3

Creating New Project
Importing MS50 Data
Rotating Viewpoints

491
493
495
497
497
505

509
509
510
510
©2015 Atlas Computers Ltd

26.10.4
26.10.5
26.10.6
26.10.7
26.10.8
26.10.9

Cloud Data Selection & Editing
Check Cloud Surface Data
Creating Base Model
Volumes By Average End Method
Volumes By Prismoidal Method
Export To Google Earth

26.11 Point Cloud Volumes By Area
26.11.1
26.11.2
26.11.3
26.11.4
26.11.5
26.11.6
26.11.7

Importing Point Cloud Data
Point Cloud Data Selection
Isolating Area Of Interest
Rotating Viewpoint
Analysis Of Surfaces
Trace Outline From Slice
Triangulate Points

26.12 Radial Comparison From Point Cloud Data
26.12.1
26.12.2
26.12.3
26.12.4
26.12.5
26.12.6

Project Creation & Data Download
Traverse Adjustment
Reprocessing Scan Data
Comparison of Two Models
Additional Radial Reports
Further Visualisations

26.13 Cutting Sections From MS50 Data
26.13.1
26.13.2
26.13.3
26.13.4
26.13.5
26.13.6

Create New Project
Downloading Control Data
Processing Traverse
Reprocessing Scan Data Based On New Station
Values
Creating Cross Sections For Comparison
Editing Scan Data Using Sections

26.14 Transforming A Cloud To Show Differences To A
Template Or Cylinder
26.14.1

Creating A Centreline Template

511
512
512
514
515
520

521
521
522
523
527
530
533
536

537
537
540
541
544
553
555

556
557
557
559
559
560
562

564
569

27

Tree Survey

572

27.1
27.2
27.3
27.4

Create New Project
Model ADB Tree
Exporting To CAD
Tree Symbols

573
573
574
574

28

System Settings

576

28.1
28.2

General Options (File Menu)
Workspaces (File Menu)

576
589

29

Import & Export

590

29.1
29.2
29.3
29.4
29.5
29.6
29.7

Import SCC Text File (File Menu)
Import Comma Separated file (File Menu)
Import Fixed format ASCII file (File Menu)
Import STAR*NET Co-ordinate file (File Menu)
Import MOVE3 Co-ordinate file (File Menu)
Import DWG/DXF File (File Menu)
Import LandXML (File Menu)

591
591
591
592
592
592
593

©2015 Atlas Computers Ltd

29.8
29.9
29.10
29.11
29.12
29.13
29.14
29.15
29.16
29.17
29.18
29.19
29.20
29.21
29.22
29.23
29.24
29.25
29.26
29.27
29.28
29.29
29.30

Import X,Y,Z ASCII file (File Menu)
Import ESRI Shapefile (File Menu)
Import ASCII Wriggle Survey (File Menu)
Import Amberg (GRPwin format) (File Menu)
Import Amberg (AR2 format) (File Menu)
Import AutoGrad/MSMM ‘As Set-Out File’ (File
Menu)
Import AutoGrad/MSMM Levelling File (File Menu)
Import AutoGrad/MSMM GDS Printout (File Menu)
Import DOER Husky File (File Menu)
Import MOSS GENIO File (File Menu)
Import MOSS 992 Report (File Menu)
Import MOSS 994 Report (File Menu)
Import User defined ASCII co-ordinate file
Panterra PXT
Import Steanne MIDAS File (File Menu)
Import SDRMAP ASCII File (File Menu)
Import Eclipse Report File (File Menu)
Import ESBI Vectors File (File menu)
Import Symbols from DXF
Import SCC for DOS Project
Import Landscape (File Menu)
Import SC0 /SCN rail files (Sections File Menu)
Importing Alignment Data
29.30.1
29.30.2
29.30.3
29.30.4
29.30.5
29.30.6
29.30.7

Import MX/MOSS GENIO Geometry strings
(Alignment File menu)
Import Entities from DWG/DXF (Alignment File
Menu)
Import DOER HIPS (Alignment File Menu)
Import DOER VIPS (Alignment File Menu)
Import Simple ASCII HIPS (Alignment File Menu)
Import Simple ASCII VIPS (Alignment File Menu)
Import Nikon FRG file (Alignment File Menu)

29.31 Export Stations as dataset (File Menu)
29.32 Export Automated Demarcation Certificate (File
Menu)
29.33 Export Create a file CRC report (File Menu)
29.34 Export Fixed format ASCII File (File Menu)
29.35 Export Comma Separated File (File Menu)
29.36 Export STAR*NET Input File (File Menu)
29.37 Export MOVE3 Input File (File Menu)
29.38 Export CAD drawing (File Menu)
29.39 Export Optimal Pole CAD (File Menu)
29.40 Export MX (MOSS)(File Menu)
29.41 Export Survey Dataset (File Menu)

594
594
594
594
594
594
594
594
594
595
595
595
595
596
597
598
598
598
598
598
598
601
601
601
602
602
602
603
603
603

603
603
603
603
604
605
605
605
607
607
610
©2015 Atlas Computers Ltd

29.42
29.43
29.44
29.45
29.46

Export Alignment Dialog (File Menu)
Export Model (File Menu)
Export Google Earth KML (File Menu)
Export Nikon FRG file (File Menu)
Export IFC file (BIM)

610
611
611
611
611

30

Downloading

611

30.1
30.2
30.3
30.4
30.5
30.6
30.7
30.8
30.9
30.10
30.11
30.12
30.13
30.14
30.15
30.16
30.17

Download Survey Data (File menu)
Datalogger Communications
PocketDTM
Leica (1100/1200/Wildsoft/LisCADD)
Leica GSI 8/16
Trimble TSC/TSCe (DC)
Trimble /Geodimeter UDS
Trimble Job XML (JXL)
Sokkia SRX/SDR33/SDR22
TopCon (TopSurv & neutral formats)
Topcon GTS7 format
TopCon X, Y, Z
Nikon AP700
Nikon (Survey Supplies .NIK)
MDL ADS CDS &CDU
MOSS SURVEY formats (Leica VIP, SDR33 MOSS)
MOSS Site Measurement Module (MSMM)

612
614
614
621
622
627
628
632
635
635
635
635
637
637
638
639
640

30.17.1
30.17.2
30.17.3

641
641
641

Huskey Hunter (MSMM)
HP100LX/200LX RS232 (MSMM)
MOSS SURVEY coding extensions

30.18
30.19
30.20
30.21
30.22
30.23
30.24
30.25
30.26
30.27
30.28
30.29
30.30
30.31

GPS X,Y,Z
Panterra
NRG PDF & GPF format
AASTHO SDMS
LSS Observation File
Zeiss REC Elta
Softdesk Field Book
NSS ASCII Export
Kingsland .OBS format
Geodimeter .DEC format
TDS
Trimble CST
Trimble SCS900
STAR*NET

643
645
645
645
647
648
650
650
650
650
650
651
651
651

31

Spreadsheets

651

31.1

Editing Spreadsheets

651

©2015 Atlas Computers Ltd

31.1.1
31.1.2
31.1.3
31.1.4
31.1.5
31.1.6

31.2
31.3

658
658

31.3.1
31.3.2

658
660

31.3.3
31.3.3.1
31.3.3.2
31.3.3.3
31.3.3.4
31.3.3.5
31.3.3.6
31.3.3.7

31.3.4
31.3.4.1

31.3.4.2
31.3.4.3

31.3.5
31.3.5.1

Station Co-ordinates
Project File Menu
Export (Project File Menu)
XML (Project File Menu)
Import (Project File Menu)
Upload Set-out (Project File Menu)
Co-ordinate Reduction Options (Project File Menu)

Project Edit Menu
Symbols (Project Edit Menu)
Line Types (Project Edit Menu)
Check Survey (Project Edit Menu)
Edit Feature to 3D Model Mapping (Project Edit
Menu)
Edit Section Coding (Project Edit Menu)
Edit Extra Title Fields (Project Edit Menu)
Compare Test Results (Project Edit Menu)

Project View Menu
Feature Library (Project View menu)
Feature Wizard (Project Edit Menu)
GIS Data Fields (Project Edit Menu)
Ground Type Library (Project View Menu)
Advanced Survey Coding (Project View Menu)

Project Model Menu
Point clouds & LIDAR (Project Model Menu)

Traverse
31.4.1
31.4.1.1
31.4.1.2
31.4.1.3
31.4.1.4
31.4.1.5
31.4.1.6

31.4.2
31.4.2.1

31.4.3
31.4.3.1
31.4.3.2

31.4.3.3

31.5

652
652
653
653
654
657

Reports (File Menu)
Project Spreedsheets

31.3.2.1
31.3.2.2
31.3.2.3
31.3.2.4
31.3.2.5

31.4

Mathematical Operations
Sorting Of Data Within Spreadsheets
Globally Edit A Range Of Data (Edit Menu)
Find (Edit Menu)
Replace (Edit Menu)
Insert Records (Edit Menu)

660
661
662
663
663

669
669
670
670
675
675
676
676

677
677
677
679
680
681

685
686

687
Introduction To Traversing
Case 1 - Loop Traverse With External RO.
Case 2 - Loop Traverse With Internal RO.
Case 3 - Link Traverse.
Case 4 - Loop Traverse Wth One Fixed Station.
Case 5 - Loop Traverse With Opening Back Sight
Case 6 - Open Traverse (No Adjustment)

Traverse Co-ordinates
Traverse Co-ordinates (View Menu)

Traverse Observations
Traverse Observations (View Menu)
Traverse Observation File Menu
Append A Traverse
Extract New Route
Check Traverse Route (Traverse File Menu)
Rebuild Traverse From Raw Survey File
Edit Raw Survey file (File Menu)
Traverse Edit Menu
Set-up (Traverse Edit Menu)
Reduce (Traverse Edit Menu)
Adjust (Traverse Edit Menu)
Corrections (Edit Menu)

Detail Observation

687
691
692
693
694
695
696

696
696

698
698
702
702
702
703
703
703
703
703
706
706
708

712
©2015 Atlas Computers Ltd

31.5.1
31.5.2
31.5.3
31.5.4

Detail Observations (View Menu)
Extra Measurements (View Menu)
Text Notes (View Menu)
Detail Observation File Menu

31.5.4.1
31.5.4.2
31.5.4.3

31.6

Edit Raw Survey file (File Menu)
Rebuild Obs From Raw Data (File Menu)
Rebuild Co-ordinates (File Menu)

719

31.6.1

719

Detail Coordinate (View Menu)
Break Long strings (Coordinate Tools Menu)
Change X,Y,Z to Y,X,Z (Coordinate Tools Menu)
Remove Duplicate Points (Coordinate Tools Menu)
Join adjacent strings (Coordinate Tools Menu)
Delete ‘Ignored’ points (Coordinate Tools Menu)
Move / Copy a string parallel. (Coordinate Tools
Menu)
Flip Sort Order (Coordinate Tools Menu)
Transform co-ordinates (Coordinate Tools Menu)
Search for String Errors (Coordinate Tools Menu)
Search for MOSS Errors (Coordinate Tools Menu)
Renumber Points (Coordinate Tools Menu)
Remove Loops (Coordinate Tools Menu)
Compute X,Y from Chainage, Offset (Coordinate
Tools Menu)
Compute Chainage, Offset from X,Y (Coordinate
Tools Menu)
Compute Vertical Design Offset from Z (Coordinate
Tools Menu)
Output Coordinates as Section Templates
(Coordinate Tools Menu)
String using Chainage / Offset (Coordinate Tools
Menu)
Compute Wriggle Survey (Coordinate Tools Menu)
Compute Vehicle Mounted GPS Errors (Coordinate
Tools Menu)
Compute Two Prism Rail Corrections (Coordinate
Tools Menu)

31.6.1.7
31.6.1.8
31.6.1.9
31.6.1.10
31.6.1.11
31.6.1.12
31.6.1.13
31.6.1.14
31.6.1.15
31.6.1.16
31.6.1.17
31.6.1.18
31.6.1.19
31.6.1.20

31.8

719
719
719

Detail Coordinate
31.6.1.1
31.6.1.2
31.6.1.3
31.6.1.4
31.6.1.5
31.6.1.6

31.7

712
716
718
718

722
722
722
723
723
723
724
725
727
727
728
728
728
728
729
729
729
729
731
732

Instrument Set Up

733

31.7.1
31.7.2
31.7.3

733
734
737

Station Orientation
Instrument Set Up
Corrections (Edit Menu)

Alignment Sheet

737

31.8.1

737

Alignment Design Menu

31.8.1.1
31.8.1.2
31.8.1.3
31.8.1.4
31.8.1.5
31.8.1.6
31.8.1.7
31.8.1.8
31.8.1.9
31.8.1.10
31.8.1.11
©2015 Atlas Computers Ltd

Design Vertical Alignment(Alignment Design Menu)
Section Templates (Alignment Design Menu)
X, Y, Z Shift (Alignment Design Menu)
Export Design as Dataset (Alignment Design Menu)
Export Design as Model (Alignment Design Menu)
Interface and Export Parameters (Alignment Design
Menu)
Compute Horizontal Entities (Alignment Design
Menu)
Compute Vertical Entities (Alignment Design Menu)
Compute Super-Elevation (Alignment Design Menu)
Check and Report Design Geometry (Alignment
Design Menu)
Compress Geometry (Alignment Design Menu)

737
739
741
741
742
742
743
743
743
744
746

31.8.2
31.8.2.1
31.8.2.2
31.8.2.3
31.8.2.4
31.8.2.5
31.8.2.6

Alignment View Menu
Horizontal Intersection Points (Alignment View
Menu)
Vertical Intersection Points (Alignment View Menu)
Horizontal Entities (Alignment View Menu)
Vertical Entities (Alignment View Menu)
Super-Elevation Nodes (Alignment View Menu)
Section Template Points (Alignment View Menu)

746
746
747
748
749
750
750

32

Modelling

752

32.1
32.2

Data Selection Dialog (Model)
Model File Menu

752
754

32.2.1
32.2.2
32.2.3

755
758
759

32.2.3.1
32.2.3.2
32.2.3.3
32.2.3.4
32.2.3.5
32.2.3.6
32.2.3.7
32.2.3.8
32.2.3.9
32.2.3.10

32.3

Attach / Detach
Workspaces (Model File menu)
Sheet Layout (Model File Menu)
Insert Sheet
Edit Sheet Properties
Move Sheet
Rotate Sheet
Delete Sheet
Create New Sheet Template
Add Titles Blocks and Legends
Saving The Sheet
Delete Existing Sheet Template
Viewing The Sheet

759
760
761
761
762
762
764
766
767
767

Model Edit Menu

768

32.3.1
32.3.2
32.3.3
32.3.4
32.3.5
32.3.6
32.3.7
32.3.8
32.3.9
32.3.10
32.3.11
32.3.12

768
769
769
770
771
771
771
771
773
774
774
775

32.3.12.1
32.3.12.2
32.3.12.3

32.3.13
32.3.14
32.3.15
32.3.16
32.3.17
32.3.18
32.3.19
32.3.20
32.3.21
32.3.22
32.3.23
32.3.24
32.3.25

Undo (Model Edit Menu)
Redo (Model Edit Menu)
Cut (Model Edit Menu)
Copy (Model Edit Menu)
Paste (Model Edit Menu)
Paste Special (Model Edit Menu)
Weed The Triangulation (Model Edit Menu)
Add and Remove Triangles (Model Edit Menu)
Flip Triangle Edges (Model Edit Menu)
Label Contours (Model Edit Menu)
Delete Contour Labels (Model Edit Menu)
Add Strings with Cursor (Model Edit Menu)
Add a new string with Feature Code
Add a new string with a Tag Code
Add a New String with DTM Status

Circles, Arcs & Rectangles (Model Edit Menu)
Delete, Points and Strings (Model Edit Menu)
Edit Strings (Model Edit Menu)
Text (Model Edit Menu)
Symbols (Model Edit Menu)
Line Types (Model Edit Menu)
Bitmap (Model Edit Menu)
Slope Lines and Hatching (Model Edit Menu)
Browse Model Points (Model Edit Menu)
Query and Edit Points (Model Edit Menu)
View Coordinate Computations (Model Edit Menu)
Offset Height of Selected Points (Model Edit
Menu)
Update Model Elevations from Survey (Model Edit
Menu)

777
777
777

778
779
782
783
787
791
792
793
794
795
800
801
801
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32.3.26
32.3.27
32.3.28
32.3.29

32.4

32.5

801
803
804
805

Model View Menu

805

32.4.1
32.4.2
32.4.3
32.4.4
32.4.5
32.4.6
32.4.7
32.4.8
32.4.9
32.4.10
32.4.11
32.4.12
32.4.13
32.4.14
32.4.15
32.4.16
32.4.17
32.4.18
32.4.19
32.4.20
32.4.21

805
807
808
811
814
818
819
821
821
822
823
823
824
824
824
833
834
834
835
836
836

Feature Annotation (Model View Menu)
Titles And Grids (Model View Menu)
Contours (Model View Menu)
Slope Analysis (Model View Menu)
Triangulation (Model View Menu)
Grid Mesh (Model View Menu)
Snap Controls (Model View Menu)
Coordinate Computations (Model View Menu)
Plan (Model View Menu)
Rotate Viewpoint (Model View Menu)
Feature Library (Model View Menu)
Station Coordinates (Model View Menu)
Model Source Files (Model View Menu)
Ground Type Library (Model View Menu)
3D Viewer (Model View Menu)
Status Bar (Model View Menu)
Customised (Model View Menu)
Extended Styles (Model View Menu)
Keyboard Short-cuts (Model View Menu)
Browse Model View
Show Or Hide Survey Observations Positions

Model Design Menu

838

32.5.1
32.5.2
32.5.3
32.5.4
32.5.5

838
839
840
840

32.5.6
32.5.7
32.5.8
32.5.9
32.5.10
32.5.11
32.5.12
32.5.13
32.5.14
32.5.15
32.5.16
32.5.17
32.5.18
32.5.19
32.5.20

32.6

Edit Extra Text Fields (Model Edit Menu)
Insert New Object (Model Edit Menu)
Object (Model Edit Menu)
Links (Model Edit Menu)

Horizontal Alignment (Model Design Menu)
Vertical Alignment (Model Design Menu)
Section Templates (Model Design Menu)
Move Alignment (Model Design Menu)
Create Alignment From String (Model Design
Menu)
Balance Cut and Fill (Model Design Menu)
Select Reference Alignment (Model Design Menu)
Create an offset setring (Model Design Menu)
View Design Sheet (Model Design Menu)
X, Y, Z, Shift...(Model Design Menu)
Export Design As Model (Model Design Menu)
Export Design As Dataset (Model Design Menu)
Interface and Export Parameters.... (Model
Design Menu)
Report Rail Lift And Slue (Model Design Menu)
Report Rail Cant And Gauge (Model Design
Menu)
Compare Strings And Remove Overlaps (Model
Design Menu)
Check and Adjust Formation Levels (Model
Design Menu)
Set the Gradient of Selected Points (Model
Design Menu)
Plane Fit Selected Points (Model Design Menu)
Undo Design Option (Model Design Menu)

Model Sections Menu
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841
842
842
843
843
844
844
845
845
846
846
846
847
847
847
848

849

32.6.1
32.6.2
32.6.3
32.6.4
32.6.5
32.6.6
32.6.7
32.6.8
32.6.9
32.6.10
32.6.11
32.6.12
32.6.13
32.6.14
32.6.15

32.7

Model Volumes Menu
32.7.1
32.7.2
32.7.3
32.7.4
32.7.5
32.7.6
32.7.7
32.7.8
32.7.9
32.7.10
32.7.11

32.8

Long Section with Cursor (Model Section Menu)
Long Section from Existing String (Model Section
Menu)
Long Section From An Alignment (Model Section
Menu)
Long Section from Coordinate Data (Model
Section Menu)
Cross Section From Existing String (Model
Section Menu)
Cross Section From An Alignment (Model Section
Menu)
Cross Sections From An SCC Section File (Model
Section Menu)
Section From Points in a Bandwidth (Model
Section Menu)
Long Section Using Paralllel Strings (Model
Section Menu)
River Section (Model Section Menu)
Live Section (Model Section Menu)
Vertical Tunnel Cross Sections Through Cloud
(Model Section Menu)
Oblique Tunnel Cross Sections Through Cloud
(Model Section Menu)
Edit Section Coding (Model Section Menu)
Non-surface String Cutting Options (Model
Section Menu)
Volumes between surfaces by area (Model
Volumes Menu)
Volumes to a Datum (Prismoidal) (Model Volumes
Menu)
Volumes to a Datum (Grid) (Model Volumes
Menu)
Volumes Between Surfaces (Prismoidal) (Model
Volumes Menu)
Volumes Between Surfaces (Grid) (Model
Volumes Menu)
Volumes of Spoil Heaps / Pits (Model Volumes
Menu)
Volumes And Areas by Depth (Model Volumes
Menu)
Volumes by Ground Type to a Datum (Model
Volumes Menu)
Volumes by Ground Type to a Depth (Model
Volumes Menu)
Areas by Ground Type (Model Volumes Menu)
Areas by Gradient (Model Volumes Menu)

Model ZVI & Flow Menu
32.8.1
32.8.2
32.8.3
32.8.4

Create ZVI Stations with Cursor (Model ZVI &
Flow Menu)
Edit ZVI Station Coordinates (Model ZVI & Flow
Menu)
View ZVI (Model ZVI & Flow Menu)
Flow Lines With Cursor (Model ZVI & Flow Menu)

849
850
850
850
851
851
852
852
852
854
859
860
860
860
861

862
863
865
866
866
866
867
867
867
868
868
868

868
869
870
870
871
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32.8.5
32.8.6
32.8.7

32.9

Flow Lines From Dataset (Model ZVI & Flow
Menu)
Flow Lines From Grid (Model ZVI & Flow Menu)
Flow Lines Options (Model ZVI & Flow Menu)

871
871
871

Model Tools Menu

872

32.9.1
32.9.2
32.9.3
32.9.4
32.9.5
32.9.6

873
876
876
877
877

32.9.7
32.9.8
32.9.9
32.9.10
32.9.11
32.9.12
32.9.13
32.9.14
32.9.15
32.9.16
32.9.17
32.9.18
32.9.19
32.9.20
32.9.21
32.9.22
32.9.23
32.9.24
32.9.25
32.9.26
32.9.27
32.9.28
32.9.29

Measure (Model Tools Menu)
Densify the Triangulation (Model Tools Menu)
Merge Two Models (Model Tools Menu)
Rebuild The Triangulation (Model Tools Menu)
Display Model Information (Model Tools Menu)
Add Ground Levels to a Dataset (Model Tools
Menu)
Extract A Grid of Levels (Model Tools Menu)
Add Strings From File (Model Tools Menu)
Join Adjacent Strings (Same Feature)(Model
Tools Menu)
Join Adjacent Strings (Any Feature) (Model Tools
Menu)
Resolve Crossing Breaklines (Model Tools Menu)
Set Preferred String Direction (Model Tools
Menu)
Transform Coordinates (Model Tools Menu)
Extract Elevation (Model Tools Menu)
Extract Levels from Text Nodes (Model Tools
Menu)
Create Tree Lines From Canopies (Model Tools
Menu)
Search for Model Noise (Model Tools Menu)
Apply Ground Types (Model Tools Menu)
Report String Names (Model Tools Menu)
Report String Details (Model Tools Menu)
Report Intersecting Strings (Model Tools Menu)
Report Triangle Coodinates (Model Tools Menu)
Report Polygon Point Density (Model Tools Menu)
Report String Lengths by Feature (Model Tools
Menu)
Compare Model Revisions (Model Tools Menu)
Delete Duplicate Points (Model Tools Menu)
Combine LandScape Models (Model Tools Menu)
Search for Orphan Points (Model Tools Menu)
Purge Unused Data (Model Tools Menu)

32.10 Model Cloud Menu
32.10.1
32.10.2
32.10.3
32.10.4
32.10.5

Select Data (Model Cloud Menu)
Edit Selected Points (Model Cloud Menu)
Copy To New Cloud (Model Cloud Menu)
Triangulate Points (Model Cloud Menu)
Export Points (Model Cloud Menu)

32.10.5.1
32.10.5.2

32.10.6
32.10.7
32.10.8
32.10.9
32.10.10
32.10.11

Export LAS
Export PTS

Point Cloud features (Model Cloud Menu)
Point Cloud Options (Model Cloud Menu)
Trace Linear features (Model Cloud Menu)
Trace Outlines From Slice (Model Cloud Menu)
Trace Selected Points (Model Cloud Menu)
Search For Model Noise (Model Cloud Menu)
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877
878
879
879
881
882
882
883
883
883
884
886
886
887
887
887
887
887
887
888
889
889
890

890
890
890
891
891
891
891
891

892
893
895
895
896
896

32.10.12 Optimise Triangulation (Model Cloud Menu)
32.10.13 Point Cloud Properties (Model Cloud Menu)
32.10.14 Smooth (Model Cloud Menu)

32.11 Model Windows Menu
32.11.1
32.11.2
32.11.3
32.11.4
32.11.5
32.11.6
32.11.7
32.11.8
32.11.9
32.11.10
32.11.11
32.11.12
32.11.13
32.11.14

New Window (Model Windows Menu)
Cascade (Model Windows Menu)
Tile Horizontal (Model Windows Menu)
Tile Vertical (Model Windows Menu)
Arrange Icons (Model Windows Menu)
Split (Model Windows Menu)
Zoom Window (Model Windows Menu)
Zoom In (Model Windows Menu)
Zoom Out (Model Windows Menu)
Zoom Extent (Model Windows Menu)
Zoom Previous (Model Windows Menu)
Zoom Centre (Model Windows Menu)
Zoom to Scale (Model Windows Menu)
Zoom to X, Y Position (Model Windows Menu)

896
898
898

898
898
899
899
900
901
901
902
902
903
903
903
903
903
904

33

Sections

904

33.1
33.2

Data Selection Dialog (Section)
Sections File Menu

904
906

33.2.1
33.2.2
33.2.3
33.2.4
33.2.5

906
907
908
909
909

33.3

33.4

XML (Section File Menu)
Export Sections (Section File Menu)
Attach Feature Library (Section File Menu)
Load / Save Section Styles (Section File Menu)
Import Sections (Sections File Menu)

Sections Edit Menu

910

33.3.1
33.3.2
33.3.3
33.3.4
33.3.5
33.3.6
33.3.7
33.3.8
33.3.9
33.3.10
33.3.11
33.3.12
33.3.13
33.3.14
33.3.15
33.3.16
33.3.17
33.3.18
33.3.19
33.3.20
33.3.21
33.3.22
33.3.23
33.3.24
33.3.25

910
910
911
911
911
911
911
912
912
913
914
915
916
917
918
918
919
919
919
920
921
921
921
921
921

Undo (Section Edit Menu)
Redo (Section Edit Menu)
Copy (Section Edit Menu)
Copy Bitmap to Clipboard (Section Edit Menu)
Paste (Section Edit Menu)
Paste Special (Section Edit Menu)
Add Points (Section Edit Mentu)
Delete Points (Section Edit Menu)
Move Points (Section Edit Menu)
Text (Section Edit Menu)
Symbols (Section Edit Menu)
Hatch between strings (Section Edit Menu)
Descender Annotation (Seciton Edit Menu)
Query and Edit Points (Section Edit Menu)
Subdivide Profiles (Section Edit Menu)
Append Surfaces (Section Edit Menu)
Append Other Model Data (Section Edit Menu)
Reverse Sections (Section Edit Menu)
Volumes (Sections Edit Menu)
Optimise Section Volumes (Section Edit Menu)
Renumber River Chainage (Section Edit Menu)
Transform Coordinates (Section Edit Menu)
Insert New Object (Section Edit Menu)
Links (Section Edit Menu)
Object (Section Edit Menu)

Section View Menu

923
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33.4.1
33.4.2
33.4.3
33.4.4
33.4.5
33.4.6
33.4.7
33.4.8
33.4.9
33.4.10
33.4.11
33.4.12

33.5

Scales, Titles And Grids (Section View Menu)
Section Sheet Layout (Section View Menu)
Annotation Settings (Section View Menu)
Radial Annotation (Section View Menu)
Next Section Sheet (Section View Menu)
Previous Section (Section View Menu)
Snap Controls (Section View Menu)
Feature Library (Section View Menu)
Status Bar (Section View Menu)
Customise (Section View Menu)
Extended Styles (Section View Menu)
Keyboard short-cuts (Section View Menu)

923
926
927
928
929
929
929
929
930
930
930
930

Section Window Menu

931

33.5.1
33.5.2
33.5.3
33.5.4
33.5.5
33.5.6
33.5.7
33.5.8
33.5.9
33.5.10
33.5.11

931
931
931
931
932
932
932
932
932
933
933

New Window (Section Window Menu)
Cascade (Section Window Menu)
Tile Horizontal (Section Window Menu)
Arrange Icons (Section Window Menu)
Split (Section Window Menu)
Zoom Window (Section Window Menu)
Zoom In (Section Window Menu)
Zoom Out (Section Window Menu)
Zoom Extents (Section Window Menu)
Zoom Previous (Section Window Menu)
Zoom Centre (Section Window Menu)
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1

Introduction

1.1

SCC Manual Overview
Introduction
The SCC documentation is composed of two printed manuals and a number of additional
electronic resources. The two manuals are the SCC reference manual, and the SCC user
guide.

SCC User Guide
The SCC user guide contains a series of step-by-step tutorials that go through many of the
typical survey, modelling, mapping, volumes, and design tasks for which you are likely to use
SCC. This includes, among others, tasks such as transferring data to and from many popular
measuring instruments, using SCC with other packages such as MX and CAD, creating
models, calculating volumes and cutting sections. All of the data used in these tutorials is
available in the SCC installation folders. This manual is designed to teach you how to use SCC
to accomplish most tasks, and is a good starting point for most new users, or those putting
SCC to new uses.

SCC Reference Manual
The SCC reference manual contains a functional description of every menu option available in
the SCC software, organised in a format that has a similar logical layout to the software itself.
This manual is designed to show you how each SCC function operates, and how SCC as a
whole interacts with other software on your computer. Where appropriate, this manual also
includes references into the SCC user manual for more detailed examples on the use of
specific options.

On-line help
In addition to the printed documentation, the user and reference manuals will also be available
in the form of on-line context sensitive help from within SCC. The on-line help is likely to
contain more up to date information than the printed manuals, and additionally will contain extra
multi-media content such as video examples covering the use of different program options. For
the very latest documentation and program updates, visit the SCC web site at
www.atlascomputers.ie

Documentation Conventions
NOTES are something of special interest. They should be remembered. If
not, at least they will be easy to find in the future when surrounded by a
double border.
All menu and command options will be in inverted commas, with the main menu title appearing
in CAPITAL LETTERS.
All actions required by you, will be indented and appear in italics.
There will be a heading at the top right of the instructions describing the aim of the exercise.
Follow these exact instructions to achieve the proper results.
An example might be:

Action Identifier Table Heading
From the Main Menu Bar, Select ‘EDIT > Edit Strings > Join Strings'
©2015 Atlas Computers Ltd

2
Pick the two strings from the graphic model

1.2

Installation and set-up
To install SCC, insert the CD in your CD or DVD drive and run the 'Setup' application on that
drive. For example, if your CD drive is drive 'D', select Start, Run, 'D:\SETUP.EXE'. Please
ensure that you have a hardware lock or network license prior to commencing with SCC
installation. If you have a previous version of SCC installed, please back up all your SCC data,
and uninstall the previous version prior to installing this version.
SCC requires Windows 2000, Windows XP or Windows Vista with at least 512KB of RAM and
between 100MB and 500MB of available disk space depending on options installed. SCC
Installation is quick and easy.

To Install/Update SCC
If you have SCC already installed on your computer, backup your existing SCC directory
and any sub-directories off it.
Plug the SCC hardware lock (dongle) into the PC’s printer port or USB port
Insert the CD into your CD drive and run SETUP.EXE from the root directory.
On most machines this will run automatically when you insert the CD.
The SCC image will be displayed
Select Next
Read the Welcome dialog
Select Next
Enter in the user name and organization. Select whether the software is to be used by
many users or only the person whose name was entered.
Select Next
Select a destination directory for SCC. It will default to the directory C:\SCC\. To accept
this directory, select Next, to chose a different directory, select Change.
Select Next
Set Typical as the Setup Type
Select Next
Select Install to accept the current installation settings.
The program is now installing.
The hardware lock driver will also install.
Select Finish
Run SCC, either by double clicking on the SCC icon or by selecting SCC from the
Windows program menu.
Before performing any operations in SCC, it is important to ensure directories and external
links are setup correctly. It is sufficient to set up these links once.

Directories & Files:File Structures
Setting up SCC Directories and Files:
SCC can have direct links to a text editor, CAD and/or MX. Having a link to a CAD system or
MX will mean that when exporting a model, the CAD system or MX will open automatically and
the drawing will be generated in that program.
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The Executable files, Projects and Temporary files directory will be filled in automatically during
installation. If the default settings differ from yours ensure you change them to correspond to
your specific directory structure.
The Windows WordPad is used as the default Text Editor. No path directory has to be
entered in this option, simply type the word NOTEPAD. Any time any reports are edited
they will be presented in the Text Editor. Having a link to a CAD system or MX will mean
that when exporting an SCC model or section, to either CAD or MX, they will be
automatically opened and the drawing generated in that system.
Go to ‘FILE > General Options > Directories and Files’ panel
Check and see that the executable files directory is correct.
If you have installed SCC in a directory other than the default, type in the correct path to
this directory.
Check and see that the projects directory is correct. This should normally be the same
directory as the executable file directory.
Make sure that the temporary directory stated exists. If not create this directory.
Select the path to your CAD executable file.
Identify the text editor you wish to use for SCC generated reports.

SCC uses the Windows Wordpad as its default Text Editor. This link will be automatically set
during installation. SCC generates reports for some functions it carries out, such as traverse
reduction, adjustment and volume calculation. If you choose to edit/view these reports while
SCC is running the selected editor will display the report.
It is also possible to change the background colour of SCC from this panel as well as the
screen colours themselves as colours that are visible on a white background may be less
visible on a black background.

©2015 Atlas Computers Ltd

4

Module Licences
Maintenance codes will be specific to your dongle number and the expiry date. 10 days before
your maintenance is due to expire, a reminder message will be displayed on opening the
program. This message will be displayed until the maintenance has been renewed.
Go to ‘FILE > General Options’
Select the ‘Module Licenses’ panel
Ensure you have the entered the correct maintenance code and maintenance expiry date.

To install Maintenance Codes and Expiry Date:
Go to ‘FILE > General Options’
Within the 'System Variables' dialog box go to 'Module Licenses'
Enter Maintenance Code 2 and Maintenance Expiry Date
Select 'Purchase Maintenance'
A black correct symbol should appear in the box beside 'Maintenance Enabled'

Units & Data Checking
During the download procedure, SCC also range checks every field against a user definable
range of values. Any exceptions are reported to the log file, and optionally to screen during the
download process. The log file also includes any other potential errors relating to the input data,
reduction, adjustment and subsequent analysis.
The level of detail included in the log file is also user definable, ranging from minimal to full
diagnostic. When run in diagnostic mode, SCC will also log all intermediate computational
results to the log file for QA purposes, such as matrix dumps in least squares analysis or
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transformation, triangulation computations during modelling, etc… This can prove an
invaluable tool both for support, and when attempting to track down a complex data related
error or query.
Go to 'FILE > General Options > Units & Data Checking’ panel
Select the type of ‘Input Range Checking’, ‘Error Reporting Method’ and ‘Error
Reporting Detail’ options you prefer.
You may also set the ‘Undo’ facility in this panel but remember that the more undo levels
you select, the more memory taken.

Workspaces
The workspace contains all the file, menu and toolbar settings that appear when you first open
SCC. These settings can be changed for an individual or for the duration of a large project
where only a number of the toolbars/menus are in use and more of the display area is needed.
The workspace can be saved as default and then loaded each time SCC is opened. This option
can be accessed through the FILE > Workspaces menu.
Go to ‘FILE > Workspaces’
Save the workspace as ….
Go to ‘FILE > Workspaces’
This time select ‘Workspace Options’
Select the workspace file previously saved using the ‘Pick’ button
Set the loading option to ‘Automatically load the default workspace’
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Set the saving option to ‘Do not automatically save the workspace’

Again, these settings can be changed to suit the individual user or working project.

1.3

32 bit & 64 bit SCC Versions
SCC now includes separate native 32 bit and 64 bit versions of SCC. The 64 bit version of
SCC requires Windows 7 (64 bit) with 2GB or more of RAM. This version can work with point
clouds of up to 4 billion points and TIN models of hundreds of millions of points. A point cloud
of 4 billion points will take between 12gb and 20gb of RAM depending on colour and intensity
scheme used. A typically large cloud of ~ 1 billion points take ~10 seconds to open and can be
displayed and edited in real time on a mid range multi-core workstation. The point cloud engine
has been optimised such that it can take full advantage of modern multi-core processors for
most tasks, thus making it up to eight times faster than previous versions where eight core
processing (e.g. Intel i7 or AMD 8350) is available. This installation of SCC installs both 32 and
64 bit versions by default. The current 64 bit version is limited insofar as it does not as yet
support the geodetic grid or SnakeGrid transformations available under 32 bit.

2

Basic Concepts
This section deals with the basic concepts and terms used within SCC. It aims to explain how
SCC generates maps and surfaces from observed survey data, and what mechanisms are
used to transfer the information generated into other CAD and design packages such as
AutoCAD, MicroStation and MX.

2.1

Data storage and user interface
Data Storage
SCC uses the Microsoft document/view architecture to store and edit all its information. A
document is a file on your computer used to store one or more pieces of related information in
a self contained format, that is recognisable by the Windows operating system. Examples of
documents include Word documents, Excel spreadsheets, etc.. Each of these document types
have corresponding disk files and are registered with the operating system for use with other
programs, such as explorer.
When using SCC, all the documents relating to a given survey project, including SCC
documents and other data such as CAD drawings, will be stored in a project folder. This folder
is created when the 'New Project' option is selected, taking its name from the project name.
The location of this folder is set-up in the 'General Options > Directories and Files' dialog, by
default it will be 'C:\SCC'. When we create a new project, a new SCC project document is
opened in the project folder, based on a selected project template. All data downloaded or
imported, and models and sections generated in this project are stored in this new folder.
While you can enter names for all documents, file extensions are controlled by SCC. As with
other document based Windows software, when closing a file within SCC you will be prompted
to save this file if it has been modified. If you are carrying out a lot of editing on any document,
and you are not using a version control system to manage your revisions, we recommend that
you regularly save your changes, given each saved version a revision based file name. For
example, if you create a model called MyModel, the first time you save it you might call it
MyModel01.Model. Intermediate edits might be saved as MyModel02.Model,
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MyModel03.Model, etc.., and the final model saved as MyModel-Final.Model. In this way, if you
make any errors during the editing process, you can always revert to a previous version.
Alternatively, you can use an automated back software, such as Active Backup (
www.ajcsoft.com), to do this for you.

SCC versions and updating
Please note the following with regards to SCC versions and version compatibility. The SCC
version is made up of three digits; the release number, the major version, and the minor
version. For example, SCC 7.4.8 is SCC release 7, version 4, sub version 8. The release
number typically changes on an annual basis, when all users with a current maintenance
contract are issued with new full installation CDs and supporting documentation. The major
version changes when a modification is made that necessitates a file format change, that may
in turn lead to backward incompatibility with previous versions. For example, SCC 7.0.0 may
not be able to fully read all files created with 7.1.0. A minor version change indicates a
software modification that has no bearing on file format compatibility, for example SCC 7.4.2
can read files created in 7.4.8 as all data created in SCC 7.4.x has the same file format.
Therefore, for a group of SCC users wishing to ensure that they will be fully data compatible,
they should all be on the same release of SCC and the same major version. Note that like
most commercial software, such as AutoCAD, MS Office, etc.., all versions of SCC can always
read all files created from any previous version. Compatibility issues only arise when
attempting to read files created by a later version than the version in use.

XML Support
SCC also supports loading and saving of all of its document files in the industry standard XML
format, in addition to its native formats. XML (extensible mark-up language) is an ASCII format
widely used in Internet and database applications for the exchange and archiving of data. It
has the following advantages; Data saved by SCC in XML format is both backward and forward
compatible with any XML enabled version of SCC. XML is an open data format, thus SCC XML
data may be translated into other formats by third party software where required. Note that
XML has the disadvantages that it is much slower to save and load, and is much larger in size
than native SCC binary formats. SCC XML options are available from the File / XML menus
throughout the program.

User Interface
The view is the principal graphical interface to a document. Some documents have a single
view, for example in Word, the view is the area on screen where you type in your text. Other
programs will have multiple views, for example in Excel, you might have a single spreadsheet
that contains many pages, though each page belongs to the same .XLS document. SCC
documents typically have multiple views, for example in a survey data set, detail observations
and reduced coordinates are presented in separate spreadsheet views. All of the views in
SCC are either spread sheet views, or interactive graphical views, and have a unique name
and graphical icon, displayed in a tab at the bottom of the view. The simplest way to switch
between views is to left click on this tab with the mouse.
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Documents
SCC creates and works with the following document types: Projects, Survey Datasets,
Traverses, Models, Sections, Transformations, Alignments and Program modules. A brief
description of each document is given below, along with the views available and icons used.

2.1.1

Project
A project document is used to share station coordinates between other SCC documents in
the project folder, and to determine drawing and modelling conventions used. It contains
four sheet views
Station coordinates, used to establish and maintain the grid system used in this
project.
Feature Library, used to control naming conventions, drawing standards and
modelling defaults.
Ground Type Library, used to break down different parts of the surface model
into various ground types for viewing and analysis purposes.
Advanced Survey Coding, used to control how coding in the field is interpreted
into features and reduction options.
In addition to this the project file stores copies of all ancillary drawing support items such
as symbols, line-styles, sheet layouts, text styles, and bitmaps that are used in model and
section drawing.
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Project - Station Coordinate Sheet

Project - Feature Library Sheet
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Project - Feature Wizard

See Also
Station Co-ordinates (View Menu)
Feature Library (View menu)
Ground Type Library (View Menu)
Advanced Survey Coding (View Menu)

2.1.2

Traverse
The traverse document is used to store observations relating to traverse and network
adjustments. Within the Traverse document you can reduce and edit setups, apply
relevant corrections and perform adjustments. The traverse document includes three
sheet views
The traverse observation view, including observed angles and distances,
reduced values, and computed residuals
The traverse coordinates view, including provisional and adjusted station
coordinates, and computed error ellipse axes
Station coordinates, a back-up of the station coordinates used in this traverse,
such that the traverse document is fully self contained.

Traverse Sheet
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Corrections
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Traverse - Setup Dialogs

See Also
Traverse

2.1.3

Dataset
The survey document is used to store raw detail observations and reduced detail
coordinates in a normalised format. Survey datasets can be created by downloading data
from a survey instrument, or importing reduced data from another file. Depending on the
data source, they may or may not contain any observation data. The survey document is
made of the following five sheet views;
The detail observation spreadsheet contains all of the observations in any
given survey. Note that these observations can be total station angles and distances, GPS
latitude, longitude, height, or X, Y, Z. These different observation types may be also freely
mixed in a given job. From the observation view, we can also specify various reduction
parameters and defaults including corrections, mapping projections and GPS datum and
transformation. Any changes made in the Detail Observation view will require the detail
co-ordinates to be rebuilt in order to reflect the new changes. If the co-ordinates were not
formed from a detail survey then this sheet will be blank.

Instrument Set-ups, containing observed back-sights, used to orient the
horizontal circle whenever the total station is moved. The instrument set-up sheet also
contains distance and coordinate misclosures, along with other QA fields. Each
instrument set-up is numbered, and each detail observation contains a corresponding
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set-up number. Modifying the station set-up details will require the associated survey to
be re-coordinated and the model to be rebuilt. If the co-ordinates were not formed from a
detail survey then this sheet will be blank.

Text Notes, used to store text data and placement details.

Extra Measurements, used to store measurements other than direct
observations, such as tape measurements and copied strings. If the co-ordinates were
not formed from a detail survey then this sheet will be blank.

Detail Coordinate Sheet, used to store reduced topographic coordinates,
sorted alphabetically by feature name and string number. Note that the detail coordinates
sheet may contain interpolated data, such as curve fit points, in addition to reduced
observations or imported coordinates.
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Station coordinates, a back-up of the station coordinates used in this survey,
such that the survey document is fully self contained. In addition to the above sheet
views, the survey document also includes a copy of the downloaded survey data as a text
file in its native format, such that the other spreadsheets can be reconstructed in their
originally downloaded state at any time.

2.1.4

Model
Models are used to display and manipulate survey data graphically as plan drawings, in a
similar manner to CAD. Models can contain a mixture of 2d and 3d information, and will
typically include a triangulated surface model or TIN. The surface model is used to
interpolate elevations that have not been directly observed, for analysis purposes such as
contouring and volume calculation. Models can be formed either directly from coordinates
sources, such as CAD or MX GENIO, or from reduced survey datasets. SCC includes an
extensive range of graphic editing tools that enable simultaneous editing of the planimetry
and 3d surface. In addition to graphic editing, the model may also be edited as a
spread-sheet using a split screen editor. SCC models contain the following views;
Plan view, used for all graphical display and editing
Station coordinates, copied from the surveys used when creating the model.
You may also cut and paste in additional unreferenced stations from the project as
required.
Feature Library, copied from the project, used to control naming conventions,
drawing standards and modelling defaults.
Ground Type Library, copied from the project, used to break down different
parts of the surface model into various ground types for viewing and analysis purposes.
ZVI station coordinate, used for ZVI station positions in visual intrusion analysis
As with the project, the model also stores copies of all referenced symbols, line styles, text
styles, bitmaps, and sheet layouts, such that it forms a fully self contained document.
Additional SCC documents, including traverses, alignments, sections and even other
models may also be attached to a model for graphical display purposes.
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Model

Model - Split View option which allows the user to browse the dataset table whilst the
cursor interactively moves to the chosen x, y, z

See Also
Modelling

2.1.5

Section
A section document is used to graphically represent profiles, long sections and cross
sections. Sections can either be cut from a model or generated directly from coordinate or
chainage / offset data, can include any number of surfaces per section, and can be drawn
to user defined standards. A section document contains the following views;
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Section view, used for all graphical display and editing
Feature Library, copied from the project, used to control naming conventions,
drawing standards and modelling defaults
As with the project, the model also stores copies of all referenced symbols, line styles, text
styles, bitmaps, and sheet layouts, such that it forms a fully self contained document.
Section style files can also saved and loaded from section views to simplify the process of
applying standard drawing styles and sheet layouts to different types of section drawings.
Sections can also be attached to ground models, to show their plan position, and
annotated with chainage and offset.

2.1.6

Transformation
The transformation document has a single spreadsheet view consisting of
pairs of control co-ordinates used to move datasets between coordinate systems. SCC
includes 2D affine plus level shift, 2D / 3D conformal, 2D / 3D scale free and 2D / 3D best
fit (2 or more points) transformations. Furthermore, SCC supports national grid
transfromations between ITM, Irish Grid, OSGB36 and ETRS89. These transformations
utilise Grid Inquest software provided by Quest Geo Solutions. Transformations may be
applied to project stations, reduced coordinates and models.

©2015 Atlas Computers Ltd

17
Transformation - Local Grid to National Grid

See Also
Transform Coordinates

2.1.7

Alignment
The alignment document stores all information relating to horizontal, vertical, and section
template design data. SCC enables you to create linear and polygonal designs, using
both interactive graphics and spreadsheets. Designs can include surfaces and multiple
section templates for different chainage ranges. Linear designs can be created either
from horizontal and vertical intersection points, or directly from entities. Designs may also
be imported from MX GENIO geometry and master alignment strings, and from other
design packages. The SCC alignment document contains the following views;
Horizontal intersection points
Vertical intersection points
Horizontal entities
Vertical entities
Section template points
Super-elevation nodes
Interactive section template design
Interactive vertical design
Interactive horizontal design is carried out in plan in the model view. As with the project,
the model also stores copies of all referenced symbols, line styles, text styles, bitmaps,
and sheet layouts, such that it forms a fully self contained document. Alignment
documents can also include attached models representing non-alignment related strings
in the design, and a model for level reference.
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Alignment - Horizontal Geometry Entities

Alignment - Vertical Geometry Entities

2.1.8

Program Module
In addition to using SCC interactively, SCC can be driven programmatically, through any
scripting language that supports OLE automation or COM, such as Visual BASIC or Java
Script. This may be used to automate complex or time consuming SCC user processes.
SCC program modules are edited in a script viewer that also includes a visual
form designer.

2.1.9

Using SCC with Microsoft Office and other Windows Applications
Any SCC documents may be transferred to other Windows programs by cutting or copying
data to the clipboard and pasting it into the target location. SCC supports standard ‘Cut’, ‘
Copy’, ‘Paste’ ‘Paste Special’ and ‘OLE’ commands. You may also cut and paste data
from other packages into SCC. SCC spreadsheets support text and Microsoft Excel
clipboard formats. SCC models additionally support cut, copy and paste of graphical data
between any other OLE compliant software.

Cutting or Copying Data within SCC
Spreadsheet data may be cut or copied between spreadsheets.
Highlight the cells to be cut or copied. Go to ‘EDIT > Cut/Copy’.
Highlight the cell where you wish to place the data. Go to ‘EDIT > Paste’.
Data within models may be selected for cutting or pasting using the Data Selection dialog.
Copying a model to a new dataset or to a new model is different than exporting models, in
that, only the survey points selected are copied. Model data may also be copied to the
clipboard in its native format or as a bitmap. When data is copied to the clipboard it may
be pasted or inserted into any other Windows program. When copied in its native format
in may be inserted into another document as an OLE object.

OLE
An object created in another application that supports OLE may be inserted into SCC. To
insert objects such as Microsoft Excel worksheet objects, use the 'Insert New Object'
command or the 'Paste Special' command, both found under the Edit menu.
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Similarly objects created in SCC may be input into any other Windows application.
Objects are created in SCC by using the ‘Copy to Clipboard’ option.

Send
Send attaches the current file to a new blank e-mail message. Select the recipient and
type your message.

2.1.10 Backup Strategies
We recommend that in addition to saving your documents using a revision number based file
naming convention, that you include your main SCC folder in you backup plan. Good practice
is to keep any important data in at least two physical locations at any given time.
In addition, several options are available within 'FILE > General Options > Directories & Files' to
allow the user to select auto save options but also to create backup files automatically.

2.2

Feature Names Conventions & The Feature Library
A feature name is the name given to one or more similar surveyed objects used to group
strings and points of the same type. Examples of feature names include TREE, ROADEDGE,
DITCH, WALL, MANHOLE and shortened or mnemonic versions such as TE, RE, DH, WL,
MH. In SCC, a feature name can be up to eight characters long although it is common to use
shorter abbreviations. In SCC, feature names are used to determine how survey data is drawn
and modelled. This is controlled by the feature library, which is essentially a spreadsheet
containing a large number of fields against each feature determining how it will be interpreted
for modelling, mapping, and export purposes. These fields include colour, line-style, annotation
defaults, symbology, MX label, and CAD layer.
Many large organisations will have there own naming conventions, whether it be based on
string labelling conventions for MX users, layer naming conventions for AutoCAD users, or
both.
The feature library controls the application of a feature, layer, and string naming conventions
when generating SCC models and sections, AutoCAD and Microstation drawings or MX
models. The key field in the feature library is the feature name.
Most survey data collectors will include a feature name or point code field that can either be
directly used as a feature name, or mapped onto a feature name using the advanced field
coding sheet. When transferring data from a MX SURVEY or GENIO file, the feature may be
the first few characters of the string label that define the object. For example, the SW from the
MX string label SW01 might indicate the string is a sidewalk. The numeric 01 part of the label
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indicates string number or occurrence of this feature in the current model. When transferring
from AutoCAD or Microstation to SCC, the layer name, entity type, colour and line-style can all
be used to determine the SCC feature.
In SCC, the method of matching survey features with feature names in the feature library is
determined in SCC by a parameter within General Options. ('FILE > General Options >
Directories and Files').

The variable name is 'Add new features' and its value will be one of the following;
· No, warn about new feature name
· No, use nearest feature name
· Yes, all new features
· Yes, using first character
· Yes, using first 2 characters
· Yes, using first 3 characters
· Yes, using first 4 characters
· Yes, using alpha characters only

Feature Wizard
The feature library contains a very large number of fields, approximately four hundred per
feature, that allow for a very fine degree of control on how any given feature is drawn and
annotated. While this allows for a very high degree of field to finish automation, it can be quite
daunting to edit and maintain.
The solution to this dilemma is the ‘Feature Wizard’, which can be accessed using ‘EDIT >
Feature Wizard’ from the feature library spreadsheet. This displays the dialog shown below;
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The feature wizard is an automation tool that helps you generate and maintain feature libraries
with the minimum of effort. It offers the following facilities;
· All of the fields for a given feature are displayed in a single dialog, with a preview panel that
shows a sample string or point for that feature, including annotation and symbology. This
preview panel is updated when any field is changed.
· Feature styles may be saved and re-used. For example, if you set up a manhole with a
circular symbol, and the plot name and cover level to the left of the symbol, you might save
this as a man hole feature style. If you then wish to set-up a similarly drawn feature, such as
a gas valve, you simply re-select the man-hole feature style, and the gas valve will inherit the
man holes symbology and annotation settings.
· The feature wizard also allows you to create and edit text styles, which consist of font
selection and display attributes, such as italicisation, and underlining.

See Also
General Options (File Menu)
Feature Library (View menu)
Ground Type Library (View Menu))
Developing SCC Feature Library for use with MX

2.3

Strings
In order to form a surface model and map from a survey, it is necessary to create a number of
distinct geometric entities from the observed points. These include points, lines, curves, and
combinations of lines and curves. In SCC, these entities are referred to as strings. An
example of a string might be the edge of a road. This string would include sections of straight
lines, curves and possibly gaps or discontinuities. A string can be two or three-dimensional and
can have varying significance to the surface depending on how it is defined. An example of a
two dimensional string might be an overhead telecommunications line which is displayed in
plan for cartographic purposes. An example of a non DTM three dimensional line might be an
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overhead transmission line where the conductor cable could be represented as a three
dimensional line in CAD and not influence the formation of the surface model. An example of a
three dimensional string might be the edge of an embankment which is fully represented as a 3
dimensional line which significantly influences the surface model formation since it delineates a
characteristic fold in the physical terrain.

String Number
The string number field, available in detail coordinates view of the survey data set, indicates the
instance of a given feature within a survey. All points in a survey with the same feature name
and string number will be sequentially joined to form a single string. It is therefore used to
distinguish multiple occurrences of the same feature. For example, if there are two distinct
buildings in the survey both having the feature name BUILDING, all the points on the first
BUILDING would have a string number of 1, and all the points on the second have a string
number of 2. This makes it possible to survey part of Building 1 and move on to BUILDING 2.
It would then be possible to subsequently come back to continue the first building by picking up
the next sequential point on BUILDING 1. A string number of 0 is used to denote a point
feature (unconnected point) such as a spot level, bus stop, traffic signal etc.

Tags
The tag code determines the connective geometry and specifies how the current point on the
string will be connected to the next point on the string. This can be used to specify straight
lines, curves, arcs, and squared up pieces of geometry in a string.

DTM Code
The DTM (Digital Terrain Model) status code determines the significance of the point of the
surface model / digital terrain model being generated.

See Also
Feature Library (View menu)

2.4

Models
Models within SCC are formed from a variety of co-ordinate files, such as reduced survey, DXF
and GENIO. A model in SCC consists of the plan drawing and the feature library. If a SCC
dataset is used to create a model then the feature library from that project will be copied as the
feature library for the model file. If the model is generated directly from a co-ordinate file, new
features encountered will be added to the default feature library (depending on the setting
defined within General Options). A model comprises of cartographic map detail formed from
the strings and a surface or TIN model used to form contours. TIN stands for Triangular
Irregular Network. Put simply, this means that points adjacent to one another are connected to
form triangular facets. These facets can be considered as oblique planes for the express
purpose of interpolating contours, profiles, cross sections, volumes, and other surface analysis
tasks. Strings are paramount in the creation of TIN as they are used to form breaklines, that is,
linear areas of the surface, such as banks, ditches, and walls, where there is a sharp or
marked discontinuity of the terrain surface. See diagram below:

©2015 Atlas Computers Ltd

23

The picture below shows the effect of not creating a breakline from a string where one was
required. Compare this picture to the previous one of the same model. The dataset in terms of
spatial co-ordinates remains the same but the formation of the triangulation has been deformed
because the correct DTM code has not been selected. The selection of sufficient point density
and the delineation of the physical surface characteristics for the purposes of intended use are
prime requirements during the surveying process.

Models, which were created from SCC datasets, have links back to their original co-ordinate
and survey observations files. As such they may also be used to graphically query all aspects
of the detail survey database. Thus recovery from measurement errors, mistakes in DTM
definition, feature object dimensions etc. may be achieved interactively. Data may be
combined from a variety of sources for model creation.
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2.5

Field Practice Applicable to SCC
Field Practice for Topographic Surveying
SCC models are formed from point or line string information. Point strings are discrete points
such as trees and spot heights whereas line strings are connected features such as roads,
walls and hedges. In order for strings to appear in the model, the surveyor must record string
information when surveying. This involves recording one or more fields that tell the software the
type of feature being surveyed, e.g. Wall, Tree, Road, and optionally additional geometric
information to specify the string number or instance of that feature, for example, WALL 02
might be the second wall surveyed.
The coding of string information in the field is dependent on the data collector being used. Data
collectors, such as PocketDTM and AutoGRAD/MSMM, include distinct feature name and
string number fields. This has the advantage that points on a string do not have to appear in
sequential and unbroken order within the survey. For example, we could observe points on a
road in sectional format from a number of different set-up stations yet they would appear as
strings in the model. This can greatly reduce the overall amount of fieldwork. Modern total
stations allow a high degree of customization, allowing us to collect as many or as few fields as
required.
We can also collect geometric codes that allow us to specify the geometry connecting string
sections, such as straights, curves, arcs, and rectangles, dimensional information, and various
offsets.
On data logging systems without explicit fields for feature code, string number, tag code, etc...
we can use the advanced field coding sheet to achieve most of the same results given a single
point code field. This sheet determines whether a field code represents a feature code or a
control code, and what to do with numeric values within a point code. For example, we might
say that KB represents a KERB feature, connected by straights, whereas KBC might be a
KERB feature connected by curves. Thus KB and KBC would lie on the same string. Similarly,
we can say that for KB and KBC, any numerics in the point code represent the string number,
such that KB02 and KBC02 represent straight line and curved segments of KERB string 2. We
can also use control codes, for example ST might be used to start a new string with the current
feature. Individual observations may also have more than one code when surveyed in this
manner, for example HE01 GA might represent the junction point between HEDGE string 1 and
a GATE. This type of coding allows us to replicate topographic field surveying techniques used
in many popular legacy systems such as SDRMap, Panterra, LandScape and NRG.

Field Practice for Traversing
SCC supports both traverse and network adjustment. As with topographic surveying, the
method of collecting a traverse will vary between data loggers and instruments used. When
surveying combined topographic detail and traverse data in a single job, observations with a
specified feature code can be extracted into the traverse sheet for adjustment purposes.
A traverse connects chains of straight lines with measured lengths and angles. A traverse is
one means of providing 2 or 3 dimensional control in which position is determined by a
combination of angle and distance measurements between successive lines joining control
stations. SCC allows closed and open traversing with several methods of traverse adjustment
computed. The calculations will generate co-ordinates based on the error adjustment selected
and it is the surveyor’s responsibility to assess the accuracy of the calculated co-ordinates.
It is always good survey practice to record more information than necessary. When observing
traverse information, sight to all possible stations. If extra measurements are observed to form
a network the Least Squares traverse adjustment should be carried out. This adjustment can
also be computed in PocketDTM prior to using SCC.
When observing an open traverse no adjustment may be selected and provisional co-ordinates
used.
Where possible ensure the RO is part of the traverse and not an external observation.
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The accuracy of the traverse is governed largely by the observation and measurement
techniques applied and by the type of equipment used.

Field Practice for Setting Out
SCC allows uploading of data from co-ordinate files to a number of dataloggers. Sections,
strings or contours may be uploaded to the logger.
Generally design data will be imported into SCC from MX, DOER or CAD. This data would be
uploaded to the datalogger to set out positions of proposed buildings or structures.
Road alignments are usually set out in section. It is important that the stringing is correct before
uploading sections for setting out. When you have created the sections you wish to set out,
export the section file to a survey dataset (co-ordinate file) and upload the dataset.
The zero contour line on an isopachyte model may be set out on the ground to determine the
extent of boundary between the cut and fill on the ground. The position of the cut or fill
contours from the isopachyte model may be uploaded to set out the position of the excavations.

See Also
Feature Library (View menu)
Detail Observation

3

Getting Started

3.1

Creating A New Project
A new project should be created before data may be downloaded into SCC or models formed.
The project file stores the co-ordinates of stations used in the surveys which are stored in the
current directory.
It is important that there is only one project file open at a time.

Creating a New Project
Two options are available when SCC is opened, either open an existing project or start a new
project.
When using SCC for the first time, it is necessary to start a new project.

Starting the Software
Double click the SCC Icon
On first entry to the software, or if there is no active projects, the following dialog will be
shown on screen

Select 'Cancel'
If a project is selected at this point, no directory will be set up for the
project directory. This option will simply create a project file in the
'C:\SCC\' directory, and associated files will be placed there as well. This
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will make it difficult to track project work files. Also, 'New' dialog does not
give the user the option to select a Project Template (Feature Library).

Creating A Project Directory
From the Main Menu Bar, select ‘FILE >New Project’
Enter in a Project/Job name
Select a Project Template from the list 'Default v7 Complex.Project'
Select ‘OK’
The project template contains all the feature coding, layering, string labelling, modelling,
symbology and annotation standards that will be applied to the project.
The project itself consists of a spreadsheet containing the control stations used in the
project, along with a feature library spreadsheet.
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Project Folder

Use default SCC project folder
This option creates a directory under the SCC root level directory/Project Directory
('General Options > Directories and Files'), and creates a project file in that directory. The
name of the new directory is taken from the project name.
For example, within the General Options the user has the Project Directory set to 'C:
\SCCProjects\' as shown below:

Therefore, a new project folder will be created called Test ('C:\SCCProjects\Test\') and
associated files will be downloaded/saved and exported to this directory.

Select an alternative folder
This option allows the user to specify a specific project directory different to the directory
specified within the General Options in which the project file is placed.

3.2

Import & Downloading Files Into SCC
Having created the project, it is necessary either to import data into a dataset or to download
traverse and detail information. SCC must be told what survey instrument/logger format to use,
what type of data is being downloaded and what type of media it is being downloaded from.
For training purposes, the download process from some of the common survey instruments
and logging formats are discussed.
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3.2.1

Importing Data Into SCC
SCC can import files from various other systems. All imported files are co-ordinate files and
are displayed in the co-ordinate spreadsheet. Because only co-ordinate information was input
it is not possible to access detail observations, instrument set-ups or extra measurements
information. The following lists the import options available within SCC:
Import SCC Text File (File Menu)
Import Comma Separated file (File Menu)
Import Fixed format ASCII file (File Menu)
Import STAR*NET Co-ordinate file (File Menu)
Import MOVE3 Co-ordinate file (File Menu)
Import DWG/DXF File
Import LandXML (File Menu)
Import X,Y,Z ASCII file (File Menu)
Import ESRI Shapefile (File Menu)
Import ASCII Wriggle Survey (File Menu)
Import Amberg GRPwin Format (File Menu)
Import Amberg AR2 Format (File Menu)
Import AutoGrad/MSMM ‘As Set-Out File’ (File Menu)
Import AutoGrad/MSMM Levelling File (File Menu)
Import AutoGrad/MSMM GDS Printout (File Menu)
Import DOER Husky File (File Menu)
Import MOSS GENIO File (File Menu)
Import MOSS 992 Report (File Menu)
Import MOSS 994 Report (File Menu)
Import User defined ASCII co-ordinate file
Panterra
Import Steanne MIDAS File (File Menu)
Import SDRMAP ASCII File (File Menu)
Import Eclipse Report File (File Menu)
Import ESBI Vectors File (File menu)
Import SCC for DOS Project
Landscape (File Menu)
STAR*NET and MOVE3 are traverse and network adjustment packages. If the user
chooses to adjust the traverse in one of these packages, the result may be an output file
containing the adjusted co-ordinates. These co-ordinates are input into the Project file.
Select 'FILE > Import' and select file type from given list.
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3.2.1.1

Importing User Defined ASCII file
The following examines importing user defined ‘*.txt’ files (extract below) into SCC. Note that in
this case, coordinates are placed in the detail coordinate sheet, and no further survey reduction
takes place.

1001,277888.8971,240915.1356,83.0006,KB,01
1002,277888.5933,240915.4912,82.6221,SH,
1003,277891.9484,240916.0136,80.2850,KB,01
1004,277889.5419,240920.9060,80.7244,KB,01
1005,277886.3506,240922.5783,79.3112,KB,01
1006,277886.2381,240922.5023,80.4776,SH,
1007,277886.2772,240922.5681,80.8412,SH,
1008,277887.8752,240920.7858,79.4522,SH,

A.Creating Project
Opening Existing Project
Open SCC
Go to ‘FILE > New Project’
Enter the Project Name and assign a Project Template

B.Import User Defined *.txt Files
Having opened our project, we can proceed to download our data files:

Import Sample Txt File
Go to ‘File > Import > User Defined ASCII Coordinate File’
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Within Data Format Section, enter Format Name ‘TEST’
Select ‘Variable Width Fields’
Enter ‘,’ as a Separator
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Within ‘Input Data Fields’ select ‘Add’
Enter 6 Additional lines

Using the Drop Down Menu within the Input Data Fields column enter the required cell
values
Point No (No.), Easting (-E/X-), Northing (-N/Y-), Height (-Ht/Z-), Code (Feature), String
No (Str)
Select ‘Save’
The format file ‘TEST.InputFormat’ can be select from the drop down menu in subsequent
imports.
Select the Input File using ‘Pick>>’
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Note the File Preview

Select ‘OK’
The selected file is imported to Co-ordinate Observation Sheet as follows:

3.2.1.2

Importing Models From Landscape
The following steps should be implemented when transferring model data from LandScape into
SCC:

A. Export Files from Landscape
Export your model from LandScape as GENIO
‘5002.crd’
Export your model from LandScape as 3DDXF

©2015 Atlas Computers Ltd

33
‘5002.dxf’
Export trees from LandScape using the print option
‘5002.txt’
Export stations from LandScape using the print option
‘5002.stn’

B. Setting up SCC Project
Set up Project
Open SCC
Select ‘FILE > New Project’
Enter the Project Name and attach the ‘LandscapeSample.Project’ template

C. Importing Files into SCC
Import .txt files
From the Project View, select 'FILE > Import > LandScape > Landscape ASCII Text
Notes File'

Select ‘5002.txt’
Go to ‘FILE > Save As > Trees.Survey'

3.2.2

Downloading & Processing Traverse Data
From the 'Download Survey Data' dialog, it is possible to select the type of datalogger used
(Detail Topography, Traverse, As Set Out or Levelling) and the input device being used.
Some dataloggers will not record traverse and detail information in the one file and it important
to specify which type of data is being input.
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Processing Traverse Data
Download Raw Traverse File
Select 'FILE > Download Survey Data'
Select Survey Data Logger 'HUSKY Hunter (MSMM)'
Set the Data Type to 'Traverse'
Set Datalogger Input Device' to 'Disk

Select 'OK'
Look in the ‘Tutorials’ folder in the main SCC directory and highlight ‘Example.G31’
Select ‘Open’
The following spreadsheet is presented:

The traverse observation spreadsheet contains the measured traverse observations, and their
reduced values such as bearing, height difference, forward measured angle. Also included on
this sheet are standard errors that may be set for any given observation, residuals generated by
the adjustment, and atmospherics.
Having done this you should perform an initial ‘free’ least squares adjustment, in which the only
constraints applied are those of the opening set-up. This checks the internal consistency of the
measurements independently of any known station information, and provides us with initial
station coordinates in the station coordinate spreadsheet. A significant change in the residuals
produced by the free adjustment and a later constrained adjustment indicates that
measurements are not consistent with the constraints (fixed control) provided. This is typically
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due to incorrect application of scale factor, corrections, or poor quality of fixed control data. It
can also occur where the fixed control has been generated by GPS, with and inappropriate
transformation or projection selected. The traverse adjustment dialog also allows us to specify
default standard errors, and an output report file name.

Traverse Adjustment
Before adjusting the traverse we can use the ‘Check Traverse Route’ tool from the ‘FILE’
menu. This function searches the traverse observation file for pairs of matched back-sight (BS)
and foresight (FS) observations. It then sets the codes of these observations to form a correct
route through the traverse.
Go to ‘FILE’ and select ‘Check Traverse Route’

Select ‘Only compute round numbers and traverse codes’
Then, go to ‘EDIT’ and select ‘Setup’

Select the Opening Station and Opening Reference Station from the pull down lists.
The Opening Station 1 should be held 'Fixed' and the Opening Reference Station should be
held 'Free'
The Orientation method should be set to 'Enter As A Bearing'
Select the Closing Setup tab
For this traverse example, the closing station and reference station should be left blank and
set to 'Free'
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Select 'OK'
Select 'EDIT > Adjust'x
Select 'Least Squares/Variation of Coordinates' as the adjustment method

Select 'OK'
If you wish to edit the adjustment report, select 'Yes', if not, select 'No'
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The option to update the station coordinates/project file with the adjusted values,
provisional values or not to update

Select 'Yes, use adjusted values'
The project file should now be updated with the new adjusted station co-ordinates.
We can also configure the application of mapping scale factor, atmospheric and mean
sea level corrections at this stage. This dialog can be accessed from the EDIT >
Corrections menu.

Setting the Corrections
Go to ‘EDIT > Corrections’

Select your option for Refraction, ‘K’ and curvature, the default being ‘Earth curvature
only’
You now have the option of adjusting the traverse again but this time holding some of the
new stations fixed.
Save Files
Within the Project, select 'FILE > Save As > Test.Project'
Within the Traverse, select 'FILE > Save As > Example.Traverse'
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3.2.2.1

Displaying & Annotating the Traverse
After adjusting the traverse and updating the project file with the new adjusted co-ordinates, the
stations can then be exported to a survey file where they can be modelled and the
traverse/network file attached.

Export stations to a dataset
From the project file, select ‘FILE > Export > Stations as dataset’
Save the dataset as ‘Stations.Survey’

Go to ‘FILE > Model > SCC Dataset > Select ‘Stations.Survey’

Select 'Create the model and triangulation' and Initial Plot Scale of '1:200'
Go to ‘FILE > Attach/Detach > Attach traverse file
Select saved traverse 'Example.Traverse'
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Traverse Annotation
Select ‘EDIT > Text > Annotate Traverse'
Set up the following:

Select 'OK'
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3.2.2.2

Processing A Complex Traverse
The following worked example shows how to process a complex control project in SCC that
includes interlinked traverses, cross braces and additional side-shots. This includes
processing the complete observation set as an unconstrained network via least squares,
extracting separate traverses for Bowditch adjustment, and fixing the primary stations for
constrained least squares adjustment. The steps to achieve this are given below;

A. Project Creation & Download
Use ‘FILE > New Project’ to create a new project based around the default template.

Into this project use ‘FILE > Download Survey’ to download the Trimble / Geodimeter
UDS file, \SCC\Tutorials\ComplexTrav.DAT, using the parameters shown.
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This results in the traverse spread-sheet given below;

B. Adjustment of Traverse
Adjust the control in its entirety, using a least squares adjustment with minimal
constraints.
Select ‘EDIT > Set-up’, and enter an opening setup as shown in the dialog below.
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Note that only the closing station and RO should be left ‘Free’.
Select ‘EDIT > Adjust’ and adjust this data by least squares.
When prompted, save the adjusted values to the project station sheet.

3.2.2.3

Processing A Resection Network
The following tutorial covers the processing of the Leica GSI control network provided in the file
‘Resection-Network.GSI’ (available in \SCC\Tutorials). The job consists of a large number of
total station measurements from primary unknown stations to other secondary unknown
stations. The network can be computed as there are enough common target points between
each set-up to allow computation of provisional values of all primary stations by resection (or
free-station), and secondary stations by direct trigonometry. Due to the interdependency of the
stations, the computation of provisional coordinates is iterative, whereby new station
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coordinates are generated with each iteration thus providing base information for successive
iterations. Having computed all of the provisional station coordinates, the network can then be
adjusted using a least squares variation of coordinates method, which provides the best and
most consistent final station values for the observed data.
The steps taken to process this job are as follows:

A. Project Creation & Download
Use ‘FILE > New Project’ to create a new project based around the default template.

Into this project use ‘FILE > Download Survey’ to download the 'Leica GSI 8/16',
\SCC\Tutorials\Resection-Network.gsi, using the parameters shown.
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B. Traverse Reduction Processing of Traverse Data
Given the size of the job, 1076 observations to 321 stations, it is advisable to reduce the
data prior to adjustment.
Select 'EDIT > Reduce' to reduce the data.

The reduction creates mean forward measured angles and distances for multiple similar
observations, in this case reducing the number of input observations from 1076 to 538.
The reason for doing this is primarily processing time. Many of the matrix manipulation
routines in the least squares adjustment are making a number of computations based on
the square of number of observations times the number of unknown stations, i.e.
(1076x1076x320 = 370,488,320 for unreduced data, or 538x538x320 = 92,622,080 for
reduced data). Using the reduced data also provides better initial provisional coordinates,
such that fewer iterations of the transformation are required to get a final result. The net
effect is that on a 1.5Ghz machine, adjusting the data without first reducing it will take
about 110 minutes, whereas adjusting the reduced data takes about 7 minutes. If
individual observation residuals, as opposed to residuals on averaged measurements, are
required, you should not reduce the data prior to the adjustment.
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3.2.2.4

Traverse Reduction & STAR*NET Export options
Traverse Reduction options support output to Crystal reports and additional 2D or 3D
STAR*NET export options.
The following details the processing of 'Z41120424TRAV1.GSI' using 'LUL1.GSIConfig'
and based on the 'LUL01.Project' feature library. This assumes the following coding has
been used:
41 = 1 Station set-up record
42 = At Stn
43 = Inst Height
44 = Rod height
45 = BS Stn

For example, from Z41120424TRAV1.GSI
410002+00000001 42....+000Z4105 43....+00001611 44....+00001520 45....+000Z4106
110004+000Z4106 21...2+35959590
22...2+08934580 31...0+00101597 81...0+02999999 82...0+05101594 83...0+00100831
51....+0000+000 87....+00001520
71....00000STN
41 = 5 Coding details
42 = Feature code
43 = D1
44 = D2
45 = D3

The feature code line comes after the observation, and dimensions can be a mix of mm or
metres. For trees 43 is the diameter in mm, 44 is the spread in metres, 45 is the height in
metres. The feature is carried until a new feature code is logged.
110008+00004514 21.324+03518040 22.324+07941180 31..00+00020489 51..1.-0000+034
81..00+83107925 82..00+35861779
83..00+00098576 87..10+00000000 410009+00000005 42....+00000201 43....+00000300
44....+00000010 45....+00000014
41 = 6 Offsets
42 = Line of sight offset, forward or back, in millimetres.
43 = Line of sight offset, left or right, in millimetres.

As with the feature code, this relates to the previous observation, for example in the line
below tree at point 4514 is offset 150mm to the right of the point taken, which is half the
trunk diameter in this case. These offsets apply to a single point only.
110008+00004514 21.324+03518040 22.324+07941180 31..00+00020489 51..1.-0000+034
81..00+83107925 82..00+35861779
83..00+00098576 87..10+00000000 410009+00000005 42....+00000201 43....+00000300
44....+00000010 45....+00000014
410010+00000006 42....+00000000 43....+00000150

Other field codes can be added as required.
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Crystal Report
Extreme variances at user defined tolerances can be highlighted within the Crystal Report.
Additional crystal reports have been added to support different reduction options,
specifically rounds and faces, rounds only, and faces only.

These reports can be readily customized either by Atlas or directly by the user using a
copy of Crystal reports, and data can be output to a wide variety of formats such as PDF,
MS Excel, MS Word, etc….
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STAR*NET Export
The STAR*NET export option has been enhanced to support export to 2d or 3d, using
observed format (e.g. sets of horizontal directions, see page 75 of the STAR*NET v6
reference manual), or reduced angles (included angle to backsight station). Where 3d
data is selected, rod height and instrument height are included as are standard errors.
The STAR*NET output now also includes an option to create a project file in addition to
the DAT file.
The output allows for the inclusion of either standard errors or observation residuals as
remarks. Inclusion of standard errors within the data has also been made optional.
In relation to traverse processing and adjustment in SCC ;

In the least squares adjustment Report, in the line referring to Chi squared it
displayed “value exceeded lower bound(0.00)” the question was raised should
this not say (1.00)?
Typically, values of 0.00 (exceeds lower bounds) and 100.00 (exceeds upper
bounds) can be seen where the weighting isn't in good agreement with the data.
The chi squared graph is asymptotic to the x axis, and tends towards 0 quite
quickly. SCC could report this to a greater number of decimals but the difference
between failing at say 0.01 and failing at 0.0001 has no real meaning in most
surveys. Very small values are quite common and just indicate that the standard
errors given were way too high.
A traverse is adjusted between 5 stations where 1 and 5 are fixed, 2 and 4 are new
and 3 is known but free. In the report there is no differentiation in the adjusted
coordinate tags between 2,3,4 . All stations are shown to be Provisional. The user
would prefer 2 and 4 to be tagged provisional new and 3 to be tagged provisional
free. In this way, the user would be able to look how well the expected
coordinates of stations tie in with the adjusted coordinates without being confused
by adjusted coordinates of truly new stations.
In SCC, the user can discriminate between stations in plan and elevation as
follows;
Free
The station will not be used as input to the adjustment. This is also the value given to
stations output from the adjustment.

Provisional
The station will be used as input to the adjustment, but can be freely moved by the
adjustment. i.e. a provisional coordinate is the initial unadjusted value as given by the
surveyor.

Constrained
The station will be used as input to the adjustment, and can be moved by the adjustment
in accordance with the standard coordinate errors provided. i.e. a GPS coordinate
provided as input with known accuracy.

Fixed
The station will be used as input to the adjustment, and cannot be moved by the
adjustment
Note that as per the requirement above, provisional coordinates (initial values supplied)
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are already distinguished from free coordinates (initial values not supplied) in the
adjustment and report.

3.2.3

Downloading & Processing Detail Topography Data
Once station coordinates have been computed, detail topography can be downloaded.
It is important to remember that only the survey file is automatically saved
on download. All other files must be saved by the user.
Sample download proceeds for specific data formats are examined as follows:

3.2.3.1

Downloading PocketDTM Data
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'PocketDTM'
Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type
Set Input Device to RS323 port (cable)

Select ‘OK’
On the hand-held device, go to ‘FILE’
Select ‘Export to SCC’
Select ‘Connect’ from the dialog displayed

In SCC, a dialog displaying all available jobs will appear on screen
Highlight the job you wish to download
Select ‘OK’

3.2.3.2

Downloading Leica Data
SCC includes a number of different Leica interfaces to support correspondingly different
data collection strategies. The simplest of these is the TPS series interface which maps
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user definable fields on the instrument directly onto SCC observation fields.

Downloading Leica Data
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data Logger to 'Leica GS1 8/16'
Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type
Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required
Select ‘OK’
Select the file you require and ‘OK’

In this case, for example, field 41 on the instrument will be used to store the SCC feature
name. Any SCC fields that are not being recorded in the field should be set to 99.
Note that these settings will become the defaults for all future downloads from the Leica
and do not have to be entered with each download.
An alternative method is to use the LisCADD or WildSoft style coding (Leica 1100/1200
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(GSI config)) which will be more familiar to LisCadd users. In this case field 41 on the
instrument is always used to determine what is stored in other instrument fields. For
example, in the dialog shown below, if field 41 contains the word ‘FEATCODE’ the feature
code is expected in field 42, whereas if it contains ‘Remark’ a survey remark is expected
in field 42.

Note that in both cases, a traverse feature code may be provided to determine that
subsequent observations are to be included in the traverse spreadsheet. This is provided
to facilitate combined detail topography and traverse surveys.

Leica 1200 Data Input
The following outlines the transfer of format files on to a Leica1200 system and the use of
the 'SCC Sys1200.FRT' file. Download steps into SCC are noted. The use of extra
measurements such as 'Line of Sight offsets, Tape Offsets, Parallel Offsets, Dimensions
and Remarks are examined.

A. Files for SCC Coding on Leica TPS1200 Series instruments:
SCCSys1200.FRT

Format File (*.FRT) generated in Leica GEO
Office to a System 1200 sensor

badleyt_0405_211712.xcf

Parameter Files

badleyt_0405_211712.x23
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badleyt_0405_211712.x06

B. Setting up Coding on the TPS1200:
a)Transfer of Format Files on PC:
· Copy Format Files to the Convert Directory on the Compact Flash [CF] Card
· Copy the *.xcf, *.x23 and *.x06 files into the Code Directory on the Compact Flash [CF]
card
Note:
The Compact Flash card must always be “Stopped” before removing it from your
computer. The System 1200 sensor must always be switched off before removing the
Compact Flash.
b)PC Card in the instrument – Format File:
· Select option 6 Tools… from the Main Menu

This option can be selected by pressing the number 6 key, or by navigating to 6 Tools...
and pressing the Enter key, or by touching the Tools… icon when using an active touch
screen
· Select option 2 Transfer Objects… from the Tools Menu.
· Select option 6 Format Files from the Transfer Objects Menu

· Select the Format File (SCCSys1200.FRT) you wish to transfer, from the CF Card, to
the SystemRAM, in the Transfer Format Files screen.
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· Select CONT [F1]
The System 1200 sensor will return to the Main Menu once the Format File transfer is
completed.
c)PC Card in the instrument – Transfer Configuration Sets:
· Select option 6 Tools… from the Main Menu
· Select option 2 Transfer Objects from the Tools Menu
· Select option 2 Configuration Sets from the Transfer Objects Menu
· Set up appropriately (TC, TCRP RCS etc.):

· Select ‘F3 – ALL’
d)PC Card in the instrument – Configuration:
· Select option 5 Configuration… from the Main Menu
· Select option 4 Interfaces from the Configuration: TC Menu

· Select GSI Output

· Select ‘F1 – CONT’

C. Setting up Survey
a)PC Card in the instrument – Management:
Select option 3 Management… from the Main Menu
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Select 1 Job from Management Menu

· Select F2 New from Job (CF Card) Menu

· Within General Tab enter relevant details:

· Tab to Codelist and ensure that the setting assigned in Step C d
(Transfer Codelist) have been attained

· Within Tab Coord System select None
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· Within Avge Tab select Off

· Select F1 Store
· Within Main Job Screen select F1 CONT with TEST highlighted

D. Setting up Stations within 1200 Series:
(Known Azimuth)
· Select option 1 Survey… from the Main Menu

· Set up the appropriate Reflector
· Set Method to Known BS
· Select Frm Fixpoint Job as Station Coord

· Select F1 CONT to access the Station Setup Panel
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· With Station ID highlighted select Enter (or Tap on Station ID focus)

· Select F2 NEW
· Enter Coords

· Within Code Tab
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· Select F1 STORE
· Select F1 CONT twice to return to Select Station Dialog
· Select Station ID and enter Instrument Height
· Select F1 CONT
· Enter A Backsight ID and set Azmuith

E. Surveying Detail with SCC Codelist:
Leica TPS1200 Coding
· After Station Set up select 1 Survey from Main Menu
· 4 tabs are available
· For Example
Go to Code tab:Enter Reflector Ht.
Assign Point Code either using arrows or double click to view Code and Code
Description Dialog
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· Assign String, Line Tag and DTM Status appropriately
Offsets are available from either the offset Tab or by within the Free Codes ‘F7’.
Extra Measurements have also been set up within the Free Codes ‘F7’.

F.

SCC Settings for Leica coding using Leica TPS1200 Instruments
Open SCC and set up Project
Select ‘FILE > Download Survey’
Select ‘Leica 1100/1200 (GSI Config)’ as Survey Data Logger
Select the required ‘Data Type’
Select ‘Data logger input Device’
Select ‘OK’

Select ‘Leica1200.GSIConfig’ Format File
Set up additional settings as shown below:
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Select ‘OK’

Traverse Observation Feature Code
Traverse Observation Feature Code field should be filled with the user’s individual code
i.e. PSSA or STN etc.
If this is not filled in, no stations file will be produced.
Always include the decimal point when inputting any number so that SCC knows the units
i.e. 12.0 or 0.25

G. Tag Codes
The tag code determines the connective geometry and specifies how the current point on
the string will be connected to the next point on the string. This can be used to specify
straight lines, curves, arcs, and squared up pieces of geometry in a string. The tag codes
may be entered either in numeric or alpha-numeric format.

See Also
Feature Library (View menu)

H. DTM Tag Code
The DTM (Digital Terrain Model) status code determines the significance of the point of
the surface model / digital terrain model being generated. The DTM codes may be
entered either in numeric or alpha-numeric format
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See Also
Feature Library (View menu)

I.

Extra measurement fields
Extra user defined GSI fields may be used to collect extra measurement information
corresponding to the SCC extra measurement sheet.

Several offsets are available as part of the main interface:

The Offsets are as follows:
Offset Cross:

Line Of Sight L/R (Radial Offset)

Offset Length:

Line Of Sight F/B (Lateral Offset)

Offset Height:

Elevation offset.

Additional Extra Measurements have been set up as part of the Free Codes (F7):

Free Code:

Line OF Sight
The ‘-Left+Right’ offset corresponds to the distance left or right along the line of sight
between the instrument and the target.
The ’–Forward+Back’ offset corresponds to the distance forward or back along the line of
sight between the instrument and the target.
The ‘–Up+Down’ offset corresponds to the elevation offset.
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Point 101:

Line of Sight Offset to the left –3.500

*110017+0000000000000101 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410018+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+0000000000-3.500
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 102:
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*110019+0000000000000102 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410020+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+000000000000.000
46....+0000000000-6.500 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 103:

Line of Sight Offset to the Down +10.00

*110021+0000000000000103 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410022+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+000000000000.000
46....+000000000000.000 47....+000000000010.000 48....+0000000000000000
49....+0000000000000000
Tape

The’–Forward+Back’ offset corresponds to the distance forward or back along the line
(Baseline) connecting the last two survey points.
The ‘-Left+Right’ offset corresponds to the distance left or right along the line (Baseline)
connecting the last two survey points.
The ‘–Up+Down’ offset corresponds to the elevation offset.
Point 201:

Tape Offset to the Back +2.300

*110026+0000000000000201 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
©2015 Atlas Computers Ltd

62
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410027+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+000000000002.300
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 202:

Tape Offset to the Right +4.500

*110028+0000000000000202 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410029+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+0000000000000000
46....+000000000004.500 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 203:

Tape Offset to the Up -8.000

*110030+0000000000000203 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410031+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000-8.000 48....+0000000000000000
49....+0000000000000000
Parallel Offset

‘Dist Offset’ corresponds to the distance between the observed feature line and the
generated feature line (Feature?).
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‘Elev Offset’ corresponds to the elevation offset.

Point 302:

Parallel Offset – Offsetting HE Left -2.500 from TB Feature

*110035+0000000000000302 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TB 72....+0000000000000056 73....+000000000000000S
74....+000000000000000D *410036+00000000Parallel 42....+0000000000000000
43....+0000000000000003 44....+00000000000000HE 45....+0000000000-2.500
46....+000000000000.000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 302:

Parallel Height Offset – Offsetting HE in Z +2.500 from TB Feature

*110037+0000000000000303 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TB 72....+0000000000000056 73....+000000000000000S
74....+000000000000000D *410038+00000000Parallel 42....+0000000000000000
43....+0000000000000003 44....+00000000000000HE 45....+000000000000.000
46....+000000000003.200 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Dimension

©2015 Atlas Computers Ltd

64

This option allows the user to manually input a Dimension 1 and Dimension 2 value.
Point 401:

TC feature with assigned D1 of 5.0 and D2 of 0.500

*110040+0000000000000401 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TC 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410041+000000Dimensions 42....+0000000000000000
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000000000 48....+000000000005.000
49....+000000000000.500
For example, Feature ‘Tree’ may have a Dimension 1 value denoting the Canopy size and
also a Dimension 2 referring to Tree Trunk size.
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Remarks

Additional annotation can be assigned to a specific point with ‘Remarks’.
Point 95:

WALL feature with assigned Remark ‘BRICK’

*110043+0000000000000095 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+000000000000WALL 72....+0000000000000001 73....+000000000000000S
74....+000000000000000D *410044+0000000000Remark 42....+00000000000BRICK
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 376:

TC feature with assigned Remark ‘OAK’
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*110045+0000000000000376 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TC 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410046+0000000000Remark 42....+0000000000000OAK
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000

J.

Traverse observation feature code (not specific to 1200)

An extra user defined feature code may be used to signify a control observation. This
observation will be used as a reference observation in the instrument set-up sheet and as
a traverse observation in the traverse sheet. This facilitates combined detail and traverse
surveys using the GSI format. If this field is left blank, and tag codes are not being
collected, all observations will be output to the traverse sheet. If this field is left blank and
tag codes are being collected, observations with tag codes of FS, BS, and SS will be
output to the traverse sheet.

K. Store Station co-ordinates (not specific to 1200)
Tick this field if you want to store station coordinates present in the input file, in fields 84 to
86, in the SCC project control file.

L.

Codes precede observations (not specific to 1200)

This option controls whether a code block is associate with the preceding observation, or
the following observation. For example, in the input below the code block precedes the
data block
410006+000000KB 48....+0000000S 47....+0000000D 49....+00000002 110007+00000169
21.304+12359530 22.304+09515230 31...0+00003502

M. Use Topo X,Y,Z in preference to HA,Va,Sd (not specific to 1200)
This option allows the computed X,Y,Z positions in the GSI input file to be stored in the
SCC observation sheet rather than the Ha,Va,Sd values, where both occur in a single data
line. This is useful if the GSI file does not include all of the survey observations, such as
observed back-sights, as shown in the example below;
*110001+000000000000GR0A 84..10+0000000320728329
85..10+0000000376869559 86..10+0000000000099259
*110002+000000000000GR01 81..00+0000000320715339
82..00+0000000376754428 83..00+0000000000100000
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*110003+000000000000GR0A 84..10+0000000320728329
85..10+0000000376869559 86..10+0000000000099259
87..10+0000000000001500 88..10+0000000000001602
79....+000000000000GR01
*110004+0000000000000066 21.324+0000000018626250
22.324+0000000008940550 31..00+0000000000115851
87..10+0000000000001500 71....+0000000000000000
72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 81..00+0000000320715334
82..00+0000000376754441 83..00+0000000000100005
*110005+0000000000000067 21.324+0000000015216010
22.324+0000000008744130 31..00+0000000000074790
87..10+0000000000001500 71....+0000000000000OSC
72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 81..00+0000000320763106
82..00+0000000376803412 83..00+0000000000102315

Case Study
Case 1:

Tape Offset

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D
*110015+000000000000002 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D
*110016+000000000000003 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D
*410017+000000000000003 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+0000000000000000 46....+000000000002.250
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000
*410017+000000000000004 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+000000000004.760 46.... +000000000000000
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000
*410017+000000000000005 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+0000000000000000 46....-000000000000.700
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000
Tape Offset Pt. 3: Longitudinal Offset of +2.250
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New Baseline is now Pt. 2- Pt. 3
Tape Offset Pt. 4: Lateral Offset of +4.760m (+Right)
Baseline now Pt. 3 – Pt. 4
Tape Offset Pt. 5:

Case 2:

Lateral Offset of -0.700m (-Left)

2 Point Symbol OR 2 Point + Width

2 Point Symbol
*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000030 73....+000000000000000S 74....+000000000000000D
*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000030 73....+000000000000000S 74....+000000000000000D
Within the Project File assign ‘2Point Symbol (Side)’ Symbology and select a Dimension 1
symbol which has side intersection points.

Within the Project select ‘EDIT > Symbols > Edit symbols insert point’
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Case 3:

2 Point + Width

Manhole / Utility Cover

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000020 73....+0000000000000R2W 74....+000000000000000D
*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000020 73....+0000000000000R2W 74....+000000000000000D
*410041+000000Dimensions 42....+0000000000000000 43....+0000000000000000
44....+0000000000000000 45....+0000000000000000 46....+0000000000000000
47....+0000000000000000 48....+000000000002.000 49....+0000000000000000

Case 4:

2 Point Circle

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
©2015 Atlas Computers Ltd

70
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+00000000000000C2 74....+000000000000000D
*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+00000000000000C2 74....+000000000000000D

3.2.3.3

Downloading Leica HexML Data
The SCC HexML interface to Leica Captivate includes supports for embedded photography
within observation files and models. Model points that include embedded photos will be
highlighted using an extra marker controlled by the ~OBSPIC feature. Observation
photographs can be previewed and edited under the observation tag using the Query & edit
functions. When exporting to AutoCAD DWG and DXF, embedded photographs are available
as hyper-links attached to the survey point.
The SCC HexML interface supports advanced coding through both point codes and free codes,
which can be used in conjunction with Captivate curve and arc codes. When using free codes
with captivate, the free code should be entered after the observation.

3.2.3.4

Downloading Panterra Data

Downloading Panterra Husky Traverse File
Create Project
Select ‘FILE > Download Survey’ and complete the dialog presented as shown below.

Select the file ‘Panterra.TRV’ as the input file, and press ‘Open’ to download.
This will create a new traverse spreadsheet containing all the observations in the input file.
We will adjust this traverse using a least squares adjustment, from the traverse
observation sheet:
Select 'Edit > Adjust and complete the dialog as shown.
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This will produce a report giving the full details of the adjustment.

3.2.3.5

Downloading Trimble Data

Trimble ACU Output
SCC support downloading files from the Trimble ACU, running Tsce software, using the
SDR33 output format. These attributes can be used to describe dimensions, offsets,
parallel features, and all other items available through the SCC extended coding library.
We will demonstrate the use of this facility through the sample file 060228D.DAT. Note
that in this file, Tsce attributes are stored in 13AT records, see extract below for an
example;
2NM

9020

308417.642000000231995.58500000051.33300000000001.50000000000000

07NM
9020
03NM1.70000000000000
09F1
9020

9021

27.900185437685727.9001854376857

9021

12.874430000000088.109739263113027.9001854376857STN

09F1

9020

1001

18.593340000000088.669171829746923.1694290000000BG

13ATOffset
09F1

9020

0.30000000000000
1002
17.165240000000088.759832243491514.1117367500000BG

To process this file in SCC, do the following;
Create a new project, based on a standard template
Select Import / View SDR translation table
Add a record for each attribute type present in the Tsce format being used. For example,
for the OFFSET attribute, we add a new record with the name and code of OFFSET, type
of ‘Control Code with Parameter (CCP)’, and SDR Control type of ‘Par Ofs L/R’. This
means that when SCC encounters an attribute called OFFSET, it will take the attribute
value and store it in the parallel offset field in SCC. For this job, the rest of the records will
be as follows;
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Note that regular features that contain embedded string numbers should also appear in
this sheet with a type of ‘PC’ and a PntInFtr setting of ‘String’. This sheet can also be
used to control default tag and DTM codes for these features.
Once you have completed editing this translation table, you should save the project as a
new template in the SCC folder, such that you do not have to repeat this exercise.
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Trimble TSC/TSCe (DC)'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select '060228D.Dat' from '\SCC\Tutorials' directory
Select 'Open'
Select 'OK'
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Set 'SDRMap Coding Extensions' and 'Search remarks for dimensions'
Select 'OK'
This will generate the following detail survey file;

*.DC files from TSCE containing observations in DC formats as defined in DC10.70 or
DC7.5 are also supported. Observations must be in HA,Va,Sd or X,Y,Z formats. SCC
does not currently read GPS vectors, or GPS lat,long, height records from this format.

Combined Total Station & GPS Files Trimble Data
SCC supports the download of combined Total Station and GPS information contained
within one complete file.

Total Station Detail
08PD
08PD
08PD
08PD
08PD
08PD
08PD

1853
1854
1855
1856
1857
1858
1859

240109.491174308230536.45323307880.5785407722807CONC2
240106.941616718230533.14415286880.4446191824330CONC2
240106.934895243230533.12155861780.4350418868451K2
240103.591644851230535.66377808680.3671757765827K2
240102.973759388230536.67287284980.3818527249702K2
240102.946912372230537.66137346080.3672869395576K2
240108.024260067230544.61543070080.4062528838890K2

GPS Data
09F1

S4

1871

19.485780000000086.2995339500897308.269300500000SL
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09F1

S4

1872

20.122220000000086.2101823251036306.161937000000HE3

13NMOFFSET HE3 2.0M LEFT
09F1
S4

1873

26.350400000000086.0417014778084314.111125500000HE3

09F1

S4

1874

36.881090000000086.4799984710826316.234896000000HE3

09F1

S4

1875

45.070550000000086.8506673231004318.345708000000HE3

09F1

S4

1876

56.991010000000087.4670758972154318.269134018868HE3

09F1

S4

1877

58.376750000000087.5556657440944316.922418000000EP

09F1

S4

1878

60.863180000000087.5235304357424318.604251600000B10

09F1

S4

1879

60.548220000000087.5381532946088326.509790400000B10

From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select 'RAWsdr33dc.dc' from '\SCC\Tutorials' directory
Select 'Open'
Select 'OK'

Set 'Search remarks for dimensions'
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Select 'OK'

Note that the option to strip string numbers from field codes has bee selected with the
'Coordinate Reduction Options'.

Trimble DC Format
SCC also supports the direct download of DC format as follows:
D2NM1021.70000000000
69FD
S22
11
E0NM
S22
E1NM
S22

0.14200000000000
137412.769000000253513.23000000046.1450000000000CON
1.620000000000001.000000000000001
S21
190.187083794199

77NM1.500000000000002.000000000000000.00000000000000
D9F1
S22
S21
91.250749347157591.8136377610403190.187083794199CON
50.003182501540000.001388888888890.00138888888889
A6F1
-0.00090101528280.00846784874555
D9F1
S22
1
90.790027562819091.9271004383258190.244880000000S
10.010181580100000.001388888888890.00138888888889
D9F1
S22
2
90.795487574480291.9263806245318190.249560000000S
10.010181591020000.001388888888890.00138888888889
77NM2.000000000000002.000000000000000.00000000000000
10.010192322360000.001388888888890.00138888888889
D9F1
S22
8001
86.761130395951992.3277570859462213.880050000000HEC1
10.010173522320000.001388888888890.00138888888889
D9F1
S22
8002
77.753634782899292.0915956056461219.797010000000HEC1
10.010155507320000.001388888888890.00138888888889
77NM1.500000000000002.000000000000000.00000000000000
D9F1
S22
8003
73.815260826027192.3056179106150224.597520000000HEC1
10.010147630580000.001388888888890.00138888888889
D9F1
S22
8004
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68.620739011095391.8354586405055234.321300000000HEC1
10.010137241520000.001388888888890.00138888888889
D9F1
S22
8005
64.289547497628291.1620741098151249.494310000000HEC1
10.010128579120000.001388888888890.00138888888889

From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select File
Select 'Open'
Select 'OK'

Set 'Search remarks for dimensions'
Select 'OK'

Trimble/Geodimeter UDS
SCC supports Trimble/Geodimeter format and can be processed as follows:
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data Logger to 'Trimble/Geodimeter UDS'
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Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type
Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required
Select ‘OK’

Select the file you require and ‘OK’
Additional settings may be checked at this stage that relate to the field coding standards
used that are particular to a given instrument. Note that these settings will become the
defaults for all future downloads from the Geodimeter and do not have to be entered with
each download.

Codes 90 through to 99 in the Geodimeter are user definable and may be used log extra
dimensions in SCC. For existing ‘Landscape’ users, the first time we download into SCC,
we will also have to set up the coding options as shown above. The LandScape coding
options determine how the numeric field codes entered in the instrument will be translated
into SCC tag codes, DTM codes, and ancillary measurements based on existing ‘
Landscape’ techniques.
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SCC lets us freely mix data from a range of different instrument manufacturers and
instrument types within a given project. The LandScape processing options are currently
enabled for the Geodimeter and Leica instruments.

Transferring survey data from a Geodimeter CU
Connect the Geodimeter instrument/keyboard to the PC with the appropriate cable and
through the correct communications port. Enter program 54, for data transfer.
Choose from which device the data will be transferred from Internal memory (2. Imem) or
Serial (3. Serial). Select internal memory (2. Imem).
Select the file type for transfer from 1. Job (file), 2. Area (file), 3. U.D.S. Choose option
number 1 - Job file, and type in the job file number in which the observed data is stored.
Choose destination device for the job file from 2. Imem (internal memory) and 3. Serial
(serial device - PC). Select 3 - Serial and accept or enter the correct serial parameters,
which are Com=1.8.0.9600. Prepare SCC(PC) before accepting the serial parameters
because once the serial parameters have been accepted then the data will be transferred.
The display on the Geodimeter/keyboard shows ‘Wait’ during the data transfer. When the
data transfer is finished the Geodimeter/keyboard will exit from program 54 and return to
program 0.

Transferring Setting Out and Control data to a Geodimeter CU
Connect the Geodimeter instrument/keyboard to the PC with the appropriate cable and
through the correct communications port. Enter program 54, for data transfer.
Choose from which device the data will be transferred from Internal memory (2. Imem) or
Serial (3. Serial). Select Serial (3. Serial) and accept or enter correct serial parameters,
which are Com=1.8.0.9600
Select file type for the data to be saved as from 1. Job (file), 2. Area (file), 3. U.D.S.
Choose option number 2 - Area file, and type in the area file number in which the data is
to be stored.
The display on the Geodimeter/keyboard shows "Wait" and is now ready to receive data.
Start the data transfer from SCC. When the data has been transferred the
Geodimeter/keyboard will exit from program 54 and return to program 0.

Downloading
Downloading Trimble
TrimbleDC
DCWith
WithSpecific
Specific
Attributes
Attributes
SCC support downloading files from the Trimble ACU/TCU/TSC2/TSCe, running Tsce
software, using the SDR33 output format. These attributes can be used to describe
dimensions, offsets, parallel features, and all other items available through the SCC extended
coding library. Such attributes have been set up within the feature file
'ATLAS_AM_DCC_ALPHA.fal' and should be used in conjunction
'Trimble_TSCE_ALPHA.Project' feature library in which all features coincide.
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Examination of Feature File and Raw Data
The following screenshots have been captured from Survey Pro to demonstrate the attributes
set up in 'ATLAS_AM_DCC_ALPHA.fal'. Three common survey field codes have been
examined 'BB' Bottom of Bank, 'SO' Spot Height and 'TO' Tree. In turn, extracts from raw
survey data are displayed. Note that, Tsce attributes are stored in 13AT records.
The drop down code list can be accessed within the main 'Measure Top' screen

'BB' Bottom Of Bank String Feature and Attributes:
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09F10003100034.698000090.7002777159.380833BB
13ATSTRING
1.00000000000000
13ATLINETAG
S
13ATDTM
A
13ATREMARK
13ATDIM1
13ATLOSLR
13ATLOSFB
13ATZOFSUD
13ATPARLR
13ATPARFB
13ATTAPELR
13ATTAPEFB
13ATCOPYFEAT
13ATCOPYLR
13ATCOPYUD

0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000

'SO' Spot Height Point Feature and Attributes:

09F10450106819.867000090.5027777255.889444SO
13ATLINETAG
G
13ATDTM
E
13ATDIM1
0.00000000000000
13ATREMARK
13ATLOSLR
0.00000000000000
13ATLOSFB
0.00000000000000
13ATZOFSUD
0.00000000000000

'
TO' Tree Point Feature and Attributes:
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09F10450106738.205000090.0836111263.203611TO
13ATLINETAG
G
13ATDTM
A
13ATREMARK
OAK
13ATDIM1
13ATDIM2
13ATDIM3
13ATLOSLR
13ATLOSFB
13ATZOFSUD

10.0000000000000
0.75000000000000
1.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000

Note:
Many attributes contain drop down menus. For instance, several line connection tags
(tabulated below) which determines the connective geometry and specifies how the
current point on the string will be connected to the next point on the string are included as
a drop down menu.
Alpha Code

Description

S

Straight

C

Curve

A

Arc

G

Gap

L

Link Back To First Point on the String

DC

Discontinuous Curve (Non-Tangential
Incoming Tangent from Straight to Curve)

DS

Discontinuous Straight (Non-Tangential
Outcoming Tangent from Straight to Curve)

Ar3

Three Point Arc

Cr3

Three Point Circle

Cr2

Two Point Circle

C1R

Radius and Centre Circle

Rec3

Three Point Rectangle

Rec2

Two Point and Width Rectangle
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In the same manner, common DTM (Digital Terrain Model) status code which determines
the significance of the point of the surface model / digital terrain model are set up
(tabulated below). As such DTM controls whether the point is 2D or 3D, whether it should
be used in surface model generation and subsequent contouring and other surface
analysis, and whether it lies on a string forming the model boundary.
Alpha Code

Description

D

DTM Elevation

A

Approximate Elevation (2D Point)

E

Non DTM Elevation

I

Ignore

X

DTM Elevation with text turned off on download

Processing & Download Steps:
To process a file in SCC, do the following;
Create a new project, based on 'DublinCityCouncil_Feb07_A_ALPHA.Project'
Select Import / View SDR translation table
A record for each attribute type present in the Tsce format being used. For example, for
the LINETAG attribute, we add a new record with the name and code of LINETAG, type
of ‘Control Code with Parameter (CCP)’, and SDR Control type of ‘Tag Code’. This
means that when SCC encounters an attribute called LINETAG, it will take the attribute
value and store it in the parallel offset field in SCC. When using the feature file
'ATLAS_AM_DCC_ALPHA.fal' on the instrument, the following records should be set up;
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Note:
Regular features that contain embedded string numbers should also appear in this sheet
with a type of ‘PC’ and a PntInFtr setting of ‘String’.
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Trimble TSC/TSCe (DC)'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select file
Select 'Open'
Select 'OK'

Select 'View>>' beside 'SDRMap Coding Extensions'
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Note:
The default library 'Trimble_TSCE_ALPHA.Project' already contains existing field codes
within the Extended field coding table. However, for a new library the user can simply use
'Import codes from library' at this stage to automatically add all feature library codes to the
SDRMap table. The user can then save the project as a default library for future
downloads.
Select 'OK' within the 'Extended field coding table'
Within the 'Sokkia SDR22/33/PowerSet,Trimble TSC..' dialog, select 'SDRMap Coding
Extensions', 'Search remarks for dimensions' with 'Skip remarks starting with -'
Ensure that 'Use change in occupied station to create new set-ups'
Select 'OK'
The dataset will be presented.

Examination
Examination Of Feature
Feature Library
Library
The following examines the feature library 'ATLAS_AM_DCC_ALPHA.fcl' within Trimble
Geomatics Office:
Open Trimble Geomatics Office Software, select 'Utilities > Feature and Attribute Editor'
Within the Feature and Attribute Editor' dialog, select 'FILE > Open'
Select 'ATLAS_AM_DCC_ALPHA.fcl'
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Template Features
5 specific template features have been set up within Trimble Geomatics Office which all
other features are based. As a result, the library can be quickly edited by amending or
changing the 5 main features on which all other features are based.
The following outlines each and details the attributes assigned:

'SO' Spot Height Feature set up as a 1pt Feature:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

SO

LINETAG

G

DTM

D

Spot Height

DIM1
REMARK
LOSLR
LOSFB
ZOFSUD
NOTE:
LINETAG - Line Connection Tag, DTM - DTM Status, DIM1 - Dimension 1, LOSLR - Line
Of Sight Offset Left / Right, LOSFB - Line Of Sight Offset Forward / Back, ZOFSUD Elevation Offest Up / Down
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All other 1 point Features have been set up based on 'SO'.
Therefore, if you double click on a 1 point feature in the Feature and Attribute Editor or
right click mouse on 1 point feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'SO'. In the example below, Sign 1 point 'SGO' uses
'SO' :
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The following diagram demonstrates the relationship of the attributes within Trimble
Geomatics Office 'Feature and Attribute Editor' dialog and the actually screens from the
instrument showing the attribute:

To globally edit all 1 point feature the feature 'SO' can be modified.
For instance, if you do not wish to have specific attributes assigned to a 1 point feature,
the feature 'SO' can be edited and in turn, all 1 point features based on 'SO' will be
modified.
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'KT' Kerb Top Feature set up as a String:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT
VALUES

KT

STRING

1

LINETAG

S

DTM

D

Kerb Top

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
COPYFEAT
COPYLR
COPYUD
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back, COPYFEAT - Copy Feature,
COPYLR - Copy Feature Left / Right Offset, COPYFB - Copy Feature Forward / Back
Offset
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All other strings have been set up based on 'KT'.
Therefore, if you double click on a string feature in the Feature and Attribute Editor or right
click mouse on string feature and then select 'Properties' you can see the 'Uses actions of
another feature' is set to 'KT'. In the example below, Bottom of Bank string 'BB' uses
'KT' :
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The following diagram demonstrates the relationship of the attributes within Trimble
Geomatics Office 'Feature and Attribute Editor' dialog and the actually screens from the
instrument showing the attribute:

To globally edit all string features, the feature 'KT' can be modified.
For instance, if you do not wish to have specific attributes assigned to a string, the feature
'KT' can be edited and in turn, all stings based on 'KT' will be modified.
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'MHRT' Manhole Feature set up as a 3 Point Rectangular:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

MHRT

LINETAG

Rec3

DTM

D

Manhole 3pt Rec

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 3 point rectangles have been set up based on 'MHRT'.
Therefore, if you double click on a 3 point rectangles feature in the Feature and Attribute
Editor or right click mouse on a 3 point rectangles feature and then select 'Properties' you
can see the 'Uses actions of another feature' is set to 'MHRT'. In the example below,
Recycle Bin 3 point rectangle 'RBT' uses 'MHRT' :

To globally edit all 3 point rectangles features, the feature 'MHRT' can be
modified.
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'MHRW' Manhole Feature set up as a 2 Points plus Width:
FEATURE

DESCRIPTION

ATTRIBUTES DEFAULT
VALUES

MHRT

Manhole 3pt Rec

LINETAG

Rec2

DTM

D

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 2 point plus width have been set up based on 'MHRW'.
Therefore, if you double click on a 2 point plus width feature in the Feature and Attribute
Editor or right click mouse on 2 point plus width feature and then select 'Properties' you
can see the 'Uses actions of another feature' is set to 'MHRW'. In the example below,
Recycle Bin 3 point rectangle 'RBW' uses 'MHRW' :

To globally edit all 2 point plus width features, the feature 'MHRW' can be
modified.
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'ARAHL' Arrow Ahead Left Feature set up as a 3 Points:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

ARAHL

STRING

1

LINETAG

S

DTM

D

Arrow Ahead Left

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
COPYFEAT
COPYLR
COPYUD
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back, COPYFEAT - Copy Feature,
COPYLR - Copy Feature Left / Right Offset, COPYFB - Copy Feature Forward / Back
Offset
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All other 3 point features have been set up based on 'MHRW'.
Therefore, if you double click on a 3 point feature in the Feature and Attribute Editor or
right click mouse on a 3 point feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'ARAHL'. In the example below, Arrow Ahead Right 3
point rectangle 'ARAHR' uses 'ARAHL :

To globally edit all 3 point features, the feature 'ARAHL' can be modified.

'OE' Line Eircom Overhead Feature set up as a 2D (Approx Elevation)
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String:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT
VALUES

OE

STRING

1

LINETAG

S

DTM

A

Eircom Overhead

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 2D string features have been set up based on 'OE'.
Therefore, if you double click on a 2D string feature in the Feature and Attribute Editor or
right click mouse on a 2D string feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'OESB'. In the example below, ESB Overhead 'OESB'
uses 'OE' :

To globally edit all 2D string features, the feature 'OE' can be modified.

'TO' Tree Feature set up as a 2D (Approx Elevation) 1 point feature with
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specific Dimension Attributes for Canopy and Trunk Size:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

TO

LINETAG

G

DTM

A

Tree

DIM1
DIM2
DIM3
REMARK
LOSLR
LOSFB
ZOFSUD
NOTE:
LINETAG - Line Connection Tag, DTM - DTM Status, DIM1 - Dimension 1, DIM2 Dimension 2, DIM3 - Dimension 3, REMARK - Remark / Note, LOSLR - Line Of Sight
Offset Left / Right, LOSFB - Line Of Sight Offset Forward / Back, ZOFSUD - Elevation
Offest Up / Down
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Trimble
Trimble Exchange
Exchange
The user can download using Trimble JXL, Trimble DC, SDR33, Geodimeter UDS or GPS X,Y,
Z formats using the Trimble Link Engine.
To download from using Trimble Link Engine in SCC, use the following steps;
Go to 'FILE > Download survey'

If this is the first time using TLE, and downloading from file, press the 'Create New
Device' icon

Create a Survey Data Card device for the folder containing your raw Trimble data.
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Select the device, select the job and press Open to begin downloading.
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General SCC download steps can be implemented from this stage.
The TLE interface can be configured under 'FILE > General options > Communications >
Trimble options'

Zone may need to be changed to reduce RTK to coordinates, but most of the other defaults
should be ok.

3.2.3.6

Downloading TopCon Data
This following outlines the usage of the SCC TopSurv interface using the raw TopSurv
files ‘Skippets1’, ‘Skippets2’, ‘Skippets3’, ‘Skippets4’, and ‘Skippets5’, as provided via
TopCon. The steps required in processing this job are as follows;
In TopSurv, open each job, and export it in both raw data and point formats.
Select Job > Open > Skippets1.Job
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Select 'Job > Export To File > Raw Data, and select the TDS format as shown below. This
will create the file Skippets1.RAW.

Select 'Job > Export To File > Points, and select the custom format as shown below.
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This will create the file Skippets1.txt. Use the custom format shown below.

If this is the first time you have used this option, press the Edit format button, and select
the fields as shown.
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Finish the points output as shown, repeat the above steps for all five jobs, and copy all the
resultant .RAW and .TXT files onto the PC running SCC.

Import the TopSurv files into SCC
In SCC, select 'FILE > New project' to create a new project. The project file will be used
to store all the common stations between the different jobs, and to store the feature library,
which in turn controls the drawing, layering and model creation standards that will be
used.
Select 'FILE > Download' to download all five jobs as shown below;
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This will create ten new SCC documents, which are made up of a detail survey document
and traverse document for each raw job.

Adjust The First Traverse
The traverse documents created in SCC will be used to tie the five separate detail jobs
into a single, common, grid. Each survey job was carried out using common station
names, but different grids. The SCC traversing routines will be used to resolve these into
a common grid. This can be done either by adjusting the traverse information for each job
separately, or by combining the all the raw data to form a single traverse. We will start be
adjusting the first traverse in isolation.
Select 'EDIT > Setup', and enter the opening and closing setups as shown.
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This arrangement with on fixed station and one fixed bearing provides a minimally
constrained traverse network that is useful for testing the internal integrity of the
measurements.
Select 'EDIT > Adjust, and adjust the traverse using a least squares method, as shown
below;

The first attempt at doing this will show up a station naming error in the raw data.

We can see that the observation at station 35, from STN10 to STN11, has a horizontal
angle and distance that suggests that the sighted station is actually STN12 rather than
STN11. This can be rectified by changing the ‘To Stn’ field to STN12, or by setting the ‘
Use Obs’ field to ‘No’.
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Repeating the adjustment gives us no more errors in this job, and yields the traverse
report.

We can now store the station coordinates in the project file, and repeat the process for the
remaining jobs. Another solution, which is preferable in this case, is use the option '
Append Traverse' to create a single traverse job, and adjust them simultaneously, again
using the method described above. The final traverse file and project that includes all of
the adjusted stations are attached in ‘Skippets-all.traverse’ and ‘TopSurvDemo.project’.

Coordinate And Model The Detail Topography
Use ‘FILE > Open’ to open all of the detail survey jobs as shown below. In each job,
select ‘File / Rebuild coordinates’ to apply the effects of the control adjustment.
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Select ‘FILE >Model > SCC Survey Datasets’, and again select all five jobs to create the
model as shown below.

Note that SCC is interpreting the TopSurv attributes as follows in order to provide some of
the reduction and drawing details;
DIAMETER.REAL=
SPREAD.REAL=

The attributed is evaluated and stored in D1, which
is in turn used for tree spreads, wall widths, etc…

WIDTH.REAL=
GIRTH.REAL=

The attributed is evaluated and stored in D2 which
is in turn used for tree spreads, etc
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HEIGHT.REAL=

The attributed is evaluated and stored in D3

“S”

The tag code is set to straight

“C”

The tag code is set to curve

“s

The tag code is set to discontinuous straight, that is
a straight that follows a curve that does not impose
any tangent conditions on the curve.

“C”

The tag code is set to discontinuous curve, that is a
new curve that is not tangential to the last straight
or curve.

“R”

The point is assumed to be part of a three point
rectangle.

&

The numeric following determine the string
number. If these are not present the observation
refers to a discrete point feature

Note that all other tag and dtm codes are derived from the feature library.
To annotate the traverse on the model select ‘FILE > Attach/Detach > Attach traverse’
and select ‘Skippets-all.traverse’. The select ‘EDIT > Text > Annotate Traverse’ as
shown

This will result in the stations being annotated on the traverse.
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3.2.3.7

Downloading Sokkia Data
SCC support downloading files using the SDR33 output format.

Extract of Sample File
07TP00030004305.1843910.00000000
03NM1.59000000
09F10003000490.561000090.16305550.000000000004
03NM1.50000000
09F10003100034.698000090.7002777159.380833TS01
09F10003100136.903000088.7950000165.696944TB01
09F10003100222.805000089.8027777189.280277201 TS01
09F10003100327.147000087.9900000188.787777TB01
09F10003100425.362000088.3702777191.974166PTDS
13NMP 1004 1.10 m ELM
09F10003100523.497000089.8994444247.683888TS01
09F10003100627.212000088.2977777243.250555TB01
09F10003100734.248000089.9150000271.187500TS01
09F10003100836.355000088.7963888266.240833TB01
09F10003100924.278000090.1666666283.591111PLIT
09F10003101038.033000090.3277777315.945833SK50
13NM203 SK50 SK51 0.0 -1.85
09F10003101130.238000090.2000000348.368611SK50 CS50
09F10003101229.183000090.2005555348.219444CS50
09F10003101329.090000090.1336111354.765555CS50
09F10003101430.140000090.1333333354.751388CS50 SK50
09F10003101536.737000089.807777728.3350000SK50

Download Steps
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'
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Select 'OK'
Select 'PKTOPO1.Dat' from '\SCC\Tutorials' directory
Select 'Open'
Select 'OK'

Set 'MX/MOSS coding extension' and 'Search remarks for dimensions'
Select 'OK'

See Also
Downloading Trimble DC Format Data

Downloading
Downloading Sokkia
SokkiaSRX/SDR33/SDR22
SRX/SDR33/SDR22

Creating a New Project
From the Main Menu Bar, select ‘FILE >New Project’
Enter in a Project/Job name 'TEST.Project'
Select a Project Template from the list 'Default v7 Complex.Project'
Select ‘OK’
The project template contains all the feature coding, layering, string labelling, modelling,
symbology and annotation standards that will be applied to the project.
The project itself consists of a spreadsheet containing the control stations used in the
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project, along with a feature library spreadsheet.

Feature Library
Importing SDR Library
From the Main Menu Bar, select ‘VIEW > Feature Library'
Select 'FILE > Import > SDR Map Feature Library'
Select 'FCLIB02.DAT' feature library

Modification of Library
Each feature can be modified easily within the Feature Wizard '
From the Main Menu Bar, select ‘VIEW > Feature Library'
Select 'EDIT > Feature Wizard'
Select the feature from the drop down menu, set up the symbology, symbol, colour, text
and CAD layer for instance.
For example, the feature 'GU' gully should have a symbology of 'Point Symbol' as
observed as a single observation. A specific symbol can be assigned (MH_SQR1) and
symbol size.
The user can also define what text to turn on and the position of such text within Text
Annotation

Note: Additional Symbols can be imported from dxf/dwg

Select 'OK'
Many other features may need attention and in particular 3 point feature such as 'BT3'
which should have a Line Connection Tag of 'Rec3' assigned and forced by the library
('Use above value' within the Feature Wizard)
In addition to the modification of the Feature Library Sheet, strung feature should have a
starting string number assigned within the SDR Map translation library
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Select 'VIEW > Advanced Survey Coding'
Go to 'LH' for example place '1' in the 'Str' column
Save Library

Download Steps
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select raw file
Select 'Open'
Select 'OK'
Set SDRMap Coding Extensions and 'Use change in occupied station to create new set-ups'
as shown below

Select 'OK'
On download SCC range checks each observation, base on the settings within 'General
Options > Units & Data Checking'. In this case, a spurious slope distance has been
noted.

©2015 Atlas Computers Ltd

115

Select 'OK'

Select 'OK' to disable range checks
The log file will present any potential error which may need further investigation. Such
spurious points can be eliminated by change the DTM status to 'I Ignore' within the Detail
Observation Sheet and then select 'FILE > Rebuild Coordinates'
Further error check can be carried out by examining station set ups with 'VIEW >
Instrument Setups'
Save Dataset

Model Data
Select 'FILE > Model > SCC Dataset'
Select saved dataset
Select ‘Create the model and triangulation’ and set Intial Plot Scale of 200

Select ‘OK’ to Attributes summary dialog
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3.2.3.8

Downloading MOSS Site Module Data
SCC supports MOSS Site Module format and can be processed as follows:
Go to ‘FILE > Download Survey’
Select ‘Husky Hunter (MSMM)’ as the survey data logger
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required

Select ‘OK’
From the ‘Tutorials’ folder in the main SCC directory, highlight ‘FGL1.G11’, ‘FGL2.G11’
, ‘FGL3.G11’ and ‘FGL4.G11’ and ‘Open’.
You will be presented with 4 SCC datasets called ‘FGL1’, ‘FGL2’, ‘FGL3’ and ‘FGL4’.
These datasets will be automatically saved on download.
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3.2.3.9

Downloading X,Y,Z coordinates from GPS
The following examines downloading coordinate files into SCC using ‘GPS XYZ’
Download option. Note that in this case the coordinates are initially placed in the
observation sheet, such that they can be processed by the survey reduction. This allows
for curve fitting, squaring up strings, and completion of any other survey geometry.

A. Setting up Project
Set up Project
Open SCC
Select ‘FILE > New Project’
Enter the Project Name and attach the ‘Default(v6-9 Complex).Project’ template.

B. Download & Model Creation
Downloading the sample detail file
Go to ‘FILE’
Select ‘Download Survey’
Select ‘GPS X, Y, Z’ as the survey data logger
Select ‘Detail Topography’ as the data type and set the datalogger input device to ‘disk’
Select ‘OK’

Select ‘GPSTEST.txt’

Extract of ‘GPSTEST.txt’
121,936.4463,1078.9469,42.5348,WL,BRICK
122,935.3751,1076.8353,42.6115,WL,BRICK
123,932.9097,1072.0190,42.5418,WL,BRICK
124,932.2931,1070.8306,42.6371,WL,BRICK
125,931.0534,1068.3674,42.5873,WL,BRICK
126,927.4137,1062.1438,42.5386,TE,OAK
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127,925.6250,1059.3698,42.5524,TE,ASH

Select ‘Point No., X, Y, Z, Feature, Remark
Select 'OK'
This method has the advantage of the ‘Detail Observation’ Sheet being available for
editing.

3.3

Creating A Model
A SCC model can now be generated using the survey dataset files.
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3.3.1

Topographic Model Creation & Editing
A model in SCC is a visual representation of one or more surveys that includes all the
annotated planimetry and a TIN surface model which in turn generates contours, slope
lines, relief mapping, etc.. Note that all of the colours used within SCC, both foreground
and background, are fully user definable to suit the users preference, and the media in
use

Before becoming a visual graphic representation, each model starts out as text in one
form or another. The most common form of data files are SCC Datasets, DXF files, MX
Genio and X,Y,Z ASCII files. These sources can be mixed and matched. SCC will keep
track of where the data comes from. Your responsibility rests in choosing the right data to
combine into your model.

Creating the Model
To create the model, go to ‘FILE > Model > SCC Dataset > and select all 4 downloaded
datasets.
Select ‘Create the model and triangulation’ and set Intial Plot Scale of 200

Select ‘OK’ to Attributes summary dialog
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Your model should like the image below

3.3.2

Creating A Model from An External File
SCC can also create models from existing SCC data or directly from external files. The
external co-ordinate files are files, which are imported into SCC.

3.3.2.1

Modelling A DXF File
The following examines the direct modelling of a DXF file
Select 'FILE > Model'
A dialog will be presented requiring the external file to be selected.
When querying the model using the Query and Edit Points (Model Edit Menu) option from
the Edit menu only feature information will be available. If the file was imported, saved as
a SCC dataset and then a model created feature and co-ordinate information would be
available.
The option to Edit String Details under the Edit menu allows access to global editing
without having to import the file.
Select 'FILE > Model > DWG/DXF File'
Using the Pick button on the Import DXF file dialog, go to the \SCC\TUTORIAL\
directory and select the file OGL.
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Select 'OK'
Select 'Create model and triangulation and set the Initial Plot Scale '200'

Select 'OK' for the SCCW window which summarises model attributes
The model OGL will be drawn:

3.3.2.2

Modelling A GENIO File
The following examines the direct modelling of a GENIO file
Go to ‘File > Model > MX GENIO file’.
Select the file ‘GROUND.CRD’ from the TUTORIALS directory
Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely
and GENIO L-string processing to ‘Treat as points’.
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Select 'OK'

Set the Initial Plot Scale as '200'
Select 'Create the model and triangulation'

Go to ‘FILE > Save’
Save the model as ‘Ground.Model’

3.4

Triangle Editing
SCC supports two methods of triangulation: 'Delaunay' or '3D Nearest Neighbour'. Either of
these may be selected depending on the requirements of the dataset under consideration.
Generally the final model produced by either method for a given dataset will be almost
identical.

Delaunay triangulation forms the set of most equilateral triangles for a set of points. As
such it is deciding the final triangulation based on a purely 2 dimensional criterion and then
adding elevations to form a surface. As a rule it normally gives the most even spread of
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triangles, and hence interpolation results, particularly in areas where data is sparse.

3D nearest neighbour joins every point to all its nearest neighbours while not allowing any
edges to cross. While not providing as even a spread of triangles as Delaunay, the triangulation
is being weighted on a 3D criterion. This may often be more suitable for surfaces where strings
have not been surveyed and points are being selected randomly from the surface, e.g. for
bathymetric work. This is because triangle edges will form more along contours than across
them, hence finding the equivalent of natural strings.
The triangulation is derived from the strings and points in the model. Therefore, all efforts
should be made to edit the strings before editing the triangulation. Editing the triangulation
allows further control over the final model surface and its boundaries.

Triangle Weeding
The simplest way of triangle editing is to ‘Weed the Triangulation’.

Weeding Model Triangles
From the Main Menu Bar, select ‘EDIT > Weed the Triangulation’

Select OK to accept the defaults 'Use mean edge lengths and areas'
The weeding factor determines how many standard deviations from the normal will be
required to eliminate the triangle. A higher number will eliminate fewer triangles.
Weeding cycles determine how many times the system will run through this process.

Adding And Removing Triangles
The weeding defaults work reasonably well on most models but it is possible that some
triangles may be eliminated from the interior of the model that you wish to keep. The ‘A
dd/Remove’ option will allow you to replace any of those triangles.
Additionally, there may be triangles the weeding did not remove, that are invalid. These
may be close to equilateral triangles crossing a concave area, or triangles interior to a
building or other flat surface. The above option also allow you to remove any of these
unwanted triangles.
By selecting ‘EDIT’ and then ‘Add/Remove Triangles’, you will activate the triangle editor.
You know when this editor is active because the color of the triangles in your model will be
filled in either green or blue. Triangles may be interactively selected or by using previously
selected points. The invalid or removed triangles are shown in blue and the valid triangles
are shown in green.
When you select this option a dialog will be displayed. This dialog allows you to control
how the triangles are selected and the action you wish to apply to them.
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By selecting points in advance, for example all points on a road center line, it is very easy
to set triangles by feature or string. In this case, selecting ‘All triangles with any points
selected’ will usually refer to any triangle in contact with a road centre line. This will be
much quicker than selecting triangles manually.

Triangle Editing
From the Main Menu Bar, select ‘EDIT > Add and Remove triangles’
Highlight ‘All triangles intersecting line’
Highlight ‘Remove triangles’
Click OK
Select the triangles shown in blue in the image below by left click mouse to start the
intersecting line, move the cursor across triangle you wish to remove and then left click
mouse to end intersecting line.
Select Close (or press ESC) when finished
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SCC then gives you the option of storing the boundary you have created using the ‘
Add/Remove Triangles’ option, as a boundary string. If you say ‘Yes’ to this, a boundary
string called '~BNDRY' is created and stored in your model. This is very useful especially
when volume calculations may be needed.

Click 'Yes' to 'Store model boundary as a string'

The ‘Add/Remove Triangles’ option also allows you to disable contours in a given area,
but keeping the triangles active. For example, on a road, you may not want to display
contours across the hard surface but will wish to generate profiles and cross sections of
the road at a later stage. Removing the triangles from this area will mean that no sections
can be generated at all so therefore you would use the ‘Disable contours’ option instead.

3.5

Annotation In The Model
In terms of text placement, SCC has eighteen automatically annotatable fields per point. For
each of these fields it is possible to specify text size, width, position relative to the point,
justification relative to the point, alignment relative to string, grid and sheet, suffix and prefix,
output layer, font and style. Additionally you can specify whether to annotate all or selected
points for this feature and field, and what the relative priority of this field is when automatically
deleting overwriting text. This can all be set up in the feature library prior to download, thereby
reducing the amount of work that needs to be done to produce the final plot.
Once in the model, these settings can be viewed through the ‘Query & Edit Points’ option from
the ‘EDIT’ menu.
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However, it is recommended that any further editing of text should be done using one of the
following options:

Text Node Editing
Create Text
This option allows you to add free form text and text macros to your model. Selecting it
presents the ‘Create / Edit Text’ dialog shown below.

Type in the text you wish to add to the model. Then click on the model where you wish to
insert the text. You may set the height, width, rotation and justification of the text in the
dialog or interactively when the text is inserted into the model. Font information for the
text will be determined by the current text style.
There is also the option of adding X,Y and Z co-ordinates (in text form) to the model using
the nearest and interpolation macros available. To do this, select X,Y or Z from either ‘Get
from nearest point’ or ‘Interpolate from model’ and hit the 'APPLY' button. As you move
the cursor about the model, the text will be automatically updated, giving you either the
interpolated co-ordinates of the point at the end of the cursor of the co-ordinates of the
nearest point, depending on the option selected. Ticking the ‘Enable dynamic update’
option means that if at a later stage you have to move the text, it will be updated
automatically to display the co-ordinates of the new position.

Edit Existing Text
This option allows you to edit existing text in the model. The option works in a similar
manner to the create edit text option, but in this case you must initially select the text with
the mouse, rather than entering it in the dialog.
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Delete Text
This option allows you to delete existing text. Select this option and then select the text
you wish to delete. To select the text, click on it with the mouse. Use the 'Data Selection
Dialog' prior to selecting this option to delete a large amount of text at the same time.

Move Text
This option allows you to move existing text. Select the text by clicking on it and then
moving it with the mouse to its position. Use the 'Data Selection dialog' prior to selecting
this option to delete a large amount of text at the same time. Pressing the ‘*’key in move
or rotate text changes the mode between moving and rotating the selected text item.

Rotate Text
This option allows you to rotate existing text graphically about the insertion point of the
text. The insertion point of text is to the bottom left of the text. Use the 'Data Selection
dialog' prior to selecting this option to rotate a large amount of text at the same time. This
will give you an option to either set a fixed angle for all the selected text or add a relative
rotation to that text.

Move and rotate text
This option combines the move and rotate function into one button. After selecting this
option you can move text and then left click to change to rotate function.

Resize Text
This option allows you to resize exiting text interactively on the screen. Use the 'Data
Selection Dialog' prior to selecting this option to resize a large amount of text at the same
time.

Copy Text
This option allows the user to copy text and paste the text multiply.

Text Style
The text style controls the font and effects for model text. To set the style of text nodes in
the model, first use the 'Data Selection Dialog' to select the text nodes you wish to modify,
then select the desired text style from the list given in this control.

Edit Text Style
This option allows you to create or edit a text style, using the standard Windows Font
dialog. To create a text style, enter the name of the style and press this button. To edit an
existing text style, select the name of the style and press this button. Apart from being
displayed and plotted in SCC, text styles may be exported to CAD.

Unlock Text
This allows you to convert associative dimension text into literal text, in order to make it
editable. Once dimensional text has been unlocked it is converted into remarks text for
the purposes of the model annotation dialog. Use the 'Data Selection Dialog' prior to
selecting this option to unlock a large amount of text at the same time. This option is only
applicable for annotation items that have an feature library ‘Insert Method’ set to ‘
Associative Dimension’. This will typically only be the case when working with very large
models.
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Show / Hide Macro Text
This option shows or hides text macro details, in order to let you see how various text
items have been created, and what they represent. Text macros are typically used for
annotating point dimensions, such as elevation and point number. All feature library text
macros will appear as ‘[VTX]’ with any appropriate prefixed and / or suffixes. A complete
list of text macros currently in use in SCC is given below
Macro Name

Description

[VTX]

Any point annotation generated by the feature library

[Name]

The file title of the current model

[Path]

The full file name and folder location of the current model

[Scale]

The plot scale

[Client]

The client name, entered in the ‘Scales, titles and grids’ dialog.

[Date]

The date, entered in the ‘Scales, titles and grids’ dialog.

[Surveyor]

The surveyor name, entered in the ‘Scales, titles and grids’
dialog.

[ProjectTitle]

The project title, entered in the ‘Scales, titles and grids’ dialog.

[Project]

The SCC project name.

[Operator]

The operator name, entered in the ‘Scales, titles and grids’
dialog.

[Time]

The current system date and time.

[Version]

The SCC version number

[Page]

The number of sheets in the model

[Pages]

The sheet number currently being plotted or displayed.

[ContourScale]

A graphic representing the colour contour scale for relief
contours

[ModelX]

The X ordinate of the text node

[ModelY]

The Y ordinate of the text node

[ModelZ]

The Z ordinate of the text node, interpolated from the
triangulation

[ModelChainage]

The chainage of the text node, interpolated from the active
alignment

[ModelOffset]

The offset of the text node, interpolated from the active
alignment

[NearestX]

The X ordinate of the nearest model point to the macro text
node

[NearestY]

The Y ordinate of the nearest model point to the macro text
node

[NearestZ]

The Z ordinate of the nearest model point to the macro text
node

[NearestChainage]

The chainage, generated from the active alignment, of the
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nearest model point to the macro text node
[NearestOffset]

The offset , generated from the active alignment, of the
nearest model point to the macro text node

[NearestD1]

The first dimension of the nearest model point to the macro
text node

[NearestD2]

The second dimension of the nearest model point to the macro
text node

[NearestD3]

The third dimension of the nearest model point to the macro
text node

[NearestPoint]

The point number of the nearest model point to the macro text
node

[NearestFeature]

The feature name of the nearest model point to the macro text
node

[Stn <n> Name]

The name of the <n>th station in the model, normally used for
creating station schedules in sheet layouts.

[Stn <n>X]

The X ordinate of the <n>th station in the model

[Stn <n>Y]

The Y ordinate of the <n>th station in the model

[Stn <n>Z]

The Z ordinate of the <n>th station in the model

[Stn <n>]

The name X,Y and Z of the <n>th station in the model

[Ftr <n> Name]

The name of the <n>th feature in the model,normally used for
creating legends in sheet layouts.

[Ftr <n> Layer]

The layer name of the <n>th feature in the model

[Ftr <n> Title]

The description of the <n>th feature in the model

[Ftr <n>]

The name, layer name and description of the <n>th feature in
the model

[DrawFtr <n>]

A graphic sample of the <nth> feature in the model

[Fcode <n> Name]

The name of the feature, with feature named <n>in the model,
normally used for creating fixed coded legends in sheet
layouts.

[Fcode <n> Layer]

The layer name of the feature named <n>in the model

[Fcode <n> Title]

The description of the feature named <n> in the model

[Fcode <n>]

The name, layer name and description of the feature named
<n> in the model

[DrawFcode <n>]

A graphic sample of the feature named <n> in the model

[Signature]

A graphic of the surveyor’s signature, created by the
PocketDTM ADC module. Used for signed models.

Toggle Text On/Off
This option turns on or off all the text associated with a given point and is provided as an
alternative to manually deleting text, or using the delete overlapping text option.

Align Text To A String
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This option aligns text to a given reference string, either interactively or by pre-selecting a
number of text nodes.

Edit Text Annotation
As briefly discussed previously this option is used in conjunction with the 'Data Selection
Dialog' and is extremely useful for annotating individual points and strings.
Once your model has been downloaded, all survey points will be annotated using the
settings from the feature library. However, depending on the number of points in the
model, some strings/points may become cluttered and illegible. Using the 'Data Selection
Dialog' allows you to highlight individual points, selected strings or points in a specific
area, and change the annotation settings without changing those in the feature library.
The ‘Edit Text Annotation’ dialog also contains several annotation settings that are not
contained within the main feature library.

Using The Edit Text Annotation Tool
Right click the mouse to bring up the ‘Data Selection Dialog’
Select ‘All points on selected string’ and make sure that ‘Mark all points’ is selected.
Select ‘OK’
Pick any point on a string by left click mouse
All points should be highlighted
Go to ‘EDIT > Text > Edit Text Annotation’
Turn on or off the annotation settings as desired.
Using the ‘Edit Text Annotation’ option is purely a model function and does
not effect the annotation settings in the feature library.

Feature Annotation
The feature annotation option is similar to the string annotation option except that it allows
the user to add annotation to the model by feature rather than selected points or strings.
Remember that a feature refers to all strings of the same type, such as all hedges, all
walls etc. Group information set up within the feature library is also displayed within the
Feature Annotation dialog. This allowing the user to modify, select and display data based
on their defined group.

Viewing Feature Annotation
Select ‘VIEW > Feature Annotation’
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Note that Feature Annotation option modifies the models feature library,
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and re-annotates all strings for any features that are altered. This is liable
to undo other text editing and should be used with caution. If you have
already carried out a significant amount of text editing, use ‘Edit Text
Annotation’ instead.

Delete Overlapping Text
This option allows SCC to delete any overlapping text based on the number entered in
the ‘Priority’ field of the text attributes in the feature library. Each piece of associated text
is given a number and the higher the number, the higher the priority. Therefore, if there
are two pieces of text overlapping where the point number has a priority of 3 and the
elevation has a priority of 6, then, the point number will be deleted. This option can be
used in conjunction with the 'Data Selection Dialog' to highlight either certain areas,
features or strings.

Delete Overlapping Text Using The Data Selection Dialog
First, press the ‘Escape’ button. This will cancel any active editing process.
Press the right mouse button and the ‘Data Selection Dialog’ should appear.
Select ‘All point in a window’
Select ‘OK’
In the model, draw a window around the area in question.
All points within this area should be highlighted blue.
Go to 'EDIT > Text > Delete Overlapping Text'
SCC will then inform you of how many pieces of text were deleted during the process.
Any remaining text can then be interactively moved, rotated, resized, deleted or edited.
Text that has been deleted can also easily be restored using the ‘Annotate Strings’ tool,
which again works best in combination with the data selection tool.

4

The Feature Library
The feature library controls how survey spreadsheets are translated into graphical SCC
models, CAD drawings, and MX models. It includes a large number of fields for each survey
feature that control how it is drawn, annotated, modelled, and output. Each project in SCC
should have its own feature library.

See Also
Feature Naming Conventions & The Feature Library
Feature Library (View Menu)
To set-up a new feature it is often easiest to use the feature wizard as follows;
Type the feature name and description into the boxes at the top right of the dialog.
Pick a base style that most closely matches the feature you are creating. Scrolling through
the base styles is a good way of looking at how different features can be drawn.
Change the CAD layer, MX label, and any other fields as required.
To change any annotators, select the annotator in question from drop down menu, e.g.
Level, and then modify the other annotation fields.
If you wish to create a number of other features with a similar look, type in a new base
style and press ‘Save’.
When you have finished, press OK
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Select 'File > Save' or 'File > Save As' to save the project.
If you wish to change a field value for a large number of features, it will be
quicker to do this directly in the feature library spreadsheet using the
search and replace function.

4.1

Using the Feature Library
This section describes how to record specific features in the field and then set up SCC so as it
will automatically draw these specific features when they are downloaded.

4.1.1

Creating Rectangles (Using the Feature Library)
The rectangle option speeds up the process of surveying rectangular features such as
inspection covers, road gullies or simple buildings. The surveyor need only record two
successive points while moving in a clockwise direction around the feature. The breadth
of the feature must then be entered in the dimension field of the data logger.

To generate rectangles in SCC the switch Create squares and rectangles in the
Co-ordinate Reduction options menu of the Detail co-ordinate file (Coordinate Reduction
Options (File Menu)) must be turned on, and the symbology field for that particular feature
name must be set to Rectangle in the Feature Library (Feature Library (View menu).
Note that if any feature is inadvertently surveyed in an anti-clockwise direction then the
rectangle will be generated on the wrong side of the surveyed line. This can be corrected
by reversing the string direction using the global editor.

See Also
Creating Strip Levels (Using the Feature Library)
Creating Trees (Using the Feature Library)
Inaccessible Linear Features

4.1.2

Creating Strip Levels (Using the Feature Library)
Surveying the centre-line of a linear feature such as a track, ditch or wall generates a
strip-level. As the surveyor progresses along the centre-line the width of the feature must
be entered into the dimensional field in the survey data recorder.
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When the survey data is processed in SCC the feature will be displayed as a strip of the
appropriate width. The centre-line will not be displayed. In order to have specific features
treated as strip-levels the following options must be set within SCC; in the Detail
Co-ordinate File menu go to co-ordinate reduction options (Coordinate Reduction Options
(File Menu) and turn on the switch to Create `Strip levels', and in the Feature Library the
symbology field for that particular feature name must be set to Strip level (Feature Library
(View menu). Note that all instances of that feature will now be treated as a strip-level.
SCC provides the option to model three-dimensional strip-levels. Thus, features such as
streams, ditches or walls may be surveyed as a series of points along the centre-line with
an associated width for the top and the base; the height or depth of the feature at each
surveyed point should also be recorded. In the case of a stream the rod will typically be
placed on the stream bed, the strip-level dimensions should be entered into the data
logger's dimensional fields as indicated in the diagram.

Note that the depth of the stream course will be positive if the rod is placed on the bed.
To have all streams treated as strip-levels set the options within SCC as described above.
In the case of a wall, the dimensions should be entered into the survey data recorder
dimension fields as illustrated in figure below. Note that because the top of the wall has
been observed the height should be entered into the second dimensional field as a
negative value. In order to have walls treated as strip-levels in the SCC model, follow the
procedure described above. The second width (that is the third dimensional field) must
always be less than the first width as over-hangs cannot be triangulated. If the first and
second dimensions are recorded, but the third field is omitted SCC will supply a default
width for the third field (the value for the first dimension will be copied into the third
dimension).
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See Also
Creating Rectangles (Using the Feature Library)
Creating Trees (Using the Feature Library)
Inaccessible Linear Features

4.1.3

Creating Trees (Using the Feature Library)
SCC places two symbols for trees; one representing the canopy and the other the trunk.
The process of surveying a tree is illustrated in the diagram. Generally, the reflector is
first placed to the side of the trunk such that the observer can measure the distance from
the instrument to the centre of the trunk. The centre-line of the trunk - relative to the
instrument - is then indicated so that the instrument operator may hold the observed
distance fixed whilst observing the correct horizontal angle; these are then downloaded to
the data recorder as a pair. Finally, the assistant will measure the mean canopy and trunk
diameters; these will be entered in the D (1) and D (2) fields of the data logger
respectively. In order to have trees appear as scaled symbols in the model the following
options must be set within the SCC feature library; you must enter the symbol name Tree
in the Symbol field for the feature TREE and symbology field must be set to Scaled Point.

See Also
Creating Rectangles (Using the Feature Library)
Creating Strip Levels (Using the Feature Library)
Inaccessible Linear Features

4.1.4

Inaccessible Linear Features
The diagram illustrates the process of surveying an inaccessible linear feature; in this
instance a wall, which is obscured by a hedge. The feature is recorded as an offset; an
offset right in this example, as the wall lies to the right of the line of progress. A series of
points are observed in convenient positions and the offset distance to the wall is entered
into the dimensional field of the data recorder. SCC treats offsets to the right as positive
and those to the left as negative. To have offsets processed you must set the Parallel
feature offsets switch in the co-ordinate reduction options dialog to Apply in the X-Y Plane.
This option may be found in the File menu of the Detail Observations and Detail
Co-ordinate spreadsheets. The other settings within this option are used when processing
building facade surveys
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See Also
Creating Rectangles (Using the Feature Library)
Creating Strip Levels (Using the Feature Library)
Creating Trees (Using the Feature Library)

4.1.5

Developing SCC Feature Library for use with MX
The following outlines the implementation of MX coding within an SCC Feature Library.
SCC’s ability to create customised MX styles set and macros based on the SCC library
are described. Furthermore, a systematic quality check is outlined to verify MX codes, MX
styles sets and MX macros.

MX Codes
MX Codes can be entered in the feature library either directly within the Feature Library
table or within the ‘Feature Wizard’
Go to ‘FILE > Open’
Open ‘Default (v6-14 Complex). Project’
Select ‘VIEW > Feature Library’
MX codes can be assigned to each feature within the Feature Library table or with the use
of the Feature Wizard
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MX Coding Convention:
Strings:
· Are individual features of a model
· Contain linked points of digital information
· Identified by a string label
· String Label consist of a maximum of four alphanumeric characters
· Strings may contain as few or as many points as you wish
String Features, for example:
· Point strings – no link at all between the points. Used for features such as trees, road
signs, telegraph poles, and manhole covers etc.
· Null Levels (Z = -999.0) - Are set on strings where the elevation is not required. Any
points with null levels will be ignored by any vertical analysis function such as
sectioning.
String Labels:
· All strings have a four character string label
· Four alphanumeric codes are assigned for single string generation
· Coding must be unique and explicate
· Some string types require particular first character
-M used for Master alignment strings
-G used for Geometry strings
-P used for point strings
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Features with Varied Dimension:
When designing an SCC Feature Library for use with MX, the user must be aware that all
points with a varied dimension, for example, Trees, Hedges and Walls, will produce a
separate style set file which should be drawn within MX, in addition to the ground model.

Symbol Naming:
MX symbols are restricted to an 8 character name. Therefore, all symbols used with the
SCC library should be limited to 8 character names before export. This may require the
user to rename existing symbols.

Creation / Export of MX Style Sets
MX Not Installed on PC:
Before exporting style sets, if MX is not installed on the local PC, it is important to create
the directory ‘\Mfw\styles’ to which SCC can export the necessary files. All style sets and
macros are output to ‘\Mfw\styles’.
As a final step the user separates the style set files into a ‘\styles’ folder and the macros
into ‘\macros’ folder for use within MX.

MX Installed on PC:
On the other hand, if MX is installed on the local PC, both a ‘\styles’ folder and \macros’
folder have been created during the MX installation.
The Mfw style set directory path can be defined within SCC System Variables
‘FILE > General Options > Directories & Files’

Style Sets and Macro files are export to this location.
It is important that when SCC outputs the required files that no files of the same name are
overwritten.
The new styles set are added to the existing MX styles sets.
The following options are available for the new macro symbols:
1. The new macro files can be placed in a new ‘\macros’ folder replacing the
existing MX ‘\macro’ folders present from the installation. This is not often
desirable as other projects may require the original macro symbols.
2. The new macros can be copied and added to the existing original ‘\macros’
folder. However, it is important not to overwrite existing macros of the same
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name. That is, some newly created macro symbols may have the same name as
the original macro symbols provided on installation.
3. The existing macros folder can be renamed (e.g. ‘\macros_Original’) and a new
macro folder created and placed in the same directory. Therefore, the user has
the option to use either folder. MX always uses the macros within the folder ‘
\macros’.
For example, when processing a project created from ‘SCC.Project’ the user
ensures that the macros folder created from SCC is entitled ‘\macros’ and the
original renamed to ‘\macros_Original’.
On the other hand, when processing a project, which requires the original
macros, the user renames the macros folder created from SCC ‘\macro_SCC’
and ensures that the original symbols are in ‘\macros’ folder.

Export MX Style Sets
With the Feature Library open, select ‘FILE > Export >MX style sets’
SCC creates *.PSS file, *.FNS file and the associated macros *.mml and *.mms within ‘
\Mfw\styles’

All newly created symbols can be viewed and edited within MX’s Macrosymbol Editor

©2015 Atlas Computers Ltd

140

Check / Verification of MX Codes & Styles Sets
An important check to verify MX codes, Styles Sets and Macros can be can be carried out
by:
· modeling the Feature Library within SCC
· creating a GENIO file of this model
· importing the GENIO into MX using the relevant styles sets and macros previously
created from SCC

Model Feature Library
Go to ‘FILE > Open’
Open ‘Default (v6-14 Complex). Project’
Select ‘FILE > Model > Feature Library'
Select ‘OK’ to create the model
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Save Model
Go to ‘FILE > Save As > Default. Model’

Export Model
Select ‘FILE > Export Model > MX Model’
Enter File Name and set up relevant settings:
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MX
Ensure that the required styles sets and macros are in the correct MX directory.
Open MX
Set up New Project
Go to ‘FILE > New Plan Display’ and enter title
Import ‘FtrLib.inp MX file
Go to ‘DISPLAY > Plan with Style Set…’ and set up the following:
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In turn, it is necessary to draw the additional style sets for features of varied dimensions.

4.1.6

Symbol Creation & Insertion
The feature library contains all the symbols used to create model features within SCC. These
symbols can be point symbols, such as trees and lampposts, or line symbols, such as hedges,
fences etc. Symbols can be created in SCC and copied to the current project or imported from
AutoCAD or Microstation. Symbol options are available from the edit menus in the model and
project.

Importing Symbols from DXF
Symbols may be drawn in AutoCAD/Microstation, exploded and saved. Go to ‘FILE > I
mport Symbols from DXF’ and the new symbols will be added to the current project file.

Creating New Symbols in SCC
It is just as easy to create new symbols in SCC whether the design is from a DXF file or
drawn in SCC itself.

Create a New Symbol
Go to ‘FILE > New >SCC model’ – this creates a blank model from which to work
Create your symbol using the ‘Add Strings With Cursor’ option and ‘Update In Model’
when you are finished.
Click on the right mouse button.
Select ‘All Points In Window’
Put a window around all your points
Go to ‘EDIT > Symbols’ and select ‘Create New Symbol’
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Type in a name for the symbol.
Select OK.

Setting Symbols Insertion Points
SCC Symbols may be inserted into SCC using one, two or three points. The symbol’s
insertion points correspond to the points observed in the field by the surveyor, when
surveying the feature represented by that symbol. The symbology field in the feature
library determines how the survey points are used to determine the position, size and
orientation of the symbol. To edit a symbol’s insertion points select 'Edit > Symbols > Edit
Symbol Insertion' points. This will display the dialog shown below.

Each symbol has a separate set of insertion points for insertion by one, two and three
points. When inserting symbols by three points, the third point is used to determine the
orientation and lateral dimension. If the first two points lie on the same horizontal or
vertical base line, the third point can be picked up on either side of that base line. Thus a
turn left symbol can also be used as a turn right symbol.

Inserting Symbols Into The Model
The selected data has now been copied to the project feature library as a new symbol.
This symbol can now be inserted into the model either manually or by using the ‘Query &
Edit points’ option. All inserted symbols can be edited, rotated and scaled similar to the
characteristics of freeform text.

To insert a symbol for a surveyed point, it is best to use the ‘Query & Edit Points’ option
from the ‘EDIT’ menu. Changing the feature symbol using this option, will automatically
update all the points in the model with the same feature.

Changing A Feature Symbol
Open the model FGL
Turn off the contours (‘VIEW > Contours’)
Go to ‘EDIT > Query & Edit Points’
Select any point with the feature code ‘s’ i.e. Spot level
A tab menu is displayed showing all the feature library entries relating to the feature ‘S’
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Change the symbol in the ‘Dimension #1’ field to display ‘Tree_1’ and change the value to
7.0
Change the colour to green and the units to Model (Diameter)
Press the ‘Apply’ button and OK

All the points in the model with the feature ‘s’ will now display a tree symbol, see figure
below:
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4.1.6.1

Creating a Circle Symbol (Using the Feature Library)
The following examines Creating Symbols From with a model:

A. Creating A Circle Symbol
Within the open model, select 'EDIT > Circles, Arcs & Rectangles.. > 2pt Circle'
Left click on model to generate first point of circle and left click again to produce second
point
Right click mouse and select 'Update string in Model'

Repeat the above steps to generate inner circle
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Within the open model, select 'EDIT > Circles, Arcs & Rectangles.. > 2pt Circle'
Left click on model to generate first point of circle and left click again to produce second
point
Right click mouse and select 'Update string in Model'
Highlight the Circle
Right Click the mouse to bring up ‘Data Selection Dialog’
Select ‘All points in a window’
Select ‘OK’

Window the symbol, highlighting all points in blue

Go to ‘Edit > Symbol > Create New Symbol’
Enter ‘New Symbol Name’
Select ‘OK’
Select ‘Esc’ on keyboard to unselect symbol

B. Setting Symbol Insertion Point
Go to ‘File > Symbols > Edit Symbol insert points’
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From this dialog box the insertion points can be assigned.
Select the symbol from the list
By selecting ‘Single point insertion position’ the centre of the symbols is defined as the
insertion point depicted by a red cross

C. Applying New Symbol to Feature Within Existing Model
The new symbol can be applied to a feature within the existing Model as follows:
Select 'EDIT > Query & Edit Points'
Left click on Feature, for example 'S' for Spot Height
Change the Dimension 1 symbol to 'NewSymbol' available within from the drop down
menu
Select 'OK'
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4.1.6.2

Creating symbols from DXF or DWG (Using the Feature Library)
The following examines Creating Symbols From a Given *.dxf within SCC:

A. Creating Project
Opening Existing Project
Open SCC
Go to ‘File > New Project’
Enter the Project Name and assign a Project Template

B. Import DXF File
Creating A North Symbol
‘File > Model > dxf > North.dxf’
Highlight the North Symbol
Right Click the mouse to bring up ‘Data Selection Dialog’
Select ‘All points in a window’
Select ‘OK’

Window the symbol, highlighting all points in blue
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Go to ‘Edit > Symbol > Create New Symbol’

‘Create Symbol From String Data’ Dialog appears
Enter ‘New Symbol Name’
Select ‘OK’
Select ‘Esc’ on keyboard to unselect symbol

Go to ‘File > Symbols > Edit Symbol insert points’
From this dialog box the insertion points can be assigned.
Select the symbol from the list
By selecting ‘Two point insertion positions’ the insert points can then be defined using the
mouse and shown on screen as red cross
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The symbol is automatically available for the existing open working project.
Select ‘Edit > Symbol > Export Symbol to File’ exports the symbol to the SCC directory
allowing the symbol to be used in other projects
The size of the symbol can be defined in the Feature Wizard

Note 1:

General Symbol Creation and Availability

a) A symbol created in a model is available to the model it was created in
b) 'Edit > Symbol > Export Symbols to File’ allows for all symbols including the newly
created symbol to be output to the SCC directory and available for importing into a project
[Open the Projects Feature Library ‘Edit> Symbols > Import Symbols From File’]
c) The symbols in the SCC Directory can also be imported into an existing model and
subsequently used [Open Model ‘Edit > Symbol > Import symbols from files’ ]
It is important to note that in all 3 scenarios how the symbol is used is dependent on how
the feature has been set up in the Feature Library

Note 2:

Exporting Symbols to SCC Directory – Overwriting Facility

‘Edit > Symbol > Export Symbols to File’ allows for specific symbols to be selected from
the dialog to be output to the SCC directory

The ‘Do you wish to overwrite it’ dialog box will appear for each symbol being exported.
The function of this dialog is to allow for symbols that have been edited without any name
change to overwrite what already exists in SCC directory.
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Note 3:

Symbol Name

When creating a symbol, the ‘Create Symbol From String Data’ Dialog appears which
allows the user to enter the new symbol name

However the name entered also defines the symbols description within the
*.VectorSymbol file.
SCC uses the symbol description (embedded in the file) for importing symbols.
Therefore if the user changes the file name in explorer the user will not be able to import
the renamed file, as SCC will source the symbol description (embedded in the file).
For example, a symbol created and exported named NorthArrow will also have a
description (embedded in the file) of NorthArrow. NorthArrow will therefore be available in
the ‘Import symbols from file’ dialog box.

However, if in explorer NorthArrow.VectorSymbol was renamed North_1.VectorSymbol
this file will still have NorthArrow as the symbol description (embedded in the file).
In turn the ‘Import symbols from file’ dialog box, which uses symbol descriptions
(embedded in the file) will only have NorthArrow available as no North_1 description
exists.

4.1.6.3

Creating Symbol and redefining baseline
The following examines Creating Symbols 'ES3' as a 2 point symbol with a define width
from a Given *.dxf within SCC:

A. Creating Project
Opening Existing Project
Open SCC
Go to ‘File > New Project’
Enter the Project Name and assign a Project Template
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B. Explode Blocks within CAD
Before importing dxf into SCC all elements must be explodes within CAD. Then resave
file.

C. Import & Edit Symbol
‘FILE > Model > DWG/DXF > ES.dxf’
The symbol must be rotated so the insertion points are on the horizontal axis.
Right Click the mouse to bring up ‘Data Selection Dialog’
Select ‘All points in a window’
Select ‘OK’

Highlight all symbol points
Go to 'EDIT > Edit Strings > Move String
Set the Rotation to '90 00 00' and Left click on base point
Select 'Apply'
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D. Creating A Symbol
Highlight the rotated Symbol
Right Click the mouse to bring up ‘Data Selection Dialog’
Select ‘All points in a window’
Select ‘OK’

Window the symbol, highlighting all points in blue
Go to ‘EDIT > Symbol > Create New Symbol’
‘Create Symbol From String Data’ Dialog appears
Enter ‘New Symbol Name’
Select ‘OK’
Select ‘Esc’ on keyboard to unselect symbol

Note :

Symbol Name

When creating a symbol, the ‘Create Symbol From String Data’ Dialog appears which
allows the user to enter the new symbol name
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However the name entered also defines the symbols description within the
*.VectorSymbol file.
SCC uses the symbol description (embedded in the file) for importing symbols.
Therefore if the user changes the file name in explorer the user will not be able to import
the renamed file, as SCC will source the symbol description (embedded in the file).
For example, a symbol created and exported named NorthArrow will also have a
description (embedded in the file) of NorthArrow. NorthArrow will therefore be available in
the ‘Import symbols from file’ dialog box.

However, if in explorer NorthArrow.VectorSymbol was renamed North_1.VectorSymbol
this file will still have NorthArrow as the symbol description (embedded in the file).
In turn the ‘Import symbols from file’ dialog box, which uses symbol descriptions
(embedded in the file) will only have NorthArrow available as no North_1 description
exists.

E. Define Insertion Point
Go to ‘File > Symbols > Edit Symbol insert points’

From this dialog box the insertion points can be assigned.
Select the symbol from the list and select 'Two point postion', 'Horizontal Baseline' and
'Snap to nearest point'
Left click on 1st point and left click on second
Select 'Apply'
The symbol is automatically available for the existing open working project.
(If the symbol is exported and later imported into another feature library the insertion
points may need to be redefined)

Note :

General Symbol Creation and Availability

a) A symbol created in a model is available to the model it was created in
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b) 'Edit > Symbol > Export Symbols to File’ allows for all symbols including the newly
created symbol to be output to the SCC directory and available for importing into a project
[To import Open the Projects Feature Library ‘Edit> Symbols > Import Symbols From
File’]
c) The symbols in the SCC Directory can also be imported into an existing model and
subsequently used [Open Model ‘Edit > Symbol > Import symbols from files’ ]
It is important to note that in all 3 scenarios how the symbol is used is dependent on how
the feature has been set up in the Feature Library

F. Exporting Symbol
To allow the symbol to be used within other project the symbol can be exported to the
\SCC directory
Select ‘Edit > Symbol > Export Symbol to File’

Note :

Exporting Symbols to SCC Directory – Overwriting Facility

‘Edit > Symbol > Export Symbols to File’ allows for all symbols to be output to the SCC
directory
The ‘Do you wish to overwrite it’ dialog box will appear for each symbol being exported.
The function of this dialog is to allow for symbols that have been edited without any name
change to overwrite what already exists in SCC directory.

G. Importing Symbol into Default Library
Open default Project
Select 'VIEW > Feature Library'
‘Edit> Symbols > Import Symbols From File’
Select symbol from list and select 'Import'

H. Defining 'ES3' Symbol as a 2 point symbol (centre) with fixed width
Firstly, measure and take note of the defined unchanging width (e.g. 2.285) of the
structure.
With the default feature library open, insert blank new record 'EDIT > Insert Record'
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Enter specific attributes for ES3 feature such as field codes, CAD layer
Then go to 'VIEW > Feature Wizard'
Drop down to 'ES3' feature and set up the following:

Set the symbology to '2 Point Symbol (Centre)
Select symbol for Dimension 1 and enter known D1 value
Select 'Use Library Value' as this value in defined and will not change
Select 'OK'
Save Project

Perform Checks
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5

Editing A Model
When moving around the model, there are certain window controls you can use. These can be
found under the WINDOW menu, on the model toolbar, or under specific keys on the keyboard
as follows;
Esc

Quits any of the interactive editing options

Home

Zoom Extents

End

Zoom Previous

Page Up

Zoom Out

Page Down

Zoom In

Space Bar

Zoom Centre (Pan)

TAB

Pan to the next crossing breakline, next duplicate point, or next
potential model error. This option will only pan to crossing
breaklines and / or duplicate points if they are currently being
displayed. This is controlled using `View / Triangulation options'.
Other potential model errors that are detected with this option
include links between 2d and 3d points, duplicate 3d points with
different elevations, and polygons with less than three points.
This key press is very useful when correcting survey errors
interactively.

F2

Pressing this key pans to the next selected point. This option
should be used in conjunction with the data selection dialog, and
is very useful for finding specific points in the model. For
example, to find a specific point in the model, use the advanced
section of the data select dialog to highlight the point (or point
range), and press F2 to pan to that point.

s

Pressing ‘s’ toggles between the available snap lock modes,
including nearest point, nearest DTM point, nearest 2D point, gird
position, midpoint, perpendicular (to string), perpendicular
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(current string) and design grid (chainage/offset).
n

Pressing ‘n’ turns snap lock off.

g

Pressing ‘g’ enables snap to grid mode.

m

Pressing ‘m’ enables multiple point selection mode. This is useful
when selecting a point, or piece of text that overlaps other items.
If multiple point selection is enabled, and a position on screen is
selected where there are multiple overlapping points, a dialog will
be presented that allows you to select the desired point from a list
of points within a specified range from the cursor.

\

Use of ‘\’ and ‘*’ keyboard shortcuts can be used to the create text
function, as per other text editing functions. Note that when
creating new free form text, the drop down feature list in the tool
bar may be used to set the texts feature and hence colour and
CAD layer.

H or V

Pressing 'H' or 'V' will snap vertically or horizontally. The base
point used will be the last point on the string if you're already
creating a string, or the cursor position if not, so you can extend
from an existing point using snap point and then press 'H' or 'V'
for subsequent points.

O

Pressing 'O' snaps perpendicular from the last two points, or
horizontal if no points have been entered. The default behaviour
after picking a point with snap horizontal or vertical is switch to
snap perpendicular from the last two points. This can be turned
on or off in the snap points dialog.

Q

Pressing 'Q' closes the string and updates the model using the
Link Square tag. This creates a new point by intersecting a line at
right angles from the last two points selected with another line at
right angles to the first two points. Thus if you have entered three
points, pressing 'Q' will square off by creating a fourth point to
from a quadrilateral.

L

Pressing 'L' closes the string and updates the model using the
normal Link tag. Thus if you have entered three points, pressing
'L' will give you a triangle.

You can also use the mouse wheel to zoom in and out of the current position, and to pan
around the model by moving the mouse with the wheel pressed down.

Snap Controls
The snap control option available from the 'VIEW' menu has the following options:
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This dialog allows you to force the cursor to always lock onto a specific point or grid
co-ordinate while editing the model. It is particularly useful when positioning points exactly
on top of survey points, for example, when generating a boundary string.
Pressing ‘s’ on the keyboard toggles through the snap options. The current snap option is
displayed on the bottom right of the status bar.

The snap control dialog is also used in the selection of overlapping points. If you highlight
the ‘Enable search for multiple points’ option, a list of all points within the prescribed radius
is displayed whenever you have to select a point in the editing options. This is particularly
useful when querying points that overlap or join strings at the junction point of other
strings.
The snap selection may be changed in the middle of a command. For example, if adding
points the user snaps to grid and in the middle the user wishes to snap to a feature, the
snap control can be changed to ‘Nearest point’ and allow the user to continue with the
previous command, ‘adding strings with cursor’.

Pressing ‘m’ on the keyboard enables a shortcut key to ‘Enable search for multiple points’.
There are three methods of editing a model within SCC.
Point editing allows you to query a point in the model and modify any information relating
to that point.
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String editing allows you to identify string lines in the model. Field errors relating to
connectivity can be edited here.
Triangle editing allows you to identify which triangles you will use in modelling
applications.

5.1

Probable Modelling Errors
SCC graphically highlights probable modelling errors such as crossing strings and duplicate
points. Crossing strings are indicated by red crosses and by pressing the TAB key, the screen
will be re-centred over each one, allowing them to be easily located and therefore easily
resolved.
While crossing strings do not necessarily pose a problem in themselves, they are often
indicative of a survey or modelling error that could have more serious implications. For
example, where a kerb top and kerb channels are surveyed as two separate 3d strings. These
strings are very close to one another in plan, and may actually cross in a number of places.
While this makes very little difference to the plan, it has a serious effect on the 3d model as
shown in the section below.

Using the ‘move points’ option to shift the offending point by a few millimetres in plan quickly
resolves this problem, as shown in the second section drawing.
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5.2

Correcting Survey Errors
In a model the most easily recognisable survey errors are crossing breaklines. Crossing
breaklines are identified by the Breakline Intersection Point (~BRK_INT) feature. This is a
standard SCC feature. The symbol for this feature is a red X. Look around this model there a
few red Xs. When editing the model the operator should aim to remove all crossing breakline
from a model. Depending on the strings and how they overlap different editing tools may be
used to rectify the errors.

5.2.1

Control Orientation Error
On creating a SCC model, you discover that the detail enclosed at ‘A’ is not in its true position.
Surveyed features are both shifted and rotated. An error of this nature is frequently caused by
setting an incorrect reference orientation on the horizontal circle prior to observing a reference
object. Incorrect traverse observation or reduction may also cause orientation errors. Surveys
which involve combined traversing and detailing (as opposed to those in which the traverse is
reduced before the detail survey is undertaken) are particularly susceptible to orientation
problems. Establishing the cause of such errors may involve time-consuming reviews of the
traverse observations and much experimentation to uncover the offending data.

It is often possible to correct the error by editing the station set-up for the displaced area. To do
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this, choose the Query and Edit points option from the Edit menu. Click on any point in the
displaced area. Select the Instrument Set-up tab. Both occupied and reference station names
should be correctly spelt and have a valid co-ordinate, i.e. XYZ set to ‘Yes’, in order for the
orientation to be correct. If you have taken a full observation, including a distance, to the
reference station, SCC will back compute the co-ordinates of the reference station and display
the differences between those co-ordinates and the values in the station co-ordinates file. It will
also compute the difference in observed and calculated horizontal distance. If the co-ordinate
difference is large, but the distance difference is very small, you have a genuine orientation
error. If both co-ordinate and distance differences are large, you most probably have an error
in either a reference station name, or a reference station co-ordinate value. An incorrect
occupied station name, or incorrect occupied station co-ordinate value would result in a control
shift error.

5.2.2

Control Shift In Plan
A less common form of control error involves a simple shift in station co-ordinates. Such an
error occurs when, for example, one survey data set containing a particular station is loaded
into a project. If, at a later stage, you add another data set, containing a station of the same
name, but different co-ordinates, to that project then the co-ordinates of the first station will be
over-written. As a result the detail associated with the first data set will be shifted. This may
also cause orientation errors, as the same station may be used as a reference station
elsewhere. Every control station name must be unique to the current SCC project. You are
most likely to encounter duplicate station names on larger projects where several crews have
established minor stations using names, which were chosen arbitrarily. The problem of
duplicate names may also arise when more recent survey data sets are being added to older
projects.

You can reduce the risk of duplicate names by establishing a station naming convention to be
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used by all field crews. If you suspect that a survey data set is displaced as a result of a station
having incorrect co-ordinates then you can correct the problem as follows; Choose the Query
and Edit points option from the Edit menu. Use the mouse to select an element of the
displaced area. Select the Station co-ordinate tab. Type in the correct easting (or X
co-ordinate), northing (or Y co-ordinate) and level for the station. This will cause the survey
co-ordinates and model to be regenerated. If you do have two distinct stations with the same
name, it will be necessary to rename one of them. Having done this you will also have to
modify any references to this station in the associated station set-up information in the relevant
detail observations file(s).

5.2.3

Control Station Datum Error
The diagram illustrates a topographic survey covering a number of fields. The field marked ‘A’
has been surveyed entirely from station A. All the surrounding fields have been surveyed from
stations other than station A. On examining the diagram you will see that there is marked
build-up of contours around the perimeter of field ‘A’. The general plan trend of the contours,
excepting those along the boundary of field ‘A’, is correct, though the contour values will differ
significantly between the two areas. The over-all planimetric detail is also correct. The steep
shelf of contours suggests that there is an error in the reduced level of station A. An error of
this nature may occur because the level of an existing station is over-written when a survey
data set containing a station of the same name and plan co-ordinates but a different reduced
level is loaded into the current project. Such an error is most liable to occur when the control
station levels are first determined in relation to an arbitrary datum, but shifted at a later stage to,
for example, National height datum.
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To correct this error choose the Query and Edit points option from the Edit menu. Use the
mouse to select an element of the displaced area. Select the Station co-ordinate tab. Type in
the correct elevation for the station. If this causes the error to occur in a different area of the
model, ensure that all your stations are based around the same datum.

5.2.4

Surface Model Errors
Errors in the surface model may be caused by control station errors, by poor field survey
techniques, or by the wrong rod height being recorded. Incorrect elevations due to wrong rod
height are often difficult to see on the screen, particularly on rugged terrain. When examining
the surface model for errors you may find it beneficial to set a small contour interval, (e.g. 0.1
meters rather than 1.0 meters) as this will tend to highlight anomalies in the surface model.
The diagram to below shows part of a golf course survey, the area enclosed at ‘B’ is a bunker
and contains a number of surveyed points of similar elevation. In contrast, the area indicated at
‘A’ contains just a single point of significantly different elevation; this suggests a rod height
error, though of course such a suspicion can only be confirmed by knowledge of the terrain.

To correct a single point error of this nature choose the Query and Edit points option from the
Edit menu. Using the mouse select the point to be edited. Select the Detail Observation tab.
You may now remove the point from the DTM by changing the DTM switch to Approx.
Elevation. Alternatively, if you know the correct rod height you may leave the point in the DTM
but change the Rod Ht field to the appropriate value. Note: it is good field procedure to
maintain one rod height throughout a survey. If the rod height must be altered, for example, in
order to survey obscured detail then it is recommended that you increase the rod height by
even increments and return the standard rod height as soon as practicable. Using standard
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increments will often make it easier to identify any incorrect rod heights.

To model the ground surface correctly it is not sufficient to survey a high density of levels
across the terrain. It is necessary to define the shape of the ground using both spot levels and
break-lines. All three-dimensional strings are treated as break-lines (or form-lines). A
breakline must be surveyed where obvious changes of grade occur on the ground. They are
essential if the triangulation is to form correctly. The diagram depicts an example of a poorly
surveyed surface. Because the base of the spoil-heap has not been completely enclosed by a
string, severe deformation of the surface occurs in the area marked ‘A’. Note that the model
depicted in the diagram consists of the same set of observations, only the string tag code has
been edited within SCC from STRAIGHT to LINK. STRAIGHT would be looking to link up with
the next sequential point on a feature of the same name and string number, but not having
found any would terminate and leave the toe of the slope open.

Go to Edit and select Edit String Details. Select the string forming the base of the mound.
Change the Tag of the last point on the string to Link. Then select Update String in Model.
See the diagram for the results.
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We described the function of break-lines previously. The figure below and to the right
illustrates another consequence of failing to survey break-lines. A ditch or watercourse has
been surveyed using three-dimensional strings to define the tops of the banks. The bed of the
ditch has, however, been surveyed as a number of unstrung points. The resulting “Paternoster
effect” is not merely a misrepresentation, in a cartographic sense, of the shape of the ground,
but more importantly it constitutes a flawed triangulation which will cause incorrect sections and
volumes to be generated and will not permit water to flow down hill.

Go to Edit and select Edit String Details. Select any point along the base of the string, which
should be strung. Go to Global Edit and change the String No. from 0 to any positive number.
Pick a high number just in case this feature has appeared in the model in other places.
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At first glance the error illustrated in the figure below might seem similar to that shown
previously. In this instance however, the surveyor wrongly recording the pylons of an overhead
transmission line as a three-dimensional string causes the deformation of the surface.
Consequently, the overhead line is included in the triangulation. The pecked circles in figure
below left indicate the pylons supporting the power-line. This error will also be encountered in
localised areas when, for example, the tops of trees, lamp standards, or telecommunication
masts are included in the DTM.

To correct an error of this nature you could change the DTM code of the pylon feature in the
feature library. Choose the Query and Edit points option from the Edit menu. Use the mouse
select the power-line. On the Feature Library Entry tab. Go to the Digital Terrain Model field.
Change the value to Approx. Elevation. Then select the option to Use the above value. All
over-head lines will now derive their DTM status from the feature library Master DTM tag rather
than the survey file. On pressing OK the model will be regenerated and the surface will now
appear as shown below.

©2015 Atlas Computers Ltd

169

5.2.5

Determining The Height Value of Crossing Breakline
A. New Project
Select 'FILE > New Project'
Enter Project Name 'Crossing Breaklines' and attach Project Template 'Default (v6).
Project'

B. Model DXF
Select 'FILE > Model > DWG/DXF'
Using 'Pick>>' button select 'DUMP.dxf' from the SCC\Tutorials directory
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Select 'OK'
Select Initial Plot Scale of 250
Select 'Create the model and triangulation'
Select 'Ok' to Model Attributes dialog

Zoom in and then select 'WINDOW > Zoom XY' and enter 1878.360, 3275.959'

Note the drainage line running perpendicular to the top and bottom of bank. Where the
drainage lines meets the bank a crossing breakline symbol is generated. What we are
going to do is insert a point onto both strings at each point where they cross. The height of
the new points will be taken from the height of the point interpolated.
Set the snap lock to snap point by pressing the ‘s’ key. On the right of the status bar the
current snap setting is displayed.
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5.3

String Errors
Stringing errors are arguably the most common error encountered when processing
topographic surveys. The problem is especially associated with urban areas where the sheer
number of features, combined with the difficulty of gaining access to every point, militates
against even the most seasoned field crew. The diagram depicts two errors. The building BG
18 (the circled area) has had all the required points surveyed. The surveyor has, however,
failed to link the final point (No. 10) to the first (No. 1). In the second case, (enclosed by
rectangles) two separate buildings have inadvertently been allocated the same string number.

To correct the first error we simply need to establish a link between the first and the last
surveyed point. Choose the Query and Edit points option from the Edit menu. Select point
number 10 on string BG 17. Click the Detail Observations tab. Then change the Tag from
Straight to Link. In the second case, select point number 6 on string BG 16; once again select
Edit Observation for selected point. This time change the Tag from Straight to End. Re-create
the model; the model will appear as shown in the figure above. Note that because you have
used the End tag SCC incremented all those strings following BG 16. You may now close both
building outlines by using the Link tag as described above.

Alternatively, if you had a number of such links to remove, you could use the Break string links
on the ‘Model’ menu. Remember that this option operates on co-ordinate file(s) rather than
observation files. As such that all editing carried out using this option will be undone if you edit
observation data and rebuild the co-ordinate file.
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5.4

Point Editing
The 'Query and Edits points’ option from the main EDIT menu allows you to select a point of
interest for which a number of different detail tabs are displayed.

We have already mentioned the feature library tab and how it is used to set up or make
changes to the characteristics of the point. Any changes made to the library using this tab, will
present you with the option to update the project file.
The other four tabs are extracts from the survey file or SCC dataset used to create the model.
The Detail Co-ordinate and Detail Observation tabs are nearly identical. The main difference
relates to which dataset is being changed.
· If the Detail Observation tab is changed, the survey co-ordinates will be rebuilt to reflect the
change.
· If the Detail Co-ordinate tab is changed, the detail observations are not affected.
A copy of the original survey file is kept so the coordinate files may be rebuilt from raw
observations at any time you require them.
When querying a model that was created from multiple datasets, the dataset from which the
queried point originated is displayed at the top of the dialog. In this example the queried point is
taken from the ‘FGL3’ dataset.
Another item of particular interest is the Instrument Setup tab. This tab displays what station
you were set up on for the point in question and also what station was backsighted to.

©2015 Atlas Computers Ltd

173

In the Station Coordinates menu, you can determine the position of each station that was set
up upon. Sometimes the wrong station name is entered in the field, resulting in a disorientation
of part of the survey. This can be easily tracked and corrected.
Editing models with the ‘Query and Edit Points’ option will undo any local string editing carried
out on your model for the queried dataset. For this reason, it is advisable to do any query
based editing prior to carrying out interactive string editing.
As changes are made to the model using the ‘Query and Edit Points’
option the survey file will be automatically updated.

5.5

String Editing
SCC has an extensive set of string editing tools, similar to CAD tools, to interactively edit the
model. This editing always occurs simultaneously in plan and 3d. String editing tools include
trim, extend, move, copy, rotate, copy parallel, join, split, partial delete, reverse string, change
geometry, change feature, and change DTM status can all be located under the main EDIT
menu.
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All tools work both interactively and with pre-selected data, such that they can be used to carry
out a given operation on a large amount of points as a single operation. To access the ‘Data
Selection Dialog’, you must press the right mouse button once when in the model.
For example, if you wished to use the ‘Delete overlapping text’ tool in a given area, you can
used the ‘All points in a window’ option to select the chosen area. Likewise, if you wanted to
apply the command to a particular feature code, you can use the ‘Apply String/Feature Range’
to define the points.
Data selection also works with ‘Cut’, ’Copy’ and ‘Paste’ commands, allowing you to transfer
selected data between models and datasets.
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If you wished to show the string direction and point number for all points on a selected string
you would do the following;

Display String Direction & Point Numbers on a String
Press Escape to clear any active editing operation
Press the right mouse button to access the‘Data Selection Dialog’
Select ‘All points on selected string’
Select ‘Mark selected points’
Press OK
Pick the string you wish to annotate
Go to the ‘EDIT > Text > Edit Text Annotation’
Turn on ‘Display point numbers’ and ‘Display segment direction’

‘All points on selected string’ will remain the default data selection method now until you
change it, such that to similarly annotate subsequent strings you only have to go through
the last three stages.

5.6

Survey Error Detection & Correction
There are various facilities available in SCC to rectify survey errors depending on how they
were formed. Apart from red crosses, which highlight probable errors in your model, contours
also play a part in highlighting possible height errors in the model. Selecting a small contour
interval will draw your attention to any discrepancies in the survey.
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Changing The Contour Interval
Activate the window FGL.model
From the toolbar, select black arrow on the contour button

Change the Regular Contour Interval to 0.5 and the Index to 2.0.
Set the Linear contour type to ‘Quick Screen’ and the Solid Relief Contours to ‘None’.
Select ‘OK’
You should immediately be able to see if there are any height discrepancies in the model.

5.7

Using SCC Editing Facilities to Rectify Survey Errors
The following examines specific editing tools to correct survey errors in the model.

5.7.1

Delete Points & Strings
At the bottom of the model along the road there are three crossing breakline symbols. The
coordinates of this area are roughly 194152E and 374879N. If you look closely at this
area you will see that there are four short lines running in the direction of the road. It
seems that the surveyor began surveying the road with these short lines, but they were
never finished. The road was surveyed using different strings. It may have been surveyed
on a different day and/or by a different surveyor.
We want to delete the short intersecting lines. Select these lines by drawing a polygon
around them. All points along these short lines will be selected as shown in the picture
below. When the option to delete points is selected a dialog will be presented as to
whether or not you want to delete the selected points. Choose Yes.

Selecting Points By Creating A Polygon
To view the Breakline Intersection Points more easily turn off the contours.
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Zoom into an area where extra unnecessary points have been generated.
The co-ordinate of the top corner is 194140E, 374888N and the bottom right co-ordinate is
194166E, 374868N.

You will see that there are four short lines running in the direction of the road. It seems
that the surveyor began surveying the road with these short lines, but they were never
used to finish it. The road was surveyed using different strings. It may have been
surveyed on a different day and/or by a different surveyor.
Left click mouse to bring up 'Data Selection Dialog'.
Select 'Create A Polygon'
This automatically selects 'All points in selected polygon string' and 'Mark selected points'
The option can also be used to 'Clear selected points' from an area where points have
already been selected.

Draw a polygon around the four short lines by right clicking mouse to form 3 sides of the
polygon and left clicking mouse button to close the polygon. All points along these short
lines will be selected.
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Delete Points and Strings
Go to 'EDIT > Delete Points and Strings > Delete Points'
Select 'Yes' to 'Delete Selected Points'
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5.7.2

Breaking String Links
While the previous option allowed us to delete entire strings or points, we will often want to
simply break a string into two separate parts by removing an undesired connecting link.
Breaking string links may be achieved by selecting the above button or the ‘Break Strings’
option in the ‘EDIT’ > ‘Delete Points & Strings’ menu.
Zoom into the top left area to see the unwanted crossing strings.

As you move the cursor on screen you will see a thick blue line that you can align to
potentially unwanted string links. When this line lands on the correct link, press the left
mouse button and the link will be removed. Alternatively you can use the ‘Individual Points
’ options from the data selection dialog to mark the end points of the unwanted link and
then select the ‘Break Links’ option.

Breaking A String
Go to 'WINDOW > Zoom Window'
Zoom into the top of the model. There are two lines crossing.
If a segment of one of the lines were deleted, there would be no crossing breaklines.
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Go to ‘EDIT > Delete Points & Strings > Break strings’ or
Align the cursor along the string segment you wish to break and click the left mouse
button.
Place cursor over line segment.
This option inserts a gap into the string. The line tag of the point at the start of the
segment is changed to GAP.

Note:
To move to the next set of crossing breaklines hit the Tab key. SCC will retain the current
view size and move to the nearest set of crossing breaklines. This facility saves zooming
in and out of the model looking for crossing breaklines.
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5.7.3

Partial Delete
This option may be accessed from the ‘Delete Points & Strings’ option in the ‘EDIT’ menu.
‘Partial Delete’ allows any segment of a string to be deleted. It differs from the ‘Break
Links’ option in that, the segment being deleted does not have to be between two
surveyed points, it may be anywhere along the string.

Deleting Any Part Of A String
Go to ‘EDIT > Delete Points and Strings > Partial Delete’ or
Select the string you wish to delete – a blue bar appears perpendicular to the chosen string
Select a point on this string where you wish to delete from by left clicking mouse, and then
the point you wish to delete to by left clicking mouse again.

5.7.4

Annotating Strings
In the last few examples, the string errors in the model were very easy to identify, but in
many cases the error can be quite subtle and it helps to annotate the strings in order to
figure out what is going on. Panning down and to the right on the model we see another
area, where there are many crossing breaklines.

It appears to be an unwanted string link but we will do some more investigation to be sure.
Using the 'Data Selection Dialog' select the string of interest. Go to ‘EDIT’ and ‘Edit text
annotation’ and display the point numbers and segment direction.
Zoom into an area at the bottom of the model where the end of one string seems to be
joined to the beginning of another.
The co-ordinate of the top corner is 194054E, 374987N and the bottom right co-ordinate is
194178E, 374919N.
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Note: The string of interest has been highlighted in the diagram.
Left click mouse to bring up 'Data Selection Dialog'.

Select 'All points on selected string' and 'OK'
Left click on string, all points on the string are highlighted in blue nodes
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Display Point Numbers & Segment Direction
Go to ‘EDIT > Text >Edit Text Annotation’ or
Select 'Display Segment Direction' and 'Display point numbers'

Note that highlighting boxes in this dialog will turn the associated text on,
clearing boxes will turn text off, and leaving boxes grayed out will not effect
associated text at all.
Select 'OK'
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You will notice one long segment going from point number 392 to 397 over which all the
crossing breaklines lie. If this segment is deleted or removed then there will be no
crossing breaklines.
Go to 'EDIT > Edit String Details'
Left click on string, which will bring up a coordinate spreadsheet containing the
coordinates of each point.
Change Point 392 tag code from 'Straight' to 'Gap'

Select 'Update string in model'
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5.7.5

Using The String Editor
Selecting the ‘Edit String Details’ option from the ‘Edit Strings’ menu in the model view
accesses the string editor. To select a string simply press the left mouse button over any
point on the string we wish to edit. A spreadsheet containing the co-ordinate details of the
select string, is displayed.

Inserting A Gap In A String
Go to ‘EDIT > Edit Strings > Edit String Details’ or
Select the string you have just annotated
Type ‘G’ in the Tag field for observation number 378
Select Update string in model
The string editor is the most versatile of the editing tools and can be used to add and
remove points, change the direction of parts of a string, re-label a string etc. If you can’t
find another way of performing a string editing operation, you will usually be able to do it in
the string editor.
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5.7.6

Moving Points On A String
We are now going to look at a crossing breakline problem caused by two strings
overlapping. Using the ‘Move Points’ option best solves this type of problem. First go to
the area of interest.

Zooming to specific coordinates
Press 'Page Down' to zoom in quite close
Select ‘WINDOW > Zoom to X,Y position’
On the dialog, enter coordinates of 194156.253, 374916.680

Select the ‘Move Points’ option from the ‘EDIT’ menu to move the point on the dashed
string (Point 598) to the far side of the string it crosses, hence removing the overlap and
the crossing break lines.

Moving Point
Select 'EDIT > Edit Strings > Move Points' or
Left click on the dashed string (Point 598) and drag to the far side of the string it crosses,
hence removing the overlap and the crossing breaklines.
The ‘Move Points’ option should be used in conjunction with the snap controls where the
ends of two strings that meet, overlap slightly. It is better used free hand when fixing
problems such as the one above, and re-aligning tops and bottoms of kerbs for example.
Below is the result of using the ‘move points’ option.
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5.7.7

Extending Strings To Intersect
Apart from breaking string links there is often a requirement to join strings together. This
typically occurs on larger jobs where several crews may be surveying the same string,
either at different times or from different directions. This will often leave a string in many
separate sections that needs to be connected.
If we zoom back up to the area where we were using the string editor we can see a few
strings that may need to be joined up.

The ‘Join Strings’ option
may be used to join two strings together with a single line.
Alternatively the ‘Extend to Intersect’ option may be used to extend the two strings until
they meet.
The ‘Join Strings’ option will convert the two separate strings into a single string if they
both are of the same type. If they are not the same type an extra segment will be added to
the end of the first string to make it meet the second string, in this case they will remain
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separate strings.
Select the ‘Extend to Intersect’ option from the ‘Edit Strings’ sub-menu and press the left
button first on point 398 and then on point 305 to join up the outer fence string.

Extend Lines To Intersect
Go to ‘EDIT > Edit Strings > Extend To Intersect’ or
Select point 398 and then select point 305
Both lines will be extended until they intersect

5.7.8

Trim Lines
Strings may sometimes extend further than they should. If this happens use the ‘Trim’
command to trim the strings back to a cutting edge.

Trim A Line
Select ‘WINDOW > Zoom to X,Y position’
Type in the X and Y co-ordinates 193782.717 and 375066.203 respectively

Select 'Ok'
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Go to ‘EDIT > Edit Strings > Trim’ or
Pick 'TB' as the cutting string for trim – once selected, the cutting edge will turn to red
Select 'FL', as string to trim

Press 'ESC' quit this command
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5.7.9

Copying/Moving Strings
Copying or moving strings in the model, brings up the following dialog display.

Due to an error in the original survey, it may be necessary to offset a string a certain
distance, or copy a string parallel. For example, if a hedge has been offset 2.0m to the left
instead of 2.0m to the right, then, by using the above command, you can offset the hedge
string 4.0m to the correct position.

Copy A String Parallel
Select ‘EDIT > Edit String Details > Copy String Parallel’ or
Enter the horizontal distance of 2m in the relevant box and turn on the ‘Lock Horizontal
Distance’ and ‘Remove loops from new string’ options.
Using Drop Down Feature Menu select 'F' as the new feature name
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Left click on existing string and move/drag cursor in correct offset direction
Left click to place new string
Select 'Close'

A vertical offset may also be entered though the new string will assume the levels of the
original string if the box is left at 0.000. If a horizontal distance is not specified and the ‘
lock horizontal distance’ box left blank, then the string selected can be moved
automatically with the cursor and the distance is shown in the ‘horizontal distance’ display.

5.7.10 Adding Slope Lines To A Model
As well as adding text to the model, you may wish to add a feature such as a slope string,
which indicates the slope of a selected area and the direction in which it is falling. Slope
strings can be added using two methods:
· Slope lines between strings or
· Slope lines using reference string
The first method allows you to pick two strings and generates the slope lines between the
two from the lowest to the highest.
The second method is more likely to be used when the two strings are more curved or
jagged and in this case, the first method will not work. To add the slope strings between
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strings of this nature, you need to add a reference string first. When the reference string
has been added, the slope string can be drawn, by selecting, in order, the first string, the
second string and finally the new reference string.

Add Slope Strings Using A Reference String
Add the reference string by selecting the
to update the string in the model.

icon from the toolbar. Select the

icon

Select ‘EDIT > Slope Lines & Hatching > Slope lines using reference string’
A blue cross will appear at the end of the cursor.
Select the First String and then second string by left clicking mouse on each respectively
Select the reference string
Enter in your own values

OR
Accept the defaults
Select ‘OK’

5.7.11 Adding Hatching To A Model
SCC also gives you the option to add hatching to a model. The two options available are:
· ‘Hatch a polygon’ assumes a closed link between the first and last points on the string
regardless of whether it is displayed in the model.
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· ‘Hatch between strings’ will hatch between any two strings selected by the user. The
strings must be selected prior to using this option. This can be done using the ‘Data
Selection Dialog’.

Hatch A Polygon
Go to ‘EDIT > Slope lines & Hatching > Hatch a polygon’
Left click mouse on polygon you wish to hatch

Enter in the values for angle and spacing and select whether you want simple or cross
hatching displayed.
Select ‘OK’

5.8

Editing Pre-selected Data
Using the data selection dialog allows various methods of point and string selection. If points
have been pre-selected and then an editing option chosen, you will be asked if you wish to
perform this task on the selected points.
The following editing options may be used with pre-selected:
§ Move points
§ Delete points and strings
§ Break Strings
§ Unlock Text
§ 3Pts Arc
§ Fillet Arc
§ Arc 2Pts + Radius
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§ Arc 2Pts + Tangent
§ 2Pts Circle
§ 3Pts Circle
§ Circle, Radius + Arc
§ 2Pt Rectangle
§ 3Pts Rectangle

Creating A 3Pts Arc From Pre-selected Data
Open the FGL model
Zoom into the south east of the model as shown in the diagram below
Click the right mouse button to access the 'Data Selection Dialog'
Set the selection method to ‘Individual Points’
Select OK
Select the points shown below

Go to the Circles, Arcs and Rectangles toolbar
Set the Change Radius/Width to 0.1
Select the third icon – Arc 3Pts
Select 'Yes' to ‘Convert selected points’
The result should look as below.
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5.8.1

Surveying Circular and Curved Objects
The following examines tag codes (Curve, Arc Fit & Circle Fit) assigned to man made circular
structure.
One must considers that circular object on site have been designed with a specific defined
radius. As the radius is unknown the surveyor must implement geometry tag codes between
survey points to best represent the structure on the ground.
It is important to note that curve fitting in plan is merely a plan fit in 3D and therefore not
recommended for man made structures on an incline/decline i.e. sloping ground.
In conclusion, circle fit is shown to give the best representation of man made object.

Curve / Curve Fitting Within SCC:
Extra curve points are generated in between surveyed curve points. The type of curves
used is 'Splines under tension'. Curve generation parameters may be further defined by
tension and point density parameters. Points used to define curves should be surveyed at
even intervals apart. The number of points required for accurate delineation of a curve
depends on the accuracy requirements. As a guide on tight curves on road belmouths,
points for engineering accuracy requirements may be as close as 1 -2 meters - very tight
curves on traffic islands may be at 0.1 to 0.2 meters centres depending on the tightness of
the curve - main highway curves may be as far apart as 10 to 20 meter centres depending
again on requirements.

Curve Type
The following curve-fitting algorithm can be assigned;

Default
The curve fitting settings will be the default one found in the coordinate reduction options
dialog.

Catmull-Rom (Tight)
A Catmull-Rom curve will be fit through the survey points. This curve type stays very
close to the survey line and has user definable tension and tangent weights.
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Tspline (Circular)
A trigonometric spline curve will be fit through the survey points. This curve is suitable for
more circular features that are not true circles. A T-Spline curve through an equilateral
triangle will result in a circle. When collecting points on this type of curve, it helps if they
are reasonably evenly spaced. Failure to do so may result in a curve that billows away
from the surveyed line.

Circle fit
This option creates a best fit circle through all the points on the surveyed polgon. It is
usefull when dealing with circular tanks, small roundabouts, and other man-made circular
features.

Curve point density
This is the ratio of curve fit points to surveyed points. For example, a value of 10 would
result in ten extra 3d curve fit points being generated for every survey point.

Curve tension
This applies to Catmull-Rom curves only, and defines the closeness of the surveyed line
to the curve. The default value of 0.5 rarley needs to be changed. A value of 0 results in
a straight line. A value of greater than 0.5 allows the curve to billow further from the line,
(i.e. it loosens the curve).

Curve tangent weight
This applies to Catmull-Rom curves only, and defines the effect of the incoming and
outgoing tangents on the curve. The default value of 1.0 rarely needs to be modified.

Coordinate Reduction Option
The Coordinate Reduction option allows the user to edit configurable parameters relevant
to the generation of the detail co-ordinate information. These parameters are used when
creating detail co-ordinates from the detail observation spread sheet.
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Feature Library
Also specific settings may be assigned to individual features within the Feature Library –
Feature Wizard as shown below:

Case Study:
Consider the Man Made Object with a defined radius denoted in each scenario in red.
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Ten survey points have been pick up in the field.

Scenario 1:

Curve ‘C’ Tag Code

In the field, the surveyor has pick up 10 points and assigned the relevant ‘C’ tag code to
each. Extra curve points are generated in between surveyed curve points.

Note the influence of the point spacing in area A and B. In area C, points have been
surveyed closer together and as a result the curve is a better representation of what is on
the ground.

Scenario 2:

Arc Fit Tag Code

An Arc Fit Tag Code assigns a best-fit circular arc to the surveyed points.
When more than 3 points are used to generate the arc, the additional points are used only
to influence the arc. That is, the arc will not intersect or pass through all points, as shown
below:
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The position and spacing of survey points is important.

Scenario 3:

Circle Fit Tag Code

This option creates a best-fit circle. It is useful when dealing with circular tanks, small
roundabouts, and other man-made circular features.
Like Arc fit, not all survey points are intersected but rather influence the position of the
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circle.

When generating a circle fit use the snap point command to pick up each survey point.
As shown below, the circle fit is the best representation of the man made object.

Note:
Additional Tag Codes have been added to the tag code drop down menu and also the ‘
EDIT > Circles, Arcs, & Rectangles…’
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6

Generation Of Boundaries
Boundaries are important for volume calculations. If the surface used in volume calculation is
not clearly defined the result of the volume calculation will be ambiguous. If a boundary has not
been surveyed in the field for whatever reason, one must be generated in SCC.
We have already discussed how to use the ‘Add/Remove Triangles’ option to create a
boundary in the model.
Here we will describe how to use the ‘Add String With Cursor’ option to generate a new string in
your model. If your model already contains strings that may form part of the surface boundary,
they may be used to generate the new boundary. The most common way to generate boundary
strings is to select the outmost surveyed points in the model. It is important therefore that the
snap control is set to nearest point.

Adding A New String To The Model
It is possible to add strings to a model using the Add Strings toolbar.

Using the field boxes above, set the feature code to ‘boundary’ and the tag code to ‘
straight. The DTM code is set to ‘clip polygon’ because we wish to use this string as a
boundary where all contours and triangles outside of the polygon are clipped out of the
DTM.
Select the ‘polygon’ button,
to start adding points to your polygon. Click the left
mouse button once for each point you wish to add, and click the ‘Update String In Model’
button

to complete the process.

Pressing the right mouse button while adding points to the model provides you with a
sub-menu containing options for setting specific information about the string being
created. These options can also be found on the relevant toolbar.

A very useful technique on this menu is the option to ‘Save Co-ordinates As Dataset’. This
allows the new boundary co-ordinates that you have created to be saved as a separate
dataset that can then be used as a boundary for multiple sub-surfaces.

Creating A Boundary String
On the 'Add Strings'toolbar, enter the feature code BNDRY in the feature box, set the tag
code to ‘Straight’ in the tag code box and the DTM code to ‘Clip Polygon’ in the DTM
status box.
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Go to ‘EDIT > Add String with Cursor’
Click the right mouse button on the model
On the secondary menu go to ‘New > Polygon’
Press ‘s’ on the keyboard to turn the snap to ‘3D point’
Select the first point on the string
Go around the model clicking on the outer most surveyed points
When you come to the second last point click the right mouse button and select ‘Update
String In Model’.
Note that when creating boundary strings we should either have the snap controls set to ‘S
nap to Existing DTM points’, or ensure that valid contouring exists inside the entire
polygon. We do not have to enter elevations for points on the boundary string as these
are automatically interpolated from the DTM surface.
The other buttons on the toolbar allow for creation of point strings, open and closed line
strings and open and closed curves. If you are introducing a mixture of curves, gaps and
other geometry into a single string, you can change the Tag code field for specific points
by changing the code in the box.

String Editing Using The List Boxes

This option is used in conjunction with the ‘Add Strings from cursor’ command and works
very similar to ‘Edit String Details’.
By selecting the relevant code from the list and entering it in the box, any new string that is
drawn in the model using the ‘Add Strings From Cursor’ option, will have this new status.
This option also allows you to edit the status of a pre-selected string. By using the ‘Data
Selection Dialog' (right mouse button) and highlighting the string that you wish to change,
you can then enter the new code in the DTM box and SCC will ask you whether you wish
to convert all selected points to the new status.

6.1

Additional Samples of Creating A Boundary String
There are several ways of creating a boundary string within SCC. The following methods are
often used
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Creating A Boundary String Using Add/Remove Triangulation Options
The 'Add/ Remove Triangles' option can be used to create a boundary string.
The 'Add/ Remove Triangles' option allows the user to turn on and off given triangles in
the triangulation. Triangles that are turned off (passive/sterile, are indicated by being filled
in blue) will not be used when computing volumes, contours, grids, sections, viewsheds
etc.
Selecting this option highlights all valid and invalid triangles (valid are highlighted in
green). Selecting this option presents the Add and Remove Dialog.
When the required triangles have been removed, the user is presented with the option to
'Store boundary as a string'. If 'yes' is selected a boundary string '~BNDRY' is created
around all valid triangles.
Select ' EDIT > Add/ Remove Triangles'

Creating A Boundary String Using 'Clip Polygon' status
Set up Project
Open a ‘New Project’ and attach the ‘Default(v6).Project’ template.
Call the project ‘Boundary’.
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Model Data
Go to ‘File > Model > MX GENIO file’.
Select the file ‘GROUND.CRD’ from the TUTORIALS directory
Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely
and GENIO L-string processing to ‘Treat as points’.

Select 'OK'

Set the Initial Plot Scale as '200'
Select 'Create the model and triangulation'

Go to ‘File > Save’
Save the model as ‘Ground.Model’
There are existing strings along the top and bottom of the model, which define two
sections of the boundary.
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Go to View and Snap Control . Set the snap locks to 'Nearest DTM Point'.

Alternatively, press 's' on the keyboard until 'Snap 3D Point' appears on the bottom left
toolbar

Go to 'EDIT > Add new String with Cursor .
Set the String / Feature name to be BOUNDARY.
Also on this toolbar set the DTM status to 'Clip Polygon'
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Start at the top left hand corner of the model. (point a)
Snap to the survey points along the edge of the model (points b, c and d, for instance) until
the next point you wish to select is on the existing string in the model (point e).
Right click mouse and select 'Add data from an existing string'
Left click on string (point e)
And left click again (point e) to select first point on string
Turn 'Snap 3D Point' off to 'Snap Off'
Move cursor to the end of the string (point f)
Now turn 'Snap 3D Point' on
Left click on mouse to select last point on string
Continue to add points to string with the cursor (points g, h, and i)
To add the top string, right click mouse and select 'Add data from an existing string'
Left click on string (point k)
And left click again (point k) to select first point on string
Turn 'Snap 3D Point' off to 'Snap Off'
Move cursor to the end of the string (point f)
Now turn 'Snap 3D Point' on
Left click on mouse to select last point on string
When all points on the string have been selected, right click the mouse button and select
Close String with Link.
Click the right mouse button again and select Update string in model. The will appear as it
is below
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7

Import & Export From Model
SCC includes a wide range of methods for communicating with other software packages and
survey devices. These comprise of general purpose data exchange methods and functions
that are specifically for communication with a given package. The general purpose methods
include cut & paste, full OLE (object linking and embedding) client, server and automation
support and user defined ASCII import and export. The cut and paste routines support cut and
paste in text format, Microsoft Excel and Access format, bitmap format, OLE object format, and
internal SCC coordinate exchange format. This means that cut and paste can be freely used
both internally within SCC and to transfer information between most other Windows software.
The specific functions include highly configurable bi-directional CAD and MX/MX interfaces.

7.1

Importing Additional Model Data
There may be instances where you have recorded a survey, downloaded it into SCC, created
and edited the model and then you are required to take more survey information. To add this
extra survey information to your existing model, you will need to download the new survey into
SCC, using the original project file, save this file as a dataset (survey file) and add it to the
existing model. The ‘Add Strings from File’ option, under the ‘TOOLS’ menu allows you to do
this.
Data can be added to the model from files other than SCC datasets. SCC is capable of
accepting additional information from DXF files, ASCII files and MX (Moss) Genio files.
Create a model using the existing survey files, FGL1, FGL2 and FGL3 and then add the Survey
file FGL4 to the model.

Adding More Survey Information to an Existing Model
Go to ‘FILE > Model > SCC Datasets’
Highlight the files, ‘FGL1.Survey’, ‘FGL2.Survey’ & ‘FGL3.Survey’.
Select ‘Create the model and Triangulation’ as before
Select OK
Save the model as ‘FGL123.model’
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Go to ‘TOOLS > Add Strings from File > SCC datasets’
Highlight the file ‘FGL4.survey’
Select Open
Select ‘Normal Topographic Data’
Select OK
Selecting ‘Normal Topographic Data’ means that SCC uses the elevation/height detail
from the SCC dataset you are adding. If you select ‘2D boundary strings’, SCC will drape
the X and Y co-ordinates on to the model and add the elevation/height information from
the existing ground surface. This is more commonly selected when adding boundary
strings.

7.2

Export Data from SCC to CAD
The CAD interface supports a wide variety of CAD packages, and where the CAD system is
available on the same computer as SCC, SCC will automatically run the model into CAD. The
CAD export also includes user definable colour matching for Microstation, and nearest colour
palette mapping where relief mapping is in use. Note the Microstation DGN output supports
alpha-numeric layer names.

The key thing to remember in exporting model data to CAD is 'what you see on screen is what
will be transferred'. That includes grids, text contours and triangles, etc.The feature library is
used to control MX labelling and CAD layering such that it is entirely independent of the field
coding in use.
SCC will create AutoCAD line styles and text styles to match the SCC drawing with the
minimum number of entities. Note that when exporting in 3d, all polylines will appear as
continuous lines. This is a restriction in AutoCAD rather than SCC.

Export Model To Cad Drawing
Go to ‘FILE > Export Model > Cad drawing’
Enter in a file name, this name should be no longer than 8 characters and contain no
spaces
Select ‘Advanced Options’
Select the host Cad system you are using
Select whether you want 2D or 3D information and other required settings
Select ‘OK’
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Direct links (within General Options) may be created from SCC to Windows based CAD
systems such as AutoCAD 2006.

7.2.1

Using SCC Text Styles with AutoCAD
SCC version 6.7.6 and above allow the translation of TrueType font styles from SCC into
AutoCAD via DXF in the Text Styles table. When dealing with TrueType fonts, one of the
primary things to observe is the difference between fixed width fonts, such as Courier, and
variable width fonts, which include most other supported fonts. With fixed width fonts, the width
of a piece of text is determined by the text width multiplied by the number of characters. With
variable width fonts, the text width, the exact characters used, and the font characteristics
determine the width of the text. This potentially can lead to huge variations in overall text width,
caused by changing fonts, without changing the specified width of a piece of text.
SCC minimizes the effect of this phenomenon, by calculating the average width of the most
commonly encountered characters in the current font, and using this as a scaling factor when
outputting text. Thus the string 0123456789.-+ at a given text size will occupy a very similar
bounding rectangle for most fonts. This is shown in the ‘Text.Model’ found in the tutorials
directory. It is important that the extents of pieces of text can be easily calculated in SCC, as
they are used by a number of modules, such as the automatic deletion of overwriting text.
AutoCAD does not attempt to correct the text width based on the characteristics of the font
used. Thus changing a piece of text from a ‘Courier’ or monospaced font, to a variable width
font, will have a very dramatic effect on its width. While this is not a problem in itself, it can lead
to output differences when plotting from SCC and CAD.
The solution to this, implemented in SCC 6.7.6, is to scale the text, using the font
characteristics prior to going into CAD. While there are still some differences between the
SCC and AutoCAD text, they are greatly reduced by doing this. See ‘Text.DWG’, also in the
tutorials directory, for an example of this. The only potential pitfall in CAD, is that changing the
style of the text will again change the width. As this already occurs in CAD it is not considered
to be a major problem.

7.3

Export Data from SCC to MX
The MX Interface
The MX interface includes support for transfer of model, section, alignment and drawing
data, using GENIO and other MX formats. Output of model data can be in 3d or 4d,
where the fourth dimension is the survey point number, and includes support for non-DTM
3d data such as invert levels and overhead features. The ‘Export to Moss’ option can be
located under the ‘FILE > Export Model’ menu.

Export Model To Moss Model
Go to ‘FILE > Export Model > MX (Moss) Model’
Enter in a file name
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Select the options 'Do not output any DRAW information', 'Export non-DTM elevations as
null levels (-999) and 'Collate point strings'
Select ‘OK’
The input file will be saved in your current working directory

MX String Labelling
The feature library controls the conversion of SCC survey data sets into MX models. Part of
this process is the automatic allocation of MX string labels. This may be either totally
automatic, or where required, full MX string labels may be coded in field.
In the feature library, the 'LBL' field is used to determine the label of any MX string generated
for a given feature. For example, if coniferous tree is coded as TCONIF, the 'LBL' field might
have a value of 'TC', hence point strings for this feature would be labelled PTC0 to PTCZ, and
line strings coded TC00 to TCZZ.
In MX SURVEY based data collectors, the surveyor may code strings with a full four character
MX string label. If the initial characters of the string label agree with the 'LBL' field of the
matching feature in the feature library, the surveyed string label will be carried through. For
example, say the centre line of the road being surveyed is given a feature name of CL05. SCC
is set up to use the nearest matching feature in the feature library, which in this case might be
CL. The feature CL also has CL set in its 'LBL' field, thus the feature name CL05 will be
created as string CL05 in the MX model. If a MX SURVEY file contains a feature of less than
four characters in length this is treated the same as any other feature, in MX this is referred to
as a partial string label.
The characters M (Master alignment string) or G (Geometry string) should be avoided as the
first character in the 'LBL' field as they denote strings of special significance in MX.

See Also
Developing SCC Feature Library for use with MX

7.4

Extracting An Elevation From A Model
Often models, while primarily plan drawings, will contain one or more elevations, which we wish
to extract into separate models. SCC provides a tool to do this, in ‘Tools > Extract Elevation’.
To try this out, we will first open the model ‘Tutorials\Bridge.Model’.

Extract Elevation
Open 'Bridge.Model' from \SCC\Tutorials' directory
Right Click the mouse ‘Data Selection Dialog’
Select ‘Create Polygon’

Draw a Polygon around the points that are to be included in the elevation using the left
mouse button and click the right mouse button to close the polygon
From the Main Menu Bar, Select ‘TOOLS > Extract Elevation’
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Using ‘Snap Controls’ draw a line selecting the first and last points.

This line defines the base plan. The data is projected onto this base plan.

The coordinate system for the elevation model uses X, and Y to represent
chainage and height resepctively, thus differences in Y in this model
represent differences in height

7.5

Viewpoint
The following exercise demonstrates the use of Viewports within SCC. The sample model
'Bridge.Model' is available within the SCC tutorials directory.

Sample Model
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Open 'Bridge.Model' from \SCC\Tutorials' directory

Elevation through two points
Within the model, select 'VIEW > Rotate Viewpoint'
Select 'Pick>>' button to define rotation origin and left click on model
Use Axis angle buttons 'XY', 'XZ' and 'YZ' to achieve required viewpoint

Saved view point
By selecting 'Save' button specific viewpoints can be save and then selected at a later stage
from the 'Saved Viewpoint' drop down menu

Plan
To revert to Plan, pick 'Plan' button

Rotate Viewpoint
Two point elevations can also be achieved
Select 'Two point elevation', within the model left click the mouse to define first point of
the baseline and left click once again to define last point on baseline
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See samples below:

8

Typical QA Procedures for Survey Models
Before delivering the model you should check the following:
There are no crossing breaklines. Crossing breaklines are identified in SCC as a red cross, and
indicate that the elevation at that point in the model is either incorrect or ambiguous. They
typically highlight string linkage errors, inaccurate surveying, or string naming and hence DTM
coding errors.
· Strings representing single continuous features on the ground should consist of a single
continuous string in the model. This can be checked using the ‘All points on string’ option
with the 'Data Selection' dialog and picking any point on the string. If the string is continuous
all points on it will have a selection highlight. For example, if the survey contains a road
centerline, that centerline should be a single string, such that you can use it to generate long
sections and cross sections for the length of the road. The same is true of boundary strings
and other closed strings, where the software is dependent on the polygonal nature of the
string for certain calculations.
· Strings should not contain two or more consecutive gaps. While SCC allows this, if exporting
your model to MX, this will cause the GENIO file generated to fail in MX. This can be
checked using the ‘Report String Details’ under the ‘TOOLS’ menu and checking the right
hand side of the report for consecutive gaps. These gaps can be removed either using the
string editor or the ‘Delete points’ option.
· Strings should not contain more than one closing link. Such errors will automatically be fixed
by SCC and noted in the log file.
· Strings with less than 3 points should not contain a closing link. Such errors will automatically
be fixed by SCC and noted in the log file.
· Point strings should not contain gaps or closing links. Such errors will automatically be fixed
by SCC and noted in the log file.
· Strings, particularly road strings, should not contain duplicate points or double back on
themselves. An example of what this looks like and how to rectify it is shown in the section on
point deletion.
· Gaps should not be used to break up separate strings. It is a common survey mistake to end
each string with a gap such that the same string label can be re-used. SCC provides an END
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tag for this purpose. Using a gap means that many options such as copying and offsetting
the string will not work correctly, as the option will be applied to too many points. It also
means that if such a string is closed with a link, the link will probably join back the wrong
point. Gaps, and MX DISC codes, should only be used to represent a gap in a given string
that corresponds to an actual gap on the ground, for example a gap in a fence for a gate, or
a gap in a major road for a junction with a minor road.
· String editing can be the most time consuming part of model editing. It can generally be
minimized by good field practice.

Checking The Accuracy Of The DTM
Checking the accuracy of the DTM is usually very simple and involves checking there are no
spurious elevations in the model and no features that have been included in the DTM that are
not part of the ground surface. Checking for spurious elevations is achieved by looking for
obvious anomalies in the contours. The relief contours tend to highlight such problems.
Generally, if a single point or a single point on a string causes a significant change in the
contours, shown as a series of circular contours around that point, the point is suspect and
should be investigated further.
It is good survey practice to survey in strings rather than discrete points. While discrete points
can be used to adequately describe smooth and reasonably flat surfaces, they are unsuitable
for describing irregular surfaces containing significant grade changes such as embankments,
spoil heaps, pits & hollows, etc. Strings are used as breaklines and as such, constrain the
triangulation around irregular areas, the net effect of not using strings where they are required
is that embankments, pit edges, etc. may appear to spill. Note that the only difference in
survey procedure is to enter a unique non-zero string number for any string being surveyed.
Not providing strings where they are required can often lead to serious volumetric errors.
Another method, applicable to road and similar surveys, is to take a series of cross sections
down the center of the road and check for anomalies on the sections.
Where high accuracy is required and must be proven, the usual method is to abstract either a
grid or sections from the model, get an independent crew to stake them out on the ground and
compare elevations using a level. This is a time consuming job and would normally only be
required where elevation accuracy is of primary importance.

QA Tools in SCC
In order to speed up the process of QA checking in a model, SCC provides an extensive range
of tools to rapidly identify and correct all of the potential modelling problems outlined. Please
read the topics listed below for details on these tools.

See Also
Resolve Crossing Breaklines (Model Tools Menu)
Join Adjacent Strings (Any Feature) (Model Tools Menu)
Join Adjacent Strings (Same Feature)(Model Tools Menu)
Set Preferred String Direction (Model Tools Menu)
Search for Orphan Points (Model Tools Menu)
Report Intersecting Strings (Model Tools Menu)

9

Volumetric Analysis & QA
Overview of Different Methods of Volumetric Analysis
In SCC there are 3 methods by which volumes may be calculated.
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1. Cross Sectional End Areas method
2. Prismoidal / Isopachyte method
3. Grid method
All three methods of volume calculation should be performed when calculating volumes, as
each method is mathematically independent of the other and hence each provides a check on
the other. Differences of more than one or two percent indicate possible errors.
When calculating volumes it is important that there is a common boundary between the two
surfaces, defining a common plan area over which volumes will be measured. Accurate
volumes can usually not be calculated between two surfaces where a common boundary is not
defined, due to the ambiguous nature of the area over which the measurement is taken. Poor
boundary definitions are probably the most common cause of gross error in volume
calculations.

9.1

Creating Profiles & Sections
Before volumes are calculated we will take a brief look at creating profiles and sections.

Profiles
Profiles can be taken through any number of models, using existing strings or selecting
points with the cursor. In either case, a SCC section file will be created containing the
profile information.

With A Cursor
To create a profile with the cursor, using the left mouse button, simply select points on the
model where you want the profile to run. When you are finished with the profile and are
ready to view the section, click your right mouse button. Your profile will be displayed and
can be saved as a ‘.Section’ file. If you wish, you can continue adding points to the profile
by using the left mouse button again.

Using Existing Strings
Select ‘Long Section From Existing String’, and then in the model, select any point on the
string you wish to generate a long section from. Again, your profile will be displayed
automatically and can be saved appropriately.

From Coordinate Data
This option allows you to use the X, Y co-ordinates of another file to define the plan path
of the profile. The elevations will be derived from your current model. The data can come
in many formats, datasets, DXF and ASCII being the most common.

Cross Sections
From Existing String
For this option you will be asked to provide the left and right offset distances. You can
choose to have sections taken at regular intervals, at the survey points, or both.

From Coordinate Data
This option is used where you have previously created a long section using one of the
profile options under the ‘SECTION’ menu. After choosing this option you will select the
file to generate the cross sections from and then proceed as using an existing string
above.
To get some experience with sections, open the example project and the FGL model.
Create a profile along the center of the length of this model and save the section file as ‘
FGL long.Section’.
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Opening An Existing Model
Open the Project Example.project
Go to ‘FILE > Open’
Change the Files of Type to SCC Models (*.Model)
Select the model 'FGL.Model'
After opening the Example project and the FGL model:

Creating A Profile
From The Main Menu Bar, select ‘SECTIONS > Long sections with cursor’
Select three or four points with the left mouse button following the center of the FGL
model
When finished, click the right mouse button
View the profile
Select ‘FILE > Save As’ and call the file' FGL long.Section'
Go to ‘FILE > Close’

Now let’s create the cross sections

Creating Cross Sections
Select ‘SECTIONS > Cross-sections from an existing string’
Set the Chainage Interval to 10
Set Offsets to 100 (should go beyond required area)
Leave the option to ‘Add Sections at Regular Interval’ on
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Select OK
Left click on road center line string
View the cross sections

Select ‘FILE > Save As’ and save as FGL Cross.Section
Have the file FGL cross.section file open:
Adding a Second Surface to the Sections
Select ‘EDIT > Append Surfaces’
Select OGL.Model from tutorials directory
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Data from the OGL surface is now added to the FGL sections. This only occurs where the
two models overlap.
When displaying sections in SCC it is important to select a datum that is
lower or equal to the lowest point of any of the models being analysed.

9.2

Calculation Of Volumes Using Different Methods
Using the models FGL and OGL we will calculate volumes using prismoidal, grid and cross
sectional methods. Both these models have been previously created. However no boundary
has been defined on either model. We will define a boundary on the smaller model, OGL. This
model already contains a boundary string, probably surveyed in the field, however the DTM
extends beyond this string (look at the contours). We need to change the DTM status of this
string to 'Clip Polygon', which means that no information outside this line will be included in the
DTM.
Changing the DTM status of an existing string can be done in two ways, by using the string
editor (that is, ‘EDIT > Edit String Details’) or using the list boxes on the ‘Add strings with cursor
’ menu bar. The method below describes the latter.

Creating A Boundary From An Existing String
Open the model OGL
Click on the right mouse button to bring up the ‘Data Selection Dialog’
Select ‘All points on selected string’
Press OK
In the model, select a point on the outermost string (the boundary string)
Once it has been highlighted, go to the list boxes on the ‘Add Strings’ toolbar and change
the code in the DTM status box to ‘Clip Polygon’.
You will be asked ‘Do you wish to convert all points to Clip polygon’, press OK
Save the model

9.3

Average End Area Method
To calculate volumes using this method, you must first create sections that contain all the
surfaces being considered. The reference string can be an existing string or a profile you
created using the ‘Long Section with Cursor’ option. In either case, the following procedure is
the same.
1. Create section set
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2. Append surface of additional models
3. Calculate volumes between surfaces of interest
Having the model FGL active:

Opening Existing Edited Models from Tutorials
Select 'FILE > Open'
Select 'FGL.Model'
Repeating the same steps, select 'FILE > Open' and select 'OGL.Model'
Both models have been triangulated correctly and the relevant boundaries formed prior to
calculating volumes.

Generation of Cross Sections
Within 'FGL.Model', select ‘SECTIONS > Cross Sections From An Existing String’
Set the Chainage Interval to 10
Set Offsets to 100 (should go beyond required area)
Leave the option to ‘add sections at regular interval’ on

Select OK
Left click on the road center line
View the cross sections

Select ‘Save’ and save as FGL cross.section
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Append Surface
Within the Section File, select 'EDIT > Append Surface'
Select 'OGL.Model

End Area Volumes
Select 'EDIT > Volumes'
Select Existing Surface and Proposed Surface
Select to 'Annotate Volumes' and to 'Highlight cut and fill'

Examine report and results

9.3.1

Exporting User Defined ASCII file From Sections
The following examines the exporting of a user-defined file from a Section file.
Case 1 considers the export of a *.txt file containing Chainage, Offset, X, Y, Z, Feature of all
ground points within the Section File.
Whilst, case 2 outlines the creation of a *.txt file of Chainage, X, Y, Z, Feature of all annotated
points:

Section File
Open Project File
Open Section File
In this instance, Cross Section have been generated along a string at Chainage Intervals
of 10.00m .
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Case 1:

Output Ground Points

The User is required to output a *.txt file of Chainage, Offset, X, Y, Z, Feature of all ground
points:
Annotation Settings:
Go to ‘EDIT > Annotation Settings’
Assign the following
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Exporting User Defined File
Within the Section File, select ‘FILE > Export Sections > User Defined ASCII File’

Select ‘Section Details’ and place cursor in the box below
Select required ‘Field’ from drop down menu with the ‘Add Field to Macros’
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For example, ‘Chainage’ and select ‘ADD’
Manually enter a comma ‘,’ between each macro field added to construct a csv file

Enter a Format Name within Field Details ‘Section_Test’ and select ‘Save’
This saves the format to allow the user to output other files using same Section Details.
The Format should be available from the drop down ‘Format’ Menu in future.
Enter ‘Output File’. ‘Ch0-1100.txt’
Select ‘OK’
Select 'No' to 'Output surface intersection points only'

Extract of File Shown below:
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
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-100.000,
-99.014,
-98.382,
-94.799,
-93.068,
-81.994,
-73.145,
-67.501,
-61.539,
-52.869,
-46.577,
-33.948,
-27.429,

193692.647,
193691.675,
193691.051,
193687.517,
193685.810,
193674.888,
193666.159,
193660.592,
193654.711,
193646.160,
193639.954,
193627.497,
193621.067,

375479.004,
375479.167,
375479.271,
375479.861,
375480.146,
375481.970,
375483.428,
375484.358,
375485.340,
375486.768,
375487.805,
375489.885,
375490.959,

19.584,0
19.552,0
19.522,0
19.380,0
19.296,FL
18.813,0
18.057,0
17.606,0
16.907,FL
16.667,0
16.385,0
16.033,0
15.902,0
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0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
10.000,
10.000,
10.000,
10.000,
10.000,
10.000,
10.000,

-17.478,
-14.144,
-12.891,
-9.593,
-4.925,
-1.074,
0.000,
1.135,
4.983,
-100.000,
-92.998,
-89.331,
-88.681,
-84.014,
-79.447,
-72.407,

193611.253,
193607.964,
193606.728,
193603.475,
193598.872,
193595.073,
193594.013,
193592.894,
193589.099,
193691.000,
193684.094,
193680.476,
193679.835,
193675.231,
193670.727,
193663.782,

375492.598,
375493.147,
375493.354,
375493.897,
375494.666,
375495.300,
375495.477,
375495.664,
375496.298,
375469.177,
375470.328,
375470.931,
375471.037,
375471.805,
375472.555,
375473.713,

15.818,0
15.970,0
16.100,0
16.260,0
16.394,RL
16.517,0
16.543,RL
16.521,0
16.471,RL
20.680,0
20.342,0
20.131,0
20.087,0
19.833,0
19.502,FL
18.940,0

Note:
The user defined output from the Section Screen, is unaffected by the Annotations
Settings.
For instance, if the user turns all descenders off as shown below and outputs using ‘
SectionTest.SCCOutput’ the *.txt file will remain the same.

Case 2:

Output Surface Points/Annotated Points

The user is required to output a *.txt file of Chainage, X, Y, Z, Feature of all annotated
points:

Annotation Settings:
Go to ‘EDIT > Annotation Settings’
Assign the following
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Exporting Dataset
Within the Section File, select ‘FILE > Export Sections > SCC Dataset’

Select ‘Export all annotated points’
Select ‘OK’
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Exporting User Defined File
Within the Dataset File, select ‘FILE > Export > User Defined ASCII File’
Select ‘SectionTest.SCCOutput’ Format previously created
Enter output file name ‘Ch0-1070_AnnotationPoints.txt

9.4

Prismoidal Method
The first and most accurate method of computing volumes is the Prismodial projection method.
This method involves the creation of an isopachyte or thickness model from the two surfaces
under consideration. This is achieved by calculating differences in elevation from all surveyed
points, and along all surveyed strings, in both models, and triangulating the result. Once the
isopachyte model has been formed, prismoidal volumes are calculated by adding the volume of
each triangular prism generated by projecting the isopachyte triangle to a datum of zero. Note
that individual triangular prisms may contain both cut and fill with this type of measurement.
The volume calculation report generated from the volume computation shows us the plan and
surface areas under consideration as well as the total cut and fill volumes. It also gives us
average material depth and calculates the effect of survey elevation accuracy on the volume.
To calculate prismoidal volumes you must have a model window active.

Calculating Prismoidal Volumes
Select ‘VOLUMES > Volumes between surfaces (prismoidal)’
Fill in the dialog box with the existing surface and the proposed surface
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Since SCC provides the default name of VOLUMES.REP to all volume
reports, you may want to use a specific file name to avoid having the data
overwritten
Select 'OK'

Isopachyte Surface Model
Select 'Create the model and triangulation' and set the Inital Plot Scale as 200

Select 'OK' to the Model Attributes Dialog
Examine Report
Once we have created an isopachyte model, we can colour it according to depth of material
and calculate material volumes by depth. Note that this is using an end areas method based on
horizontal sections whose accuracy is dependent on the vertical interval.

9.5

Grid Method
This option is similar to the prismoidal method, except that the volumes are derived from a
regular grid of rectangular prisms. Each prism is generated by calculating height differences for
the four grid points that make up its vertical edges. The total volume is computed as the sum of
the volumes of the individual prisms. You can use the default grid sizes, or fill in different
values on the dialog box.
The main disadvantage of using this technique to compute your volumes is that it does not
provide graphical representation of the results. It does have the advantage though that it does
not require any additional memory resource to compute the volumes, other than required by the
input models. This is useful when using larger models and computer resource limitations are an
issue.

Volumes Calculations
Within FGL, select 'VOLUMES > Volumes between surfaces (Grid)'
Using the 'Pick>>' button select the existing and proposed surfaces
Enter report filename
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9.6

Calculating Spoil Heap Volumes
Often when calculating spoil heap volumes the original ground surface is not available.
Therefore, the original surface has to be estimated from the surveyed surface. The base of
spoil heap or the top of a quarry site would be taken as the original ground surface.
We are going to use the model DUMP.

Create the model ‘DUMP’ from DXF file
Go to ‘FILE > Model > DXF file’
Select Pick
Select the file DUMP.DXF from the directory \SCC\Tutorials\
Select Open

Select OK
Select ‘Create Model and Triangulation’
Select OK
Save model as DUMP.Model
There is a spoil heap in the bottom half of this model. Using the Data Selection Dialog
(right click mouse), highlight all points on the base string of the spoil heap and from the
DTM list box, convert the string to ‘Clip Polygon’.

Creating The Boundary String
Zoom into the area of the spoil heap
Click the right mouse button to access the Data Selection Dialog
Set the selection method to ‘All points on selected string’
Select OK
Select the string indicating the base of the spoil heap (See image below)
From the list boxes, select ‘Clip Polygon’ from the DTM status box.
Select ‘Yes’ to convert the string
Save the model
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From the ‘VOLUMES’ menu, selecting the ‘Volumes of Spoilheaps/Pits’ option will
calculate the volumes of any spoilheap or pit so long as there is a clip polygon string
around it. This option also allows multiple clip polygons in the model. SCC copies the
boundary string to a second model and then computes volumes between the two using
the prismodial method. It does this in one step and gives you the option of keeping the
intermediate boundary model, the isopachyte model and report file and whether you wish
to annotate the volumes on the model.

Computing Spoil Heap Volumes
Go to ‘VOLUMES > Volumes of Spoilheaps/Pits’
Enter in a new or accept the default report name
Select the options you require, if the options to ‘Keep intermediate isopachtye models’ and
‘Keep intermediate boundary models’ are not turned on, these two models will be stored in
your current working directory regardless.
Select ‘OK’
Selecting the options as shown above will present you with the following;
Volumetric analysis report for spoil heaps and pits (Prismoidal method)
12:40:56 2007
Survey model DUMP
No
Cut Volume Fill Volume Plan Area Surface Area
----- ---------- ----------- --------- -----------1
18160.8
19.1
8290.3
8424.8
SCC for Windows v7.8.22 (C) 1990 - 2005 Atlas Computers Ltd
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9.7

Identification of Potential Errors In Volumes
Before volume calculations are carried out both models should be checked for the following
points.

Define Topography Using Strings Not Entirely Discrete Points
Ensure that the models are defined using strings and not entirely of discrete points (spot
elevations). While discrete points can be used to adequately describe smooth and reasonably
flat surfaces, they are unsuitable for describing irregular surfaces containing significant grade
changes such as embankments, spoil heaps, pits & hollows, etc. Strings are used as
breaklines and as such constrain the triangulation around irregular areas, the net effect of not
using strings where they are required is that embankments, pit edges, etc. may appear to spill
as illustrated in the diagram below;
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The error shown above is corrected by connecting the discrete points defining the embankment
/ grade change with a string to produce the results shown in the following picture.

Note that the only difference in survey procedure is to enter a unique non-zero string number
for any string being surveyed. Not providing strings where they are required can often lead to
serious volumetric errors.
When calculating prismoidal volume between models that contain only point information, there
is an option to ‘Add Surface Intersections’ to ‘Triangle Edges’. Make sure that this is set before
computing the volumes.
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Boundary
The survey model should always extend beyond the design area to facilitate side slope design,
and the side slopes should be recomputed whenever the survey model is modified. For
accurate volumetric analysis, a common boundary string, normally generated from the side
slope intercept points, should be included in both models.

Accurate Volumes
Accurate volumes cannot be calculated between two surfaces where a common boundary is
not defined. Poor boundary definitions are probably the most common cause of gross error in
volume calculations. The boundary string should always have a DTM status of clip polygon and
will normally take the form of an existing string line, one generated by interface design, or one
added manually to the model in SCC. If a boundary is not provided, most modeling packages,
including SCC, will automatically determine a boundary, using a convex hull or similar
algorithm. Such boundaries rarely reflect conditions on site, as can be seen in many cases, by
contours appearing outside the surveyed areas. In any case, such a boundary is ambiguous, as
it is dependent on the algorithm selected by the software package rather than the judgement/
agreement of the engineers and surveyors on site. Weeding and the adding/removing of
traingles may also be used to define plan areas although use of a boundary string is far
superior.

Visual Verification
Both models, that is, the survey and design or OGL and FGL, should always be visually verified
prior to computing volumes, as if there are any discrepancies in either model the result is liable
to be a gross error in the results. To verify a model, increase the contour interval, say to 0.2m
and visually check the contours. It is also wise to generate a number of profiles and cross
sections, with vertical exaggeration of say 5:1, through the model to further check for
anomalies.

Volume Verification
Having verified all models you may then proceed with volume calculations. When calculating
volumes, it is advisable to use all three methods, i.e. prismoidal, grid and cross sectional, and
compare the results. Each method is mathematically independent of the other, and hence each
provides a check on the other. Differences of any greater than approx. 0.5% indicate
ambiguities in either the surface or boundary conditions. Of the three methods, cross-sections
are most prone to error, particularly when dealing with survey models in rough terrain. The
reason for this is that cross sectional volumes assume that data along the cross section is
typical of data between cross sections, which is often not the case. If you have errors in your
data, cross sectional volumes are liable to magnify their effect.
Cross sectional volumes may also contain errors due to curvature. The end-areas method of
calculation also assumes that cross sections being used are parallel to one another. This may
not be the case where cross sections are being taken along a curved centre line, such as a
road centre line. In this case, small errors can occur where there is fill on one side of the
centre line and cut on the other side, or vice-versa. This is another reason to measure your
volume using more than one method, prismoidal and grid volumes do not suffer from this error.

Using Cross Sections To Verify Design
In many measurements, including road and building footprint design, it is the case that the
design and survey surfaces meet at the boundary string. This will normally be carried out
through a process of interface design, either in SCC, or using another specific design package
such as MX or DOER. If this is the case, it is necessary to check that the two models do
actually meet at the boundary. The simplest way of doing this is to take a regular set of cross
sections through both models and check that there are no vertical side slopes visible, as shown
in the following figure.
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This can be caused by a number of different factors. The most common reasons are that the
survey model does not cover a large enough area to accommodate the interface design, or that
one or both models have been altered after the interface has been designed and the design
has not been updated. In either case, the result is liable to be a gross error in the volumes.

Contours
When verifying the contours in a design model where interface strings are being employed with
fixed side slopes, the contours along those side slopes should be parallel to one another. In
the case of a flat building footprint, they should also be parallel to the edge of the design model.
If this is not the case, there is probably an error in the interface design that will lead to errors in
sections and volumes.

10

Section Editing
The following tutorials outlining briefly section editing functionality. All section editing
commands will be demonstrated using sample file 'Bridge.Model' available from the tutorials
directory.

Open Model
Select 'FILE > Open' and pick 'Bridge.Model' from \SCC\Tutorials' directory

Creating A Profile
From The Main Menu Bar, select ‘SECTIONS > Long sections with cursor’
Left click mouse on Point 1 and Point 2 illustrated below
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Right click mouse to create Section

Select 'FILE > Save As > Bridge1.Section'

10.1

Section Snap Controls & Data Selection Options
Section Editing can be carried out with the use of additional Snap Controls and Data
Selection Dialog:

Snap Controls
The following snap controls are available:
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Data Selection Dialog
The use of the Data Selection Dialog allows the user to isolate specific data easily:

10.2

Section Editing Of Surface & Non-Surface Strings
SCC supports section annotation of levels on surfaces, and cuts through strings that are not
part of the DTM surface. These can be illustrated as follows;
Open the sample project 'SECTION_EDITING.Project' and '2d-sectest.Model'.
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Select 'EDIT > Non-surface string cutting options' which are also available in the section.
Selecting Non-surface string cutting options shows the following dialog:

Input model is only used when the option is used from within an existing section
Output surface name is the same given to the surface annotation line within the
sections

Cut all strings in the input model is only used when calling the option from an
existing section, and causes all cut strings to be added to the section

Only cut Non-DTM points (Approx and Elevation) will cut all strings that are not
part of the DTM surface in the input model and add the cut positions as single points to
the section.

Only cut Elevation strings does the same but is restricted to strings with a DTM code
of Elevation.

Only use the following features (comma separated) cuts all string with the
nominated features. For example, a value of TB,BB,RL,RR would only cut strings with
one of these feature names.

None indicates that this function will not be used when creating new section.
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Cut data does not have valid levels forces the cut points output to assume the level
of the sections datum.
When selected within a model, the above rules will apply to all newly cut sections created
using long or cross sections, created using the cursor, existing strings, or alignments.

To demonstrate this cut a section using 'SECTION > Long sections with cursor', using
the above values:

Note that additional symbols and annotation have automatically been added based on the
feature library and section coding options being used. Where the cut feature, for example
OHL has a valid dimension 3 symbol and value a symbol will be drawn in the section.
Text annotation for feature and level will also used for this point in section, including text
alignments, offsets, and orientation. OHL setting can be viewed using the Query and edit
function from plan.
Note that the D3 Units field controls whether the symbol is placed above the cut point, e.g.
for a fence, wall, etc.. or centred around the cut point, e.g. for a pipe.

©2015 Atlas Computers Ltd

239

The 'SECTION > Edit section codes option' allows the user to specify additional annotation
options by feature. Using a value of Level on surface annotates the level of any given
point on the surface in addition to the annotation boxes. A code and feature value of
~BLANK may be used for triangle cuts that do not relate to a string.
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This annotation can be turned off for individual points as required using the 'EDIT > Query
and edit points' option from within the section.

10.3

Adding Surface String & Point Data To An Existing Section
The addition of string and point data to an existing section can be examined using
'Bridge.Model’ and 'Bridge1.Section'.
If you are within 'Bridge1.Section' revert to 'Bridge.Model' to copy and paste bridge detail
from the model to the section file.
By changing the model view using 'EDIT > Viewports' specific bridge detail strings can be
easily identified and in turn selected for insertion onto Section Profile.

Viewport
Go to 'Bridge.Model'
Select 'VIEW > Viewports > Rotate Viewports'
Select 'Pick' from Create viewport by rotation dialog and left click on model to assign
point
In this instance, rotate the model in the YZ axis as shown below:
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Select 'Close'

Bridge Detail
Left click mouse to bring up 'Data Selection Dialog'.

Select 'All points on selected string' and 'OK'
Left click on string of interest, all points on the string are highlighted in blue nodes

Select 'EDIT > Copy > Copy to Clipboard'
Go to Section File, select 'EDIT > Paste'
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Move cursor over section which you wish to add the detail to (In this case there is only one
profile) and a blue box will border the section
Left click to add the detail to this section
Within the 'Add section data' select surface 'ADDPTS', feature 'O' and 'Disable
annotation for new strings'

Select 'OK'

Select 'FILE > Save As > Bridge2.Section'

10.4

Delete Points (Section Edit Menu)
Specific delete options are available within the 'EDIT' menu'.

Delete Points
With 'Bridge2.Section', select 'EDIT > Delete Points > Delete Points'
Left click on points to delete
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10.5

Move Points (Section Edit Menu)
The move function is also available.

Move Points
With 'Bridge2.Section', select 'EDIT > Move Points'
Left click on points and move cursor
Left click mouse to drop/reposition points
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10.6

Text (Section Edit Menu)
Text options available within a SCC model can also be used with the section file. The
example below illustrates the use of the 'Create Text' option

Text
With 'Bridge2.Section', select 'EDIT >Text > Create Text'
Within the Create/Edit Text dialog, enter 'GRASS', set the height and width to 0.8 and
Rotation to 45
Move the cursor across model and left click mouse to position text
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10.7

Symbol (Section Edit Menu)
Symbol options available within a SCC model can also be used with the section file. The
example below illustrates the insertion of a 'B_MARK' symbol.

Symbol
With 'Bridge2.Section', select 'EDIT >Symbol > Insert Symbol'
Select 'B_MARK' from the symbol list, set height and width to 0.02 and rotation to 270 00
00
Move the cursor across model and left click mouse to position symbol

10.8

Hatching Between Strings (Section Edit Menu)
Hatching can be applied between two strings.

Creation of Construction String
Select 'EDIT > Add points'
Within the 'Add section data' select surface 'ADDPTS', feature 'O' and 'Disable
annotation for new strings'

Select 'OK'
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Draw string as illustrated below along the base of bridge
Left click mouse and select 'Update String in Model to complete

Hatching Between Strings
Select 'EDIT > Hatching between strings'
Enter 45 00 00 as the Hatch angle and set 0.2 as the Hatch spacing

Select 'OK'
Move cursor over bridge outline and left click mouse when string is highlighted in blue
Then move cursor over 'construction string' and left click mouse when string is highlighted
in blue
Hatching will be applied as shown below between the two selected strings
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Remove String
Select 'EDIT > Delete points > Delete surface'
Move cursor over 'construction string' and left click mouse when string is highlighted in
blue

The string is removed
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10.9

Query Points (Section Edit Menu)
Additional information can be obtain about a specific point using the Query function within
the Edit menu

Query Points
With 'Bridge2.Section', select 'EDIT > Query Point'
Left click on specific point and the 'Query section detail' dialog is presented
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10.10 Removal of Specific Points from Section
This tutorial is based on previously created 'FGL.Model' or you may have already created
'FGL long.Section' in which case step 1 'Creating A profile' can be skipped

Creating A Profile
Within FGL.Model, select ‘SECTIONS > Long sections with cursor’
Select three or four points with the left mouse button following the centre of the FGL
model
When finished, click the right mouse button
View the profile
Select ‘FILE > Save As’ and call the file' FGL long.Section'

Annotation of Section to Isolate Points belonging to 'TB' feature
Within Section File, select 'VIEW > Annotation Settings'
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Select 'Annotate Feature Names' and press 'OK'

Deletion of 'TB' points from Section
Within section, right click mouse to bring up 'Data Selection Dialog'
Enter 'TB' as the First and Last feature range

Select 'OK'
All 'TB' point on the section are highlighted as shown below:
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Select 'EDIT > Delete > Delete Points'
Select 'Yes' to 'Delete selected points'

©2015 Atlas Computers Ltd

252

10.11 Optimised Volumes
Consider that a river trench design has been completed 'River_Trench_3.Alignment' using the
existing ground model 'River_Ground.Model and required design parameter. The following
tutorial outlines the generation of Cross sections from the Alignment to allow optimised
volumes to be carried out. Particular attention is drawn to the optimised volumes steps.

Generation of Sections from Alignment
The optimisation function is base on sections generated from the alignment

Cross Section From an Alignment
Within ‘River_Ground.Model’ which has the Alignment ‘River_Trench_3.Alignment’
attached, select ‘Sections > Cross Section From an Alignment
Enter required Parameter for example below:

Select 'OK'
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Select ‘FILE >Save As > Survey.Sections’

Optimised Volumes:
The optimised surface calculations are carried out as follows:

Optimised Volumes
Within the Section file, select ‘EDIT > Optimise Volumes’
Using arrow button select Design Template ‘River_Trench_3.Alignment’ (currently
attached to model)
Set the Offset Internal and Maximum additional shift per section
Select the following options also

Select ‘OK’

Offset Interval
Offset Interval is the value, which the design section is iteratively shifted with respect to
the survey river section. The larger the offset interval value the quicker the optimisation
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processes. The smaller offset interval value the slower but more accurate the
optimisation process. For example, the default value is 0.1 means that the design section
will be placed within 0.1m of the optimum position

Maximum Additional Shift per Section
This parameter controls the amount the design section may be shifted in position relative
to the position of the previous design section. The value controls the maximum deviation
of the optimised centre line from the original centre line. For example, a value of 2m
would mean that the centreline position of the current design section could only deviate a
maximum of 2 m from the design centreline. A large value can potential allow the
optimum design centreline to zig zag across the river in order to optimise or to minimized
the dredged volume. A smaller value prevents the optimum centreline from deviating
sharply away from the design centreline.

Volumes Calculation & Report
The volumes are calculated as follows:

Volumes
Select ‘EDIT > Volumes’
Select Existing Surface ‘River_Ground.Model’ and Proposed Surface ‘~Optimized’
Select ‘Annotate volumes and ‘Highlight cut and fill’ options
Enter relevant Volumes report file name
Select ‘OK’
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Cut and Fill Volumes are report firstly in a dialog box
The user can also view report in a text editor

The sections now show the original model surface, original design and the optimised
design. Cut and Fill are highlighted as shown below:
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11

Interface Design Using The Alignment Module
SCC’s Alignment module allows simple and straightforward interface design.
Create a model from a MX GENIO file. Design a simple building interface which can then be
moved about the model until the amount of cut and fill indicated is roughly equaled.

Creating A Model From A GENIO file
Close all open windows except the Project Window
Go to ‘FILE > Model > MX GENIO file'
Select Pick
Go to the directory \SCC\Tutorials\
Select the file 'GROUND.CRD'
Select Open
Set the GENIO L-string processing to Treat as points

Save the model as GROUND.model

Designing A Building Interface
Fill in the list boxes as required.
Enter 50.0 into the Level Control box

Go to ‘EDIT > Add Strings with cursor’
Click on the right mouse button
Select ‘New > Polygon’
Draw a simple building
When you are finished, click the right mouse button
Select ‘Save string as interface’
Set the Fillet Radius to 0.15
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Select OK
The option Move/Edit Alignment is automatically activated and the design can be moved
about the model until the correct amounts of cut and fill are indicated.

The design can then be exported to a model and used for calculating volumes as before.

Export Design To A Model
Go to the ‘DESIGN > Export Design as a Model’
The dialog below will be displayed
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Enter the relevant details
Select Ok to create the model
The model can be saved and volumes calculated between the design and the survey.

11.1

Simple Football Pitch Design
The following outlines designs steps with SCC to design a football football pitch (130m * 80m)
with 1:2 side slopes and in turn to balance cut and fill. Specific parameters may be changes
where appropriate to achieve the desired design

Open Existing Data
Select ‘FILE > Open’
Open Project and Model

Construct Pitch
Turn On Grid as show below so that we can snap to grid points when drawing in pitch
Select ‘VIEW > Titles & Grids’
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Pick feature from the drop down menu ‘KERB’ or ‘PITCH’ for example
Set the DTM status as ‘Approx Elevation’

Turn snap grid on and Left click mouse at corner points of pitch
Right Click mouse, select 'Update string in model' to end string
With the grid points turned on the user can easily set out 130m*80m

Create Alignment String
We can use the alignment module to apply side slope to the pitch boundary string
Pick feature from the drop down menu ‘KERB’ or ‘PITCH’ for example
Set the DTM status as ‘DTM’
Set the elevation to 90 (In this instance, 90 is the average height)

Turn snap grid on and Left click mouse at corner points of pitch
Right Click mouse, select 'Save As Interface String'
Set up the following:
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Revert to model

As can be seen in the model above, the pitch with 1:2 side slope does not currently fit
(bottom side slopes not shown). We can manually move the alignment as follows:
Left click mouse on model, move cursor and a blue line will appear which will allow you to
move the alignment in the line direction.
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To check design parameters, select ‘DESIGN > Section Template’
Turn on side slope of 1:2 for left side (String was drawn in a clockwise direction so we
want the slope outside so therefore left must be selected)

Balance Cut & Fill
In order to allow the optimise cut and fill function to work the surface/model needs to be
larger.
Draw in an arbitrary string around the field boundary at height of 90 for instance.
Pick feature from the drop down menu ‘0’ for example
Set the DTM status as ‘DTM’ and height of ‘90’ in the elevation box (circled in image
below)
Left click mouse to place point
Right click mouse to select ‘Update String in model’
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Select ‘DESIGN > Balance Cut and Fill’

Select ‘Ok’ to except default ‘Balance Cut and Fill’ settings
Remove arbitrary string (delete points command)

Export Design
Select ‘DESIGN > Interface & Export parameters
Set up the following and ensure that original model is set as the ground surface

Select ‘OK’
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Sections
To verify a design generate cross sections:
Within Design Model, select ‘SECTIONS > Long Section with Cursor’
Left click on first point of section and left click on last point
Right click to finish section
A good check is to also append the original surface:
Within the section, select ‘VOLUMES > Append Surface’
Pick original surface
See sample section below:
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11.2

River Section: Sections From A Bandwidth
The following tutorial outlines the steps to generate River Sections from a centreline using a
bandwidth.
‘Section From A Bandwidth’ method is typically used when creating river sections, where the
surveyed section line is greater than the actual river width. The section is created using the
surveyed elevations snapped, at right angles, onto the user-defined centreline.

Open Existing Data
Open ‘RIVER.Project’ and ‘RIVER_Strung.Model’ from '\SCC\Tutorials'
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Creating Centreline Alignment
Select ‘DESIGN > Create Alignment from String’
Left click on centreline of river
Enter Alignment Name
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Generation of Sections
Select ‘SECTIONS > Sections from a Bandwidth’
Set the desired bandwidth ‘0.500’ for example
Set ‘Output survey feature names’ and ‘Use current alignment as cross section centre line’
as outlined below:
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And secondly, all point within the set bandwidth are highlighted (in blue) for inclusion
Right click mouse to produce Section
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By reverting to the model view without dropping the ‘Sections from a bandwidth’
command, that is, without selecting ‘Esc’, the user can move to the next cross section
position and create a section.

Select ‘FILE > Save As > River.Sections’
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Skew Angle
Skew Angle is the angle of deviation from the normal to the centre line, that is, a skew
angle of 0° implies that the cross section is at normal, right angle to the centre line.
A large skew angle means that the area of the cross section will be significantly larger
than the cross section area at the river at that point.
Dividing the offsets of the cross section (the width of the cross section) by the Cosine of
the skew angle may be used to normalise the cross section.
y = xCosA

Annotation of Skew Angle
Select ‘View > Scales, Titles & Grids’
Select ‘Add’ within the ‘Section Graph Titles’ Area
Within the Title Column, select ‘Skew Angle’ from drop down menu
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Attaching Sections
Select ‘FILE > Attach/Detach > Attach Section File’
Select ‘River.Sections’
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12

Presentation & Archiving of Measurment Results
In order to minimise the risk of error appearing into a measurement, and also to illustrate the
checks that were applied during the calculations, it is advisable to incorporate the procedures
used and results obtained into a standardised form. A sample of such a form is included at the
end of this section.
When presenting the results, the following items should be included:
· Measurement results / Volumetric check list
· Plan drawings of both models used
· Sample sections showing both surfaces, with cut and fill highlighted.
· Plan drawing of isopachyte model showing depth of cut and fill
· Electronic media containing any of the above where required.
In many cases, using a small A4 or A3 colour printer, is a fast and very cost effective way of
producing the above. Remember that the drawings are provided to illustrate the method and
accuracy of measurement and are in addition to any other survey drawings required. If the
calculations have been carried out correctly, the above information is generated as a natural
by-product of the measurement process and adds little or no overhead to time required.
Copies of all results provided to any third parties, should be kept and filed. You never know
when you might need them!
Where regular measurements are being taken over a reasonable period of time, it is some
times preferable to use a database to enter any volumetric result check list details. The form
given below can be easily recreated in Microsoft Access or a similar database. This greatly
simplifies the retrieval of given measures and the production of summary information of
measures taken to date.
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Volumetric Measure Check List
SCC Project
Measure Number
Measure Description
Carried Out By
Date
Survey Datasets Used
(Including Directory, Date and
File Size)
Survey Model Name
(Including Directory, Date and
File Size)
Design Datasets Used
(Including Directory, Date and
File Size)
Other Datasets Used
(Including Directory, Date and
File Size)
Names Of Other Models Used
(Including Directory, Date and
File Size)
Task

Completed

Strings have been used to define all significant features and grade changes in
all of the survey models
The contours on each model have been visually checked at a 0.2 or smaller
interval and appear to agree with conditions on the ground. There are no large
humps, hollows, or embankments in the model, visible via contours, that have
not been described by strings.
Any survey data that is not consistent with ground conditions has either been
corrected or removed, with enough data remaining to fully describe the ground
surface.
SCC Cross sections have been taken through all models and they appear to
agree with conditions on the ground, and, the intercept lines from the design
meet the ground for all sections.
A common boundary string has been developed and included in the survey
and design models and this string has been set to a Clip Polygon in SCC.
There are no contours visible outside of this boundary in any of the models,
and, this boundary does not affect any existing contours in any other way.
Contours along design side slopes are parallel on one another.
Volumes calculated by cross section
Cut_____________
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Volumes calculated by Prismoidal volumes between surfaces
Cut_____________ Fill_______________
Area_____________

Isopachyte Plan

Probable error due to bad overlap ___________M3

___%

Volumes calculated by Grid volumes between surfaces
Cut_____________

13

Fill________________

Reports Within SCC
SCC produces high quality reports from all SCC documents using the industry acclaimed
Crystal reports engine. These reports can include data, charts, bitmaps and other rich content,
and can be output to printers, PDF, Excel, HTML and Word files.
Sample reports are available within the SCC directory. These templates can be used to
regenerate project specific report data directly from SCC. The Crystal reports also have the
advantages that they allow the report layout to be readily changed without affecting the content,
they allow automatic highlighting of out of spec values such that they can be easily picked up by
anyone reading the report, and they can be readily exported to a range of formats including
Word, PDF, Excel and HTML.
Note that while creation of new report formats requires a Crystal reports license, creation,
viewing, printing and export of reports is included within the SCC license. To view a report,
click 'FILE > Reports' and select sample report.

Extract from sample files provides can be viewed below:
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Sample Feature Library Report:
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Sample Traverse Report:
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Sample Check Survey Report:

14

Plotting From SCC
There are plotting facilities in SCC for creating and editing sheet layouts. These facilities work
with all Windows compatible plotters and printers, with full print preview.
Sheet layouts can be imported from DXF or created in SCC as a model file. This file can then
be added to the feature library within a project or attached to a model using the ‘Attach/Detach’
option under the ‘FILE’ menu. To create a new sheet template, go to ‘FILE > Sheet Layout >
Create new sheet template’ and select the paper size and orientation.
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Title blocks, legends and station co-ordinate boxes can be added to the template and it is then
saved to the current project file.
When you have added a title block to the sheet, a dialog will be displayed. This option allows
the user to add and design title blocks for a sheet template.
The box is positioned using the right mouse button; the first click should be used to position the
top left corner of the data box and the second click to denote the bottom right corner of the box.
When the box is drawn the following dialog is presented:

Selecting one of the options on this dialog will determine the type of data displayed. The options
are as follows:

Empty Title Box
This option allows the user to add an empty rectangular box to the sheet model, which can
be used for data entry, borders etc.

Grid
When selecting this option, the user also needs to enter a value for the amount of rows or
columns required in the grid. The grid may be used for entering data such as 'Project
Name', 'Scale' or 'Date' etc..

Feature Library Legend
To select this option the user must enter a value in the rows box. This value indicates the
total amount of feature library entries the user would like to display in the legend when the
sheet is inserted into the model. This works by taking each entry in the model in
sequential record number and displaying the description and the linetype or symbol in the
feature library legend. Features that are not used in the model, do not count.

Station Co-Ordinates
The user must also enter a value in the rows box. The value entered is the total amount
of station coordinates that the user wishes to display on the sheet, where STN 1 is the first
record number in the station coordinates spreadsheet.
The images below show how the station coordinate box appears both in the sheet
template and in the model.
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You can design the sheet template by adding your own company logo, the company
feature library and legend and also additional information about stations, bench level
values and location.
Below is a list of macros that can be used to create the sheet template. When the sheet is
inserted into a model or section these macros will be automatically updated with the
relevant job data, either from the operating system that is being used or from the data
entered into the ‘Titles & Grids’ dialog.

Sheet Creation Macros
Operating System
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[Name}

Model / Section Name

[Path

Full Model/Section path

[Project]

Project Name

[Time]

Current time

[Version

SCC Version & Dongle Number

[Scale

Plot Scale

[Page]

Sheet Number

[Pages]

Number of Pages

Titles & Grids Dialog
[ProjectTitle]

Job Name / Title

[Client

Client Name

[Date]

Date

[Surveyor]

Username

[Operator]

Operator

See the images below for an example of how the macros use the data entered in the
‘Titles & Grids’ dialog. The first grid box displays the macros typed in sheet creation. The
second grid box show how the macros are used when inserted into the model.
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Create A New Sheet Layout
Start with a blank screen
Go to ‘FILE > Open’
Change FILES OF TYPE to ‘Project’
Select ‘Default.project’.
Go to ‘FILE > Sheet Layout > create New Sheet Template’
Select the paper size and orientation.
Select OK
Select OK to view the model
Remember, when creating a new sheet template, to allow enough margin
space to accommodate the printer rollers on your selected printer. These
may vary across printers and though the sheet size will be correct, it may
stop the print process if the margin size is not large enough.

Saving The Template
To save the sheet template, go to ‘FILE > Sheet Layout > Save Sheet Template’
Enter a name for your sheet (it is good to contain the size of the sheet in the name)
Select Ok
Close the model
Go into the project file
Select ‘FILE > Save’
Save the project file
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Inserting Sheet Into Model
Once the template has been saved to a project file, any model created with this project will
store the new sheet in the feature library. This sheet can then be inserted into the model
and viewed either within the model view or by print preview. Remember, to view the layout
in print preview, you must have the correct sheet size selected in the print set-up!

Inserting the sheet into the model
Open the FGL. Model file
Go to ‘FILE > Sheet Layout > Insert Sheet’
Select the sheet you wish to insert, from the list
Set the correct orientation and plot scale
Note that the plot scale effects the size of the sheet relevant to the model.
Then drag the sheet and place it over the model
Pressing the left mouse button once will secure the sheet in position

Once the sheet is in the model, it can be rotated, moved and the plot scale changed. If
there is more than one sheet in the model, it is possible to view each sheet individually by
changing the view number in the control box on the Sheet Layout menu bar.

Sections
Once the sheet layouts have been saved to the feature library, these can then be used to
plot sections and profiles. The method of inserting sheets into section drawings differs
slightly from that of the model. Once a section has been generated, a sheet can be
inserted by going to the ‘VIEW’ menu and selecting ‘Section Sheet Layout’. You can then
select the sheet of your choice and also set the way in which you sections appear on the
sheet.
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14.1

Creating Sheets in SCC
The following outlines the creation of a SCC Sheet Layout:

A.Set Up Project
Open a ‘New Project’ and attach the ‘Default(v7-0 Complex).Project’ template.
Call the project ‘Sheet’

B.Creating Sheet Layout
Go to 'FILE > Sheet Layout > Create Sheet'
A dialog is displayed with a selection of sheet sizes and orientations. Select a sheet.

A model of the selected sheet is generated. The user can add text to the title blocks,
creating an individual sheet style for the company. Symbols can also be added to the
models. These symbols can be created from dxf files and are especially useful for
inserting north arrows or company logos. See Symbols.

C.Save Model
Save the model 'FILE > Save As'
This means that the sheet can be edited at a later date and the previous template
overwritten.

D.Save Sheet Layout
To add the template to the feature library, go to 'FILE > Sheet Layout > Save Sheet
Template’ and give the template a name. This template will be automatically saved to the
current project library.

©2015 Atlas Computers Ltd

283

E.Export Sheet & Import Sheet into Default Project
In order to make this sheet available to use within other project, it is necessary to output
the sheet layout and import the file into the necessary project.
Go to ‘EDIT > Sheet Layout > Export Symbols to File’
Select ‘No’ to ‘Do you want to overwrite it’
The sheet can then be importing into the default library as follows:
Open Default Project
Select ‘EDIT > Symbols > Import Symbols from File’
Select Sheet Layout to import

Select ‘Import’

14.2

Creating a SCC Sheet Layout From a DXF/DWG file
The following outlines the creation of an SCC Sheet Layout from a given dxf file.

A.Set Up Project
Open a ‘New Project’ and attach the ‘Default (v7-0 Complex).Project’ template.
Call the project ‘Sheet’

B.Model DXF Sheet
Go to ‘Model > DXF file’
Select ‘ATLAS_A1_4006.dwg’
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C.Creation of New Sheet Layout
Go to ‘File > Sheet Layout > Create a New Sheet Layout’
Select ‘ISO A1’ and enter the relevant border settings as follows:

To easily identify the sheet edge and the border (clipping frame) use the ‘Query and Edit’
function to change the colour of each.
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Go to ‘Atlas_A4_4006.Model’, right click to access ‘Data Selection Dialog Box’ and select ‘
Mark or clear all points in the model highlight all points

©2015 Atlas Computers Ltd

286

Select ‘Edit > Copy to Clip Board’
Go to Sheet Layout ‘ISO A1’Model and select ‘Edit > Paste’
Note that the Sheet Edges coincide.
Delete the unnecessary Sheet Edge point (grey) leaving behind one Sheet Edge String
(magenta)
Where necessary use the string edit command, for example, Move Points, Trim, Extend

D.Adding Text & Text Macros
Text can be added to the Sheet Layout with the Text Tools

Either using the Text Toolbar or ‘EDIT > Text > Add Text’
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Text Macros are available within the ‘Add Text’ function
Select the Macro from the drop down menu
Select ‘Add’ and place the text in the required position
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E.Bitmaps
SCC bitmap option inserts a windows bitmap (.BMP) file into the model in a given location
and allows you to define its size and aspect ration. This option can be used when creating
sheet layouts, where bitmap information, such as company logo, are required on the sheet

.
Go to ‘EDIT > Bitmaps > Insert Bitmap’
Select bitmap using ‘>>’ option
The height and width can be defined within the window or manually on screen

The bitmap can be resized, moved and deleted using the commands within ‘EDIT >
Bitmaps’
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F.Save Sheet Layout
Go to ‘FILE > Sheet Layout > Save Sheet Layout’
Enter Sheet Name

G.Export Sheet & Import Sheet into Default Project
In order to make this sheet available to use within other project, it is necessary to output
the sheet layout and import the file into the necessary project.
Go to ‘EDIT > Sheet Layout > Export Symbols to File’
Select ‘No’ to ‘Do you want to overwrite it’
The sheet can then be importing into the default library as follows:
Open Default Project
Select ‘EDIT > Symbols > Import Symbols from File’
Select Sheet Layout to import

©2015 Atlas Computers Ltd

290

Select ‘Import’

H.Inserting Sheet Layout Within A Model
Within a Model, go to ‘FILE > Sheet Layout > Insert Sheet’

Select Sheet from list
Select Plot Scale and Insertion Method
Right click mouse to place sheet
Note: Rotation and Placement can be interactively choose on screen
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15

Transformations
SCC allows the user to create or edit a transformation from one co-ordinate system to another.
The transformation editor lets the user enter any number of co-ordinates in both systems and
calculates a transformation that will convert data between these systems.
It is for example possible to take a survey where the control stations have been destroyed and
by surveying series of well-defined points of local detail, match up the common co-ordinates
and transform the newly established stations into the old survey grid system.
Likewise, it would be possible to transform from a local or assumed grid system into the
National Grid.
It is advisable to take a large number of mutual points and to have these spread over the extent
of the survey. The system uses a least squares best-fit technique so that a large number of
points may be used to provide the strongest transformation.

15.1

Performing A Transformation
In this specific example SCC uses an affine two-dimensional transformation with elevation
datum shift. This transformation allows for rotation, translation and scaling in plan along with
translation of levels.
Go into SCC.
Go to 'FILE > New Project'
Call the project Transformation Tutorial and attach the project template Default.Project.

Go to 'FILE > Open'.
Go to the directory '\SCC\Tutorials\'.
At the bottom of the Open dialog and change the Files of Type to SCC Datasets (*.Survey)
by clicking the down arrow.
Select the dataset 'Square.Survey'. The Detail Co-ordinates window.
Go to 'TOOLS > Transform Co-ordinates'.
When you are creating a new transformation, just click on the New transformation option.
A blank transformation spreadsheet is opened.
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Type in the co-ordinates of the points, which you know in both grid systems.
Insert a blank record for each point known in both co-ordinate systems.
Go to 'EDIT > Insert Records'. Insert 3 new records.

Type in the co-ordinates of the points in the first grid system (Ea/Xa,Na/Ya and Ht/Za) and
then their co-ordinates in the second grid system (Eb/Xb,Nb/Yb and Ht/Zb).
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Save the Transformation as 'SQ.Transformation'.
Close the transformation spreadsheet and returned to Detail Co-ordinates window.
Go to 'TOOLS >Transform Co-ordinates'.
Pick the Transformation file 'SQ.Transformation'.
Apply the transformation.

©2015 Atlas Computers Ltd

295

When the transformation is performed a report is generated. You will be asked whether
or not you wish to view this report. Choose Yes to view the report . The following report
will be presented in Wordpad (or whichever Text Editor you have specified in the
Directories and Files section of the General Options.).

In the previous example, the points were known exactly in both co-ordinate systems
therefore there were no residuals listed in the report.
SCC for Windows v7.8.11 (C) 1990 - 2005 Atlas Computers Ltd
Transformation report
Transformation name SQ
Date
Wed Dec 06 09:24:02 2006
Transformation parameters are
a = 0.000000
b = 2.000000
c1 = 400.0000
c2 = -500.0000
Where x' = ax - by + c1
y' = bx + ay + c2
Pt
Name
E/X(a)
N/Y(a)
E/X(b)
-------------------0
STNA
300.000
150.000
100.000
0
STNB
400.000
150.000
100.000
0
STNC
400.000
100.000
200.000
0
STND
300.000
100.000
200.000
Block shifting parameters
(0,0) -> (400.00000,-500.00000)
(0,1) -> (400.00000,-498.00000)
(1,0) -> (398.00000,-500.00000)
Block creation point 150.00000,200.000000
Insertion point 0.00000,-200.000000
Scale = 2.00000
Rotation = 090 00 00 (Counter Clockwise)

N/Y(b)
-----100.000
300.000
300.000
100.000

rE/X
---0.0000
0.0000
0.0000
0.0000

rN/Y
---0.0000
0.0000
0.0000
0.0000
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Typical shift applied -150.00000,-400.00000

In the following example the co-ordinates of the points were not known exactly in the
second system. Apply the following changes to the transformation.

Save the transformation and then Apply it. The following transformation report is
generated.
Note the residuals at each of the Easting and Northings. The residuals are differences
between the given co-ordinate values for the point and the co-ordinate values calculated
using the transformation parameters.
Calculating the residual at the Easting of point no.1.
SCC for Windows v7.8.11 (C) 1990 - 2005 Atlas Computers Ltd
Transformation report
Transformation name SQ_2
Date
Wed Dec 06 09:33:10 2006
Transformation parameters are
a = 0.003859
b = 1.998523
c1 = 398.7149
c2 = -499.9900
Where x' = ax - by + c1
y' = bx + ay + c2
Pt
Name
E/X(a)
N/Y(a)
E/X(b)
-------------------0
STNA
300.000
150.000
99.968
0
STNB
400.000
150.000
101.010
0
STNC
400.000
100.000
200.000
0
STND
300.000
100.000
200.023
Block shifting parameters
(0,0) -> (398.71486,-499.98997)
(0,1) -> (398.71872,-497.99145)
(1,0) -> (396.71634,-499.98611)
Block creation point 150.25025,199.975575
Insertion point -0.36109,-198.939574
Scale = 1.99853
Rotation = 089 53 22 (Counter Clockwise)
Typical shift applied -150.61134,-398.91515

Calculating the residuals of Easting of STND Point No. 4:
where x' = ax - by + c1
x'=200.023
a =0.003764
x =300.000
b =1.998714
y =100.000
c1=398.7721
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N/Y(b)
-----99.897
300.000
300.005
100.000

rE/X
---0.1262
-0.5299
0.4063
-0.0026

rN/Y
---0.2489
-0.0018
-0.2001
-0.0471
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x'= (0.003764 x 300.000) - (1.998714 x 100.000) + 398.7721
x'= 1.1292 - 199.8714 + 398.7721
x'= 200.0299
The difference between the computed (200.0299) and the given (200.023) answer is 0.0069,
which is displayed in the transformation spreadsheet as the residual (rE/X).

15.2

Applying A Transformation
If a drawing has been exported to CAD and subsequently requires transformation a block may
be made of the original drawing. The block creation, insertion, scaling and rotation values
given in the report may be used to apply the transformation to a CAD drawing.
Note:
If a significant inappropriate scale, or large residual values, is generated, check your input data.
If you have a large number of points in both systems, try replacing points with large residuals
with other matched points that are near to those points.

15.3

Transformation Report
Sample Tranformation Reports:

2D Affine:
SCC for Windows v7.8.11 (C) 1990 - 2005 Atlas Computers Ltd
Transformation report
Transformation name SQ_2
Date
Wed Dec 06 09:38:21 2006
Transformation parameters are
a = 0.003859
b = 1.998523
c1 = 398.7149
c2 = -499.9900
Where x' = ax - by + c1
y' = bx + ay + c2
Pt
Name
E/X(a)
N/Y(a)
E/X(b)
N/Y(b)
rE/X
rN/Y
------------------------------0
STND
300.000
100.000
200.023
100.000 -0.0026 -0.0471
0
STNC
400.000
100.000
200.000
300.005
0.4063 -0.2000
0
STNB
400.000
150.000
101.010
300.000 -0.5299 -0.0018
0
STNA
300.000
150.000
99.968
99.897
0.1262
0.2489
Block shifting parameters
(0,0) -> (398.71486,-499.98997)
(0,1) -> (398.71872,-497.99145)
(1,0) -> (396.71634,-499.98611)
Block creation point 150.25025,199.975575
Insertion point -0.36109,-198.939574
Scale = 1.99853
Rotation = 089 53 22 (Counter Clockwise)
Typical shift applied -150.61134,-398.91515
SCC for Windows v7.8.11 7 Parameter Transformation report
No Station Obs
aX
aY
aZ
bX
bY
bZ
--- -------- --- ----------- ----------- -------- ----------- ----------- -------0 STND
0
300.000
100.000
10.000
200.023
100.000
20.000
1 STNC
0
400.000
100.000
10.000
200.000
300.005
25.000
2 STNB
0
400.000
150.000
15.000
101.010
300.000
30.000
3 STNA
0
300.000
150.000
15.000
99.968
99.897
25.000
Coordinate residuals
No Station Obs
dX
dY
dZ
dDist(2d)
dDist(3d)
--- -------- --- ----------- ----------- -------- ----------- ----------0 STND
0
0.1334
0.0846 -0.0173
0.1579
0.1589
1 STNC
0
0.5918
-0.2313 -0.0228
0.6354
0.6358
2 STNB
0
-0.6659
-0.1335
0.0173
0.6791
0.6793
3 STNA
0
-0.0593
0.2802
0.0228
0.2864
0.2873
Shifts X:399.345 Y:-499.168 Z:-5.081
Rotation X:002 49 53 Y:001 25 58 Z:089 52 30
Scale:0.50061033
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15.4

National Grid Transformations
Support has been added for national grid transformations between ITM, Irish Grid,
OSGB36 and ETRS89. These transformations utilise Grid Inquest software provided by
Quest Geo Solutions.

16

Alignments

16.1

Entering & Importing Data Into An Alignment
The following briefly examines some of the features within SCC Alignment Module.
In short, SCC Alignment Modules allows for:
· the importing of alignment information from MX
· the importing of horizontal and vertical geometry information from MX
· the importing of horizontal and vertical intersection points from DOER
· the generation of intersection point information from the horizontal and vertical geometry

16.1.1 Getting Alignment Data From MFW into SCC
Import MX GENIO Geometry strings
Set up Project
Open a ‘New Project’ and attach the ‘Default(v9-0-Complex).Project’ template.
Call the project ‘Test Align’.
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Import MX Alignment
Open a blank Alignment file
Go to ‘File > New > SCC Alignment’

A blank horizontal intersection sheet is opened. The alignment information is
imported into this SCC alignment file.
Go to ‘FILE > Import > MX GENIO Geometry strings’

Go to the Tutorials directory and select the GENIO file ‘SIMPLE.CRD’

This file contains horizontal and vertical geometry information.
The 'Select Alignments' dialog allows the user to select a specific alignment
present in the input file
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Select ' GAST' and 'OK'

The horizontal entities sheet is opened and the imported information displayed.

Go to ‘VIEW > Vertical Entities’

Save the alignment as ‘GAST.ALIGNMENT’.

16.1.2 Attaching an Alignment To A Model
Create the MX Model
Go to ‘FILE > Model > MX GENIO file’.
Select the file ‘GROUND.CRD’ from the TUTORIALS directory
Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely
and GENIO L-string processing to ‘Treat as points’.
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Select 'OK'

Set the Initial Plot Scale as '200'
Select 'Create the model and triangulation'

Go to ‘File > Save’
Save the model as ‘Ground.Model’

Attaching MX Alignment
Within the ground model, 'select 'FILE > Attach/Detach > Attach Alignment File'
Select ‘GAST.ALIGNMENT’
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16.1.3 Interactively Editing The Alignment
Within ‘SIMPLE.Alignment’, select ‘DESIGN > Move Alignment'
Click on alignment string with the left mouse button and interactively move the alignment.
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16.1.4 Typing Horizontal Intersection Points
Open 'FGL.Model' from the tutorials directory.

Horizontal Intersection Points
Go to ‘Design > Horizontal Alignment’
Call the new alignment ‘RoadDesign.Alignment’.

©2015 Atlas Computers Ltd

304

The horizontal intersection point information is in a text file. This text file, ‘HIPs.txt’ can be
found in the ‘\SCC\Tutorials\’ directory. Open it in the text editor and print it.
Horizontal Intersection Points
Transition Lengths
E/X

N/Y

Radius 1 Incoming Outgoing

193606.497

375687.288

0

0

0

193612.146

375437.006

400

100

100

193769.208

375136.441

300

100

100

194053.388

375030.792

0

0

0

There are 4 intersection points in this file. The Easting, Northing, and chainage of each
point are defined along with the length of the radius and incoming and outgoing
transitions.
Set the Horizontal Design Action to ‘Add IPs’
Turn Off ‘Create Complex Curves’ option
Type in the information for each of the four intersection points.
(E/X value, N/Y value, Radius 1, Incoming and Outgoing Transition Lengths)
After each point is entered select ‘Add HIP’ at the bottom of the dialog to add the
intersection point to the alignment.
Select ‘Close’ after last intersection point
(By pressing the tab button, the cursor will jump to each entry box in order).
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To view the horizontal intersection points,
Go to ‘Design >View design sheet’, then select ‘Horizontal Intersection Points’.

Save the alignment as ‘RoadDesign.Alignment’
The finished horizontal alignment is shown in the diagram below.
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16.1.5 Typing Vertical Intersection Points
Before creating the vertical alignment, ensure that the horizontal alignment has been
created.
The vertical intersection point data can be found in the ‘\SCC\Tutorials’ directory.
The file ‘VIPs.txt’ can be printed using Word or Notepad and contains all the necessary
information to define a vertical alignment.
Vertical Intersection Points
Chainage

ElevationN/Y

Length

0

15.00

0

245

17.00

100

422

23.00

100

734

25.00

100

872

24.00

0

Continuing from the Design above:
Select ‘RoadDesign.Alignment’ created in the earlier tutorial
From the model window, go to ‘DESIGN >Vertical Alignment’
On the top menu bar set the ‘V.E’ or ‘vertical exaggeration’ to 10
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Set the ‘Vertical Design Action’ to ‘Add IPs’
Select ‘Chainage’ as the ‘Horizontal Component’
Select ‘Elevation’ as the ‘Vertical Component’
Select the ‘Defaults>>’ option
Ensure that the method is set to ‘length’

Enter ‘100.00’ as the default values
Turn off the option to ‘use values entered in vertical design dialog’
Press ‘OK’
Select ‘Length’ as the ‘Curve Parameter’.
Type in the ‘Chainage’, ‘Elevation’ of each vertical intersection point
Select ‘Add VIP’ at the bottom of the dialog after each vertical intersection point
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The default length value of ‘100.00’ will be used to calculate the curve parameters.
The finished vertical design is displayed in the diagram below.

16.1.6 Creating Mulit-Surface Section
Applying a Second Surface to a Section Template
Having designed a horizontal and vertical alignment and a standard section template, one
can now add additional surfaces to a section template.
Open the existing section template from the model ‘Design > Section template’
Select ‘New Surface’ from bottom of the side menu bar
Set up the following surfaces:
45mm Hot Rolled Asphalt Wearing Course to cl. s905
55mm Dense Bitumen Macadam Base Course to cl. s902
120mm Dense Bitument Macadam Road Base to cl. s812
150mm Minimum Granular Material Type B Sub-Base to cl 804
Within Create New Surface dialog enter surface Name ‘c1 s804’
Set ‘000 Top Surface’ as Copy from Surface
Select ‘Do not copy Cut/Fill specific elements’
Accept default ‘From Left Offset’ and ‘To Right Offset’

Enter the relevant ‘Vertical Shift’
Select ‘OK’
Repeat the above steps for ‘c1 s902’, ‘c1 s812’ and ‘c1 905’
Use the Zoom Functions to see the additional new surfaces.
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16.2

Section Template Design On A MX Alignment
The following examines importing and modelling of MX GENIO strings into SCC. In turn
allowing for the attachment of alignment data and subsequent section template design. Long
Sections and Cross Sections are considered as a quality assurance means of examining the
Section Template.

MX GENIO Alignment
Opening Project
Select ‘FILE > Open’
Select ‘Genio-S.Project

Modeling MX GENIO File
Go to ‘FILE > Model > MX GENIO file’
Select the file ‘GENIO_DESIGN.txt’
Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely
and GENIO L-string processing to ‘Treat as points’.

Select ‘Create the model and triangulation’
Select ‘OK’
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Go to ‘FILE > Save As > GENIO_DESIGN.Model’

Taking MfW Geometry strings into SCC
Go to ‘FILE > New > SCC Alignment’

A blank horizontal intersection sheet is opened. The alignment information is imported
into this SCC alignment file.
Go to ‘FILE > Import > MX GENIO Geometry strings’
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Select the file ‘GENIO_DESIGN.txt’
Set the Feature Name field to ‘Use string label’, the GENIO Contours to ‘Ignore’ entirely
and GENIO L-string processing to ‘Treat as points’.

Select 'GC52.Alignment'
Alignment files contain horizontal and vertical geometry information. The horizontal
entities sheet is opened and the imported information displayed.
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Save As 'GC52.Alignment'.

Attaching an Alignment to a Model
Go to ‘GENIO_DESIGN.Model’
Select ‘FILE > Attach/Detach > Attach an alignment file’
Select the alignment'GC52.Alignment
Note by holding the ‘Ctrl’ key allows the user to select several alignment files together
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If we examine ‘GC52.Alignment’ note that the chainage system is available on the bottom
toolbar as the cursor is moved along the alignment.
The option to Move/Edit Alignment under the ‘Design Menu’ is automatically activated.
Within ‘GENIO_DESIGN.Model’, select ‘DESIGN > Move Alignment'
Click on alignment string with the left mouse button and interactively move the alignment.
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Original Horizontal Entities

Automatically updated Horizontal Entities after Alignment was moved within Model

Typing in Section Template Points
The section template design for this tutorial is ‘SectionTemplate.Model’.
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It contains the width and cross fall of each element in the template
Revert back to ‘GENIO_DESIGN.Model’ which has the unedited ‘GC52.Alignment’
attached.
Go to ‘Design > Section Templates’.
Set the ‘Template Design Action’ to ‘Add Points’.
Set Apply to ‘Cut and Fill’
Set the ‘Horizontal Component’ to ‘Width’ and the ‘Vertical Component’ to ‘Gradient’.
Set the Units of measurement for gradients to Percentage %
Ensure that the ‘Unit for Gradients’ is set to ‘percentage %’ within ‘FILE >General Options >
Units and Data Checking’ section.

Centre Line:
Set the ‘Surface’ to ‘TopSurface’ and the Feature ‘CL’
Enter a value of ‘0.00’ for the ‘horizontal and vertical component.
Leave the ‘interface side slopes’ turned ‘off’
Select ‘Add Point’
All horizontal components to the right of the centre line are positive, while all the horizontal
components to the left are negative.

RHS001:
Select ‘Feature > RHS001’
Set the ‘width > 2.00’ and the ‘gradient > –3’.
‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’

R-EDGE:
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Select ‘Feature > R-EDGE’
Set the ‘width > 1.00’ and the ‘gradient > –3’.
‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’

LHS001:
Select ‘Feature > LHS001’
Set the ‘width > -2.00’ and the ‘gradient > –3’.
‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’

L-EDGE:
Select ‘Feature > L-EDGE’
Set the ‘width > -1.00’ and the ‘gradient > –3’.
‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’
The Section Template should be automatically updated within the Model ‘
GENIO_DESIGN.Model’ which has the alignment attached.
However, in this instance no such update take places. Therefore further investigation of
the Vertical Alignment is necessary.
Within ‘GENIO_DESIGN.Model’ which has the ‘GC52.Alignment’ attached.
Go to ‘Design > Vertical Alignment’
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Select ‘DESIGN > Interface And Export Parameters…’
Set up the parameters as follows:

It is clear that one single Section Template is not satisfactory for this Road.
As the Road incorporates a Bridge Crossing it is perhaps more feasible to have a Section
Template specifically for this area. In other words a section template, which does not
have any side slopes.
Note also that from the contours one can deduce there is a need for string editing.
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New Section Templates
Within ‘GENIO_DESIGN.Model’ place the cursor over the bridge edges in order to obtain
Chainage Values (bottom toolbar) to begin Second and Third Section Templates
Go to ‘Design > Section Templates’.
As before Set the ‘Template Design Action’ to ‘Add Points’.
Set Apply to ‘Cut and Fill’
Set the ‘Horizontal Component’ to ‘Width’ and the ‘Vertical Component’ to ‘Gradient’.
Set the Units of measurement for gradients to Percentage %
Select ‘New Surface’ from the bottom left of the screen

Enter the new template starting chainage ’48.00’
Unselect ‘Left Interface Side Slope’ and ‘Right Interface Side Slope’
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Select ‘New Surface’ from the bottom left of the screen

Enter the new template starting chainage ’65.00’
Select ‘Left Interface Side Slope’ and ‘Right Interface Side Slope’ of 50%
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Once the section Template has been created further editing can be carried out with the
Design Sheet.
For instance, editing the starting chainage of a Section Template can be carried out as
follows:

Editing Section Template Points
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Within ‘GENIO_DESIGN.Model’ select ‘DESIGN > View Design Sheet > Section
Template Points’

Changing Section Template 2 starting point from 48.00 to 43.00:
Select ‘EDIT > Replace’
Within the Search Parameters, enter ‘Field to Search’ as ‘Chainage 1’
Enter existing value Lower and Upper Limit Values ’48.00’
Within the ‘Replacement Parameters’ enter the ‘Field to modify as ‘Chainage 1’
Enter ‘New Value’ as ‘43.00’4
The above commands are repeated to changing Section Template 3 starting point from
65.00 to 71.00:
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Applying a Second Surface to a Section Template
Having a horizontal and vertical alignment and a standard section template, the user can
now add additional surface to the section template.
The follow surfaces will be added to the Section Template:
45mm Hot Rolled Asphalt Wearing Course to cl. s905
55mm Dense Bitumen Macadam Base Course to cl. s902
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120mm Dense Bitument Macadam Road Base to cl. s812
150mm Minimum Granular Material Type B Sub-Base to cl 804
Revert to the 'Section Template Design'
Select 'New Surface'
Within Create New Surface dialog enter surface Name ‘c1 s804’
Set ‘000 Top Surface’ as Copy from Surface
Select ‘Do not copy Cut/Fill specific elements’
Accept default ‘From Left Offset’ and ‘To Right Offset’
Enter the relevant ‘Vertical Shift’
Select ‘OK’
Repeat the above steps for ‘c1 s902’, ‘c1 s812’ and ‘c1 905’
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Use the Zoom Functions to see the additional new surfaces.

Exporting Surfaces from Section Template
Surface created within a Section Template can be export as dataset or as model.
Within ‘GENIO_DESIGN.Model’ which has the ‘GC52.Alignment’ attached.
Select ‘DESIGN > Export design as model’
Set up the follow:
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Set ‘GENIO_DESIGN.Model’ as the ‘Existing Ground Surface’
Select surface from the ‘Design Surface to export’ Drop Down Menu
Save the Model
Repeat this step until all Surfaces are exported
‘c1 804.Model’, ‘c1 s812.Model’, ‘c1s902.Model’ and ‘c1 s905.Model’

Sections
Sections can be used as a QA procedure when using the Section Templates.
Within ‘GENIO_DESIGN.Model’ which has the ‘GC52.Alignment’ attached.
Select ‘SECTIONS > Long Section by cursor’
Left click the model to select first point of section, left click the mouse to select end point
and right click mouse to finish.
A more extensive examination of surfaces can be carried out as follows:

Cross Section From Alignment
Within ‘GENIO_DESIGN.Model’ which has the alignment file attached.
Select ‘SECTIONS > Cross Section from An Alignment
Set up the following:

‘Save As > CrossSection GC52.Section’
Please note the Section Annotation and Scale can be assigned within ‘VIEW > Scale,
Titles & Grids’ and ‘VIEW > Annotation Settings’

Appending Surfaces to Sections
Within ‘CrossSection GC52.Section’ select ‘EDIT > Append Surface’
Select ‘c1 804.Model’, ‘c1 s812.Model’, ‘c1s902.Model’ and ‘c1 s905.Model’ by holding ‘
Ctrl’
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Furthermore this allows for volumes by Cross Section to be carried out:

Volumes by Cross Section
Within ‘CrossSection GC52.Section’ select ‘EDIT > Volumes’
Enter a ‘Volume Report File’ ‘c1 s902.txt’
Select ‘Existing Surface’ ‘Top Surface’ and the ‘Proposed Surface’ ‘c1 s902’
Select to ‘Annotate Volumes’ and ‘Highlight Cut and Fill’
Select ‘OK’
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16.3

Getting Intersection Points from DOER
SCC can import alignment information from DOER (the Irish Department of Environment Road
Design package).

16.3.1 Getting Horizontal Intersection Points from DOER
SCC imports horizontal and vertical intersection point information from DOER.
Intersection point information may not be generated from geometric entities.
There is a DOER alignment file (BigRoad.A01) in the \SCC\Tutorials directory.

Exporting Alignment from DOER
Copy this file from this directory into the DOER directory.
From DOS or from a DOS window in NT open DOER.
From the Opening Menu of DOER select the first option ;1 to DESIGN/edit/PRINT
alignments, ground or survey point data.
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The Opening menu of the Design Module is opened.
Select option 2 to edit, process or print an existing alignment via menu “B”.

You will be required to select an existing DOER alignment file. Select the file
BigRoad.A01 from the current directory.
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Once the alignment has been selected the Main Menu for the alignment is opened. Select
option 1 to setup/edit the horizontal alignment via Menu “E”.

Choose option 8 to write ALL horizontal alignment IP data to diskfile DOERHIP.DAT.

The DOER HIP file will be processed and saved in the DOER working directory. Type in
99, to return to the opening menu.
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Exit from DOER by again typing in 99.

Importing DOER Alignment into SCC
Set up Project
Open a ‘New Project’ and attach the ‘Default(v6).Project’ template.
Call the project ‘DOER HIPS_VIPS’.

Import DOER Alignment
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Open a blank Alignment file
Go to ‘FILE > New > SCC Alignment’

A blank horizontal intersection sheet is opened. The alignment information is
imported into this SCC alignment file.
From the File menu, select Import DOER HIPS.
From the DOER directory select the file 'DOERHIP.dat'. The data will be downloaded
directly into this spreadsheet.

16.3.2 Typing Section Template Points
Once a horizontal and vertical alignment has been created, it is then possible to design a
section template.
The section template design for this tutorial may be found as a DXF file in the
\SCC\Tutorials directory.
Import the ‘Section Template.DXF’ file into SCC or CAD and print it.

It contains the width and crossfall of each element in the template.
Revert back to ‘‘FGL.Model’ which has the unedited ‘RoadDesign.Alignment’ attached.
Go to ‘Design > Section Templates’.
Set the ‘Template Design Action’ to ‘Add Points’.
Set Apply to ‘Cut and Fill’
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Set the ‘Horizontal Component’ to ‘Width’ and the ‘Vertical Component’ to ‘Gradient’.
Set the Units of measurement for gradients to Percentage %
Ensure that the ‘Unit for Gradients’ is set to ‘percentage %’ within ‘FILE >General
Options > Units and Data Checking’ section
Centre Line:
Set the ‘Surface’ to ‘TopSurface’ and the Feature ‘CL’
Enter a value of ‘0.00’ for the ‘horizontal and vertical component.
Leave the ‘interface side slopes’ turned ‘off’
Select ‘Add Point’
All horizontal components to the right of the centre line are positive, while all the horizontal
components to the left are negative.
RHS001:
Select ‘Feature > RHS001’
Set the ‘width > 3.75’ and the ‘gradient > –3’.
‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’
R-EDGE:
Select ‘Feature > R-EDGE’
Set the ‘width > 3.00’ and the ‘gradient > –3’.
‘Turn on’ ‘Right Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’
LHS001:
Select ‘Feature > LHS001’
Set the ‘width > -3.75’ and the ‘gradient > –3’.
‘Turn on’ ‘Left Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’
L-EDGE:
Select ‘Feature > L-EDGE’
Set the ‘width > -3.00’ and the ‘gradient > –3’.
‘Turn on’ ‘Left Interface slope’ and set the ‘Gradient > 50%’.
Select ‘Add Point’
The following Section Template has been designed.
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The Section Template should be automatically updated within the Model ‘FGL.Model’
which has the alignment attached.
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16.4

Designing A Fixed Gradient Interface
The following examines the creation of a design interface with 1:3 gradient for given pond data.
Consider that the ‘CL.Model’ contains the pond boundary (‘WATERLINE’ String) and
subsequent pond islands.
A design interface is required to produce a 1:3 gradient from the water edge (boundary string)
to the pond bed (96.1m).
Open Existing Files
Go to ‘FILE > Open’
Open ‘CL.Project’ and ‘CL.Model’

Create Pond Bed Model
Select ‘O’ from the Feature Drop Down Menu

Go to ‘EDIT > Add String with Cursor’
Set the Elevation to ’96.1’

Using ‘Snap Point’ draw a boundary string
Right click mouse, select ‘Drape Coordinates on Surface’
Right click mouse, select ‘Update String in model’
Select ‘Esc’ to unselect command
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Right click mouse, to bring ‘Data Selection Dialog’

Select ‘All points on selected string’
Select ‘OK’
Left click on newly created ‘0’ string

Note selected points highlighted in blue, as shown above.
Go to ‘EDIT > Copy > Copy to New Model’
Save Model as ’96-1.Model’
This string will act as a guide boundary string
Select ‘O’ from the Feature Drop Down Menu
Select to draw a ‘Polygon’ from Toolbar

Draw a Polygon around the boundary string
Set the Elevation to ’96.1’
Right click mouse, select ‘Drape Coordinates on Surface’
Right click mouse, select ‘Update String in model’
This creates a plan at the water level of 96.1
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Save Model

Create Alignment From Pond Boundary (Waterline String)
Within ‘CL.Model’, go to ‘DESIGN > Create Alignment from String’
Enter file name ‘Interface0008’ with a fillet radius of 1.000
Enter the desired gradient

Select ‘OK’
Left click mouse on pond boundary ‘WATERLINE’ string
Save Alignment

Go to ‘FILE > Attach/Detach > Edit/Detach > Detach All’
Select ‘OK’

Open ’96-1.Model’
Go to ‘FILE > Attach/Detach > Edit/Detach > Attach Alignment File’
Select ‘Interface0008.Alignment’
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Go to ‘DESIGN > Export design as model’
Select ‘Chainage Interval’ as 1.000
Select ‘Generate interface strings’, ‘Create boundary from interface string’ and ‘Create
slope signature strings (tadpoles)
Select ‘Design’ as the surface to export
Select ’96-1.Model’ as the existing ground surface using ‘Pick>>’
Set the ‘Chainage Range’ as ‘Entire Alignment’
Select ‘OK’

Save As ‘Design.Model’
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Once the design has been exported, tadpoles can be edited using ‘String Edit’ commands,
for example, Move Points, Delete Points

Merge Model
Open ‘CL.Model’
Go to ‘TOOLS > Merge two model
Using ‘Pick>>’ select the Survey and Design Model
Enter a name for Merged Model

Select ‘OK’

©2015 Atlas Computers Ltd

339

Note:
Separate Designs should be carried out for the islands in the pond, if required.

17

Flow Lines
This functionality allows the user to generate and display flow lines associate sink points from
any 3d model. A flow line is a line that follows the path of steepest descent from a given source
point until it either reaches a local low point or the edge of the model. Source points for flow
lines can either be specified using a regular grid across the model, a coordinate file, or
interactively with the cursor. In addition to generating the flow lines, SCC also identifies all the
confluence points between flow lines, and counts the number of sources meeting at each
junction and arriving at each sink point. This is useful for identifying natural drainage across a
model and designing additional drainage. An example of flow lines based on a regular grid of
source points is shown below;
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Thinner lines illustrate simple flow lines connected to a source point, whereas lines of
increasing thickness show the confluence of multiple flow lines culminating in a sink point. Note
that in this example, slope vectors are also shown to illustrate the downhill direction.

If we zoom into a given sink point we will see it is annotated with an index and count of the
number of input flow lines arrive at this sink.
Flow line functions are available from the ZVI & Flow menu, and include the following options;
Flow lines with cursor

This allows you to select flow line source points
interactively with the mouse

Flow lines from grid

This creates a regular grid of flow line source points across
the entire model.

Flow lines from data set

This creates flow line source points from a SCC coordinate
file.
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Flow line options

This allows you to control the features used to control flow
lines based on the number of incoming flow lines. It is also
used to specify the grid interval used when creating flow
lines from a grid, and control whether sink points are
annotated.

The flow line options are as follows;

18

Flow grid interval

The grid interval used when creating flow line source points
at a regular interval.

Compute cumulative
flows

This controls whether the number of lines that pass through
a given point are counted. This is required is compound flow
lines are to be drawn using different features, but is slower
when generating flow lines.

Local sink feature

The feature code used to draw flow line sink points.

Annotate sinks

This controls whether sink points are annotated with an index
number and counter.

Minimum line count to
display

Flow lines that have less than this number of input lines
passing through them will not be displayed.

Minimum sink count to
display

Sink points that have less than this number of input lines
reaching them will not be displayed

River Sections
The river sections module is designed to offer efficient stream-lined processing steps for
surveyed river data and provides for:
· simultaneous annotation and output of sections with offsets relative to the left most point of
the section, the lowest (or highest) point on the section, and the alignment centre line.
· data output to multiple modelling systems includes ISIS, MIKE, and HECRAS without having
to repeat processing of the sections
The river module functionality assumes that rivers are processed as a series of sections, which
can be collected as a single string per section or as discrete feature coded points. The module
has been designed around the following criteria:

Ease of Use:SCC incorporates the principles river sections settings within a single dialog in
order to limit the number of processing steps required to generate each river section. The
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single river section dialog allows for:
· ground, water and silt surface names to be
defined easily
· sections generation either from points with
similar chainage or using surveyed strings
· section orientation based on surveyed end
points, best fit line through all points or normal
to a defined alignment
· section feature text to be defined as feature
name or remarks from the field
· section ID, left bank and right bank feature
name search options
· water and silt line search options which can
be used to annotation and/or display such
surfaces
· options to extend water and silt line surfaces
to the nearest banks automatically
· automatic surveyed section string direction
correction
· quality controls, reporting and check options
· the selection of predefined cross section and
profile drawing styles

Flexible:
New Section Coding Table allows the user the flexibility to implement existing coding systems
currently in use in the field.
Specific remark codes used in the field can be set up to allow for the automatic generation of
labels / text within the river sections.
Importantly, left bank and right bank can be included to control the extent of the automatic
creation of water level and silt level surfaces on each river section.

Specific String Correction Options:
Automatic correction of string errors from the field provides time saving advantages during
processing. Options allow for the removal of loops from surveyed section strings and/or to set a
preferred string direction at a global level across all sections.

Simple River Centreline Definition:
An existing predefined river centreline or a new centreline reference string can be generated
from which a chainage / offset system can be created easily. The reference string controls
section orientation, section annotation on individual sections and within plan drawings and acts
as an integral part of the required output to modelling systems.

Automatic Water and Silt Surface:
Search options provide for the extraction of water and silt levels which can be used to
extrapolate water edges, silt edges and the ground profile.
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Annotation of water and silt levels can be automatically set up and applied to all sections
together with date and time stamp.

Global Section Text Annotation:
Section Annotation can be globally applied to all sections offering time saving advantages and
limiting user errors.
Text can be customised to suit deliverables.

Simple Drawing Style Applications:
Section presentation can be customised to meet client needs and applied globally with the
application of a drawing style reducing repetitive steps and ensuring continuity throughout a
large project.

Advanced Quality Checks & Reporting:
Quality assurance checks provide invaluable tools to support consistent qualitative section files
and subsequent exported deliverables. Search options for missing text within each section
detail missing text elements whilst survey errors are reported for review and correction. Output
of water levels differences by chainage offers further checks for blunders and gross errors.

Structure Display on Sections:
Surveyed structures can be easily selected from plan and attached to individual sections to
meet specification using simple copy and paste tools.
Specific annotation and text can be inserted manually allowing for customisations.

Advanced Output of Sections to Multiple Modelling Systems:
Sections can be easily output to modelling systems includes ISIS, MIKE, and HECRAS in a
single step.

18.1

Creating Project
A new project should be created before data may be downloaded into SCC or models
formed.
From the Main Menu Bar, select ‘FILE >New Project’
Enter in a Project/Job name
Select a Project Template from the list 'River_Sections.Project'
Select ‘OK’
Note: 'River_Sections.Project' template has been set up to demonstrate the river section
functionality.

Feature Library
Select 'VIEW > Feature Library'
Specific feature codes have been set up in the library which coincide with codes used in
the field.

Section Coding
From within the feature library view, select 'EDIT > Edit Section Coding'
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In this instance, specific remark codes used in the field have been set up to allow for the
automatic generation of labels / text within the river sections. Importantly, left bank and
right bank have been included to control the extent of the automatic creation of water level
and silt level surfaces but also required for HECRAS, ISIS and MIKE formats.
It should be noted that the 'Type' column controls the placement of text on a section /
profile:
· Default - places text as a descender on the section
· Surface - places text on the surface line of the section
· Water - used to annotation the water surface within a section

18.2

Creating River Centreline Model
In order to generate the river section it is necessary to have a defined river centreline.
The centreline can be generated within SCC using string creation tools or can be input
from a CAD, ASCII or MX file.
Select 'FILE > Open > RiverCentreline.Model'
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18.3

River Centreline Alignment
The river section functionality requires a horizontal alignment representing the river centre
line and hence a full SCC design license. Alignments can be created as follows;

Creating Alignment from existing string
Within 'RiverCentreline.Model', select 'DESIGN > Create Alignment from existing string'
Left click on string and enter the following:
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Click 'Ok'
Chainage and offset system is generated and is visible on the base toolbar on the bottom of
the screen
To save alignment, select 'DESIGN > View Design Sheet > Horizontal Entities'
Select 'FILE > Save As' and enter name
'RC.Alignment' is a sample alignment file for use within this tutorial.

Creating Alignment from CAD file or MX file
Existing alignments can be imported as follows:
Imported from a design or CAD package, select 'FILE > New > SCC Alignment'
Select 'FILE > Import > MOSS GENIO geometry strings', or 'FILE > Import > Entities
from DXF'
Using 'FILE > Import > LandXML'

18.4

Downloading Surveyed Section Data
Surveyed section data can be downloaded as follows:
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Select Survey Data Logger and download survey data as per SCC help tutorials

18.5

Examination of Dataset
The dataset should be examined to ensure attribute and text information has been
downloaded correctly. For instance, checks should be carried out to ensure that specific
section codes surveyed in the field have been downloaded in the Text Notes Sheet and
match the codes set up within the Section Coding table, part of the Project file.

Concatenate Multiple Remarks
It should be noted that SCC can concatenate multiple remarks on the same survey point
using the Concatenate multiple remarks tool. For example, observation 123 has two
remarks noted as WALL and STONE within the text notes sheet. To concatenate the
multiple text after download:
Select 'FILE > Coordinate Reduction Options'
Tick Concatenate Multiple Remarks and Press 'OK'
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Within the dataset, select 'FILE > Rebuild Coordinates'
Multiple remarks are text concatenated as shown below:

Note that the feature field on sections is limited to a total of 16 characters.

18.6

Creating Surveyed Section Data Model
The dataset containing the surveyed sections is model as follows:
Go to ‘FILE > Model > SCC Dataset'
Select ‘Create the model and triangulation’ and set Initial Plot Scale of 1000
Select 'FILE > Save As'
For the purpose of this tutorial open 'River_Section_Sample.Model'
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18.7

Attaching River Centreline Alignment to Survey Model
Prior to creating the river section the alignment file should be attached to the surveyed
data model:
Select 'FILE > Attach / Detach > Attach Alignment file'
Pick river centreline alignment file

18.8

Setting Preferred String Direction
If the sections have been surveyed as strings, they can be re-aligned to match the centre
line direction using 'TOOLS > Set preferred string direction', although this is not necessary
for the river sections to be created.
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This option can be run directly from the River Sections dialog using 'Correct reversed
strings'.

18.9

River Section Creation
Before creating the river sections, it is necessary to select all section data. For example, if
one or more feature names have been used the data selection dialog with 'All similar
strings (Same feature)' option selected should be selected.
Within 'River_Section.Model' with the alignment attached, right click the mouse to bring
up the 'Data Selection Dialog'
Pick 'All similar strings (Same feature)' and left click 'SURFACE' feature

Note that data that is not representative of the ground surface, such as water levels and
any structures surveyed, should not be selected. As such, selecting all points in the model
will typically not be appropriate when using this option. To create river sections:
Select 'SECTIONS > River sections to create the sections' which displays the dialog shown
with the following options
For the sample data, set up the following options:
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Specific settings are outlined as follows:

Surface Name for ground surface
This is the name displayed on the section title block for the profile line associated with the
main ground surface.

Surface name for water surface
This is the name displayed on the section title block for the profile line associated with the
water level and extrapolated water surface.

Create sections using points with similar chainage
This option is used when points on surveyed river sections are not collected as strings
defining the section line. In this case, all points within a specified chainage range are
grouped to form a section, and the points on each section are sorted by offset from the
river centre line. This option has the advantage that it allows the user to collect feature
names in the field, e.g. TOPBANK, BOTBANK, etc.. which will automatically be annotated
on the section. It has the disadvantage that section lines should not overlap, as points
may get placed on the wrong section.

Maximum chainage difference between points
This option is the maximum chainage separation allowed between points for them to be
placed on the same section. For example, a value of 2m would indicate that all points on
a section must be within a 2 meter chainage of one another. Note that for skew sections,
i.e. sections not perpendicular to the centre line, this value should be increased to allow
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for the skewing effect. This value should never be greater than half the distance between
adjacent section, e.g. if your sections are 10m apart, this value should not exceed 5.

Create sections using surveyed strings
This option should be used where sections have been collected as complete strings. It
has the advantage that sections can overlap, which can be useful on sharp changes of
direction and small radii in the river centre line.

String corrections
These only apply where the above option has been selected, and relate to automatic
correction of certain survey errors.

Leave strings as surveyed
Do not make any corrections.

Re-string sections based on offset from centre line
This option re-orders the points in the string based on their offset from the centre-line.
This will correct any overlaps, loops and doubling back in the section.

Remove loops from sections
This option removes any loops that occur in plan in the section.

Section Orientation
These options refers to how the section centre lines are formed from the surveyed points
for a given section, which due to the natural constraints of river surveying, will rarely form
an exact straight line.

Skew, based on surveyed end points
The section centre line is formed by joining the leftmost and rightmost survey points. The
survey points are then snapped onto this line when forming the section. This line will
typically not be at exact right angles to the river centre line.

Skew, based on best fit line through all points
The section centre line is formed by creating a best fit line through all the survey points.
The survey points are then snapped onto this line when forming the section. This line will
typically not be at exact right angles to the river centre line.

Normal to alignment, based on mean chainage
The section centre line is formed by computing a mean chainage from all the survey
points, and going at right angles to the left and right of centre-line at that chainage to meet
the leftmost and rightmost offsets of the survey points. The survey points are then
snapped onto this line when forming the section. This line will be at exact right angles to
the river centre line. Note that if the surveyed section is not roughly at right angles to river
centre line, points are liable to be moved significant distances when snapped onto the
centre line, and the section line may be significantly shorter than the surveyed line.

Use Alignment for section offsets
The sections are formed using the offset value of the alignment.

Section Feature Text
This controls how the feature name field in the sections is populated.
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Use feature name
Use the feature name as entered in the survey.

Use remark
Use the remark from the associated survey observation. This is useful when surveying
sections as strings, where all the points on the section have the same feature name for
stringing purposes, but may refer to different items on the section, e.g. Top of bank, edge
of water, etc…

Water line
This group of options refer to the extraction of water level points and extrapolation of a
water surface in the sections produced. Typically this will be a single water level point per
section where the water surface is being automatically extracted, or a string where water
surface has been surveyed directly.

Search for water level near section
Select this option to search for water level points near the surveyed section.

Water level feature
This is the unique feature name, e.g. WLEV, used to denote water levels.

Extend water level on section to nearest bank
When a single water level has been surveyed per section, this option will extend the level
left and right from the surveyed point to the ground profile on the section to form a water
surface.

Silt line
This group of options refer to the extraction of silt level points and extrapolation of a silt
surface in the sections produced. Typically this will be a several silt level points per
section where the silt surface is being automatically extracted, or a string where silt
surface has been surveyed directly.

Search for silt level near section
Select this option to search for silt level points near the surveyed section.

Silt level feature
This is the unique feature name, e.g. SILT, used to denote silt levels.

Extend silt level on section to nearest bank
When silt level points have been surveyed per section, this option will extend the levels left
and right from the surveyed point to the ground profile on the section to form a silt surface.

Search distance for IDs, water and silt levels
This is the maximum allowable distance from the IDs, water and silt levels to the section it
will be placed on.

Section ID feature
Section ID picked up the field are extracted and used to label individual sections.
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Section Type feature
Section Type picked up in the field are extracted and used for annotation and export
purposes.

Left Bank Feature
Left Bank feature is used for annotation and export purpose. It is also used to control the
extent of the Water and Silt level surfaces.

Right Bank Feature
Right Bank feature is used for annotation and export purpose. It is also used to control
the extent of the Water and Silt level surfaces.

Search all text in model for missing IDs and types
This quality check examines each section for missing IDs and types. Errors are reported
in a text file.

Check and report for survey errors in sections
This quality check examines each section for survey errors. Errors are reported in a text
file.

Correct reversed sections
This option re-aligned sections to match the centre line direction. This option overcomes
issues relating to section having been surveyed in a 'zig-zag' fashion and also address
problems arising from left and right bank being incorrectly surveyed.

Report water level differences by chainage
This quality check option allows the water level difference to be reported based on
chainage values.

Cross Section drawing style
This option allows the user to select a predefined section style.

Profile drawing style
This option allows the user to select a predefined section style.

Feature >>
This option links to the Extended Field Code table.

The cross section and profiles are generated as shown below:
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Cross Sections:
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Profile:

18.10 Displaying Structure On Sections
Structures and other detail can be copied from plan into section as shown below:
Select the required points to copy onto a given section using the data selection tools
Select 'EDIT > Copy > Copy to clipboard'
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Switch to your section view

Select 'EDIT > Paste'
When prompted enter the surface name that the data will be associated with, e.g.
structures, and whether or not the points will be annotated.
Click on the section you would like the data drawn on.

Note that data copied from plan to section in this manner is projected onto the section.
Therefore if a line is copied that is not parallel to the section from plan, it will appear
shorter in the section as it is the projected distance on view. The active alignment can be
used to match offsets between plan and section where required, if not, the distance from
the leftmost edge of the section will be used.
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18.11 River Section Annotation
Section Annotation can be controlled within 'VIEW > Annotation Settings':

Specific settings can be selected within the Type drop down menu to suit the required
output.
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18.12 River Section Scale Titles & Grids
The following notes common annotator for river section. Such annotator can be selected
from 'VIEW > Scale, Titles & Grids'

Chainage
The alignment chainage at the point where the river section, i.e best fit line through the
survey points, cuts the alignment centre line.

River Chainage
The alignment chainage at the point where the surveyed section string cuts the alignment
centre line

Diff Ch
The difference in chainage between this section and the next section (e.g. chainage value
used in ISIS output)

Offset
The distance on the section from the leftmost point. Note that river sections are always
displayed such that the left bank is on the left of the right bank regardless of the alignment
direction or order in which the section string was surveyed. These values are always
positive and always start from zero.

River offset
The distance from the current point on the section to the lowest point in the river bed,
which is calculated as the point of lowest elevation between the left and right banks.
Points to the left of the lowest point in the river bed have negative offsets, whereas those
to the right have positive offsets.

Skew angle
The angle at which the section deviates from the alignment normal.
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18.13 Editing Sections Using Query & Edit Function
Sections can be manually edited using the 'Query & Edit Function'. This allows the user to
set bank positions, and ISIS / MIKE & HECRAS specific values within any given section
and to correct survey errors.
For example, specific users may require the option to define the lowest point between
banks on a specific section at processing stages.

18.14 Exporting to Modelling Packages: ISIS, MIKE and HECRAS
These fields are also available under the Crystal Reports outing and user defined ASCII
export, with sample format files available for modelling packages such as ISIS and
HECRAS.
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HEC-RAS
BEGIN STREAM NETWORK:
ENDPOINT: 11755.013,10465.386,0.000,1
ENDPOINT: 11767.636,10212.144,0.000,2
REACH:
STREAM Id: River_Section_Sample (River sections)
REACH Id: Reach 1
FROM POINT: 1
TO POINT: 2
CENTERLINE:
11755.013,10465.386
11534.492,10066.627
11909.390,10161.459
11828.978,10191.503
11767.636,10212.144
END:
END STREAM NETWORK:
BEGIN CROSS-SECTIONS:
CROSS-SECTION:
STREAM ID: River_Section_Sample
REACH ID: Reach 1
STATION: 0.000
BANK POSITIONS: 0.341,0.351
CUT LINE:
11561.147,9726.411
11948.879,11204.361
SURFACE LINE:
11561.147,
9726.411,
11563.967,
9737.158,
11566.441,
9746.592,
11568.995,
9756.324,
11571.392,
9765.463,
11573.691,
9774.226,
11576.402,
9784.561,
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72.681
72.397
71.924
71.616
71.246
71.088
71.129

361
11578.921,
11581.472,
11583.843,
11586.344,
11588.795,
11591.409,
11593.867,
11596.305,
11598.788,
11601.506,
11604.352,
.........
END

9794.161,
9803.885,
9812.923,
9822.457,
9831.798,
9841.761,
9851.132,
9860.426,
9869.891,
9880.251,
9891.098,

71.132
71.176
71.254
71.204
71.034
71.015
70.816
70.542
70.612
70.509
70.350

CROSS-SECTIONS:

ISIS
River_Section_Sample (River sections)
#REVISION#1
5
0.750
0.900
0.100
20.000
0.010
0.010
0.700
RAD FILE
END GENERAL
COMMENT
0
RIVER [VTX]
SECTION
10:00:00 2011-09-09
0.000
175
0.000
72.681
11.111
72.397
20.864
71.924
30.925
71.616
40.374
71.246
49.434
71.088
60.118
71.129
70.044
71.132
80.096
71.176
89.440
71.254
99.297
71.204
108.954
71.034
119.254
71.015
128.941
70.816
138.550
70.542
148.336
70.612
159.047
70.509
170.261
70.350
179.585
70.266
182.300
70.203
184.773
70.556
186.689
70.598
197.906
70.169
210.304
69.970
224.846
69.930
245.081
69.969
260.986
69.956
273.086
70.223
284.540
70.240
295.899
70.253
305.817
70.147
316.464
70.066
327.493
70.064

0.001
0.100

12
0.700

0.000

11561.15
11563.97
11566.44
11568.99
11571.39
11573.69
11576.40
11578.92
11581.47
11583.84
11586.34
11588.79
11591.41
11593.87
11596.31
11598.79
11601.51
11604.35
11606.72
11607.41
11608.03
11608.52
11611.37
11614.51
11618.20
11623.34
11627.37
11630.44
11633.35
11636.23
11638.75
11641.45
11644.25

9726.41
9737.16
9746.59
9756.32
9765.46
9774.23
9784.56
9794.16
9803.89
9812.92
9822.46
9831.80
9841.76
9851.13
9860.43
9869.89
9880.25
9891.10
9900.12
9902.74
9905.14
9906.99
9917.84
9929.83
9943.90
9963.47
9978.85
9990.56
10001.64
10012.62
10022.22
10032.52
10043.18

0.0001
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060

1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
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338.876
349.581
360.443
370.113
380.416
391.959
402.808
413.339
426.395
438.595
449.370
458.598
461.879
461.942
467.823
480.240
480.300
494.073
500.383
505.572
510.106
514.510
518.624
519.500
520.462
521.208
521.830
522.891
523.734
524.297
525.189
526.726
528.660
530.829
532.337
533.681
534.604
536.045
536.780
538.266
539.823
540.979
544.788
547.940
549.442
550.911
551.918
554.661
........

70.058
69.904
69.990
69.984
69.885
69.892
70.217
70.461
70.087
69.909
69.705
69.650
69.629
69.626
69.740
69.537
69.542
69.588
69.825
70.214
70.580
70.764
70.701
70.619
70.578
70.448
70.206
69.554
69.268
68.702
67.409
66.910
66.972
67.304
67.828
68.119
68.574
69.934
70.030
70.013
69.939
70.420
71.830
71.198
70.649
70.173
69.765
69.715

0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.040*
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.040
0.060*
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060
0.060

1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000LEFT
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000RIGHT
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000
1.000

11647.14
11649.86
11652.61
11655.07
11657.68
11660.61
11663.36
11666.03
11669.35
11672.44
11675.18
11677.52
11678.35
11678.37
11679.86
11683.01
11683.03
11686.52
11688.12
11689.44
11690.59
11691.71
11692.75
11692.97
11693.22
11693.41
11693.57
11693.83
11694.05
11694.19
11694.42
11694.81
11695.30
11695.85
11696.23
11696.57
11696.81
11697.17
11697.36
11697.74
11698.13
11698.42
11699.39
11700.19
11700.57
11700.94
11701.20
11701.90

10054.19
10064.55
10075.06
10084.41
10094.37
10105.54
10116.03
10126.22
10138.85
10150.65
10161.07
10170.00
10173.17
10173.23
10178.92
10190.93
10190.99
10204.31
10210.42
10215.43
10219.82
10224.08
10228.06
10228.91
10229.84
10230.56
10231.16
10232.19
10233.00
10233.55
10234.41
10235.90
10237.77
10239.86
10241.32
10242.62
10243.52
10244.91
10245.62
10247.06
10248.56
10249.68
10253.37
10256.42
10257.87
10259.29
10260.26
10262.92

INITIAL CONDITIONS
label
?
flow
stage froude no velocity
umode
ustate
z
10:00:00 2011-09-09 y
0.000
0.000
0.000
0.000
0.000
0.000
0.000
123456
y
0.000
0.000
0.000
0.000
0.000
0.000
0.000
13123
y
0.000
0.000
0.000
0.000
0.000
0.000
0.000
123456
y
0.000
0.000
0.000
0.000
0.000
0.000
0.000
10:00:00 2011-09-09 y
0.000
0.000
0.000
0.000
0.000
0.000
0.000
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MIKE
River_Section_Sample (River sections)
River_Section_Sample (River sections)
0.000
COORDINATES
0
FLOW DIRECTION
0
DATUM
0.00
RADIUS TYPE
2
DIVIDE X-Section
0
SECTION ID
10:00:00 2011-09-09
INTERPOLATED
0
ANGLE
0.00
0
RESISTANCE NUMBERS
2 1
1.000
1.000
1.000
PROFILE
175
-526.726
72.681
0.060
<#0>
-515.614
72.397
0.060
<#0>
-505.861
71.924
0.060
<#0>
-495.800
71.616
0.060
<#0>
-486.351
71.246
0.060
<#0>
-477.292
71.088
0.060
<#0>
-466.608
71.129
0.060
<#0>
-456.682
71.132
0.060
<#0>
-446.629
71.176
0.060
<#0>
-437.286
71.254
0.060
<#0>
-427.429
71.204
0.060
<#0>
-417.772
71.034
0.060
<#0>
-407.471
71.015
0.060
<#0>
-397.784
70.816
0.060
<#0>
-388.175
70.542
0.060
<#0>
-378.390
70.612
0.060
<#0>
-367.679
70.509
0.060
<#0>
-356.465
70.350
0.060
<#0>
-347.140
70.266
0.060
<#0>
-344.426
70.203
0.060
<#0>
-341.952
70.556
0.060
<#0>
-340.037
70.598
0.060
<#0>
-328.820
70.169
0.060
<#0>
-316.422
69.970
0.060
<#0>
-301.880
69.930
0.060
<#0>
-281.645
69.969
0.060
<#0>
......

1.000

1.000

18.15 Exporting Text To GIS Attributes: Shape Files
River IDs can be converted into GIS attributes which can be exported to shape files. The
steps to do this are as follows;
Set up your GIS layer for features which are required for export, for example, set the GIS
layer for SURFACE to RIVERS.
Process the river sections as normal
Select all river sections and all ID points
Select 'EDIT > Text > Copy text to GIS attributes' using the parameters below
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Select 'FILE > Export > Shape File'

18.16 River Section Displayed on Model
To display the position of section lines in plan:
In the model use 'FILE > Attach/Detach > Attach Section file'.
Chainage can be annotated in plan by modifying the Chainage annotator on the ‘~SECT_T
’ feature.
Select 'VIEW > Feature Annotation'
Pick ‘~SECT_T’
Press 'Edit Feature>>'
Press 'Text Annotation>>'
Set the value of Display, Remark and Chainage to Text On.
Alternatively, this can be set up in your feature library template, such that it is the default
behaviour when attaching sections.
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19

Blunder Detection And Analysis
SCC supports blunder detection and analysis in traverses and networks. This works in three
stages as follows;
· Observed values, including angles and distances, are compared to computed values
between known stations. For example, where you have an observed distance between two
known stations, and a join distance computed from coordinates between the same stations, a
difference in distance is calculated. If this difference exceeds a user defined tolerance a
measurement blunder is considered to have occurred.
· Multiple observed values, including angles and distances, are compared for similarity. This
could be the same observation, for example two observations from STNA to STNB, or a
reverse observation, for example one from STNA to STNB and the other from STNB to
STNA. Where differences between similar observations exceed a user defined tolerance a
measurement blunder is considered to have occurred.
· Provisional values for unknown stations are computed, and differences between observed
values and computed values are calculated for these provisional stations.
Where blunders are detected, you have three options to deal with how they are processed as
follows;
· Take no action, simply highlight the blunder observations such that they can be edited
manually.
· Mark the blunder observations to be excluded from the adjustment. In the case of networks
or traverses with significant redundancy, this allows for the adjustment to be completed with
minimal editing required.
· Rename the sighted station using a suffix, such that you will have multiple adjusted station
values for blunder observations, e.g STNA, STNA(1), STNA(2), etc... This can be useful in
situations where the sighted station name has inadvertently been re-used for more than one
physical station.
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There is also an option to automatically correct probable station naming errors, which account
for a large proportion of typical blunders. This is done by comparing similar observations for a
likely match, and failing that, calculating a provisional coordinate for the sighted station and
comparing it to known stations.
The blunder analysis routines are available in the traverse observation view, under Edit /
Blunder detection. The parameters are as described above, and on running the blunder
detection and analysis, you’ll be given the option to view a detailed report of the results.
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The report is broken down into a summary, comparison between observations and
known coordinates, comparisons between similar observations, and comparison
between observations and computed provisional coordinates.
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Where the option to fix station naming errors has been selected, fixed observations will be
highlighted in green. In all other cases, the differences will be written back to the traverse
observation sheet in the residual columns, and the traverse observation sheet layout will be
changed to show these values.

Pressing F4 in this view moves you to the next blunder detected, and pressing F5 brings you
back to the default observation layout and may be used to cycle through other layouts. Note
that each stage of the blunder detection and analysis clears down the residual values, so if you
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wish the view the results from any given stage, maek sure that subsequent stages are not
enabled.

The blunder detection also checks that provisional values can be calculated for all sighted
stations. If this is the case, it should be possible to successfully adjust the traverse, although
careful attention should be paid to the output report, as a significant amount of information may
have been removed.
When updating the station coordinates, you now also have the option to store the resultant
stations as free, provisional, or fixed. This is useful when working with a traverse spanning
multiple jobs, where you wish to carry out the blunder analysis seperately on each job, but need
to carry coordinates between jobs in order to be able compute the results. The traverse report
now also details how each provisional coordinate was computed, which can be either by direct
trigonometry, resection, or intersecting rays.
An additional option to use high performance matrix processing libraries for working with very
large networks is available. This is available under File / General options / Use high
performance matrix libraries. Note that for very large networks, memory is also likely to be a
limitation, as calculation involves matrices based on the square of the size of the number of
observations. Thus 8,000 total station sightings would give us 8000 distances and a slightly
smaller number of angles, resulting in matrix sizes of ~ 15,000 x 15,000 or ~1.8gb of memory.
This would need to be either reduced or broken down into a number of smaller jobs. Networks
including < 2,000 observations should be accomodated by most 32 bit PCs, and < 4,000 is
advised for 64 bit PCs.

20

Rail

20.1

Wriggle Survey Processing
Wriggle survey functionality which can be accessed as follows;
'FILE > Import > ASCII Wriggle Survey' from the main project control view
'TOOLS > Compute Wriggle Survey from the survey coordinates view'
'TOOLS > String using Chainage > Offset from the survey coordinates view'
This is used in conjunction with an alignment to group point data into rings.
To process the sample files 9961065.ASC, 200_UPLINE-.CAN, 200_UPLINE-.HOR and ,
200_UPLINE-.VER do the following;

Create a new project
'FILE > New Project
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Create an alignment from the 200_UPLINE files
'FILE > New > SCC Alignment'
'FILE > Import > ACT horizontal entity file, picking 200_UPLINE-.HOR'
'FILE > Import > ACT vertical entity file, picking 200_UPLINE-.VER'
'FILE > Import > ACT cant file, picking 200_UPLINE-.CAN'
'FILE > Save As 200_UPLINE'
'FILE > Close'

Import the ASCII survey file
'FILE > Import > ASCII Wriggle Survey, picking 9961065.ASC'
'FILE > Save'

Compute the wriggle survey
'TOOLS > Compute Wriggle Survey', using parameters shown and pick
'WriggleSurvey.RPT' as the report file

This will compute the wriggle survey and show the following report.
Note:
· that with bearing and gradient computed from ring data, the alignment is not used in the
computations. It is still used in the report to show the difference between bearing and
gradient values computed via linear regression and those computed for the alignment.
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· the contact details in the report are taken from 'FILE > General Options > Module
Licenses > Edit user details'. The layout and content of the report can be modified to
suit individual client needs independently of SCC using Crystal reports XI or later.
Results from the SCC viewer can be saved into Microsoft Excel for further analysis by
pressing the export button on the top left of the viewer. This also supports a wide range
of other formats included Word, PDF and ODBC database tables.
When comparing the results with the output file provided, 9961065.out, SCC is producing
identical radii, and horizontal and vertical offsets that agree to within 1mm. The easting
and northing of the centres deviate by ~10mm to 30mm but looking at the radial residuals,
e.g. the difference between the final computed radius and distance from computed centre
to each point, I believe the SCC result is more accurate. I say this because the sum of the
residuals in the SCC report is smaller than those in the output report provided, indicating a
slightly better circle fit. For example on ring 1, both routines agree a radius of 3.574, and
the residuals are as follows;
9961065.out

SCC

Point

Radius

Residual

Radius

Residual

1099601

3.578

0.004

3.579

0.005

1099602

3.584

0.010

3.584

0.010

1099603

3.567

-0.007

3.567

-0.007

1099604

3.565

-0.009

3.566

-0.008

1099605

3.579

0.005

3.579

0.005

1099606

3.579

0.005

3.579

0.005

1099607

3.577

0.003

3.577

0.003
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1099608

3.561

-0.013

3.571

-0.003

Sum of square of residuals
0.056

0.046

We can see from this that the SCC centre is a slightly better fit for the data provided.

Case Study Data
To process ascii compiler-1.csv, 300DOWNLINE-.HOR, 300DOWNLINE-.VER, and
300DOWNLINE-.CAN do the following
1) Create a new project as described previously
2) Import the ACT alignment files into SCC as described previously
3) Select 'FILE > Download Survey' picking ascii compiler-1.csv using the parameters
shown below

Select 'VIEW > Detail Coordinates'
4) To group the data into rings, select 'TOOLS > Compute Chainage,Offset from X,Y'

'TOOLS > String using Chainage & Offset'

©2015 Atlas Computers Ltd

373

'FILE > Save'
5) Compute the wriggle survey as described previously, picking the 300 downline
alignment file to get the following report

Notes from the results;
The computed bearing and gradient shown by SCC are ~180 degrees off the alignment
value for the same section. This could be corrected using the alignment if required.
Without an alignment the orientation of the section is arbitrary and can flip by 180
degrees, which also reverses the gradient.
It doesn’t affect the centre, radius or offset values.
Comparing the results to those supplied in 320 wriggle analysis.xls all the radii in SCC are
exactly 50mm smaller which appears to correspond to the BFC from DTA radial value and
Lining radial value in the xls file. Horizontal and vertical offsets appear to agree to with
about 2mm but centres are differ by ~50-60mm. This could possibly be related to radial
offsets. Re-computing using alignment bearing and gradients does not appear to make a
significant difference to this, though further investigation is probably required.
The xls provided appears to have a limit of size points per ring, though this could just be a
reporting anomaly.

20.2

String Comparison & Overlap Processing
String comparison and overlap processing option are available within the model view under
'DESIGN > Compare strings and remove overlaps'. This requires a model with one or more
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overlapping strings, and an alignment for reference purposes. The following is an example of
the usage of this function based around the sample data provided;

Create Project And Import Data
Create a new project, via 'FILE > New Project, or open an existing project
Create a model from the DXF files provide
'FILE > Model > DWG> DXF file' and select 'DM with compensation.dxf'
'TOOLS > Add strings from file DWG > DXF file', and select 'DM without
compensation.dxf'

Create Alignment
Create a new alignment from existing centreline for analysis purposes
'DESIGN > Create alignment from existing string'
Pick LINTRACK, string 1
Select Create alignment from straights and fillet arcs and press Ok

String Analysis
Select strings for analysis
Zoom into area 1009,1356
Right click to bring up data selection dialog
Select All points on selected string, Ok
Pick the three strings as shown

Select 'DESIGN > Compare strings and remove overlaps', using the parameters shown.

These parameters work as follows;
· Horizontal and vertical tolerances are used to determine the scope of the search.
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· Points that are further away from each other that this are not considered for
comparison.
· Report only is used to generate a comparison report, but will not change the model.
· Interpolate all points on all strings is use to generate additional comparison points at
chainages where a point exists on one string under analysis but not others. It is typically
useful where the same part of the same string has been surveyed more than once, but
the surveyed points are at different locations.
Press Ok to perform the analysis and pick a report.

Note that two standard reports have been added to SCC to support this option as
follows;

String Overlaps (all).rpt shows all points used in the comparison alongside their
generated average positions. Any differences greater than 1mm in horizontal or vertical
are highlighted in red.
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String Overlaps (Diffs).rpt only shows points where the difference exceeds either 1mm
in the horizontal or vertical.
Following on from the analysis, we can see that the overlapping strings have been
replaced with a single averaged string.
Note:
Report titles and logo relating to user details can be controlled throughout SCC using
'FILE > General options > module licenses > user details.

20.3

Lift And Slue Reporting
This tutorial gives an example of how to use the lift and slue reporting functionality.
This involves comparison of a design model with a survey model for left (vertical
separation) and slue (lateral separation) on nominated left and right rails. It also
computes cant a gauge between left and right rails, and reports any failures to meet
tolerance in cant. To demonstrate this functionality, do the following;
Import GENIO files to create a design model, a survey model, and an
alignment.
'FILE > Model > MOSS GENIO file' picking C:\SCC\Lift and Slue\Example1 DESIGN.TXT
'FILE > Save > Design.Model'
'FILE > Model > MOSS GENIO file' picking C:\SCC\Lift and Slue\Example1 SURVEY.crd
'FILE > Save > Survey.Model'
'FILE > New > SCC Alignment'
'FILE > Import > MOSS GENIO geometry strings' picking C:\SCC\Lift and
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Slue\Example1 - DESIGN.TXT
Pick MC02 as the alignment string to import
'FILE > Save > MC02.Alignment'

Rail Lift And Slue Analysis
Open the design model,
Pick 'DESIGN > Report rail lift and slue'
Select the files which have just been created and the design and survey strings to analyse.

Reporting Rail Lift And Slue
When prompted, pick 'Rail lift and slue.rpt' from the reports list.
This will produce a report as shown below. The report is broken down into separate
sections for lift and slue values between survey and design for left and right rails, cant and
gauge between rails with any values outside tolerance highlighted in red, and surveyed
6/10 foot.
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20.4

Rail Cant Computations
Separate design sheet views for road super elevation and rail cant are available, and includes
low rail cant calculations based on curve directions. This can be demonstrated using the a
LandXML file including rail cant, such as readings.pax.land.xml. To process this file and check
the results, do the following;

Create A New Project
Create a new SCC project

Import LandXML Files
'FILE > Import > LandXML' and pick readings.pax.land.xml as the input file.
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To view the cant stations, select VIEW > Rail Cant, which will show the following, which
agrees with the LandXML values.

Checking Gauge And Cant
To check the gauge and cant, select 'DESIGN > Enter Gauge and compute Cant'. The
gauge will have been read in from the LandXML file in this case, so you simply enter the
feature names and offsets for left and right rails, as shown in the dialog below.

This option will also produce a report listing the cant stations, and applied cant values on
either rail at a regular chainage interval. The chainage interval can be specified using '
DESIGN > Interface and export parameters'.
Rail cant check report
Date: Wed Aug 11 11:54:32 2010
Alignment: base readings.pax
Gauge: 1.500

Left Rail:LRAIL Offset 0.000

Right Rail:RRAIL Offset 1.500

Chainage

CL Height

L.Cant

R.Cant

L.Height

R.Height

Direction

----------

----------

-------

-------

----------

----------

----------

9860.000

99.169

+0.000

+9.844

99.169

99.178

Left (CCW)

9870.000

99.126

+0.000

+8.111

99.126

99.134

Left (CCW)

9880.000

99.077

+0.000

+3.156

99.077

99.080

Left (CCW)

9890.000

99.013

+6.547

+0.000

99.020

99.013

Right (CW)

9900.000

98.938

+18.707

+0.000

98.957

98.938

Right (CW)

9910.000

98.873

+16.969

+0.000

98.890

98.873

Right (CW)

9920.000

98.828

+19.726

+0.000

98.848

98.828

Right (CW)

9930.000

98.778

+20.626

+0.000

98.799

98.778

Right (CW)

9940.000

98.707

+21.350

+0.000

98.728

98.707

Right (CW)

9950.000

98.642

+18.360

+0.000

98.660

98.642

Right (CW)

9960.000

98.598

+21.790

+0.000

98.620

98.598

Right (CW)

9970.000

98.532

+23.403

+0.000

98.556

98.532

Right (CW)

9980.000

98.500

+30.983

+0.000

98.531

98.500

Right (CW)

9990.000

98.482

+34.832

+0.000

98.517

98.482

Right (CW)

10000.000

98.438

+33.475

+0.000

98.472

98.438

Right (CW)

Cant Stations
Chainage

Cant

Direction

----------

-------

---------

9857.035

+10.669

Left (CCW)

9864.255

+8.661

Left (CCW)

9871.057

+8.010

Left (CCW)
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9884.879

+0.508

Right (CW)

9892.152

+9.086

Right (CW)

9898.901

+19.766

Right (CW)

9905.943

+12.978

Right (CW)

9912.923

+19.845

Right (CW)

9926.657

+19.614

Right (CW)

9933.803

+21.776

Right (CW)

9940.840

+21.292

Right (CW)

9954.909

+16.788

Right (CW)

9961.805

+23.564

Right (CW)

9968.853

+22.139

Right (CW)

9975.754

+29.744

Right (CW)

9982.833

+31.809

Right (CW)

9989.718

+34.964

Right (CW)

9996.593

+31.754

Right (CW)

9999.818

+33.451

Right (CW)

10004.996

+34.120

Right (CW)

SCC for Windows v9.10.0

(C) 1990 - 2010 Atlas Computers Ltd

Pressing the create template, will create a simple design template consisting of just the two
rails. This can be viewed as a spreadsheet using 'VIEW > Section template points'

or graphically via 'DESIGN > Section templates'
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A cant graph can also be viewed with the profile using 'DESIGN > Vertical design'.
N.B. use the V/ E controls to change the vertical exaggeration.

On the vertical design view, the status bar shows instantaneous cant at the cursor
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position, along with chainage, profile height, gradient and curve direction.
The cant at a given chainage is linearly interpolated based on the surrounding cant
stations. For a given chainage and horizontal offset, if the cant direction is right >
clockwise, the cant is given as
G = Interpolated cant > gauge
C = (Right rail offset – horizontal offset)*G
If the cant direction is left > ant-clockwise, the cant is given as
G = Interpolated cant > gauge
C = (horizontal offset - Left rail offset)*G
The design height for that chainage and offset is calculated as sum of the profile height at
that chainage, the vertical offset in the template string point (e.g. 0 for the rails), and the
cant as computed above. This is the same for all surfaces in the alignment.

20.5

Amberg Trolley Data
An input routine to support the Amberg Trolley data provided. This creates two points per line,
one for left rail, one for right rail, using the station for string number and ident for point number.
D1,D2, and D3 are used to store odometer, gauge, and super-elevation in the input file, such
that they can be annotated as required. The rail features are named LRAIL and RRAIL. Note
that the user defined ASCII input was limited to 255 characters per line, which I have now also
changed to a maximum of 4096 characters per line. The new import is available from the Main
Project > Station View, under 'FILE > Import> Export > Import Amberg Trolley data'

20.6

Wriggle Survey From Point Cloud Data
This note covers the steps required to create a wriggle survey from a scanned tunnel in order to
ascertain the circularity of the tunnel and produce an accurate best fit alignment through the
tunnel. The stages are as follows;

20.6.1 Setting Analysis Of Data
Open the tunnel project and model, and use the point cloud editing tools to separate tunnel wall
data other scanned data within the tunnel. Set the analysis of data that is not part of the tunnel
wall to Display only.
'FILE > Open', Open Project
'FILE > Open', Open Model
Right click to bring up the point cloud data selection dialogue, and select option to isolate
an area 10 metres either side of the selected centre line. Set the section offset interval to
20m and press Isolate points
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Select two points either side of tunnel roughly 90 degrees to the tunnel wall.

This will show an elevation through the tunnel, with a depth 10 metres either side of the
centre line. The up and down arrows can be used to move the area displayed up and
down the tunnel, and pressing 'P' or 'E' can be used to flip between plan and elevation.
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Right click the mouse button to bring the data select dialog up again, and this time select
'All points in a polygon' and press the Select points button.
Left click to place points on a polygon that encloses the points we want to exclude from the
wriggle analysis.
Right click to close the polygon and highlight the selected points

Use 'CLOUD > Edit selected points' to change the feature of the selected points to
'OTHER'. Repeat this to separate out all other points on the inside of the tunnel.
Use 'CLOUD > Point cloud features' to set the analysis type of 'OTHER' to be 'Display
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only', such that these points will not be included when creating sections.

Use 'FILE > Save' to save this model under the new name of 'XXX (edit 1).Model'

20.6.2 Setting Arbitary Centreline
Create an arbitrary centreline through the tunnel. This will be used to cut sections through the
tunnel and should roughly follow the tunnels plan position and gradient.
Select 'VIEW > Coordinate computations'
Isolate a vertical section through the tunnel at one end of the tunnel as described
previously, but make the area narrower by specifying a minimum offset of -1 and a
maximum offset of 1.
Select 'TOOLS > Measure > Triangle, areas, centres and gradient'
Pick three well separated points on the tunnel wall to generate a circumcircle as shown.
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The coordinates for the triangle and circumcentre will be shown in a coordinate
computations spreadsheet at the bottom of the screen.
Repeat these steps for another circle at the middle of the tunnel, and a further one at the
far end.
Press escape to close the triangle measurement dialog, and P to return to plan view.
Right click to bring up the data selection dialog, select All points in cloud and press Enable
points to turn all the points back on again.
Select 'EDIT > Add strings with cursor'
Select the first CIRCUMCENTRE point from the computed coordinates and press Output.
Repeat for the other two CIRCUMCENTRE points

Right click and select Save string as interface from the pop-up menu. This create a 3d
alignment that passes through the three points.
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20.6.3 Cutting Sections
Cut sections at the desired interval through the tunnel, such that there is a section at every
position where the tunnel changes direction or gradient. If the tunnel is not horizontal, these
can be oblique sections rather than vertical cross sections
Select 'SECTIONS > Cross sections from an alignment'.
In this case, we're cutting sections every 1.4m on the basis that the tunnel direction can
vary at any keystone on the tiled wall.

Visually check that the sections don't include any data that does not relate to the tunnel
wall.
Use right click to use a window to select unwanted points, followed by 'EDIT > Delete /
Delete points' to get rid of those points.

Use 'EDIT > Delete / Delete sections' to remove any sections that do not include enough
data to contribute meaningful results to the wriggle survey.
This will typically be areas that do not include enough scan data to create a section or
areas where the tunnel is not circular.
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Export the sections sections to a survey data set, which will be used as the input to the
wriggle analysis.
Select 'FILE > Export sections > Survey data set'

In the coordinate spreadsheet, select 'TOOLS > String using chainage and offset', such
that the wriggle survey will have all the contents of a single section as input for each ring.

'FILE > Save As' Wriggle input

20.6.4 Wriggle Analysis
Run the wriggle analysis to produce a report, sections and new alignment.
Select 'TOOLS > Compute wriggle survey' using the parameters shown. If we do not
know the initial design radius, we can enter the mean value from the circumcircles
computed previously.
Providing an outlier distance means that once the analysis is initially carried out, any
outliers with a distance outside the the value specified will be removed and the analysis
repeated.
The deformation tolerance is used for reporting purposes, where any points with a
distance outside of this range are considered out of tolerance. For scanned data with a
huge number of input points we can then elect to only report out of tolerance points to
provide a more manageable report.
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If the difference between the design radius and computed radius is similar for each ring,
and we're working off a provisional design radius, we can repeat the analysis based on a
new radius.
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In our section view, use 'FILE > Load Save' section style and pick the Wriggle from scan
style to set-up appropriate annotation and scales for wriggle survey from a scanned tunnel.
This shows us the difference between design and fit radius at each chainage, along with
the worst of the out of tolerance points for each area of the section.

Zooming in we can see the scanned section overlaid with the design and best fit circles,
with whatever annotators we've specified. Annotation is limited such that where it would
overlap, only the annotator with the largest error is added.
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The wriggle analysis will also output a model and alignment which can be saved and
attached to our original scanned model for verification purposes.

21

Processing LandXML File In SCC For Machine Control
The following text gives the steps required to import your 3d LandXML alignment into SCC,
enter a type section including bottom ballast and formation surface details, and export those
surfaces to Scanlaser via LandXML. The steps are as follows;
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Create A New Project
Select 'FILE > New project' in SCC and enter a project name and template as shown
below.

Import LandXML Files
Import the alignment from LandXML and enter cant
Select 'FILE > Model > LandXML file' and pick the file DES UPT - FINAL temporary
interface (18.556m - 2641.176m).xml

This will create a 3d alignment containing the horizontal and vertical entities in
the XML file and 3d string model of the same. The initial view will be of the 3d
string model in plan.

To view the horizontal entities, click the highlighted tab
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To view the vertical entities, select 'VIEW > Vertical Entities'

You can change gradient units between ratios, e.g. 1:2, to percentages using 'FILE >
General Options > Units and data checking'
Note that in the data provided, the horizontal alignment is slightly shorter than the vertical
alignment, so you may wish to edit the length of final horizontal entity. Once you are
happy with the alignments, select 'FILE > Save to' save the alignment file.
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To view the horizontal entities in plan, switch back to plan view and select
'FILE > Attach> Detach > Attach Alignment File, picking the file DES DR CL 644.Alignment

You will see the alignment drawn with straights in yellow, transitions in red, and circular
arcs in blue. As you move around the screen you will also see the chainage and offset of
the cursor position being updated.

If you have any cant, you can enter this in using 'VIEW > Super-elevation > Cant'.
Selecting 'DESIGN > Compute super-elevation > Cant' will place cant nodes at transitions,
allowing you to enter cant values and run-off for each node.
To inspect the vertical profile graphically, this can be done from plan view by selecting
'DESIGN > Vertical Alignment'. Vertical straights are shown in yellow and parabolic
curves in blue. The positions of horizontal changes are shown as yellow, red or blue
vertical lines. As you move the mouse on screen, the chainage and height of the current
cursor position is displayed.
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Below the vertical profile you will also see a diagram showing application of cant >
super-elevation by chainage. This is also interpolated and updated in the status bar for
the current cursor position as you move the mouse.

Cross Section Templates
Select 'DESIGN > Section Templates' to bring up the template design screen as shown.
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Enter the following points to build the section templates as shown
Surface

Feature

Hz.Offset

Vt.Offset

BALLAST

LEFT

-1.000

-1.000

BALLAST

LRAIL

0.000

-1.000

BALLAST

RRAIL

1.500

-1.000

BALLAST

RIGHT

2.500

-1.000

FORMATION

LEFT

-2.000

-1.200

FORMATION

RIGHT

3.500

-1.736

The values given here are arbitrary intended to illustrate the process. You can enter real
values either using horizontal and vertical offsets, or any combination of offsets, height
differences, widths and gradients. The small blue circle on the template indicates the
position of the centerline.
Once you have entered the template points, select 'FILE > Save to' save your work. You
can also view, enter and edit these points in spreadsheet fashion by selecting 'VIEW >
Section template points'

Create the surface models
From the section template view, select 'Design > Export design as model', and enter the
following parameters to export the formation model.

Note that the chainage interval controls the number of points that will be output to the
triangulated surface. A higher number can give better representation of horizontal and
vertical curves in the triangulated surface, at the expense of a larger model.
If you do not wish to apply cant to this surface your can also disable it at this point.
To remove any spurious triangles around the model boundary, use the Add / Remove
triangles tool. Use the options to remove all triangles to the left of the left edge and to the
right of the right edge (lower on screen).
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The final triangulated surface will appear as follows. Select 'FILE > Save' once your are
done, giving a name of Formation.Model

To export the bottom ballast surface, go back to the section template view and select
'DESIGN > Export design as model' using the following parameters;

Note that we have picked the formation model as our existing ground surface and
instructed SCC to generate an interface between these surfaces using the side slopes
entered in the section template. When you zoom into the resulting model you will see red
tadpoles connecting the edge of the ballast surface down to the formation surface.
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To verify the correctness of the surfaces generated we will cut some cross-sections
through them.
Select 'FILE > Attach/Detach > Attach Alignment File', picking the file DES UPT FINAL temporary interface.Alignment and then pick 'Sections > Cross sections' from an
alignment using the parameters shown;

From the section view, select 'EDIT > Append surfaces' and pick the formation model.
This will result in sections as shown below:

To get an animated run through of the sections, use 'VIEW > Sheet layout' with the
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parameters shown below;

Press + to move up the chainages and – to move back down. It is valuable to use this to
check chainages where cant changes around transitions.
Note: If you want to apply a template position to points after cant has been applied, this
can be done as follows;
· Exporting the surface with cant
· In plan view use 'Design > Create an alignment from an existing string' to create a new
alignment
Add the second template to this alignment and proceed as described above.

Export LandXML files
To export a LandXML file for a given model, open the model and select 'FILE > Export >
LandXML.'
Doing this for Ballast.Model and Formation.Model will result in the files
Ballast.Model.Land.XML and Formation.Model.Land.XML.
These files can be opened in Internet explorer as shown below.

Examining the XML files shows they contain points, strings, breaklines and the
triangulated surface
Note: Widening or narrowing at a given chainage
To widen or narrow an alignment between given chainages we need to create extra
templates. For example say we wished to widen the formation surface between
chainages 380 and 420, we would do the following;
§ In section template view, press the New section button and create a new section at
chainage 380.
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§ Press the New section button again, and create another section at chainage 420.
§ Edit the right formation edge to have a new offset and/ or height as required
§ Export to a model as described previously.

Viewing the section template points shows we now have three sections, each containing
all the strings for both surfaces. The first and second sections, starting at chainages 0
and 380, are the same indicating there is no change between these chainages. The third
section, at chainage 420, has a modified height and offset values for the right formation
level. This means that there will be a linear change of height and offsets between
chainages 380 and 420. As there are no further sections after chainage 420, the section
template at 420 will be carried to the end of the alignment.
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22

Working With AutoCAD Civil3D Files

22.1

Exporting TIN models from SCC to Civil 3d
The following examines how to export a triangulated surface from SCC to Civil 3d
using the LandXML format. It is based around SCC 10.0.6 and Civil 3d 2013. The
steps are as follows:
Open your model in SCC
Select 'FILE > Export > LandXML' using the following parameters

Open Civil3d and start a new blank drawing
Select 'Insert > LandXML'
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Pick the LandXML file created in SCC, the file contains a large number of points and one
surface that corresponds to the TIN surface
When drawn initially in Civil3d it may not show the TIN, depending on the default surface
style set in use.
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To display the TIN, first create a style set with triangles turned on as follows:
Click New in the Surfaces section of the Settings pane in the Toolspace.
Give your new surface style a name, e.g. Display TIN
In the Display tab, turn on the triangles
Press Ok to close the dialog
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To apply the style set to the surface:
Click 'MODIFY > Surface'
Click 'SURFACE > Properties'
Select the appropriate style e.g. Display TIN, as the surface style
Press Ok
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Triangles are now displayed and can be used for analysis.

22.2

Importing AutoCAD Civil3D files into SCC
The following details the exporting of specific design entities from AutoCAD Civil3D 2013 which
are then imported and modelled in SCC.

Exporting Specific Entities from AutoCAD Civil3D
Open the drawing file in AutoCAD.
Note in some instance a message as shown below will detail that the drawing may be
missing some shape files and xrefs. For the purpose of the demo this message is
ignored. The error message will not appear if the file is opened on a PC where the files
are available locally.

In the sample shown, the missing references appear as huge text in the drawing, where
the area of interest to be exported is at the bottom right of the word Tin.

Zoom into the area of interest, and type in SAVEAS to save a copy of the file under a new
name.
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Type EXPLODE and select the corridor, to convert the entire C3D corridor object into an
AutoCAD block.
Type EXPLODE again to convert the block into simple entities.
Type DXFOUT to save these entities to a DXF file.
On the Tools menu of the Save Drawing As dialog, pick Select Entities, as this option
allows for just the road corridor entities.
Enter a name and press Save.
Use the mouse to drag a window around the area of interest, and press Enter.

Close Civil 3d

Importing Entities from AutoCAD Civil3D into SCC
Open SCC
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'FILE > New Project', to create a new project, or open an existing project

'FILE > Model > DXF or DWG' and pick the file just created

The data from Civil3d is all line segments, use 'TOOLS > Join adjacent strings (Same
feature)' to convert them back to polylines.
Right click to select all the points in the model, and pick a DTM code of DTM elevation to
ensure all points are triangulated for contouring, sectioning, etc...
Use 'EDIT > Add/Remove triangles' to limit the extents of the triangulation and form a
boundary.
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Use 'EDIT > Query & edit points' to set feature colours and line styles as required.
When prompted save the changes to the feature library, such that the feature library can
be used as a template for future imports, such that this step is not necessary in future.

Notes:
If specific design lines are required out of Civil3d you can export the data as polylines, as
described below. This is fine for a few lines but would become cumbersome on a large
design as each line has to be done individually.
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The TIN and alignments can be exported from Civil3d in LandXML as required, but this
doesn't appear to create line work, so the above method give a better result.

23

Using Adjustment Constraints
Additional fields to enter coordinate constraints against station coordinates, and to include
some extra adjustment options to deal with these have been added. Specifically, when you
use 'VIEW > Station Coordinates', you will see three extra constraint fields, rE/X, rN/Y and
rHt/Z, which correspond to the known accuracies > standard errors of the stations. You will
also notice that the Type field has been broken down into two separate fields for X,Y Type and
Z Type, and that a new type of Constrained has been added.

Entering a value into a constraint field, and setting the corresponding type to constrained will
allow the station to be modified slightly during the course of a least squares adjustment to the
limits of the constraint entered. For example, in the above spreadsheet, the X,Y, and Z
coordinates have standard errors of 5mm, and hence may be adjusted by an amount that will
normally be less than this value. Note that in networks with blunders and unusually large
residuals, the adjustment may be greater than the standard error entered.

Open Existing Files
To illustrate the use of constraints, open 3d-example.project and 3d-example.traverse

Traverse Adjustment
Select 'EDIT > Adjust' with the following parameters.
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This yields the report shown below. Note the report layout has been improved in SCC
9.9.0 to combine residual values and standard errors in with original observations and
provisional coordinates, and similarly adjustments with adjusted coordinates. Note that
the coordinates and elevation of STN1 and STN2 have been modified slightly in
accordance with the constraints given.
SCC for Windows v9.9.0 (C) 1990 - 2009 Atlas Computers Ltd
Traverse adjustment report
Title

3d-EXAMPLE.Traverse

Date

Thu Jun 03 08:48:43 2010

Coordinate adjustment method
Height adjustment method

Variation of Co-ordinates

Least Squares (Default weighting)

Corrections applied
------------------Local scale factor : No local scale factor
Earth curvature and refraction : Curvature only

(Earth Radius 6380000.000)

Temperature and pressure : No
Mean sea level correction : No
Default Standard Errors
Angles (secs)

: 3.000

Distances (constant mm)

: 5.000

Distances (ppm mm)

: 2.000

Heights (mm)

: 3.000

Provisional coordinates
Name
Ht> Z

E> X
StdErr

StdErr

N> Y

StdErr

Type

Type

---------------- --------------------------- ------ ----

------

--------------

------

----

STN1
54.31100

0.0050

1100.00000

0.0050

Cons

1166.19500
0.0030

Cons
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STN2
55.68500

0.0030

Cons

STN4
53.02486

0.0000

Free

STN5
52.35902

0.0000

Free

STN6
51.47829

0.0000

Free

STN7
50.76723

0.0000

Free

STN8
58.79736

0.0000

Free

STN9
40.62047

0.0000

Free

TEM1
52.22092

0.0000

Free

TEM2
52.25085

0.0000

Free

1100.00000

0.0050

1100.00000

0.0050

Cons

1099.88478

0.0000

1125.34510

0.0000

Free

1141.22028

0.0000

1122.19111

0.0000

Free

1202.08301

0.0000

1098.41752

0.0000

Free

1225.12102

0.0000

1097.61346

0.0000

Free

1220.29787

0.0000

1075.01497

0.0000

Free

1215.15799

0.0000

1142.77027

0.0000

Free

1101.17775

0.0000

1143.46424

0.0000

Free

1105.95935

0.0000

1132.62374

0.0000

Free

Adjusted coordinates
Name
Adj

E> X

Adj

N> Y

Adj

---------------- --------------------------- -------

-------

--------------

-------

STN1
54.30905

1166.19517

+0.0002

1100.00000

+0.0000

-0.0019

STN2
55.68695

1099.99983

-0.0002

1100.00000

+0.0000

+0.0019

STN4
53.01638

1099.88673

+0.0019

1125.33990

-0.0052

-0.0085

STN5
52.35103

1141.22332

+0.0030

1122.18748

-0.0036

-0.0080

STN6
51.47357

1202.08386

+0.0008

1098.41665

-0.0009

-0.0047

STN7
50.76387

1225.12161

+0.0006

1097.61285

-0.0006

-0.0034

STN8
58.79446

1220.29869

+0.0008

1075.01485

-0.0001

-0.0029

STN9
40.61866

1215.15749

-0.0005

1142.77221

+0.0019

-0.0018

TEM1
52.21244

1101.17898

+0.0012

1143.45910

-0.0051

-0.0085

TEM2
52.24236

1105.96101

+0.0017

1132.61879

-0.0050

-0.0085

Bearings
At Station

To Station

Bearing

StdErr

------------

Residual

------------

----------

------

STN1
(Fixed)

STN2

270 00 00.0

0.000

-000 00 00.00

1.000

STN2
(Fixed)

STN1

090 00 00.0

0.000

-000 00 00.00

1.000

-------------

StdRes
------

Angles
At Station

To Station

------------

------------
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------
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STN1

STN8

204 47 16.0

3.000

-000 00 00.56

0.190

STN1

STN8

204 47 17.9

3.000

-000 00 02.56

0.857

STN8

STN7

077 15 36.0

3.000

-000 00 00.61

0.206

STN8

STN7

077 15 38.0

3.000

-000 00 02.61

0.872

STN7

STN9

155 30 36.9

3.000

-000 00 01.07

0.358

STN7

STN9

155 30 35.0

3.000

+000 00 00.92

-0.309

STN7

STN6

079 57 03.9

3.000

-000 00 01.05

0.351

STN7

STN6

079 57 05.0

3.000

-000 00 02.05

0.684

STN6

STN9

284 25 27.0

3.000

+000 00 00.90

-0.301

STN6

STN9

284 25 29.0

3.000

-000 00 01.09

0.365

STN6

STN5

199 20 14.0

3.000

-000 00 03.36

1.121

STN6

STN5

199 20 10.0

3.000

+000 00 00.63

-0.213

STN5

STN9

323 06 25.0

3.000

+000 00 00.91

-0.303

STN5

STN9

323 06 26.0

3.000

-000 00 00.08

0.030

STN5

STN4

163 01 38.0

3.000

-000 00 02.54

0.850

STN5

STN4

163 01 35.9

3.000

-000 00 00.54

0.183

STN4

TEM2

305 29 03.0

3.000

-000 00 00.00

0.000

STN4

TEM1

269 43 06.0

3.000

-000 00 00.00

0.000

STN4

TEM1

269 43 06.0

3.000

-000 00 00.00

0.000

STN4

TEM2

305 29 03.0

3.000

-000 00 00.00

0.000

STN4

STN2

085 23 01.0

3.000

-000 00 01.50

0.502

STN4

STN2

085 23 01.0

3.000

-000 00 01.50

0.502

STN2

STN4

269 44 39.0

3.000

+000 00 00.34

-0.115

STN2

STN1

090 15 21.0

3.000

-000 00 00.34

0.115

STN2

STN1

090 15 23.0

3.000

-000 00 02.34

0.781

Horizontal Distances
At Station

To Station

Distance

StdErr

Residual

StdRes

------------

------------

----------

------

----------

------

STN1

STN8

59.593

0.005

0.000692

-0.135

STN1

STN8

59.594

0.005

-0.000348

0.068

STN8

STN1

59.593

0.005

0.000649

-0.127

STN8

STN7

23.107

0.005

-0.000509

0.101

STN8

STN7

23.107

0.005

0.000358

-0.071

STN8

STN1

59.594

0.005

-0.000283

0.055

STN7

STN8

23.106

0.005

0.000475

-0.094

STN7

STN9

46.243

0.005

0.002698

-0.530

STN7

STN9

46.244

0.005

0.001672

-0.328

STN7

STN6

23.052

0.005

-0.000284

0.056

STN7

STN6

23.052

0.005

-0.000277

0.055

STN7

STN8

23.108

0.005

-0.001375

0.272

STN6

STN7

23.052

0.005

-0.000291

0.058

STN6

STN9

46.241

0.005

0.000829

-0.163
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STN6

STN9

46.242

0.005

-0.000144

0.028

STN6

STN5

65.341

0.005

-0.003070

0.598

STN6

STN5

65.339

0.005

-0.001065

0.208

STN6

STN7

23.054

0.005

-0.002290

0.454

STN5

STN6

65.339

0.005

-0.001078

0.210

STN5

STN9

76.745

0.005

0.001273

-0.247

STN5

STN9

76.744

0.005

0.002205

-0.428

STN5

STN4

41.456

0.005

0.000916

-0.180

STN5

STN4

41.458

0.005

-0.001084

0.213

STN5

STN6

65.340

0.005

-0.002070

0.403

STN4

STN5

41.457

0.005

-0.000081

0.016

STN4

TEM2

9.480

0.005

0.000000

-0.000

STN4

TEM1

18.165

0.005

0.000000

-0.000

STN4

TEM1

18.165

0.005

0.000000

-0.000

STN4

TEM2

9.480

0.005

0.000000

-0.000

STN4

STN2

25.340

0.005

0.000528

-0.104

STN4

STN2

25.340

0.005

0.000528

-0.104

STN4

STN5

41.457

0.005

-0.000081

0.016

STN2

STN4

25.339

0.005

0.001509

-0.299

STN2

STN4

25.342

0.005

-0.001435

0.284

Number of observations : 65
Number of unknowns : 20
Number of redundant obs : 45
Reference variance : 0.15305
Reference standard deviation So : 0.41621
Failed Chi-Square test at 95% level; exceeded lower bound (0.00)
Error ellipses
Standard

At 90% conf.

At 95% conf.

At
Su

99% conf.
Station
Sv

Su

Sv

Su

Sv

Su

Sv

-------- ----------------- -------

-------

-------

-------

-------

-------

-------

STN1
0.00526

090 00 00.0
0.00470

0.00165

0.00147

0.00362

0.00324

0.00416

0.00373

STN2
0.00526

090 00 00.0
0.00470

0.00165

0.00147

0.00362

0.00324

0.00416

0.00373

STN4
0.00540

153 35 55.0
0.00523

0.00169

0.00164

0.00372

0.00360

0.00428

0.00414

STN5
0.00551

122 51 06.3
0.00527

0.00172

0.00165

0.00379

0.00363

0.00436

0.00417

STN6
0.00547

141 06 05.8
0.00527

0.00171

0.00165

0.00377

0.00363

0.00433

0.00417

STN7
0.00555

136 49 35.9
0.00532

0.00174

0.00166

0.00382

0.00366

0.00440

0.00421

STN8
0.00549

109 06 07.7
0.00486

0.00172

0.00152

0.00378

0.00335

0.00435

0.00385
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STN9
0.00558

173 25 53.7
0.00540

0.00175

0.00169

0.00385

0.00372

0.00442

0.00428

TEM1
0.00715

002 32 44.1
0.00530

0.00224

0.00166

0.00493

0.00365

0.00567

0.00420

TEM2
0.00707

038 17 50.0
0.00537

0.00221

0.00168

0.00487

0.00370

0.00560

0.00425

Height residuals
At Station

To Station

HtDiff

StdErr

Residual

StdRes

------------

------------

----------

------

----------

------

STN1

STN8

4.486

0.003

0.000000

0.000

STN1

STN8

4.486

0.003

0.000945

0.315

STN8

STN1

-4.485

0.003

0.000442

0.147

STN8

STN7

-8.030

0.003

0.000000

0.000

STN8

STN7

-8.030

0.003

0.000190

0.063

STN8

STN1

-4.486

0.003

0.000475

0.158

STN7

STN8

8.030

0.003

0.001027

0.342

STN7

STN9

-10.147

0.003

-0.000752

-0.251

STN7

STN9

-10.147

0.003

-0.000607

-0.202

STN7

STN6

0.711

0.003

-0.001565

-0.522

STN7

STN6

0.711

0.003

-0.001555

-0.518

STN7

STN8

8.031

0.003

0.001349

0.450

STN6

STN7

-0.711

0.003

0.001573

0.524

STN6

STN9

-10.858

0.003

0.000161

0.054

STN6

STN9

-10.858

0.003

-0.001042

-0.347

STN6

STN5

0.881

0.003

-0.003018

-1.006

STN6

STN5

0.881

0.003

-0.003247

-1.082

STN6

STN7

-0.711

0.003

0.003264

1.088

STN5

STN6

-0.879

0.003

0.003554

1.185

STN5

STN9

-11.728

0.003

-0.001104

-0.368

STN5

STN9

-11.727

0.003

-0.001934

-0.645

STN5

STN4

0.666

0.003

0.004431

1.477

STN5

STN4

0.666

0.003

0.004954

1.651

STN5

STN6

-0.880

0.003

0.000505

0.168

STN4

STN5

-0.666

0.003

0.000537

0.179

STN4

TEM2

-0.774

0.003

-0.002581

-0.860

STN4

TEM1

-0.804

0.003

-0.000453

-0.151

STN4

TEM1

-0.804

0.003

0.000000

0.000

STN4

TEM2

-0.774

0.003

0.000000

0.000

STN4

STN2

2.671

0.003

-0.000000

-0.000

STN4

STN2

2.671

0.003

-0.000000

-0.000

STN4

STN5

-0.666

0.003

0.000480

0.160

STN2

STN4

-2.671

0.003

0.000480

0.160

STN2

STN4

-2.671

0.003

-0.000453

-0.151

Network contains 11 legs
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From
To
dHt Obs Type
------------ --STN8
-0.0005
STN8
0.0005

Comp Length
Bearing

Meas.Length

Difference

Comp dHt

Meas dHt

-----------------

-----------

----------

--------

--------

59.594

0.0001

4.4854

4.4859

23.107

-0.0003

8.0306

8.0301

----

STN1
4
Loose
STN7
4
Loose

59.594
294 47 15.4
23.107
012 02 50.8

STN7
-0.0016

STN9
2
Closed

46.246
347 33 26.7

46.243

0.0022

10.1452

10.1468

STN7
-0.0013

STN6
4
Closed

23.052
271 59 53.7

23.053

-0.0008

0.7097

0.7110

STN6
-0.0031

STN9
2
Closed

46.242
016 25 21.6

46.242

0.0004

10.8549

10.8580

STN6
-0.0028

STN5
4
Closed

65.338
291 20 04.3

65.340

-0.0018

0.8775

0.8803

76.745

0.0018

11.7324

11.7277

41.457

-0.0000

0.6653

0.6658

STN5
0.0047

STN9
2
Closed

STN5
-0.0005

STN4
4
Closed

76.746
074 26 30.3
41.457
274 21 39.8

STN4
0.0000

TEM2
2
Closed

9.480
039 50 42.8

9.480

-0.0000

0.7740

0.7740

STN4
0.0000

TEM1
2
Closed

18.165
004 04 45.8

18.165

-0.0000

0.8039

0.8039

25.340

0.0003

2.6706

2.6711

STN4
-0.0005

STN2
4
Loose

25.340
179 44 39.3

Diff

Total length 434.767, total length misclosure 0.008, total height misclosure
0.0154
Length after removing fixed legs 434.767, misclosure 0.008, height misclosure
0.0154
Length after removing fixed and loose legs 326.726, misclosure 0.007, height
misclosure 0.0140, equivalent linear accuracy 1:47115.3
(This result only takes into account closed loops, and legs on sections that lie
between fixed stations,
It provides the best equivalent to a Bowditch adjusted result)
Relative Error ellipses and standard errors of computed quantities between
points
Ellipse details
From Station

To Station

------------

------------

STN1

STN2

090 00 00.0

0.00353

0.00000

000 00 00.0

0.00353

STN1

STN4

005 25 09.0

0.00355

0.00192

000 00 06.0

0.00346

STN1

STN5

010 13 44.7

0.00300

0.00185

000 00 13.7

0.00274

STN1

STN6

014 47 45.8

0.00244

0.00194

000 00 11.2

0.00242

STN1

STN7

027 32 06.8

0.00236

0.00197

000 00 07.1

0.00229

STN1

STN8

024 41 58.0

0.00237

0.00056

000 00 01.9

0.00237

STN1

STN9

035 05 42.3

0.00253

0.00210

000 00 07.9

0.00213

STN1

TEM1

272 15 29.8

0.00405

0.00358

000 00 10.3

0.00371

STN1

TEM2

060 51 30.2

0.00456

0.00286

000 00 12.4

0.00343

STN2

STN4

270 30 28.2

0.00194

0.00020

000 00 01.6

0.00194

STN2

STN5

009 08 21.5

0.00243

0.00188

000 00 09.2

0.00224
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STN2

STN6

009 12 31.4

0.00280

0.00195

000 00 03.9

0.00279

STN2

STN7

008 05 48.0

0.00307

0.00203

000 00 03.3

0.00306

STN2

STN8

001 45 45.0

0.00314

0.00111

000 00 02.0

0.00310

STN2

STN9

079 07 27.9

0.00294

0.00223

000 00 03.7

0.00292

STN2

TEM1

273 35 01.4

0.00406

0.00040

000 00 02.0

0.00405

STN2

TEM2

302 20 09.0

0.00389

0.00113

000 00 11.1

0.00363

STN4

STN5

004 19 34.1

0.00242

0.00046

000 00 02.2

0.00242

STN4

STN6

008 08 05.1

0.00281

0.00122

000 00 02.4

0.00280

STN4

STN7

008 55 15.8

0.00309

0.00141

000 00 02.2

0.00308

STN4

STN8

001 36 05.7

0.00314

0.00204

000 00 03.4

0.00302

STN4

STN9

087 59 51.4

0.00291

0.00159

000 00 02.8

0.00290

STN4

TEM1

274 04 45.8

0.00356

0.00027

000 00 03.1

0.00356

STN4

TEM2

309 50 42.8

0.00355

0.00014

000 00 03.1

0.00355

STN5

STN6

020 55 55.7

0.00171

0.00081

000 00 02.5

0.00171

STN5

STN7

016 13 45.1

0.00220

0.00103

000 00 02.4

0.00220

STN5

STN8

088 14 48.6

0.00225

0.00194

000 00 04.5

0.00216

STN5

STN9

071 16 18.2

0.00193

0.00120

000 00 03.2

0.00193

STN5

TEM1

274 38 14.7

0.00359

0.00243

000 00 15.6

0.00265

STN5

TEM2

053 07 57.5

0.00392

0.00181

000 00 18.6

0.00275

STN6

STN7

005 32 45.6

0.00096

0.00029

000 00 02.6

0.00096

STN6

STN8

287 31 10.2

0.00195

0.00100

000 00 11.8

0.00138

STN6

STN9

287 13 53.2

0.00129

0.00075

000 00 03.3

0.00129

STN6

TEM1

271 42 35.4

0.00377

0.00283

000 00 06.8

0.00299

STN6

TEM2

055 26 04.4

0.00409

0.00229

000 00 07.2

0.00303

STN7

STN8

281 15 12.8

0.00195

0.00028

000 00 02.4

0.00195

STN7

STN9

167 20 09.1

0.00128

0.00072

000 00 03.2

0.00128

STN7

TEM1

179 29 50.3

0.00384

0.00310

000 00 05.8

0.00320

STN7

TEM2

058 21 22.6

0.00421

0.00251

000 00 05.8

0.00338

STN8

STN9

275 28 07.0

0.00222

0.00101

000 00 03.2

0.00219

STN8

TEM1

277 14 23.0

0.00411

0.00316

000 00 05.9

0.00332

STN8

TEM2

053 10 54.9

0.00443

0.00264

000 00 06.6

0.00308

STN9

TEM1

281 05 10.2

0.00392

0.00289

000 00 07.0

0.00293

STN9

TEM2

053 15 00.4

0.00430

0.00223

000 00 05.5

0.00385

TEM1

TEM2

291 56 08.9

0.00479

0.00156

000 01 02.6

0.00352

Traverse Observation Spreadsheet
You will also notice that on the View menu in the traverse observations spreadsheet, there
are additional commands to better organize the spreadsheet for specific tasks. These are
as follows;
'VIEW > Layout > All observed and reduced data (3d)
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'VIEW > Layout > All observed and reduced data (2d)'

'VIEW > Layout > Reduced observations (3d)'

'VIEW > Layout > Reduced observations (2d)'

'VIEW > Layout > Reduced levels only'

The observed options correspond to the layout available in previous versions of SCC,
where the 2d option removes the instrument height, rod height and height difference
fields. The reduced observations options show forward measured angles, horizontal
distances, height differences, known bearings, and their corresponding standard errors.
The reduced level option only shows height and distance information, again with standard
errors, where distances may be used to calculate relative weights as an alternative to
entering standard errors.
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Constraint Adjustment
Standard errors in any of these views correspond to observation weights or accuracies,
thus if I know a height difference is good to +> - 3mm I enter 3.0 in the –Err- field that
follows the –Ht Diff- field. I can also use the modify the Obs. Type field to fix a height
difference, horizontal distance, angle or bearing to further constrain the adjustment. For
example, in the report above, you will notice a fixed bearing between STN1 and STN2 of
270 degrees, such if the coordinates are moved during the adjustment, the bearing
between them will be fixed at 270 degrees.

The content of the report will also be modified by the type of adjustment selected. For
example, if we open 2d-example.project and 2d-example.traverse, and adjust using the
parameters given, we get the report shown below.
SCC for Windows v9.9.0 (C) 1990 - 2009 Atlas Computers Ltd
Traverse adjustment report
Title

2d-EXAMPLE.Traverse

Date

Thu Jun 03 10:25:59 2010

Coordinate adjustment method

Variation of Co-ordinates

Corrections applied
------------------Local scale factor : No local scale factor
Earth curvature and refraction : Curvature only

(Earth Radius 6380000.000)

Temperature and pressure : No
Mean sea level correction : No
Default Standard Errors
Angles (secs)

: 3.000

Distances (constant mm)

: 5.000

Distances (ppm mm)

: 2.000

Heights (mm)

: 3.000

Provisional coordinates
Name

E> X

StdErr

N> Y

StdErr

Type
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----------------

--------------

------

--------------

------

----

1A

10000.00000

0.1800

10000.00000

0.1800

Cons

2C

12487.08000

0.1800

10528.65000

0.1800

Cons

3B

10862.48000

0.0000

11103.93000

0.0000

Prov

4D

11990.88000

0.0000

9387.46000

0.0000

Prov

5E

10948.55000

0.0000

9461.90000

0.0000

Prov

6F

11595.22000

0.0000

10131.56000

0.0000

Prov

Adjusted coordinates
Name

E> X

----------------

Adj

N> Y

Adj

--------------

-------

--------------

-------

1A

9999.99844

-0.0016

9999.99967

-0.0003

2C

12487.08156

+0.0016

10528.65033

+0.0003

3B

10862.48289

+0.0029

11103.93327

+0.0033

4D

11990.88203

+0.0020

9387.46189

+0.0019

5E

10948.54878

-0.0012

9461.89972

-0.0003

6F

11595.22309

+0.0031

10131.56264

+0.0026

Horizontal Distances
At Station

To Station

Distance

StdErr

Residual

StdRes

------------

------------

----------

------

----------

------

1A

3B

1400.910

0.023

0.000000

-0.000

1A

5E

1090.550

0.022

-0.000030

0.001

3B

2C

1723.450

0.023

-0.002524

0.110

2C

6F

976.260

0.022

0.003354

-0.152

2C

4D

1244.400

0.023

-0.002556

0.111

3B

5E

1644.290

0.023

-0.002432

0.106

3B

6F

1217.540

0.022

0.003779

-0.172

4D

6F

842.750

0.022

0.002603

-0.118

4D

5E

1044.990

0.022

-0.002160

0.098

5E

6F

930.930

0.022

0.002896

-0.132

Number of observations : 14
Number of unknowns : 12
Number of redundant obs : 2
Reference variance : 0.00995
Reference standard deviation So : 0.25426
Failed Chi-Square test at 95% level; exceeded lower bound (0.99)
Error ellipses
Standard

At 90% conf.

At 95% conf.

At
Su

99% conf.
Station
Sv

Su

Sv

Su

Sv

Su

Sv

-------- ----------------- -------

-------

-------

-------

-------

-------

-------

1A
0.64398

0.04577

0.03262

0.19417

0.13841

0.28212

0.20111
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2C
0.64398

168 00 00.0
0.45906

0.04577

0.03262

0.19417

0.13841

0.28212

0.20111

3B
0.56690

065 31 18.2
0.46203

0.04029

0.03284

0.17093

0.13931

0.24835

0.20241

4D
0.62006

049 54 36.3
0.46410

0.04407

0.03298

0.18696

0.13993

0.27164

0.20331

5E
0.55321

110 24 33.2
0.46386

0.03931

0.03297

0.16680

0.13986

0.24235

0.20321

6F
0.48217

017 58 02.5
0.46286

0.03427

0.03289

0.14538

0.13956

0.21123

0.20277

Network contains 10 legs
From
To
dHt Obs Type
------------ ---

Comp Length
Bearing

Meas.Length

Difference

Comp dHt

Meas dHt

-----------------

-----------

----------

--------

--------

----

1A
-0.1538

3B
1

1400.910
038 00 00.0

1400.910

-0.0000

0.0000

0.1538

Closed

1A
-0.0932

5E
1

1090.550
119 33 56.3

1090.550

-0.0000

0.0000

0.0932

Closed

3B
-0.2328

2C
1

1723.448
109 29 58.0

1723.450

-0.0025

0.0000

0.2328

Closed

2C
-0.0747

6F
1

976.263
245 59 58.7

976.260

0.0034

0.0000

0.0747

Closed

2C
-0.1214

4D
1

1244.397
203 30 00.0

1244.400

-0.0025

0.0000

0.1214

Closed

3B
-0.2119

5E
1

1644.288
176 59 58.6

1644.290

-0.0025

0.0000

0.2119

Closed

3B
-0.1162

6F
1

1217.544
143 00 00.0

1217.540

0.0038

0.0000

0.1162

Closed

4D
-0.0557

6F
1

842.753
331 59 57.0

842.750

0.0026

0.0000

0.0557

Closed

4D
-0.0856

5E
1

1044.988
274 05 05.3

1044.990

-0.0021

0.0000

0.0856

Closed

5E
-0.0679

6F
1

930.933
043 59 58.1

930.930

0.0029

0.0000

0.0679

Closed

Diff

Total length 12116.073, total length misclosure 0.022, total height misclosure
1.2131
Length after removing fixed legs 12116.073, misclosure 0.022, height misclosure
1.2131
Length after removing fixed and loose legs 12116.073, misclosure 0.022, height
misclosure 1.2131, equivalent linear accuracy 1:543380.1
(This result only takes into account closed loops, and legs on sections that lie
between fixed stations,
It provides the best equivalent to a Bowditch adjusted result)
Relative Error ellipses and standard errors of computed quantities between
points
Ellipse details
Angle (t)

From Station

To Station

------------

------------

1A

2C

168 00 00.0

0.25456

0.03248

000 00 20.6

0.03248

1A

3B

037 35 51.5

0.14265

0.02294

000 00 21.0

0.02296

1A

4D

287 21 04.3

0.21004

0.03043

000 00 20.7

0.03045

1A

5E

299 58 18.0

0.11276

0.02195

000 00 21.3

0.02197

-------------

Su

Std Errors

-------

Sv
-------

Direction

Dist.

-------------

-----
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1A

6F

175 23 29.0

0.16214

0.03288

000 00 20.8

0.03289

2C

3B

289 39 00.5

0.17420

0.02189

000 00 20.8

0.02190

2C

4D

023 17 43.6

0.12781

0.02187

000 00 21.1

0.02188

2C

5E

145 13 31.4

0.18896

0.02576

000 00 20.8

0.02576

2C

6F

156 01 43.1

0.10082

0.01989

000 00 21.3

0.01989

3B

4D

056 44 21.1

0.20791

0.02565

000 00 20.8

0.02565

3B

5E

086 56 01.1

0.16688

0.02192

000 00 20.9

0.02192

3B

6F

053 02 37.5

0.12493

0.01934

000 00 21.1

0.01934

4D

5E

274 15 14.6

0.10831

0.02117

000 00 21.3

0.02117

4D

6F

062 14 51.0

0.08875

0.02078

000 00 21.7

0.02078

5E

6F

043 47 19.3

0.09675

0.02043

000 00 21.4

0.02044

Similarly, to adjust a level network we can turn off the horizontal adjustment. For
example, if we open Level-example.project and Level-example.traverse, and adjust using
the parameters given, we get the report shown below.
SCC for Windows v9.9.0 (C) 1990 - 2009 Atlas Computers Ltd
Traverse adjustment report
Title

LevelAdjust.Traverse

Date

Thu Jun 03 10:30:03 2010

Height adjustment method

Least Squares (Default weighting)

Corrections applied
------------------Local scale factor : No local scale factor
Earth curvature and refraction : Curvature only
Temperature and pressure : No
Mean sea level correction : No
Default Standard Errors
Heights (mm)

: 2.000

Provisional heights
Name
----------------

Ht> Z

StdErr

Type

--------------

------

----

BMX

100.00000

0.0050

Cons

BMY

107.50000

0.0000

Fix

A

105.10000

0.0000

Prov

C

106.25000

0.0000

Prov

B

104.42000

0.0000

Prov

Adjusted heights
Name
----------------

Ht> Z

Adj

--------------

-------

BMX

100.07566

+0.0757

BMY

107.50000

+0.0000

A

105.17338

+0.0734

C

106.22004

-0.0300

B

104.50447

+0.0845
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Height residuals
At Station

To Station

HtDiff

StdErr

Residual

StdRes

------------

------------

----------

------

----------

------

BMX

A

5.100

0.002

0.002282

1.141

A

BMY

2.340

0.002

0.013378

6.689*

BMY

C

-1.250

0.002

0.029957

14.978*

C

BMX

-6.130

0.002

0.014387

7.193*

A

B

-0.680

0.002

-0.011096

-5.548*

BMY

B

-3.000

0.002

-0.004473

-2.237

B

C

1.700

0.002

-0.015570

-7.785*

In all of the least square adjustment reports, we will see equations listed in the form
Stations used, observed value, standard error, observation residual, and standard
residual. The standard error equates to how accurate you thought the observation was
(e.g. a-priori value), whereas the residual corresponds to how much the observation was
actually changed to reflect the adjusted station values (e.g. a-posteriori value). The
standard residual is obtained by dividing the standard error by the observation residual,
and as such should be close to one if the standard errors given match the residuals
produced. High values for the standard residual are flagged with an asterisk, indicating
lack of agreement between observations and standard errors given. Fixed observations
will be marked as (Fixed) in the report and the standard residual forced to one.
If the average value of the standard residuals is more than 1, your observations are not as
accurate as stated. If one observation has a particularly high standard residual, it should
be checked. If the average values of all standard residuals are much less than one, the
standard errors entered are two high, which in turn means the adjustment has been given
too much freedom to move the stations. Either of these events will tend to trigger a failure
to pass the chi-squared test, which is essentially a statistical analysis of the standard
residuals.

Traverse And Error Ellipse Annotation
'VIEW > Station coordinates'
'FILE > Export > Station Coordinates as dataset'
'FILE > Save As', and give the stations a name, typically corresponding to the project
name
'FILE > Model > SCC dataset', picking the dataset produced
'FILE > Attach> Detach > Attach traverse'
'EDIT > Text > Annotate traverse', to add annotation for stations and legs as required.
You will need to use this command twice if you wish to annotate both station and traverse
leg information
The following features are used to control display of ellipses
~RELELLI Corresponds to relative ellipses drawn along legs
~ERRELLI Corresponds to error ellipses at stations
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Ellipse scale and relative ellipse content can be set using 'FILE > Attach/ Detach'

24

Working With Trimble Data
The following tutorial provides information relating to the downloading and processing of
Trimble data within SCC.

24.1

Create A Project
A new project should be created before data may be downloaded into SCC or models
formed.
From the Main Menu Bar, select ‘FILE >New Project’
Enter in a Project/Job name
Select a Project Template from the list
Select ‘OK’

24.2

Download Trimble Data from ACU
Trimble ACU Output
SCC support downloading files from the Trimble ACU, running Tsce software, using the
SDR33 output format. These attributes can be used to describe dimensions, offsets,
parallel features, and all other items available through the SCC extended coding library.
We will demonstrate the use of this facility through the sample file 060228D.DAT. Note
that in this file, Tsce attributes are stored in 13AT records, see extract below for an
example;
2NM

9020

308417.642000000231995.58500000051.33300000000001.50000000000000

07NM
9020
03NM1.70000000000000
09F1
9020

9021

27.900185437685727.9001854376857

9021

12.874430000000088.109739263113027.9001854376857STN

09F1

1001

18.593340000000088.669171829746923.1694290000000BG

9020

13ATOffset
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09F1

9020

1002

17.165240000000088.759832243491514.1117367500000BG

To process this file in SCC, amendments must be made to the default project template as
follows;
From within the Project, select Import / View SDR translation table
Add a record for each attribute type present in the Tsce format being used. For example,
for the OFFSET attribute, we add a new record with the name and code of OFFSET, type
of ‘Control Code with Parameter (CCP)’, and SDR Control type of ‘Par Ofs L/R’. This
means that when SCC encounters an attribute called OFFSET, it will take the attribute
value and store it in the parallel offset field in SCC. For this job, the rest of the records will
be as follows;

Note that regular features that contain embedded string numbers should also appear in
this sheet with a type of ‘PC’ and a PntInFtr setting of ‘String’. This sheet can also be
used to control default tag and DTM codes for these features.
Once you have completed editing this translation table, you should save the project as a
new template in the SCC folder, such that you do not have to repeat this exercise.
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Trimble TSC/TSCe (DC)'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select '060228D.Dat' from '\SCC\Tutorials' directory
Select 'Open'
Select 'OK'
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Set 'SDRMap Coding Extensions' and 'Search remarks for dimensions'
Select 'OK'
This will generate the following detail survey file;

*.DC files from TSCE containing observations in DC formats as defined in DC10.70 or
DC7.5 are also supported. Observations must be in HA,Va,Sd or X,Y,Z formats. SCC
does not currently read GPS vectors, or GPS lat,long, height records from this format.

Combined Total Station & GPS Files Trimble Data
SCC supports the download of combined Total Station and GPS information contained
within one complete file.

Total Station Detail
08PD
08PD
08PD
08PD
08PD
08PD
08PD

1853
1854
1855
1856
1857
1858
1859

GPS Data
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240109.491174308230536.45323307880.5785407722807CONC2
240106.941616718230533.14415286880.4446191824330CONC2
240106.934895243230533.12155861780.4350418868451K2
240103.591644851230535.66377808680.3671757765827K2
240102.973759388230536.67287284980.3818527249702K2
240102.946912372230537.66137346080.3672869395576K2
240108.024260067230544.61543070080.4062528838890K2

427
09F1

S4

1871

19.485780000000086.2995339500897308.269300500000SL

09F1

S4

1872

20.122220000000086.2101823251036306.161937000000HE3

13NMOFFSET HE3 2.0M LEFT
09F1
S4

1873

26.350400000000086.0417014778084314.111125500000HE3

09F1

S4

1874

36.881090000000086.4799984710826316.234896000000HE3

09F1

S4

1875

45.070550000000086.8506673231004318.345708000000HE3

09F1

S4

1876

56.991010000000087.4670758972154318.269134018868HE3

09F1

S4

1877

58.376750000000087.5556657440944316.922418000000EP

09F1

S4

1878

60.863180000000087.5235304357424318.604251600000B10

09F1

S4

1879

60.548220000000087.5381532946088326.509790400000B10

From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select 'RAWsdr33dc.dc' from '\SCC\Tutorials' directory
Select 'Open'
Select 'OK'

Set 'Search remarks for dimensions'
Select 'OK'
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Note that the option to strip string numbers from field codes has bee selected with the
'Coordinate Reduction Options'.

Trimble DC Format
SCC also supports the direct download of DC format as follows:
D2NM1021.70000000000
69FD
S22
11
E0NM
S22
E1NM
S22

0.14200000000000
137412.769000000253513.23000000046.1450000000000CON
1.620000000000001.000000000000001
S21
190.187083794199

77NM1.500000000000002.000000000000000.00000000000000
D9F1
S22
S21
91.250749347157591.8136377610403190.187083794199CON
50.003182501540000.001388888888890.00138888888889
A6F1
-0.00090101528280.00846784874555
D9F1
S22
1
90.790027562819091.9271004383258190.244880000000S
10.010181580100000.001388888888890.00138888888889
D9F1
S22
2
90.795487574480291.9263806245318190.249560000000S
10.010181591020000.001388888888890.00138888888889
77NM2.000000000000002.000000000000000.00000000000000
10.010192322360000.001388888888890.00138888888889
D9F1
S22
8001
86.761130395951992.3277570859462213.880050000000HEC1
10.010173522320000.001388888888890.00138888888889
D9F1
S22
8002
77.753634782899292.0915956056461219.797010000000HEC1
10.010155507320000.001388888888890.00138888888889
77NM1.500000000000002.000000000000000.00000000000000
D9F1
S22
8003
73.815260826027192.3056179106150224.597520000000HEC1
10.010147630580000.001388888888890.00138888888889
D9F1
S22
8004
68.620739011095391.8354586405055234.321300000000HEC1
10.010137241520000.001388888888890.00138888888889
D9F1
S22
8005
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64.289547497628291.1620741098151249.494310000000HEC1
10.010128579120000.001388888888890.00138888888889

From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Sokkia SDR33/22 & Trimble TSC'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select File
Select 'Open'
Select 'OK'

Set 'Search remarks for dimensions'
Select 'OK'

Trimble/Geodimeter UDS
SCC supports Trimble/Geodimeter format and can be processed as follows:
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data Logger to 'Trimble/Geodimeter UDS'
Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type
Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required
Select ‘OK’
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Select the file you require and ‘OK’
Additional settings may be checked at this stage that relate to the field coding standards
used that are particular to a given instrument. Note that these settings will become the
defaults for all future downloads from the Geodimeter and do not have to be entered with
each download.

Codes 90 through to 99 in the Geodimeter are user definable and may be used log extra
dimensions in SCC. For existing ‘Landscape’ users, the first time we download into SCC,
we will also have to set up the coding options as shown above. The LandScape coding
options determine how the numeric field codes entered in the instrument will be translated
into SCC tag codes, DTM codes, and ancillary measurements based on existing ‘
Landscape’ techniques.
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SCC lets us freely mix data from a range of different instrument manufacturers and
instrument types within a given project. The LandScape processing options are currently
enabled for the Geodimeter and Leica instruments.

Transferring survey data from a Geodimeter CU
Connect the Geodimeter instrument/keyboard to the PC with the appropriate cable and
through the correct communications port. Enter program 54, for data transfer.
Choose from which device the data will be transferred from Internal memory (2. Imem) or
Serial (3. Serial). Select internal memory (2. Imem).
Select the file type for transfer from 1. Job (file), 2. Area (file), 3. U.D.S. Choose option
number 1 - Job file, and type in the job file number in which the observed data is stored.
Choose destination device for the job file from 2. Imem (internal memory) and 3. Serial
(serial device - PC). Select 3 - Serial and accept or enter the correct serial parameters,
which are Com=1.8.0.9600. Prepare SCC(PC) before accepting the serial parameters
because once the serial parameters have been accepted then the data will be transferred.
The display on the Geodimeter/keyboard shows ‘Wait’ during the data transfer. When the
data transfer is finished the Geodimeter/keyboard will exit from program 54 and return to
program 0.

Transferring Setting Out and Control data to a Geodimeter CU
Connect the Geodimeter instrument/keyboard to the PC with the appropriate cable and
through the correct communications port. Enter program 54, for data transfer.
Choose from which device the data will be transferred from Internal memory (2. Imem) or
Serial (3. Serial). Select Serial (3. Serial) and accept or enter correct serial parameters,
which are Com=1.8.0.9600
Select file type for the data to be saved as from 1. Job (file), 2. Area (file), 3. U.D.S.
Choose option number 2 - Area file, and type in the area file number in which the data is
to be stored.
The display on the Geodimeter/keyboard shows "Wait" and is now ready to receive data.
Start the data transfer from SCC. When the data has been transferred the
Geodimeter/keyboard will exit from program 54 and return to program 0.

24.3

Examination of Sample Code List For Trimble Unit
A sample feature code list 'ATLAS_AM_DCC_ALPHA.fal' is availalbe for use with Survey Pro
onboard software. This codelist contains attributes such as dimensions, offsets, parallel
features. The 'ATLAS_AM_DCC_ALPHA.fal' codelist should be used in conjunction
'Trimble_TSCE_ALPHA.Project' feature library in which all features coincide.
The following examines the feature library 'ATLAS_AM_DCC_ALPHA.fcl' within Trimble
Geomatics Office:
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Open Trimble Geomatics Office Software, select 'Utilities > Feature and Attribute Editor'
Within the Feature and Attribute Editor' dialog, select 'FILE > Open'
Select 'ATLAS_AM_DCC_ALPHA.fcl'

Template Features
5 specific template features have been set up within Trimble Geomatics Office which all
other features are based. As a result, the library can be quickly edited by amending or
changing the 5 main features on which all other features are based.
The following outlines each and details the attributes assigned:

'SO' Spot Height Feature set up as a 1pt Feature:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

SO

LINETAG

G

DTM

D

Spot Height

DIM1
REMARK
LOSLR
LOSFB
ZOFSUD
NOTE:
LINETAG - Line Connection Tag, DTM - DTM Status, DIM1 - Dimension 1, LOSLR - Line
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Of Sight Offset Left / Right, LOSFB - Line Of Sight Offset Forward / Back, ZOFSUD Elevation Offest Up / Down

All other 1 point Features have been set up based on 'SO'.
Therefore, if you double click on a 1 point feature in the Feature and Attribute Editor or
right click mouse on 1 point feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'SO'. In the example below, Sign 1 point 'SGO' uses
'SO' :
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The following diagram demonstrates the relationship of the attributes within Trimble
Geomatics Office 'Feature and Attribute Editor' dialog and the actually screens from the
instrument showing the attribute:

To globally edit all 1 point feature the feature 'SO' can be modified.
For instance, if you do not wish to have specific attributes assigned to a 1 point feature,
the feature 'SO' can be edited and in turn, all 1 point features based on 'SO' will be
modified.
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'KT' Kerb Top Feature set up as a String:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT
VALUES

KT

STRING

1

LINETAG

S

DTM

D

Kerb Top

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
COPYFEAT
COPYLR
COPYUD
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back, COPYFEAT - Copy Feature,
COPYLR - Copy Feature Left / Right Offset, COPYFB - Copy Feature Forward / Back
Offset
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All other strings have been set up based on 'KT'.
Therefore, if you double click on a string feature in the Feature and Attribute Editor or right
click mouse on string feature and then select 'Properties' you can see the 'Uses actions of
another feature' is set to 'KT'. In the example below, Bottom of Bank string 'BB' uses
'KT' :
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The following diagram demonstrates the relationship of the attributes within Trimble
Geomatics Office 'Feature and Attribute Editor' dialog and the actually screens from the
instrument showing the attribute:

To globally edit all string features, the feature 'KT' can be modified.
For instance, if you do not wish to have specific attributes assigned to a string, the feature
'KT' can be edited and in turn, all stings based on 'KT' will be modified.
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'MHRT' Manhole Feature set up as a 3 Point Rectangular:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

MHRT

LINETAG

Rec3

DTM

D

Manhole 3pt Rec

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 3 point rectangles have been set up based on 'MHRT'.
Therefore, if you double click on a 3 point rectangles feature in the Feature and Attribute
Editor or right click mouse on a 3 point rectangles feature and then select 'Properties' you
can see the 'Uses actions of another feature' is set to 'MHRT'. In the example below,
Recycle Bin 3 point rectangle 'RBT' uses 'MHRT' :

To globally edit all 3 point rectangles features, the feature 'MHRT' can be
modified.
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'MHRW' Manhole Feature set up as a 2 Points plus Width:
FEATURE

DESCRIPTION

ATTRIBUTES DEFAULT
VALUES

MHRT

Manhole 3pt Rec

LINETAG

Rec2

DTM

D

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 2 point plus width have been set up based on 'MHRW'.
Therefore, if you double click on a 2 point plus width feature in the Feature and Attribute
Editor or right click mouse on 2 point plus width feature and then select 'Properties' you
can see the 'Uses actions of another feature' is set to 'MHRW'. In the example below,
Recycle Bin 3 point rectangle 'RBW' uses 'MHRW' :

To globally edit all 2 point plus width features, the feature 'MHRW' can be
modified.
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'ARAHL' Arrow Ahead Left Feature set up as a 3 Points:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

ARAHL

STRING

1

LINETAG

S

DTM

D

Arrow Ahead Left

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
COPYFEAT
COPYLR
COPYUD
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back, COPYFEAT - Copy Feature,
COPYLR - Copy Feature Left / Right Offset, COPYFB - Copy Feature Forward / Back
Offset
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All other 3 point features have been set up based on 'MHRW'.
Therefore, if you double click on a 3 point feature in the Feature and Attribute Editor or
right click mouse on a 3 point feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'ARAHL'. In the example below, Arrow Ahead Right 3
point rectangle 'ARAHR' uses 'ARAHL :

To globally edit all 3 point features, the feature 'ARAHL' can be modified.

'OE' Line Eircom Overhead Feature set up as a 2D (Approx Elevation)
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String:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT
VALUES

OE

STRING

1

LINETAG

S

DTM

A

Eircom Overhead

REMARK
DIM1
LOSLR
LOSFB
ZOFSUD
PARLR
PARFB
TAPELR
TAPEFB
NOTE:
STRING - String No., LINETAG - Line Connection Tag, DTM - DTM Status, REMARK Remark / Note, DIM1 - Dimension 1, LOSLR - Line Of Sight Offset Left / Right, LOSFB Line Of Sight Offset Forward / Back, ZOFSUD - Elevation Offest Up / Down, PARLR Parallel Offset Left / Right, PARFB - Parallel Offset Forward / Back, TAPELR - Tape
Offset Left / Right, TAPEFB - Tape Offset Forward / Back
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All other 2D string features have been set up based on 'OE'.
Therefore, if you double click on a 2D string feature in the Feature and Attribute Editor or
right click mouse on a 2D string feature and then select 'Properties' you can see the 'Uses
actions of another feature' is set to 'OESB'. In the example below, ESB Overhead 'OESB'
uses 'OE' :

To globally edit all 2D string features, the feature 'OE' can be modified.

'TO' Tree Feature set up as a 2D (Approx Elevation) 1 point feature with
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specific Dimension Attributes for Canopy and Trunk Size:
FEATURE DESCRIPTION

ATTRIBUTES DEFAULT VALUES

TO

LINETAG

G

DTM

A

Tree

DIM1
DIM2
DIM3
REMARK
LOSLR
LOSFB
ZOFSUD
NOTE:
LINETAG - Line Connection Tag, DTM - DTM Status, DIM1 - Dimension 1, DIM2 Dimension 2, DIM3 - Dimension 3, REMARK - Remark / Note, LOSLR - Line Of Sight
Offset Left / Right, LOSFB - Line Of Sight Offset Forward / Back, ZOFSUD - Elevation
Offest Up / Down
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Examination of Feature File and Raw Data within SurveyPro software
The following screenshots have been captured from Survey Pro to demonstrate the attributes
set up in 'ATLAS_AM_DCC_ALPHA.fal'. Three common survey field codes have been
examined 'BB' Bottom of Bank, 'SO' Spot Height and 'TO' Tree. In turn, extracts from raw
survey data are displayed. Note that, Tsce attributes are stored in 13AT records.
The drop down code list can be accessed within the main 'Measure Top' screen

'BB' Bottom Of Bank String Feature and Attributes:
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09F10003100034.698000090.7002777159.380833BB
13ATSTRING
1.00000000000000
13ATLINETAG
S
13ATDTM
A
13ATREMARK
13ATDIM1
13ATLOSLR
13ATLOSFB
13ATZOFSUD
13ATPARLR
13ATPARFB
13ATTAPELR
13ATTAPEFB
13ATCOPYFEAT
13ATCOPYLR
13ATCOPYUD

0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000

'SO' Spot Height Point Feature and Attributes:
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09F10450106819.867000090.5027777255.889444SO
13ATLINETAG
G
13ATDTM
E
13ATDIM1
0.00000000000000
13ATREMARK
13ATLOSLR
0.00000000000000
13ATLOSFB
0.00000000000000
13ATZOFSUD
0.00000000000000

'
TO' Tree Point Feature and Attributes:

09F10450106738.205000090.0836111263.203611TO
13ATLINETAG
G
13ATDTM
A
13ATREMARK
OAK
13ATDIM1
13ATDIM2
13ATDIM3
13ATLOSLR
13ATLOSFB
13ATZOFSUD

10.0000000000000
0.75000000000000
1.00000000000000
0.00000000000000
0.00000000000000
0.00000000000000

Note:
Many attributes contain drop down menus. For instance, several line connection tags
(tabulated below) which determines the connective geometry and specifies how the
current point on the string will be connected to the next point on the string are included as
a drop down menu.
Alpha Code

Description

S

Straight

C

Curve

A

Arc

G

Gap

L

Link Back To First Point on the String

DC

Discontinuous Curve (Non-Tangential
Incoming Tangent from Straight to Curve)

DS

Discontinuous Straight (Non-Tangential
Outcoming Tangent from Straight to Curve)
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Ar3

Three Point Arc

Cr3

Three Point Circle

Cr2

Two Point Circle

C1R

Radius and Centre Circle

Rec3

Three Point Rectangle

Rec2

Two Point and Width Rectangle

In the same manner, common DTM (Digital Terrain Model) status code which determines
the significance of the point of the surface model / digital terrain model are set up
(tabulated below). As such DTM controls whether the point is 2D or 3D, whether it should
be used in surface model generation and subsequent contouring and other surface
analysis, and whether it lies on a string forming the model boundary.

24.4

Alpha Code

Description

D

DTM Elevation

A

Approximate Elevation (2D Point)

E

Non DTM Elevation

I

Ignore

X

DTM Elevation with text turned off on download

Download Trimble Data with Specific Attributes
Processing & Download Steps:
To process a file containing information based 'ATLAS_AM_DCC_ALPHA.fal' within SCC:
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From the Main Menu Bar, select ‘FILE >New Project’
Enter in a Project/Job name
Select a Project Template from the list 'Trimble_TSCE_ALPHA.Project'
Select ‘OK’
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data logger to 'Trimble TSC/TSCe (DC)'
Highlight ‘Detail Topography’ as the Data Type
Set Input Device to 'Disk'

Select 'OK'
Select file
Select 'Open'
Select 'OK'

Select 'View>>' beside 'SDRMap Coding Extensions'
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Note:
The default library 'Trimble_TSCE_ALPHA.Project' already contains existing field codes
within the Extended field coding table.
The dataset will be presented.

24.5

Creating A Model
Go to ‘FILE > Model > SCC Dataset'
Select ‘Create the model and triangulation’ and set Initial Plot Scale of 250
Select 'FILE > Save As'

25

Working With Leica Data
The following tutorial provides information relating to the downloading and processing of Leica
data within SCC.

25.1

Create A Project
A new project should be created before data may be downloaded into SCC or models
formed.
From the Main Menu Bar, select ‘FILE >New Project’
Enter in a Project/Job name
Select a Project Template from the list
Select ‘OK’

25.2

Download Leica Data
SCC includes a number of different Leica interfaces to support correspondingly different
data collection strategies. The simplest of these is the TPS series interface which maps
user definable fields on the instrument directly onto SCC observation fields.
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Downloading Leica Data
From the Main Menu Bar, select ‘FILE > Download Survey Data’
Set Survey Data Logger to 'Leica GS1 8/16'
Highlight ‘Traverse’ or ‘Detail Topography’ as the Data Type
Set Input Device to 'Dsk', 'RS323 port (cable) 'or 'Atlas communications controller' as
required
Select ‘OK’
Select the file you require and ‘OK’

In this case, for example, field 41 on the instrument will be used to store the SCC feature
name. Any SCC fields that are not being recorded in the field should be set to 99.
Note that these settings will become the defaults for all future downloads from the Leica
and do not have to be entered with each download.
An alternative method is to use the LisCADD or WildSoft style coding (Leica 1100/1200
(GSI config)) which will be more familiar to LisCadd users. In this case field 41 on the
instrument is always used to determine what is stored in other instrument fields. For
example, in the dialog shown below, if field 41 contains the word ‘FEATCODE’ the feature

©2015 Atlas Computers Ltd

454
code is expected in field 42, whereas if it contains ‘Remark’ a survey remark is expected
in field 42.

Note that in both cases, a traverse feature code may be provided to determine that
subsequent observations are to be included in the traverse spreadsheet. This is provided
to facilitate combined detail topography and traverse surveys.

Leica 1200 Data Input
The following outlines the transfer of format files on to a Leica1200 system and the use of
the 'SCC Sys1200.FRT' file. Download steps into SCC are noted. The use of extra
measurements such as 'Line of Sight offsets, Tape Offsets, Parallel Offsets, Dimensions
and Remarks are examined.

A. Files for SCC Coding on Leica TPS1200 Series instruments:
SCCSys1200.FRT

Format File (*.FRT) generated in Leica GEO
Office to a System 1200 sensor

badleyt_0405_211712.xcf

Parameter Files

badleyt_0405_211712.x23
badleyt_0405_211712.x06

B. Setting up Coding on the TPS1200:
a)Transfer of Format Files on PC:
· Copy Format Files to the Convert Directory on the Compact Flash [CF] Card
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· Copy the *.xcf, *.x23 and *.x06 files into the Code Directory on the Compact Flash [CF]
card
Note:
The Compact Flash card must always be “Stopped” before removing it from your
computer. The System 1200 sensor must always be switched off before removing the
Compact Flash.
b)PC Card in the instrument – Format File:
· Select option 6 Tools… from the Main Menu

This option can be selected by pressing the number 6 key, or by navigating to 6 Tools...
and pressing the Enter key, or by touching the Tools… icon when using an active touch
screen
· Select option 2 Transfer Objects… from the Tools Menu.
· Select option 6 Format Files from the Transfer Objects Menu

· Select the Format File (SCCSys1200.FRT) you wish to transfer, from the CF Card, to
the SystemRAM, in the Transfer Format Files screen.

· Select CONT [F1]
The System 1200 sensor will return to the Main Menu once the Format File transfer is
completed.
c)PC Card in the instrument – Transfer Configuration Sets:
· Select option 6 Tools… from the Main Menu
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· Select option 2 Transfer Objects from the Tools Menu
· Select option 2 Configuration Sets from the Transfer Objects Menu
· Set up appropriately (TC, TCRP RCS etc.):

· Select ‘F3 – ALL’
d)PC Card in the instrument – Configuration:
· Select option 5 Configuration… from the Main Menu
· Select option 4 Interfaces from the Configuration: TC Menu

· Select GSI Output

· Select ‘F1 – CONT’

C. Setting up Survey
a)PC Card in the instrument – Management:
Select option 3 Management… from the Main Menu
Select 1 Job from Management Menu
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· Select F2 New from Job (CF Card) Menu

· Within General Tab enter relevant details:

· Tab to Codelist and ensure that the setting assigned in Step C d
(Transfer Codelist) have been attained

· Within Tab Coord System select None
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· Within Avge Tab select Off

· Select F1 Store
· Within Main Job Screen select F1 CONT with TEST highlighted

D. Setting up Stations within 1200 Series:
(Known Azimuth)
· Select option 1 Survey… from the Main Menu

· Set up the appropriate Reflector
· Set Method to Known BS
· Select Frm Fixpoint Job as Station Coord

· Select F1 CONT to access the Station Setup Panel

· With Station ID highlighted select Enter (or Tap on Station ID focus)
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· Select F2 NEW
· Enter Coords

· Within Code Tab
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· Select F1 STORE
· Select F1 CONT twice to return to Select Station Dialog
· Select Station ID and enter Instrument Height
· Select F1 CONT
· Enter A Backsight ID and set Azmuith

E. Surveying Detail with SCC Codelist:
Leica TPS1200 Coding
· After Station Set up select 1 Survey from Main Menu
· 4 tabs are available
· For Example
Go to Code tab:Enter Reflector Ht.
Assign Point Code either using arrows or double click to view Code and Code
Description Dialog

· Assign String, Line Tag and DTM Status appropriately
Offsets are available from either the offset Tab or by within the Free Codes ‘F7’.
Extra Measurements have also been set up within the Free Codes ‘F7’.

F.

SCC Settings for Leica coding using Leica TPS1200 Instruments
Open SCC and set up Project
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Select ‘FILE > Download Survey’
Select ‘Leica 1100/1200 (GSI Config)’ as Survey Data Logger
Select the required ‘Data Type’
Select ‘Data logger input Device’
Select ‘OK’

Select ‘Leica1200.GSIConfig’ Format File
Set up additional settings as shown below:

Select ‘OK’

Traverse Observation Feature Code
Traverse Observation Feature Code field should be filled with the user’s individual code
i.e. PSSA or STN etc.
If this is not filled in, no stations file will be produced.

©2015 Atlas Computers Ltd

462
Always include the decimal point when inputting any number so that SCC knows the units
i.e. 12.0 or 0.25

G. Tag Codes
The tag code determines the connective geometry and specifies how the current point on
the string will be connected to the next point on the string. This can be used to specify
straight lines, curves, arcs, and squared up pieces of geometry in a string. The tag codes
may be entered either in numeric or alpha-numeric format.

H. DTM Tag Code
The DTM (Digital Terrain Model) status code determines the significance of the point of
the surface model / digital terrain model being generated. The DTM codes may be
entered either in numeric or alpha-numeric format

I.

Extra measurement fields
Extra user defined GSI fields may be used to collect extra measurement information
corresponding to the SCC extra measurement sheet.

Several offsets are available as part of the main interface:
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The Offsets are as follows:
Offset Cross:

Line Of Sight L/R (Radial Offset)

Offset Length:

Line Of Sight F/B (Lateral Offset)

Offset Height:

Elevation offset.

Additional Extra Measurements have been set up as part of the Free Codes (F7):

Free Code:

Line OF Sight
The ‘-Left+Right’ offset corresponds to the distance left or right along the line of sight
between the instrument and the target.
The ’–Forward+Back’ offset corresponds to the distance forward or back along the line of
sight between the instrument and the target.
The ‘–Up+Down’ offset corresponds to the elevation offset.

Point 101:

Line of Sight Offset to the left –3.500
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*110017+0000000000000101 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410018+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+0000000000-3.500
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 102:

Line of Sight Offset to the Forward -6.500

*110019+0000000000000102 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410020+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+000000000000.000
46....+0000000000-6.500 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 103:

Line of Sight Offset to the Down +10.00

*110021+0000000000000103 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000PS 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410022+000Line of Sight 42....+0000000000000000
43....+0000000000000001 44....+0000000000000000 45....+000000000000.000
46....+000000000000.000 47....+000000000010.000 48....+0000000000000000
49....+0000000000000000
Tape
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The’–Forward+Back’ offset corresponds to the distance forward or back along the line
(Baseline) connecting the last two survey points.
The ‘-Left+Right’ offset corresponds to the distance left or right along the line (Baseline)
connecting the last two survey points.
The ‘–Up+Down’ offset corresponds to the elevation offset.
Point 201:

Tape Offset to the Back +2.300

*110026+0000000000000201 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410027+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+000000000002.300
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 202:

Tape Offset to the Right +4.500

*110028+0000000000000202 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410029+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+0000000000000000
46....+000000000004.500 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 203:

Tape Offset to the Up -8.000
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*110030+0000000000000203 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+0000000000000PST 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410031+000000000000Tape 42....+0000000000000000
43....+0000000000000002 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000-8.000 48....+0000000000000000
49....+0000000000000000
Parallel Offset

‘Dist Offset’ corresponds to the distance between the observed feature line and the
generated feature line (Feature?).
‘Elev Offset’ corresponds to the elevation offset.

Point 302:
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*110035+0000000000000302 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TB 72....+0000000000000056 73....+000000000000000S
74....+000000000000000D *410036+00000000Parallel 42....+0000000000000000
43....+0000000000000003 44....+00000000000000HE 45....+0000000000-2.500
46....+000000000000.000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 302:

Parallel Height Offset – Offsetting HE in Z +2.500 from TB Feature

*110037+0000000000000303 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TB 72....+0000000000000056 73....+000000000000000S
74....+000000000000000D *410038+00000000Parallel 42....+0000000000000000
43....+0000000000000003 44....+00000000000000HE 45....+000000000000.000
46....+000000000003.200 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Dimension
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This option allows the user to manually input a Dimension 1 and Dimension 2 value.
Point 401:

TC feature with assigned D1 of 5.0 and D2 of 0.500

*110040+0000000000000401 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TC 72....+0000000000000000 73....+000000000000000S
74....+000000000000000D *410041+000000Dimensions 42....+0000000000000000
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000000000 48....+000000000005.000
49....+000000000000.500
For example, Feature ‘Tree’ may have a Dimension 1 value denoting the Canopy size and
also a Dimension 2 referring to Tree Trunk size.

Remarks
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Additional annotation can be assigned to a specific point with ‘Remarks’.
Point 95:

WALL feature with assigned Remark ‘BRICK’

*110043+0000000000000095 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+000000000000WALL 72....+0000000000000001 73....+000000000000000S
74....+000000000000000D *410044+0000000000Remark 42....+00000000000BRICK
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
Point 376:

TC feature with assigned Remark ‘OAK’

*110045+0000000000000376 21.044+0000000008100000 22.044+0000000008100000
31..00+0000000000010000 51....+000000000000+000 87....+0000000000001500
71....+00000000000000TC 72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 *410046+0000000000Remark 42....+0000000000000OAK
43....+0000000000000000 44....+0000000000000000 45....+0000000000000000
46....+0000000000000000 47....+0000000000000000 48....+0000000000000000
49....+0000000000000000
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J.

Traverse observation feature code (not specific to 1200)

An extra user defined feature code may be used to signify a control observation. This
observation will be used as a reference observation in the instrument set-up sheet and as
a traverse observation in the traverse sheet. This facilitates combined detail and traverse
surveys using the GSI format. If this field is left blank, and tag codes are not being
collected, all observations will be output to the traverse sheet. If this field is left blank and
tag codes are being collected, observations with tag codes of FS, BS, and SS will be
output to the traverse sheet.

K. Store Station co-ordinates (not specific to 1200)
Tick this field if you want to store station coordinates present in the input file, in fields 84 to
86, in the SCC project control file.

L.

Codes precede observations (not specific to 1200)

This option controls whether a code block is associate with the preceding observation, or
the following observation. For example, in the input below the code block precedes the
data block
410006+000000KB 48....+0000000S 47....+0000000D 49....+00000002 110007+00000169
21.304+12359530 22.304+09515230 31...0+00003502

M. Use Topo X,Y,Z in preference to HA,Va,Sd (not specific to 1200)
This option allows the computed X,Y,Z positions in the GSI input file to be stored in the
SCC observation sheet rather than the Ha,Va,Sd values, where both occur in a single data
line. This is useful if the GSI file does not include all of the survey observations, such as
observed back-sights, as shown in the example below;
*110001+000000000000GR0A 84..10+0000000320728329
85..10+0000000376869559 86..10+0000000000099259
*110002+000000000000GR01 81..00+0000000320715339
82..00+0000000376754428 83..00+0000000000100000
*110003+000000000000GR0A 84..10+0000000320728329
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85..10+0000000376869559 86..10+0000000000099259
87..10+0000000000001500 88..10+0000000000001602
79....+000000000000GR01
*110004+0000000000000066 21.324+0000000018626250
22.324+0000000008940550 31..00+0000000000115851
87..10+0000000000001500 71....+0000000000000000
72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 81..00+0000000320715334
82..00+0000000376754441 83..00+0000000000100005
*110005+0000000000000067 21.324+0000000015216010
22.324+0000000008744130 31..00+0000000000074790
87..10+0000000000001500 71....+0000000000000OSC
72....+0000000000000000 73....+0000000000000000
74....+0000000000000000 81..00+0000000320763106
82..00+0000000376803412 83..00+0000000000102315

Case Study
Case 1:

Tape Offset

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D
*110015+000000000000002 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D
*110016+000000000000003 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+000000000000000S 74....+000000000000000D
*410017+000000000000003 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+0000000000000000 46....+000000000002.250
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000
*410017+000000000000004 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+000000000004.760 46.... +000000000000000
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000
*410017+000000000000005 42....+0000000000000000 43....+0000000000000002
44....+0000000000000000 45....+0000000000000000 46....-000000000000.700
47....+0000000000000000 48....+0000000000000000 49....+0000000000000000
Tape Offset Pt. 3: Longitudinal Offset of +2.250
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New Baseline is now Pt. 2- Pt. 3
Tape Offset Pt. 4: Lateral Offset of +4.760m (+Right)
Baseline now Pt. 3 – Pt. 4
Tape Offset Pt. 5:

Case 2:

Lateral Offset of -0.700m (-Left)

2 Point Symbol OR 2 Point + Width

2 Point Symbol
*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000030 73....+000000000000000S 74....+000000000000000D
*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000030 73....+000000000000000S 74....+000000000000000D
Within the Project File assign ‘2Point Symbol (Side)’ Symbology and select a Dimension 1
symbol which has side intersection points.

Within the Project select ‘EDIT > Symbols > Edit symbols insert point’
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Case 3:

2 Point + Width

Manhole / Utility Cover

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000020 73....+0000000000000R2W 74....+000000000000000D
*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000MH
72....+0000000000000020 73....+0000000000000R2W 74....+000000000000000D
*410041+000000Dimensions 42....+0000000000000000 43....+0000000000000000
44....+0000000000000000 45....+0000000000000000 46....+0000000000000000
47....+0000000000000000 48....+000000000002.000 49....+0000000000000000

Case 4:

2 Point Circle

*110015+000000000000001 21.324+0000000001732120 22.324+0000000008645360
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31..00+0000000000030223 81..00+0000000000109092 82..00+0000000000128773
83..00+0000000000013208 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+00000000000000C2 74....+000000000000000D
*110016+000000000000002 21.324+0000000000927290 22.324+0000000008548510
31..00+0000000000030413 81..00+0000000000104984 82..00+0000000000129919
83..00+0000000000013720 87..10+0000000000000000 71....+00000000000000BG
72....+0000000000000020 73....+00000000000000C2 74....+000000000000000D

25.3

Creating A Model
Go to ‘FILE > Model > SCC Dataset'
Select ‘Create the model and triangulation’ and set Initial Plot Scale of 250
Select 'FILE > Save As'

26

Point Cloud Module
To start using this functionality you must have the point cloud module licensed and can either
create your own point cloud models or use the samples provided (Cathedral, Topo, and
Bridge).

26.1

Importing Point Cloud Data
To create a new point cloud model you need data in either PTS, LAS, LAZ, or ESRI ASC
format.
To start, select 'FILE > Model > Point clouds & LIDAR' and pick the appropriate input format.
This will show the following screen;

The colour usage option controls how much space is used per point, where RGB12 allows
about 100 million points on a system with 1GB available memory. Palette colouring is slower to
import data, but more efficient at the loss of some colour resolution. Selecting the Create
palette option builds a palette and cloud feature library, based on paramers selected. This can
be an optimized palette from the cloud RGB data, a colour range corresponding to intensities,
or the standard AutoCAD 256 colour or VGA 16 colour palettes.
Pressing the Edit button allows you to make further edits to the point cloud feature library, and
save it for re-use on other point clouds. This will be explained in more detail later on in this
tutorial.
Point cloud functionality is accessed in the model via the Cloud menu and / or Point Cloud tool
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bar in the SCC model view.

In the current release of SCC a 13gb PTS file containing 270 million input points of X,Y,Z,
intensity (no RGB color) takes about 34 minutes to process on a dual core PC running
Windows 7 (64 bit) with 4GB of RAM. The SCC point cloud on disk comes out at 1.1gb, based
on using 16 levels of intensity. Using an RGB12 format the same data takes 1.6gb on disk and
takes 39 minutes. The current version of the software can handle approximately 300 million
rgb colour points or about 450 million grey scaled, palletized or monochrome points. Anything
larger than this would currently have to be broken into more than one file. This is based on a
32bit version of the software, where we are planning that the next major release will be a 64bit
version supporting multi-billion point clouds on PCs with more available RAM.

26.2

Selecting And Isolating Parts of the Cloud
The most commonly used option will be data selection, which shows the point cloud selection
dialog. The allows you to control how you are going to pick data (i.e. points in a window, points
in a polygon, using a horizontal or vertical section / slice, relative to an alignment, points similar
to a given reference point, points close to another SCC surface) and what to do with picked
data.

This includes selecting and deselecting data as per typical SCC usage, locking and unlocking
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data which hides the data and prohibits it from being used in future operations, and isloting data
which is the same as locking everything except the picked points.
To start with, we’ll open the Cathedral model, and isolate an area of interest using the
parameters as shown. After pressing All points close to a line and Isolate Data, the dialog is
closed, and we can select the section of interest by clicking either end of its centre line.
This highlights the area of interest as an elevation and switches the colour of all the locked
points to light gray. Pressing ‘P’ and ‘E’ we can move between plan and elevation view to get a
better idea of what has just happened.

We can also use the up, down, left and right arrows to advance and move the section relative
to the direction of view. The distance here is based on the Section offset increment in the data
selection dialog, which can also be brought up using the right mouse button. From plan view
we can also use the mouse at any stage to pick an alternate section as shown below;
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Other keyboard options are + and – to widen or narrow the area of interest, and L and X to
move between long section and cross section related view when selection a sectional area
relative to an alignment.
When a horizontal section / area of interest is in use the arrow keys may be used to raise or low
the elevation of the section.
Note that as you move the cursor around in you cloud, either in plan or another view, you see
the x,y,z position of the cursor in the cloud, and can snap to cloud positions as you would any
other survey point. How this works is controlled via Cloud Options, which also helps control
how the cloud is treated as a surface for section and volume analysis. Note that only active
points are used for snapping, and other operations such as data selection, and export. This
allows you to first select an area of interest for analysis purposes and hide all other parts of the
cloud, and then select further points from that area of interest for editing. To illustrate this
better we’ll open our topographic model, TOPO, which if we look at in elevation contains a lot of
trees and street furniture that we would like to exclude from any surface analysis such as
sections, volume, and contours.
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To get an elevation of the entire cloud, we’ll use 'VIEW > Rotate Viewpoint > Two point
elevation', picking points at either end of the road. While we can get all of the upper foliage
using a polygon selection method, trimming the trunks closer to the ground is more
problematic, as some are hidden behind hills, fences or in dips in the ground.

The solution here is to first isolate an area of interest, and then select from within that area, e.g.
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Note that one of the quickest ways of carrying out this type of analysis on a large topographic
model is to develop a rough SCC TIN model based on a sample of spot levels taken from the
cloud, and selecting all the points a set distance above this model, by ticking Height relative to
selected surface in the data selection dialog.
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Once we have data selected, we can copy it, delete it, re-colour it, and most importantly group it
by feature using 'Cloud > Edit selected points'. This is done using 'Cloud > Point cloud features'
, which shows the following dialog. Most commonly, we will be changing the feature of
selected points. Once we have have assigned features to groups of points we can then
process those groups and tell SCC how they work with different types of analysis.

26.3

Point Cloud Feature Library
The point cloud feature library is used to break down the cloud into groups of points on similar
feature, e.g. all points corresponding to vegetation, all points corresponding to the road surface
etc… This allows us to fine tune how analysis operations work, as this will change significantly
based on the type of feature. E.g. how we cut sections through the ground will be different to
how we cut sections through more complex 3d features such as buildings.

The point cloud feature fields are as follows;
· Feature – The name of the feature
· Surface – The surface on which the feature is placed. Note that you can have multiple
features placed on the same surface, e.g. trees and bushes might both go on a vegetation
surface
· Analysis – This controls how SCC interprets these points for surface analysis purposes.
Options are
o Display only – The points are displayed only, but not subject to analysis
o Ground – The points are treated in the same way as the triangulation surface in a normal
SCC model, from the point of view of sections, volumes, draping points, extracting levels,
etc…
o Other surface – The points are treated in a similar manner as an additional triangular
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surface, such as a reference model.
o Other 3d – The points are treated as a non-mappable 3d surface, not suitable for surface
analysis operations. Sectioning through 3d surfaces will be considerably slower than
ground / mappable surfaces.
· Colour – The default colour of this feature when not coloured by point
· Colur by point – Whether points on this feature have individual colours or the same colour
· Visibility – Controls whether or not these points are displayed, and if they are displayed
whether they are considered opaque or transparent.
· Lock – Whether or not these points are included in analysis
· Size – The size of displayed points
· Sect. Width – The search corridor width used when cutting sections through this feature.
Note this will typically be small for ground surfaces, e.g. 10mm, and larger for 3d surfaces,
e.g. 100mm – 500mm. The larger this value, the more 3d data will get projected onto a
section and analysed. This in turn can slow down processing and significantly increase the
size of sections produced.
· Max Dist. – For 3d features, the maximum distance to which points will be connected.
· Trace Dist. – For 2d features extracted by tracing selected points, the maximum distance
between adjacent points
· Min. Length – For all traced output, the minimum total string length allowed for a string to be
included in the output.
The cathedral and topo models already have some features applied. Thus is you cut sections
through them, you’ll see different items appearing. For example, if we use 'SECTION > Long
section with cursor' through our topo model taking in the tree above, we get the following;

And similarly for the cathedral;
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The feature library is also very useful for quickly colouring and analysing monochrome point
clouds, as shown in the model below (Tunnel 950-1050 (edited).Model)

By selecting and isloting appropriate elevation and sectional areas, we can quickly differentiate
the tunnel, cabling, rails, and foliage. This in turn allows is to cut complex sections, develop a
ground surface and isolate features of interest.

26.4

Tracing Sections and Slices
In addition to cutting sections there are a number of other ways to extract linear data and
analyse cloud surfaces. The simplest of these is via 'CLOUD > Trace outlines from slice',
which will draw outlines based on an isolated sectional area. This can be either from plan,
elevation or based on an oblique viewpoint.
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The results can then be exported to other packages, such as CAD, in 2d or 3d, and multiple
slices can be used to build-up a wire frame model from your cloud. The cloud feature library
determines how the data is analyses, where the centre of the displayed section or slice is used
as the centre-line for sectioning.

26.5

Tracing Linear Features On A Point Cloud
The option 'CLOUD > Trace Linear Features' allows us to trace linear features contained in a
point cloud by matching points on a section template to points in the cloud at regular chainages
along an alignment. This is done in a split screen view, with the template details shown below
the model, updated in real time as the template is developed.

©2015 Atlas Computers Ltd

485

The stages involved are as follows;

26.5.1 Select Or Create A Reference Alignment
This is a design line running roughly parallel to the features you want to extract. If you
already have a suitable alignment attached, you can pick it using the Ref Line drop down.
You can also interactively draw a new alignment as follows;
· Select an active tag code of Curve or Straight as require.
· Zoom into the area of interest in the model.
· Press New to create a new reference string.
· Left click on two or more points on the desired reference string.
· Right click to finish creating the reference string and start creating the template.
· The reference line will be saved such that it can be re-used later as required.
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26.5.2 Enter Template Size & Parameters
Before creating our template we need to enter its width and height in reference to the
centre line. We can also enter a vertical exaggeration to make it easir to find features
such as kerbs.

Having entered width, height, and vertical exaggeration, as we move the mouse along the
alignment in plan, we see a section cut through the cloud at the chainage corresponding
to the mouse position. Pressing the left mouse button will lock the chainage to the current
position, in order to allow us to create template points, pressing the right button unlocks
the chainage to examine sections at other chainages. It is important that the widths
specified are large enough to encompass the features being sought at all required
chainages.

26.5.3 Creating Points On The Template
Once we have locked the section at a given chainage position, we can add points to the
template either by left clicking on the section or the plan. This has the effect of adding
points to the section template overlaying the cut section, and showing the details of those
points in the accompanying spreadsheet to the right of the section drawing.
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Newly created points are given a feature name and type based on values entered. The
types are as follows;
· String – A string line will be output to the model based on this section template point.
For any given chainage, a point in the cloud corresponding to this point on the template
must be found for the template to valid.
· Point – A point will be output at each chainage to the model based on this section
template point. As per the string, this point is required for the template to be valid.
· Reference – Nothing is output to the model, but a point corresponding to this point is
required for the template to be valid.
· String (Opt) – A string line will be output to the model based on this section template
point, but it is not required for the template to be valid.
· Point (Opt) – A point will be output to the model based on this section template point,
but it is not required for the template to be valid.
Once the template points have been entered, right clicking the mouse allows us to unlock
the chainage and test how well the template matches the points in the cloud at differing
positions along the alignment.
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If the template is not valid at the current chainage, it is drawn in bright red. For example,
in the case above the left and right road edges don't exist so a match to the template is
not found. If those template points were optional, i.e. They had a type of String (Opt), the
section would still be valid.
We can also save our template to file once created, such that it can be re-used elsewhere
in this point cloud and future point clouds, simple by entering a template name and
pressing Save.

26.5.4 Creating Strings
Once we have created our template, we can generate our model by entering a chainage
range and interval, and pressing Create strings. To pick a From or To chainage simply
lock the section at the desired chainage by pressing the left mouse button and then
clicking on the required From or To chainage button.

Created strings seen here with the cloud turned on
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And below with the cloud turned off. Note the gaps in the strings at certain positions
where an acceptable match to the template could not be found. This will typically be due
to an interference factor, such as a car on the road obscuring the required point, or a
required template point not existing on the ground at a given chainage.

26.5.5 Linear Feature Extraction Parameters
Pressing the options button from the linear feature extraction dialog brings up an additional
parameters dialog that allows us to fine tune how the extraction process works. These
parameters are as follows;
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Maximum horizontal template shift from C/L
This controls how far the entire template can be shifted from the design centre line and still
remain valid. Larger values enable the same template to be used over a wider range of
conditions, but can also introduce incorrect data into the output.

Vertical tolerance for valid fit
This value, typically a few centimetres, is how close the relative height difference between
points on the ground and points on the template must be to be considered valid.

Horizontal search interval
This value, typically a few millimetres, is the search interval used when matching template
sections to cloud sections. The smaller the value, the better the probability of finding a fit, and
the improved accuracy of the fit, at a cost of processing speed.

Maximum chainage to join missed points
When the template does not match the ground at a given chainage no points are output.
Where the chainage distance between successive points on the same string fall above this
value, a gap is introduced into the string.

Allow stretch between left and right sides
This switch allows the left and right points on the template to be treated as separate templates.
This allows horizontal and vertical shift between left and right hand sides, while still holding the
template valid. It also allows strings on one side of the template to be valid, even if the other
side is not valid.

Hold horizontal offset (Force template value)
This forces the horizontal section template position to be held for all chainages

Hold vertical offset (Force template value)
This forces the height difference between section template points to be held for all chainages.
The default is that the output height is based on the cloud values where other tolerances are
met.
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Process all 3d surface features
This controls whether analysis is limited to cloud points on the primary ground feature, or
whether all 3d feartures are analysed as in the example above. Analysing all features is
significantly slower than limiting the analysis to ground features.

Grid colour
The colour of grid lines in the section display

Ground line colour
The colour of the interpolated ground line at the current chainage in the section display. Note
that other 3d features take their colours from their point cloud feature library entries.

In range section colour
The colour used to draw the template as fitted to the ground at the current chainage, when the
fit produces valid output based on the tolerances given.

Out of range section colour
The colour used to draw the template as fitted to the ground at the current chainage, when the
fit does not produce valid output based on the tolerances given. The details drawn are based
on the best fit found.

Template colour
The template line, not fitted to the ground, as it was originally entered

Grid interval
The horizontal and vertical grid interval on the section.

26.6

Extracting A TIN Surface From The Cloud
We can also triangulate selected areas of interest for further analysis and export to software
that does not support point clouds. In this case we’ve created a small alignment and selected
points in an area 7.5M either side of the centre line as shown below.
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To triangulate the data we select 'CLOUD > Triangulate points', which gives us the option of
producing an optimized triangulation of the selected data. This reduces the amount of points
used from the selected points in the cloud to just those required to achieve the stated vertical
tolerance, in this case 10mm.

Note, this option can be slow depending on the parameters and the number of points selected.
To improve performance and final result remove or isolate noisy features such as grass, trees,
cars, street furniture and overhead cables prior to running this option. Only selected points
whose features have an analysis type of Ground are considered when running this option, so
simply changing the feature of such points to any other feature will accomplish this.
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Other options relating to point cloud processing include linear feature extraction, density based
feature extraction (stringing clumps of points), tracing string manually in conjunction with cloud
snap, and use of other surface based tools in conjunction with the point cloud ground surface
rather than the TIN.
To add further information to our TIN model, from coarser areas of the model that may have
lower accuracy requirements, we can use 'TOOLS > Extract a grid of levels', and add the
generated data to the TIN created above, along with traced linear features such as kerbs
described earlier. Note that when extracting a grid of levels, it is best to select the option to
snap to the level of lowest point in the defined snap search radius, as this will tend to generate
a more uniform surface, skipping small vegetation and similar items. This is set under
'CLOUD > Point cloud options'.

26.7

Tracing 2D Features Such As Road Markings
We can also use the SCC point cloud module to trace outlines of features using a combination
of colour / intensity difference, height difference and distance from a reference point. To do this
we start by selecting similar points as shown in the selection dialog. We start by pressing the
Pick>> button to select a reference point for colour and position, and then press Select points to
highlight all the points that are similar to that reference point. Note that if we were trying to pick
up road markings we could first isolate the road area using a chainage / offset or polygon
selection first.
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Our selected data will appear as shown below;

We would typically now use additional reference points to add more data, and polygon based
de-selection of any areas that were included but not required. Removing points in this many
will also speed up the tracing process, and reduce the size of the output model. Selecting
'CLOUD > Trace selected points' produces the following;
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26.8

Using The Cloud With Other SCC Model Options
Most SCC options can interact with the cloud in a similar manner to the TIN surface generated
from a traditional total station or GPS survey. This is largely controlled by use of the point
snapping and sections mechanisms in 'Cloud > Cloud options'. The following snaps are
available;
· Do not snap to cloud – The cloud is not used with other SCC string creation functions.
· Snap to cloud for levels only – The cloud is used in plan view for interpolating elevations only.
· Snap to cloud in 3d – The cloud is snapped to in full 3d, regardless of the viewpoint.
When using could snaps, and interpolating from the cloud as a surface in general, a search
radius is used. If a cloud point is not found within this radius, the cloud snap fails. When
interpolating levels, the underlying TIN is used in place of the cloud in this circumstance. This
allows us to seamlessly mix TIN and cloud interpolation in a single model.
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Given that we’re searching for cloud points in a given radius, we can also control how the
selected point or points are determined and used as follows;
· Nearest point – The nearest point to the desired position, e.g. mouse cursor position, is used
· Lowest point – The point with the lowest elevation of the points in range is used. This can be
very useful for manually tracing lines such as bottom of kerb, where bottom of kerb and top
of kerb are very close and difficult to distinguish. If is also very useful for extracting grids of
elevations over ground that may include vegetation and other spurious high points on the
ground such as lamp posts. Note that this option is best selected with small search radii, and
used judiciously.
· High point - The point with the lowest elevation of the points in range is used. This can be
very useful for manually tracing lines such as top of kerb.
· Median point – The point nearest the mean position of all the points in the selection radius is
picked. This can be useful for drawing strings represented by dense linear groups of points
in the cloud, such as walls shown in the slice taken from the cathedral model previously.
· Mean point - The mean position of all the points in the selection radius is picked. This will not
correspond to any one point.
· Nearest 2d (Screen) – The point drawn on screen nearest the mouse cursor is picked.
For options such as sectioning, volumes, extraction of grids, draping of 2d data to extract
levels, etc… the option to Cut sections through the point cloud must be selected. This allows
the cloud to be used in a similar manner to a TIN surface for most SCC surface analysis
operations. Interpolation is limited to points with a feature Analysis set to Ground, so it is very
important to change the feature of all other cloud data, such as vegetation, buildings and
overhead lines, prior to interpolating from the cloud in this manner.
For sectional analysis, we can also specify a level tolerance for smoothing, and horizontal and
vertical tolerances for removing spikes from the section. This is necessary as cloud data is far
denser than conventional survey data and is prone to include a significant amount of noise.
Smoothing and spike removal also greatly reduces the size of the data extracted, which is also
typically beneficial.
Other options on the same dialog control how the point cloud is visualized. These control
whether the display is clipped behind and in front of the viewing plane, typically when using two
point elevations, and how isolated points are displayed. Note that clipping the view has no
effect on point selection in the way that isolating or disabling points would. Displaying Inactive
points allows you to see where your active points are in relation to the rest of the cloud.
Inactive points are always transparent and typically drawn in a lighter colour. Displaying a
©2015 Atlas Computers Ltd

497
reduced number or outline of isolated points will reduce display clutter and improve display
speed on larger clouds.

26.9

PTS Point Cloud Data
PTS data can be reduce, processed and compared within SCC. Additional options are also
available to extract linear features such as kerb lines from the data.

26.9.1 Extracting Linear Features From PTS Point Clouds
SCC can reduce, process and extract linear features such as kerb lines from PTS cloud data.
The steps are as follows:

Create a new project, or open an existing one
'FILE > Open > SCC Project' and pick 'PM-Clouds.Project'

Model PTS File
Select 'FILE > Model > Point clouds & LIDAR > PTS file' which will show the following
dialog:

The default options shown above stream in a RGB file which is mapped to a palette of 256
colours to an accuracy of 10mm. The fields are used as follows;

Stream and optimize for TIN modelling
Selecting this option inputs processes the point cloud in smaller sections such that SCC
can handle very large point clouds relatively quickly. As data is input it is optimized to the
specified vertical tolerance, and any points that would not make a change to the final
surface are discarded. This eliminates vast number of co-planar points where they exist,
leading to a much smaller, faster and more efficient TIN model without sacrificing any
accuracy as would be the case with simpler decimation techniques.
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Accuracy Tolerance
This is the vertical accuracy to which the TIN model is optimized. All points that would not
affect the final surface by more than this amount are removed.

Maximum Iterations
This specifies the maximum number of times the optimization process is repeated. If no
changes are made on any given iteration, the optimization is halted.

Optimization interval
This is the number of points at any given time that are held in memory when streaming
and optimizing.

Colour and intensity mapping
These fields control how the RGB colours and intensities in the input data are mapped
onto SCC features. Default colour mappings are No colour matching, 16 Colours, and
256 Colours.

Intensity Matching
Intensity matching is either off (No intensity matching), or grouped into a number of equal
ranges (Group by intensity), controlled by the Groups, From and To fields.

Create
Pressing Create will generate a list of features for the number of colours multiplied by the
number of intensity ranges. Each feature is mapped to the nearest SCC palette colour
and named based on colour and intensity. The scheme also includes a DTM field to allow
certain points to be either excluded from the surface or removed entirely. For example,
setting the DTM code to IGNORE for all colours that represent a shade of green would
strip most vegetation from the input data. Similarly points with low intensity values could
be easily excluded.

Scheme Name
File name, Save, New

Feature Mapping
These fields allow colour and intensity schemes to be saved and loaded to and from file
such that they can be re-used.
Using the 2.6 million point file available from the SCC Tutorials folder, 'ROAD-0mm.PTS'
yielded the following results on an older 2ghz Athlon based PC under XP with 2GB of
memory.
Vertical tolerance set to 10mm, 256 colour processing took 7 minutes and resulted in an
optimized TIN model of 47 thousand points taking 12mb on disk. The model is shown
below in plan, where we can see that the bulk of the points relate to the grass, the kerb
edges, and the instrument box and tripod.
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Using 'VIEW > Rotate viewpoint' the model can be viewed in perspective, as shown
below;
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By re-running to input with all colours except blacks and greys and very dark shades
filtered out as shown, we further automatically reduce the base model size to slightly over
27 thousand points.
This corresponds to automatic elimination of 99% of the input points to create a model

©2015 Atlas Computers Ltd

501
with a vertical accuracy of within 10mm of the original data.
To start creating strings, select 'TOOLS > Point Cloud Trace linear features' which will
split the screen with a new dialog on the bottom as shown. Tracing linear features is
broken down into two stages;
· Creating a reference line which involves drawing a polyline roughly parallel to the
features you wish to extract. For example on the drawing below, we created a
reference line by left clicking on the road beside kerb bottom at the top left hand corner
of the drawing and again at the bottom left hand corner of the drawing. Right clicking
closes the reference line, and switches to string selection mode. You can also change
geometry when creating curved or angled reference lines by picking the appropriate tag
code or geometry icon. So for example, the quickest way to create a reference line for
the curved sections in the model is to use a 3 point arc. All points on the reference
string should lie on the model, as this is a 3d entity corresponding to a simple alignment
string.

To start a new reference line, simply press the New ref line button, which is also useful if
you have made a mistake on your current reference line. Note that the reference line
should lie entirely on one side or another of the set of features we wish to extract.
· Selecting strings to extract. Once you right click when creating a reference line, you can
start selecting strings. As you move the mouse around the screen, you’ll notice a
sample section line in plan and in section on the bottom of the screen. The width of this
section is controlled by the Left Ofs and Right Ofs fields. Pressing the left button again
locks the chainage of the section, and as you move the mouse you will now see a
vertical line in on the section corresponding to the mouse offset position in plan.
Pressing the left mouse button again creates a point at the current offset, and adds it to
the spreadsheet beside the section. The feature name and position can be edited in
this sheet.
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Pressing the right mouse button unlocks the chainage and allows you to move the section
along the reference line, showing the selected points with the cut surface at varying
chainages.
Pressing the create button creates the selected strings based on the parameters given.
These are as follows;

Ch. Int.
This is the interval at which points will be created on the new string

Horiz. Tol.
This is the horizontal search distance that will be used to find a point from the cloud data
to add to the new string at the current chainage. The distance is an offset distance from
the reference point, and all points are searched within this distance and half the chainage
interval along the line.

Vert. Tol.
This is the vertical search distance that will be used to find a point from the cloud data to
add to the new string at the current chainage. The distance is a height difference from the
reference point, and all points are within the defined horizontal tolerance are search.
Where multiple points are found, the nearest point is selected.

Hold Hz Offset
If this option is selected, the new point is placed at the specified horizontal offset rather
than the offset of the nearest point found. The effects of this can be seen on the pictures
below
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Hold Vt Offset
If this option is selected, the new point is placed at the specified vertical offset rather than
the offset of the nearest point found.
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Hold regular chainage
If this option is selected, the new point is placed at the current chainage rather than the
chainage of the nearest point found.

Delete all points in hz offset range
This option deletes all the point cloud data within the specified horizontal distance of the
points created for the chainage ranges along the alignment where new points are added.

Break string links over given length
This option forces the output strings to be broken between chainages over the specified
length where not suitable cloud points are found for the new strings. In this case, extra
spot levels are added at the chainage interval and offset with heights interpolated from the
model, thus allowing deletion of extra unwanted points while maintaining the shape of the
surface. This can be seen in the drop kerbs in the circular sections of the example below.

Extracting the linear features using the parameters given, and using the polygon selection
options to delete the unnecessary grass points, tripod and instrument box, further reduces
the final model down to approx two thousand point. This string model is now usable in
most CAD, engineering, and visualisation packages with very little overhead, and
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represents a reduction in size by a factor of over a thousand from the original input data.

26.9.2 Processing PTS Point Clouds
SCC can reduce, process and compare point clouds in PTS format using SCC. The steps are
as follows;

Create a new project, or open an existing one
'FILE > Open > SCC Project' and pick 'PM-Clouds.Project'

Model PTS File
Select 'FILE > Model > Point clouds & LIDAR > PTS file' which will show the following
dialog;
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The default options shown above stream in a file in monochrome to an accuracy of 10mm.
The fields are used as follows;

Stream and optimize for TIN modelling
Selecting this option inputs processes the point cloud in smaller sections such that SCC
can handle very large point clouds relatively quickly. As data is input it is optimized to the
specified vertical tolerance, and any points that would not make a change to the final
surface are discarded. This eliminates vast number of co-planar points where they exist,
leading to a much smaller, faster and more efficient TIN model without sacrificing any
accuracy as would be the case with simpler decimation techniques.

Accuracy Tolerance
This is the vertical accuracy to which the TIN model is optimized. All points that would not
affect the final surface by more than this amount are removed.

Maximum Iterations
This specifies the maximum number of times the optimization process is repeated. If no
changes are made on any given iteration, the optimization is halted.

Optimization interval
This is the number of points at any given time that are held in memory when streaming
and optimizing.

Colour and intensity mapping
These fields control how the RGB colours and intensities in the input data are mapped
onto SCC features. Default colour mappings are No colour matching, 16 Colours, and
256 Colours.

Intensity Matching
Intensity matching is either off (No intensity matching), or grouped into a number of equal
ranges (Group by intensity), controlled by the Groups, From and To fields.

Create
Pressing Create will generate a list of features for the number of colours multiplied by the
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number of intensity ranges. Each feature is mapped to the nearest SCC palette colour
and named based on colour and intensity. The scheme also includes a DTM field to allow
certain points to be either excluded from the surface or removed entirely. For example,
setting the DTM code to IGNORE for all colours that represent a shade of green would
strip most vegetation from the input data. Similarly points with low intensity values could
be easily excluded.

Scheme Name
File name, Save, New

Feature Mapping
These fields allow colour and intensity schemes to be saved and loaded to and from file
such that they can be re-used.
Using the 16 million point file available from the SCC tutorials folder, 'CHECK1.PTS'
yielded the following results on an older 2ghz Athlon based PC under XP with 2GB of
memory.
Vertical tolerance set to 10mm, monochrome, processing took 29 minutes and resulted in
an optimized TIN model of 32 thousand points taking 4.6mb on disk. The model is shown
below with 0.1 meter contours;

Vertical tolerance set to 5mm, monochrome, processing took 42 minutes and resulted in
an optimized TIN model of 242 thousand points taking 25.5mb on disk. The model is
shown below with 0.1 meter contours;

While contours and sections from these models look almost identical, the higher
resolution model shows up line work relating to very shallow (<10mm) depressions in the
surface that may be of value to the client. There is also a dark patch near the centre of
the model, which is not present in the 10mm model, which correlates to the scanner
position. This suggests that the scanner is slightly less accurate or prone to interference
at very close ranges (e.g. ~5mm of noise at less than 10 meters range in this case).
Vertical tolerance set to 2mm, monochrome, processing took just under 4 hours and
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resulted in an optimized TIN model of 2.3 million points taking 362mb on disk.
For the purposes of this exercise a 5mm vertical tolerance was used throughout. The
same process was applied to BASE1.PTS which yielded a 48 thousand point model based
on 5mm optimization as shown below.

To compare the base and check models, use 'VOLUMES > Volumes between surfaces
(prismoidal)' using the default values, as shown below;

This generated an isopachyte (height difference) model shown below, which can be
coloured using relief contours as shown.

To take the test points in select 'FILE > Import > ASCII X,Y,Z' and pick the text file
provided, Laser Scan Pointstxt.txt.
The file will initially have the levels in the text file.
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Select 'FILE > Save' to save this to disk as an SCC dataset.
To extract height differences for the points in the text file, go back to the isopachyte model
and select 'TOOLS > Add ground levels to a dataset picking the dataset just saved and the
parameters shown.

Going back to the dataset view, it can be seen that any points that overlaid the two models
now have a height difference in the Z column.
To remove all the other points, select 'EDIT > Replace' with the values shown below,
followed by 'TOOLS > Delete ignored points'

Columns can then be copied and pasted to other programs such as Excel, Word,
Notepad, etc… as required. The values below have been copied from SCC;
Extract of file:
95
99
103
107
109
112
114
117

654.559
655.153
655.748
656.342
656.468
656.937
657.063
657.531

3009.412
3011.322
3013.231
3015.141
3008.818
3017.051
3010.727
3018.960

-0.1127
-0.0074
-0.0017
-0.0027
-0.1453
-0.0076
-0.0060
-0.0106

26.10 Cloud Volumes
This tutorial examines data from the Leica MS50. In addition, sample data is explored for
volume analysis.

26.10.1 Creating New Project
'FILE > New Project' as shown below:
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26.10.2 Importing MS50 Data
Insert the card from the MS50 into the PC, select 'FILE > Model > Point clouds and
LIDAR > Leica MS50', and pick the XCF file from your MS50 project

This tutorial uses the TOPO model from the SCC\Point clouds\Tutorials folder.

26.10.3 Rotating Viewpoints
The most important step computing volumes from point clouds is to ensure the cloud
model is free from data not related to the measurement such as vegetation, street
furniture, etc..
Select such data en-masse and change its feature. e.g. in the TOPO model compute the
volume of the roundabout island to the surrounding road as follows;
'VIEW > Rotate viewpoint > Two point elevation', select a line running through the area of
interest
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Note:
The option to allow setting a view point origin and orientation using the mouse and
keyboard has been made optional, such that those primarily working in plan can't
inadvertently change their viewpoint. This is controlled within 'FILE > General Options >
Units & Data Checking > Allow mouse to be used to rotate'

26.10.4 Cloud Data Selection & Editing
To select data, right click to bring up the Data selection dialog, followed by picking 'All
points in a polygon' and press Select data
On the model to select points for exclusion from the measure, press left click on mouse to
pick points on the polygon followed by right click to close it.

Select 'CLOUD > Edit selected point', and pick a new feature such as TREES for these
points.
For volumes one feature in addition to GROUND will suffice. For more complex analysis
this method can be use in conjunction with the isolate points option to break a model down
into multiple features as has been done on the TOPO model.
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26.10.5 Check Cloud Surface Data
Select 'CLOUD > Point cloud features', and change the analysis type for excluded features
to 'Display only', and the Visibility to 'Hidden'.
To check the surface is as we intend, select 'SELECT > Long section with cursor', and
take a section through a vegetated area of the traffic island.

Use 'FILE > Save As' to save a copy of our edited model.

26.10.6 Creating Base Model
On order to compute volumes, a base model is needed. The easiest way to create one is
to simply draw a polygon around the area of interest, interpolating levels from the cloud,
and saving it as a new surface. This can be done as follows;
'CLOUD > Point cloud options' and set a lowest point snap as shown.
This has the effect that levels will be taken based on the lowest point within the given
radius of the plan point, thus avoiding any noise than may have been left in the model
during the editing process.
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Create a new polygon or closed curve around the area of interest, using 'EDIT > Add
strings with cursor' or one of the equivalent icons

Press Right click, Save coordinates as dataset to save the 3d outline of the base model to a
new dataset, followed by 'FILE > Model > SCC dataset' to create a model of the base
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26.10.7 Volumes By Average End Method
Create a new string along the centre of the traffic island with a DTM code of approximate
that can be used as a base line.

Select 'EDIT > Sections > Cross sections from exsiting string', and pick the selected centre
line

In the sections, select 'EDIT > Append surfaces' and pick the base model
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Select 'EDIT > Volumes' to compute the volumes

26.10.8 Volumes By Prismoidal Method
To compute the volume using an isopachyte method, do the following;
Use 'EDIT > Add/remove triangles' to turn off any triangles in the TOPO model.
The reason for this is that SCC allows combined TIN and point cloud surface models,
where levels will be interpolated from the TIN model if they are not found in the point
cloud.
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Select 'FILE > Attach/Detach > Attach model', and attach the base model to our point
cloud.
As the cursor is moved over the traffic island, x,Y,Z and dZ can be seen to the base surface.
Right click to bring up the data selection dialog and isloate all the points in the cloud
relative to the base model as shown;
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Select 'TOOLS > Extract a grid of levels' to take a 0.5m grid across the island, and save
the resultant data set.

Use 'FILE > Model >SCC dataset' to create a model from the grid, and save this model
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Select 'VOLUMES > Volumes between surfaces (Prismoidal)' to compute the volume
between the base and island

By applying a relief scheme in plan via our contouring options we can also visualise where
the cut and fill is ocurring.
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Using 'EDIT > Text > Create text', a scale to the relied scheme can be added to show how
depths are coloured.
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26.10.9 Export To Google Earth
If the model is in national grid, which will typically be the case using the MS50 with GPS, a
quick visualise of result can be viewed in Google earth by selecting 'FILE > Export >
Google earth'
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26.11 Point Cloud Volumes By Area
This tutorial can be implemented using either the user own point cloud models or the samples
provided (Cathedral, Topo, and Bridge). To create a new point cloud model you need data in
either PTS, LAS, LAZ, or ESRI ASC format. LAS and LAZ are significantly quicker to import
than the ASCII based PTS format.

26.11.1 Importing Point Cloud Data
To start select 'FILE > Model > Point Clouds & LiDAR' and pick the appropriate input
format. This will show the following screen;
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The colour usage option controls how much space is used per point, where RGB12 allows
about 100 million points on a system with 1GB available memory. Palette and grey scale
systems are slower to import data, but more efficient at the loss of some colour resolution.
Selecting the Create palette option builds a palette and cloud feature library, based on
paramers selected. This can be an optimized palette from the cloud RGB data, a colour
range corresponding to intensities, or the standard AutoCAD 256 colour or VGA 16 colour
palettes.

26.11.2 Point Cloud Data Selection
Pressing the edit button allows the user to make further edits to the point cloud feature
library, and save it for re-use on other point clouds.
Point cloud functionality is accessed in the model via the 'Cloud menu' and / or 'Point
Cloud' tool bar.

The most commonly used option will be data selection, which shows the point cloud
selection dialog. The allows you to control how you are going to pick data (i.e. points in a
window, points in a polygon, using a horizontal or vertical section / slice, relative to an
alignment, points similar to a given reference point, points close to another SCC surface)
and what to do with picked data. This includes selecting and de-selecting data as per
typical SCC usage, locking and unlocking data which hides the data and prohibits it from
being used in future operations, and isolating data which is the same as locking everything
except the picked points.
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26.11.3 Isolating Area Of Interest
Open the Cathedral model from the tutorials directory

Isolate an area of interest by right clicking the mouse to bring up the Data Selection dialog.
Set up the following parameters:
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After pressing 'All points close to a line' and 'Isolate Data', select 'Close'
Draw the centre line of the section line of interest by left click on the model (first point and
last point of line).
This highlights the area of interest as an elevation and switches the colour of all the locked
points to light gray. Pressing ‘P’ and ‘E’ will move between plan and elevation view to get
a better idea of what has just happened.

the up, down, left and right arrows are used to advance and move the section relative to
the direction of view. The distance here is based on the Section offset increment in the
data selection dialog, which can also be brought up using the right mouse button. From
plan view we can also use the mouse at any stage to pick an alternate section as shown
below;
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Other keyboard options are + and – to widen or narrow the area of interest, and L and X to
move between long section and cross section related view when selection a sectional area
relative to an alignment.

When a horizontal section / area of interest is in use the arrow keys may be used to raise
or low the elevation of the section.
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Note that as the cursor is moved around in the cloud, either in plan or another view, the
x,y,z position of the cursor in the cloud can be seen, and cloud positions can be snapped
to as in any other survey point.
How this works is controlled via Cloud Options, which also helps control how the cloud is
treated as a surface for section and volume analysis.
Note that only active points are used for snapping, and other operations such as data
selection, and export. This allows the user to first select an area of interest for analysis
purposes and hide all other parts of the cloud, and then select further points from that
area of interest for editing. To illustrate this better TOPO.Model from the SCC tutorials
directory. When viewed in elevation the model can be seen to contain a lot of trees and
street furniture that can be exclude from any surface analysis such as sections, volume,
and contours.
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26.11.4 Rotating Viewpoint
To get an elevation of the entire cloud, select 'VIEW > Rotate Viewpoint > Two point
elevation', picking points at either end of the road.
All of the upper foliage can be obtained using a polygon selection method, trimming the
trunks closer to the ground is more problematic, as some are hidden behind hills, fences
or in dips in the ground.
The solution here is to first isolate an area of interest, and then select from within that
area, e.g.
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Note:
The option to allow setting a view point origin and orientation using the mouse and
keyboard has been made optional, such that those primarily working in plan can't
inadvertently change their viewpoint. This is controlled within 'FILE > General Options >
Units & Data Checking > Allow mouse to be used to rotate'
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26.11.5 Analysis Of Surfaces
Note that one of the quickest ways of carrying out this type of analysis on a large
topographic model is to develop a rough SCC TIN model based on a sample of spot levels
taken from the cloud, and selecting all the points a set distance above this model, by
ticking Height relative to selected surface in the data selection dialog.

Once data is selected, it can be copied, deleted, re-coloured, and most importantly
grouped by feature using Cloud / Edit selected points.
When features are assigned to groups of points, the groups can then be processed and
different types of analysis applied. This is done using Cloud / Point cloud features, which
shows the following dialog. The point feature fields are as follows;
· Feature – The name of the feature
· Surface – The surface on which the feature is placed. Note that you can have multiple
features placed on the same surface, e.g. trees and bushes might both go on a
vegetation surface
· Analysis – This controls how SCC interprets these points for surface analysis purposes.
Options are
· Display only – The points are displayed only, but not subject to analysis
· Ground – The points are treated in the same way as the triangulation surface in a
normal SCC model, from the point of view of sections, volumes, draping points,
extracting levels, etc…
· Other surface – The points are treated in a similar manner as an additional triangular
surface, such as a reference model.
· Other 3d – The points are treated as a non-mappable 3d surface, not suitable for
surface analysis operations. Sectioning through 3d surfaces will be considerably
slower than ground / mappable surfaces.
· Colour – The default colour of this feature when not coloured by point
· Colour by point – Whether points on this feature have individual colours or the same
colour
· Visibility – Controls whether or not these points are displayed, and if they are displayed
whether they are considered opaque or transparent.
· Lock – Whether or not these points are included in analysis
· Size – The size of displayed points
· Sect. Width – The search corridor width used when cutting sections through this
feature. Note this will typically be small for ground surfaces, e.g. 10mm, and larger for
3d surfaces, e.g. 100mm – 500mm. The larger this value, the more 3d data will get
projected onto a section and analysed. This in turn can slow down processing and
significantly increase the size of sections produced.
· Max Dist. – For 3d features, the maximum distance to which points will be connected.
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The sample models 'Cathedral.Model' and 'Topo.Model' already have some features
applied. Different items appearing when displayed in section. As shown in the examples
below:

The feature library is also very useful for quickly colouring and analysing monochrome
point clouds, as shown in the model below (Tunnel 950-1050 (edited).Model)
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By selecting and isloting appropriate elevation and sectional areas, data can be quickly
differentiated the tunnel, cabling, rails, and foliage. This in turn allows the user to cut
complex sections, develop a ground surface and isolate features of interest.
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26.11.6 Trace Outline From Slice
In addition to cutting sections there are a number of other ways to extract linear data and
analyse cloud surfaces. The simplest of these is via 'CLOUD > Trace outlines from slice',
which will draw outlines based on an isolated sectional area. This can be either from plan,
elevation or based on an oblique viewpoint.
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The results can then be exported to other packages, such as CAD, in 2d or 3d, and
multiple slices can be used to build-up a wire frame model from the cloud. The cloud
feature library determines how the data is analyses, where the centre of the displayed
section or slice is used as the centre-line for sectioning.
To extract linear features, sure as kerb lines, from the cloud, use 'CLOUD > Trace linear
features'. This function allows the user to create or select a reference line, which is a line
running roughly parallel to the desired features, and create strings based on similarity to a
given section template. To demonstrate this, do the following;
· Select an active tag code of Curve
· Zoom into the area of Topo.Model shown below
· Left click on three or more points within half a metre of the kerb to generate our
reference string. Right clicking finishes the reference string and start analysing the
data. Select any other active alignment to use as our reference string, or press New to
create a new reference string.
· Once a reference string is defined, moving the mouse in the model cuts a cross section
through the cloud at the chainage nearest the cursror, which is shown on the bottom left
of the screen.
· Left clicking again freezes the position of this section, and further left clicks let us to pick
sample template points. Pressing right click unfreezes the section position.
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· Once points are selected, change the feature names and adjust the position in the
section template sheet at the bottom of the screen.
· Pressing create, generates strings based on this template, with points at the specified
chainage interval.
The horizontal tolerance controls how much the template can move along the section,
from chainage to chainage, to find a best fit with points from the cloud. The vertical
tolerance controls the maximum difference in relative vertical separation between points
on the template and corresponding points on the cloud for the cloud points to be
considered acceptable as string points. Where the vertical tolerance is not met, spot level
points are out in place of string points at the correct horizontal position and cloud
elevation. This helps identify areas such as drop kerbs, and positions where the feature
has been occluded from the scanners line of sight.
The user can also triangulate selected areas of interest for further analysis and export to
software that does not support point clouds. In this case create a small alignment and
select points in an area 7.5M either side of the centre line as shown below.
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26.11.7 Triangulate Points
To triangulate the data, select 'CLOUD > Triangulate points', which gives the option of
producing an optimized triangulation of the selected data.
This reduces the amount of points used from the selected points in the cloud to just those
required to achieve the stated vertical tolerance, in this case 10mm. Note, this option can
be slow depending on the parameters and the number of points selected. To improve
performance and final result remove or isolate noisy features such as grass, trees, cars,
street furniture and overhead cables prior to running this option. Only selected points
whose features have an analysis type of Ground are considered when running this option,
so simply changing the feature of such points to any other feature will accomplish this.
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Other options relating to point cloud processing include linear feature extraction, density
based feature extraction (stringing clumps of points), tracing string manually in conjunction
with cloud snap, and use of other surface based tools in conjunction with the point cloud
ground surface rather than the TIN.
To add further information to our TIN model, from coarser areas of the model that may
have lower accuracy requirements, use 'TOOLS > Extract a grid of levels', and add the
generated data to the TIN created above, along with traced linear features such as kerbs
described earlier.
Note that when extracting a grid of levels, it is best to select the option to snap to the level
of lowest point in the defined snap search radius, as this will tend to generate a more
uniform surface, skipping small vegetation and similar items. This is set under 'CLOUD >
Point cloud options'.

26.12 Radial Comparison From Point Cloud Data
Support has been added for radial analysis of point clouds based on alignment, for the purpose
of creating tunnel sections directly from scanned data with no additional interpolation.
This tutorial covers the use of the SCC survey, point cloud and sections modules to compare
tunnels models, scanned using the Leica MS50, for deformation monitoring purpose.
Control and scan information for the tunnel is collected using the MS50. Control Observations
from the MS50 is downloaded SCC using DBX.

26.12.1 Project Creation & Data Download
Create New Project
'FILE > New Project'
Pick a appropriate project name and template
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Download Survey Data
'FILE > Download Survey', pick the Leica 1100/1200 logger and DBX as the input device.

When the DBX translation dialog is shown change the DBX folder to point to location in
which your MS50 scan data is stored and press Refresh to update the dialog.

Select SCC-TPS2GSI-v4.frt as your format file, click on your job file name (e.g.
M4PIER82 in this case) and press OK.
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Select MS50Trav.GSICONFIG in the Leica data input dialog and press Ok to download
and import the survey data into SCC.

This will download control observations into the traverse spreadsheet, and any known
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entered station coordinates into the project station coordinates sheet.

26.12.2 Traverse Adjustment
Switch to the station coordinates sheet, and change the type of any known coordinates to
either Fixed or Constrained in both XY and Z as required.

Switch back to the traverse observation view, and select 'EDIT > Adjust'
If the initial occupied stations are unknown (i.e. computed by resection or free station)
make sure to have the option to exclude fixed bearings for opening and closing set-ups
ticked, as the opening orientation will not be known. Instrument accuracies for height,
angle and distance should be entered based in the stated accuracy of the instrument in
use, number of rounds of measurement taken, and anticipated standard errors.
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Check the traverse report to ensure that the errors reported and station positions and
heights are all within an acceptable tolerance. Specific attention should be paid to
chi-squared pass/fail results, error ellipses and height errors, and observation residuals.
Where scanning is being carried out at the same time as control measurement, the
absolute accuracy of any scanned point will be based around the station accuracy and
standard error of the scanner EDM.
If the adjustment results are acceptable, update the project station values as shown.

26.12.3 Reprocessing Scan Data
To reprocess the scan data based on the updated station values, select 'FILE > Model >
Point Clouds & LIDAR > Leica MS50'.
Pick your scanned project file, and tell SCC to recompute the scan positions based on the
SCC stations.
Note that we only recompute scanner orientation when moving between grid systems,
as any transformation residuals are liable to reduce rather than improve overall
accuracy.
Press OK on the point cloud, and create the model.
You will need to repeat this process for each survey.
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Once we have two models created of the same tunnel in the same grid system we can
compare them as follows
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26.12.4 Comparison of Two Models
Open your base survey model 'Tunnel (Edited).Model' from \SCC\Tutorials\Point Clouds\

For the purposes of this tutorial, we're only interested in the tunnel itself.
Press right click to bring up the point cloud data selection dialog, select 'All points in
polygon' and press 'Isolate points'.
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Left click on four or more points to form a polygon around the tunnel, and right click to
turn off all points not inside that polygon.
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Select 'CLOUD > Point cloud features', and change the Analysis of Tunnel from Other 3D
to Other Radial.
This means that section points on this feature will be connected radially from the
alignment centre line.

Select 'VIEW > Rotate Viewpoint, followed by Two point elevation to create a view point
that looks down the tunnel.
Note that by changing the angle in the rotation side bar dialog to a small value, e.g. 1
degree, we can make fine adjustments to this view as required.
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To set the feature of any group of points, right click to bring up the point cloud data
selection dialog, select 'All points in a polygon' and press 'Select points'.
Left click on all the polygon points, and right click to select / highlight all the scanned
points inside that polygon.
Select 'CLOUD > Edit Selected points', and change the feature of the selected points as
required. Repeat this process to edit the cloud such that tunnel walls and ground are
separated, and any spurious information is set to another feature such that it can be easily
identified in section.

Press 'P' to return to a plan view, and 'SECTIONS >Long section with cursor' to verify the
model is correct.
To create the section left click on two points, one on each side of the tunnel, and right click
to finish.
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To create cross sections for a comparison, an alignment centre line is needed.
This can be imported from DXF/DWG, LandXML, or GENIO as requied. In this case,
draw the centre line manually.
Select 'EDIT > Add strings with cursor'.
Place the mouse over the centre of the tunnel in plan and press enter. This will show a
dialog with the current mouse position. Enter a height of 116 for this point and press ok.
Repeat for a point at the other end of the tunnel, and press the right mouse button to bring
up a pop-up menu. On this menu, select Save string as interface, as give this new
alignment a name as shown.
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A chainage, offset and centre line height for the tunnel have been achieved, which are
draw as a yellow line in the model. As the mouse cursor is moved around the screen, the
chainage and offset is reported in the status bar in addition to X,Y,Z.

To cut some cross sections, select 'SECTIONS > Cross sections from an alignment' using
the values given.
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To add another survey model onto these sections, use 'EDIT > Append surfaces' and pick
your second model.
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Select View / Radial annotation to show the radial separation between the two surfaces.
In this case, the radius of the base model is annotated and the difference in radius at
offsets -1 and 1 and at every 20 degrees from the centre line.

Separate features are used to show radial lines, differences and out of tolerance points.
A sample section style is also available to highlight these features, which can be loaded
using 'FILE > Load save section style', and picking MS50-Tunnels.SectionStyle
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To export the differences in report format, select 'FILE > Reports' and pick 'Section radial
comparisons.rpt'.

Pressing the top left button in the report viewer can be used to export the report to other
formats such as Excel or PDF for analysis and archive purposes.

©2015 Atlas Computers Ltd

553

26.12.5 Additional Radial Reports
Additonal Reports are available such as 'Section radial comparisons (with X,Y).rpt' which will
produce the following;
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Note that you can also use File / Export / Export sections to a survey dataset, and model
this dataset to get a further visual, e.g.
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26.12.6 Further Visualisations
Note that using 'FILE > Export > Export sections to a survey dataset', and then modelling
this dataset further visualisations can be achieved:
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In addition the original point cloud can be attached.

26.13 Cutting Sections From MS50 Data
This tutorial examines the use of the SCC survey, point cloud and sections modules to model
scanned using the Leica MS50, and cut sections from it.
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26.13.1 Create New Project
'FILE > New Project' as shown below:

26.13.2 Downloading Control Data
'FILE > Download Survey'
Pick the Leica 1100/1200 logger and DBX as the input device.

When the DBX translation dialog is shown change the DBX folder to point to the location
in which the MS50 scan data is stored and press 'Refresh' to update the dialog.

Select 'SCC-TPS2GSI-v4.frt' as the format file, click on the job file name and press 'OK'
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Select 'MS50Trav.GSICONFIG' in the Leica data input dialog and press 'OK' to
download and import the survey data into SCC.

This will download control observations into the traverse spreadsheet, and any known
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entered station coordinates into the project station coordinates sheet.

26.13.3 Processing Traverse
Switch to the station coordinates sheet, and change the type of any known coordinates to
either 'Fixed' or 'Constrained 'in both XY and Z, and edit any changes to position or
elevation as required.
Switch back to the traverse observation view, and select 'EDIT > Adjust'.
If initial occupied stations are unknown (i.e. computed by resection or free station) make
sure the option to exclude fixed bearings for opening and closing set-ups is ticked, as the
opening orientation will not be known. Instrument accuracies for height, angle and
distance should be entered based in the stated accuracy of the instrument in use, number of
rounds of measurement taken, and anticipated standard errors.

Check the traverse report to ensure that the errors reported and station positions and
heights are all within an acceptable tolerance. Specific attention should be paid to
chi-squared pass/fail results, error ellipses and height errors, and observation residuals.
Where scanning is being carried out at the same time as control measurement, the
absolute accuracy of any scanned point will be based around the station accuracy and
standard error of the scanner EDM.
If the adjustment results are acceptable, update the project station values.

26.13.4 Reprocessing Scan Data Based On New Station Values
To reprocess the scan data based on the updated station values, select 'FILE > Model >
Point Clouds & LIDAR > Leica MS50'.
Pick the scanned project file
Pick 'Recompute scan positions based on stations in SCC project'
Note that 'only recompute scanner orientation' is selected when moving between grid
systems, as any transformation residuals are liable to reduce rather than improve overall
accuracy.
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Press 'OK' on the point cloud, and create the model.

26.13.5 Creating Cross Sections For Comparison
To create cross sections for a comparison, an alignment centre line is needed. This can be
imported from DXF/DWG, LandXML, or GENIO as requied. In this case, a centre line manually
is manually drawn.
Press the curve button on the tool bar and left click on all three or more points
representing your centre line.
Press the right mouse button to bring up a pop-up menu.
Select 'Save string as interface' and enter new alignment name
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A chainage, offset and centre line height for the tunnel is drawn as a yellow line in the
model. As the mouse is moved around the screen, a chainage and offset is reported in
the status bar in addition to X,Y,Z.
To cut some cross sections, select 'SECTIONS > Cross sections from an alignment' using
the values given.
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Save sections, 'FILE > Save As'
Sections can be displayed in plan:
'FILE > Attach/Detach > Attach sections'

26.13.6 Editing Scan Data Using Sections
In the event of the sections containing unwanted data, such as structures, overhead lines,
noise from vegetation, etc. the scan can be edited as required and the sections re-cut.
For example, at chainage 100 there is an obvious spike as shown below;

To edit sections, select 'FILE > Attach/Detach > Edit detach', pick section file.
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Right click to bring up the cloud selection dialog, and isolate all points in the chainage
90-110 range as shown.

This highlights the area of the scan in elevation as shown.

Press 'P' or 'E' to move between plan and elevation, and use the up and down arrows to
move between chainages for the area isolated.

Move back to elevation view, press right click to bring up the 'Data Selection Dialog', tick
'All points in a polygon' and press 'Select points'. Use the left click button on mouse to
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draw a polygon around the area of the scan to exclude from the sections as shown, and
right click to close the polygon.

Select 'CLOUD > Edit selected points', and change the feature of the selected points to
NOISE, TREES, etc. as appropriate.
Repeat this process throughout the model, and re-cut the sections.
A tidier surface line is achieved with any additional features outlined in 3d.

26.14 Transforming A Cloud To Show Differences To A Template Or
Cylinder
This note covers the steps required in importing a scanned tunnel job in LAS format into SCC
and developing it into a plan model showing separation from a template design or cylinder.
The steps are as follows;
'FILE > New Project' entering a name for the new project and selecting a default template.
The project template contains the naming conventions, symbols, and drawing conventions
that will be used when creating models.
Creating a new project also creates a folder in which all project items, such as models and
drawings will be stored.
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'FILE > Model > Point clouds & LIDAR > file', picking the sample file provided, followed
by creating the model at 1:100 scale when prompted.

This creates the following model, containing ~145 million points from the 657mb LAS file
and resulted in a 100mb SCC model using 64 intensity levels. On an 8 core AMD
processor at 4ghz this takes ~37mins. The 64 features + intensity layout is both compact
and quite flexible in terms of what you can do.
The default rendering for the library used is by intensity, where a palette has been
selected that corresponds the height range in the scan. Turning the mouse wheel can be
used to zoom in and out, and holding the wheel down and moving the mouse to pan.
Alternatively, the PgUp and PgDn buttons can be used to zoom, and space bar to centre
around the cursor. We can also rotate the view in 3d, using 'VIEW > Rotate ViewPoint'
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In order to unwrap the model, i.e. transform it such that x,y,z model coordinates become
chainage (distance along a centreline), offset (lateral distance away from a centre line)
and separation (perpendicular distance from a design surface), we need a design
centreline, and one or more section templates. The centre line can be be imported from
LandXML, DXF or Bentley MX, or manually created.
In this case we have a design centreline and templates which can be attached to our
scanned model using 'FILE > Attach/Detach > Attach Alignment' and picking CL with
Template.Alignment. Details on how this alignment was created are given further on in
this tutorial.
We can limit the area of the model being processed by right clicking to bring up the point
cloud selection dialog, selecting 'All points in a polygon', followed by Isolate Points. Left
click to pick points on the polygon, and right click to close the polygon and isolate an area
of interest.
To unwrap the selected area, use 'TOOLS > Transform Coordinates' with the following
parameters. This is computation intensive operation that takes approx 4 minutes on this
model, where the time taken is based on the total number of points being processed, to
number points on the centreline, the number of section templates, and the number of
points on each template.

©2015 Atlas Computers Ltd

567

If we were working with a circular tunnel, we would not need a section template and could
select either Cylinder from Alignment or Cylinder from string along with a design radius to
create a model based on cylindrical separation rather than template separation.
Rotating this model we can see the effect of the transformation more clearly.
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To render out model based on separation distance, select 'CLOUD > Point Cloud' features,
and change the By field to Elevation for the GROUND feature. Specific colours and
ranges can be changed by pressing the Elevation Colours button.
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26.14.1 Creating A Centreline Template
If we do not have a design centreline and template for our model we can create them as
follows;
Right click to bring up the point cloud selection dialog. Select 'All points close to a line
(Vertical section)' and press 'Isolate points'.
Click two points in plan to draw a line at right angles to the tunnel close to the start of the
tunnel. This will show an isolated section of the start of the tunnel in elevation.

Select 'TOOLS > Measure > Intersect lines', and pick four points to create two intersecting
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diagonals at the edge of the tunnel.

Select Close, press P to move from elevation back to plan, and repeat the above steps to
create additional centreline points.
Select 'VIEW > Coordinate computations', to get a list off all generated intersection points.
Select 'EDIT > Add strings with cursor' to start creating a new string. For each
intersection point, select it, and press Output to add it to the new string.

Right click the mouse, and select 'Save string as interface'.
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Select 'CLOUD > Trace linear features > Manual', which will show the split screen view
below

As we move the mouse in plan, we will see a section of scan at the current cursor
position. In this case, we're tracing from the raw scan based on a 0.2m extract of points,
which doesn't require any editing of the scan prior to using it. We've also selected to
display a section for the current chainage 5m either side of the centre line. We can use
the zoom in / out and extents keys to navigate the section, as well as changing the vertical
exaggeration to allow for more accurate selection of levels, and dragging with the mouse
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wheel.
To start creating a design template, left click on points in section or plan, edit point details
such as feature name and string number, and repeat for the number of template points
required. In this case, we'll pick five points representing the tunnel walls where the last
point is the same as the first. If we know exact horizontal and vertical offsets to the design
centreline we can enter them here.
To create section templates at specific chainages, select Pick Points, and select the
highlighted point in plan or section for each point on the template. This allows us to vary
the template by chainage, to accommodate changes in width of the tunnel and possible
inaccuracies in the centreline.
Once enough sections have been entered, you can investigate the behaviour of the
interpolated strings between chainages, by pressing the Chainage button. As you move the
mouse around screen in plan, you will see the interpolated section along with the scanned
points in the section view. Pressing the left mouse button locks the chainage and lets you
enter an additional section where required.
Selecting 'DESIGN > View Design sheet > Section template points' shows us the points
created.

SCC uses linear interpolation between sections templates to calculate horizontal and
vertical offsets for arbitrary chainages. We can save our design for re-use simply by
selecting 'FILE > Save As' from this view.

27

Tree Survey
This tutorial covers the steps required in processing a tree survey in ADB format in SCC and
producing CAD drawings.
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27.1

Create New Project
'FILE > New Project', entering a name for the new project and selecting 'Trees.Project' as
the template.
The project template contains the naming conventions, symbols, and drawing conventions
that will be used when creating models. Creating a new project also creates a folder in
which all project items, such as models and drawings will be stored.

27.2

Model ADB Tree
'FILE > Model > ADB tree file'
Pick the sample
Select Initial Plot Scale 250 and press 'Create the model and triangulation'

This creates the following model;
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27.3

Exporting To CAD
To create an AutoCAD drawing of this model, select 'FILE > Export model > CAD
drawing', using the settings as given below.

27.4

Tree Symbols
Note that tree symbols taken in ADB format are represented by five points, corresponding
to a point at the trunk, and four points on the edge of the canopy. Colour, symbols and
annotation are determined by feature name, which corresponds to the category field in the
ADB file.
To examine this a bit further, select 'EDIT > Query and edit points' and click on tree T021.
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The feature B2 is set up to draw a five point symbol using tree-sol for the canopy and
trunk-sol for the canopy, with draw blue used the outline and trunk, and light blue for the
fill. The layer on which data will be exported can also be entered with the Query Model
Feature Library Entry screen.
To illustrate how this works, change symbol 1 TREE_0, the colours to brown and green,
and press ok. When prompted do not update the project library with these changes.

To create a new tree, or any other feature, select the feature name in the drop down box in
the top left of the screen, and use 'EDIT > Add strings with cursor', and click five times on
the screen on points corresponding to the trunk and four canopy points. Note that the four
canopy points do not have to correspond to compass positions and can also be used to align
the tree canopy, such that they form a rough kite shape as shown below.
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'EDIT > Edit Strings > Move points can also be used to change any point on an existing
string.

28

System Settings

28.1

General Options (File Menu)
System Variables
The General Options section of SCC allows the user to set up any operational parameters that
are global to SCC. These comprise of directories used on the PC, data logger selection and
communications, and working units in terms of length, angles, scale and conversion factors. It
is normally only necessary to set up these parameters once for a given installation. License
codes for the SCC modules may be entered in the Module License section.

Communications
Here the user may specify the communication parameters used when downloading or
uploading data to a survey datalogger. It is important that the baud rate, protocol and
parity here agree with those set on the logger. If a datalogger is not supported translation
programs may be written either by Atlas Computers Ltd or by the user, to convert the data
into a form supported by the software.
This module controls all the functions relating to serial data transfer.

©2015 Atlas Computers Ltd

577

These are as follows:
· Downloading of survey data from the RS232 port.
· Uploading of setting out data to the RS232 port.
· Management of serial transfer parameters.
Default serial transfer parameters are read from device configuration files rather than
relying solely on user knowledge to set the communication parameters. These
parameters are:
· Communications port (COM1...COM4)
· Baud rate (110…115,250)
· Parity
· Data bits
· Stop bits
· Protocol (RTS/CTS, XON/XOFF, MSMM PC-LINK)

Graphic Display Scaling
This option allows you to correct the aspect ratio on screens where the pixels are not
square and the screen driver provided does not correctly handle aspect ratio
· Use Device Defaults
This value assumes that there are no aspect ratio issues
· User Defined Graphics Scaling
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This value allows you to enter user defined X and Y screen scaling to correct aspect ratio
issues. To check that these values are correct, create and display a model of a circle and
verify that it appears as a circle on screen.

File Locking
This option warns if a file is already open and in use by another user. This option is
designed for use in networked environments that don't have explicit file sharing and
locking enabled (see screenshot attached). The following options are available:
· Do not use any file locking
· Warn when opening a document that is already open
· Do not allow documents to be opened by more than one user at a time
By default the option 'Do not use any file locking' is set. The other options need to be
manually selected. If a file has been locked delete the additional delete-error log file.

Units And Data Checking
This section specifies the measurement units and drawing scales which will be used
throughout the software. The method of range checking on all data entered and the
method of error reporting may also be set. CAD layers may be set with global prefixes
and suffixes to make them more easily identifiable.

Units of Measurement
· Model - This field specifies the units used when inputting and outputting ground
distance, length and height data. All lengths are stored internally as meters and
converted for purposes of translation. Approximations of the conversion factors used
are as follows: -
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1 Metre

1000mm

1 Metre

100cm

1 Metre

0.001Km

1 Metre

39.370078 Inches

1 Metre

1/0.3048 Feet (International)

1 Metre

3937/1200 Feet (US Survey)

1 Metre

1.094 Yards

1 Metre

0.00062137 Miles

1 Metre

0.0005396 Nautical Miles

· Paper - This field specifies the units used when inputting and outputting paper length
data such as text sizes and margins. All such values are stored internally as meters
and converted for purposes of translation.
Metre
Centimetres
Millimetres
Kilometres
Inches
Feet (International)
Feet (U.S. Survey)
Yards
Miles
Nautical Miles
· Angles - This field specifies the angular units used when inputting and displaying data.
All angles are stored internally as radians and later converted for purposes of input and
output.
1 Degree

60 Minutes

1 Minute

60 Seconds

1 Degree

PI/180 Radians (0.0174532925199444)

1 GRAD

PI/200 Radians (0.0157079632679490)

PI

3.14159265358979323846

· Gradient - This field specifies the gradient units used when inputting and displaying
data.
Decimal (1.0=100%)
Percentage %
Ratio 1:n
Vertical Angle

Drawing Scale
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This field specifies how drawing scales are described. This may be either as a meter per
meter ratio for metric units or inches per foot for imperial units.

Input Range Checking
This field specifies whether extended validation checks will be carried out on all input
fields. Every input field has a legal range and a normal range. The system can check one
or both of these ranges when data is entered and provide warnings and errors for out of
range data. These checks can be used to reduce the risk of error in your data.
The limits of normal values for each field type can be set by pressing the ‘Ranges>>’
button from the units and data checking dialog. Note that some of these fields, such as ‘k’
value, represent computed rather than directly surveyed values, but are still representative
of the input data.

Error logging and output
This field controls the amount of detail that is written to the log file during processing. Error
logging and reporting includes Crystal reports based log files broken down by menu items
selected, and colour coded by message type. Multiple reports are available based on
level of detail required. The default level is to include all errors, warnings, processing
notes and raw data. The reason for including the raw data is that the error message will
be shown in the context of the input file being processed, as shown below;
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With all possible diagnostic information turned on, all intermediate calculation steps are
output, along with detailed error checking. For example, when calculating a least squares
network adjustment with diagnostic turned on, all the values of all the matrices used in the
adjustment for each iteration would be output. This is not the default as its use will lead to
the production of very large log file, and greatly reduce the overall performance of the
software.

Delete Old Error Logs When Closing A Document
This option when selected automatically delete log files created during processing when
the document is closed.

Log errors to file only
This options send error messages directly to log file.

Log to file and display on screen as messages
This options send error messages to log file and also displays information on screen.

CAD Layering
This option found in the Units and Data Checking section of the General Options, allows
addition of prefixes and suffixes to layer names when exporting data to CAD. This may be
used to make layers more easily identifiable. Suffixes may be added to elevation, point,
feature and other text layers. A specified prefix may also be added to each layer.
Many user choose to set up specific prefixes and suffix within their own feature library
instead of using this approach.

Co-ordinate Layout
The co-ordinate layout may be changed from the default X,Y,Z format to read data stored
in Y,X,Z format. When the co-ordinate layout is changed to Y,X,Z format station coordinate, detail co-ordinate, survey notes, traverse co-ordinates, transformation coordinates, horizontal intersection points and horizontal entity sheets will also display their
coordinates as Y, X, Z. Note that data is still stored internally on these sheets X, Y, Z and
is translated on input, output and display.
Input of coordinates from any ASCII files assumes that coordinates in these files are given
in Y, X, Z unless otherwise specified in the file. This includes station and detail
coordinates coming from instrument/ datalogger files as well as GENIO N, Y, Z. file etc.
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Model reporting and string editing will use the Y,X,Z switch.
Note: When this switch is turned on many of the tutorial datasets will not work. The
reason for this is that survey station co9-ordinates will be reversed and will no longer
correlate with station orientation and azimuth observations.

Configure Undo
Configuring the Undo facility allows the user to step back through one or more editing
steps that has been completed, allowing the user to recover from a range of keying errors

Disable Undo Facility (Improves performance on large documents)
This option specifies whether or not the Undo facility is enabled. When undo is enabled a
copy of the model will always be stored in the RAM. Hence, when working on large
models the undo facility may use up a large amount of memory.

Max Undo Levels
This option documents the number of Undo and Redo stages through which you can
move backwards and towards. The higher this figure the more memory required. If the
amount of memory used within any given document exceeds the maximum undo buffer
size, the number of undo stages will be reduces accordingly.

Max Undo Buffer (MB)
This is the limit of the amount of memory that will be used per open document for undo
and redo operations. Note that using large undo buffers on machines with limited memory
may have a significant impact on program performance.

Join Identically Labelled MX Strings When Creating Models
This option joins strings of the same name across multiple survey datasets, when using
full MX coding

Flip All String Aligned Text To More Closely Match The Plotted Sheet
This option will force any model text to be re-oriented to more closely match the plotted
sheet where it would otherwise appear upside down. It does not affect the bounding
rectangle of the text, see the before and after pictures below for an example of the effect
of this option.
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Disable Redrawing Of String Annotation With String Edits
Selecting this option disables the complete redrawing of all annotation for a given string
once that string has been edited. This option should be selected if you are mixing string
editing and model editing during any given model editing session. If you do not have this
option selected, edting a string is liable to undo previous text edits, such as moving or
deleting text, that related to points on the string being edited. To redraw the annotation,
use 'EDIT > Text > Redraw String Annotation.

Disable Mouse Cursor Repositioning For Zooming And Panning
When using the Zoom and Pan operations within a model, SCC typically repositions the
mouse at the center of the screen after completing the operation. The reason for this is
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that when using search based panning operations, such as zoom to next selected point
(F2) or zoom to next potential error (Tab), the cursor will lie exactly over the selected point
when the operation is complete. This in turn leads to simplified editing. The status
messages, given at the bottom of the screen, also depend on mouse repositioning to work
correctly with search based panning operations. For example, when zooming to the next
potential model error, the error message details will only be displayed correctly on the
status line if cursor repositioning is enabled.
When zooming in, mouse repositioning guarantees that you will continue zooming into the
same location on successive zoom in operations.
Select this option only if you do not wish the mouse cursor to be repositioned under these
circumstances.

Use Gaps To maintain Polygons In Editing Operations
This option controls how certain model editing functions, such as trim strings and break
links, behave when applied to polygonal strings. If this option is selected these functions
will insert a gap in the string in order to preserve its status as a polygon. This means that
it can still be used as a clip, void or boundary polygon, and will still have an area when
queried. Note that using gaps in strings to maintain polygons can be confusing, as what
appears as a line string on screen for editing purposes is actually a polygon.
If this option is not selected, breaking a polygon will cause the polygon to be converted
into a simple line string. The latter option will provide more intuitive editing, and provide
similar editing to CAD.

Hide Dimension Annotators With A Value Of Zero
This options turns off dimension text with a value of zero within a model

Allow Fast Chainage / Offset Computations On Alignments
This option allows for fast calculation of chainage and alignment data.

Exclude hidden features from data selection
This option prevents hidden features from being selected during model editing, operating
in a similar manner to inactive layers in CAD.

Mouse wheel zoom factor %
This option controls the level of zoom applied with the mouse wheel, which has the effect
of making zooming in smoother and slower on fast PCs.

Search tolerance for sections

Edit Text Masks >>
The text masks control which points in a model are excluded from automatic annotation.
This typically includes all derived and interpolated points, such as curve fit points.

Directories and Files
This section specifies paths to different files used by SCC, such as the executable files,
the projects directory, temporary files and datalogger files. If these are not set correctly
the program will not work correctly and/or will not create automatic jumps to CAD, MX or
the text editor. If you are using SCC in conjunction with MX, the version of MX being used
must be selected. The 'Add New Features' section specifies how the feature library
handles new features when downloading or importing data.
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Executable Files Directory
This is the directory in which the SCC program and system data files reside.

Project Directory
This directory is used for permanent storage of raw field data, survey data sheets, models,
drawings and related data.
Sub-Directories will be created off this directory for individual survey data sets.

Temporary Files Directory
This directory will be used for temporary storage of data within the program.

Data Logger Files Directory
This is the directory searched for raw survey data files. Usually it will be the root directory
of the 3.5-inch floppy drive on your PC by default.

Command Path to CAD
This is the path to the AutoCAD executable file. This allows a link directly into AutoCAD
when exporting a model or sections file to AutoCAD.

Command Path to Text Editor
This is the path to the text editor, which is used to view all report files generated by SCC.

Command Path to MX
This is the path to the MX executable file. This allows a link directly into MX when
exporting a model or sections file to MX.

MX Style Set Directory
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This specifies the path to the directory where all the Style Sets for MX are saved. Thus
when a MX Style Set is being exported from SCC, it is created and stored in this directory.

Add New Features
This switch defines how new features encountered in a survey dataset, that do not exist in
the feature library, are treated. If new features are NOT automatically added to the
feature library the nearest match will be used when associating feature information with
surveyed features. E.g. if the feature HEDGEROW occurs in the survey it will take its
colour, layer, and symbology from the feature HEDGE. When surveying using MX labels
in the logger this field may be used to group similar strings without allocating a record in
the feature library for every string.

Autosave Files
This option allows the autosave function to be enabled and the time interval at which the
saves occur to be determined.

Do not prompt to save
This option turns off prompt message when autosave is in use.

Append (AutoSave) suffix
This option adds the suffix AutoSave to the file name during autosave.

Disable Keyboard And Command Processing While Drawing
This option disables the ability for the user to interrupt drawing by selecting another option
or pressing a function key. This is useful if you are capturing video footage from screen,
or using an automated testing tool.

Disable user defined keyboard short-cuts
This options disables keyboard short-cuts.

Create backups of previous versions during save
This option creates a backup file (*.bak) during saving.

Use extra memory to improve model display speeds
SCC takes full advantage of multiple processor PCs for drawing and model analysis for
faster and more responsive processing.

OLE Options
This option disables the use of OLE document storage, or compound document storage
where it is not required. This typically halves the size of SCC document files on disk.

OLE document storage is useful if the user wish to set and query user defined document
attributes from Windows explorer, and if the user is embedding OLE objects into your
SCC models.

Change Screen Colours & Background >>
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This option allows the user to change any of the sixteen pre-defined SCC palette colours
to any true 24bit colour value. This dialog also allows the user to specify a screen
background colour for the graphic views, and whether that colour is used when plotting.
Note that for most output devices it is inappropriate to plot a background colour.

MX Version
The user can select the version of MX in use. The information is required when exporting
files to MX.

Module Licenses
This dialog details the current SCC License serial number and the activated modules.
The Maintenance Expiry Date is also available.

Maintenance Codes can be entered as follows:
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Within SCC, go to 'FILE > General Options'
Within the 'System Variables' dialog box go to 'Module Licenses'
Enter Maintenance Code 2 and Maintenance Expiry Date
Select 'Purchase Maintenance'
A black correct symbol should appear in the box beside 'Maintenance Enabled'

Edit User Details>>
This dialog allows the user the option of inputting company details and logo which can be
automatically set up to appear within sheet layouts and reports.
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28.2

Workspaces (File Menu)
Workspaces are used in SCC to store all the program settings that relate to the graphical user
interface. This includes the display and positioning of tool bars and menus, keyboard
shortcuts, the size of the main SCC frame window, a list of currently open documents, and the
default spreadsheet colors and fonts.

Workspace Options
The ‘Workspace options’ dialog, allows the user to control whether workspaces are
automatically loaded at startup and saved on existing SCC.
If the user chooses to automatically load and save a workspaces, SCC will reopen the last
used workspace.
If the user chooses to automatically load a default workspace, SCC will reopen the same
each time you run it, with whatever GUI customization applied. This allows a senior
surveyor to set-up a workspace that simplifies the operation of SCC for other users, by
removing unused menu options and tool bars.
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Saving and Loading Configuration Files
Two options are available in SCC to save and restore the SCC configuration to external
files. These are 'FILE > Workspaces > Save SCC configuration' and 'FILE > Workspaces >
Load SCC configuration'. These configuration files store all user definable parameters
relating to survey download, reduction, etc... that are not stored as part of the project
template or workspace, i.e. all the values in the system registry under
'HKEY_CURRENT_USER/SOFTWARE/Atlas computers Ltd'. Configuration files are
placed in the SCC executables directory with the file type ‘SCCConfig’.
Note that you require backup and restore privileges in order to use these options. If you
encounter problems using these options, please contact your system administrator.

Use of external files rather than the system registry
To overcome issues with access to the registry (slow or restricted with some security
policies), SCC now in addition to Workspace Configuration options uses external files
rather than the system registry to store most of the configuration settings. The
configuration file is now stored as <SCC directory >SCC Profile for <Logon Name>.BIN, e.
g. C:\SCC\SCC Profile for Shane.BIN. If the user wishes to copy the configuration to
another login, or another PC with a different login name it is just a matter of renaming the
<Logon Name> part of this file accordingly. When moving from the previous versions of
SCC to this version, configuration settings will automatically be moved from the registry to
this file as they are required.
In addition, all configuration settings in SCC for the current user can be viewed in a
prefined Crystal report 'SCC Settings.rpt', which can be accessed by selecting 'FILE >
Reports'.

29

Import & Export
Many import and export options are supported within SCC.

See Also
Import SCC Text File (File Menu)
Import Comma Separated file (File Menu)
Import Fixed format ASCII file (File Menu)
Import STAR*NET Co-ordinate file (File Menu)
Import MOVE3 Co-ordinate file (File Menu)
Import DWG/DXF File
Import LandXML (File Menu)
Import X,Y,Z ASCII file (File Menu)
Import ESRI Shapefile (File Menu)
Import ASCII Wriggle Survey (File Menu)
Import Amberg GRPwin Format (File Menu)
Import Amberg AR2 Format (File Menu)
Import X,Y,Z ASCII file (File Menu)
Import AutoGrad/MSMM ‘As Set-Out File’ (File Menu)
Import AutoGrad/MSMM Levelling File (File Menu)
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Import AutoGrad/MSMM GDS Printout (File Menu)
Import DOER Husky File (File Menu)
Import MOSS GENIO File (File Menu)
Import MOSS 992 Report (File Menu)
Import MOSS 994 Report (File Menu)
Import User defined ASCII co-ordinate file
Panterra
Import Steanne MIDAS File (File Menu)
Import SDRMAP ASCII File (File Menu)
Import Eclipse Report File (File Menu)
Import ESBI Vectors File (File menu)
Import SCC for DOS Project
Landscape (File Menu)

29.1

Import SCC Text File (File Menu)
This option allows for the importing of *.sio files.

See Also
PocketDTM

29.2

Import Comma Separated file (File Menu)
This option allows the user to append data from a comma separated ASCII file to the current
data sheet. This file may have been created from another data sheet or a spreadsheet or
database.
It is important that the comma separated file has the relevant columns to match that of the
Detail Coordinate Sheet:
No. Str. Pos Feature Type Tag DTM E/X N/Y Ht/Z D(1) etc.

29.3

Import Fixed format ASCII file (File Menu)
This option allows the user to append data from an ASCII file to the current data sheet. This
file may have been created from another data sheet or a text editor. The input format is fixed
width fields, sample input data may be obtained from the ‘Export Fixed format ASCII file’ option.
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29.4

Import STAR*NET Co-ordinate file (File Menu)
This option appends station co-ordinates to the station co-ordinates spreadsheet from a
STAR*NET '.PTS' file. Selecting the option presents the following options;

29.5

Import MOVE3 Co-ordinate file (File Menu)
This option appends station co-ordinates to the station co-ordinates spreadsheet from a
MOVE3 '*.COR' file. Selecting the option presents the following options;

29.6

Import DWG/DXF File (File Menu)
This option converts a DXF or DWG file directly into an SCC survey dataset or model. It is
ideal for transferring data from a variety of CAD packages such as AutoCAD, Microstation, and
MX. The dialogue contains the following options;

For large DWG and DXF files it is considerably more efficient to model them directly in SCC,
using 'FILE > Model > DWG/DXF', rather than importing them into a spreadsheet format.
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The layer to feature mapping dialog may be used to map any combination of DWG layers,
entitiy types and line styles onto SCC features. Default layer maps may be created either from
the current feature library or from the selected DWG or DXF file. Once a layer map has been
set-up, it can be saved to file for re-use and distribution as required. After creating a layer map
file, it will remain the default until changed.
Mapping layers onto a feature called IGNORE, which has a corresponding feature library entry
with DTM code forced to IGNORE, is a good way of using the layer map to filter out unwanted
drawing data.

29.7

Import LandXML (File Menu)
SCC incorporates bi-directional support for transfer of data in LandXML format, as described
in www.landxml.org. This includes support for import of model, geometric alignment, and
survey observations in LandXML, and export of model and alignment data in this format.
Support for LandXML has been provided as a mechanism to allow for exchange of data
between SCC and a range of other software packages and survey instruments. It is not suitable
as an alternative mechanism for archiving data, or exchanging complete model and survey
data between SCC users as it does not include a complete representation of everything
contained in an SCC model or survey dataset. Typically, LandXML is good for exchanging
survey information, alignment geometry, and simple surface model information. It is not suitable
for exchanging edited cartography, which may include symbols, line styles, bitmaps, surface
textures, and various point and line annotation.
SCC currently supports import and export of data in both LandXML 1.0 and LandXML 1.1
format. We intend to deepen and extend our support to include LandXML 1.2 as it becomes
ratified, and anticipate increasing use of LandXML as a preferred transfer format when
communicating with total station and GPS equipment.
To directly model a LandXML file in SCC, select 'FILE > Model > LandXML file'.
To create a survey dataset from a LandXML file, select 'FILE > Import LandXML file'.
If alignment data is present in the input file in either of these cases you will be given the
option save that data as an SCC Alignment document. To export a model from SCC in
LandXML format, select 'FILE > Export > LandXML'.
If the model includes any attached alignments they will be included in the LandXML
output file.
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29.8

Import X,Y,Z ASCII file (File Menu)
This option provides a simple method of importing co-ordinates into a SCC Detail Coordinate
spreadsheet. It can take in data in either X,Y,Z format or Point number, X, Y, Z, Feature name
format.
In addition, this option checks to see if the file extension is .PTS and if so assumes PTS point
cloud data is X, Y, Z, intensity, R, G, B. This import is slower as the software will carry out a
nearest match RGB colour to the SCC & AutoCAD palette for feature naming purposes, for
example, the point cloud data is grouped and sorted by colour for analysis purposes.

29.9

Import ESRI Shapefile (File Menu)
This option allows the user to import points, lines and polygons from an ESRI shape file
Note:
Shape files are limited in that they can only store one of the above in any given file.

29.10 Import ASCII Wriggle Survey (File Menu)
SCC supports the import of wriggle survey data for tunnel analysis. This option takes a file
containing surveyed points representing rings / rough tunnel sections, and uses a least squares
analysis to compute best-fit radii and plane details for each ring ('TOOLS > Compute Wriggle
Survey').

29.11 Import Amberg (GRPwin format) (File Menu)
SCC supports data from the Amberg GRP rail trolley. This creates two points per line of data
from the trolley file, one for left rail, one for right rail, using the station for string number and
ident for point number. D1, D2 and D3 are used to store odometer, gauge, and super elevation
in the input file, such that they can be annotated as required. The rail features are named
LRAIL and RRAIL.

29.12 Import Amberg (AR2 format) (File Menu)
SCC supports data from the Amberg rail trolley. Where multiple AR2 files are selected for
import, they are merged into a single job, where the string number is used to denote the input
file number. The AR2 format is useful for importing continuous rail with closely spaced points.

29.13 Import AutoGrad/MSMM ‘As Set-Out File’ (File Menu)
This option imports a file from the AutoGrad Setting Out module.

29.14 Import AutoGrad/MSMM Levelling File (File Menu)
This option imports a file from the AutoGrad levelling module.

29.15 Import AutoGrad/MSMM GDS Printout (File Menu)
This module converts detail observation and station co-ordinate data from an AutoGRAD
printout file into AutoGRAD / MSMM binary and SCC binary format. The printout option
selected on AutoGrad should be the GDS detail printout option. This is similar but not identical
to the GRAD GDS format. GRAD was the predecessor of AutoGrad.

29.16 Import DOER Husky File (File Menu)
This option provides a facility for inputting data from the Irish Dept. of the Environment Roads
package, ‘DOER’. This module converts Husky Setout data generated by DOER into a SCC
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co-ordinate file. For newer versions of DOER, the option to create DXF polylines is a better
method of transferring design data into SCC.

29.17 Import MOSS GENIO File (File Menu)
This option converts a GENIO file into a detail co-ordinates spread sheet. In doing so all
strings are converted into 3 dimensional strings. This option has the advantage that models
created can make full use of the SCC feature library facilities. As such it can be useful for
converting external MX models into SCC generated models. Selecting this option presents a
dialogue with the following options;

29.18 Import MOSS 992 Report (File Menu)
This option translates ASCII files containing 992 REPORT information into SCC co-ordinate
spreadsheets. It is an alternative method for transferring string information from other MX
systems into SCC.

29.19 Import MOSS 994 Report (File Menu)
This option translates ASCII files containing 994 REPORT information into SCC co-ordinate
spreadsheets. It is an alternative method for transferring sectional information from other MX
systems into SCC.

29.20 Import User defined ASCII co-ordinate file
This option provides a simple method of importing user defined XYZ ASCII co-ordinate files into
a SCC Detail Coordinate spreadsheet. On selecting this option, a dialog is presented from
which you can create your own ASCII input file based on the data file selected. This format can
be saved as a template to be used for future files.
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Data can be imported in fixed format or variable width fields, with options for automatically
stripping out certain characters, such as white space, quotes, inverted commas, etc…
To create a new import format, first select your input file, and press ‘Show’. This will display a
portion of your input file in the preview box and allow you to determined whether it is fixed or
variable format, and if it is fixed format, to specify the column numbers for various fields.
Having done this, press the ‘Add’ button to enter details for the fields you wish to extract. If the
file is fixed format, you must enter the starting column and width for each field. If it is variable
width, you must enter the field number for each field, in this case the start and width are
ignored.
Once you have created your new format file, you should save it, such that the next time you
wish to import a file in this format, you simply select the format file and press ok. The file is
saved into your SCC executables file directory, normally C:\SCC\, with the extention ‘.
InputFormat’.
To complete the import of your file, simply press ok.

29.21 Panterra PXT
This option allows you to either import or directly model a file in Panterra PXT format. The
translation uses a combination of options from the feature library and Panterra PXT options
dialog as follows;
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Rotate non-string aligned text to grid using feature library
This option rotates any text that is set as 'string aligned' in the feature library to the survey
grid, overriding the PXT text rotation value for given features.

Flip text that to match grid orientation
This option flips any text that is upside down to make it more readable.

Use justification codes from the feature library
This option uses the feature library to determine the justification code for any text in the
PXT file with a justification set to zero

Use text x,y offsets from the feature library
This option applies X,Y offsets from the feature library to PXT text.

Use feature library text prefixes
This option applies feature library prefixes to any PXT dimensional text such as levels.

Delete annotation set as 'Text off' in the feature library
This option deletes any text from the PXT file that is set as Text Off in the feature library,
enabling selective filtering of annotation by feature

Delete levels with justification code 0
This option deletes any text in the PXT file with a justification set to zero

Text justification codes
These fields control how PXT justification codes are interpreted by SCC

29.22 Import Steanne MIDAS File (File Menu)
This option translates ASCII files containing GPS co-ordinates from MIDAS into SCC coordinate spreadsheets. The MIDAS system is a general purpose GPS surveying system with
full feature coding capability that ideally compliments SCC and the MSMM.
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29.23 Import SDRMAP ASCII File (File Menu)
This option allows the user to convert ASCII data generated by SDRMAP into SCC co-ordinate
file(s). Two formats are supported by this translator, these are SDR co-ordinate format and
comma separated format.

29.24 Import Eclipse Report File (File Menu)
This translator allows the user to import data from an Eclipse report file into a SCC co-ordinate
file. The report taken from Eclipse is a surface detail point listing report. This function can be
very useful when transferring data from older Eclipse based systems that do not support
GENIO and DXF.

29.25 Import ESBI Vectors File (File menu)
This module converts water velocity data in position-vector format into a SCC co-ordinate file.
The co-ordinate file is 2D with a two-point string generated for each vector. This module is
primarily designed to enable cartographic mapping of this data rather than modelling.

29.26 Import Symbols from DXF
This option imports symbols from a DXF file. Once you have imported symbols from a DXF file
you may need to edit their insertion points in order to use them directly from survey.

29.27 Import SCC for DOS Project
This option allows conversion of SCC for DOS and TopoMOSS projects into SCC for Windows.
Select the project directory to be convert and all control, traverse and co-ordinate information
will be converted into .Project, .Traverse and .Survey files respectively. No model information
is transferred. A project directory is created as a subdirectory of the main SCC directory and
the project file opened.

29.28 Import Landscape (File Menu)
Landscape to SCC Model Converter
This option allows the user to convert a dxf created from Landscape together with a Genio
file to produce an SCC Model.
The following processing steps should be followed:
Open Project File
Select 'FILE > Import > Landscape > Landscape to SCC Model Converter'
Select dxf file '\SCC\Landscape\5002.DXF'
Select 'Yes' to 'Search GENIO file for missing point data

Set the Plot Scale (for text conversion) to 200
Select 'Layer to feature mapping>>'
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Set 'DXFLandscape.LayerMap' as the Map file

Select 'OK'
Select 'OK' within the 'Import DWG/DXF file' dialog
The user is then prompted to select the Genio file
Using the 'Pick>>' button, select '5002.CRD' from '\SCC\Landscape'
The conversion is now carried out and the model is created
Select 'FILE > 5002.Model' and the model is available as the last document
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29.29 Import SC0 /SCN rail files (Sections File Menu)

SCC can import SC0 and SCN files as sections, where the sections also include all the
SC0 and SCN header information. A new section style, SC0 SCC.SectionStyle, for
drawing these sections to show structure and rail information in included in the tutorials
directory. Extra header information is available by querying the section.

29.30 Importing Alignment Data

29.30.1 Import MX/MOSS GENIO Geometry strings (Alignment File menu)
This option imports Geometry string information from a MX GENIO file.
The file can be selected using the 'Import MX GENIO Data' dialog:

On importing, SCC list alignment strings to allow the user to select the specific one for
download.
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Compress Geometry Strings
This option is used to remove redundant elements from an alignment. It operates by
testing the end conditions of any given element, extended by the length of the subsequent
element, with the end conditions of the subsequent element. If they fall within the
specified tolerance, the element is extended by that length, and the subsequent element is
deleted. This is repeated until no more elements can be deleted.

Compress Tolerance
When compressing geometry strings, this tolerance is the maximum allowable deviation
between the original input geometry and the compressed geometry at any given point in
the alignment.
This geometric information is stored in the Horizontal Entities (Alignment View Menu) and
Vertical Entities (Alignment View Menu) sheets. Note that SCC uses clothoid transitions
throughout and may prove unsuitable where other MX design entities are in use, for
example, Sine transitions in high-speed rail. The horizontal intersection points sheet will
not be populated as there are no HIP points in a MX/MX geometry string.

29.30.2 Import Entities from DWG/DXF (Alignment File Menu)
This option reads horizontal geometry entities from polylines in a DXF or DWG file. These
can include straights and arcs as required.

29.30.3 Import DOER HIPS (Alignment File Menu)
This option imports horizontal intersection point information from DOER. To view this
information go to ‘View > Horizontal Intersection Points’.

See Also
Horizontal Entities (Alignment View Menu)

29.30.4 Import DOER VIPS (Alignment File Menu)
This option imports vertical intersection point information from DOER. To view this
information go to ‘View > Vertical Intersection Points’.
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See Also
Vertical Entities (Alignment View Menu)

29.30.5 Import Simple ASCII HIPS (Alignment File Menu)
This option reads a comma separated ASCII file of horizontal intersection points.
Individual lines in this file can be in one of the following formats;
· Easting, Northing
· Easting, Northing, Incoming transition length, Radius , Outgoing transition length
· Easting, Northing, Incoming transition length, Radius 1, partial transition length, Radius
2 , Outgoing transition length, arc direction, arc length
· Easting, Northing, Incoming transition length, Radius 1, partial transition length, Radius
2 , Outgoing transition length, arc direction, arc length
· Easting, Northing, Incoming transition length, Radius 1, partial transition length, Radius
2 , Outgoing transition length, arc direction, arc length1, arc length2

29.30.6 Import Simple ASCII VIPS (Alignment File Menu)
This option reads a comma separated ASCII file of vertical intersection points. Individual
lines in this file can be in one of the following formats;
· Chainage, level
· Chainage, level, length

29.30.7 Import Nikon FRG file (Alignment File Menu)
This option reads a Nikon full road geometry file from disk, and stores the details in the
horizontal entity, vertical entity, and section template points sheets. For an example of
this file format, see ‘Example.FRG’ in the tutorials directory.

29.31 Export Stations as dataset (File Menu)
This options exports station values present in a project file to a new dataset.

29.32 Export Automated Demarcation Certificate (File Menu)
This client specific option provides an automated demarcation certificate for use during land
parcel surveys.

29.33 Export Create a file CRC report (File Menu)
This option computes CRC (cyclic redundancy checks) for a list of selected files and passes
this on to the report viewer. CRC can be used for digital signing of documents.

29.34 Export Fixed format ASCII File (File Menu)
This option is available from the model, section, and coordinate view menus and allows you to
export ASCII data in a user-defined format. The output file is broken down into five basic
sections; the file header and footer, the string or section header and footer, and the point
details. The section header and footer is written for each new section graph in a section file.
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The string header and footer is written for each new string in a model or coordinate data set.
The point details are written for every point on a section or string.
Each section can contain literal text information and text corresponding to SCC data fields.
SCC data fields are added to the output format using field macros, where a field macro is the
name of any given field enclosed in square brackets. A field macro can also contain qualifiers
to specify the field width, padding, and number of decimals. For example, given a chainage
value of 1006.102, the following macros would give the following output;
[Chainage] 1006
[Chainage:010:1] 00001006.1
[Chainage: 0:3]

1006.102

[Chainage:5]

1006

Once you have defined an output format, you can save it to file, such that it can be reused and distributed to other users.

Export From A Dataset
This option allows the user to create a comma separated ASCII file from your current data
sheet. This file may be imported into a spreadsheet or database package. It may also be
read into another sheet with the same fields using the ‘Import Comma Separated file’
option.

29.35 Export Comma Separated File (File Menu)
This option allows the user to create an ASCII file from your current data sheet. This file may
then be printed or edited using a text editor. It may also be read into another sheet with the
same fields using the ‘Import Fixed format ASCII file’ option.
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29.36 Export STAR*NET Input File (File Menu)
This function outputs the current traverse data sheet to a STAR*NET input file. The file is given
the name <Data SetDAT>. On selecting the option the following dialog is presented;

29.37 Export MOVE3 Input File (File Menu)
This function outputs the current traverse data sheet to a MOVE3 input file. This creates
MOVE3 project, terrestrial observation, and terrestrial co-ordinate files. Note that the MOVE3
project created defines a default projection system that the user may wish to modify prior to
computing the network. On selecting this option the following dialogue is presented;

29.38 Export CAD drawing (File Menu)
When outputting models to CAD a link may be made to the CAD system so that it is
automatically called when this option is selected in SCC. For a direct link to your CAD system
fill in the Command path to AutoCAD in the ‘General Options > Directories and Files'.
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If the CAD system is not Windows based and no direct link is possible select the option ‘Text
DXF’. This creates a DXF in the current working directory.

CAD File Name
This is the name file that will output to your CAD system. For the purposes of exporting to
CAD, please do not use spaces in your CAD filename.

Prototype File
This is the DXF file containing the symbols on which the feature library is based. There
are different feature library files found in main SCC directory. Each symbol is an AutoCAD
block. It is not necessary to select or use a prototype file as SCC will create a full
prototype where one is not provided.

©2015 Atlas Computers Ltd

607

Host CAD System
This specifies which CAD system the file will be output to. To automatically jump into your
CAD system the ‘Command path to CAD’ in the ‘Directories and Files’ section of the
‘General Options’ must be set up correctly. If this is not set up correctly a link will not be
made to the CAD system and the DXF file will be saved to the current working directory. If
‘Text DXF’ is selected as the mode of output the same occurs (that is, the DXF file is
stored in the current working directory).

Drawing Type
This specifies whether the drawing output will be 2D or 3D. Note that some CAD systems
may be limited in their ability to edit 3d drawings.

Colour Map
This option allows SCC colours to be mapped to colours in an AutoCAD system. This
option is mainly used when exporting to MicroStation. Find the number associated with
the colours from the colour table in the Host CAD system. Type this associated number in
box opposite the colour.

29.39 Export Optimal Pole CAD (File Menu)
This option allows for data to be exported from a model in Optimal Pole CAD format.

29.40 Export MX (MOSS)(File Menu)
This option exports a model directly into MX system. This includes translation of the strings in
the SCC model to GENIO, and optionally converting drawing information either into MX Style
sets, or MX DRAW statements. SCC will also create triangulation and contour statements in
the input file if required. Note that the location of MX style sets must be specified in a directory
in the general options.
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The MX Label field in the feature library determines the labeling convention used when
exporting to MX. If you elect to create DRAW information or MX style sets, the user should
also ensure that any symbol names used in the feature library are consistent with available MX
macrosymbol names.
When exporting to MX and MX, the SCC model is converted into multiple MX models using
multiple GENIO statements. These include a ground model, a text notes model, and models
containing the extra dimensional information. For example, if the SCC model is called ‘Survey’,
this would get translated into the models SURVEY GROUND, SURVEY TEXT, SURVEY
SYMBOLS1, and SURVEY SYMBOLS2. Many MX users will only require the first and possibly
second models. The symbol models contain strings that include extra dimensional information
for features of varying sizes, such as trees. So that for an given tree point will appear as an X,
Y,Z coordinate in SURVEY GROUND, an X,Y,D1 coordinate, where D1 is the canopy diameter
in SURVEY SYMBOL1, and an X,Y,D2 coordinate, where D2 is the trunk diameter in SURVEY
SYMBOL1. If the surveyor had picked up the tree name and annotated the dimensions, these
annotations would occur in SURVEY TEXT.
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MX Drawing Creation
Do not output any draw information
The GENIO file is created with only co-ordinate information.

DRAW directly using feature library
Take DRAW information from the SCC feature library that is currently attached to the
model.

DRAW by creating new MX style set
This option uses the feature library to create a new MX style set in the MX style set
directory, and then draws the model using that style set. The style set will always be
prefixed by the letters SCC and may be used within MX to draw other models or redraw
this model.

DRAW using an existing MX Style Set
Select an existing MX Style Set in the dialog. The directory in which the Style Sets are
stored is set in the Directories and Files section of the General Options.

Masking Of Non-DTM Point
Export non-DTM elevations as null levels (-999)
This option sets the elevation of non-DTM points in the GENIO file to -999 such that they
will not get included in the MX triangulation. This means that the elevations of non-DTM
strings will not be available in MX.

Create 019 mask based on string label
This option creates a MX 019 mask table using the DTM codes from the feature library.
Any features with a DTM code that would exclude them from the SCC DTM will have a
091 entry generated to exclude them from the MX triangulation. This allows the third
dimension of non-DTM strings to be included in the MX model.

Create 019 mask based on string sub-reference
This option adds a sub-reference of NULL to all strings going to MX that are not in the
SCC DTM. A single 019 option is then added that excludes all such strings from the MX
triangulation. This allows the third dimension of non-DTM strings to be included in the MX
model. This has the added advantage that mixed DTM and non-DTM strings may be
used for the same feature.

Create PBRK string for invalid triangle
This option creates a PBRK string for invalid triangles in MX such that surface editing
involving adding and removing triangles, along with the effects of CLIP and VOID
polygons, will get transferred into MX.

Create triangulation in MX
This option regenerates the SCC triangulation in MX using the MX triangulation options.

Create contours from MX triangulation
This option regenerates the SCC contours and triangulation in MX using the MX
triangulation and contouring options

Export in 4D (X,Y,Z,Pt No)
Selecting this option will output survey strings as four dimensional strings when exporting
the model, where the fourth dimension is the survey point number. This provides a useful
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refernce system between the MX model and the SCC model. If this option is not selected,
survey strings will be output in 3D.

Convert rectangles to point strings
Selecting this option converts four point rectangular strings, such as inspection covers, to
point strings in the GENIO input file.

Collate point strings
Selecting this option collates multiple point strings under the same feature name into a
single MS point string. This is useful for avoiding potential re-labelling issues, where four
digit MX labels are used for point strings.

Vectorise 3 point symbols
This option draws 3 point symbols, such as road markings, into the MX GENIO file as
strings such that they appear identical in MX and SCC. This will also make the MX model
larger.

Vectorise 2 point symbols
This option draws 2 point symbols, such as road markings, into the MX GENIO file as
strings such that they appear identical in MX and SCC. This will also make the MX model
larger.

Export ground model only
This options export only the ground model.

29.41 Export Survey Dataset (File Menu)
This option outputs the model information into a SCC dataset. The co-ordinate spreadsheet is
presented on screen and may then be saved as a separate dataset.

29.42 Export Alignment Dialog (File Menu)
This dialog is presented when the option to Export the alignment as a survey dataset or as a
model is selected, and when in the alignment file the option to View Interface and Export
Parameters is selected.

This option sets the parameters for exporting an alignment. The alignment may be output as
an interface string.
If the option to Generate Interface Strings is selected the two options; 'Create boundary from
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interface string' and 'Create slope signature strings' are enabled. The existing ground surface
is the surface to which the interface line of the template extends.

29.43 Export Model (File Menu)
This option creates a model from the alignment file. Selecting this model presents the Export
Alignment option.

29.44 Export Google Earth KML (File Menu)
This options allows for a model which is in national grid to be exported for visualisation into
Google Earth.

29.45 Export Nikon FRG file (File Menu)
Export the alignment to Nikon Full Road Geometry file and assign a file name and extension.
The file will be saved to the current SCC project directory.

29.46 Export IFC file (BIM)
This option exports models in IFC format for import into most BIM packages such as Revit and
ArchiCAD. This currently uses triangle ground types, with one mesh created per ground type.
This export is suitable for large models, such as meshes created from point clouds. Additional
options will be added to this export in future releases to include mapping of discrete and linear
survey objects onto BIM objects.

30

Downloading
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30.1

Download Survey Data (File menu)
This option facilitates the download of data from any of the supported dataloggers.
From the 'Download Survey Data' dialog, it is possible to select the type of datalogger used
(Detail Topography, Traverse, As Set Out or Levelling) and the input device being used.
Some data loggers will not record traverse and detail information in the one file and it important
to specify which type of data is being input.
A model may be generated of the downloaded data.
When downloading data the raw observations are input into the Detail Observation
spreadsheet, the co-ordinates are calculated and input into the Detail Coordinate spreadsheet.
When the data is downloaded these spreadsheets remain open on the screen. On downloaded
the Survey file is automatically saved. However when the option to 'Create model from input
data' is selected the detail observations and calculated co-ordinates are saved in the survey
file. The survey file is closed and the model is the only window remaining open. If traverse
information is being downloaded, the Traverse Sheet remains open on the screen whether a
model is created or not.

Survey Datalogger
This switch defines the type of datalogger that is being used. This may be either a MX site
measurement module based data collector or a simpler instrument based datalogger, for
example. Please note that the HP-1000 LX performs the same as the HP-100/200.
The following dataloggers are supported:
PocetDTM
Leica (1100/1200/Wildsoft/LisCADD)
Leica GSI 8/16
Trimble TSC/TSCe (DC)
Trimble /Geodimeter UDS
Trimble Job XML (JXL)
Sokkia SRX/SDR33/SDR22
TopCon (TopSurv & neutral formats)
Topcon GTS7 format
TopCon X, Y, Z
Nikon AP700
Nikon (Survey Supplies .NIK)
MDL ADS CDS &CDU
Huskey Hunter (MSMM)
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HP100LX/200LX RS232 (MSMM)
GPS X,Y,Z
Panterra
NRG PDF & GPF format
AASTHO SDMS
LSS Observation File
Zeiss REC Elta
Softdesk Field Book
NSS ASCII Export
Kingsland .OBS format
Geodimeter .DEC format
TDS
Trimble CST

Data Type
This dialog specifies the type of survey data being downloaded. Detail Topography and
traverse data may be downloaded from any of the supported data loggers. Setout data
and levelling data may be downloaded from loggers running the MX Site Measurement
Module. Some data loggers contain both detail and traverse information in the one file so
they may be downloaded in one step by highlighting both these options.

Datalogger Input Device
This switch specifies how the data is to be downloaded. Data may be transferred from a
disk or via a RS232 cable

Create Model From Input Data
This switch defines whether or not a model is drawn as the data is downloaded or not.

Advanced >>
The ‘Advanced’ option accesses the System Variables Communications section of the
General Options. It is important that the correct communications parameters are set.
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30.2

Datalogger Communications
SCC supports direct communications with a range of survey instrumentation. This is carried
out using both generic survey data interchange formats, such as MX SURVEY and AASHTO
SDMS, and formats that are proprietary to given instrument manufacturers.
The level of automatic model and drawing completion is largely governed by the limitations of
these formats. In formats where free form comments are available, such as in the SDR22and
the Zeiss REC Elta, they are used to code additional information such as tape measurements.
The MX Site Measurement Module can be linked to all other instruments that are not directly
supported by SCC.
It also improves the level of error checking and speed of data collection for the other directly
supported instrumentation. As such, it is to be recommended to anyone carrying out a
substantial amount of surveying in a quality conscious productivity oriented environment.

30.3

PocketDTM
The following outlines the download steps from PocketDTM to SCC using an RS232 cable:
Before downloading to SCC from PocketDTM, ensure that ActiveSync is turned of on both
the PC and the handheld device.
To download your survey from PocketDTM, connect the handheld device to the PC via the
RS323 port. In PocketDTM, select the ‘FILE > Export to SCC’. The following dialog is
displayed;
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In SCC, go to 'FILE > New Project’.
Enter in the job name and select from the list, the template you wish to base your survey
on.
If you have used for example ‘Default (v6-9 Simple).Project’ feature library in
PocketDTM, ‘Default (v6-9 Simple).Project’should be selected from the list.

You will be presented with a blank station co-ordinate (project) file.
Go to'FILE > Download Survey’

Select ‘PocketDTM’ as the survey data logger, select ‘Detail topography’ as the data type
and ‘RS323 port’ as the Datalogger Input Device.
Select ‘OK’ to begin.
A progress bar will appear in the top left hand corner of SCC with a message stating that
SCC is ‘searching for *.SIO…’.
Go back to the handheld device and press ‘Connect’.
A dialog will now appear in SCC listing all the job files available from PocketDTM.
Highlight the file you want and select ‘OK’ to download.
The file is then transferred to SCC and the user should see the progress bar moving until
completion.
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SCC to PocketDTM file transfer format
The SIO format is used to transfer coordinate, GPS and total station data in comma
separated ASCII format between SCC and PocketDTM. Where the value of a field is not
available or relevant, use a default value of zero. PocketDTM ASCII files should have the
extension ‘.SIO’. The principal record types are as follows;

Observation record
Observations that contain a non-zero slope distance are taken to be total station
observations. Observations with a non-zero number of satellites are taken to be raw
Lat/Long GPS observations. All other observations are assumed to have valid reduced
coordinates. Line of sight offsets are only applied to total station observations, other
offsets are applied to all observations.

Name

Type

Description

Type

OBS2

Record type

ObsNo

Integer

Point number

AtPt

char[8]

Occupied station name

ToPt

char[8]

Sighted station name

Feature

char[8]

Feature code

str_no

Integer

String number

tag

Integer

Tag code as numeric value
1 - Straight
2 - Curve
3 - Arc
4 - Gap
5 - Link
6 - Duplicate
7 - Square
8 - Disc Curve
9 - Gap Curve
10 - Gap Arc
11 - Link Curve
12 - Link Arc
13 - Link Square
14 - Disc Straight
15 - Vertical
16 - End
17 - Fly Station
18 - Check Station
19 - 3Pt Arc
20 - 2Pt+Tan Arc
21 - 2Pt+Rad Arc
22 - Fillet Arc
23 - 3Pt Circle
24 - 2Pt Circle
25 - 1Pt+Rad Circle
26 - 3Pt Rectangle
27 - 2Pt+Width Rect
28 - Begin
29 - Begin Closed Curve
30 - Begin Polygon
31 - Back-Sight
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Name

Type

Description
32
33
34
35
36
37
38
39
40
41
42

-

Fore-Sight
Side-Shot
Free Station
GPS XYZ Shift
GPS Trans. Point
GPS Lat/Long Shift
GPS Base set-up
Triangle
Taped point
Parallel point
Parallel string

43
44
45
46
47
48

-

Circle fit
Arc fit
Catmull-Rom curve
Trig Spline
Quadratic B-Spline
Cubic B-Spline

Back sights, free stations, and GPS tags will all
be used to create instrument set-up records in
the survey document. Back sights, fore sights,
side shots and free stations will be included as
traverse observations.
Taped point, parallel point, and parallel string
tags will be used to create extra measurements
on the current string.
dtm

Integer

DTM code as numeric value
1 - DTM Elevation
2 - Approx. Elevation
3 - Elevation
4 - Ignore
5 - Break line
6 - Void Line
7 - Clip Polygon
8 - 2D Void Line
9 - 2D Clip Polygon
10 - 2D Boundary
11 - Approx. String
12 - Exclude

x

Double

E/X in meters

y

Double

N/Y in meters

z

Double

Height in meters

inst_ht

Double

Instrument height in meters

rod_ht

Double

Rod height in meters

ha

Double

Horizontal angle in radians

va

Double

Vertical angle in radians
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Name

Type

Description

sl_dist

Double

Slope distance in radians

d1

Double

D1 in meters

d2

Double

D2 in meters

d3

Double

D3 in meters

ParLatOffset

Double

Lateral offset based on line of travel of current
feature

ParLongOffset

Double

Longitudinal offset based on line of travel of
current feature

LosLatOffset

Double

Lateral offset based on line of sight from total
station

LosLongOffset

Double

Longitudinal offset based on line of sight from
total station

ZOffset

Double

Vertical offset

ObsSeq

Integer

Sequential observation number

ObsTime

Integer

Observation time

Lat

Double

WGS 84 latitude

Long

Double

WGS 84 longitude

Height

Double

WGS 84 height

XRMS

Double

XRMS error

YRMS

Double

YRMS error

ZRMS

Double

ZRMS error

HDop

Double

Horizontal dilution of precision

VDop

Double

Vertical dilution of precision

NoSats

Integer

Number of satellites used in computation

FixType

Integer

Quality of GPS fix
0 – No GPS
1 – Autonomous
2 – Float
3 – Fixed
4 – Fixed
5 – Fixed

CalibNo
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Station Coordinate Record
Name

Type

Description

Type

STN

Record type

Name

Char[8]

Station name

x

Double

E/X in meters

y

Double

N/Y in meters

z

Double

Height in meters

PointNumber

Integer

PointType

Integer

Lat

Double

WGS 84 latitude

Long

Double

WGS 84 longitude

Height

Double

WGS 84 height

Text note / Survey remark record

Name

Type

Description

Type

TXT

Record type

Feature

Char[8]

Station name

x

Double

E/X in meters

y

Double

N/Y in meters

z

Double

Height in meters

Height

Double

Text height in mm

Width

Double

Text width in mm

Rotation

Double

Text orientation in radians

Point number

Integer

Justification

Integer

Set to 0

Flags

Integer

Unused

Style

Char[32] Font style, set to ‘Normal’

Group

Integer

Unused

ID

Integer

Unused

Text

Char[255 Survey remark
]
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Sample of a PocketDTM .SIO file
STN,1
,
10000.000,
10023.327,
99.831,
1, 1, 0.0000000000,
0.0000000000,
0.00000
STN,2
,
10000.000,
10000.000,
100.000,
10, 1, 0.0000000000,
0.0000000000,
0.00000
STN,3
,
9978.367,
9958.395,
100.183,
11, 0, 0.0000000000,
0.0000000000,
0.00000
STN,4
,
9995.958,
9993.189,
100.042,
12, 0, 0.0000000000,
0.0000000000,
0.00000
STN,5
,
9942.640,
9974.957,
100.544,
13, 0, 0.0000000000,
0.0000000000,
0.00000
STN,6
,
9977.029,
10017.215,
99.990,
14, 0, 0.0000000000,
0.0000000000,
0.00000
STN,7
,
10010.679,
10067.107,
99.148,
15, 0, 0.0000000000,
0.0000000000,
0.00000
STN,8
,
10045.615,
10124.225,
98.028,
16, 0, 0.0000000000,
0.0000000000,
0.00000
STN,9
,
10074.590,
10168.625,
97.805,
17, 0, 0.0000000000,
0.0000000000,
0.00000
OBS2,
1,2
,1
,~STATION,
0,031,002,
10000.000,
10023.327,
99.831,
1.591,
1.650,2.04123528,1.57550387,
23.327,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
1,1086157647, 0.0000000000,
0.0000000000,
0.00000,
0.000,
0.000,
0.000,
0.000,
0.000,000,000,000
OBS2,
2,2
,3
,~STATION,
0,033,002,
9978.368,
9958.393,
100.185,
1.591,
1.660,5.66227958,1.56538581,
46.895,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
2,1086157685, 0.0000000000,
0.0000000000,
0.00000,
0.000,
0.000,
0.000,
0.000,
0.000,000,000,000
OBS2,
3,2
,1
,~STATION,
0,032,002,
10000.001,
10023.326,
99.837,
1.591,
1.650,5.18288127,4.70792869,
23.326,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
3,1086157876, 0.0000000000,
0.0000000000,
0.00000,
0.000,
0.000,
0.000,
0.000,
0.000,000,000,000
OBS2,
4,2
,3
,~STATION,
0,033,002,
9978.364,
9958.395,
100.197,
1.591,
1.660,2.52077419,4.71806615,
46.895,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
4,1086157918, 0.0000000000,
0.0000000000,
0.00000,
0.000,
0.000,
0.000,
0.000,
0.000,000,000,000
OBS2,
5,2
,1
,~STATION,
0,032,002,
10000.001,
10023.327,
99.831,
1.591,
1.650,2.04126437,1.57550387,
23.327,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
5,1086157971, 0.0000000000,
0.0000000000,
0.00000,
0.000,
0.000,
0.000,
0.000,
0.000,000,000,000
OBS2,
6,2
,3
,~STATION,
0,032,002,
9978.367,
9958.394,
100.187,
1.591,
1.660,5.66230382,1.56534217,
46.895,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
0.000,
6,1086158008, 0.0000000000,
0.0000000000,
0.00000,
0.000,
0.000,
0.000,
0.000,
0.000,000,000,000

©2015 Atlas Computers Ltd

621

30.4

Leica (1100/1200/Wildsoft/LisCADD)
Leica WildSoft/LisCADD style interface

The ‘WildSoft/LisCADD’ style processing option for Leica GSI files lets us configure how the
code fields in the GSI file are interpreted, based on the value stored in the ‘41’ record. The
value in the 41 field controls how all the other user definable GSI fields, i.e. 42 to 49, and 70 to
79 are interpreted. Additionally, for each 41 field value, we can specify the observation record
type, i.e. detail, instrument setup, extra measurement, traverse obs, or remark. These settings
are stored in a ‘.GSIConfig’ file such that they can be recalled for later use.
The duplicate points setting shown below assumes that where there are multiple code lines,
these represent the junction between two or more strings. For example, the code below would
represent the junction between VO 8 and WB 2, where point 376 represents the last point on
VO 8, and the first point on WB 2.
410495+FEATCODE 42....+000000VO
410496+0CodeNum 42....+00000008
410497+FEATCODE 42....+000000WB
410498+0CodeNum 42....+00000002
110500+00000376 21.324+18000260 22.324+08910400 31..00+00065931

See Also
Downloading Leica Data
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30.5

Leica GSI 8/16
This option allows the user to download Leica gsi data.

Detail Fields
These fields allow the user to define which GSI input fields correspond to which SCC
observation fields. For example field 41, GSI Code block ID, will normally be used to store
the SCC feature name. GSI fields 42 to 49 are typically used for additional survey coding,
and fields 71 to 79 are used for survey attributes. Any of these fields can be used to store
values for the feature name, tag code, DTM code, string number, parallel offset, and
dimensions in the SCC observation file. Where an SCC observation field is not logged in
the GSI input file, the value is taken from the SCC feature library currently open. As such,
it is mandatory to log at least the feature code when surveying.

For example, given the dialog values shown in the picture below, the following code block
might be used to describe a tree with a 6.0 meter canopy diameter and a 0.7 meter trunk
diameter.
410006+000000TE 47....+000006.0 48....+000000.7
This presumes that there is a feature called TE in the feature library which is used to
generate trees, and that this feature assumes that D1 is used for the canopy diameter and
D2 for the trunk diameter. This is the case for the default feature library. Note that
alternative coding could be used where D2 represents the trunk radius or girth.
The following example, again assuming the same dialog values, would create a top of
kerb string that includes a curved section
410006+000000KB 42....+0000000S 43....+0000000D 44....
+00000002
110007+00000169 21.304+12359530 22.304+09515230
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31...0+00003502 410006+000000KB 42....+0000000C
43....+0000000D
44....+00000002
110008+00000170 21.304+31544090 22.304+09831430
31...0+00001963
110009+00000171 21.304+30311260 22.304+09221420
31...0+00006222
110010+00000172 21.304+29959310 22.304+09046370
31...0+00010371
410006+000000KB 42....+0000000S 43....+0000000D 44....
+00000002
110011+00000173 21.304+29751120 22.304+08934090
31...0+00015533
110012+00000174 21.304+29730550 22.304+08916290
31...0+00019686
Note that in this example there are three code blocks, and six data blocks, which will yield
six observations in SCC. The first point will be joined to the second point via a straight
line, signified by the 42....+0000000S. The second to the fifth points will be joined via a
curve, signified by the 42....+0000000C, which is tangential to the incoming and outgoing
straights. The fifth point will be joined to the sixth point by a straight. As all the points
have the same string number, they will be part of the same string. The string will also be
triangulated, as a DTM code of D has been given.

Tag Codes
The tag code determines the connective geometry and specifies how the current point on the
string will be connected to the next point on the string. This can be used to specify straight
lines, curves, arcs, and squared up pieces of geometry in a string. The tag codes may be
entered either in numeric or alpha-numeric format.

See Also
Feature Library (View menu)

DTM Code
The DTM (Digital Terrain Model) status code determines the significance of the point of
the surface model / digital terrain model being generated. The DTM codes may be
entered either in numeric or alpha-numeric format

See Also
Feature Library (View menu)

Extra Measurement Fields
Four extra user defined GSI fields may be used to collect extra measurement information
corresponding to the SCC extra measurement sheet. These will be for measurement
type, longitudinal offset, lateral offset, and elevation offset. The measurement type
corresponds to the SCC extra measurement type field and can have the following values;
Name

Numeric Code

Description
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Line Of Sight
Offset

1

The first offset corresponds to the
distance forward or back along the
line of sight between the instrument
and the target. The second offset
corresponds to the distance left or
right along the line of sight between
the instrument and the target. The
third offset corresponds to the
elevation offset.

Taped Offset

2

The first offset corresponds to the
distance forward or back along the
line connecting the last two points.
The second offset corresponds to the
distance left or right from the line
connecting the last two points. The
third offset corresponds to the
elevation offset.

Copy Parallel

3

The first offset corresponds to the
distance between the observed
feature line and the generated feature
line. The third offset corresponds to
the elevation offset.

Point Duplication
This field controls how junction points are created. Junction points are typically created
when there are two successive code lines in the input file, with no intervening data lines.
This facility can be disabled, enabled only for data lines that include a tag code of D
(Duplicate), or enabled for all multiple code lines.
*41....+00000000000000WL 420026+000000000000000D
43....+0000000000000001 44....+0000000000000000 45....
+0000000000000000
*41....+00000000000000HE 420026+000000000000000D
43....+0000000000000002 44....+0000000000000000 45....
+0000000000000000
*110027+0000000000000014 21.322+0000000005145900
22.322+0000000010039100 31..00+0000000000034988
51..1.-000000000010+002 87..10+0000000000001500
*110028+0000000000000015 21.322+0000000004558400
22.322+0000000010054450 31..00+0000000000036128
51..1.-000000000010+002 87..10+0000000000001500
*110029+0000000000000016 21.322+0000000004059700
22.322+0000000010046050 31..00+0000000000035758
51..1.-000000000010+002 87..10+0000000000001500
The GSI example above will generate four points, the first two are a junction between a
wall and a hedge, the next two are on the wall. In this case, the tag code of ‘D’ has been
used in field 42 to create the duplicate point. Note that point duplication is only supported
where codes precede observations.

Traverse Observation Feature Code
An extra user defined feature code may be used to signify a control observation. This
observation will be used as a reference observation in the instrument set-up sheet and as
©2015 Atlas Computers Ltd

625
a traverse observation in the traverse sheet. This facilitates combined detail and traverse
surveys using the GSI format. If this field is left blank, and tag codes are not being
collected, all observations will be output to the traverse sheet. If this field is left blank and
tag codes are being collected, observations with tag codes of FS, BS, and SS will be
output to the traverse sheet.

Use Instrument Height Field (88) To Indicate New Setup
Tick this box to indicate that all 88 fields in the input file are to signify a new station set up.

Store Station Co-ordinates
Tick this field if the user wishes to store station coordinates present in the input file, in
fields 84 to 86, in the SCC project control file.

Landscape Coding Extensions
Tick this box to indicate that the field coding used is in the landscape format, rather than
the default SCC format . This box should only be ticked if you are replacing an existing
Landscape system with SCC and wish to maintain your current field coding methods.

This dialog controls the translation, when applicable, from LandScape style field coding to
SCC coding. The field values in this dialog are stored in the registry and only need to be
changed when a modification is necessary.

See Also
Landscape Coding Extensions Trimble /Geodimeter UDS

Use Enhanced Coding Extensions
The enhanced coding extensions operates by providing an extra table, stored in the project file,
that maps field codes onto feature codes, tag codes, DTM codes, and string numbers. It can
be accessed in the project menu via ‘Import / View SDR translation table’.
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See Also
Advanced Survey Coding (View Menu)

Codes Precede Observations
This option controls whether a code block is associate with the preceding observation, or
the following observation. For example, in the input below the code block precedes the
data block
410006+000000KB 48....+0000000S 47....+0000000D 49....
+00000002
110007+00000169 21.304+12359530 22.304+09515230
31...0+00003502

Use Topo X,Y,Z in Preference to HA,Va,Sd
This option allows the computed X,Y,Z positions in the GSI input file to be stored in the
SCC observation sheet rather than the Ha,Va,Sd values, where both occur in a single data
line. This is useful if the GSI file does not include all of the survey observations, such as
observed back-sights, as shown in the example below;
*110001+000000000000GR0A 84..10+0000000320728329
85..10+0000000376869559 86..10+0000000000099259
*110002+000000000000GR01 81..00+0000000320715339
82..00+0000000376754428 83..00+0000000000100000
*110003+000000000000GR0A 84..10+0000000320728329
85..10+0000000376869559 86..10+0000000000099259
87..10+0000000000001500 88..10+0000000000001602
79....+000000000000GR01
*110004+0000000000000066 21.324+0000000018626250
22.324+0000000008940550 31..00+0000000000115851
87..10+0000000000001500 71....+0000000000000000
72....+0000000000000000 73....+0000000000000000 74....
+0000000000000000 81..00+0000000320715334 82..00
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+0000000376754441 83..00+0000000000100005
*110005+0000000000000067 21.324+0000000015216010
22.324+0000000008744130 31..00+0000000000074790
87..10+0000000000001500 71....+0000000000000OSC
72....+0000000000000000 73....+0000000000000000 74....
+0000000000000000 81..00+0000000320763106 82..00
+0000000376803412 83..00+0000000000102315

30.6

Trimble TSC/TSCe (DC)
SCC can read data from the Sokkia SDR series of loggers, and the later Trimble TSCE
loggers, in their native format either from disk or RS232 port. This option can read data in
wide and narrow SDR formats, and Trimble DC formats up to DC 10.70, supporting enhanced
D9, 79, 80, E1 and E0 records. When exporting GPS data from the Trimble TSCE or ACU, it
should be exported in SDR33 format to get coordinated output.
The following dialog is displayed on download;

MX / MOSS coding extensions
This field specifies whether MOSS SURVEY coding extensions are included in the Sokkia
input file. These are as follows:
Station names occur in the description field
String labels occur in the description field
All labels starting with P or TP and containing numerics are FLY stations
201 and 203 indicators may be included in description and comment records
Dimensions for REP rectangular features are coded in the comment record

SDRMap Coding Extensions
This option uses the advanced field coding library to interpret SDRmap style field coding

Only treat the following observation numbers as stations
This assumes that a given range of survey point numbers, usually 0-999, are reserved for
station observations, and all other point numbers refer to topography points
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Station Name Suffix
This field contains a four character suffix that will be added to all station names input from
this input file. This may be used to distinguish different sets of stations with the same
names held in different traverses in the same project. Leave this field blank if you are
using consistent station names across all the information in this project

Alpha-numeric station names
This assumes that station names are entered into the point code field. If this option is not
selected the point number will be used as the station name

Search remarks for dimensions
This option enables support for entering of extra point and control codes in the comment
fields. These can be SDR codes or MOSS codes depending on the coding option
selected

Skip remarks starting with
If this option is selected, and 'Search remarks for dimensions is selected', remarks
starting with this value are taken is a text notes rather than extra field codes.

Use change in occupied station to create new set-ups
Selecting this option assumes the instrument set-up changes whenever the occupied
station changes

Use 02 (Inst Ht) records to indicate new-setups
Selecting this option assumes the instrument set-up changes whenever a new occupied
coordinate record (02) is encountered

Use 07 (Ref Ha) records to indicate new-setups
Selecting this option assumes the instrument set-up changes whenever a new occupied
coordinate record (07) is encountered

Traverse feature code
Entering a value into this field forces all observations with this feature code to be included
in the traverse observation sheet

Apply Prism Constant (DC 77 record)
This options applies the prism constant present in the raw file to data on download.

Allow dot seperated codes (MSG)
This options supports advanced codes separated by a decimal point.

Setting Out / Stakeout with SDR/Power SET Dataloggers
Setting out data is passed to both the SDR loggers and the PowerSET total station as a
series of 08 co-ordinate records. The format of these records will vary between the SDR
loggers and the PowerSET due to the increased field width available on the PowerSET.
The setting out information will contain co-ordinates for all the data to be set out along with
all the station co-ordinates for the current project. Setting out data may be either written to
file or transmit directly to the RS232 port.

30.7

Trimble /Geodimeter UDS
This option allows the user to download Geodimeter and Trimble data. The user can input
specific fields within the 'Trimble/Geodimeter Data Input' Dialog to coincide fields set up on
their own instrument considering that fields 90-99 are label which can be defined by the user.
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This interface also supports Landscape and Enhanced coding.

If your survey combines detail topography and traverse data, use the 'Traverse Feature' field to
distinguish between traverse and detail observations.
If you are downloading data from the Geodimeter traverse program, set the 'Traverse Code' to
61 in the above dialog. This supports explicit face 2 measurements using the 17 and 18 fields,
and UDS traverse codes in the 61 field.

See Also
Downloading for the Geodimeter
Uploading to the Geodimeter

Landscape Coding Extensions
Tick this box to indicate that the field coding used is in the landscape format, rather than
the default SCC format . This box should only be ticked if you are replacing an existing
Landscape system with SCC and wish to maintain your current field coding methods.
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This dialog controls the translation, when applicable, from LandScape style field coding to
SCC coding. The field values in this dialog are stored in the registry and only need to be
changed when a modification is necessary.

Coding Extensions
The coding extensions determine the suffixes used on point and line codes. These can
be applied to both numeric or alphanumeric coding.

Linear Features
If numeric coding is being employed, the first two digits of the survey code are used for the
feature, and the third and fourth are used for the codes suffixes given below. For
example, given the values below, a code of 4135 would represent a feature name of 41 on
a 2d curved string, that also includes a parallel.

If alphanumeric coding is used, the last character of the survey code is used for the suffix.
For example, KBC might be used to represent a curve point on a KB, or kerb line, feature.
The suffix will only be checked if the full survey code is present in the feature library.
When linear feature suffixes are being checked, sequential linear features with different
feature details will create string junctions. For example, given a four point sequence of 1
Kerb, 2 Gate, 3 Kerb, 4 Kerb, point 1 would be joined to point 2 by a kerb, point 2 to 3 by a
gate, and 3 to 4 by a kerb.

Straight 2D
Indicates that the point is on a straight line and is not in the DTM

Straight 3D
Indicates that the point is on a straight line and is in the DTM

Curved 2D
Indicates that the point is on a curve and is not in the DTM

Curved 3D
Indicates that the point is on a curve and is in the DTM
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Parallel
Indicates that a second string will be generated from the survey string using the surveyed
dimensions for offset distance. This is only applied with numeric coding.

Point Features
Circular (1 point + dim)
One or more symbols are placed at the point, with the dimensions taken from the
surveyed dimensions. The feature library determines the units of the dimension. The
number of dimensions controls the number of symbols placed.

Point (1 point)
A point or symbol is placed at the survey point. The feature library controls whether a
symbol is placed, and gives the symbol a size.

Rectangular (2 points)
A symbol, such as a gate, is fitted between two survey points. Either the feature library, or
survey dimension can be used to control the transverse dimension.

Triangular (2 points)
An equilateral triangle is placed using the two survey points as the base, and the apex on
the right of the two points.

Rectangular (3 points)
A symbol is fitted into the rectangle generated by the three survey points.

Comma separated alpha-coding
This option allows the use of multiple, comma separated codes, in a given survey code, to
produce a string junction. For example KB,GA might be used to create a point that is
common to a kerb and gate.

Use alpha coded standard SCC tags
This option allows the use of SCC tag codes in the survey code. For example KB,C might
be used to indicate a point of curvature on a string.

End String
Use this code to signify the end of the current linear string feature.

Close String
Use this code to signify the current point on the current linear string feature is to be linked
back to the first point to form a closed polygon.

New String
Use this code to start a new string

Control Obs
Use this code to signify that the current observation is to be included in the traverse file,
and/or used as an RO in the detail file.

Ref Station
Use this code to signify that the current observation is to be included in the traverse file,
and/or used as an RO in the detail file.
Extract of Geodimeter File denoting two topographic points:
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5=3
7=225.2138
8=88.0915
9=90.158
4=HE
6=1.900
99=1
98=S
97=A
5=4
7=236.5228
8=88.1239
9=89.088
4=HE
6=1.900
99=1
98=S
97=A
where 4 =Point Code
5 = Point Number
6 = Signal Height
99 = String No. (User Defined)
98 = Tag Code (User Defined)
97 = DTM Code (User Defined)

30.8

Trimble Job XML (JXL)
This option allows the user to download Trimble Job XML files directly into SCC. This option
supports multiple feature codes and/or dimensions entered as a single feature code when
using the advanced coding options.
<?xml version="1.0" encoding="UTF-8"?>
<JOBFile jobName="TEST" version="5.2" product="Trimble
Survey Controller" productVersion="12.44"
productDBVersion="1243-2"
TimeStamp="2009-04-22T09:12:24"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
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xsi:schemaLocation="http://www.trimble.com/schema/JobX
ML/5_2
http://www.trimble.com/schema/JobXML/5_2/JobXMLSche
ma-5.2.xsd">
<FieldBook>

<UnitsRecord ID="00000002"
TimeStamp="2009-04-22T09:12:41">
<DistanceUnits>Metres</DistanceUnits>
<HeightUnits>Metres</HeightUnits>
<AngleUnits>DMSDegrees</AngleUnits>
<AzimuthFormat>Azimuth</AzimuthFormat>
<LatitudeLongitudeUnits>DMSDegrees</LatitudeLong
itudeUnits>
<CoordinateOrder>East-North-Elevation</Coordinate
Order>
<TemperatureUnits>Celsius</TemperatureUnits>
<PressureUnits>MilliBar</PressureUnits>
<GradeUnits>Percentage</GradeUnits>
<AreaUnits>SquareMetres</AreaUnits>
<StationingFormat>1+000.0</StationingFormat>
</UnitsRecord>

<FeatureCodingRecord ID="00000003"
TimeStamp="2009-04-22T09:12:41">
<LibraryName>TEST</LibraryName>
<SourceFilename>TEST.FXL</SourceFilename>
<AttributeCheckSum>0</AttributeCheckSum>
<AttributesStored>true</AttributesStored>
</FeatureCodingRecord>

<CorrectionsRecord ID="00000004"
TimeStamp="2009-04-22T09:12:41">
<SouthAzimuth>false</SouthAzimuth>
<GridOrientation>IncreasingNorthEast</GridOrientati
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on>
<MagneticDeclination>0</MagneticDeclination>
.......
.......
<PointRecord ID="00000017"
TimeStamp="2009-04-22T09:18:26">
<Name>ST02</Name>
<Code>PSTN</Code>
<Method>Coordinates</Method>
<SurveyMethod>KeyedIn</SurveyMethod>
<Classification>Normal</Classification>
<Deleted>false</Deleted>
<Features>
<Feature Name="PSTN">
<Attribute>
<Name>REMARK</Name>
<Value/>
<Type>Text</Type>
</Attribute>
</Feature>
</Features>

<Grid>
<North/>
<East/>
<Elevation/>
</Grid>
</PointRecord>

<AtmosphereRecord ID="0000001b"
TimeStamp="2009-04-22T09:19:30">
<Pressure>1027</Pressure>
<Temperature>8</Temperature>
<PPM>-15.843347593016</PPM>
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30.9

Sokkia SRX/SDR33/SDR22
The format varies between SDR22 and 33 and can include attributes when taken from Trimble
SC as per your feature library.

See Also
Trimble TSC/TSCe (DC)

30.10 TopCon (TopSurv & neutral formats)
This option can be used to download detail topography and traverse data from TopCon
equipment in either TopSurv or CivilCAD Neutral (.NEU) formats. For more details on the
TopSurv format, refer to the TDS interface.

30.11 Topcon GTS7 format
This option can be used to download detail topography and traverse data from TopCon
equipment in GTS7 format. Feature codes in the GTS7 format can contain embedded string
numbers to facilitate stringing in the field, for example KB01 would be KB string 1. Point codes
that are less than 3 characters and point codes that do not include numeric data are taken to
be discrete point features.

30.12 TopCon X, Y, Z
This option allows the user to import TopCon XYZ files.
Sample Files: *.txt file
JB,NMTOPCON001,DT07/04/2005,TM12:46:38
MO,AD0,UN1,SF1.0,EC0,EO0.0,AU0
OC,OPSTN1,N 500.000,E 1000.000,EL10.000,--STN,STN,STN,
STN
LS,HI1.569
BK,OPSTN1,BP2,BS169.0120,BC0.0000
--HR at Backsight: 1.600
BK,OPSTN1,BPSTN2,BS169.0115,BC243.2606
BK,OPSTN1,BPSTN2,BS169.0115,BC243.2606
BK,OPSTN1,BPSTN2,BS169.0125,BC243.2606
BK,OPSTN1,BPSTN2,BS169.0125,BC243.2606
OC,OPSTN1,N 500.000,E 1000.000,EL10.000,--STN,STN,STN,
STN
LS,HI0.000
BK,OPSTN1,BP10,BS0.0000,BC0.0000
--HR at Backsight: 0.000
LS,HI0.000,HR1.600
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SS,OPSTN1,FPSTN2,AR292.5835,ZE93.5130,SD35.710,--STN
SS,OPSTN1,FPSTN2,AR292.5830,ZE93.5125,SD35.711,--STN
SS,OPSTN1,FPSTN3,AR72.0545,ZE89.3600,SD35.904,--STN
SS,OPSTN1,FPSTN3,AR72.0550,ZE89.3600,SD35.901,--STN
LS,HI0.000,HR99.000
--Z
SS,OPSTN1,FP500,AR73.2320,ZE90.1530,SD54.418,--BG
--Z
SS,OPSTN1,FP501,AR73.1310,ZE90.2225,SD54.142,--BG
LS,HI0.000,HR0.500
SS,OPSTN1,FP502,AR73.0645,ZE90.2035,SD54.130,--BG
SS,OPSTN1,FP503,AR71.4400,ZE90.5055,SD51.092,--BG
LS,HI0.000,HR2.000
SS,OPSTN1,FP504,AR67.4935,ZE90.1125,SD44.140,--BG
--X

*.raw fille
Header>> Delimiter(,) FileFormat(Name,Lon(East),Lat
(North),Ht(G),FullCodes,Notes) <<
STN1,1000.000,500.000,10.000,STN,STN&"21",
STN&"166",STN&"180",
STN2,967.198,513.908,5.997,STN,STN&"148",
STN&"170",
STN3,1034.164,511.038,8.651,STN,STN&"37",
STN&"170",
500,1052.146,515.557,-89.245,BG&"1"@"Z",
501,1051.835,515.631,-89.353,BG&"1"@"Z",
502,1051.795,515.724,9.176,BG&"1",
503,1048.512,516.013,8.743,BG&"1",
504,1040.875,516.659,7.853,BG&"1",
505,1039.694,516.736,7.849,BG&"2"@"X",
506,1034.155,517.235,7.370,BG&"2",
507,1034.215,517.464,7.368,BG&"2"@"X",
508,1034.252,517.502,7.350,BG&"3"@"X",
509,1034.474,520.342,7.156,BG&"3",
510,1034.675,521.455,7.148,BG&"4"@"X",
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511,1034.606,521.480,7.148,BG&"4"@"X",
512,1035.160,528.304,7.103,BG&"4",
513,1035.315,529.189,7.108,BG&"5"@"X",
514,1035.244,529.231,7.109,BG&"5"@"X",
515,1035.301,530.220,7.118,BG&"5"@"X",
516,1035.680,533.816,7.126,BG&"6",
517,1035.610,533.850,7.126,BG&"6"@"X",
518,1035.706,535.169,7.130,BG&"6",
519,1035.860,536.059,7.123,BG&"7"@"X",
520,1035.795,536.095,7.123,BG&"7",
521,1035.889,537.211,7.120,BG&"7"@"X",
522,1036.050,538.313,7.124,BG&"8"@"X",
523,1035.975,538.345,7.125,BG&"8",
524,1036.045,539.418,7.118,BG&"8"@"X",
525,1036.231,540.548,7.122,BG&"9"@"X",
526,1036.156,540.584,7.122,BG&"9"@"X",

30.13 Nikon AP700
AP700 files are obtained from the Nikon AP700 on board software.
The AP700 files contain six basic record types;
AP700 Record Types

How these records are represented in
the survey files ?

Co-ordinates

UC

Station Records

ST

Control Points

CP

Side-shots

SS

Stakeout records

SO

Comments / Notes

CO

This data may be downloaded as raw data or co-ordinate data. It is best to work with raw
observations for error detection, therefore it is strongly advisable to always download the
raw data.
When downloading Nikon AP700 data in SCC the Nikon AP700 Data Input is presented
after you select the file you wish to download. This dialog requires station naming and
data formats to be set. There is an option to store Stakeout records in datasheet if there
are any present in the data file.

30.14 Nikon (Survey Supplies .NIK)
FastMAP700 is the on board Nikon software that was developed by Survey Supplies Ltd. The
software runs on the Nikon DTM700 series of field stations and the HP palmtop and Husky FS
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series of dataloggers. SCC can read in the raw .NIK files and traverse .OBS files
When .NIK files are selected for download SCC presents the user with the Nikon Data Input
(Survey Supplies .NIK) dialog. This dialog requires First Station Number and Station Feature .
If MX coding was used in the survey SCC can be set to read this. The Remarks column may
be searched for dimensions.
The following is a line of observation information taken from a NIK file;
0001 A,02.587,1854247,0881648,54.310,MHS
Detail Information in NIK file

What They Represent ?

0001

Observation Number

A

Raw Detail Observation Value

02.587

Target Height

1854247

Horizontal Angle

0881648

Vertical Angle

54.310

Height / Z value

MHS

Feature Name

The following is a line of station information taken from a NIK file;
9001 B,500.000000,500.000000,50.000000,STN
Station Information in NIK file

What They Represent ?

9001

Station Name

B

Co-ordinates value

500.000000

Easting

500.000000

Northing

50.000000

Height

STN

Feature Name

30.15 MDL ADS CDS &CDU
This option downloads data created by MDL ALS scanners in either CDS or CDU format. Data
can be downloaded as both topographic surveys and traverses as required, though only simple
stringing is supported. When you choose to download from the ALS, you will be prompted for
the data format and whether you wish to string the points. SCC uses P codes in the input file
as feature codes. If you elect to connect points using strings, you can force given features
back to point codes using the feature library. Tag and DTM codes cannot be logged and are
taken from the feature library.
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Change of station is noted by a feature code 54 in the CDS format, or 60 in the CDU format.
Feature code 90 is used to generate a clip polygon in the CDS format. For sample CDS and
CDU files, please refer to the SCC tutorials directory.

30.16 MOSS SURVEY formats (Leica VIP, SDR33 MOSS)
MX SURVEY is the set of minor options provided by MX to input detail and traverse survey
information. As such it is a generic format output by many data loggers. SCC allows input of
MX SURVEY information into the SCC database, or, directly into the MX model.
MX SURVEY information may be transferred into SCC either via disk or the serial port. When
transferring MX SURVEY data from the RS232 port, SCC uses 9600 baud, no parity, and XON/
XOFF handshaking. This may be set up on the SDR33 as follows ;

Press F3 to select COM
Select COMMS SETUP and enter the following settings
PORT

BOTTOM

MODEM

NO

BAUD RATE

9600

DATA BITS

8

PARITY

NOT SET

STOP BIT

1

OUTPUT DELAY

0

Select MX output and press Enter.
The MX SURVEY translator generates output in the log file that describes any errors or
potential errors found in the input file. This information is accompanied with the offending
line and its line number. The offending line is skipped and the remainder of the file is
processed. The following error messages may be reported;
1. Warning, Wrong observation format <MX code>, SDVA, VASD, required
2. Error, Dimension of rectangle not coded
3. Error, Dimensions not coded on feature offset
4. Error, Horizontal offset not coded on parallel feature
5. Warning, Vertical offset not coded on parallel feature
6. Error, Dimensions not coded on tape measurement
7. Error, Radius not coded on circle
8. Error, Dimensions not coded on line of sight offset
9. Error, <MX code> in field 3 moved to field 2
10.Skipping string label <MX code> (Miscoded minor option record)
11.Error, <MX code> in field 3 moved to field 1
12.Error,No VA coded, using default from 190 record
13.Error,Bad observation number
14.Error,No station name coded
Only SURVEY records that have counterparts in the SCC database will be transferred.
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These records are input directly into a raw MX SURVEY file in the field

SURVEY records include the following
· Instrument set-up information

Minor option 200

· Angle and distance theodolite
observations for detail and traverse

Minor option 201
Minor option 201,TRAV
Minor option 201,FLY
Minor option 201,CHE

· Station co-ordinates

Minor option 180

· Circular features

Minor option 201
CRC,CR2,CR3,CRD

· Rectangular features

Minor option 201
REM,REP

· Parallel strings

Minor option 203

· Offset strings

Minor option 201,OFF

· Taped measurements

Minor option 201,TAP

· Unit settings

Minor option 017

30.17 MOSS Site Measurement Module (MSMM)
Data is transferred in the internal binary formats used by the MSMM and as such may not be
edited by the user. All data transfer occurs using either the high-speed serial link or the Oracle
GT disk drive.
When transferring data via the RS232 port SCC will scan the MSMM for data in jobs 1 to 9. If
data is found in any of these jobs the software will ask the user whether or not to download the
job with a default name. The default name comprises of the MSMM job number and transfer
date in the format J<Job number>Q<Date>.
For example, if one were to download data from job 7 on the 23rd of July the default job
name would be J7Q29JUL. At this point, the user can do one of three things ;
· Select Load to download the job under its default name
· Type in an alternative name for the job and press Enter to download
· Select Skip to skip this job and move onto the next job
When all nine jobs have been checked, the communications program will automatically
terminate on both the PC and MSMM.
Setting out data may be sent either directly to the logger or written to a disk. Setting out
data includes point number, point description, chainage, offset, and x, y, z information.
Setting out files will be created for both the setting out and levelling programs. The station
co-ordinates will also be output as an MSMM control file.
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30.17.1 Huskey Hunter (MSMM)
Data is transferred in the internal binary formats used by the MSMM and as such may not be
edited by the user. All data transfer occurs using either the high-speed serial link or the Oracle
GT disk drive.

30.17.2 HP100LX/200LX RS232 (MSMM)
Downloading & Processing Traverse Data
Downloading & Processing Detail Topography Data

30.17.3 MOSS SURVEY coding extensions
MOSS Coding Extensions
In addition to the SCC advanced field coding, SCC also supports MOSS SURVEY style
coding on a number of its survey interfaces. The following options are available

3 point rectangle

To create a three-point rectangle, where SCC generates the fourth point, in the Cd field
enter REPS <Label> for three successive observations. You may also use REPR, and
REPL. Strings coded with REPS and REPR will appear in the triangulation whereas those
with REPL will not.

2 point rectangle

To create a two-point rectangle, where SCC generates the third and fourth points, in the
Cd field enter REMS <Label> for two successive observations. You may also use REMR,
and REML. Strings coded with REMS and REPR will appear in the triangulation whereas
those with REML will not. After the second observation press the Note key and enter
W=<Width>, where <Width> is the width of the rectangle. Negative values place the
generated points to the left of the surveyed points. Positive values place the generated
points to the right of the surveyed points.

3 point circle
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To create a three-point circle in the Cd field enter CR3S <Label> for three successive
observations. You may also use CR3R, and CR3L

2 point circle (2 points on the diameter)

To create a two-point circle with two points on the diameter, in the Cd field enter CRDS
<Label> for two successive observations. You may also use CRDR, and CRDL. Strings
coded with CRDS and REPR will appear in the triangulation whereas those with CRDL will
not.

2 point circle (Point on centre and circumference)

To create a two-point circle with the first points on the centre and the second on the
circumference, in the Cd field enter CR2S <Label> for two successive observations. You
may also use CR2R, and CR2L. Strings coded with CR2S and CR2R will appear in the
triangulation whereas those with CR2L will not.

Taped measurements
SCC supports entry of tape measurements, in the form of lateral and longitudinal offsets,
from a base line. The last recorded point and previous point on the same string are used
as a base line. Once you have established a base line press the Note key and enter
TAPE <Lat. Offset> <Long Offset>. You may also use the form TAPE <Label> <Lat.
Offset> <Long Offset> to place the taped point in a different string. Additionally you can
use TAPE CLOS <Lat. Offset> <Long Offset> or TAPE SQUC <Lat. Offset> <Long
Offset> to close off the taped string by linking the current point back onto the first point in
the string. Successive tape measurements will use the last two points, whether observed
or taped, as the base line for the next measurement. The example below, in both graphic
and SDR output format, illustrates tape measurement.
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09F105003101113.44500084.8016666295.277777SK01
09F105003101113.44500084.8016666295.277777LP00
03NM5.00000000
09F105003102106.66000085.0094444295.616388202 SK01
09F10500310397.195000085.3947222293.794166SK01
03NM2.00000000
09F10500310489.405000088.1933333286.959444SK01
03NM5.00000000
09F10500310591.100000088.2391666276.691944SK01
09F10500310692.765000088.6469444275.394444201 CLOS
13NMS SK01 STN AND CONC WLK
03NM1.80000000
09F105003107114.65000086.7227777300.166944LP00
13TS19-Jun-92 12:08
13NM201 TAPE LP00 -8.2
13NM201 BD03
baseline
03NM5.00000000
09F105003108125.31000086.0102777304.772500BD03
13NM201 TAPE BD03 -18.6
13NM201 TAPE BD03 2.7
13NM201 TAPE BD03 -6.0
13NM201 TAPE BD03 -2.7
13NM201 TAPE BD03 4.2
13NM201 TAPE SQUC -48.5

First point on base line

SK01
Second point on base line
First taped point on LP00 (3107.2)
Copy taped point into BD03 for new

Second point of new base line

Close BD03 to form a linked polygon

Copying a string parallel
To copy a string parallel on the SDR33 first press the Note button. Then enter 203
<Existing string> <New string> <V. Offset> <Hor. Offset>. For example, we have
surveyed the edge of pavement and wish to generate the curb top as a copy of this string
0.1 above and 0.05 to the left. We press the note key and enter the remark as shown on
the left. Apart from saving us a lot of survey work this ensures that the top of curb string
will not cross the edge of pavement string at any point. Remember that we are surveying
the road, NOT designing it. While this facility can save a lot of time it should be used with
care.

30.18 GPS X,Y,Z
This option allows the user to download GPS data and has been extended to support multiple
remarks as required by river surveys. In addition, the river attribute option treats unknown
features with start and continue attributes as strings, and remark attributes as points.
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The following options are also available:

Landscape Coding Extensions
Tick this box to indicate that the field coding used is in the landscape format, rather than
the default SCC format . This box should only be ticked if you are replacing an existing
Landscape system with SCC and wish to maintain your current field coding methods.

This dialog controls the translation, when applicable, from LandScape style field coding to
SCC coding. The field values in this dialog are stored in the registry and only need to be
changed when a modification is necessary.

See Also
Landscape Coding Extensions Trimble /Geodimeter UDS

Use Enhanced Coding Extensions
The enhanced coding extensions operates by providing an extra table, stored in the
project file, that maps field codes onto feature codes, tag codes, DTM codes, and string
numbers. It can be accessed in the project menu via ‘Import / View SDR translation
table’.
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See Also
Advanced Survey Coding (View Menu)

30.19 Panterra
This option downloads data created by a Panterra Husky data logger, comprising of either
topographic survey data or traverses data.

See Also
Panterra

30.20 NRG PDF & GPF format
This option downloads NRG format data either in reduced coordinate format from NRG (GPF)
or radial format from a Psion logger (PDF). The PDF format can be used to transfer detail
topography, stations and traverse data. The SCC Advanced survey coding library may be used
in conjunction with the PDF and GPF format for complex stringing as required.
NRG ‘+’ and ‘-‘ codes may also be used within the GPF format for stringing. Note that when
downloading GPF data, the SCC feature library controls drawing defaults, such as colour, line
style and annotation.

30.21 AASTHO SDMS
SCC supports the AASHTO (American Association of State Highway and Transportation
Officials) SDMS standard (Survey Data Management System) as defined in the SDMS v3.1
manuals. SDMS tasks supported are radial topography (TK:RTO), traverse (TK:TRA), and
stake out.
Data may be transferred to and from an SDMS logger either via disk or RS232 connection.
The default communications settings for an RS232 connection are 9600 baud, no parity, 8 data
bits, one stop bit, and XON/XOFF handshaking.
The following information is translated from an SDMS side shot into a SCC detail observation
when processing radial topography;
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Code

Value

AC:

SS

PN:

Point number

PD:

Comment

FE:

Feature name

GM:GM:

LINEARGM:POINTGM:MOSSGM:SPLIGM:CLOS Geometry
codeJoin to next point by a straight lineSet this observation to be a
single pointJoin to next point by a curveJoin to next point by a
curveJoin back to first point on the string

PS:

Point specifier used for extra measurements

PS:IGN

Ignore elevation of point

PS:IGL

Ignore point entirely

PS:DISC

Insert a gap in a string (Discontinuity)

PS:DISB

Change string direction (Bearing discontinuity)

PS:REM

Rectangle using 2 points and an offsetTwo successive points must
have PS:REM included, the second point should have the offset
coded in the OF: field. If REML is used the level of the generated
points will be ignored.

PS:REP

Rectangle using 3 pointsThree successive points must have PS:REP
included. If REPL is used the level of the generated points will be
ignored.

PS:CRD

Circle using 2 points on the diameterTwo successive points must
have PS:CRD included. If CRCL is used the level of the generated
points will be ignored.

PS:CR2

Circle using 2 points, radius and centreTwo successive points must
have PS:CR2 included. The first is the centre, the second any point
on the circle. If CR2L is used the level of the generated points will be
ignored.

PS:CRC

Circle using 2 points, radius and centreTwo successive points must
have PS:CR2 included. The first is the centre, the second any point
on the circle. If CR2L is used the level of the generated points will be
ignored.

PS:CR3

Circle using 3 pointsThree successive points must have PS:CR3
included. If CR3L is used the level of the generated points will be
ignored.

PS:TAP

Taped measurementThis uses the last two observed points as a
base line. The lateral offset is coded in the OF:field. The
longitudinal offset is coded in the LN: field. If TAPL is used the level
of the generated points will be ignored. It is not necessary to code a
full radial observation with this measurement. Successive taped
measurements without radial observation information will use the last
two generated points as a base line.

PS:OFF

Offset pointThe lateral offset is coded in the OF: field. The
longitudinal offset is coded in the LN: field. If OFFL is used the level
of the generated points will be ignored.

PS:CHE

Station checkThis assumes that the station name is coded in the FE:
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field and that this is an observation to that station. The difference
between the computed and stored co-ordinates for the station will be
output to the log file during co-ordinate reduction.
PS:FLY

Fly stationThis assumes that the station name is coded in the FE:
field and that this is an observation to that station. The station coordinates will be computed and output to the log file during coordinate reduction.

OF:

Offset value used for extra measurements

HT:

Horizontal angle

VT:

Vertical angle

DS:

Slope distance

CM:
NEWS

Comment used to start a new string

RA:

Radius of circular features

LN:

Level difference used for extra measurements

30.22 LSS Observation File
This option can be used to download detail topography and traverse data from LSS load files.
The SCC advanced field-coding library is used to translate LSS field codes into SCC features,
tags, DTM and strings. Typically, point features will begin with the letter P, and new strings will
be started with a full stop. String numbers will typically be embedded into feature names, e.g.
KB10 will be used to identify KB string 10.

When processing traverse data, SCC assumes that all observations beginning with the
sequence ‘-ST’ are control observations. For an example of downloading LSS load files into
SCC, see the project template ‘LSS-Demo.Project’, and the LSS load file ‘LSS-Demo.001’ in
the tutorials directory. This data should be processed as combined detail and traverse.
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30.23 Zeiss REC Elta
Data transfer is supported on the Zeiss REC Elta either via disk or RS232 serial port. RS232
parameters are set for 4800 baud, 8 data bits, no parity, 1 stop bit, Xon/Xoff handsaking
protocol.
The Zeiss REC Elta stores data as a series of records where each record contains a user
supplied information section and an observation. These records are numbered and transmitted
to SCC in an ASCII format. The SCC interface has been designed to allow a range of
measurement types to be coded in the user supplied information section of each record.
These comprise of the following record layouts, where field information is expected at specified
character positions in the record ;

Project Information
Pos

Value

Meaning

1-2

10

Record Type Identification

4-11

Job Name

13-16

Date in the Format DDMM

18-22

Project Name

Traverse Station Occupation
Pos

Value

Meaning

1-2

21

Record Type Identification

4-11

Occupied Station Name

13-16

Instrument height in millimeters

Traverse Observation
Pos

Value

Meaning

1-2

22

Record Type Identification

4-11

Target Station Name

13-16

Target Prism Height in millimeters

Detail Station Occupation
Pos

Value

Meaning

1-2

32

Record Type Identification

4-11

Occupied Station Name

13-16

Instrument Height in millimeters

Detail Reference Observation
Pos
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1-2

32

Record Type Identification

4-11

Target Station Name

13-16

Reference Station Height in millimeters

Detail Observation
Pos

Value

Meaning

1

4

Record Type Identification

2

Line Connection Tag
0

Straight

1

Arc

2

Curve

3

Duplicate

4

Link

5

Discontinuous Straight

6

Discontinuous Curve

7

Link with Curve

8

Gap in Curve

9

End String

4-6

String Number
0

Point Feature

1-999

String Feature

8-10

Point Number, position of point
within the string

12-15

Feature Name, used in conjunction
with Feature Library to determine
other attributes

17-20

Offset Value in millimeters

22

Offset Type
1

Forward Along the Line of Sight

2

Backward Along the Line of Sight

3

Left from the Line of Sight

4

Right from the Line of Sight

5

Extension to the Line in the direction of
the String

6

Start Free Interpolation for Taped
Measurement

7

Change Default Rod Height
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8

Lateral Offset Left for Taped
Measurement

9

Lateral Offset Right for Taped
Measurement

30.24 Softdesk Field Book
This option allows you to download detail and traverse data from the Field Book format file,
used by LDD, SoftDesk, and DCA.

30.25 NSS ASCII Export
This option allows the user to download NSS ASCII files.

30.26 Kingsland .OBS format
Support for the Kingsland Surveys .Obs format is based on the format document (Coding.doc)
and sample data files provided (Pound1.obs and Pound2.obs).
These files include control and detail survey information and may be processed in SCC.

30.27 Geodimeter .DEC format
This option allows you to download detail and traverse data from the Geodimeter .DEC format
in use in the Netherlands

30.28 TDS
Tripod Data Systems TDS
TDS Survey tasks supported are detail, traverse and stake out.

Explanation of Topcon TDS field recorded data
At the end of each line of field data there are two minus signs. These are followed by
point codes. These codes comprise of feature, tag and stringing information.
•

A dot indicates that the point is a strung feature. If the dot is omitted the
feature is a discrete point an does not form part of any string.
For example;
SS,OP49,FP1688,AR263.3840,ZE86.1410,SD39.255,--.TB3
Defines string number 3 with feature TB (Top of Bank)

11

defines a curved point it may or may not be on a string , depending on
whether or not there is a dot in front of it.
For example;
SS,OP83,FP1671,AR185.0005,ZE90.0650,SD373.650,--.11EP1
Defines a curve of feature EP (Edge of Pavement) on string number 1
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22

Defines the END of a string.
For example;
SS,OP49,FP1744,AR173.4705,ZE90.1100,SD93.230,--.22
Defines the end of the current string

33

Defines a LINK from the last point on a string back to the first point.
For example;
SS,OP49,FP1745,AR175.2925,ZE90.1105,SD94.040,--.33
Defines a link from the current point on the current string to the first point on
that string

Features may be represented on more than one string. For example a point at the edge
of footpath where the footpath and the grass verge meet may be a point on the string
defining the grass verge and on the string defining the footpath.
For further information on the structure of native Topcon files consult your Topcon FS/2
manual.

30.29 Trimble CST
This option supports Lat/Long/Height values and reduces them using either Grid Inquest or
SCC 7 parameter transformation functionality.

30.30 Trimble SCS900

30.31 STAR*NET

31

Spreadsheets

31.1

Editing Spreadsheets
SCC incorporates a powerful data editor for the purpose of editing your surveys. This editor
operates in a similar manner to a spreadsheet in that it is aware of the type of information
stored in each field. As such every field available is validated as it is entered. Tasks such as
search and replace, global editing and limited arithmetic operations are available within the
editor.
The user may move around the editor using the cursor keys or mouse. To change the value of
any given field simply move the cursor to that field and enter a new value, clicking the right
mouse button gives a list of all the options for that field or produces an Edit field dialog. The
following keys may also be used within the data editor:
F1

Display a help screen relating to the current dialog

F3

Repeats the last ‘Find’ command
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PgUp

Page up through the editor

PgDn

Page down through the editor

Home

Move to the first field in the record

End

Move to the last field in the record

Delete

Delete the character in front of the cursor in the current field

Back Space

Delete the character at the cursor in the current field

Ctrl-Home

Move to the first record in the field

Ctrl-End

Move to the last record in the field

31.1.1 Mathematical Operations
To enter an arithmetic value for a numeric field rather than an absolute value, type '=' followed
by the mathematical operator, followed by the operand. The following mathematical operators
are available for numeric fields;
+

Add a constant value to the field, e.g. to add 10 to the value of a field,
enter ‘= +10’ in that field

-

Subtract a constant value from the field, e.g. to subtract 10 to the
value of a field, enter ‘= -10’ in that field

*

Multiply the field by a constant value, e.g. to multiply the value of a
field by 10, enter ‘= *10’ in that field

/

Divide the field by a constant value, e.g. to divide the value of a field
by 10, enter ‘= /10’ in that field

^

Raise the field to the power of a constant value, e.g. to square the
value of a field, enter ‘= ^10’ in that field

!

Subtract the field from a constant value, e.g. to subtract the value of
the field from 10, enter ‘= !10’ in that field

>

Clip the field to below a constant value (used in search and replace),
e.g. to set the value of a field to 10 if it is greater than or equal to 10,
enter ‘= >10’ in that field.

<

Clip the field to above a constant value (used in search and replace),
e.g. to set the value of a field to 10 if it is less than or equal to 10,
enter ‘= <10’ in that field.

:

Calculate a gradient value for an angle field, e.g. to enter a gradient of
1 in 10 for a vertical angle, enter ‘=1:10’ in that field.

31.1.2 Sorting Of Data Within Spreadsheets
Each spreadsheet within SCC automatically sorts all the information into an order suitable for
the particular type of data being entered. For example, records within the detail observations
are sorted by point number, whilst detail co-ordinates will always be sorted alphabetically by
feature and then by string number and position etc.
In the description of individual spreadsheets, certain fields will be noted as index fields and
have an index number. For example, the Detail Coordinate spreadsheet is indexed first by
feature name, then by string number, then by string position and then by point number. These
are noted as being index fields 1, 2, 3 and 4 respectively. This means that the detail coordinates spreadsheet is sorted primarily alphabetically by feature name. String number will
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sort records with the same feature. Records with the same feature and string number will be
sorted by string sequence position. Records with the same feature, string number and string
position will be sorted by point number. Hence, changing the value of these fields may be used
to change the position of a point within a string. This is useful if a point may not be observed
on a string because of some temporary obstacle. This point may be observed out of sequence
and by changing the point number, the correct line linkages may be performed.

31.1.3 Globally Edit A Range Of Data (Edit Menu)
This option allows the user to modify the value of a field in the current editor for a range of
records. Selecting this option presents the user with a dialogue containing the following fields;

Field to Modify
This field specifies which field in the spreadsheet will be modified.

New Value for Field
This field contains the new value that will be stored in the selected field for the selected
record range. This value may include mathematical operators and conversion suffixes
where required.

Record Range
From
This field contains the record number, as displayed in the title of the first record that will be
modified. Note that the record number will generally NOT be the same as the survey point
number. See the replace option for more flexible global editing.

To
This field contains the record number, as displayed in the title of the last record that will be
modified. Note that the record number will generally NOT be the same as the survey point
number. See the replace option for more flexible global editing.

Shortcuts
Toolbar

31.1.4 Find (Edit Menu)
This option allows the user to search a range of records for a field value that lies within a
specified range of values.
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Field to search
This field specifies which field in the spreadsheet is to be searched.

Range of values
Lower limit
This field contains the lowest value of the selected field that will be used for the search
and replace function.

Upper limit
This field contains the highest value of the selected field that will be used for the search
and replace function.

Record Range
From
This field contains the record number, as displayed in the title of the first record that will be
modified. Note that the record number will generally NOT be the same as the survey point
number. See the replace option for more flexible global editing.

To
This field contains the record number, as displayed in the title of the last record that will be
modified. Note that the record number will generally NOT be the same as the survey point
number. See the replace option for more flexible global editing.
number will generally NOT be the same as the survey point number. See the replace
option for more flexible global editing.

Shortcuts
Toolbar

Keys

Ctrl + F

31.1.5 Replace (Edit Menu)
This option allows the user to modify the value of a field for a range of records in the editor that
have a specified range of values in another field. Selecting this option presents you with a
dialogue containing the following fields;
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Selecting this option presents you with a dialogue containing the following fields;

Search parameters
Field to search
This field specifies which field in the spreadsheet is to be searched.

Lower limit
This field contains the lowest value of the selected field that will be used for the search
and replace function

Upper limit
This field contains the highest value of the selected field that will be used for the search
and replace function

Replacement parameters
Field to modify
This field specifies which field in the spreadsheet will be modified.

New value
This field contains the new value that will be stored in the selected field for the selected
record range. This value may include mathematical operators and conversion suffixes
where required.

Record Range
From
This field contains the record number, as displayed in the title of the first record that will be
modified. .

To
This field contains the record number, as displayed in the title of the last record that will be
modified.

Using the Replace facility
The global editor and search and replace facility may be used in each of the
spreadsheets. The possible applications of them are endless, but the examples below
provide an indication of how the replace facilities can be used to manipulate your survey
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data:
Example 1

Exclude a range of levels from the terrain model

Example 2

Correcting a rod-height error.

Example 3

Globally change feature names

Example 1: Exclude a range of levels from the terrain model
Use the replace facility to search the co-ordinate file for a range of levels and on the basis
of this change the DTM code to IGNORE. This option might be used to globally remove
unsuitable levels from the terrain model. This may often be the case where data has been
provided by a third party and perhaps not expressly for the purposes to hand.
From the SCC Main Menu, select 'VIEW > Detail Co-ordinate' spreadsheet
Select 'EDIT > Replace'

Example 2: Correcting a rod-height error.
Use the replace facility to search the observation file for a given station set-up number and
on the basis of this add half-a-meter to the rod height. This may be used to correct a rod
height error, which occurred at a particular station.
From the SCC Main Menu, select 'VIEW > Detail Observations' spreadsheet
Select 'EDIT > Replace'

Example 3. Globally change feature names.
Use the search and replace facility to change all feature names in the range T to TRZZ to
the name TREE. This particular example can be adapted to change the feature names
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used by another surveying practice to match your own naming convention.
From the SCC Main Menu, select 'VIEW > Detail Co-ordinate' spreadsheet
Select 'EDIT > Replace'

Note: Feature Names are case-sensitive.

Shortcuts
Toolbar

31.1.6 Insert Records (Edit Menu)
This option inserts a number of blank records into the data sheet.

Selecting this option presents you with a dialogue containing the following fields;

Insert after record
This field specifies the spreadsheet record number after which the new records will be
inserted.

Number of records
This specifies the number of new records that will be inserted into the spreadsheet.

Blank new records
This field specifies whether or not the inserted records will be copies of the previous
record or whether they will have the default string, position, tag, entries etc.
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Shortcuts
Toolbar

31.2

Reports (File Menu)
SCC produces high quality reports from all SCC documents using the industry acclaimed
Crystal reports engine. Reports have been added for editing log files, that include filters for
currently open documents only, and last selected menu option only. These reports can include
data, charts, bitmaps and other rich content, and can be output to printers, PDF, Excel, HTML
and Word files.
Reporting options also allow that where a new default report is selected for any given activity, it
becomes the new default for that activity.
Sample reports are available within the SCC directory.

See Also
Reports Within SCC

31.3

Project Spreedsheets

31.3.1 Station Co-ordinates
The station co-ordinates spreadsheet is used to store all the station co-ordinates for a
given SCC project. Individual traverse data sets will read fixed co-ordinates and write
adjusted co-ordinates to this sheet. The instrument set-up sheet will refer to co-ordinates
stored in this sheet for purposes of orientation and position when calculating detail coordinates from polar co-ordinates (Ha, Va, Slope Distance). Station co-ordinates may also
be read directly from certain data loggers or entered manually from the keyboard.

Whenever a data logger transfer or survey computation attempts to change the value of
an existing station co-ordinate, a check will be made for the differences between the new
value and the existing value. If a difference of more than 1mm in any axis occurs a
message will be presented asking you to keep the existing value or to overwrite it with the
new value.
At this stage you will be offered a choice to keep the existing value or the new value. If
either value is less than or equal to zero in the x or y axis it will automatically get rejected
with no message displayed. This message will also get output to the current log file.
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Name
This field contains the name of the Control Co-ordinate being edited. This will be the
station name entered or co-ordinate name from the datalogger.

Feature
Eight character field contains the name of the feature being edited

X, Y Type / Z Type
This field specifies whether traverse adjustment or other calculations may modify the coordinates of this station: Free, Fixed, Constrained, Provisional, Prov. Trig, Prov. Resect,
Prov. Intersect, Adjusted.

Fixed co-ordinates may not be modified and may be used to constrain least squares
network adjustment, i.e. 'Variation of co-ordinate' Adjustments applied in the traverse data
sheet. In a Bowditch Adjustment, fixed co-ordinates may only be used for opening and
closing stations. A station co-ordinate may be fixed in all dimensions (Fixed), fixed in plan
only (Fixed X, Y), or not fixed at all (Free).

Source
This field specifies how the co-ordinate for the current station was established.

There are four options:
Traverse

Taken from the Traverse Module

Detail

A Fly Station

Manual

Manually entered (typed) in from the Keyboard

Control

Taken from the Logger

-E/XThis field contains the co-ordinated X value or Easting for the current point in the file.

-N/YThis field contains the co-ordinated Y value or Northting for the current point in the file.
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-Ht/ZThis field contains the co-ordinated Z value or Elevation for the current point in the file.

Remark
This field contains a free from remark entered in the data logger for this observation.

Use
This field contains a counter to indicate how many times this station was accessed in the
last model created. It is used internally by the software when computing traverse
adjustments and creating models.

31.3.2 Project File Menu

31.3.2.1 Export (Project File Menu)
The following options are available from the project export options:
Export Stations as dataset (File Menu)
Export Comma Separated File (File Menu)
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Export Fixed format ASCII File (File Menu)
Export Automated Demarcation Certificate (File Menu)
Export Create a file CRC report (File Menu)

See Also
Import & Export

31.3.2.2 XML (Project File Menu)
SCC supports loading and saving of all of its document files in the industry standard XML
format, in addition to its native formats. XML (extensible mark-up language) is an ASCII
format widely used in Internet and database applications for the exchange and archiving
of data. XML has the advantage that it may be used to import SCC data from SCC into
other programs and between versions. It has the disadvantages that it is slow and
memory intensive to work with, and produces substantially larger files than native SCC
formats. For transferring SCC data between SCC and other LandXML capable
applications.

See Also
LandXML (Project File Menu)
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31.3.2.3 Import (Project File Menu)
The following import options are available:

See Also
Import & Export
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31.3.2.4 Upload Set-out (Project File Menu)
This option facilities the uploading of specific set out files to survey unit.

See Also
Import & Export

31.3.2.5 Co-ordinate Reduction Options (Project File Menu)
This option allows the user to edit configurable parameters relevant to the generation of
the detail co-ordinate information. These parameters are used when creating detail coordinates from the detail observation spread sheet. These comprise of Apply Curvature
and Refraction, Standard value for 'k', Radius of the Earth, Apply temperature and
pressure. A full list of survey reduction parameters is as follows;
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Curve Fitting
This switch defines whether extra curve points are generated in between surveyed curve
points. Surveyed curves are generated by using the curve tag codes. The type of curves
used is 'Splines under tension'. Curve generation parameters may be further defined by
tension and point density parameters. Points used to define curves should be surveyed at
even intervals apart. The number of points required for accurate delineation of a curve
depends on the accuracy requirements. As a guide on tight curves on road belmouths,
points for engineering accuracy requirements may be as close as 1 -2 meters - very tight
curves on traffic islands may be at 0.1 to 0.2 meters centres depending on the tightness of
the curve - main highway curves may be as far apart as 10 to 20 meter centres depending
again on requirements.

No Curve Fitting
Points surveyed as curves are treated as straights. No extra points are generated for
curve fitting.

Treat Arcs as Curves
All Arcs in the Detail Observation file are treated as curves in the detail coordinate file.

Process Arcs and Curves
Arcs and curves are processed as they appear in the detail observation file. That is, arcs
are processed as arcs and curves are processed as curves.

Curve Point Density
This value defines the number extra curve points generated in between surveyed curve
points. The final curve will be created as a set of straights joining these points.
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Curve Spline Tension
This value defines the tension of curves created. The value range between 0.0 and 0.1,
where 0.0 connects the surveyed points by a straight line. The curve fitting honors the
points surveyed to define the curves by passing through these points. The tension either
flattens or permits the curve to billow between these points.

Curve Tangent Weight
This value determines the effects of incoming tangents on curves produced. The larger
the value, the higher the influence of the incoming and outgoing straight line on the curve
produced. Typically, this value should be similar to the length of the surveyed curve
segments.

Default Curve Type
T-Spline (More Circular)
A trigonometric spline curve will be fit through the survey points. This curve is suitable for
more circular features that are not true circles. A T-Spline curve through an equilateral
triangle will result in a circle. When collecting points on this type of curve, it helps if they
are reasonably evenly spaced. Failure to do so may result in a curve that billows away
from the surveyed line.

Catmull-Rom (Tighter to survey line)
A Catmull-Rom curve will be fit through the survey points. This curve type stays very
close to the survey line and has user definable tension and tangent weights.

Replace Curves with Arcs and Circles
Tolerance
Plane fit elevations
Use mean elevation
Interpolate elevations from obs
The above options control how levels are created for circle fits and arc fit strings. These
are to use a mean level, to drape all points on a best fit plane through the input data, or to
interpolate non-planar levels for each input point based on the input data.
This option when selected will automatically replace open and closed Catmull-Rom curves
with arcs and circles in situations where a best fit arc or circle lies within a given tolerance
of the surveyed curve point, This is to allow SCC surveys to more closely match
LandScape style curve fitting where required. Note that this is not advisable in situations
where high accuracy is required, as the arc or circle is allowed to 'miss' the surveyed
positions by the tolerance given in order to achieve a more aesthetically pleasing result.

Origin Shift
This value, normally 0.0, defines X/Easting, Y/Northing, and Z/Ht offsets that are added to
all co-ordinates when they are being computed.

Exaggeration / Scale
This value, normally 1.0, defines an exaggeration or scale factor that will be applied to
E/X, Y/N and Z/Ht when computing co-ordinates.
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Missing Stations
Coordinate missing stations from (0,0,0)
Warn about missing stations, do not create coordinates
The above options instruct SCC to set Station which are missing coordinates to use 0,0,0
or to warn user of missing station values.

Line of sight offsets
To options are available to facilitate the application of line of sight offsets:
Apply to slope distances or Apply to horizontal distance

Use Of Numbers In Features
Ignore
The numbers in the features entries are not used for stringing but may be used for feature
coding.
For Example, if an oak tree were surveyed as TREE1, the feature name would be TREE1

Use as strings
This option allows the string field to be created from the numeric part of the feature field
as opposed to using the MSMM string field.
For Example, the feature code CH0345 would be converted into feature CH and string 345

Remove from Feature
Any numerics held within a feature code to be removed altogether. The alpha part of the
feature will remain and the current string numbers will also remain.

Parallel Feature Offsets
This switch defines whether or not offsets in the observation file are applied to the coordinate file and if so in which direction they are applied. They may be ignored,
interpolated in the horizontal (X, Y) plane, or interpolated in the vertical (X, Z or Y, Z)
plane. For land survey purposes it is normal to use the horizontal plane whereas for
building facade surveys a vertical plane may be required.

Close Ends On Parallel
Selecting this option will cause parallel copied strings to close back onto the string that
generated them, at the end points. This is useful when using the copy parallel facility to
generate walls and similar features

Use MSMM Coding Conventions
This option is used to specify the convention used for parallel offsets. SCC has previously
followed the Eclipse convention, which was later carried through to the MX Site
Measurement Module (MSMM) remark coding. In this case a left (or negative) offset,
implied that the survey point was on the left of the object being surveyed. The alternative,
and to many people more logical, convention is to say that a left offset implies that the
object is on the surveyors left. This convention is used in MX Survey and other packages.
The former option is default, as it means that those already using parallel offsets do not
have to change anything in the field.
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Create Squares And Rectangles
This switch defines whether squares/rectangles in the observation file will be placed when
the detail co-ordinates are being generated from the raw data file. Squares can be
created either via the square tag code or by linking a two-point string. Rectangles will be
created if a side length is given in the first dimension field.

Resolve MX Partial Coding
This switch defines whether the observation file will be checked for partially coded MX
data within the observation file. The rules used when interpreting partially coded data are
as follows;
· If a feature name is left blank it is assumed to have the same name as the last feature
entered.
· If a feature name is 4 characters long, it is taken as the full MX label and given a string
number of 1.
· If a feature name has less than 4 characters it is allocated the next available string
number for that feature.
· If a feature name begins with the letter P it is given a string number of zero.

Create 'Strip levels'
This switch defines whether strip levels in the observation file will be created during
co-ordination of the raw data file. Strip levels are points that are placed offset to the left
and right and offset by level of a given survey point. An example of this would be where
the centre line of a wall is surveyed and the width and height are entered as the first and
second dimensions respectively. In this case, for each surveyed centre line point taken,
four co-ordinates would be generated for the top-left, top-right, bottom-left, and bottom
right of the wall at that point.

Query file Updates
When data is entered in the observation file, the instrument set-up file, or the feature
library, the corresponding co-ordinate files need to be updated to reflect the changes
made. This may result in loss of any directly entered co-ordinates in those files. This
switch defines whether the user is prompted as to whether this updating should take place
when the system deems that it is required.

Include Construction Points
This switch defines whether survey points used in constructing squares, curves, offsets,
and strip levels will be included in the co-ordinate file. The co-ordinate file will be larger as
a result of doing this.

Include Curves In TIN
This switch dictates whether points interpolated on curves will be included in the TIN
model when it is formed. Setting this option off will significantly decrease the size of TIN
models.

Force string numbers in advanced coding
This options applies the string numbers present in the advanced coding table on
import/download to string information.
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Allow observations between points on two and three point rectangles,
arc and circles
This options allows the user to pick up detail between points on two and three point
rectangles, arc and circles

Load Defaults
This option loads the default coordinate reduction options from the registry into the current
project

Reset Defaults
This option resets the coordinate reduction options to the default values when SCC is first
installed.

Save Defaults
This option saves the coordinate reduction options from the current project to the registry
such that they will be used as default values for any new projects subsequently created.

Enable duplicate tag coding
This option provides for duplicate tag coding.

Concatenation multiple remarks
This option allows concatenation of multiple remarks into a single space remark for
display on sections.
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31.3.3 Project Edit Menu

31.3.3.1 Symbols (Project Edit Menu)
This option allows the user to import, export and delete symbols from the feature library. In
addition, the user can define the symbols insertion points.

Import Symbols from file
The user can import symbols from file by selecting the symbol from the list provided.

Import Symbols from DXF
The user can import symbols from a dxf file.

Export Symbols to file
Symbols can be export to the default project folder. The exported symbols can then be
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imported to another feature library.

Edit Symbol insert point
The user can manually define the insert point of each symbol within the Edit Symbol Insert
Point dialog.

Delete symbols from library
The user can select specific symbols to delete from the feature library.

31.3.3.2 Line Types (Project Edit Menu)
This option allows the user to import, export and delete line types from the feature library.

Import Line Types from File
This option allows the user to import line types from file.

Import Line Types from DXF
This option allows the user to import line types from a DXF file.

Export Line Types to File
Line styles that are present in the feature library can be exported. This option prompt the
user whether an existing line style should be overwritten.

Delete Line Types from library
Specific line types can be deleted from the feature library.

31.3.3.3 Check Survey (Project Edit Menu)
In order to simplify the processing of check surveys, we have added some additional
functionality to SCC to effectively automate the task. The automated processing of the
check survey is carried out in three phases, as follows;
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Comparison of contract survey stations with check survey stations
This assumes that the check survey traverse has been adjusted, the final values of check
stations are available in a given SCC project file, and the final values of the contract
survey stations are available in a separate SCC project file. It also assumes that the
nominal accuracy of the check survey stations is known as a result of the adjustment,
coupled with redundant measurements taken. Given these prerequisites, SCC searches
for stations matched by name, and computes relative and absolute differences between
them, in plan and elevation, referred to in the report as raw errors. The raw errors are
reduced by the nominal accuracy to give corrected errors, which are subsequently
compared to acceptance criteria at 67%, 95% and 99% levels, to determine if the contract
survey stations meet specification. For the survey to meet specification, 67% of the
stations must fall within given absolute and relative error criteria, 95% must fall within a
looser criteria, and 99% must fall within a loosest criteria.

Comparison of discrete topographic detail from contract survey stations
with similar detail in the check survey
A similar process is carried out for all discrete topographic detail features, which are
identified by feature name. This assumes that the check model includes all final reduced
check coordinates. In this case it is assumed that each point in the check survey has
been surveyed twice from different stations, and the distance between the two positions is
used in place of nominal accuracy. The contract survey is searched for points with the
same feature name in a specified search radius, which are used as a basis for
comparison. Acceptability computations are the same as used in the station analysis, with
alternative acceptance parameters.

Comparison of linear detail from contract survey stations with similar
detail in the check survey
In the case of linear features we cannot be sure that the check survey points are
coincident with the contract survey points, so the checking routine cuts a series of cross
sections and uses the chainage, offset and level of the position where the section cuts the
linear feature in place of the surveyed coordinate. In this scenario, for any given cut the
chainages will always agree whereas the offsets and heights are used to determine error.
This is significant, as with offset (e.g. width of carriageway) is of primary interest to the
client. As with the discrete points, it is assumed that the check survey will include each
string twice surveyed from separate stations, as a means of computing the accuracy of
the check survey.
To process the check survey we do the following;
Process the check survey control and models as with any other survey.
Select the ‘Check Survey’ option which will display the following dialog;
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Provide details for check survey project and models, contract survey project and models,
linear and discrete feature names, and acceptance criteria.
This will create a detailed report as shown below which includes a summary and
breakdown for stations and topographic detail. All out of specification items are
highlighted in red.
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In addition to the report, the delivery of the check survey should include check models,
and all survey and traverse observations, as per the contract survey.
If the check survey includes a visual inspection on sight for missing detail, the results of
this inspection should also be included with the check report.
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31.3.3.4 Edit Feature to 3D Model Mapping (Project Edit Menu)
This option allows the user to map specific features to object for use within the 3D Viewer.

31.3.3.5 Edit Section Coding (Project Edit Menu)
This option allows the user to map section codes picked up in the field to a feature and to
dictate whether the code is a surface point or water level.
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31.3.3.6 Edit Extra Title Fields (Project Edit Menu)
This options allows the user to enter additional attribute information specific to the model /
project which will be used to update the attributes set up in a sheet layout or inserted within a
model. For example, Drawing Revision No. or Surveyors Name.

31.3.3.7 Compare Test Results (Project Edit Menu)
This option is used internally by Atlas for large scale regression testing, where all the results
are collated and any differences between versions can be explored in detail. It is not typically of
use to end users.
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31.3.4 Project View Menu

31.3.4.1 Feature Library (Project View menu)

Feature Library
The Feature Library controls most of the translation required when converting surveys into
models, AutoCAD drawings, and MX models. It comprises of a list of feature names,
each of which has a set of user defined characteristics. Each project in SCC has it’s own
feature library. When a model is created from any dataset in the project a copy of the
feature library will be made and saved as part of the model. The ‘Feature’ field indexes
this spreadsheet.

Feature
FeatureWizard
Wizard (Project
(Project Edit
EditMenu)
Menu)
The feature library contains a very large number of fields, approximately four hundred per
feature, that allow for a very fine degree of control on how any given feature is drawn and
annotated. While this allows for a very high degree of field to finish automation, it can be
quite daunting to edit and maintain.
The solution to this dilemma is the ‘Feature Wizard’, which can be accessed using ‘EDIT
> Feature Wizard’ from the feature library spreadsheet.
The SCC feature wizard is an automation tool that helps you generate and maintain
feature libraries. This option is available from the edit menu in the feature library and has
the following features;
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All of the fields for a given feature are displayed in a single dialog, with a preview panel
that shows a sample string or point for that feature, including annotation and symbology.
This preview panel is updated when any field is changed.
Annotators may be positioned interactively with arrow buttons. To turn an annotator on or
off, first select the annotator, e.g. Level, in the text annotation box. Then set the display
value to ‘Yes’ or ‘No’ to turn the annotator on or off respectively. Having done this modify
the alignment, justification, and position as required. Prefixes and suffixes may be also be
added, for example a cover level may be prefixed with CL, and dimensions may be
prefixed with the dimension names such as spread, girth, radius etc…
Feature styles may be saved and re-used. For example, if you set up a manhole with a
circular symbol, and the plot name and cover level to the left of the symbol, you might
save this as a man hole feature style. If you then wish to set-up a similarly drawn feature,
such as a gas valve, you simply re-select the man hole feature style, and the gas valve will
inherit the man holes symbology and annotation settings. The feature style basically
includes everything in the feature record except for the feature name, description, plot
name, layer, and moss label. Feature styles are designed to speed up the feature editing
process, and improve the consistency among similar feature types.
The feature wizard also allows you to create and edit text styles, which consist of font
selection and display attributes, such as italicization, and underlining. Note that while SCC
can use all Windows fonts, many CAD packages are restricted to using TrueType fonts,
which are shown with a ‘TT’ or ‘O’ prefix in the font attributes dialog. For this reason, we
recommend you restrict the fonts you use to commonly use true type fonts.
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GIS
GISData
DataFields
Fields (Project
(Project Edit
EditMenu)
Menu)
SCC allows for an arbitrary number of GIS attributes to be stored against survey observations
and/or model points.

This operates as follows:
· GIS layers can be specified in the feature library and specific GIS data fields can be entered
within the Define attribute dialog. Therefore, any number of fields can be added against any
given GIS layers.
· GIS layers can be imported form ESRI shape files.
· Models including GIS data can be exported to ESRI shape files with both vector and
database information.
· GIS attribute information can be view within the model from 'EDIT > Query & Edit points >
GIS Attribute tab'. This works with any logger that can use advanced coding where there is a
new control code for GIS attributes in this table.
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31.3.4.2 Ground Type Library (Project View Menu)
Accessible from the Project window and the Model window.
The ground type or land use library contains information on the textures applied when
using the 3D viewer.

Name
This field contains the land use name.

Description
This field contains a free form description of the current Land Use type.

Colour
This field contains the colour of the current land use.
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Fill Style
This field contains the style of the texture of the current land use.
This field has 7 options;
Backward Diagonal

Cross Hatch

Diagonal Hatch

Forward Diagonal

Horizontal

Solid

Vertical

Area
This is the plan area under the current ground type. This field is populated after selecting
the 'Areas by Ground Type' option

Slope Area
This is the slope area under the current ground type. This field is populated after selecting
the 'Areas by Ground Type' option

Layer
This field contains the layer on which the current ground type will be stored.

Texture
This field contains the path to the bitmap image, from which the texture is obtained.

Triangles
Display
This field has two options; No or Yes

Model
This field has two options; No or Yes

Contour
This field has two options; No or Yes

Apply
This field has two options; No or Yes

31.3.4.3 Advanced Survey Coding (Project View Menu)

Enhanced Coding
SCC supports SDRmap style enhanced coding extensions in the Leica 1200, Leica GSI
8/16, Trimble/Geodimeter UDS, and GPS X,Y,Z interfaces. These coding extensions
provide the following advantages;
· A single, user defined, field code may be used to control multiple SCC input fields
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including Feature code, tag code, DTM code, string number, and dimensions. For
example, KB might represent a kerb, KBC the start of a curve on a kerb, and KBS the
end of the curve on the kerb. Similarly, KBC1 and KB1 might be used to represent
points on the first kerb string, whereas KBC2 and KB2 might be used to represent
points on the second kerb string, thus allowing two kerb strings to be surveyed
simultaneously without using a separate instrument field for string numbering.
· Field codes may be mapped onto features, as described above, or onto control
functions that do not change the current string details. For example, a code of END or
999 might be used to terminate the current string.
· Multiple field codes may be used in a single instrument field. This can be used to
represent junction points between strings. For example, the code HE,GA,WL could be
used to signify the common junction point between a hedge, gate, and wall.
· This interface can be used in conjunction with the LandScape coding interface to allow
automatic creation of string junctions to be created. For example, the four observations
coded HE, GA, HE, HE would generate six points in SCC, due to the implicit junction
between the hedge and gate. This is provided as mechanism for existing users using
LandScape coding to maintain their existing practices, and is not recommended for new
users.
· The interface also supports parallel features and tape measurements.
The enhanced coding extensions operates by providing an extra table, stored in the
project file, that maps field codes onto feature codes, tag codes, DTM codes, and string
numbers. It can be accessed in the project menu via ‘Import > View SDR translation
table’. This table is made up of the following fields;
Field

Description

Code

The field code typed into the total station or logger

Feature

The SCC feature created by this code

Description

A description of this field code

Type

PC

A point code; This code is used to directly map a field code onto
an SCC feature code, tag code and dtm code. For example,
KBC might be used to generate a feature KB that lies on a curve.
A point is generated in the detail observation file for each point
code in the input file. Thus multiple point codes for a single
observation may be used to generate duplicate points, such as
the junction between a fence and a gate.

CC

A control code; This code is used to perform an operation such
as starting or ending a string, or changing the tag or dtm code. It
does not generate an extra point in the detail observation file.
An example of a control code is END, which may be used to end
the current string.

PCP

A point code with parameter. This is a point code that includes
extra dimensions, which are assumed to be in the subsequent
codes. For example, PTR 5.4 might be used to indicate a tree
with canopy diameter of 5.4. Up to three codes may be used for
values stored in D1, D2 and D3 in SCC.

CCP

A control code with parameter. This is a control code that
requires a parameter in the following field, for example JP 54,
might be used to join this string back to point 54.

Tag

SCC Tag Code

Master

Controls whether the tag code for this code is used
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DTM

SCC DTM Code

Master

Controls whether the dtm code for this code is used

Str

String number for this code

SDR Control This is used to perform operations that are not directly catered for using tag
codes
It can be one of the following:
None

Not used

Start

Start a new string for the current feature

Join to
Point

Join back to a specific point. The next code is used for the point
number

Close

Close the current string back with a link

Close
curve

Close the current string on a curve

Close rect Close the current string to form a rectangle
Rect

Start a two point rectangle, the next code gives the width

Feature
offset

Perform one or more right angle offsets from the current string,
similar to tape measurement. Each subsequent numeric code is
used to generate a right angle offset point from the pervious two
points

Copy
Parallel

The three subsequent codes are used for horizontal offset,
vertical offset, and new string name. If only one or two
subsequent codes are provided, the new string will be given the
name as the current string, i.e. for the second side of a wall or
ditch

Dim 1

Dimension 1

Dim 2

Dimension 2

Dim 3

Dimension 3

Dim 1 & 2 Dimension 1 & 2
Dim 1,2 & Dimension 1, 2 & 3
3
Par Offs
L/R
Par Offs
F/B

Parallel Offset Left/Right

Parallel Offset Forward/Back

LOS Offs
Line Of Sight Offset Left/Right
L/R
LOS Offs
Line Of Sight Offset Forward/Back
F/B
Remark

Remark

Z Offset

Z Offset

Tag

Tag Code
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DTM

DTM

String No. String No.
Copy
Feature

Feature which is being copied parallel

Copy L/R Value which to copy feature Left/Right
Copy U/D Value which to copy feature Up/Down
Tape L/R Tape Offset Left/Right
Tape F/B Tape Offset Forward/Back
Multi
More than 1 remark entry
Remarks
GIS
GIS Attributes which are linked to GIS data fields and GIS
Attributes Attribute tab within the models Query & Edit Tab
PntInFtr

This field controls how an embedded number in the code is treated. This
can be one of three values;
Ignore

The number is not used

Point

The number represents the observations point number

String

The number represents the observations string number, for
example KB05 would indicate the fifth KB string

DIM

The number represents the D1 value for observation

See Also
Leica (1100/1200/Wildsoft/LisCADD)
Leica GSI 8/16
Trimble /Geodimeter UDS
GPS X,Y,Z
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31.3.5 Project Model Menu
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31.3.5.1 Point clouds & LIDAR (Project Model Menu)

LAS File
The LAS file format is a public file format for the interchange of 3-dimensional point cloud data
between data users and developed primarily for exchange of lidar point cloud data. SCC
supports the importing of LAS format data, with options to map colour and intensity to features
and layers.

PTS File
PTS is a Leica proprietary format and does not retain any original scan or registration
information. The PTS format is often used when exporting final registered point clouds that
have been unified in Cyclone. SCC supports the importing of PTS format data, with options to
map colour and intensity to features and layers.

ARC/INFO ASCII grid (LIDAR)
ArcInfo Grid is a raster file format developed by ESRI to contain information about geographic
space in a grid. SCC supports the importing of ARC/INFO ASCII grid files.

Leica MS50
SCC supports the importing of data directly from Leica MS50. On import the user has the
following options:
· Recompute scan position based on stations in SCC project
· Recompute scanner orientation based on station differences
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E57 File
The ASTM E57 Committee on 3D Imaging Systems has developed an open standard for 3D
imaging system data exchange. The E57 File Format for 3D Imaging Data Exchange (E57
format hereafter) is capable of storing point cloud data from laser scanners and other 3D
imaging systems, as well as associated 2D imagery and core meta-data. SCC supports the
modelling of E57 format files.

31.4

Traverse
The traverse document is used to store observations relating to traverse and network
adjustments. Within the Traverse document you can reduce and edit setups, apply relevant
corrections and perform adjustments

31.4.1 Introduction To Traversing
A traverse is the most common method of establishing co-ordinated control for a survey.
Traversing is flexible and well suited to providing control quickly over large areas. It is widely
used because of operational convenience and speed. It is particularly suited to modern Total
Stations.
However, the traverse network is simple and provides little in the way of structural strength to
the geometry. For this reason, other measurements such as "cross-bracing" or GPS
observations should be included in all control traversing. Low order work can dispense with the
extra work and attendant costs. The traverse provides a framework within which all detail
survey points will be co-ordinated. The accuracy of the entire survey is dependent on the
quality of the control traverse.
A traverse connects chains of straight lines with measured lengths and angles. A traverse is
one means of providing 2 or 3 Dimensional control in which position is determined by a
combination of angle and distance measurements between successive lines joining control
stations. SCC allows closed and open traversing with several methods of traverse adjustment
computed. The calculations will generate co-ordinates based on the error adjustment selected
and it is the surveyor’s responsibility to assess the accuracy of the calculated co-ordinates.
In order to compute and adjust a traverse, a method of adjustment must be selected. The
adjustment options are either;

Bowditch Adjustment
The Bowditch adjustment, or compass rule adjustment, is the preferred traditional method
for adjusting a traverse. It operates by calculating an angular and length misclosure for
the traverse and redistributing this misclosure evenly among the traverse legs. The
disadvantages of this method are that cross bracing is not catered for, and that the
traverse must be surveyed in one of five supported configurations.

Variations of Co-ordinates (Least Squares Adjustment)
All survey measurement is subject to error. In the establishment of a 2D or 3D control
network, the basic measurements are angles and distances. It is very important that in
practice, more data is observed than is strictly necessary. This is in order to provide
checks on errors and enable a more statistically viable ‘adjustment’ and strength analysis
to be carried out. The additional or extra data observed is referred to as ‘redundant’
measurements and is necessary to strengthen the overall geometry of the control
network.
Modern instrumentation combined with professional skills enables the capture of the field
data to almost perfect precision and very high accuracy. Therefore, while it is still
necessary to adjust the data to produce a geometrically correct figure, only those methods
of adjustment which produce minimal changes in the observations should be used. Least
Squares adjustment is such a method as it has the advantages of affecting minimal
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changes in the data, whilst still providing a statistically viable method that is universally
applicable to all types of network control.
In surveying literature, the principle of Least Squares is shown derived for observations of
normal distribution and is usually expressed as ‘the most probable value or best linear
unbiased estimate of an observation is the one for which the sum of the squares of
the weighted residuals is a minimum’.
SCC uses a ‘variation of co-ordinates’ method of adjustment, which is a least squares
method using observation equations. There are many reasons for using this method;
1. The technique can be applied to all types of network, that is, triangulation, trilateration
and traversing.
2. It affords a complete strength analysis of the final ‘adjusted’ network.
3. The adjustment allows weights to be assigned to each individual part of every
observation. This allows the surveyor to control the effect that any given observation or
set of observations has on the adjustment, based on external factors such as weather,
calibration of instrument etc.
The procedure involved in the application of the ‘variation of co-ordinates’ method to
network adjustment is as follows;
1. To obtain provisional co-ordinates for each station/control point in the network
2. Using these co-ordinates, included angles and distances of the observed data are then
computed.
3. Formulate observation equations for each and every observation.
4. The corrections are applied and the adjusted co-ordinates now replace the provisional
co-ordinates.
The adjustment employed by SCC independently adjusts X,Y using a 2d adjustment and
levels using a 1D adjustment, such that external height difference observations from
levelling can be used in conjunction with total station observations.

Error Ellipses
The error ellipse may be defined as the ‘confidence limits of a point’, as it indicates the
standard error in the position of the adjusted control point in the network. The bearing of
the semi-major axis is also significant for interpretation purposes in that, if normal to the
direction to the fixed origin of the network, it implies predominant angular error. If the
bearing of the semi-major axis is on the same bearing to the fixed origin the predominant
error is linear. Therefore, the larger the error ellipse, the greater indication of error in the
measurements.

Advantages of Variation of Coordinates Adjustment in comparison to
Bowditch Adjustment
The variation of co-ordinates adjustment has a number of advantages over the Bowditch
adjustment method. These are as follows;
1. The adjustment used is a full network adjustment rather than a simple traverse
adjustment. This allows for a far stronger overall geometry including cross bracing and
shots to external known stations. It also allows a wider range of measurement types
including angle only and fixed bearing observations, and the mixing of direct
observations with resections, intersections, and free stations.
2. The adjustment may be used to simultaneously adjust a number of connected
traverses.
3. The adjustment provides a set of observation residuals as part of its output. These
residuals show how much any given observation would have to be changed as part of
the adjustment. Large residuals indicate an error in the survey and may be used to
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pinpoint that error.
4. The adjustment allows weights to be assigned to each individual part of every
observation. This allows the surveyor to control the effect that any given observation or
set of observations has on the adjustment, based on external factors such as weather,
calibration of instrumentation etc.
5. The adjustment has superior survey error detection capabilities.
6. The adjustment can create provisional coordinates using mixed angles and distances,
angle only resections, distance only resections, and angle only intersections, and works
well with most ad hoc survey methods.
7. Support for fixing of coordinates in plan, elevation or both
8. Support for weighting and fixing for all or part of any observation

Equivalent Linear Accuracy
When adjusting by least squares the traverse report includes an equivalent linear
accuracy figure, to reduce the need for bowditch adjustments. This value is computed by
comparing the average observed distances on each leg with the computed join distances
for each leg, summing the leg lengths and length differences, and computing the ratio
from the result. While this is a comparable figure to a Bowditch linear accuracy, it has the
following notable differences;
1. The linear accuracy reported will typically be less than the Bowditch accuracy for the
same data as it is not affected by compensating errors, for example, a distance that is
too short followed by a distance that is too long in a Bowditch adjustment will tend to
cancel each other out. This will not be the case with the above computation.
2. The linear accuracy on a Bowditch adjustment is given as the total traverse length
divided by the distance of the provisional value of the closing station to the known value
of the closing station. The above figure assumes that each leg is a 'mini-traverse' in
itself with known coordinates for stations at either end of the leg. This means that all
observations, including cross braces and spur stations, are included in the
computation.
3. The equivalent linear accuracy figure will not be valid for networks or traverses that do
not contain either loops, or links between known stations. For open traverses, the value
quoted will be artificially high.
The net effect of the above is that if a client specifies a Bowditch linear accuracy, a
Bowditch adjustment must be carried out. In other cases, it may be advisable to notify the
client that the linear accuracy has been computed as part of a least squares adjustment.
The equivalent linear accuracy computations also reports traverse leg types. These can
be one of fixed, free, or closed, where a fixed leg is based on observations between two
fixed stations, a free leg is a leg that is part of a run that is fixed at one end only, and a
closed leg is a leg that lies on a loop, or on a run between fixed stations. The equivalent
linear accuracy figures are now reported for all observations, all except free legs, and
closed legs only. The computation based only on closed legs gives the best equivalent to
a Bowditch or compass rule style traverse adjustment.

Chi squared test
The least squares adjustment also includes a Chi squared test and standardised residuals
in the report. The Chi squared test is a 'goodness of fit' test based on the computed
reference variance. An adjustment may fail the Chi squared test where large standardised
residuals indicate that the computed model is not in good agreement with the
observations. SCC computes the Chi squared test at a 95% confidence level, such that a
network may fail the test if the result does not fall within the 5% to 95% confidence region.
Failure at the high end of the confidence interval can be indicative of an error in the
computed model, e.g. the residuals were significantly higher than the estimated standard
errors. Failure at the low end of the confidence interval can be indicative of an error in the
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stochastic model, e.g. the residuals were significantly lower or not in good agreement than
the estimated standard errors. Note that passing the Chi squared merely indicates that
the residuals tend to agree with the estimated standard errors, and should be used in
conjunction with reviewing the network geometry, observation residuals, and error ellipses.

No Adjustment/Use Provisional Co-ordinates
Alternatively no adjustment can be selected and SCC will compute the provisional
co-ordinates of the traverse stations and use them for further processing if required.
The accuracy of the traverse is governed largely by the observation and measurement
techniques applied and by the type of equipment used.
The following configurations are the configurations supported by the Bowditch/Compass Rule
adjustment.

Explanation of Traverse Codes

Traverse Reference Codes
ORO

Opening Reference Orientation

OBS

Opening Backsight

OFS

Opening Foresight

BS

Backsight

SS

Sideshot

FS

Foresight
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CBS

Closing Backsight

CFS

Closing Foresight

CRO

Closing Reference Orientation

The above references are traverse activity codes. The instrument is set up at station S1, the
opening reference orientation station X is observed and a backsight observation to S5 and a
foresight observation to S2 are taken. Thus, the ORO station X is a special case of a backsight
station of known orientation, which in this case is external to the traverse.
Each station, S2, S3, S4 and S5 are occupied and the back and foresight observations taken
as usual, with the exception of station S2 which also includes the observations to a loose
station SS1. In this case, station S1 is re-occupied for a second time to give an independent
closing orientation (CRO) back on to station X.

The traverse above shows the opening ORO and traverse backsight is coincident. In this case
the BS and is referred to as the ORO since the leg S1 to S5 has a known orientation. The other
stations are observed as usual and the final set-up is on station S5 where the closing foresight
to S1 is called the closing reference orientation (CRO).
In summary, a backsight of known orientation is the ORO and a foresight of known orientation
is the CRO.
Case 1 - Loop traverse with external RO
Case 2 - Loop traverse with internal RO.
Case 3 - Link traverse.
Case 4 - Loop traverse with one fixed station.
Case 5 - Loop traverse with opening back sight
Case 6 - Open traverse (No adjustment)

31.4.1.1 Case 1 - Loop Traverse With External RO.

Double lines indicated above are separated for diagram purposes and are in fact the same
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observed line.

Set up the instrument at station S1 and observe the reference station, X recording the
angles and distance, then observe station S2 recording the angles and distance. Move to
station S2, observe the previous station (S1) and the forward station (S3). Repeat this for
stations S3, S4 and S5. Finally occupy S1, observe S5, and station X as the closing
orientation for the traverse. This provides the closing reference orientation.
Note: This closed loop traverse has an external reference station (X).
@ STN

To STN

T Code

S1

X

ORO

S1

S2

FS

S2

S1

BS

S2

S3

FS

:

:

:

:

:

:

S1

S5

BS

S1

X

CRO

TCode

Travese Code

ORO

Opening Reference Orientation

FS

Foresight

BS

Backsight

CRO

Closing Reference Orientation

31.4.1.2 Case 2 - Loop Traverse With Internal RO.

Double lines indicated above are separated for diagram purposes and are in fact the same
observed line.

Set up the instrument at station S1 and observe the reference station S5 recording the
angles and distance, then observe station S2 recording the angles and distance. Move to
station S2, observe the previous station S1 and the forward station S3. Repeat this for
stations S3 and S4. Finally occupy S5 and observe S4 and S1 as the closing orientation
for the traverse.
Note: This closed loop traverse has an internal reference station S5.
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@ STN

To STN

T Code

S1

S5

ORO

S1

S2

FS

S2

S1

BS

S2

S3

FS

:

:

:

:

:

:

S5

S1

CRO

In this example, the traverse contains two fixed co-ordinated stations.
TCode

Travese Code

ORO

Opening Reference Orientation

FS

Foresight

BS

Backsight

CRO

Closing Reference Orientation

31.4.1.3 Case 3 - Link Traverse.

Double lines indicated above are separated for diagram purposes and are in fact the same
observed line.

Set up the instrument at station S1 and observe the reference station X1, recording the
angles and distance, then observe station S2 recording the angles and distance. Move to
station S2, observe the previous station S1 and the forward station S3. Repeat this
procedure at stations S3 and S4. Finally occupy S5 and observe S4 and Y as the closing
orientation for the traverse.
@ STN

To STN

T Code

S1

X1

ORO

S1

S2

FS

S2

S1

BS

S2

S3

FS

:

:

:
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:

:

:

S5

S4

BS

S5

Y

CRO

TCode

Travese Code

ORO

Opening Reference Orientation

FS

Foresight

BS

Backsight

CRO

Closing Reference Orientation

31.4.1.4 Case 4 - Loop Traverse Wth One Fixed Station.

Double lines indicated above are separated for diagram purposes and are in fact the same
observed line.

This traverse type only contains one fixed station S1 and an internal reference orientation
S1 - S5.
The first set-up is on station S1, observing S5 (Free) as the opening orientation of the
traverse. Setup on S2, S3 and S4 and finally on S5, observing station S1 as the closing
reference orientation for the traverse.
@ STN

To STN

T Code

S1

S5

ORO

S1

S2

FS

S2

S1

BS

S2

S3

FS

:

:

:

:

:

:

S5

S4

BS

S5

S1

CRO

TCode

Travese Code

ORO

Opening Reference Orientation

FS

Foresight
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BS

Backsight

CRO

Closing Reference Orientation

31.4.1.5 Case 5 - Loop Traverse With Opening Back Sight

Double lines indicated above are separated for diagram purposes and are in fact the same
observed line.

Setup on S1, the opening station set-up, and observe station X as the opening reference
orientation, then observe station S5 for the opening backsight and finally S2 as the Fore
Sight. Setup on S2, S3 and S4 and finally on S5, observing station S1 as the closing
reference orientation (Fixed) for the traverse.
@ STN

To STN

T Code

S1

X

ORO

S1

S5

OBS

S1

S2

FS

S2

S1

BS

S2

S3

FS

:

:

:

:

:

:

S5

S4

BS

S5

S1

CRO

TCode

Travese Code

ORO

Opening Reference Orientation

FS

Foresight

BS

Backsight

CRO

Closing Reference Orientation
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31.4.1.6 Case 6 - Open Traverse (No Adjustment)

Double lines indicated above are separated for diagram purposes and are in fact the same
observed line.

Setup on station S1 and observe the opening reference station X recording the angles and
distance. Observe station S2, recording the angles and distance. Setup on station S2,
observe the previous station S1 and the forward station S3. Setup on S3, S4 and S5 and
repeat this procedure.
@ STN

To STN

T Code

S1

X

ORO

S1

S2

FS

S2

S1

BS

:

:

:

:

:

:

S4

S3

BS

S4

S5Y

FS (End)

TCode

Travese Code

ORO

Opening Reference Orientation

FS

Foresight

BS

Backsight

CRO

Closing Reference Orientation

31.4.2 Traverse Co-ordinates

31.4.2.1 Traverse Co-ordinates (View Menu)
The traverse co-ordinate spreadsheet contains a list of provisional co-ordinates, adjusted coordinates, and adjustments applied for every station in the traverse. The traverse co-ordinates
spreadsheet is stored as part of the traverse file.
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The traverse co-ordinate spreadsheet contains the following fields;

Name
This field contains the name of the Control Co-ordinate being edited. This will be the
station name entered or co-ordinate name from the datalogger.

Code
This field specifies the method by which this point on the traverse are computed.

-Prov E/XThis field contains the provisional Easting or X co-ordinate for the current point in the file.

-Prov N/YThis field contains the provisional Northing or Y co-ordinate for the current point in the file.

-Prov Ht/ZThis field contains the provisional Level or Z co-ordinate for the current point in the file.

-Adj E/XThis field contains the adjusted Easting or X co-ordinate for the current point in the file.

-Adj N/YThis field contains the adjusted Northing or Y co-ordinate for the current point in the file.

-Adj Ht/ZThis field contains the adjusted Level or Z co-ordinate for the current point in the file.

-Corr E/XThis field contains the correction to the Easting or X co-ordinate for the current point in the
file.

-Corr N/YThis field contains the correction to the Northing or Y co-ordinate for the current point in
the file.

-Corr Ht/ZThis field contains the correction to the Level or Z co-ordinate for the current point in the
file.

©2015 Atlas Computers Ltd

698

Stn No
This field contains the station number for this point. The station number is used internally
by the least squares adjustment routines. In all other cases, stations are referred to by
name rather than number.

Remark
This field contains a free from remark entered in the data logger for this observation

31.4.3 Traverse Observations

31.4.3.1 Traverse Observations (View Menu)
Set-up number, round number, and code sorts traverse observations. The structure of the
traverse spreadsheet and supporting computations allows for calculation of both traverses and
networks. The ‘Set-up’ and then the ‘Round’ index this spreadsheet. The traverse
observations spreadsheet is stored as part of the traverse file.

Each spreadsheet is comprised of the following record fields;

Set-up
This field contains the station set-up number for the current observation. All observations
sighted from the same occupation of any given station will have the same set-up number.
This value is used to sort the traverse observations. The software will normally
automatically set the value in this field. The 'Check traverse route' option may be used to
fill in values for this field for the entire traverse. This option is found in the 'FILE' menu.
Index 1

Round
This field contains the round or arc number for the current observation. All observations
taken to the same backsight or RO station within a set-up should have the same round
number. This field is used to facilitate changing the value of the zero of the horizontal
circle between multiple rounds of observations within a given instrument set-up. It is used
to sort data within a set-up. The software will normally automatically set the value in this
field. The 'Check Traverse Route' option may be used to fill in values for this field for the
entire traverse. This option is found in the 'FILE' menu.
Index 2

At Stn
This field contains the name of the current occupied station. The co-ordinate value for this
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point may be found in the station co-ordinate spreadsheet.

To Stn
This field contains the name of the current station observed from the occupied base
station. The co-ordinate value for this point may be found in the station co-ordinate
spreadsheet

Code
This field specifies the relevance of this point to the traverse. Traverse codes are sorted,
within a round, such that the RO and back sight will always occur at the start of the round
and fore sights will occur at the end of the round. Fore sight and side shot angles are
always computed as the included angle between the fore sight or side shot angle and the
back sight or RO angle from the same round and set-up. The 'Check Traverse Route'
option may be used to fill in values for this field for the entire traverse. This option is found
in the 'FILE' menu.
Index 3
There are nine possible parameters;
Opening Ref. Obs., Opening Back
Sight, Opening Fore Sight, Back
Sight, Side Shot, Fore Sight, Closing
Back Sight, Closing Fore Sight,
Closing Ref. Obs..

Use Obs
This field may be used to exclude observations from the adjustment.

Inst HtThis field contains the instrument height as entered in the field. It is used when calculating
station elevations.

-Rod HtThis field contains the rod height entered for the current station observation. It is used in
conjunction with the instrument height and the derived height difference (Ht Diff) between
the instrument collimation and the tilting axis of the prism to check the height difference
between the occupied station and the reference station from that computed from the
control station elevations.

-HAThis field contains the observed horizontal angle for the current observation.

-ErrThis field contains the accuracy of the horizontal angle for the current point in the file. For
example, a value of 3 would indicate that the theodolite is accurate to plus or minus 3
seconds in the horizontal. The instrument manufacturer (DIN 18723) normally defines
this. This value is only used when applying a least squares adjustment. This value is only
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used when applying a least squares adjustment. An entry in this field over-rides the value
in the error field in the Least Squares adjustment dialog.

-VAThis field contains the observed vertical/zenith angle for the current observation.

-ErrThis field contains the accuracy of the observed vertical/zenith angle for the current point
in the file. For example, a value of 3 would indicate that the theodolite is accurate to plus
or minus 3 seconds in the vertical. The instrument manufacturer (DIN 18723) normally
defines this. This value is only used when applying a least squares adjustment. This
value is only used when applying a least squares adjustment. An entry in this field
over-rides the value in the error field in the Least Squares adjustment dialog.

-Sl DistThis field contains the slope distance for the current observation.

-ErrThis field contains the accuracy of the slope distance for the current point in the file in
millimeters. See also the help on parts per million error. For example, a value of 3 would
indicate that the EDM is accurate to plus or minus 3 millimeters for this reading. The
instrument manufacturer (DIN 18723) normally defines this. This value is only used when
applying a least squares adjustment. This value is only used when applying a least
squares adjustment. An entry in this field over-rides the value in the error field in the
Least Squares adjustment dialog.

-PPMThis field contains the accuracy of the slope distance for the current point in the file in
terms of parts per million of the slope distance. It is applied as well as the normal
distance error. For example, given a value of 3 in this field, a slope distance of 1000.0m
(i.e. 1 Million mm), and a value of 2 in the 'Dist Err' field would indicate that the slope
distance is accurate to plus or minus 5 millimeters overall, for this reading. This value is
only used when applying a least squares adjustment. This value is only used when
applying a least squares adjustment. An entry in this field over-rides the value in the error
field in the Least Squares adjustment dialog.

Remark
This is the free form remark entered in the logger.

Bearing
This field contains the whole circle bearing for the current observation. This value is
computed from the orientation and the horizontal angle. It is provided for reference
purposes only.

-Hor DistThis field contains the horizontal distance, computed from the slope distance and the
zenith angle, for the current point in the file. It is provided for reference purposes only.

-Ht DiffThis field contains the height difference, computed from the slope distance and the zenith
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angle, for the current point in the file. It is provided for reference purposes only.

-AngleThis field contains the forward measured clockwise angle for the current station in the file.
It is computed as the angle contained between the ORO/backsight station and the current
side shot or foresight station targets. This field is blank for a back sight observation
record. It is provided for reference purposes only.

From
This field contains the name of the back sight station for this record. Its co-ordinate value
may be found in the control file. This field is the same as the To Stn field for a back sight
observation record.

Obs. Type
This field specifies the type of information stored in this traverse observation. This field is
only used with variation of co-ordinates adjustment. Use this field to limit the use of a
given observation to a particular component, such as angle only, bearing only, bearing and
distance, etc... or to fix part of an observation. This may be used to include fixed
bearings, angles, distances, and height differences into the adjustment. For intersection
based networks, the observation type can be set to angle only, or angle and height
difference.

-rAThis field contains the residual angle generated by the least squares adjustment for this
point, i.e. the number of seconds of arc that the observed angle would have to be changed
in order to point to the adjusted result. This field is only relevant to angular measurements
after a least squares adjustment has been completed. This residual is back-computed
and presents the surveyor with the alteration of the field measured values in order to give
an appreciation of the impact of the adjustment in measurement units. It is provided for
reference purposes only.

-rDThis field contains the residual distance generated by the least squares adjustment for this
point, i.e. the number of millimeters that the observed horizontal distance would have to
be changed in order to give the adjusted result. This field is only relevant to distance
measurements after a least squares adjustment has been completed. This residual is
back-computed and presents the surveyor with the alteration of the field measured values
in order to give an appreciation of the impact of the adjustment in measurement units. It is
provided for reference purposes only.

-rBThis field contains the residual bearing generated by the least squares adjustment for this
point, i.e. the number of seconds of arc that the observed bearing would have to be
changed in order to point to the adjusted result. This field is only relevant to bearing
measurements after a least squares adjustment has been completed. It is provided for
reference purposes only.

BS 'k'
This field contains the refraction correction constant 'k' that has been computed locally for
this set-up from the backsight observation. This is used in conjunction with the foresight
'k' to form a mean value of 'k' for this set-up.
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FS 'k'
This field contains the refraction correction constant 'k' that has been computed locally for
this set-up from the foresight observation. This is used in conjunction with the backsight
'k' to form a mean value of 'k' for this set-up.

Mean 'k'
This field contains the refraction correction constant 'k' that has been computed for this
set-up from the foresight and backsight 'k' values. This value is computed from the
difference in height difference between the backsight and foresight stations. Refraction
correction may then be used to improve the accuracy of side-shots via trigonometric
levelling.

Scale
This field contains the PPM distance scale factor computed from temperature and
pressure entered at time of survey. This value will not by default be applied as the
instrument normally applies it.
To apply this value select the ‘Corrections' menu. It is calculated as -

ppm=275 - 79.55 x (p / (273 + t))
where

p = pressure
t = temperature

Temperature
This field contains the temperature, in degrees centigrade, measured at time of survey. It
is used in calculating atmospheric scale correction.

Pressure
This field contains the pressure, in millibars, measured at time of survey. It is used in
calculating atmospheric scale correction.

Face 2
Used to indicate if an observation was taken on face 2

31.4.3.2 Traverse Observation File Menu

Append
Append AA Traverse
Traverse
This option is used to combine two or more traverses into a single traverse job for the purposes
of adjustment. To do this, open the first traverse, select 'FILE > Append a Traverse', and
highlight one or more traverses to add to the currently open traverse.
SCC automatically renumbers round and set-up numbers for the appended traverse
observations.

Extract
Extract New
New Route
This option may be used to extract a loop or link traverse from a more complex control network,
made up of multiple intersecting traverses or more complex control. To use this option you
must first use the Setup option to specify the opening and closing conditions for your sub©2015 Atlas Computers Ltd
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traverse. SCC will then analyze the control network for all possible routes through your data
from the opening set-up to the closing setup.

See Also
Processing A Complex Traverse

Check
CheckTraverse
Traverse Route (Traverse
(TraverseFile
FileMenu)
Menu)
This function searches the traverse observation file for pairs of matched back-sight (BS) and
foresight (FS) observations. It then sets the codes of these observations to form a route
through the traverse. It also renumbers the rounds, and optionally renumbers the set-ups.
The logic it uses is to set any observations in a given set-up to the next set-up as fore sights
(FS), any observations in a given set-up to the last set-up as back sights (BS), and all other
observations as side shots.

It will also attempt to make sure that every round has a valid back-sight, and that the opening
and closing RO codes are correct for most typical traverse cases.
If the user has a traverse that includes two set-ups at the same occupied station, with one
directly following the other in the input file, the user should NOT renumber the set-ups, as these
will be incorrectly amalgamated into a single setup.

Rebuild
Rebuild Traverse
Traverse From
From Raw
RawSurvey
SurveyFile
File
Selecting this option rebuilds the traverse data for this data set from the original raw data files.
This will undo any editing that you have done on these files.

Edit
EditRaw
Raw Survey
Survey file
file (File
(FileMenu)
Menu)
Selecting this option allows the user to edit the ASCII file that was downloaded and used to
create this file. A backup of this data is made to allow the user to return to the original version
of the raw data. This option is only available for data collectors that transfer data in an ASCII
format. This format will be different for different makes of data collector.

31.4.3.3 Traverse Edit Menu

Set-up
Set-up(Traverse
(Traverse Edit Menu)
Menu)
This allows you to enter details of your opening and closing stations for orientation and
adjustment purposes.

Opening Setup
This option allows the user to enter values for your opening set-up. This includes values
for the initial occupied station and reference orientation station. It is necessary to enter
the opening set-up prior to attempting to adjust the traverse.
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Opening Station
Name

This field contains the name of the station occupied as the origin of the
traverse. If this corresponds to the name of a station in the control file
that point will be used, if it does not, the named point will be added to
the control file.

E/X

Easting grid value of station.

N/Y

Northing grid value of station

Level/Z

Reduced elevation of station.

Reference Object Station
Name

This field contains the name of the station sighted as the opening
reference orientation station. If this corresponds to the name of a
station in the control file, that station’s grid values will be used. If it
does not the manually entered values will be added to the control file.

E/X

Easting grid value of the RO station.

N/Y

Northing grid value of the RO station.

Level/Z

Reduced elevation of the RO station.

Station Type
This field specifies whether the opening station co-ordinates may be held fixed or are
permitted to be changed during the traverse adjustment.

Orientation Method
This field specifies whether the opening orientation is calculated from the occupied station
and the reference orientation station co-ordinates or entered directly as an azimuth.
Enter As A
Bearing

The opening orientation is taken from the typed in bearing.

Calculate from
Coordinates

Use the co-ordinates to compute a bearing for the reference
orientation.

R.O. Stn Type
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This field specifies whether the opening reference object may be moved during the
traverse adjustment.

Opening Orientation
This field contains the whole circle bearing between the opening station and the opening
reference object.

Closing Setup
This option allows the user to enter values for the closing set-up. This includes values for
final occupied station and reference orientation station. It is necessary to enter ther
closing set-up prior to attempting to adjust the traverse.

Closing Station
Name

This field contains the name of the station occupied as the origin of the
traverse. If this corresponds to the name of a station in the control file
that point will be used, if it does not, the named point will be added to
the control file.

E/X

Easting grid value of station.

N/Y

Northing grid value of station

Level/Z

Reduced elevation of station.

Reference Object Station
Name

This field contains the name of the station sighted as the opening
reference orientation station. If this corresponds to the name of a
station in the control file, that station’s grid values will be used. If it
does not the manually entered values will be added to the control file.

E/X

Easting grid value of the RO station.

N/Y

Northing grid value of the RO station.

Level/Z

Reduced elevation of the RO station.

Station Type
This field specifies whether the opening station co-ordinates may be held fixed or are
permitted to be changed during the traverse adjustment.
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Orientation Method
This field specifies whether the opening orientation is calculated from the occupied station
and the reference orientation station co-ordinates or entered directly as an azimuth.
Enter As A
Bearing

The closing orientation is taken from the typed in bearing as the
reference orientation.

Calculate from
Coordinates

Use the co-ordinates to compute a bearing for the reference
orientation.

Computed
Use the backsight as the reference orientation.
Backsight Bearing

R.O. Stn Type
This field specifies whether the opening reference object may be moved during the
traverse adjustment.

Closing Orientation
This field contains the whole circle bearings between the closing station and the reference
object.
When adjusting via least squares, the minimum requirements are to have one fixed station and
one fixed bearing, or two fixed stations. These can be entered into the opening setup. In this
case, set the closing station and closing RO type to free.

Reduce
Reduce(Traverse
(Traverse Edit Menu)
Menu)
This option creates mean observations from sets of observations observed from the same setup to the same target station. This includes conversion of horizontal directions to mean
forward measured angles, reduction of double-faced observations, and meaning or averaging
of multiple values.

This option searches for face left / face right pairs in sequential rounds and averages them
into a single round. Thus if there are four rounds on both faces, then four rounds on face
one will remain, where those represented the average of the two faces.
This option allows for the storage of reduction standard deviations for each round in the
residuals of the reduced observations.
Results can be output to Crystal reports and the user can set tolerances to highlight on the
exported file.

Adjust
Adjust (Traverse
(Traverse Edit
Edit Menu)
Menu)
This option allows the user to adjust the traverse. This is carried out in three steps that are
carried out in sequence on selecting this option.
1. To set your adjustment criteria and perform the adjustment.
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2. To update the station co-ordinate file with the adjusted co-ordinates.
3. To review the adjusted co-ordinates.
On selecting 'EDIT > Adjust' the following options are presented;

Adjustment Method
This field specifies the computations used to adjust the traverse. Bowditch Adjustment is
a more traditional method of adjustment, as such it may prove useful when checking
existing traverses. The MSMM adjusts its traverses using this method. Variation of coordinates is a least-squares adjustment that gives the best possible distribution of errors
and permits the user to influence the results by assigning weights to different readings. It
also allows side shot bracing to be included in the traverse. The final option uses No
adjustment and simply calculates the Provisional co-ordinates.

Least Squares Height Adjustment
No Height Adjustment
The levels of the stations are left unadjusted, adjustment takes place in X,Y only.

Default /Manual Weighting
The levels of the stations are adjusted based on the entered height accuracy and distance
weighting

Distance weighted (mm per KM)
This option allows the user to specify distance weighting in terms of mm per KM, where
entering a value of zero indicates the levels are not weighted by horizontal distances.

Output Report File Name
This is the name of the report file that will be created by the adjustment. The contents of
the report will vary based on the method of adjustment selected. The variation of
co-ordinates adjustment will provide the most detailed report.
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Having adjusted the traverse, the user will be given an option to edit the output report file
with the system editor.

Horizontal Accuracy (secs)
This field contains the default accuracy of the horizontal angle for all points in the file. It is
usually based around the intrinsic accuracy of the instrument and the number of
observations taken for a given final traverse observation. The accuracy may be accepted
as that defined by the instrument manufacturer (DIN 18723) or may be derived by the user
over a period by analysing previous traverses. This value is only used when applying
weights in a least squares adjustment and may be overridden by entering a specific value
in the 'Ha Err' field for any given observation.

Vertical Accuracy (secs)
This field contains the default accuracy of the zenith angle for all points in the file. It is
usually based around the intrinsic accuracy of the instrument and the number of
observations taken for a given final traverse observation. The accuracy may be accepted
as that defined by the instrument manufacturer (DIN 18723) or may be derived by the user
over a period by analysing previous traverses. This value is only used when applying
weights in a least squares adjustment and may be overridden by entering a specific value
in the 'zVa Err' field for any given observation.

Distance Accuracy (mm)
This field contains the default accuracy of the slope distance for all points in the file. It is
usually based around the intrinsic accuracy of the instrument and the number of
observations taken for a given final traverse observation. The accuracy may be accepted
as that defined by the instrument manufacturer (DIN 18723) or may be derived by the user
over a period by baseline calibration. This value is only used when applying weights in a
least squares adjustment and may be overridden by entering a specific value in the 'SlDist
Err' field for any given observation.

Scale Accuracy (ppm)
This field contains the default accuracy of the slope distance in parts per million for all
points in the file. It is usually based around the intrinsic accuracy of the EDM. This value
is only used when applying weights in a least squares adjustment and may be overridden
by entering a specific value in the 'PPM' field for any given observation.

Convergence Tolerance
This value is the maximum shift between any two successive iterations of the adjustment
that must occur for the adjustment to continue. If no stations move by more than this
amount the adjustment is consider complete, if not it will continue until complete or the
maximum number of iterations take place.

Maximum Iterations
This options specifies the number of time the computations/algorithm is run.

Corrections
Corrections (Edit
(Edit Menu)
Menu)
This option allows the user to control how corrections for refraction, earth's curvature, local
scale factor, temperature, and pressure are applied.
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Values for 'k' will be computed in the traverse observation and station set-up files. These
values should be within the following ranges if they are to be used

Refraction, ‘k’ and curvature
This variable determines how corrections due to the curvature of the earth and refraction
‘k’ are applied. Values for 'k' will be computed in the traverse observation and station setup files. These values should be within the following ranges if they are to be used
Distance

'k' Range

50 - 100 meters

> -10 < 'k' < +10

150 - 200 meters

> -5 < 'k' < +5

200 - 300 meters

> -3 < 'k' < +3

>300 meters

> -2 < 'k' < +2

The correction applied is

dZ = ((1-k).(Hd.Hd))/(2.R) OR dVa = ((1-k).Hd/(2.R)
where

dZ : Subtraction from Elevation in meters
dVa : Addition to Zenith Angle in radians
Hd : Horizontal Distance
R : Radius of the Earth

If you were using a correction in which the term (1-k) appears as (1-2k) you should double
the value of 'k' that you were using in order to obtain the same results, e.g. 0.07 -> 0.14.

No Corrections
This should be selected if the data you are using has already been corrected for these
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factors prior to transfer into SCC.

Earth curvature only
A correction for earth curvature only is applied. Refraction is not accounted for.

Earth curvature, standard ‘k’
Corrections are applied for earth curvature and a standard value for refraction ‘k’ is
applied. The standard value for refraction is defined above.
Legal Values

-1000.0000 to 1000.0000

Usual Values

-10.0000 to 10.0000

Default Value

0.14

Earth curvature, calculated ‘k’
Corrections will be applied for earth curvature and refraction ‘k’. The value for ‘k’ will be
calculated from traverse and station set-up observations.

Standard value for 'k'
This value defines a standard value for the refraction constant 'k' that will be used where
refraction correction is required but the values for 'k' computed from traverse and station
set-up observations are not regarded as being suitable.

Radius of the Earth
This value is used when calculating earth curvature and refraction corrections. There are
different accepted values for the radius of the earth based on different ellipsoidal
projection systems. Typical values include 6400000, 6380000, 6375000, and 6370000
meters. This value primarily effects accurate trigonometric levelling.

Local Scale Factor
This variable determines how correction for mapping scale factor is applied. This
correction of important when doing traverse and detail surveys that are to be combined
with existing mapping data, typically Ordnance Survey data. The software allows you to
either nominate a fixed scale factor or derive a local scale factor from your data.
This is calculated as

LSF

=
where

SF0.(1+((Ya2+ Ya.Yb + Yb2)/(6*R2))
LSF : Local Scale Factor
SFO : Transverse Mercator Scale Factor along Central Meridian
Ya : Minimum survey Easting - Easting value from the Central
Meridian
Yb : Maximum survey Easting - Easting value from the Central
Meridian
R : Radius of the Earth

None applied
No local scale factor will be applied to the data.

User defined scale factor
A scale factor defined by the user will be applied to all observations. The user may define
the scale factor by inputting values in the local map scale factor, local scale factor along
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central meridian easting of central meridian.

Transverse Mercator, User defined
A transverse Mercator scale factor defined by the user will be applied to all observations.
The user may define the scale factor by inputting values in the local map scale factor,
local scale factor along central meridian easting of central meridian.

TM, Ireland (Airy Modified)
This is the map projection system used in Ireland. It is a modified version of the Airy
Transverse Mercator projection.

TM England (Airy)
This is the map projection system used in the UK.

ITM, Ireland (GRS80)
This is the map projection system used in Ireland.

Local map scale factor
This value is the local scale factor applied to observed horizontal distances. The value
may either be entered directly or computed by the software. This is determined by the
scale factor/projection selected.

Scale factor along C.M.
This value is the transverse Mercator scale factor along the central meridian. It is used
when computing a value for local map scale factor. This is 1.000035m for Ireland and
0.99960127 for England.

Easting of central meridian
This value is the easting or x value for the central meridian. This is used when computing
local scale factor. Values are 200,000m for Ireland and 400,000m for England.

Minimum Survey Easting
This value is the minimum easting or y value for your current detail or traverse survey.
This is used when computing local scale factor. It is derived from the co-ordinates of
occupied stations in the station co-ordinate file.

Maximum Survey Easting
This value is the maximum easting or x value for your current detail or traverse survey.
This is used when computing local scale factor. It is derived from the co-ordinates of
occupied stations in the station co-ordinate file.

Centring Errors
This option supports the computation of errors due to instrument and target centring. The
options allow the user to control whether centring errors are not computed, computed but
not applied, or computed and applied.
Centring errors are input as mm errors to instrument and target positions, and calculated
as errors in the horizontal angle. These errors will be inversely related to the lengths of the
legs subtended by the included horizontal angle, with the error being larger for shorter
lengths. Where centring errors are applied, it is in addition to standard errors (weights) on
angles, and to a lesser extent on distances and height differences. The net effect of this
is that on traverses or network with shorter leg lengths and centring errors applied, angles
will carry lower weights than distances.
From 'Engineering Surveys' Schofield and Breach, some typical input values for centring
errors are:
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3mm - 5mm for a plumb bob
0.5mm - 1mm for an optical plummet
1mm for a centring rod
0.1mm - 0.3mm for forced centring

Horizontal Angle Correction
This value, normally 000.00.00, defines an angular offset that is applied to all horizontal
angles when computing co-ordinates.

Vertical Angle Correction
This value, normally 000.00.00, defines an angular offset that is applied to all vertical
angles when computing co-ordinates.

Apply Temperature and Pressure
This variable determines whether a scale factor derived from temperature and pressure
will be applied as a correction to your slope distances. This field will normally be set to
'No' as most modern total stations allow you to enter temperature and pressure and
provide corrected readings. Only set this value to 'Yes' if scale factor has not already
been applied to your EDM.
When refraction is being calculated, either in the traverse observations sheet or the detail
station set-up sheet, multiple reference stations may be sighted. In this instance, a
distance weighted mean value is calculated for 'k'.

Mean Sea Level Correction
Mean sea level correction is not applied by default, but can be enabled by selecting this
option. The correction is applied to the horizontal distance as Horizontal Distance x (
Reduced Elevation / Radius of the Earth). See Bannister & Baker, Surveying, ISBN
0-582-23644-4, Page 34

31.5

Detail Observation
The detail observation spreadsheet contains all of the observations in any given survey. Note
that these observations can be total station angles and distances, GPS latitude, longitude,
height, or X, Y, Z.

31.5.1 Detail Observations (View Menu)
The detail observation spreadsheet contains all the topographical survey information as
collected in the field by polar co-ordinate observation. Data is held in raw form, horizontal and
vertical angle, slope distance and the other information that is required to generate map
planimetery and the surface model. The sheet is sorted by survey point number (Index 1) and
as such records are presented in the original chronological survey order.
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The detail observation sheet comprises of the following fields;

No.
This field contains the original survey point number.

Str
This field contains the string number of the surveyed point. The string number allows
separate strung features of the same name to be distinguished from one another. Points
in the detail co-ordinate file are ordered by Feature Name, String Number, Position and
surveyed Point Number.

Feature
This eight-character field contains the name of the Feature being entered as entered in
the data collector.

Stn
This field contains the station set-up number for this point. This corresponds with a
station set-up number in a record in instrument set-up spreadsheet. This record contains
information relating to the occupied and reference station used when this point was
observed, along with the atmospheric conditions.

Tag Codes
The tag code determines the connective geometry and specifies how the current point on
the string will be connected to the next point on the string. This can be used to specify
straight lines, curves, arcs, and squared up pieces of geometry in a string. The tag codes
may be entered either in numeric or alpha-numeric format.

See Also
Feature Library (View menu)
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DTM Code
The DTM (Digital Terrain Model) status code determines the significance of the point of
the surface model / digital terrain model being generated. The DTM codes may be
entered either in numeric or alpha-numeric format

See Also
Feature Library (View menu)

-Rod HtThis field contains the observed prism rod height for the current points in the file.

-HAThis field contains the observed clockwise horizontal angle for the current point in the file.
To convert an angel between clockwise and anticlockwise enter a value of '=!360' either in
the spread sheet or global editor.

-zVAThis field contains the observed vertical/zenith angle for the current point in the file.

-Sl DistThis field contains the observed slope distance for the current point in the file.

Offset
Every observation in SCC can include up to five offsets as follows:

Line of Sight Offsets Left or Right (LOfs L/R)
This is an offset based on the line connecting the Total Station to the prism. The
offset is lateral, with a negative value indicating a distance to the left of the surveyed
line, or positive indicating a distance to the right of the surveyed line.

Line of Sight Offsets Forward or Back (LOfs F/B)
This is an offset based on the line connecting the Total Station to the prism. The
offset is longitudinal, with a negative value indicating a distance towards the
instrument, or positive indicating towards the prism. This corresponds to a radial
offset, and might be used for tree trunks etc.

Line of Travel Offsets Left or Right (POfs L/R)
This is an offset based on the line connecting the last two survey points. The offset
is lateral, with a negative value indicating a distance to the left of the surveyed line, or
positive indicating a distance to the right of the surveyed line. It is used where it may
be difficult to get to the centre of a wide linear object such as a hedge or ditch, where
the feature coding does not explicitly specify that the face of the object is being
surveyed.

Line of Travel Offsets Forward or Back (POfs F/B)
This is an offset based on the line connecting the last two survey points. The offset
is longitudinal, with a negative value indicating a distance back along thesurveyed
line, or positive indicating an extension of the surveyed line. It is used where a point
may be obscured from the instrument view. such as an internal building corner, and
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that point can be generated by extending from the last two survey points.

Height Offset (Ht/Z Ofs)
This is a simple offset to the Z value, with negative indicating a distance down, and
positive indicating a distance up.

D(1)
This field contains the first dimension for the current point. If this value is non-zero it is
used as a scale factor for primary symbols. It is also used as a width on strip levels/
parallel features such as walls, ditches etc. See diagram below.

D(2)
This field contains the second dimension for the current point. If this value is non-zero it is
used as a scale factor for secondary symbols. It is also used as a width on strip levels/
parallel features such as walls, ditches etc. See diagram above.

D(3)
This field contains the third dimension for the current point. It is also used as a width on
strip levels/parallel features such as walls, ditches etc. If a value is not entered into this
field it is assumed to be same as D(1). See diagram above .

MX Attr.
This switch defines whether or not there is an attribute associated with this observation.
To view the attributes/extra measurements select 'VIEW > Extra Measurements' . There
are three options; No, Yes or Construction Point

Obs.
This field contains observation or survey numbers, it is used to link the measurement to a
given observation or string.
Observations numbers are assigned to survey points in original chronological survey
order.

Time
This field can be used to store the exact time at which the current observation was taken
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X, Y, Z
The detail observation file also allows use of X,Y,Z coordinates as a form of raw data.
These will be used in the absence of a valid slope distance or lat/long coordinates.

Lat, Long, Height
The detail observation file allows the user to enter and log observations from GPS in
WGS84 latitude, longitude, and height. These will be converted into coordinates based on
the settings of the GPS transformation options. If an observation contains a non-zero
slope distance, its coordinates will be calculated using angles and distances, regardless of
the values in these fields.

XRMS, YRMS, ZRMS
The root mean square variation of position between successive epochs for a given
observation

H. DOP, V. DOP
Horizontal and vertical dilution of precision

No. Sats
The number of satellites that were observed when this observation was taken

Fix
Solution type
Whether the RTK solution was fixed, floating or autonomous. For
survey work this should nearly always be fixed.

31.5.2 Extra Measurements (View Menu)
Attributes/Extra Measurements are additional measurements, which use the polar co-ordinates
taken with the Total Station as the topographic control geometry for field survey completion.
The attribute spreadsheet contains details of the extra measurements taken as part of the
survey. These comprise of taped measurements, square and circular features and strings,
parallel features, and offset measurements. Obs. and No order this spreadsheet respectively.
The extra measurements spreadsheet is stored as part of the survey file. For further details
on the collection of attributes see the MSMM manual.

No.
This field contains the extra measurements record number, it is used to order the
measurements in this file.
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Obs.
This field contains observation or survey numbers, it is used to link the measurement to a
given observation or string.

Type
This field specifies the type of attribute employed for the current record e.g. Feature offset,
taped measurement etc.
There are 13 possible options; Line of Sight, Taped Measure, Feature Offset, MX Check,
Orhto Feature, Radius & Centre, Point & Centre, 2 Pts Circle, 3 Pts Circle, 3 Pts
Rectangle, Change Bearing, Parallel Ftr, Real Co-ordinate.

Obs #1
This field contains the survey point number of the first reference point for the attribute.
For example, the first point on a base line, 3 point circle or rectangle.

Obs #2
This field contains the survey point number of the second reference point for the attribute.
For example, the second point on a base line, 3 point circle or rectangle.

Obs #3
This field contains the detail observation number of the third reference point for the
attribute.
For example, the third point, on a 3 point circle or rectangle.

Offset #1
This field contains the first offset for the attribute.
For example, the distance along a base line for taped measurements.

Offset #2
This field contains the second offset for the attribute.
For example, the distance away from a base line for taped measurements.

Offset #3
This field contains the third offset for the attribute.

Level
This field determines whether the point generated is included or excluded from the
planimetery and surface model. If this is set to 'Real', Offset #3 contains the level of the
point. If the level is set to 'Ignore', then the level of the point is taken from the previous
point.
The field has six possible options; Ignore. No, Real, T. Cons, T. Link or Yes
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Feature
This feature determines whether the data generated by this attribute will be converted into
a string or an object within SCC. Objects are drawn in the model as symbols and have no
effect on the surface model

Name
This field contains the feature name given to this attribute.

31.5.3 Text Notes (View Menu)
This spreadsheet contains E/X, N/Y and rotation information about the remark text coded in the
field. Each entry in the number column is associated with a corresponding number in the detail
observations spreadsheet. The sheet is ordered Number. The text notes spreadsheet is
stored as part of the survey file. The text notes sheet comprises of the following fields;

Number
This field contains the observation number that the text notes is associated with.

Remark
This is the free form remark entered in the logger.

Feature
This is the feature code of the surveyed point. Information relating to this feature in the
feature library is associated with the remark text. Associated information includes colour
and text size.

E/X
This field contains the Easting/X value of the first letter of the text.

N/Y
This field contains the Northing/Y value of the first letter of the text.

Angle
This field specifies the angle that the text notes are to be rotated if displayed in the model.

31.5.4 Detail Observation File Menu
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31.5.4.1 Edit Raw Survey file (File Menu)
Selecting this option allows the user to edit the ASCII file that was downloaded and used to
create this file. A backup of this data is made in order that you may always return to the original
version of the raw data. This option is only available for data collectors that transfer data in an
ASCII format. This format will be different for different makes of data collector.

31.5.4.2 Rebuild Obs From Raw Data (File Menu)
Selecting this option rebuilds all survey data for this data set from the original read only raw
data files. This will undo any editing that the user has carried out. The files affected are Detail
Observation, Instrument Set Up, and Extra Measurements (View Menu) files.

31.5.4.3 Rebuild Co-ordinates (File Menu)
Selecting this option rebuilds all the detail co-ordinates from the current detail observation and
control information. This will undo any editing that the user has carried out on this file. It will
also create any fly stations present in the detail observation file.

31.6

Detail Coordinate
Detail Coordinate Sheet, used to store reduced topographic coordinates, sorted alphabetically
by feature name and string number.

31.6.1 Detail Coordinate (View Menu)
The detail co-ordinates spreadsheet contains the reduced Cartesian co-ordinates for a survey.
These co-ordinates may have been computed from a detail observation spreadsheet or read in
from an external file, such as a DXF or GENIO file. The detail co-ordinates spreadsheet is
sorted differently from the raw detail observation file, which is ordered by point number. The
strings are grouped feature-wise and in numerical string order and appear in their correct order
alphabetically down the sheet. The detail co-ordinates spreadsheet is stored as part of the
survey file.

The detail co-ordinates spreadsheet has the following fields;

No.
This field contains the original survey point number.

Str
This field contains the string number of the surveyed point. The string number allows
separate strung features of the same name to be distinguished from one another. Points
in the detail co-ordinate file are ordered by Feature Name, String Number, Position and
surveyed Point Number
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Pos
This field contains the sequential string position number of the co-ordinated point within a
given string. This means that points that are not surveyed sequentially may be re-ordered
so as to be graphically correct within the model file. The first point taken on FEATURE <Hedge>/STRING # <1> will have a STRING POSITION # <1> on the first hedge, and on
FEATURE - <Hedge>/STRING #<2> will have a STRING POSITION <#1> on the 2nd
hedge - the survey point number is independent and will be related to the number of all
points surveyed in the current data set.

Feature
This eight-character field contains the name of the Feature being entered as entered in
the data collector.

Type
This field specifies the source of the current point. Manual points are points entered by
the user, construction points are points generated by the computer and detail and control
points are generated by the survey datalogger.
Field has 25 possible options; 2 Pts Circle attribute, 3 Pts Circle attribute, 3 Pts Rectangle
attribute, As Set Out Point, Construction, Control, Curve fit, Design, Detail, Draped Profile,
DXF, External file, Feature Offset attribute, GENIO point, Levelled point, Line of Sight
attribute, Manual, Ortho Feature attribute, Parallel Feature attribute, Point & Centre
attribute, Radius & Centre attribute, Square, String, Offset, Strip level, Taped Measure
attribute,

Tag Codes
The tag code determines the connective geometry and specifies how the current point on
the string will be connected to the next point on the string. This can be used to specify
straight lines, curves, arcs, and squared up pieces of geometry in a string. The tag codes
may be entered either in numeric or alpha-numeric format.

See Also
Feature Library (View menu)

DTM Code
The DTM (Digital Terrain Model) status code determines the significance of the point of
the surface model / digital terrain model being generated. The DTM codes may be
entered either in numeric or alpha-numeric format

See Also
Feature Library (View menu)

-E/XThis field contains the co-ordinated X value or Easting for the current point in the file.

-N/YThis field contains the co-ordinated Y value or Northing for the current point in the file.
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-Ht/ZThis field contains the co-ordinated Z value or Elevation for the current point in the file.

D(1)
This field contains the first dimension for the current point. If this value is non-zero it is
used as a scale factor for primary symbols. It is also used as a width on strip levels/
parallel features such as walls, ditches etc. See also Detail Observation.

D(2)
This field contains the second dimension for the current point. If this value is non-zero it is
used as a scale factor for secondary symbols. It is also used as a width on strip levels/
parallel features such as walls, ditches etc. See also Detail Observation.

D(3)
This field contains the third dimension for the current point. It is also used as a width on
strip levels/parallel features such as walls, ditches etc. If a value is not entered into this
field it is assumed to be same as D(1) See also Detail Observation.

Chainage
This field contains the chainage of the current point along the current design string. This
value may be used for reference when setting out via a datalogger. The chainage will only
be set if the co-ordinate file has been created from a file containing relevant design
information, e.g. a MX 992 REPORT file.

Offset
This field contains the offset distance of the current point from the current design string.
This value may be used for reference when setting out via the Site Measurement Module.
The offset will only be set if the co-ordinate file has been created from a file containing
relevant design information, e.g. a MX 992 REPORT file.

Obs.
This field contains observation or survey numbers, it is used to link the measurement to a
given observation or string.
Observations numbers are assigned to survey points in original chronological survey
order.

Group
Each observation is allocated a unique group number. This number is used internally by
SCC.

ID
Each observation is allocated it’s own ID. This number is used internally by SCC to
uniquely identify every point in a model, given that a model can contain two datasets with
the same survey point numbers.

Flags 1 and Flag 2
SCC to preserve annoation flags when transferring data between the model and survey
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data sets uses these values internally.

31.6.1.1 Break Long strings (Coordinate Tools Menu)
This option searches the co-ordinate file for string segment lengths greater than a specified
distance and inserts gaps in the strings at those positions. All points remain on the same
string. This facility is useful to automatically handle certain stringing errors arising due to
survey feature/string number identification errors or importing data without full stringing.
The user can input the maximum length for each string segment:

31.6.1.2 Change X,Y,Z to Y,X,Z (Coordinate Tools Menu)
This option flips the file from being Easting, Northing, Level, or X,Y,Z to Northing, Easting,
Level.

31.6.1.3 Remove Duplicate Points (Coordinate Tools Menu)
This option deletes points in the co-ordinate file that are within a specified plan distance of one
another.
This is useful for minimising the co-ordinate file size and reducing the possibility of duplicate
points appearing in the model. This option is particularly useful on files imported from CAD or
another sources, where the modeller is reporting duplicate points. The option always attempts
to minimise changes to the plan cartography and surface model.
For example, if it finds two points that are on separate strings and both in the DTM, it will
remove one from the DTM rather than deleting it altogether. Selecting this option presents;

The following parameters are available:

Search Tolerance
This field specifies the plan distance below which points are considered to be identical.
Default value: 0.0020

Detailed search
This switch defines which points are checked for distance against the current point. This
can be either every co-ordinate in the sheet, every co-ordinate in the same string, or just
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the co-ordinates immediately behind and ahead of that co-ordinate in the sheet. This
option may be quite slow if every point is being checked against every other point. If a
duplicate point found is a single point and is the same as a point lying on a string, the
single point will be deleted.

Only check DTM points
If this switch is turned on duplicate points will only be removed when both points are in the
DTM.

31.6.1.4 Join adjacent strings (Coordinate Tools Menu)
This option automatically joins adjacent strings to form new continuous strings (polylines). This
is typically used when recreating strings from line segments input from CAD. This operates by
searching for pairs of points that have similar co-ordinate values and feature names but
different string numbers. When such a pair of co-ordinates is found one of the co-ordinates is
deleted and the remainder of the string is renumbered to form and extension of the previous
string. This option will also close strings, using a LINK tag, where the first point is the same as
the last point. Selecting this option presents;

The following parameters are available:

Search tolerance
This field specifies the plan distance below which points are considered to be identical.
Default value: 0.0020

Add string links
If this option is selected any strings with start and end points within the tolerance given will
have their last point deleted and the tag code of their second last point set to link (close
string).

31.6.1.5 Delete ‘Ignored’ points (Coordinate Tools Menu)
This option deletes all points with the DTM code IGNORE from the sheet. Deleted points may
not be recovered. This facility reduces the overall size of this co-ordinate sheet, it is called
automatically by the co-ordinate reduction function. It may be used in conjunction with the
search and replace functions in order to perform a search and delete operation. For example,
if the user imported a DXF file from AutoCAD that included a layer called GRID that was not
required in SCC. Use the search and replace function to set the DTM code of all records with
feature name ‘GRID’ to IGNORE and then call this function.

31.6.1.6 Move / Copy a string parallel. (Coordinate Tools Menu)
This option creates a new string, or moves an existing string, that is offset to a given string by a
given distance in plan and level. The start record number determines the source string. This
option is useful for extruding surfaces such as buildings, storage tanks and tops of kerbs.
When using this option to extrude a surface, ensure that a small horizontal distance, such as
10mm, is given in order for the triangulation to form correctly. For example, if using this facility
to put a roof on a building, ensure that the string representing the roof is inside the string
representing the base. Checking the direction of the string visually, and entering a small
horizontal offset to force the roof string inside the base string may do this. The building will now
be represented in full 3D in the surface model and may be used in sectional, volumetric, and
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viewshed analysis.

This facility is also available directly from survey by using the parallel feature attribute in
the MSMM, or by entering a parallel feature attribute in the observation sheet. To extrude
walls, ditches and similar features see the ‘strip level’ option in the feature library.
Selecting the ‘Copy > Move a string parallel’ option presents you with a dialogue
containing the following parameters; New string name, Horizontal offset, Vertical offset,
Start record number, Copy String / Move String

Horizontal Offset
This field specifies the plan distance between the survey string and the parallel offset
string. A negative distance indicates a left offset, a positive distance indicates a right
offset.

Vertical Offset
This field specifies the height difference between the survey string and the parallel offset
string.

Start record number
This field contains record number, as displayed in the title on the bottom of the sheet, of
the first record that will be used or modified. Note that the record number will generally
NOT be the same as the survey point number.

Copy String/Move String
This switch defines whether the co-ordinates that make up the existing string will be
deleted. If this is the case the copy parallel facility operates as a move parallel facility.
Setting the DTM status of the original string co-ordinates to IGNORE carries out deletion.

31.6.1.7 Flip Sort Order (Coordinate Tools Menu)
This facility sorts the co-ordinate file by X, Y, Z, starting at 000.000, 000.000, 00.00. This would
be used so as to speed up the Remove Duplicate Points options and should be used in no
other circumstances.
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31.6.1.8 Transform co-ordinates (Coordinate Tools Menu)
This option permits the user to create or edit a transformation from one co-ordinate system to
another. The transformation editor lets the user enter any number of co-ordinates in both
systems and calculates a transformation that will convert data between these systems.
Selecting the transformation option brings up a dialogue with the following parameters;

Pick
Select an existing Transformation file.

Transformation file
Select the transformation file to be used for this transformation. This name will be used,
with the extension ‘.REP’, for the transformation results report.

Tranformation type
2D Affine
The transformation used is an affine two-dimensional transformation with elevation
datum shift. This transformation allows for rotation, translation and scaling in plan
along with translation of levels. Independent scaling will be used on both axes. This
transformation is suitable for moving two dimensional data, that may have been
digitized from mapping, from one coordinate system to another.
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3D Conformal 7 Parameter Transformation
The transformation used is a 3D conformal transformation, sometimes called a 7
parameter transformation. This transformation shifts, rotates and scales in three
dimensions. The scale is applied uniformly on all axes. This option is suited to
moving between different 3d coordinate systems, such as local and national grid.

2D Conformal Transformation
The transformation used is a 2D conformal transformation. This transformation
shifts, rotates and scales in plan. The scale is applied uniformly on both X and Y
axes. This option is suited to moving between different coordinate systems in cases
where you do not wish to change the surveyed elevations.

Force the conformal transformation to be scale free
The conformal transformations can now be forced to use a scale factor of 1.0

2D Scale Free
The coordinates will be shifted and rotated in plan but not scaled.

3D Scale Free
The coordinates will be shifted and rotated in plan but not scaled.

2D Best Fit (2 or more points)
The 2D Best Fit requires a minimum of two points rather than the 3 points required
for the least squares transformations, and is based around a plan shift, level shift and
plan rotation. The report includes the shifts, rotation, scale where appropriate, and
CoG origin about which shift and rotation is performed

3D Best Fit (2 or more points)
The 3D Best Fit requires a minimum of two points rather than the 3 points required
for the least squares transformations, and is based around a plan shift, level shift and
plan rotation. The report includes the shifts, rotation, scale where appropriate, and
CoG origin about which shift and rotation is performed
To obtain more detailed statistics, including CoG information, on the 2d and 3d (7
parameter) transformations, select 'FILE > General Options / Units & Data Checking
> All Possible diagnostic information'. This should be reset to 'errors, warnings, and
notes' after completing the transformation

Do not rotate grid aligned text
This option allows the user to not rotate grid aligned text during a transformation.

National Grid Transformation (Grid InQuest)
Support has been added for national grid transformations between ITM, Irish Grid,
OSGB36 and ETRS89. These transformations utilise Grid Inquest software provided
by Quest Geo Solutions.
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Developing Distance To Shape
Options are available to allow transforming of plan models onto the insider of a cylinder.
This complements the cylinder unwrapping tool, to allow editing of unwrapped models
such as tunnels to be re-wrapped to the tunnel coordinate system:
Cylinder from alignment
Cylinder from string
Section template from alignment
Reverse cylinder from alignment (re-wrap)
Cylindrical radius

Transformation Result Report
Once the transformation has been computed, a report file showing the transformation
results is generated and may be edited. This report includes the data used, the residuals
generated, and the transformation coefficients computed. Also generated are block
creation, insertion, scaling and rotation values that may be used to apply the
transformation to a CAD drawing. Block creation and insertion points based around the
origin, and the centres of gravity of the original data are generated. If the user does not
wish to apply the scale provided, the second of these should be used. If a drawing has
been exported to CAD and subsequently requires transformation a block may be made of
the original drawing. The block may then be transformed using the given co-ordinates of
the block creation point, insertion point and the scale to be applied. If a significant
inappropriate scale, or large residual values, is generated, check your input data. If the
users has a large number of points in both systems, the user should try to replace points
with large residuals with other matched points that are near to those points.

31.6.1.9 Search for String Errors (Coordinate Tools Menu)
Strings are searched for errors. When errors are found they are automatically fixed and
reported to the logfile. Errors encountered may be a gap at the end of a string, one point on a
string, less than three points on a curve etc.

31.6.1.10Search for MOSS Errors (Coordinate Tools Menu)
The file is searched to make sure that every string complies with MX coding. This option has
been implemented for use specifically by INDOT.
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31.6.1.11Renumber Points (Coordinate Tools Menu)
This option renumbers the construction points within a survey. ‘01’ is added to the end of the
point number.
For example, Point 91 becomes 9101. This option is present so as to make construction points
easily recognisable.

31.6.1.12Remove Loops (Coordinate Tools Menu)
This option is designed for use in conjunction with the Edit Strings Details option from the
Model Edit menu.
1. Select a string in the model that contains loops.
2. Go to 'Edit > Edit String Details' and then select 'Edit > Remove Loops'.
3. A dialog will be presented asking for the record range to be entered.

If the first point on a string is selected, all loops will be removed from the string.
If a point on a loop is selected as the first point in the record range, the loop will remain
and the rest of the string will be deleted. When all changes have been made select
'Update string in model'.
This option may be used with a dataset when you determine the record range from which
the loops should be removed.

31.6.1.13Compute X,Y from Chainage, Offset (Coordinate Tools Menu)
This option and the option to compute chainage, offset from X,Y have been added to the
coordinate sheet to allow bi-directional conversion between chainage & offset, and X,Y. This
option uses an alignment string to perform the necessary interpolations. This option greatly
simplifies creation of DTMs from levelling data.

31.6.1.14Compute Chainage, Offset from X,Y (Coordinate Tools Menu)
This option and the option to compute X,Y, from chainage, offset have been added to the
coordinate sheet to allow bi-directional conversion between chainage & offset, and X,Y. These
options use an alignment string to perform the necessary interpolations. This option greatly
©2015 Atlas Computers Ltd

729
simplifies the creation of sectional data where the design is available.

31.6.1.15Compute Vertical Design Offset from Z (Coordinate Tools Menu)
This option allows you to calculate and store differences between the current elevation and the
design elevation for the current chainage, for a range of points. The design elevation used is
the elevation of the vertical alignment at the chainage for the current point. This elevation is
subtracted from the current elevation and the result replaces the current elevation.

This option also allows you to compute and store instantaneous cant / super-elevation in the
dimension fields, d1, d2 and d3. The left instantaneous cant or super-elevation is stored in d1,
the right in d2. The effect of super-elevation on the level of the current point, based on its
chainage and offset, is stored in d3

31.6.1.16Output Coordinates as Section Templates (Coordinate Tools Menu)
This option presents an Output Design Dialog.

31.6.1.17String using Chainage / Offset (Coordinate Tools Menu)
This option sorts data based on the chainage and offset values.

31.6.1.18Compute Wriggle Survey (Coordinate Tools Menu)
This option supports the computation of wriggle survey data. The following options are
available:
· to export the rings as annotated sections, including surveyed points, design circle and best fit
circle on each sections.
· to allow the alignment generated by connecting ring centres to be kept.
· to allow storage of additional information in exported dimension columns, which can be
reviewed in the exported models
· to report details of design and best fit radii, and point by point difference to the design radius.
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· to automatically detect and remove outliers while carrying out the wriggle processing, where
a user defined tolerance may be used to control what constitutes an outlier. Outliers that
have been removed appear as spots on the section, whereas points kept appear as the
surveyed string.
· to set deformation tolerances, where out of tolerance points are highlighted in section and in
the report files.
· to allow the output of raw data, fit data and design data.
· to display text on wriggle sections displayed radially, with thinning options to remove
potentially overlapping text.

D1, D2 and D3
Specific Dimension 1, 2 and 3 options are available: Ht. Diff to Alignment, Ht. Diff to
Alignment, Ht. Diff to Centre, Alignment Ht/Z, Radius, Diff Radius from mean, Diff Radius
from design, None
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Text thinning
This options specifies the amount of text the user wishes to keep.

Sections are annotated with the dimensions with some extra annotation at the centres as can
be seen below. Settings can be customised within the section style and feature library. Titles
can be changed as required, and the text editing functions can be used to move and tidy up the
text.

31.6.1.19Compute Vehicle Mounted GPS Errors (Coordinate Tools Menu)
This tool automatically corrects for errors occurring in vehicle mounted GPS surveys due to
pitch and roll e.g. beach surveys done with a quad bike, where the effect of the vehicle
travelling over non-level ground means that the GPS antenna and pole is not vertically above
the ground. The roll and pitch of the vehicle in the direction of the vehicle are the cause of this
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error, and can be calculated by creating a provisional DTM from the uncorrected data.

Once run, a new data set is created with the corrected coordinates, and longitudinal, lateral and
height corrections are stored in D1, D2, and D3. Longitudinal corrections will be large when
going up or down hill and small when on the flat or following a contour. Lateral corrections will
be large when following a contour on a sloped surface, and small going directly up or down hill
or on a flat.
While the length and width of the wheel base are not that significant, whether the pole is to the
front or to the back is as important as whether it is on the left or right. Basically, the vehicle
dimensions and pole positions are used to determine the position of two points at which and
elevation is taken, which in conjunction with the surveyed point are used to determine pitch and
roll. If the pole is on the left, the point used to determine roll is taken on the right of the line of
travel, otherwise it is taken on the left. This is important when the vehicle is following the edge
of an embankment. If the pole is on the front of the vehicle, the point used to calculate pitch is
taken from behind the line of travel, otherwise it is taken in front. This is important where the
vehicle is going from a flat to sloped surface or vice versa. Both are important where there is a
lot of grade change, e.g. dunes.
Entering an incorrect pole position relative to the wheel base of the vehicle would lead to the
position of change of grades, e.g. top and bottom of bank, being incorrect. The size of the
correction is due to the slope of the ground and the antenna height, with greater antenna
heights leading to a larger correction. On test data sets used, with an antenna height of 1.45m
and a gradient of 1:5, the horizontal correction was approx.
correction

260mm and the vertical

25mm.

Note that the corrected dataset will be slightly smaller than the uncorrected dataset, as
corrections cannot be safely calculated for all points at the edge of the model.

31.6.1.20Compute Two Prism Rail Corrections (Coordinate Tools Menu)
This option supports surveying of rail tracks using a two prism method. This produces a report
showing raw and adjusted coordinates, and will create a new survey containing the adjusted rail
data. The point number is based on field 71 of the left hand rail rather than the survey point
number.
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31.7

Instrument Set Up
Instrument Set-ups, containing observed back-sights, used to orient the horizontal circle
whenever the total station is moved. The instrument set-up sheet also contains distance and
coordinate misclosures, along with other QA fields.

31.7.1 Station Orientation
The primary function of the instrument set-up spreadsheet is to determine the orientation of the
horizontal circle of your instrument. This is referred to in the software as the instrument zero.
When we set-up a theodolite we measure included clockwise angles between the instrument
zero and the target point. These angles are horizontal dimensions (that the current horizontal
circle reading for the current telescope pointing) rather than bearings as they are not relative to
grid north. However, in order to calculate co-ordinates from our detail observations we require
that these directions be converted into bearings. To do this we must determine the included
angle between grid north, the occupied station and the instrument zero. We refer to this angle
as the HA datum, this is the angle that must be subtracted from any horizontal direction
observed from this set-up to convert it into a bearing.

In order to compute the HA datum we need to know the bearing of the line Occupies Station to
Reference Station. This will be computed from co-ordinates, if co-ordinates for the occupied
and reference station are available. If co-ordinates are not available the bearing of this line
may be entered manually. This will often be the case when an arbitrary grid is being used on a
small survey. We also require an observation to the reference station to be taken. Given
these two pieces of information the HA datum can be calculated as the difference in angles
between the observed direction and the calculated bearing.
If more than one reference station is sighted multiple values for the instrument zero are
calculated and the mean value is used when computing co-ordinates. This provides a strong
orientation solution when accurate surveying is to be undertaken. If the dispersion of the
residuals about the mean is small, then this is in fact checking the included angles between
successive reference orientation stations. This of course removes the possibility of gross error
or will detect weakness in the control stations.
It is possible to perform multiple sightings to the same station to increase orientation strength
but this will not provide the other checks as previously outlines. The other method of checking
for gross error is to check the join distance between the occupied station as derived from the
control co-ordinates and the values measured to a target in the field.
However, this is sometimes inconvenient in certain circumstances. For instance, if station
points are on the periphery of a quarry and it takes a considerable time to observe these by
occupying the reference station with the prism target, then by observing at least two reference
stations for horizontal angel only, the included angle can be checked, the orientation improved
and gross error avoided.
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31.7.2 Instrument Set Up
Selecting this option allows you to edit the station set-up details from which the current point
was fixed. Modifying the station set-up details will require the associated survey to be re-coordinated and the model to be rebuilt. If the co-ordinate file was not formed from a detail
survey then this option may not be used.

Number
This field contains the sequential station set-up or occupation number, which corresponds
to the station field in the detail observations file. Multiple records with the same number
indicate that mean values for orientation and corrections will be calculated based on
multiple reference objects.

At Stn
This field contains the name of the station occupied for this set-up. The co-ordinate value
for this station may be found in the station co-ordinates file.

XYZ
This field specifies whether a co-ordinate exists for the occupied station in the station
co-ordinates file.
There are two parameters; Yes or No

To Stn
This field contains the name of the reference station observed for this set-up. The
co-ordinate value for this station will normally be found in the station co-ordinate file. This
field may be blank or have an invalid station name, in which case orientation is calculated
from the bearing entered between the occupied and reference stations.

XYZ
This field specifies whether a co-ordinate exists for the occupied station in the station
co-ordinates file.
There are two parameters; Yes or No

-Inst HtThis field contains the instrument height as entered in the field. It is used when calculating
station elevations.

-Rod HtThis field contains the rod height entered for the current station observation. It is used in
conjunction with the instrument height and the derived height difference (Ht Diff) between
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the instrument collimation and the tilting axis of the prism to check the height difference
between the occupied station and the reference station from that computed from the
control station elevations.

-HAThis field contains the observed horizontal angle for the current observation. Note that
this is a horizontal direction rather than an azimuth as it is measured from the zero of the
horizontal circle of the instrument.

-zVAThis field contains the observed vertical/zenith angle for the current observation. This is
combined with the height and rod height in the formula to determine the difference in
height between the occupied and reference station (as described under -Rod Ht-).

-Sl DistThis field contains the slope distance for the current observation. This is combined with
the height and rod height in the formula to determine the difference in height between the
occupied and reference station (as described under -Rod Ht-).

Obs. Zero
This field contains a value for the instrument zero for this observation. This will either be
calculated from the co-ordinates of the occupied and reference stations, or entered
directly if co-ordinates for the reference station are not available. For example, if
orientation is being calculated from a landmark such as a church spire.

Mean Zero
This field contains the mean instrument zero for all the observations in this station set-up.
It is used to convert observed horizontal angles (directions) into whole circle bearings.

Zero Err
This field contains the difference between the mean zero and the observation zero for this
observation. It is only applicable to set-ups with more than one reference observation.

-X ErrThis field contains difference in X co- ordinate for the stored and calculated values of the
reference station. It is only valid if a distance has been observed and the reference
stations exist in the station co-ordinates file.

-Y ErrThis field contains difference in Y co-ordinate for the stored and calculated values of the
reference station. It is only valid if a distance has been observed and the reference
stations exist in the station co-ordinates file.

-Z ErrThis field contains difference in elevation/z for the stored and calculated values of the
reference station. It is only valid if a distance has been observed and the reference
stations exist in the station co-ordinates file.
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-Sl Dist ErrThis field contains difference between the observed slope distance and the join distances
computed from the occupied and reference station co-ordinates. It is only valid if a
distance has been observed and the reference stations exist in the station co-ordinates
file.

Obs 'k'
This field contains the refraction correction constant 'k' that has been computed locally for
this observation. This value will only be calculated if a distance has been observed and
the reference stations exist in the station co-ordinates file. Refraction correction is used to
improve accuracy for trigonometric levelling.

Mean 'k'
This field contains the mean refraction correction constant 'k' that has been computed
from the individual computed values for each observation.

Scale
This field contains the PPM distance scale factor computed from temperature and
pressure entered at time of survey. This value will not by default be applied as the
instrument normally applies it.
To apply this value select the ‘Corrections' menu. It is calculated as -

ppm=275 - 79.55 x (p / (273 + t))
where

p = pressure
t = temperature

Temperature
This field contains the temperature, in degrees centigrade, measured at time of survey. It
is used in calculating atmospheric scale correction.

Pressure
This field contains the pressure, in millibars, measured at time of survey. It is used in
calculating atmospheric scale correction.

Comp Dist
This field contains the join distance computed between the occupied station and the
reference station. It is only valid if both stations exist in the station co-ordinates file.

Comp Brg
This field contains the join bearing computed between the occupied station and the
reference station. If the reference station co-ordinates are not available a value may be
entered here for the purposes of computing orientation.

-Hor DistThis field contains the horizontal distance, computed from the slope distance and the
zenith angle, for the current point in the file. It is provided for reference purposes only.
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-Ht DiffThis field contains the height difference, computed from the slope distance and the zenith
angle, instrument and rod heights, for the current point in the file. It is provided for
reference purposes only.

31.7.3 Corrections (Edit Menu)
This option allows the user to control how corrections for refraction, earth's curvature, local
scale factor, temperature, and pressure are applied.

See Also
Corrections (Edit Menu)

31.8

Alignment Sheet
The alignment document stores all information relating to horizontal, vertical, and section
template design data.

31.8.1 Alignment Design Menu

31.8.1.1 Design Vertical Alignment(Alignment Design Menu)
This option 'Design > Vertical Alignment' may only be selected when a horizontal alignment is
currently attached to the model.
The horizontal menu bar appears at the top of the vertical design sheet contains the options
increase/decrease the vertical exaggeration and display a horizontal or vertical grid across the
profile. A better view of the existing ground profile may be obtained by increasing the Vertical
Exaggeration.
©2015 Atlas Computers Ltd

738

The position of the horizontal design elements is indicated by the coloured vertical lines along
the profile. The colours correspond to the colour of the elements on the horizontal design.
Colour

Design Element

Yellow

Straight

Red

Transition

Blue

Curve

When this option is selected a side bar menu and a top bar menu are opened. The side bar
menu highlighted in red above contains the following options;

Vertical Design Action
The action required by the selected option is displayed in the bottom section of this dialog.
This field contains 4 options;
Add IPs

Adds Intersection points interactively to the profile

Delete IPs

Allows existing intersection points to be deleted from the vertical
alignment by selecting them interactively

Move IPs

Allows existing intersection points to be moved interactively on the
profile.

Edit IPs

Allows existing intersection points information to be edited via the
horizontal and vertical component, curve parameters and gradients
dialogs.

Horizontal Component
The horizontal position of the vertical design may be specified with the cursor or by
chainage. This option is used when Add IPs or Edit IPs is selected. This option is used in
conjunction with the chosen vertical component.
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Vertical Component
The vertical component of the design may be defined with the mouse, or by a predefined
elevation or gradient. When Elevation or Gradient is specified the vertical component may
only be moved along the specified elevation or gradient.

Curve Parameters
This field allows specification of the following parameters for the generation of vertical
curves;
K Value
Radius
Length

Gradients
This field allows specification of incoming and outgoing gradients. The units by which
gradients are defined are specified in the 'Units and Data Checking' section of the General
Options.

Status
This field defines the status of the current vertical design. If there is a problem with the
design, it will be displayed here. When designing the alignment the next action required is
displayed in this field.
The vertical design sheet displays the vertical profile of the model along the horizontal
design and position of all horizontal design elements 'View > Vertical Design Entities'.

31.8.1.2 Section Templates (Alignment Design Menu)
Section Templates may be interactively designed. Sections of varying width may be attached
to different chainages along the alignment. This may be needed to accommodate roads of
varying width. Elements such as drains, which may occur only in cut or elements which occur
only in fill may also be catered for in the section templates.
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When this option is selected a side menu bar and a top menu bar are opened.
The top menu bar tells the section number, the chainage of the current section, the vertical
exaggeration of the section, horizontal and vertical grid, and cut and fill displays.

The side menu bar contains the following options;

Action
The action required by the selected option is displayed in the status section of the
Template Design Action.
This field contains 4 options;
Add IPs

Allows profile points to be added to the template interactively.

Delete IPs

Allows existing profile points to be moved interactively on the
template.

Move IPs

Allows existing profile points to be deleted from the template by
selecting them with the cursor.

Edit IPs

Allows existing profile points to be edited via the horizontal and
vertical components and the Interface side slopes.

Feature
This option sets the feature for each point added to the template. Having a separate
feature name for each point makes them more easily recognisable. Select a feature from
the list given.

Surface
More than one surface may be created on a section template. Select a surface from the
list given. To create a new surface select the New Surface option at the bottom of the
side menu bar.
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New
This option allows a new section template to be designed. This option is used when the
same template cannot be used for the whole of the alignment. When this option is
selected specify the chainage where the new template will begin. The new template will
run from this chainage to the end of the alignment.

Horizontal Component
This option works in conjunction with the vertical component. The horizontal component
of each template point may be selected using 4 different methods. Select interactively
with the cursor, select by specifying a horizontal offset, select by specifying a width or
horizontal distance from the previous point or select by specifying a slope distance from
the previous point.

Vertical Component
This option works in conjunction with the horizontal component. The vertical component
of each template point may be selected using 4 different methods. Select interactively
with the cursor, select by specifying a vertical offset, select by specifying a height
difference from the previous point or select by specifying a gradient from the previous
point.

Interface Side Slopes
Interface side slopes extend from the end points of the section at a specified gradient until
they meet the ground surface. Specify the gradient of the side slopes and whether or not
they are switched on.

31.8.1.3 X, Y, Z Shift (Alignment Design Menu)
This option moves the alignment by specified X, Y and Z values. These values are typed into
the Move Alignment Origin dialog.

31.8.1.4 Export Design as Dataset (Alignment Design Menu)
This option allows the alignment to be exported to a survey data set. The Export Alignment
dialog is presented.
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The data set will contain X,Y,Z, chainage and offset information.

31.8.1.5 Export Design as Model (Alignment Design Menu)
This option exports the alignment to a separate TIN model. The Export Alignment dialog is
presented.

31.8.1.6 Interface and Export Parameters (Alignment Design Menu)
This option presents the Export Alignment Dialog which allows you to view and adjust the
parameters for exporting the current alignment as an interface string.
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31.8.1.7 Compute Horizontal Entities (Alignment Design Menu)
This option allows the user to recompute the horizontal entities when a change has been made
to the horizontal entity or horizontal intersection point spreadsheet. The horizontal entities are
automatically computed when the horizontal intersection point information is downloaded, but is
not automatically updated when changes are made to this information in SCC.
SCC can either compute horizontal entities from horizontal intersection points, or allow them to
be entered directly. In the latter case, it is only necessary to enter the minimum number of
fields required to compute the entities, and SCC will complete the rest. This allows the user to
re-compute sets of unknown values in the horizontal entity sheet based around the input
information you have available. For example, if the user did not have length and vector
information could be re-computed from the other parameters. Alternatively, if the user did not
have plan position, or chainage, such values could be re-computed. The user is limited to
having up to two unknown fields, as this is the minimum computational requirement.

31.8.1.8 Compute Vertical Entities (Alignment Design Menu)
This option allows the user to recompute the vertical entities when a change has been made to
the vertical intersection point spreadsheet. The vertical entities were automatically computed
when the vertical intersection point (DOER VIPS file) information was downloaded, but is not
automatically updated when changes are made to this information in SCC.

31.8.1.9 Compute Super-Elevation (Alignment Design Menu)
This option populates the super elevation sheet for the current design, based on the following
specified road design criteria;
· Carriage way width
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· Normal camber
· Design speed in Kph
· Maximum radius for super elevation

31.8.1.10Check and Report Design Geometry (Alignment Design Menu)
This option checks that the geometry of the current alignment is correct. This report tells
whether the given start point of each element is the same as the computed end point of the
previous element. An Alignment Geometry Test Report is generated detailing the horizontal
and vertical entities.
This option reports all horizontal and vertical entity information. The differences between the
given starting X, Y, Z and chainage of each element and the calculated end point of the
previous element are given to test the geometry of the entities.

Horizontal Entities
No
This field contains the number of the horizontal intersection point.

Entity Type
This field specifies the type of the current horizontal entity. A compound curve is going
from one known radius to another. Compound In curves go from a small radius to a larger
radius, while Compound Out curves go from a large radius to a smaller radius. The radius
at one end of a spiral curve is infinite, while the radius it’s the other end known.
This field has 6 possible options; Circular Arc, Compound In, Compound Out, Spiral In,
Spiral Out, or Straight.

X1
Starting X co-ordinate of current element.

Y1
Starting Y co-ordinate of current element.

Chainage
This field contains the chainage at the start of the current entity.

S. Radius
This field contains the incoming radius of the current entity.

L. Radius
This field contains the incoming radius of the current entity.

X2
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Ending X co-ordinate of current element.

Y2
Ending Y co-ordinate of current element

Vector
Outgoing Vector of previous element.

E. Chainage
The ending/final chainage of the element.

Ch Diff
The difference between the ending chainage of the last element and the starting chainage
of the current element.

X Diff
The difference between the easting of the last point on the previous element and the first
point on the current element.

Y Diff
The difference between the northing of the last point on the previous element and the first
point on the current element.

V Diff
The difference between the previous element’s outgoing vector and the current element’s
incoming vector.

Vertical Entities
No.
This field contains the number of the vertical entity. SCC has assigned this number.

Entity Type
This field specifies the geometry of the current vertical entity. This field has two possible
options; V. Curve or Straight

Chainage
This field contains the chainage at the start of the current entity.

Length
This field contains the length of the current entity.

Level
This field contains the level at the beginning of the current entity.

Gradient
This field contains the gradient of the current entity. This gradient is given in decimal
form.

Grad. Diff
This field contains the algebraic difference in height between the first and last point of the
entity.

Ch Diff
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The difference between the ending chainage of the last element and the starting chainage
of the current element.

31.8.1.11Compress Geometry (Alignment Design Menu)
This option allows the user to enter a horizontal and vertical tolerance when compressing
alignment geometry.

31.8.2 Alignment View Menu

31.8.2.1 Horizontal Intersection Points (Alignment View Menu)
The horizontal intersection points sheet, contains co-ordinate and geometric information about
each of the intersection points in the alignment. The sheet is ordered by number. Intersection
Point information may be obtained from DOER HIPS file or calculated from MX GENIO
Geometry information.

No.
This field contains the number of the horizontal intersection point.

Pivot
Centre
Inside
Outside

Curve
Left
None
Right

E/X
This field contains the Easting/X value of the current horizontal intersection point.
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N/Y
This field contains the Easting/X value of the current horizontal intersection point.

Spiral In
This field contains the length of the incoming spiral

R1
This field contains the radius of the first curve

R2
This field contains the radius of the second curve. This is used when the curve is complex
curve or partial transition.

Sprial Out
This field contains the outgoing spiral

31.8.2.2 Vertical Intersection Points (Alignment View Menu)
The vertical intersection point spreadsheet contains chainage, level and gradient information on
all vertical intersection points. This information is obtained from DOER VIPS files.

No.
This field contains the number of the vertical intersection point.

Chainage
This field contains the chainage of the current vertical intersection point.

Level
This field contains the level/Z value of the current intersection point.

Length
This field contains the length of the current vertical entity.

Grade In
This field contains the value of the incoming gradient.

©2015 Atlas Computers Ltd

748

Grade Out
This field contains the value of the outgoing gradient.

31.8.2.3 Horizontal Entities (Alignment View Menu)
The horizontal geometry entities spreadsheet contains information on the horizontal alignment.
This information is obtained from a MX GENIO Geometry File. If alignment information has
been obtained from DOER HIPS or VIPS files then this sheet will remain blank.

No
This field contains the number of the horizontal entity. SCC assigns this value.

Type
This field specifies the type of the current horizontal entity. A compound curve is going
from one known radius to another. Compound In curves go from a small radius to a larger
radius, while Compound Out curves go from a large radius to a smaller radius. The radius
at one end of a spiral curve is infinite, while the radius it’s the other end known.
This field has 6 possible options;
Circular Arc
Compound In
Compound Out
Spiral In
Spiral Out
Straight

E/X
This field contains the E/X value of the starting point of the current entity.

N/Y
This field contains the N/Y value of the starting point of the current entity.

Chainage
This field contains the start chainage of the current horizontal entity.

Vector
This is the mathematical direction of the current element.
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Length
This field contains the length of the current horizontal entity.

Radius 1
This field contains the incoming radius of the current entity.

Radius 2
This field contains the incoming radius of the current entity.

31.8.2.4 Vertical Entities (Alignment View Menu)
The vertical geometry entities spreadsheet contains information about the vertical alignment.
This information is obtained from the MX GENIO Geometry file. If alignment information has
been obtained from DOER HIPS or VIPS files then this sheet will remain blank.

No.
This field contains the number of the vertical entity. SCC has assigned this number.

Type
This field specifies the geometry of the current vertical entity.
This field has two possible options;
V. Curve
Straight

Chainage(1)
This field contains the chainage at the start of the current entity.

Length
This field contains the length of the current entity.

Base Level
This field contains the level at the beginning of the current entity.

Gradient
This field contains the gradient of the current entity. The gradient is given in decimal form.
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Alg. Diff
This field contains the algebraic difference in height between the first and last point of the
entity.

31.8.2.5 Super-Elevation Nodes (Alignment View Menu)
The super elevation nodes sheet contains three fields

Chainage
This is the chainage at which the current super elevation is applied

L.Super
This is the super elevation, given as a gradient away from the centre line, used for
positions to the left of the centre line

R.Super
This is the super elevation, given as a gradient away from the centre line, used for
positions to the right of the centre line
The super elevation computed for any given chainage is linearly interpolated from the two super
elevation nodes directly above and below that chainage. The super elevation is applied to the
design elevation by multiplying the gradient by the horizontal offset to derive a height difference,
which is then added back to the design elevation. Super elevation will typically be applied over
the length of transitions in road design. The super elevation sheet may also be used for cant
calculations in rail design.

31.8.2.6 Section Template Points (Alignment View Menu)
SCC allows simple template design for the alignment. There is no limit to the number of
elements in each template. All sections are placed at right angles to the alignment string.
Different templates may be designed for different sections of the alignment. This may be
achieved by giving the templates different ‘Sect numbers’ and specifying the chainages where
these templates should be used. The side slopes of the templates are determined by the cut
and fill percentages. To export an alignment to a dataset or a model a section template must
be created. It is sufficient to have one entry in this spreadsheet.
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Sect
This field contains the number of the section template. This field will be 1, unless there
was more than one template designed.

Chainage 1
This field contains the first chainage at which the template will be placed.

Chainage 2
This field contains the last chainage at which the template will be placed.

Surface
This field indicates the surface of the current section point. This is used where the design
is being used to create multiple material layers of known thickness.

Feature
This field contains the feature of the current template element.

Str
This field contains the string number of the current element.

Hz. Offset
This field contains the value of the horizontal offset from the centre of the profile.

Vt. Offset
This field contains the value of the vertical offset from the centre of the profile.

Type
This field specifies element type for the current template point. A fixed element is a string
point that will always get included in the design model. A left or right edge is a design
point from which side slopes are projected. Elements can be included for cut situations
only, fill situations only, or both cut and fill. Thus a ‘Fixed – Cut’ element will include a
string point in the design model only in places where the design elevation is lower than the
existing ground elevation.
This field has 3 possible options;
Fixed – Both
Left Edge – Both
Right Edge – Both
Fixed – Cut
Left Edge - Cut
Right Edge – Cut
Fixed – Fill
Left Edge – Fill
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Right Edge – Fill

Cut
This field contains the upward side slope for the template, that is, the cut gradient between
the design string and the existing ground.

Fill
This field contains the downward side slope for the template, that is, the fill gradient
between the design string and the existing ground.

32

Modelling
SCC models can be created either directly from coordinate data such as DXF or GENIO, or
from reduced SCC Survey datasets. When working with large models, it is usually model the
source data, such as DXF, directly rather than importing it into a SCC Survey dataset first.

See also
SCC Models
Models

32.1

Data Selection Dialog (Model)

The following selection options are available within the Model Data Selection Dialog:

Interactive selection method
Individual points
All points in a window
All string segments intersecting line
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All points on selected string
All similar strings (Same feature)
All points in a polygon
All points in selected polygon string

Mark or clear points
Mark selected points
Clear selected points

Mark or clear all points in model
Highlights all points within the model

Polygon Selection
Apply polygon to selection
Create Polygon
Edit Polygon coordinates

Apply Coordinates range to selection
Minimum
Maximum

Apply Chainage/Offset range to selection
Minimum
Maximum

Apply String / Feature range
First string name
Last string name

Apply Point No range
First point
Last point

Apply Station range
First station
Last station

Apply derivation codes
· Detail

· Control

· Construction

· Manual

· DXF

· Draped Profile
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· Curve fit

· String Offset

· Square

· Strip Level

· Design

· External file

· Line of Sight attribute

· Taped Measure attribute

· Feature Offset attribute

· Ortho Feature attribute

· Radius & Centre attribute · Point & Centre attribute

· 2Pts Circle attribute

· 3Pts Circle attribute

· 3Pts Rectangle attribute

· Parallel Feature attribute

· As Set Out Point

· GENIO point

· Levelled point

· Text insert point

· Steps

Include selection polygon in output / cut data
Include selection polygon in existing model

32.2

Model File Menu
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32.2.1 Attach / Detach

The follow options are available:

Attach Alignment File
This option attaches the selected alignment file to the current model. The alignment does
not become part of the DTM. This option is simply a visualisation tool. Any changes
made to the alignment file while it is attached to the model are updated automatically on
the model screen.

Attach Traverse File
This option allows the user to attach a Traverse file to the current model. The user can
then annotate the Traverse Stations and Traverse Legs (Edit > Text > Annotate Traverse)

©2015 Atlas Computers Ltd

756

Attach Section File
This option allows the user to attach a Section file to the current model.
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Edit / Detach
This option allows the user to Select or Detach listed files within the 'Attach reference files
to model' dialog. Also within this dialog the user can change the scale of the Traverse
station error ellipses.

Attach Model File
This option allows the user to attach a model to an existing opened model for reference
purposes. The reference model is displayed in plan over the current model, and once
attached, the height difference between current and reference model is displayed in the
status bar. The option requires the alignment module to be licensed.
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Note: 'EDIT > Offset height of selected points' option allow levels to be offset relative to
the reference model, or to have the reference model elevation added or subtracted from
the current model.

Attach Feature Library
This option attaches a feature library to the model. The library attached will overwrite the
current feature library. This option is useful if the model, need different symbology when
drawn at different scales or if the model was being given to different clients who have their
own specific feature library.

Copy Model Feature to Project
This option allows the user to update your current project with feature library changes that
you have made to your model. This includes updating the feature library and symbols.
Once you have done this you can save your project to the ‘\SCC’ directory such that it can
be used as a project template for future projects.

32.2.2 Workspaces (Model File menu)
Workspaces are used in SCC to store all the program settings that relate to the graphical user
interface. This includes the display and positioning of tool bars and menus, keyboard
shortcuts, the size of the main SCC frame window, a list of currently open documents, and the
default spreadsheet colors and fonts.
The ‘Workspace options’ dialog, allows the user to control whether workspaces are
automatically loaded at startup and saved on existing SCC.

If the user chooses to automatically load and save a workspaces, SCC will reopen the last used
workspace.
If the user chooses to automatically load a default workspace, SCC will reopen the same each
time you run it, with whatever GUI customization applied. This allows a senior surveyor to setup a workspace that simplifies the operation of SCC for other users, by removing unused menu
options and tool bars.
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See Also
Workspaces (Project File Menu)

32.2.3 Sheet Layout (Model File Menu)

32.2.3.1 Insert Sheet
When the sheet has been created and saved to the relevant project file, it is then possible to
insert this sheet in a model.
The user may have several sheet sizes available, and each can be inserted at any plot scale.
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Remember, to insert the sheet templates, the user must have the correct feature library
attached to the model.

Shortcuts
Toolbar

32.2.3.2 Edit Sheet Properties
This options allows the user to edit the sheet layout while in the model.
It gives the user the option to change the plot scale or the rotation of the sheet.
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It also allows the user to move the sheet without affecting the model itself.

Shortcuts
Toolbar

32.2.3.3 Move Sheet
This options allows the user to move / reposition the sheet within the model.

Shortcuts
Toolbar

32.2.3.4 Rotate Sheet
This options allows the user to rotate / reposition the sheet within the model.

Shortcuts
Toolbar
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32.2.3.5 Delete Sheet
This options allows the user to delete the sheet within the model.

Shortcuts
Toolbar

32.2.3.6 Create New Sheet Template
This option allows the user to create a new sheet template, which can be used to plot models
and sections.
When the user selects this option, a choice of paper sizes and orientation is given from which
to base the sheet template on.

Select the sheet size and SCC then generates a new model consisting of a blank sheet. This
sheet can be saved as a model file which can be edited at a later date or as a template which
can be copied to the current feature library and inserted into model and section files.
Below is a list of macros that can be used to create the sheet template. When the sheet is
inserted into a model or section these macros will be automatically updated with the relevant
job data, either from the operating system that is being used or from the data entered into the
‘Titles & grids’ dialog.

Sheet Creation Macros
Operating System
[Name}

Model / Section Name

[Path

Full Model/Section path

[Project]

Project Name
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[Time]

Current time

[Version

SCC Version & Dongle Number

[Scale

Plot Scale

[Page]

Sheet Number

[Pages]

Number of Pages

Titles & Grids Dialog
[ProjectTitle]

Job Name / Title

[Client

Client Name

[Date]

Date

[Surveyor]

Username

[Operator]

Operator

See the images below for an example of how the macros use the data entered in the
‘Titles & Grids’ dialog. The first grid box displays the macros typed in sheet creation. The
second grid box show how the macros are used when inserted into the model.
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Shortcuts
Toolbar

32.2.3.7 Add Titles Blocks and Legends
This option allows the user to add and design title blocks for a sheet template.
The box is positioned using the right mouse button; the first click should be used to position the
top left corner of the data box and the second click to denote the bottom right corner of the box.
When the box is drawn the following dialog is presented:

Selecting one of the options on this dialog will determine the type of data displayed. The options
are as follows:

Empty title box
This option allows the user to add an empty rectangular box to the sheet model, which can
be used for data entry, borders etc.
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Grid
When selecting this option, the user also needs to enter a value for the amount of rows or
columns required in the grid. The grid may be used for entering data such as 'Project
Name', 'Scale' or 'Date' etc..

Feature Library Legend
To select this option the user must enter a value in the rows box. This value indicates the
total amount of feature library entries the user would like to display in the legend when the
sheet is inserted into the model. This works by taking each entry in the model in
sequential record number and displaying the description and the linetype or symbol in the
feature library legend. Features that are not used in the model, do not count.
The image below on the left depicted the feature library legend in the sheet template
whereas the image on the right depicts the legend when inserted into a model.

Station Co-Ordinates
The user must also enter a value in the rows box. The value entered is the total amount
of station coordinates that the user wishes to display on the sheet, where STN 1 is the first
record number in the station coordinates spreadsheet.
The images below show how the station coordinate box appears both in the sheet
template and in the model.
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You can design the sheet template by adding your own company logo, the company
feature library and legend and also additional information about stations, bench level
values and location.

Shortcuts
Toolbar

32.2.3.8 Saving The Sheet
This option allows the user to save the sheet as a template, which is automatically copied to the
current project file.

It is possible to edit existing sheet models once they have been created. However to save the
new template to the feature library, SCC must first recognise the model as a sheet rather than
a model file.
To overwrite an existing sheet template the user must first create a new sheet of the same size.
Then open the existing sheet model and carry out any of the necessary editing. Save the sheet.
Then go to 'FILE > Sheet Layout'. Select the option to ‘save sheet template’. This will
automatically save the template to the feature library. SCC recgonises that a sheet has been
created of a particular size and therefore saves the new template as that size also.

Shortcuts
Toolbar
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32.2.3.9 Delete Existing Sheet Template
This option allows the user to delete the sheet template from the model only.
The sheet template will still remain in the feature library and can be inserted again as normal.

Shortcuts
Toolbar

32.2.3.10Viewing The Sheet
Once the sheet has been inserted into the model, the user can move between sheet and model
view by either:
· using '+' or '-' keys on the keyboard
· using

button on the toolbar

· or using the drop down menu on the Sheet layout toolbar

Shortcuts
Toolbar
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32.3

Model Edit Menu

32.3.1 Undo (Model Edit Menu)
Use this command to reverse the last editing action, if possible. The name of the command
changes, depending on what the last action was. The Undo command changes to Can't Undo
on the menu if you cannot reverse your last action.

Shortcuts
Toolbar:

Keys:

Ctrl + Z or
ALT + BACKSPACE
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32.3.2 Redo (Model Edit Menu)
Redo the last option that was undone.

Shortcuts
Toolbar:

Keys:

Ctrl + Y

32.3.3 Cut (Model Edit Menu)
The following options are available within the 'EDIT > Cut' menu:

Cut to Clipboard
This command is used to remove the currently selected data from the document and put it
on the clipboard. This command is unavailable if there is no data currently selected.
Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar

Keys

CTRL + X

Cut to New Model
This command is used to remove the currently selected data from the document and
paste the selected data into a new model.

Cut to New Dataset
Use this command to remove the currently selected data from the document and put it in a
survey dataset.
This command is unavailable if there is no data currently selected. To cut precise areas
out of the model use the ‘Create Polygon’ option from the 'Data Selection Dialog' to define
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your boundary.

32.3.4 Copy (Model Edit Menu)
The following options are available within the 'EDIT > Copy' menu:

Copy to Clipboard
Use this command to copy selected data onto the clipboard. If there is no data selected,
the entire model gets copied to the clipboard as an OLE object, such that it can be pasted
into any other application, such as MS Word, that accepts pasting OLE objects, typically
via the Paste Special command. If any points are selected, they are copied to the
clipboard such that they can be pasted into other models.
Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar

Keys

CTRL + C

Copy Bitmap to Clipboard
This option copies the current graphical display to the clipboard such that it can be pasted
into any other application, such as MS Word, that accepts pasting bitmaps.

Copy to Model
Use this command to copy selected data into a model. This command is unavailable if
there is no data currently selected. To copy precise areas out of the model use the
‘Create Polygon’ option from the data selection dialog to define your boundary.

Copy to New Dataset
Use this command to copy the currently selected data from the document and put it in a
survey dataset.
This command is unavailable if there is no data currently selected. To cut precise areas
out of the model use the ‘Create Polygon’ option from the 'Data Selection Dialog' to define
your boundary.
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32.3.5 Paste (Model Edit Menu)
This command is used to paste data present on the clipboard into the opened or existing
model.

32.3.6 Paste Special (Model Edit Menu)
This option is used to paste OLE objects, such as office documents, into your model file.

32.3.7 Weed The Triangulation (Model Edit Menu)
This option automatically removes any triangles from the surface that are likely to be unsuitable
for interpolation purposes. This effectively automatically defines the external boundary for a
model. This is carried out by interactively removing triangles with improbably long edges or
large areas. On selecting this option the user are presented with a dialogue containing the
following parameters;

Weeding Factor
This factor is the multiple of the standard deviation of any given triangle within the
triangulation at which it is weeded. The standard deviation is calculated for a number of
possible weeding criteria based on the type of triangulation used and the spread of data
points. A large number may be used initially and then reduced if more weeding is required.

Weeding Cycles
This field contains the maximum number of iterations performed when weeding a
triangulation. More than one iteration is often required, as the standard deviation will
change having removed the worst triangles.

32.3.8 Add and Remove Triangles (Model Edit Menu)
This option allows the user to turn on and off given triangles in the triangulation. Triangles that
are turned off (passive/sterile, are indicated by being filled in blue) will not be used when
computing volumes, contours, grids, sections, viewsheds etc.
Selecting this option highlights all valid and invalid triangles (valid are highlighted in green).
Selecting this option presents the Add and Remove Dialog.
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The user can then remove multiple triangles from the model. When the selection method is ‘All
triangles intersecting line’ a line has to be drawn with the cursor by pressing the mouse button
over the end points of the line. Any triangle that has an edge that intersects this line will have
the selected action applied.

Shortcuts
Toolbar

Selection Method
Individual Triangles
Select single triangles by clicking over them with the cursor

All Triangles intersecting line
Drag and drop a line over the triangles the user wishes to select

All Triangles in the Model
Apply the action to all triangles in the model.

All Triangles with any points selected
Apply the action to triangles with any one of their vertices selected.
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All Triangles with all points selected
Apply the action to triangles with all vertices selected.

All Triangles left of selected string
Apply the action to triangles left of the selected string.

All Triangles right of selected string
Apply the action to triangles right of the selected string.

All Triangles between selected strings
Apply the action to triangles between the selected strings.

All Triangles in selected polygon
Apply the action to triangles within selected polygon.

Action
Remove Triangles
This option removes triangles from the model. They will become invalid and will be turned
blue. Once triangles have been removed they are no longer part of the DTM and
therefore contours will not be generated in areas where there are invalid triangles.

Replace Triangles
This option changes invalid triangles to valid triangles. The triangles will now be included
in the DTM.

Disable Contouring
Disable contours turns off the contours but does not exclude the survey data from the
triangulation. For example, the user may have a building that they do not want contours
going through but may require it to be included in sections.

Enable Contouring
This option is used over areas where the contours have been disabled.

Set Triangles Ground Types
Select a ground type from the ground type pick box. The selection method will determine
which triangles this ground type will be applied to.

See Also
Ground Type Library (View Menu)
3D Viewer (Model View Menu)

32.3.9 Flip Triangle Edges (Model Edit Menu)
This option allows the user to change the diagonal connecting two adjacent triangles for pairs
of triangles in the model. This has the effect of applying simple breaklines that may have been
missed by the surveyor. Selecting this option highlights the triangle edge nearest the cursor.
Pressing the left mouse button causes this edge to be flipped to the alternative diagonal.
Rebuilding the model will undo any manual triangle edge flipping that has been carried out. It
can be seen from inspection of the following diagrams that the data set in terms of point
representation is correct but severe deformation of the surface has occurred from the surveyor
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having omitted proper breakline definition during the survey. Averaging the surface and the
selection of breaklines are prime requirements when surveying broken or badly behaved
surfaces - for example in mining quarrying etc. The following diagrams show an example of
the results of edge flipping.

If all significant grade changes in the model have been included in the model as strings, edge
flipping should not be necessary. An alternative to edge flipping is to create any missing strings
and rebuild the model.

Shortcuts
Toolbar:

Keys:

Alt+E, F

32.3.10 Label Contours (Model Edit Menu)
This option allows the user to manually place contour labels within the model.

32.3.11 Delete Contour Labels (Model Edit Menu)
This option allows the user to manually delete contour labels within the model.
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32.3.12 Add Strings with Cursor (Model Edit Menu)
This option allows the user to add new points and strings to the triangulation. This is carried
out by generating a new detail co-ordinate file and adding points to that file whenever the left
mouse button is pressed. The first time the left mouse button is pressed, the user will be
prompted to enter the string details for the new string being added. When the user has finished
adding points and wishes to update the surface model, or wishes to start a new string press the
right button.
If the user already has a number of existing points selected, this option will convert the selected
points into the chosen geometry. For example, if the user selects a number of points on a
string that are currently connected by a straight line, and then press the ‘Curve’ button, those
points will be curve fit. This works for curves, arcs, circles and rectangles.
Pressing the right mouse button brings up the following dialog;

New
This option starts a new string. The string may be either a Point, Line, Polyline, Polygon,
Open Curve, or Closed Curve.

Point
This option creates a new point string. For example, when drawing trees.

Shortcuts

Line
This option creates a new line string. The feature code, line tag and DTM status of the
string will be taken from what is set in the Create Strings toolbar.

Shortcuts

Polyline
This option creates a new polyline or string. The polyline may contain straight or curve
segments or a combination of both.
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Shortcuts

Polygon
This option creates a new polygon. The closed line can have any number of sides. When
this option is selected the line tag is automatically set to Straight.

Shortcuts

Open Curve
This option creates an open curve. When this option is selected the line tag is
automatically set to Curve.

Shortcuts

Closed Curve
This option creates a closed line curve. When this option is selected the line tag is
automatically set to Curve.

Shortcuts

Circles, Arcs & Rectangles
This option allows the new string to be a circle, arc or rectangle.
The options are Arc 2Pts + Radius, Arc 2Pts + Tangent, Arc 3Pts, Fillet Arc , 2PT Circle,
3Pts Circle, Circle Radius + Centre, 2Pts Rectangle or 3Pts Rectangle.

Arc 2Pts + Radius
Select two points on the arc using the cursor on the model. Type the radius into the
Radius/Width box on the Edit Strings Toolbar. If there is a value already in there this will
be taken as the radius. This option is treated as an Add New String option, therefore if the
right mouse button is selected the secondary menu of 'Add Strings with Cursor' will be
presented. Update the arc in the model or delete it.

Shortcuts

Arc 2Pts + Tangent
Create a straight-line string, once the user has at least one points defined, select this
option and select a further two points. An arc will be generated based on the incoming
tangent derived from the first and second points, and the two points on the arc given by
the second and third point. This option is treated as an Add New String option, therefore if
the right mouse button is selected the secondary menu of 'Add Strings with Cursor' will be
presented. Update the arc in the model or delete it.
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Shortcuts

Arc 3Pts
Select points to define an arc. If 3 existing points have been selected using the data
selection option, then an arc will be drawn between these two points. This option is
treated as an Add New String option, therefore if the right mouse button is selected the
secondary menu of 'Add Strings with Cursor' will be presented.

32.3.12.1Add a new string with Feature Code
This option is used in conjunction with the ‘Add strings from cursor’ command.
By selecting the relevant feature code from the list and entering it in the box, any new
string that is drawn in the model using the ‘Add strings from cursor’ option, will be of this
feature.

If the user already has a number of existing points selected, this option will convert the
selected points into the chosen feature code. For example, if the user selects a number
of points on a string that are currently on layer ‘Ditch’, and then enters the feature ‘Wall’,
all the points on the selected string will become a string with feature code ‘Wall’.

32.3.12.2Add a new string with a Tag Code
This option is used in conjunction with the ‘Add strings from cursor’ command.
By selecting a tag code from the box prior to using the above command, any new strings
added to the model will have this new tag code.

If the user already has a number of existing points selected, this option will convert the
selected points into the chosen geometry. For example, if the user selects a number of
points on a string that are currently connected by a straight line, and then press the
‘Curve’ button, those points will be curve fit. This works for curves, arcs, circles and
rectangles.

32.3.12.3Add a New String with DTM Status
This option is used in conjunction with the ‘Add strings from cursor’ command.
By selecting the relevant code from the list and entering it in the box, any new string that is
drawn in the model using the ‘Add strings from cursor’ option, will have this DTM status.

This option also allows the user to change the DTM status of a selected string.
By using the 'Data Selection Dialog' box (right mouse button) and highlighting the string
that the user wishes to change, one can then enter the new code in the DTM box and
SCC will ask whether to convert all selected points to the new status.
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32.3.13 Circles, Arcs & Rectangles (Model Edit Menu)
This option allows the string to be a circle, arc or rectangle. This option has the same facilities
as the 'Add Strings with Cursor' option , that is when the right mouse button is selected the
same secondary menu appears.

The circles, arcs and rectangles that may be created are; Arc 2Pts + Radius, Arc 2Pts +
Tangent, Arc 3Pts, Fillet Arc , 2PT Circle, 3Pts Circle, Circle Radius + Centre, 2Pts Rectangle,
3Pts Rectangle.
In addition the option to Best Fit Circle and Best Fit Arc are available:

Best Fit Circle
This option creates a best fit circle from the selected point. If more than three points are
selected, none of them will typically lie directly on the resultant circle. The original points
are converted into discrete points with DTM code 'Elevation' for annotation purposes. The
circle fit also does a plane fit on the strings elevation for modeling purposes. Circle fitting
is also available as a tag code for survey reduction and interactive string creation.

Best Fit Arc
This option creates a best fit arc from the selected point. The start and end point will
always lie on the arc, other points typically will not. The original points are converted into
discrete points with DTM code 'Elevation' for annotation purposes. The arc fit also does a
plane fit on the strings elevation for modeling purposes. Arc fitting is also available as a
tag code for survey reduction and interactive string creation.
Both options to Best Fit Circle and Best Fit Arc are also available within the drop down
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Tag menu.
These options all work in conjunction with the ‘Add strings with cursor’ option. As such
they can be used to append arcs to strings being created with this option and may also be
used to convert the geometry of previously selected points. For example, if the user
selects a point on the corner of a building string, and then select the ‘fillet arc’ option, the
building corner will be filleted with an arc. The radius of the arc is entered in the radius
control on the Circles, Arcs & Rectangles dialog bar.

32.3.14 Delete, Points and Strings (Model Edit Menu)
This option allows the user to remove points and strings from the model. Modifying the DTM
code(s) of any points involved and locally re-triangulating the affected portion of the surface
carries this out.
Having selected this option, pressing the left mouse button will delete the point at the cursor. If
the point has an associated detail co-ordinate it will also set the DTM code of the co-ordinate to
IGNORE. If this co-ordinate was on a string, the two links on either side of the deleted point will
not join to form a break-line. This deletion may be undone by using the 'Edit points' option to
change the DTM code of the deleted point back to DTM ELEVATION. Pressing the right
mouse button presents the user with a menu containing the following items. A number of
points may be deleted or removed at the same time by selecting them before selecting this
option.

Pressing the right mouse button presents the user with a menu containing the following items.
A number of points may be deleted or removed at the same time by selecting them before
selecting this option.
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Delete Points
This option operates in a similar manner to the left mouse button but will only work with
points that have associated detail co-ordinates.

Shortcuts

Delete Entire Strings
This option operates in a similar manner to the left mouse button but will only work with
points that have associated detail co-ordinates. All the points on the string associated with
the selected point will be deleted in this manner.

Shortcuts

Remove Point from DTM
This option operates in a similar manner to the left mouse button but will only work with
points that have associated detail co-ordinates. Rather than setting the DTM code of the
deleted point to Ignore it is set to Approx Elevation. This has the effect that the point will
be removed from the triangulation without affecting the cartographic string detail.

Remove Entire String from DTM
This option operates in a similar manner to deleting the entire string but again sets the
DTM codes of all the points in the string to Approx Elevation. The string will be removed
from the triangulation and cease to be a break line but will still be displayed on screen.

Shortcuts

Delete Part of a String
This option allows part of a string to be deleted. A black line will appear at the mouse
perpendicular to the nearest string. Use this black line to select the first and last point to
delete on an existing string. Two points will be inserted into the string where the deleted
section has started and finished. The tag code of the first inserted point will be Gap.

Shortcuts

Break Strings
This option allows the user to break links in strings in the model by inserting gaps into the
selected strings. This option is useful for rectifying survey errors where the surveyor
forgot to end a string or change a string number when such as change was required. For
example, a string may zing across the site where such an error has occurred. This option
currently operates only with strings in the DTM.
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Shortcuts

Delete Co-Linear points
This option will automatically remove co-linear points on one or more selected strings.
Options are included to specify horizontal and vertical tolerances for co-linearity, and
maximum segment length above which the poin will not be considered for deletion. The
purpose of this tool is to help in the removal of unnecessary points from models,
particularly plan drawings that have had a lot of trim and extend type editing.

Quit
This option exits the ‘Delete Points and Strings’ command. The next command may now
be selected.
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32.3.15 Edit Strings (Model Edit Menu)
This option allows editing of the existing strings in the model.

The following options are available.
Join Strings, Join Points, Move Points, Edit Strings Details, Copy String, Copy String Parallel,
Move Strings, Move String Parallel, Edit Strings, Bearing And Distance, Subdivide Strings, Add
Points to a String, Insert Point In String, Insert Point On String, Reverse String, Trim or Extend
To Intersect.

Join Strings
This option allows the user to join pairs of strings together to form single continuous
strings. When selecting this option, simply pick the two strings with the cursor using the
left mouse button. These strings will be joined by the end points nearest to the point
selected, the exact end points do not have to be selected. Any number of pairs of strings
may be joined in this manner.
· If the two strings selected are of different types, for example a wall and a hedge, the first
string will be extended to meet the second string.
· If the points selected do not lie at the ends of their respective strings, a string will be
generated with the same feature as the first string.
· This option may also be used to close gaps in strings, and to close an open string to
form a polygon.
· This option may also be used to join strings with the same partial label, where MX/MX
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coding is in use. For example, joining HE01 to HE02 will result in a single string called
HE01.
To quit this option hit the Escape key.

Shortcuts

Keys:

Alt+E, J

Join Points
This option allows the user to join single points together to form single continuous strings.
When the user selects this option, simply pick the points with the cursor using the left
mouse button. The string details will be inherited from either the first point selected or
from the tool bar depending on the option selected prior to joining the points.
If a single point is selected to form a string, the original point will be removed from the
model whereas if the point selected is already part of an existing string, it will remain. To
complete the string, click on the right mouse button and the string will be updated in the
model.
To quit this option hit the Escape key.

Shortcuts

Move Points
This option allows points in a model to be moved by the user. Select the surveyed point
the user wishes to move using the mouse. The point is now attached to the mouse
pointer. Click the mouse a second time to place the point in its position. If the point is on
a string, the string links either side it will be moved to the X,Y,Z position of the point. The
option is useful for interactively editing obvious surveying errors, for example crossing top
of bank (TB) and bottom for bank (BB) strings. A number of points may be moved at the
same time by selecting them before selecting this option.
To quit this option hit the Escape key.

32.3.16 Text (Model Edit Menu)
This option allows text to be edited and created. Existing text may be edited. Dimensional text
has to be unlocked before it can be edited. Text may now be scaled, rotated and moved.
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The following options are available.
Edit Text Annotation, Create Text, Delete Text, Move Text, Rotate Text, Move and Rotate Text,
Copy Text, Edit Existing Text, Unlock Text, Show / Hide Macro Text , Toggle Text On/Off ,
Align Text To String , Annotate Angles, Delete Overlapping Text, Replace Literal Text with
Macro Text, Enable Annotation of Selected Points, Associate Remark With Nearest Point or
Copy Text To GIS Attributes

Edit Text Annotation
This option allows text and other information on the selected points to be displayed.

Points in the model must be selected before the user can access this option. If no points
are selected when this option is selected then an error message will be displayed.

Display string graphics
String information for the selected point/s will be drawn in the model.
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Display segment direction
An arrow will be drawn on the selected string showing the direction in which it was
surveyed. This is especially useful when viewing traverse/station co-ordinates or prior to
generating sections.

Display E/X
The Easting or X value for the selected point/s will be displayed. The unit of measurement
is not displayed.

Display N/Y
The Northing or Y value for the selected point/s will be displayed. The unit of
measurement is not displayed.

Display Ht/Z
The Elevation or Z value for the selected point/s will be displayed. The unit of
measurement is not displayed.

Display point numbers
The survey point number of the selected point/s will be displayed.

Display string names
The string or feature name of the selected point/s will be displayed, at the first point on the
string.

Display chainage
This option displays the chainage of the selected point along an alignment.

Display offset
This option displays the offset of the selected point from an alignment.

Display remarks text
Freeform text input in the ‘Remarks’ column of the data logger when the selected point/s
were being surveyed, will be displayed. This remarks text can be found in the survey file
by viewing the ‘text notes’.

Display segment bearing
This option displays the whole circle bearing between the incoming and outgoing
segments of the selected. If individual points have been selected, the bearing is taken
between the current point to the next point on the string.

Display segment length
This option displays the gradient of the selected segment/s. If individual points have been
selected the length is taken between the current point to the next point on the string.

Display segment gradient
This option displays the gradient of the selected segment/s. The gradient will be displayed
as a percentage. If individual points have been selected the gradient is taken between
the current point to the next point on the string.

Display angle between segments
This option displays the clockwise angle between the incoming and outgoing string
segments. No angle will be displayed for point strings.

Display D1
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This option displays dimension 1 for the selected point/points. This value is taken from
the D1 field in the detail observation sheet.

Display D2
This option displays dimension 2 for the selected point/points. This value is taken from
the D2 field in the detail observation sheet.

Display D3
This option displays dimension 3 for the selected point/points. This value is taken from
the D3 field in the detail observation sheet.

Display Latitude
This option displays the latitude of the selected point/points. Please note that this will only
work, if the points have been surveyed using GPS.

Display Longitude
This option displays the longitude of the selected point/points. Please note that this will
only work, if the points have been surveyed using GPS.

Display Height
This option displays the height of the selected point/points. Please note that this will only
work, if the points have been surveyed using GPS.

Shortcuts

Create Text
This option presents the Create / Edit text dialog box.

Type in the text to add to the model. Then click on the model to insert the text. The user
may set the height, width, rotation and justification of the text in the dialog or interactively
when the text is inserted into the model. Font information for the text will be determined
by the current text style.
There is also the option of adding X,Y and Z co-ordinates (in text form) to the model using
the nearest and interpolation macros available. To do this, select X,Y or Z from either ‘Get
the nearest point’ or ‘Interpolate from model’. As the user moves the cursor about the
model, the text will be automatically updated, giving either the interpolated co-ordinates of
the point at the end of the cursor of the co-ordinates of the nearest point, depending on
the option selected. Left click mouse to position text. Ticking the ‘enable dynamic update’
option means that if at a later stage you have to move the text, it will be updated
automatically to display the co-ordinates of the new position.
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32.3.17 Symbols (Model Edit Menu)
This option allows symbols to be inserted and edited within the model.

The following options are available: Insert Symbols, Delete Inserted Symbol, Move Inserted
Symbol, Rotate Inserted Symbol, Resize Insert Symbols, Edit Inserted Symbol Details, Explode
a symbol or macroline, Unlock Symbol, Create New Symbol, Delete Symbols from Library,
Import Symbols Form File, Import Symbols From DXF, Export Symbol To File, Edit Symbols
Insert Points or Export Symbols to Model.

Insert Symbol
This option allows the user to insert a symbol in the model and to specify its size, position
and rotation. Selecting the option displays the ‘Create/Edit Symbol’ Dialog. Selecting any
of the ‘Apply..’ boxes allows you to edit this value with the mouse, otherwise values may
be entered directly into the dialog box. Pressing Apply, or the left mouse button inserts
the symbol in the model. Press Escape to finish this option.

Shortcuts

Delete Inserted Symbol
This option deletes an inserted symbol from the model. The user may either select this
option, and click on the symbols to delete, or, pre-select the symbols to delete and then
select this option. Press Escape to finish this option.

Shortcuts

Move Inserted Symbol
This option allows the user to move an inserted symbol with the mouse. Press the left
button to select the symbol to move, press it again to select a new position. Press Escape
to finish this option.
Note that this option only works for symbols inserted with the ‘Insert Symbol’ option.
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Shortcuts

Rotate Inserted Symbol
This option allows the user to rotate an inserted symbol with the mouse. Press the left
button to select the symbol to move, press it again to select a new rotation. Press Escape
to finish this option.
The user may also pre-select the symbols to give either a new fixed or relative rotation.
Note that this option only works for symbols inserted with the ‘Insert Symbol’ option.

Shortcuts

Resize Inserted Symbol
This option allows the user to resize an inserted symbol with the mouse. Press the left
button to select the symbol to resize, press it again to select a new size. Press Escape to
finish this option.
The user may also pre-select the symbols to give either a new height and width. If
anything is selected the following dialog will be displayed :

Note that this option only works for symbols inserted with the ‘Insert Symbol’ option.

Shortcuts

Edit Inserted Symbol Detail
This option allows the user to edit the symbol type, size, position and rotation for any
symbol inserted in the drawing with the Insert symbol option. Selecting the option displays
the ‘Create > Edit Symbol’ Dialog. Selecting any of the ‘Apply..’ boxes allows the user to
edit this value with the mouse, otherwise values may be entered directly into the dialog
box. Pressing apply, or the left mouse button updates the symbol in the model. Press
Escape to finish this option.

Note that this option only works for symbols inserted with the ‘Insert Symbol’ option.
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Shortcuts

Unlock Symbol
This option converts a symbol associated with a survey point, such a tree symbol, into a
symbol that may be edited with the edit symbol command.

Shortcuts

Create New Symbol
This option allows the user to apply a new symbol name.

Shortcuts

Delete Symbol From Library
This option deletes a symbol from the feature library either from a model or from a project.
This may be used to reduce the file size of the model and to allow the symbol name to be
re-used for a new symbol.

Shortcuts

Import Symbol From File
This option imports selected symbols from external ‘.VectorSymbol’ files into the current
model or project. These include the standard symbols shipped with SCC and any other
symbols exported using the Export Symbols to File option.
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Import Symbol From DXF
This option imports symbols from a DXF file. The symbols are attached to the project
template. Feature library symbols may be drawn in CAD or MicroStation.

Export Symbol To File
This option exports all the SCC symbols from the current project to a external
‘.VectorSymbol’ files. These files such that can then be imported into other SCC projects
and models.

Edit Symbol Insert Points
This option allows the user to edit the insertion points, which correspond to the survey
points, for existing symbols. Each symbol has a set of insertion points for insertion by 1, 2
or 3 points.

When creating insertion points for 2 and 3 point symbols, it is recommended that to use
either a horizontal or vertical base line, such that SCC can easily mirror the symbol where
negative dimensions are used, or where the third point lies on the other side of the first
two points from the defined third point. This is done by specifying a horizontal or vertical
base line.
Symbol coordinates are always normalized to the range of –0.5 to 0.5, such that symbols
have an origin of 0,0, and are 1 unit wide. Symbols imported from DXF will be normalized
and centred into this coordinate range, and as such, may require modification to their
insert points.
Use the snap function to ensure that the insert point lies on an exact surveyed point on the
symbol.

Explode a symbol or macroline
This converts all the line work that made up the symbol or macroline into editable strings.

Export Symbols to Models
This option exports all the SCC symbols from the current project to a model. This can be
useful for editing and creating new, similar symbols, and for exporting symbols to other
systems such as 3D studio .3DS
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32.3.18 Line Types (Model Edit Menu)
The following options are available: Import Line Types From File, Import Line Types From DXF,
Export Line Types To File and Delete Line Types From Library

Import Line Types From File
This option is used to import line types from SCC LINETYPE files into your current project
or model. These may then be used within the feature library to draw those line types.

Import Line Types From DXF
This option is used to import line types from a DXF file into a SCC project or model file.
These may then be used within the feature library and / or export to SCC LINETYPE files
for use elsewhere. This option can be used to import all simple line types and complex
line types containing embedded text.
Note that this option cannot be used to import complex line types containing embedded
shapes, as these are dependent on shape files that are external to both DXF and DWG
files. To create more complex line types in SCC, such as macrolines and lines with
embedded symbols.

See Also
Symbology Feature Library
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Export Line Types To File
This option is used to export line types from a project or model into SCC LINETYPE files,
such that they can be imported into other projects and / or models.

Delete Line Types from Library
This option is used to permanently delete line types from a project or model.

32.3.19 Bitmap (Model Edit Menu)
The following options are available: Insert Bitmap, Move Bitmap, Delete Bitmap and Resize
Bitmap.

Insert Bitmap
This option inserts a windows bitmap (.BMP) file into the model in a given location and to
define its size and aspect ration. This option can be used when creating sheet layouts,
where bitmap information, such as company logo, are required on the sheet.

Move Bitmap
This option moves a bitmap created with the insert bitmap option. Press the left mouse
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button on the bitmap to select it, then move the mouse and press the left button again to
select a new location.

Delete Bitmap
This option deletes a bitmap created with the insert bitmap option. Press the left mouse
button on the bitmap to delete it.

Resize Bitmap
This option resizes a bitmap created with the insert bitmap option.
Press the left mouse button on the bitmap to select it, then move the mouse and press the
left button again to select a new size.

32.3.20 Slope Lines and Hatching (Model Edit Menu)
The following options are available: Slope Lines Between Strings, Slope Lines Using Reference
String, Hatch A Polygon and Hatch Between Strings.

Slope Lines Between Strings
This option allows the user to add slope lines or hachures between two strings.
The first method requires the user to select two strings, and generates slope lines
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perpendicular to the first string selected.

32.3.21 Browse Model Points (Model Edit Menu)
The browse model option allows the user to simultaneously view the model in graphical and
spreadsheet format.

Selecting a point on the graphics will update the spreadsheet position, similarly selecting a
point in the spreadsheet will re-center the graphics around that point. Most graphical editing
tools will also work while browsing the model, additionally search and replace, and global
editing operations are available while in this model.
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If the user makes a change to the spreadsheet view while browsing, ‘Update Model’ must be
selected to see these changes reflected in the graphics. Any graphic editing is automatically
reflected in the spreadsheet.

Shortcuts

32.3.22 Query and Edit Points (Model Edit Menu)
This option allows the user to query and edit survey information by simply using the mouse
device to bring the screen cursor close to the point in question. The cursor will snap on to the
nearest survey point. This facility may be used to query and edit any information relating to this
point.
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When editing data, it is important to make all changes to survey information, that is, station coordinates, station set-ups, and observations, prior to editing co-ordinate values directly. The
reason for this is that any co-ordinate editing that has been done to a survey will be lost if the
co-ordinates are rebuilt from the survey observations. If the option to search for multiple points
enabled in the Snap Lock dialog box, a list of points within the given within the search radius.
The ‘Query and Edit points’ menu contains the following options;
Feature Library, Detail Coordinates, Detail Observations, Instrument Set Up, Station
Coordinates,

Feature Library
Selecting this tab, allows the user to view and edit the feature library entry associated with
the selected point. This dialog can be used to change colour, line-style, symbology etc of
the current point and any point in the model with the same feature code.
The user can also access the annotation settings of the selected feature from this dialog.
Selecting the ‘Text Annotation>>’ button brings up the following dialog;
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The following items of annotation that can be displayed in the model;

Display
This field specifies whether or not the associated text will be displayed in the drawing for
this particular feature or whether it will follow configuration defaults.
The Display field has 3 possible options:
Default
Text On
Text Off

Height
This is the height of the associated text, it requires that the plot scale be entered in order
to operate correctly. The paper units specified in the General Options determine the units
used in this field

Width
This is the width of the associated text, it requires that the plot scale be entered in order to
operate correctly. The paper units specified in the 'General Options' determines the units
used in this field.

Colour
This is the colour of the associated text, the default being black.

Xofs
The value entered in this column determines the amount that the associated text is offset
from the surveyed point, in an east/west direction. The paper units specified in the
'General Options' determines the units used in this field.

Yofs
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The value entered in this column determines the amount that the associated text is offset
from the surveyed point, in a north/south direction. The paper units specified in the
'General Options' determines the units used in this field.

Justify
This option aligns or justifies the survey point with the associated text. For example, 'left
top' means that the survey point is to the top left corner of the associated text.
The following options are available:
Left Top

Left Centre

Left Bottom

Centre Top

Centre Centre

Centre Bottom

Right Top

Right Centre

Right Bottom

Prefix
The user can enter text that will prefix the text. For example, entering CL (cover level) in
the prefix column associated with level text will display 'CL100.98'.

Suffix
The user can enter text that will suffix the text. For example, entering IL (invert level) in
the suffix column associated with the level text will display '100.98IL' or a suffix of m
(metre) '100.98m'

Alignment
This option determines how text placed for this feature will be aligned within the model.
The following options are available:
Options

Description

String

Along String

H Sheet

Horizontal to Sheet

H Grid

Horizontal to Grid

V String

Normal to String

V Sheet

Vertical to Sheet

V Grid

Vertical to Grid

R String

Along String (Upside Down)

RH Sheet

Reverse Horizontal Sheet (Upside Down)

RH Grid

Reverse Horizontal Grid (Upside Down)

RV String

Reverse Normal to String

RV Sheet

Reverse Vertical Sheet

RV Grid

Reverse Vertical Grid

Priority
This option allows the user to prioritise text and works in conjunction with the 'Delete
Overlapping Text' Option in the 'EDIT > Text' Menu. Any value between 0 and 100 can be
entered and where two pieces of text overlap, the one with the lowest priority number will
be deleted.

Characters
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This controls the maximum number of characters in the displayed field.

Decimal
This value determines to how many decimal places the text will be displayed.

Style
This field contains the line styles used for all lines drawn when defining this feature. This
can include simple and complex user defined line styles, comprising of dashed, dots, and
embedded text.

Layer Prefix
This is a prefix added to the features layer name for this annotator, when outputting to
CAD. For example, 'AM_ROAD'

Layer Suffix
This is a suffix added to the features layer name for this annotator, when outputting to
CAD. For example, on elevations, this defaults to ‘_LVL’. This would mean that if the
road line-work went on the layer ‘ROAD’ the road elevations would appear on
‘ROAD_LVL’.

Interval
This field determines the interval at which the text annotator is placed on the survey string.
This can be the first point only, the end points, all points on the string, or points at a
regular interval. For example, the feature name would generally only be annotated at the
end points of a string, whereas the elevation is likely to be required at all points.

Point Count
Where points are being annotated at a regular interval, this field determines the interval.
For example, a value of 2 would annotate every second point on the string.

See Also
Feature Library (View menu)

Detail Coordinates
Selecting this option allows the user to edit the co-ordinate record for the selected point in
the model. It there are detail observations for the point they should be edited where
possible instead of the coordinate because if the model is rebuilt the changes made to the
coordinate file will be lost.

See Also
Detail Coordinate (View Menu)

Detail Observations
Selecting this option allows the user to edit the observation associated with the current
point. Modifying the observation will require the associated survey to be re-coordinated
and the model to be rebuilt. If the coordinate file was not formed from a detail survey then
this option may not be used.

Instrument Set-Up
Selecting this option allows the user to edit the station set-up details from which the
current point was fixed. Modifying the station set-up details will require the associated
survey to be re-coordinated and the model to be rebuilt. If the co-ordinate file was not
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formed from a detail survey then this option may not be used.

See Also
Instrument Set Up

Station Coordinates
Selecting this option allows the user to edit the station control co-ordinate from which the
current point was fixed. Modifying the station control co-ordinate will require the
associated survey to be re-co-ordinated and the model to be rebuilt. If the co-ordinate file
was not formed from a detail survey then this option may not be used.

GIS Attributes
Additional attribute information can also be viewed within the Query & Edit Dialog.

32.3.23 View Coordinate Computations (Model Edit Menu)
This dialog stores the results of calculations carried out using the edit strings options and the
measurement options. If this dialog is not opened the calculations will not be stored to it.
Output sends all the calculations to an output file. Clear deletes everything in the current
dialog.
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For example, to add the intersection point of two strings to one or both of those strings, use the
‘Intersect’ tool with snap lock on to compute the intersection. The resultant computed
coordinate will be placed in the ‘Coordinate Computations Results’ Window. Then select the
‘Insert Point onto String Tool’ and select one of the strings, and select the intersection point
displayed in the ‘Coordinate Computations Results’. Press ‘Output’ in the ‘Coordinate
Computations Results’ Window to insert the point in the string. Repeat this process for the
second string if required. Note that all model tools that compute coordinates place their results
in the ‘Coordinate Computations Results’ window such that they may be used in place of
mouse selections for any other model operations.

32.3.24 Offset Height of Selected Points (Model Edit Menu)
This option is used to change the elevation of either the selected points, or, no points are
selected, the entire model.

The function can be used to either shift the points to a fixed elevation, or to offset the elevation
of the points by a given amount. This function is particularly useful when elevation changes to
survey stations are made after a model has undergone editing. In this case, use the advanced
options in the data select dialog to select all the points from a given station prior to using this
option. Further options are for use with an attached 'Reference Model' ('FILE > Attach/Detach
> Attach Model File')

32.3.25 Update Model Elevations from Survey (Model Edit Menu)
This option is used to replace heights in a model with heights from the original data set that
created that model. This allows the user to overcome potential errors in height offsets, rod
heights, and benchmark changes that are discovered late in the editing process. It provides
the advantage that the model heighting can be changed without having to re-process
cartographic and topographic edits.
This option may be used with or without pre-selection of points. If no points are selected, the
option will be applied to the entire model. If some points have been selected, the option will be
applied to those points only. Note that this option works best either with associative level text
or level text macros.

32.3.26 Edit Extra Text Fields (Model Edit Menu)
This option allows the user to set user defined text macros in models, sheet layouts,
reports and projects.
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The Add button can be used to add pairs of field name and value records as shown. In a
model or sheet layout, these fields appear in the extra macro column, with the prefix ATTR as
shown below;
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Extra text fields are saved and loaded as part of the project template, along with the
feature library, line styles, symbols, etc... This means that if the extra fields added to a
project, those fields will be available to any models created from that project. Thus if
standard fields exist which are required by the surveyor to complete for each model,
such fields should be added to the project template, so that they appear in sheet layouts
and can be completed by surveyors on individual models. These fields are also
exported when running reports, such that they are available for report titles, etc..
32.3.27 Insert New Object (Model Edit Menu)
Inserts and embeds an object, such as a chart or an equation in a document. The application in
which the object was created becomes active on the screen. The SCC File menu will remain
active.

The following options are available:
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Create New
A new blank object is inserted into the current document. When you double click on the
object or the icon the program in which the document was generated is opened. When
the object is selected the top menu bar is changed to that of the program in which the
object was created. The only menu that does not change is the File menu.

Create from File
An existing object is inserted into the current document. Double click on the object or the
icon and it may be edited in the program in which it was generated. There is an option to
create a link between the inserted object and the original document. If the file is linked to
the current document changes to the object will be reflected in the current document.

Display As Icon
If this option is turned on the object will be inserted as an icon. When the icon is double
clicked the document is opened in its source program.

32.3.28 Object (Model Edit Menu)
The option allows the user to Select the object by clicking on it and the following options are
activated.

Display Content
Display the object in its original format. This option is used if the object is currently
displayed as an icon.

Display Icon
Displays the object as its source program icon. This option is used if the contents of the
object are currently displayed in the active SCC document.

Reset Size
Change the size of the object or the icon representing the object in the current document.

Clone
Make a copy of the current object

Delete
Delete the object from the current document
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32.3.29 Links (Model Edit Menu)
This option list and edit links to embedded documents.

32.4

Model View Menu

32.4.1 Feature Annotation (Model View Menu)
This option allows the user to turn on or off and edit features in the model. There are default
entries, which are the basic model features. These will always be prefixed with ‘~’. Features
without this sign will be features specific to the current project.
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When this option is used with literal text or macro text annotation, it does not add or remove
any text items, it merely shows or hides existing annotation. This option does not modify the
model feature library unless the ‘Edit Feature’ option is selected. To add or hide annotation for
selected points, use 'EDIT > Text > Edit Text Annotation' as before, or 'EDIT > Text > Redraw
string annotation' to do this en-mass for using feature library settings. To permanently delete
text, use the 'Delete Text' option, which can also be used with pre-selection to delete large
amounts of text.
Turning off remarks using the facilities above merely hides the remark, such that it can be
turned back on. Delete Text will permanently delete it.

Mark All
Highlights all features in the list.

Reset All
De-selects any highlighted features.

Edit Feature
Edits the currently highlighted/selected feature. If a change to a feature is made on this
sheet the feature library spreadsheet will be simultaneously updated.

Display String
This switch defines whether cartographic map data for the selected feature/s, such as
trees, walls, fences etc. will be displayed.

Display Elevations
This switch defines whether text will be placed for nominated spot elevations.
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Display Point Numbers
This switch defines whether the point numbers of the selected features will be displayed.

Display String Names
This switch defines whether the feature name of the selected strings will be displayed.

Point Justify Level Text
This option allows you to align the decimal point of the elevation text over the surveyed
point. This forces the elevation text into a mono-spaced font in both SCC and CAD, which
may occupy slightly more display space that a normal font.

Level Symbols
This switch defines whether an additional symbol is placed for every survey point in the
triangulation. This is useful for identifying points on strings and passing level data to other
systems.
None
Single Point
Circle
Cross

Symbol Scale
The user can set the scale of the level symbol being applied.

32.4.2 Titles And Grids (Model View Menu)
This option allows selection of plot scale and primary grid and secondary grid. The 'Titles and
Grids' dialog is also used in conjunction with the creation of sheet templates. The information
entered in this dialog will be used to update the corresponding data in the inserted sheet. The
displaying of grids in a model does not use the display cache, as very large grids caused
significant extra memory usage with minimal speed benefits.
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Note that primary and secondary grids are drawn using the ‘~GRID’ and ‘~GRID2’ features
respectively. These features may be modified to add suffixes and prefixes to grid annotation,
and to orient annotation text. Any of the reverse text alignments will allow the grid text to be
inverted.

Clip grid to sheer limits in model view
With this option selected, SCC will minimise the gird limits in model view based on X and
Y values in the model.

Extend grid limits
This option allows the user to specify limits in North, South, East and West direction.

Shortcuts
Toolbar:

Keys:

ALT + V, G

32.4.3 Contours (Model View Menu)
SCC provides options to produce an extensive range of both line contours and relief bands or
solid contours.
Line contours may be drawn either as straight lines or use one of a variety of curve fitting
algorithms. These include cubic and quadratic b-splines suited to cartographic work, and
Catmull-Rom curves better suited to engineering work.
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All the contour threading honours all the points interpolated on the triangle edges but the
Catmull-Rom contours more closely follow the straight line contours which is the strict contour
delineation according to the data set. However, the modification and error propagation brought
about by the curve fitting would normally be of a much lower order than that which would be
inherent in the physical point selection density, the definition of breaklines, the systematic
errors from data acquisition instrumentation etc.,

Solid contours or relief bands provide a useful backdrop to a model showing a good overall
impression of the shape of the terrain. SCC provides a variety of solid contouring options
suitable for both 16 and 256 colour displays. These options provide facilities for highlighting
elevation, gradient or a combination of both. Neither solid or line contours in SCC have any
storage overhead in terms of disk space or memory. This is not the case, however, with most
CAD packages. As such, it is wise to turn off solid contours when outputting to CAD unless
they are specifically required. 256 Colour banding is particularly unsuited to most CAD
packages due to the number of CAD entities required for its representation.
The contour menu provides the following options;

Contour Interval
Regular
This is the vertical distance at which interval contour lines are drawn. Large numbers of
contours are liable to slow down screen redrawing time and increase the size of any CAD
files produced.

Index
This is the vertical distance at which highlighted main contour lines are drawn. This value
must be a multiple of the regular contour interval.

Relief
This is the vertical distance at which solid contour lines are drawn.
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Automatic Labelling
This option allows the automatic labelling of contours dependent on the fields you select.
The user may label all contours, index only or none at all.
The user may select whether or not to label the end points of each contour or at regular
intervals along the contour line. The interval value is entered by the user and the
alignment of the contour text can be set by going to the advanced options and editing the
relevant contour feature.
It must be noted that the automatic labelling of contours will not work on quick screen
contours. This option does not effect the ‘label contours’ option in the EDIT menu.

Maximum Gradients
This option allows the user to set the maximum gradient for displaying regular or index
contour. This is particularly useful in very steep areas where contours are tight and the
user may not wish to display all the contours at the selected interval.

Linear Contour Type
This option allows the user to create linear contours from the triangulation and specify the
type of contour that will be created. These may be either straight-line contours or curved
contours.
A number of curve types are supported, while they are more aesthetically pleasing they
are slower to draw on screen, make for larger CAD files and are slightly less accurate for
engineering purposes than straight line contours. Of the curved contours the splines give
the most aesthetically pleasing curves, while the Catmull-Rom curve fit is closer to the
planar triangular surface.
All curved contours will revert to straight lines in areas where they cross break lines or
encounter extreme grade changes. Therefore when roads, for example, are crossed by
contours then these revert to straight lines because of the kerb lines, road centrelines etc.
This realistically reflects the angularity of contours defined by hard or manmade surfaces.
Straight-line contours are good for production of efficient and accurate draft drawings. TSplines have the advantage over Catmull-Rom curves that they can be used to accurately
render conics including circles, arcs, ellipses, hyperbolae and parabolas. As such, they
may prove useful when surveying roundabouts, prefabricated kerbs etc. The downside is
they tend to be less smooth than Catmull-Rom curves for irregular data and tend to
highlight any noise in the input data. Quick screen contours should be used in place of
straight line/curved contours when working on the screen. The contours can be changed
to curves just prior to exporting to CAD. This increases speed of operation within SCC.

Solid Relief Contours
This option allows the user to create solid relief contours from the triangulation. These
contours show areas of given elevation ranges as solid colour bands.
Relief contours are useful for visualising a surface and / or representing special models
such as isopachytes, isotherms, hydrographic data etc. Solid contours may be combined
freely with line contours. 256 colour contours are only available on screens that support
this number of colours - VESA compliant screens, for example. Continuous colour bands
have the visual effect of smoothing the surface to the eye. As such, they are very useful
for illustrating non-terrestrial surfaces, such as pollution level or thermal surfaces, where
the 'Z' value in the surface is of a lower order of accuracy than the plan position.
The slope high-lighted relief contours have the reverse effect. They are very useful for
visually depicting terrestrial surfaces, particularly in highlighting potential problems in the
surface as shown in the picture at the start of this chapter. High-low contours divide the
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surface into areas above and below a datum point. Areas above the datum point are
coloured from green to red in order of height above datum. Areas below the datum are
coloured from light blue to black according to depth below the datum. High - low contours
are always autoscaled and are primarily useful for coastal surveys.
Auto scaled contours divide the range of levels in the model by the number of available
colours in order to produce the contour interval. It is important when using solid contours
that the elevation ranges corresponds to those in the model. Otherwise the range (1000m to 1000m) over which the colours (16 or 256) will be spread over too wide a range.
Solid contours, particularly 256 colour solid contours, will generate very large files when
output to CAD.
There is also the option to set up a user defined solid relief band where the user defines
the colours for specific elevation ranges. User defined color relief schemes may be saved
and re-used as required (example below).

User Defined Contour Bands
This options allows a unique relief scheme to be set up, based on intervals and colours
specified by the user.
The relief scheme can be set up in two ways.
A) Creating a Relief Scheme with regular intervals using the ‘Add elevations/colour
range’ option
To create a relief scheme where the elevation ranges are based on regular intervals, it is
best to use the ‘Add elevations/colour range’ option. The user can enter the lowest
elevation value in the ‘From’ box and the highest value in the ‘To’ box. Then specify the
interval value and colour range, hit the ‘Create’ button and SCC will do the rest. To set up
ranges of different colour bands, this procedure will need to be repeated until the last
value entered in the ‘To’ box is the highest point of elevation required.

32.4.4 Slope Analysis (Model View Menu)
The slope analysis options in SCC highlights areas of the model within specified slope or grade
ranges. They also include a facility to place an arrow on every triangle showing the direction
down hill, these are referred as slope vectors. Applications for slope analysis include drainage
design, landscaping, and general cartography. Slope vectors make it easier to distinguish a
hollow from a hill on a contoured plan drawing, as can be seen from the picture above depicting
a bunker on the edge of a golf course green.
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Slope analysis menu provides the following options;

Slope Vector Magnification
This value contains the magnification factor used when displaying slope vectors. A value
of one ensures that vectors will not cross for slopes up to 90 degrees. Greater values
may be used to display larger vectors or arrows for smaller inclinations.

Minimum Annotation Gradient
This value contains the smallest vertical angle for which slope vectors will be displayed.
Slopes with smaller inclinations will not be displayed as vectors. This facility is useful to
speed up display of slope data and reduce the total CAD file size.

Show Slope Vectors
This option displays a vector or arrow for every grade change within the triangular surface.
The vectors generated points in a downhill direction and are scaled by the length and
grade of the triangle. This feature is useful for drainage design and general topographic
slope annotation.

Colour Triangulation By Gradient
This option colours the surface according to the absolute grade of each triangle.

First grade change
This is the minimum grade change that will be used in the slope analysis. Slope vectors
less than this value will be coloured in black. Slope vectors may be entered either as
vertical angles or as grades. For example, a forty-five degree slope could be entered
either as 45 or as =1:1.

Second grade change
Grades between this value and the previous value will be coloured in dark grey.

©2015 Atlas Computers Ltd

813

Third grade change
Grades between this value and the previous value will be coloured in dark blue.

Fourth grade change
Grades between this value and the previous value will be coloured in light blue.

Fifth grade change
Grades between this value and the previous value will be coloured in dark green.

Sixth grade change
Grades between this value and the previous value will be coloured in light green.

Seventh grade change
Grades between this value and the previous value will be coloured in dark cyan.

Eighth grade change
Grades between this value and the previous value will be coloured in light cyan.

Ninth grade change
Grades between this value and the previous value will be coloured in light grey.

Tenth grade change
Grades between this value and the previous value will be coloured in magenta.

Eleventh grade change
Grades between this value and the previous value will be coloured in dark brown.

Twelfth grade change
Grades between this value and the previous value will be coloured in dark red.

Thirteenth grade change
Grades between this value and the previous value will be coloured in light magenta.

Fourteenth grade change
Grades between this value and the previous value will be coloured in light red.

Fifteenth grade change
Grades between this value and the previous value will be coloured in yellow.

Sixteenth grade change
This is the maximum grade used within slope analysis. Grades between this value and
the previous value will be coloured in white.
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Shortcuts
Toolbar:

32.4.5 Triangulation (Model View Menu)

Active Triangles
This option displays the feature name for the active or valid triangles and provides an
option to display them on screen. There is also an option to edit the feature. This will
present the Feature Library Entry sheet. Any updates carried out here will be
simultaneously made to the corresponding entry in the feature library spreadsheet.

Inactive Triangles
This option displays the feature name for inactive or invalid triangles and provides an
option to display them on screen. There is also an option to edit the feature. This will
present the Feature Library Entry sheet. Any updates carried out here will be
simultaneously made to the corresponding entry in the feature library spreadsheet. The
inclusion of the legitimate model in CAD for rendering purposes is achieved by having the
valid triangular facets turned on and the invalid facets turned off.

Breaklines
This option displays the feature name for breakline data and provides a switch that defines
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whether surface model breaklines will be displayed on screen. This can be useful for
showing which strings have been used as breaklines. It is also useful for showing string
information for models, such as isopachyte models, that do not have associated survey
information. However, when switched off these lines which do not represent hard
planimetery on the ground will not appear in the CAD system. Breaklines are normally
from lines taken for the purposes of constructing the folding characteristics in the terrain
surface.

Breakline Intersections
This option displays the feature name for breakline intersection data and provides a switch
that defines whether they will be displayed on screen. This may be useful for detecting
possible errors in the triangulation and hence contouring.

Duplicate Points
This option displays duplicate points. The feature for duplicate points, ~DUP_PNT, has a
circle as a symbol. Circles are drawn around both points, which makes them easily
identifiable.

Model Co-ordinate Ranges
This option allows specification the minimum and maximum X,Y,Z values. These values
must be set before creating the model so as to be effective when transferring the data. If
the model is already created and these values are changed the model must be rebuilt for
the changes to have any effect. It is useful for example when triangulating a drawing input
from CAD that contains text and graph information. This information is not desired in the
triangulation. It is given a Z/Ht value of 0 by the CAD system. Change the ‘Minimum Z’
value to a value higher than 0 and this information will not be input into the model or if
rebuilding the model, it will be deleted from the model.

Report Breakline Intersections
This field specifies whether an error report will be produced for all points introduced due to
breakline intersection. If this switch is turned on the co-ordinates of all such intersections
will be appended to the file LOGFILE.PRN.

Breaklines imply grade change
This field specifies whether the triangulation algorithm checks for contours and flat spots
in its input data. The Delaunay criterion for Triangulation will form the most equilateral
triangles for a given data set. This algorithm is modified to force triangle edges to be
influenced by the selection of breaklines in the field. However, deformation of the model
surface may still occur. SCC is capable of repairing this deformation automatically. If this
switch is set to 'yes' the system will make additional checks in order to remove flat areas
caused when triangulating contour and string data. This is done by assuming that all
breaklines imply a grade change. Note that the breaklines and design contours are
honoured in both cases although the two surfaces produced are quite different.
This switch is turned on by default. If you are modeling data that includes large numbers
of contour strings, it is essential that this facility is alive. Visual comparison of the surface
profiles highlights the significance of this deformation and the likely impact on design,
surface contouring, surface profiles, cross-sections and volumes determination.

Triangulation Method
SCC supports two methods of triangulation. 'Delaunay' or '3D Nearest Neighbour' may be
selected depending on the requirements of the data set under consideration. Generally
the final model produced by either method for a given data set will be almost identical.
Delaunay triangulation forms the set of most equilateral triangles for a set of points. As
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such it is deciding the final triangulation based on a purely 2 dimensional criterion and
then adding elevations to form a surface. As a rule it normally gives the most even spread
of triangles, and hence interpolation results, particularly in areas where data is sparse. 3D
nearest neighbour joins every point to all its nearest neighbours while not allowing any
edges to cross. While not providing as even a spread of triangles as Delaunay, the
triangulation is being weighted on a 3D criterion. This may often be more suitable for
surfaces where strings have not been surveyed and points are being selected randomly
from the surface, for example, for bathymetric work. This is because triangle edges will
form more along contours than across them, hence finding the equivalent of natural
strings.

Breakline Densification
This field specifies whether additional points will be inserted in each breakline at a given
interval. Densifying breaklines increases the overall model size while improving the quality
of triangulation around breaklines. Densification may be used in situations where long
breaklines have been surveyed, and additional triangles are required on these breaklines
N.B. Breakline post-processing will ensure that a minimum number of points will be added
to breaklines in order that those breaklines are honoured in the model.

Max. segment length
This field specifies the maximum length that a breakline segment will be. If a segment is
longer than this it will be broken down into a series of smaller segments. It is only used if
the 'Densify breaklines' switch is turned on.

Max vertices in point string
This option specifies the maximum number of vertices that are allowed in a single point
string before splitting it into a number of point strings. Limiting the size of point strings can
speed up drawing times in large models. Set this option to a very high number if you are
exporting your model to MX/MX and do not wish to subdivide point strings.

Filter Points outside boundary model
This option is used when creating models from one or more very large datasets, where
only a subset of the input data is required. For example, when modeling a road corridor
that spans a series of Ordnance Survey digital elevation models. In this case, first make a
model of the boundary area, outside of which points are to be excluded, and select this
option and the boundary model prior to creating the main model.

Max. Breakline cycles
This field contains the maximum number of iterations applied when post-processing
breaklines in a triangulation. Breakline post-processing involves adding points to a
breakline wherever it intersects a triangle in plan. In certain cases, such as where two
parallel breaklines are close together it may be necessary to perform this operation more
than once.

Vertical resolution
This field specifies the vertical resolution to which the data will be modeled. For example,
if this field contains 0.005 (5mm) all level data within the model will be rounded to the
nearest 5mm. This has the effect of removing surface 'noise' and hence smoothing
contours and profiles.

Horizontal resolution
This field specifies the horizontal resolution that the data will be modeled to. For example,
if this field contains 0.005 (5mm) all plan data within the model will be rounded to the
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nearest 5mm. This has the effect of removing surface 'noise' and hence smoothing
contours and profiles.

Very Large Model (>100,000 points)
This field specifies whether the size of model being formed is very large for the machine
being used. If this is the case, the system will minimize its use of memory in order to allow
more memory for the model being generated. This will increase model generation time
but allow generation of larger models.

Disable local re-triangulation
Disabling local triangulation greatly speeds up string editing operations on large models
where a lot of editing is required. Changes may be reflected in the triangulation either by
re-enabling local triangulation or by selecting the rebuild model option.

Apply max link lengths from feature library
Selecting this option uses the ‘Max Len’ field in the feature library to determine the
maximum link length between consecutive points on a string for a given feature. If a link
for the given feature exceeds this length, it is automatically broken as part of the modeling
process. This can eliminate a significant amount of model editing in situations where
strings in the input survey data have not been properly terminated.

Allow open 'Void' and 'Clip' Polygons
Selecting this option allows non-polygonal strings, that is open strings, to be used as ‘Clip’
and ‘Void’ polygons. This can be useful in isopachyte volumes, where boundary strings
are not included in their entirety in the overlapping area between two models. In contrast,
it can also lead to problems, in other isopachytes, where a single clip polygon string is cut
up into multiple clip polygons. In the latter case, this option should be disabled.

Disable automatic screen refreshing during editing
This option disables automatic screen updating during the editing process. It is provided
to speed up editing of large models on slower machines. Press the space bar to manually
refresh the screen when using this option.

Disable regular grid input optimization
SCC typically checks model input data for point a string that contain regular grids, and,
where it finds them, optimizes the triangulation process as a result. This can slow down
the triangulation of non-grid based models, and can therefore be disabled.

Do not include survey records in model query
Selecting this option prevents the ‘Query and Edit’ function from accessing any survey
datasets that were used to create this model. When selected, ‘Query and Edit’ will be
restricted to displaying feature library and detail coordinate entries only, both of which are
taken from the model.

Enable fast boundary polygon processing
This option speeds up the processing of boundary polygon.

Shortcuts
Toolbar:
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32.4.6 Grid Mesh (Model View Menu)
This option creates a 3D-grid mesh over the model. When the model with a grid mesh is
output to CAD Hidden Line Removal may be used to create 3D image of the model. Selecting
this option opens the Grid Mesh dialog.

X Interval
The grid will be displayed along the X-axis at this interval.

Y Interval
The grid will be displayed along the Y-axis at this interval.

Feature
This is the name by which the Grid Mesh will be referred to in the Feature Library.
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32.4.7 Snap Controls (Model View Menu)
This option allows setting the mouse to snap onto different elements in the model.

The snap selection may be changed in the middle of a command. For example, if adding
points the user snaps to grid and in the middle the user wishes to snap to a feature, the snap
control can be changed to ‘Nearest point’ and allow the user to continue with the previous
command, ‘Adding strings with cursor’. Note when snapping in a rotated view point, Z Snap
for new strings should be set to Interpolate elevation from model.

Snap Lock
This field has the following options;

None
This option turns snap off.

Nearest Point
This option snaps to nearest point.

Nearest DTM Point
This option snaps to the nearest 3D point.

Nearest 2D Point
This option snaps to the nearest 2D point.

Grid Position
This option snaps to a grid point.

Midpoint snap
This options snaps to the midpoint of the line segment nearest the cursor.
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Perpendicular (to string)
Snap perpendicular to existing string can be utilised when creating new strings. This
snaps to a point on the existing string nearest the cursor perpendicular to the last point
created.

Perpendicular (current string)
Snap perpendicular from current string can be utilised when creating new strings. This
snaps the cursor position to a line perpendicular to the last two points created.

Design grid (Chainage/Offset)
This snaps the cursor to the nearest multiple of chainage and offset entered on the
currently active alignment. This option requires the alignment option to be licensed in
order to work.

Grid Interval
This option allows selection of the grid interval, which will be snapped to, if the grid interval
option is selected.

Overlapping Point Selection
Selecting this option allows the user to alter the method by which SCC selects points.
This may either be by selecting the point nearest the cursor, or, by selecting a point from a
list of points within a specified distance of the cursor. The user is presented with a dialog
containing the following parameters;

Enable search for multiple points
This switch defines whether an option to select a point from a list of all points within a set
distance of the cursor is enabled. This facility allows the user to access points that may
have the a similar or identical plan position

Search Radius
This field contains the horizontal search distance used when selecting points on screen. It
is a radial distance from the current mouse position.

Z snap for extend
The following options are available when using the Extend command:
· Use elevation of extended survey points
· Project gradient of extended survey line
· Interpolate elevation form 'extend to' line
· Interpolate elevation from model
· Use average of survey point and 'extend to' line

Z snap for trim
The following options are available when using the Trim command:
· Interpolate elevation form trimming line
· Interpolate elevation from line being trimmed
· Use average elevation
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· Interpolate elevation form model

Z snap for new strings
The following options are available for New Strings:
· Interpolate elevation form model
· Use fixed value

Round distances on new strings
This option can be utilised when creating new strings or adding to an existing string to
ensure that the length of a given segment will always be a multiple of the specified snap
value.

Display snap controls before trim & extend
When this option is selected, the 'Snap Control' Dialog will be presented after the 'Trim' or
'Extend' command has been selected.

Shortcuts
Pressing ‘S’ in the model view will toggle ‘Snap to Points’ on and move between snap
modes.
Pressing ‘N’ in the model view will turn snap off.
Pressing ‘G’ in the model view will toggle ‘Snap to Grid’ on and off.
Pressing ‘M’ in the model view will toggle ‘Overlapping point selection’ on and off.

32.4.8 Coordinate Computations (Model View Menu)
This dialog stores the results of calculations carried out using the edit strings options and the
measurement options. If this dialog is not opened the calculations will not be stored to it.
Output sends all the calculations to an output file. Clear deletes everything in the current
dialog.

For example, to add the intersection point of two strings to one or both of those strings, use the
‘Intersect’ tool with snap lock on to compute the intersection. The resultant computed
coordinate will be placed in the ‘Coordinate Computations Results’ Window. Then select the
‘Insert Point onto String Tool’ and select one of the strings, and select the intersection point
displayed in the ‘Coordinate Computations Results’. Press ‘Output’ in the ‘Coordinate
Computations Results’ Window to insert the point in the string. Repeat this process for the
second string if required. Note that all model tools that compute coordinates place their results
in the ‘Coordinate Computations Results’ window such that they may be used in place of
mouse selections for any other model operations.

32.4.9 Plan (Model View Menu)
This option changes the view point back to plan, i.e. model viewed from above, and switches
back to model view if in the feature library.
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32.4.10 Rotate Viewpoint (Model View Menu)

These options allow you to work in arbitrary display axes, and support creation and editing of
strings on the current display plane. For example, copy parallel in an elevation copies the
string up/down and forward back relative to the elevation rather than plan. This also allows
creation of circles, arcs, rectangles etc.. on a given plane. This option also supports interactive
3D rotation by dragging the mouse, as well as stepped rotation using the view point dialog.
The option to allow setting a view point origin and orientation using the mouse and keyboard
has been made optional, such that those primarily working in plan can't inadvertently change
their viewpoint. This is controlled within 'FILE > General Options > Units & Data Checking >
Allow mouse to be used to rotate'
The option automatically save viewpoints whenever the dialog is closed and allows selection of
a range of angle increments from a drop down list.

Rotation Origin
The user can either enter or pick from the screen a X, Y and Z point on which to rotate the
model. The origin point is displayed as part of the cursor.

Axis Angles
The user can use the axis buttons to manually rotate the model along either axis or enter
an angle.

Saved view point
This option allows the user to save a specific viewpoint or to load an existing viewpoint.

Plan
This option activates the model window and hence the model menu when the feature
library is active.
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Two Point Elevation
These option allows the user to work in arbitrary display axes, and support creation and
editing of strings on the current display plane.

See Also
Viewports

32.4.11 Feature Library (Model View Menu)
The feature library controls most of the translation required when converting surveys into
models, AutoCAD drawings, and MX models. It comprises of a list of feature names, each of
which has a set of user defined characteristics. Each project in SCC has it’s own feature
library. When a model is created from any dataset in the project a copy of the feature library
will be made and saved as part of the model.

See Also
Feature Library Spreedsheet

32.4.12 Station Coordinates (Model View Menu)
The station co-ordinates spreadsheet is used to store all the station co-ordinates for a given
SCC project. Individual traverse data sets will read fixed co-ordinates and write adjusted coordinates to this sheet. The instrument set-up sheet will refer to co-ordinates stored in this
sheet for purposes of orientation and position when calculating detail co-ordinates from polar
co-ordinates (Ha, Va, Slope Distance). Station co-ordinates may also be read directly from
certain data loggers or entered manually from the keyboard.
Whenever a data logger transfer or survey computation attempts to change the value of an
existing station co-ordinate, a check will be made for the differences between the new value
and the existing value. If a difference of more than 1mm in any axis occurs a message will be
presented asking you to keep the existing value or to overwrite it with the new value.
At this stage you will be offered a choice to keep the existing value or the new value. If either
value is less than or equal to zero in the x or y axis it will automatically get rejected with no
message displayed. This message will also get output to the current log file.

See Also
Station Coordinate Spreedsheet
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32.4.13 Model Source Files (Model View Menu)
This option allows the user to list the data and source used to generate a model.

32.4.14 Ground Type Library (Model View Menu)
This option opens the Ground Type Library spreadsheet. When a model is created this
spreadsheet will be blank. Apply textures to the model from the \SCC\TEXTURES\ .
Using the button on the Model Toolbar toggles the display of ground types on or off in the plan
display. To assign ground types to triangles, use the Edit / Add Remove triangles option. To
edit ground types, use View / Ground type library.

Shortcuts
Toolbar:

See Also
Ground Type Library (View Menu)

32.4.15 3D Viewer (Model View Menu)
The SCC advanced 3d viewer is a 3d terrain viewer based on the viewing engine used in the
Virtual Terrain project, http://www.vterrain.org/ This viewer supports surface texturing, draping
of digital photography, placement of 3d objects, shading , overlaying of simple vector
information and 3d fly-throughs.
To utilise the advanced 3d viewer, you should first use the ‘Edit / Add Remove Triangles’
option
to assign ground types to any parts of the surface you wish to visualise. You may
also want to use the ‘View / 3D Viewer / Edit feature to 3d model mapping’ to assign placement
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of 3d objects against selected survey features.

The simple 3d viewer is identical to the advanced viewer, but does not support objects such as
trees and road markings, or flight paths.

Enhanced support for road markings in the 3d viewer
The 3d viewer now includes support for automatic painting of 2d road markings onto the
©2015 Atlas Computers Ltd

826
rendered 3d surface. This works for any polygonal symbol or macroline element, and is
activated by setting the ‘Drape Z’ field in the 3d object mapping for any given feature to ‘Road
marking’. The 3d object mapping dialog is available from ‘View / 3d Viewer / Edit feature to 3d
model mapping’

Navigation on a virtual terrain
Mouse Navigation - the Standard Terrain Flyer
The drawback to the mouse is that its difficult to move in more than one degree of
freedom at a time. For example, you can turn right, or move down, but not both at the
same time. There are many ways to map the mouse position and mouse buttons to
movement. This is the way Enviro does it:
The further you are from the centre of the window, the faster you move.
Hold down the left mouse button:

Hold down the right mouse button:

Hold down both mouse buttons:

If you find yourself moving too fast, keep your mouse cursor close to the centre of the
window, or decrease your Flight Speed with the +/- toolbar buttons, or the 'F'/'S' shortcut
keys ("faster / slower")
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Mouse Navigation - the Grab/Pivot Flyer
Click and drag the left mouse button on a specific point on the ground to pivot around it.
(Be aware that if you click far from the center of your view, it is possible to undesirably roll
the camera.)

Click and drag the right mouse button to grab the ground and move it underneath you

Hold down both mouse buttons to zoom in or out.

Flight Speed does not have an effect on this style of navigation.

Keyboard Navigation
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The SHIFT key accelerates all other keys.
Same as with mouse navigation, the 'F'/'S' shortcut keys ("faster / slower") can be used to
change speed.

Edit feature to 3d model mapping
This option allows you to edit a spreadsheet that controls how 3d objects will automatically be
created in the advanced 3d viewer, based on the feature name. This spreadsheet contains the
following fields;

Feature
This corresponds to the feature name in the survey and feature library views.

Description
A brief optional description of how this object is represented

Linear Object Type
This field contains a series of defaults detailing how linear objects such as walls, hedges,
fences and overhead lines are represented in the 3D viewer. You can also use this option
to insert other 3D objects at regular intervals along a string in cases where the defaults do
not met your needs. In this case a 3D object file must also be specified and object
dimensions.

3d Object file
This field contains the full path name to the 3d object file being placed against this feature.
This can be any .3DS or .OSG object file. The 3d viewer includes a wide range of
standard objects including street furniture, vegetation and road markings, which can be
found in the ‘\Program files\VTP\Data\Objects’ directories. You can also use the SCC
option ‘Export to OSG model’ to create your own 3d objects.
The street furniture objects present in ‘\Program files\VTP\Data\Objects\101-street-furniture’
are licensed from GeoMetricks for use solely with the SCC advanced 3d viewer. If you wish to
use these objects within other packages, or you require further 3d object libraries, please
contact http://www.geo-metricks.com/ to obtain a license.
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The viewer also comes with a very extensive range of vegetation. If you open C:\Program
Files\VTP\Data\PlantModels in explorer, and select View / Film Strip, you can see all of the
300+ vegetation types along with their latin names. To map a specific tree or vegetation
type, enter the latin name in the 3d object file field.
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If you have a look at the file C:\Program Files\VTP\Data\PlantData\species.xml you will get a
good idea of how trees are stored. This is a text file that can be edited in notepad, and is laid
out similar to the following;
<species name="Sophora chrysophylla" max_height="7.00">
<common name="Mamane" />
<appearance type="1" filename="mamane1_v2_256.png" width="3.00" height="3.00" />
</species>

Simply replace the tree names and filenames in the above with your own values, and insert
your addition in the file before the line </species-file>

Other 3d models are either courtesy of the virtual terrain project, or have been generated
directly from SCC symbols.

Drape Z
This field controls how the base elevation for the 3d object being placed is determined. It
can be one of the following values
No

The base elevation for the 3d object is taken directly from the model.

Yes

The 3d object’s base elevation is generated by draping its plan position on the
triangulated surface.

Road marking
The 3d object is assumed to be a polygonal road marking, such as a road arrow or road
centre-line. The road marking is painted onto the 3d surface. For repeating linear
patterns, such as dashed road lines, use macro-lines in the SCC feature library that
include closed polygons.

X, Y, and Z offset
These fields contain an optional 3d offset to the 3d objects insertion point. The Z offset
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may be used to raise or lower the object with respect to the surface.

Apply Scale
This field determines how the 3d object will be scaled when shown in the advanced 3d
viewer, this can be one of the following values;
None

The object will not have any additional scaling applied. This will be the
default value for most objects taken from the 101-street furniture library that
are already correctly ground scaled.

Values
entered

The 3d object is scaled using the values in the X, Y and Z scale columns.

Model
values

The 3d object is scaled using the dimension values present in the SCC
model.

Both

The 3d object is scaled using the dimension values present in the SCC
model and those in the X, Y and Z scale columns.

Apply Rotation
This field determines how the 3d object will be rotated when shown in the advanced 3d
viewer, this can be one of the following values;
None

The object will not have any additional rotation applied.

Values
entered

The 3d object is oriented using the values in the X, Y and Z rotation columns.

Model
values

The 3d object is oriented using the symbol orientation present in the SCC
model.

Both

The 3d object is oriented using the symbol orientation present in the SCC
model and those in the X, Y and Z rotation columns

Export to OSG model
This option exports the current SCC surface to an OSG model such that it can be used as an
object in the advanced 3d viewer, or other software packages capable of rendering 3d objects.
This is primarily designed to allow you to use SCC to build additional 3d objects for the
advanced 3d viewer.

Insert aerial photography for 3d viewer
This option allows you to insert a rectified aerial photograph into an SCC model, such that it can
be visualised in the 3d viewer. To do this, you will require at least three known coordinates on
the photograph for which you have both pixel and real world coordinates. To insert a rectified
aerial photograph into SCC using this option do the following;
A. Use the ‘Pick>>’ button to select your photograph, which may be in TIFF, BMP or JPEG
format. This will display a preview of the image.
B. Enter the known coordinates, and press compute. This will compute the model
coordinates for the image corners, and display the selected coordinates over the image
as red crosses. You can also save these coordinates as a transformation by pressing
the ‘Save’ button.
C. Press the ‘Ok’ button to insert the image into the SCC model. This will also create a
new clip polygon string around the edge of the photograph, such that the area of the
photo corresponds with the plan area of the triangulation.
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to assign an appropriate ground
D. Use the ‘Edit / Add Remove Triangles’ option
types to any parts of the surface on which you want to drape the photograph. The
ground type selected should have its ‘Photo’ field set to ‘Yes’, and its texture field set to
the file name of the inserted image. Using the above option will automatically create a
ground type called ‘PHOTO’ with these values set if it does not already exist. Other
ground types may also be mixed in as required.
E. Use View / 3d Viewer / Advanced 3d viewer, to visualise the result in the 3d viewer.

32.4.16 Status Bar (Model View Menu)
The status bar is displayed at the bottom of the SCC window. To display or hide the status bar,
use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as the user uses the arrow keys
to navigate through menus. This area similarly shows messages that describe the actions of
toolbar buttons as they are depressed, before releasing them. If after viewing the description of
the toolbar button command the user wishes not to execute the command, then release the
mouse button while the pointer is off the toolbar button.
The right areas of the status bar indicate which of the following keys are latched down:
CAP

the Caps Lock Key is turned on

NUM

the Num Lock Key is turned on

SCRL

the Scroll Lock Key is tuned on
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32.4.17 Customised (Model View Menu)
This option allows the user to select the toolbars which SCC displays and to create new users
defined toolbars.

To Display a toolbar click the box to the left of the toolbar name. A tick beside the toolbar
means that the toolbar will be displayed if the box is blank then the toolbar will not be displayed.
Select New to create a customised toolbar. When the user gives this toolbar a name it will be
added to the client area. Drag icons from the Command tab to the new toolbar. Icons from any
number of different toolbars may be added to the new toolbar.

32.4.18 Extended Styles (Model View Menu)
This option defines how the toolbars appear. The Traditional or New look may be selected.

Traditional Look Toolbar

New Look Toolbar
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The New look has distinctive Gripper Bars. The gripper bars are the vertical lines at the right of
the toolbar.

32.4.19 Keyboard Short-cuts (Model View Menu)
This option allows the user to select a combination of keystrokes which may be used as
shortcuts for any menu command in SCC. Keyboard shortcuts will generally only be defined on
commands that are used very often. There is an option in the General Options to disable this
option. The option Disable user Defined keyboard shortcuts is in the 'Directories and Files'
section of the General Options.

Model Editing Shortcut Keys
Esc

Quits any of the interactive editing options

Home

Zoom Extents

End

Zoom Previous

Page Up

Zoom Out

Page Down

Zoom In

Space Bar

Zoom Centre (Pan)

TAB

Pan to the next crossing breakline, next duplicate point, or next
potential model error. This option will only pan to crossing
breaklines and / or duplicate points if they are currently being
displayed. This is controlled using `View / Triangulation options'.
Other potential model errors that are detected with this option
include links between 2d and 3d points, duplicate 3d points with
different elevations, and polygons with less than three points.
This key press is very useful when correcting survey errors
interactively.

F2

Pressing this key pans to the next selected point. This option
should be used in conjunction with the data selection dialog, and
is very useful for finding specific points in the model. For
example, to find a specific point in the model, use the advanced
section of the data select dialog to highlight the point (or point
range), and press F2 to pan to that point.

s

Pressing ‘s’ toggles between the available snap lock modes,
including nearest point, nearest DTM point, nearest 2D point, gird
position, midpoint, perpendicular (to string), perpendicular
(current string) and design grid (chainage/offset).

n

Pressing ‘n’ turns snap lock off.

g

Pressing ‘g’ enables snap to grid mode.

m

Pressing ‘m’ enables multiple point selection mode. This is useful
when selecting a point, or piece of text that overlaps other items.
If multiple point selection is enabled, and a position on screen is
selected where there are multiple overlapping points, a dialog will
be presented that allows you to select the desired point from a list
of points within a specified range from the cursor.

\

Use of ‘\’ and ‘*’ keyboard shortcuts can be used to the create text
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function, as per other text editing functions. Note that when
creating new free form text, the drop down feature list in the tool
bar may be used to set the texts feature and hence colour and
CAD layer.

32.4.20 Browse Model View
The browse model option allows the user to simultaneously view the model in graphical and
spreadsheet format.

Selecting a point on the graphics will update the spreadsheet position, similarly selecting a
point in the spreadsheet will re-center the graphics around that point. Most graphical editing
tools will also work while browsing the model, additionally search and replace, and global
editing operations are available while in this mode.
If the user makes a change to the spreadsheet view while browsing, the user must select
‘Update Model’ to see these changes reflected in the graphics. Any graphic editing is
automatically reflected in the spreadsheet.

Shortcuts
Toolbar:

32.4.21 Show Or Hide Survey Observations Positions
This option toggles the display of survey observation markers on or off. For this option to
work, you must have a feature '~SURVOBS' set-up in your feature library as a point symbol
with the desired dimensions. A feature style file, SURVOBS, is included in the SCC installation
to simplify the process of adding this feature to existing models and projects.
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Shortcuts
Toolbar:
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32.5

Model Design Menu
This menu allows access from the SCC model to SCC design tools.

32.5.1 Horizontal Alignment (Model Design Menu)
SCC’s alignment designer allows interactive design or horizontal and vertical alignments.
Horizontal alignments may be designed and/or viewed interactively. When this option is
selected a dialog is opened and placed on the left hand side of the model.

This dialog contains the following options;
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Horizontal Design Action
The action required by the selected option is displayed in the bottom section of this dialog.
Add IPs

Adds Intersection points interactively to a model

Insert IPs

Allows intersection points to be inserted by entering co-ordinate and
radius values in the Intersection Point parameters box.

Delete IPs

Allows intersection points to be selected and then deleted.

Move IPs

Allows existing Intersection points to be moved interactively on the
model.

Edit IPs

Allow the existing intersection point information to be editing via the
Intersection Points parameters and Transition lengths dialogs.

Intersection Point Parameters
This field displays the Easting, Northing and Radius of current Intersection Point. When
generating a horizontal alignment from given co-ordinates and other given parameters,
type the Easting, Northing and Radius of the curve here. When entering information
manually here have the Horizontal Design Action set to Inset IPs.
When the Horizontal Design Action is set to Add IPs the Easting and Northing fields are
automatically updated as new Intersection Points are added to the horizontal alignment
interactively. The Radius field has to manually updated at each new Intersection Point.

Transition Lengths
This field specifies the lengths of the incoming and outgoing transition curves. These
fields have to be entered manually no matter which Horizontal Design Action is selected.

Status
This field defines the status of the current horizontal design. If there is a problem with the
design, it will be displayed here. When designing the alignment the next action required is
displayed in this field.

Create Complex Curves
This field allows complex curves to be inserted into the design. This option is typically
used for designing reverse curves. When this option it turned on the following parameters
must be specified;Partial Transition length,
Radius 2 length,
Define an arc length and specify whether this is arc length 1 or arc length 2.
At any stage in the design the last option can be undone, if a mistake has been made.
Note:
That the Undo option only goes back one step, so if a mistake is made make sure Undo is
selected straight away before any other action is carried out.

32.5.2 Vertical Alignment (Model Design Menu)
This option may only be selected when a horizontal alignment is currently attached to the
model. The vertical design sheet displays the vertical profile of the model along the horizontal
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design and position of all horizontal design elements.

See Also
Design Vertical Alignment(Alignment Design Menu)

32.5.3 Section Templates (Model Design Menu)
Section Templates may be interactively designed. Sections of varying width may be attached
to different chainages along the alignment. This may be needed to accommodate roads of
varying width. Elements such as drains, which may occur only in cut or elements which occur
only in fill may also be catered for in the section templates.

See Also
Section Templates (Alignment Design Menu)

32.5.4 Move Alignment (Model Design Menu)
This option allows the alignment to be moved by selecting a start/base point and a second/
placement point with the mouse.
This option has it’s own secondary menu.

The following options are available;
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X, Y, Z, Shift...
Interface and Export Parameters....
Export Design As Model
Export Design As Dataset
Undo Design Option
View Alignment Sheet

Quit
Exits this command ignoring all the changes that have been made.

32.5.5 Create Alignment From String (Model Design Menu)
The option is allows you to create a 3d alignment from any SCC string, and optionally create
default side slopes for that alignment. The option can be used in one of two ways.
The first method is to convert all straight-line segments in the string to alignment straights, and
optionally insert a filleting arc of a specified radius in between the straights. It is advisable to
include these arcs to ensure that chainages can be calculated for points that are offset from the
centre-line. This also allows for creation of more aesthetically pleasing side-slopes and offset
strings. Entering a fillet radius of zero means that these arcs will not be created. This option
will work with any string, and will result in two horizontal entities and one vertical entity per
string point.
The second method attempts to fit the minimum number of straights and arcs to the current
string, based on a specified range of acceptable radii and chord to arc distances. This option is
suitable for surveyed or imported road or rail centre-line strings where the original geometry
strings are not available.
Compressing the design geometry will join adjacent horizontal entities of the same type that fall
within a specified, reducing the overall size of the alignment.
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32.5.6 Balance Cut and Fill (Model Design Menu)
This option shifts the datum of the currently active alignment and design strings surface such
that when modeled and compared to the current surface, the cut and fill volumes will be the
same. Compaction and bulking factors can be entered for cut and fill, and the balance is
computed based on the corrected volumes. The user may also enter a level tolerance, which
lets SCC know when to stop the balancing.

32.5.7 Select Reference Alignment (Model Design Menu)
This option provides a means of selecting a reference alignment, a first and a second reference
string and methods for calculating reference offsets and reference heights.

SCC calculates the difference in height between the current reference height and the alignment
centre line at the current chainage. This can be reported using the report Reference Chainage,
offsets and heights which shows the vertical height difference as well as the normal height
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difference.
The normal height difference is calculated at right angles to the vertical alignment, based on
gradient. This gradient is calculated at regular interval based on the 'Design > Interface and
export parameters' chainage interval settings, default 10m.

32.5.8 Create an offset setring (Model Design Menu)
This option allows you to create an offset string from a given model string, in relation to the
currently active alignment, with inclusion of points at regular chainage in addition to base string
points. Projecting existing slopes allows you to offset at a variable gradient based on the slope
of the existing ground from the base string at right angles to the alignment.

32.5.9 View Design Sheet (Model Design Menu)
This option allows the user to open any of the spreadsheets associated with the alignment file.

These are
Horizontal Intersection Points
Vertical Intersection Points
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Horizontal Entities
Vertical Entities
Super-Elevation Nodes
Section Template Points

32.5.10 X, Y, Z, Shift...(Model Design Menu)
This option moves the alignment by specified X, Y and Z values. These values are typed into
the Move Alignment Origin dialog.

32.5.11 Export Design As Model (Model Design Menu)
This option exports the alignment to a separate TIN model. The Export Alignment dialog is
presented.

Chainage interval controls how often points are interpolated along the alignment.
Generate Interface string controls whether the points where the design surface
intersects the ground surface are output as a string
Create boundary string controls whether the interface string generated is turned into a
clip polygon that trims the out TIN model
Create slope signature strings controls whether tadpoles or hachure lines are output at
each interface point connecting the edge of the design to the point it meets the ground.
Design surface to export selects which surface is exported from a design surface that
contains multiple surfaces
Existing ground surface is the name of the ground model used for interface
computations. This defaults to the current model when this dialog is accessed from the
model design menu.
Design strings surface is an optional additional model that will get output with the
design. This is also useful for cut/fill balancing situations where this additional model will
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also be taken into account.

See also Interface and export parameters

32.5.12 Export Design As Dataset (Model Design Menu)
This option allows the alignment to be exported to a survey data set. The Export Alignment
dialog is presented.

The data set will contain X,Y,Z, chainage and offset information. See also Interface and export
parameters

32.5.13 Interface and Export Parameters.... (Model Design Menu)
This dialog is presented when the option to Export Design as Dataset and Export Design As
Model is selected and when in the alignment file the option to 'View Interface and Export
Parameters is selected.

This option sets the parameters for exporting an alignment. The alignment may be output as
an interface string. If the option to Generate Interface Strings is selected the two options;
Create boundary from interface string and Create slope signature strings are enabled. The
existing ground surface is the surface to which the interface line of the template extends.
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32.5.14 Report Rail Lift And Slue (Model Design Menu)
This option reports rail lift and slue which involves comparison of a design model with a survey
model for left (vertical separation) and slue (lateral separation) on nominated left and right rails.
It also computes cant a gauge between left and right rails, and reports any failures to meet
tolerance in cant.

See Also
See also Lift And Slue Reporting

32.5.15 Report Rail Cant And Gauge (Model Design Menu)
This option will produce a report listing the cant stations, and applied cant values on either rail
at a regular chainage interval.

The cant and gauge report includes cant differences between successive chainages, to show
the amount of twist on the track. Large values are highlighted to show potential areas requiring
further investigation.

See Also
Rail cant computations

32.5.16 Compare Strings And Remove Overlaps (Model Design Menu)
This options compares, merges and reports on overlapping rail strings. Strings must be
selected prior to running this tool.
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See Also
String Comparison & Overlap Processing

32.5.17 Check and Adjust Formation Levels (Model Design Menu)
This option creates a new formation model from an existing rails and formation model where
the depth between the low rail (or sleeper) and top of formation is held fixed. Level adjustment
and depths to formation are output by chainage. Note that the point of minimum depth can
move from one side to another based on relative cant and gradient direction.

32.5.18 Set the Gradient of Selected Points (Model Design Menu)
This option enables the user to set the gradient between a group of points, based on a base
point, gradient, and direction. This is useful for draping groups of points onto a plane, typically
for building design and land fill foot prints.

32.5.19 Plane Fit Selected Points (Model Design Menu)
This option allows the user to plane fit selected points from a model and to generate a results
report.
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32.5.20 Undo Design Option (Model Design Menu)
This option undoes any editing that has been carried out to the alignment. This facility is
present because the Undo option under the Edit menu only applies to model information. The
alignment file is only attached to the model and is not part of the model. As the attached
alignment and the alignment spreadsheets are directly related, this option applies to any editing
that was carried out on the spreadsheets as well.
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32.6

Model Sections Menu

32.6.1 Long Section with Cursor (Model Section Menu)
This option allows the user to interactively create long sections from the current ground model
using the cursor. Pressing the left button allows the user to add a point to the existing section
line. Pressing the right button finishes the section and opens the sections file automatically.
SCC automatically remembers the last sheet size applied to a section and therefore, if the
section created is too long for the sheet, the following message will appear;

If the user selects ‘No’ to sub-divide the sheet, no sheet will appear. However, if the user
selects ‘Yes’, then the following dialog will be displayed;

The user may sub-divide the section by either a specific chainage or at regular intervals. The
length of the section and the length of the selected sheet are listed at the bottom of the dialog
so as to make it easier to determine the required interval.
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32.6.2 Long Section from Existing String (Model Section Menu)
This option allows the user to create a section graph from a string displayed in the model. This
option uses surveyed levels on this string directly rather than interpolating from the ground
model. To create a section graph simply press the left mouse button on the desired string.
This will generate a section file from that string which is automatically opened. If the user
moves back to the model view, additional strings can be selected that will be added to the
same section document.
When selecting this option initially, the user will be prompted with the question ‘Would you like
to store survey remarks in the section feature column ?’. This enables the user to annotate the
section with field notes attached to survey points as required.

32.6.3 Long Section From An Alignment (Model Section Menu)
This option generates a Long Section along the attached alignment string.

32.6.4 Long Section from Coordinate Data (Model Section Menu)
This option allows long sections to be extracted from a ground model by using any of the
standard input co-ordinate file formats as the section template.
A section will not be generated if the points in the co-ordinate file;
· are not strung (i.e. point features)
· have a DTM status other than D
· contain gaps in the strings

See Also
Detail Coordinate
Import DWG/DXF File
Import Fixed format ASCII file (File Menu)
Import X,Y,Z ASCII file (File Menu)
Import AutoGrad/MSMM ‘As Set-Out File’ (File Menu)
Import AutoGrad/MSMM Levelling File (File Menu)
Import AutoGrad/MSMM GDS Printout (File Menu)
Import DOER Husky File (File Menu)
Import MOSS GENIO File (File Menu)
Import MOSS 992 Report (File Menu)
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Import MOSS 994 Report (File Menu)
Import Steanne MIDAS File (File Menu)
Import SDRMAP ASCII File (File Menu)
Import Eclipse Report File (File Menu)
Import ESBI Vectors File (File menu)

32.6.5 Cross Section From Existing String (Model Section Menu)
This option allows the user to create cross sections from a string displayed in the model. To
create sections simply press the left mouse button on the desired string. The Create Cross
Sections dialog will then be presented. This option can create cross sections at regular
intervals (i.e. chainages) and/or at the surveyed points on the string.

32.6.6 Cross Section From An Alignment (Model Section Menu)
This option generates a Cross Section at right angles to the attached alignment string, using a
specified chainage range and interval. Additional options allow the user to add sections at
regular intervals, at tangent points (e.g. start and end of tangents, transitions, and arcs in the
horizontal design) or at user specified chainages.

Shortcuts
Toolbar

See Also
Detail Coordinate
Import DWG/DXF File
Import Fixed format ASCII file (File Menu)
Import X,Y,Z ASCII file (File Menu)
Import AutoGrad/MSMM ‘As Set-Out File’ (File Menu)
Import AutoGrad/MSMM Levelling File (File Menu)
Import AutoGrad/MSMM GDS Printout (File Menu)
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Import DOER Husky File (File Menu)
Import MOSS GENIO File (File Menu)
Import MOSS 992 Report (File Menu)
Import MOSS 994 Report (File Menu)
Import Steanne MIDAS File (File Menu)
Import SDRMAP ASCII File (File Menu)
Import Eclipse Report File (File Menu)
Import ESBI Vectors File (File menu)

32.6.7 Cross Sections From An SCC Section File (Model Section Menu)
This option creates cross sections at right angles to centre line(s) taken from all long section
templates in the selected SCC long Sections file. The start of each string in the co-ordinate file
is considered to be at chainage zero for the purposes of this option. This option will usually be
used when the long section has been created with the cursor.

32.6.8 Section From Points in a Bandwidth (Model Section Menu)
This option creates a long section from all points within a specified distance of a user-defined
centreline. To use this option, first enter the search distance or bandwidth, then press the left
mouse button over two or more points on the desired centreline, then press the right mouse
button to generate the section line. To add further sections to the section document, simply go
back to the model view and repeat the steps given.

This option is typically used when creating river sections, where the surveyed section line is
greater than the actual river width. The section is created using the surveyed elevations
snapped, at right angles, onto the user-defined centreline.
This option can also be used in conjunction with an alignment to create cross sections from
points in a bandwidth, that can be skewed from the centre line. In this case the skew angles
can be annotated on the sections, and reported on for flow analysis and area correction
purposes. Note that cross sections created in this manner should only include two end points if
they are to be used for area or flow measurement purposes. The chainage of a skew cross
section is the computed position of where it intersects the alignment.

32.6.9 Long Section Using Paralllel Strings (Model Section Menu)
This option allows you to create parallel string sections. The term ‘parallel string section’ is
used in this case to refer to a section graph that shows one or more strings, from the same
surface, overlaid on each other. An example of a parallel string section would be a section
graph showing the centre-line and left and right edges of a road carriage way.
Parallel sections present us with a number of potential problems, insofar as we are overlaying
strings with different coordinates, and thus require a common reference coordinate system to
tie the strings together. The common reference coordinate system must be a chainage / offset
based coordinate system.
©2015 Atlas Computers Ltd

853

SCC provides us with three alternative solutions to this issue, which are as follows;

Use the first selected string to define the chainage/offset system.
The first string selected is converted into a temporary alignment string, and the chainage
values of all points on all strings in the section are calculated in relation to this alignment.
Points on the second and subsequent strings that have chainages lower than zero, or
greater than the extent of the first string, are ignored.

Use the currently active alignment to define the chainage/offset system.
The current alignment is used to generate chainage values for all points. Points on all
strings that have chainages lower than zero, or greater than the extent of the alignment,
are ignored.

Do not use a common reference system
In this case, the first point on each string is treated as having a chainage of zero, and the
chainage system is based on the distance between string points.
When using a reference coordinate system, the length of the individual section lines can
also be determined in one of two possible manners listed below;

Based on the reference chainage system
In this case, all of the string coordinates are projected onto the alignment, based on the
common chainage system. For example, in the case of a curved road that goes over hill,
the hill would appear at the same position in each section in the graph.

Based on the length of the selected strings
In this case, the true lengths of the individual strings are used, and reference coordinate
system is only used to determine the extents of the sections. For example, in the case of
a curved road that goes over hill, the hill would appear at staggered positions in each
section in the graph. This is because the string on the inside of the curve will be shorter
than the string on the outside of the curve.
The model shown below illustrates the use of parallel sections, and some of the
differences obtained by selecting the various options.
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32.6.10 River Section (Model Section Menu)
This option provides the main interface for river section generation within SCC. Sections and
profiles can be automatically generated with multiple outputs. The main aspects include:
· River profiles include output of centre line, bed level / low water, water level, left bank, right
bank, minimum silt level and maximum silt level using the features CL, Low Water, Water
Level, Left Bank, Right Bank, Silt Max and Silt Min respectively. Default river profile section
style has been added to accommodate these features.
· Export options allow for the generation of ISIS, HEC-RAS and MIKE 11 formats, and have
been designed in such a way that sections can be output to all formats without any reprocessing.
· Specific features can be assigned for left bank, right bank, section ID, section type and water
level. SCC will generate a report while processing river sections providing details of any
sections that are missing any of these details.
· Typically one or two digit, can be used as section feature codes, which are mapped onto
larger names for display on the section. Such features can be displayed either in the
annotation box or on the section surface.
· In addition to cross sections, SCC will also create a river profile showing bank levels, bed
levels, water and silt level for all sections. This profile can be annotated with section
chainages and IDs.
· Where a water level has been surveyed within a specified distance of a section between the
river banks, a water surface can optionally be added to the sections. In addition a time
stamped water level annotator, fitted between the left and right banks, above the water level
line can be generated.
· Silt surfaces can be automatically added to the river sections as per the water level, with the
addition that silt surfaces can either be created from a single point or a multi-point string.
· Structures can be copied and pasted from plan onto both river sections and the river profile.
· A scaled symbol can be automatically placed on the surface for each feature, where
required. Additional symbol annotation options have been added to support display of pipes
with their dimensions, and other structures such as walls and fence on river sections and
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profiles.
· Where left and right banks have been surveyed, and the right bank has a smaller offset than
the left bank, the section will automatically be mirrored.
· Annotation options allow for labelling the offset relative to the left edge or right edge of
section, low water point, banks, and highest and lowest point on the section as well as title
annotators for section ID and section type.
· When left and right banks have been picked up, SCC will automatically search for the lowest
point between the banks, and use this point as an additional offset reference system (ISIS
offset).
· Section title options have been added for annotation of upstream and downstream chainage
(MIKE 11 & ISIS), and difference in chainage between points.

Specific settings are outlined as follows:

Surface Name for ground surface
This is the name displayed on the section title block for the profile line associated with the
main ground surface.

Surface name for water surface
This is the name displayed on the section title block for the profile line associated with the
water level and extrapolated water surface.
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Surface name for silt surface
This is the name displayed on the section title block for the profile line associated with the
silt level and extrapolated water surface.

Create sections using points with similar chainage
This option is used when points on surveyed river sections are not collected as strings
defining the section line. In this case, all points within a specified chainage range are
grouped to form a section, and the points on each section are sorted by offset from the
river centre line. This option has the advantage that it allows the user to collect feature
names in the field, e.g. TOPBANK, BOTBANK, etc.. which will automatically be annotated
on the section. It has the disadvantage that section lines should not overlap, as points
may get placed on the wrong section.

Maximum chainage difference between points
This option is the maximum chainage separation allowed between points for them to be
placed on the same section. For example, a value of 2m would indicate that all points on
a section must be within a 2 meter chainage of one another. Note that for skew sections,
i.e. sections not perpendicular to the centre line, this value should be increased to allow
for the skewing effect. This value should never be greater than half the distance between
adjacent section, e.g. if your sections are 10m apart, this value should not exceed 5.

Create sections using surveyed strings
This option should be used where sections have been collected as complete strings. It
has the advantage that sections can overlap, which can be useful on sharp changes of
direction and small radii in the river centre line.

String corrections
These only apply where the above option has been selected, and relate to automatic
correction of certain survey errors.

Leave strings as surveyed
Do not make any corrections.

Re-string sections based on offset from centre line
This option re-orders the points in the string based on their offset from the centre-line.
This will correct any overlaps, loops and doubling back in the section.

Remove loops from sections
This option removes any loops that occur in plan in the section.

Section Orientation
These options refers to how the section centre lines are formed from the surveyed points
for a given section, which due to the natural constraints of river surveying, will rarely form
an exact straight line.

Skew, based on surveyed end points
The section centre line is formed by joining the leftmost and rightmost survey points. The
survey points are then snapped onto this line when forming the section. This line will
typically not be at exact right angles to the river centre line.

Skew, based on best fit line through all points
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The section centre line is formed by creating a best fit line through all the survey points.
The survey points are then snapped onto this line when forming the section. This line will
typically not be at exact right angles to the river centre line.

Normal to alignment, based on mean chainage
The section centre line is formed by computing a mean chainage from all the survey
points, and going at right angles to the left and right of centre-line at that chainage to meet
the leftmost and rightmost offsets of the survey points. The survey points are then
snapped onto this line when forming the section. This line will be at exact right angles to
the river centre line. Note that if the surveyed section is not roughly at right angles to river
centre line, points are liable to be moved significant distances when snapped onto the
centre line, and the section line may be significantly shorter than the surveyed line.

Use Alignment for section offsets
The sections are formed using the offset value of the alignment.

Snap sections to survey / centre-line intersection point
This option allows the section position to be snapped to the position where the surveyed
section line cuts the alignment centre line. This means that centre line chainage and ISIS
chainage are coincident.

Section Feature Text
This controls how the feature name field in the sections is populated.

Use feature name
Use the feature name as entered in the survey.

Use remark
Use the remark from the associated survey observation. This is useful when surveying
sections as strings, where all the points on the section have the same feature name for
stringing purposes, but may refer to different items on the section, e.g. Top of bank, edge
of water, etc…

Water line
This group of options refer to the extraction of water level points and extrapolation of a
water surface in the sections produced. Typically this will be a single water level point per
section where the water surface is being automatically extracted, or a string where water
surface has been surveyed directly.

Search for water level near section
Select this option to search for water level points near the surveyed section.

Water level feature
This is the unique feature name, e.g. WLEV, used to denote water levels.

Extend water level on section to nearest bank
When a single water level has been surveyed per section, this option will extend the level
left and right from the surveyed point to the ground profile on the section to form a water
surface.

Silt line
This group of options refer to the extraction of silt level points and extrapolation of a silt
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surface in the sections produced. Typically this will be a several silt level points per
section where the silt surface is being automatically extracted, or a string where silt
surface has been surveyed directly.

Search for silt level near section
Select this option to search for silt level points near the surveyed section.

Silt level feature
This is the unique feature name, e.g. SILT, used to denote silt levels.

Extend silt level on section to nearest bank
When silt level points have been surveyed per section, this option will extend the levels left
and right from the surveyed point to the ground profile on the section to form a silt surface.

Search distance for IDs, water and silt levels
This is the maximum allowable distance from the IDs, water and silt levels to the section it
will be placed on.

Section ID feature
Section ID picked up the field are extracted and used to label individual sections.

Section Type feature
Section Type picked up in the field are extracted and used for annotation and export
purposes.

Left Bank Feature
Left Bank feature is used for annotation and export purpose. It is also used to control the
extent of the Water and Silt level surfaces.

Right Bank Feature
Right Bank feature is used for annotation and export purpose. It is also used to control
the extent of the Water and Silt level surfaces.

Search all text in model for missing IDs and types
This quality check examines each section for missing IDs and types. Errors are reported
in a text file.

Check and report for survey errors in sections
This quality check examines each section for survey errors. Errors are reported in a text
file.

Correct reversed sections
This option re-aligned sections to match the centre line direction. This option overcomes
issues relating to section having been surveyed in a 'zig-zag' fashion and also address
problems arising from left and right bank being incorrectly surveyed.

Report water level differences by chainage
This quality check option allows the water level difference to be reported based on
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chainage values, that is, to report water level height differences between sections to check
downstream direction.

Profile Creation
When creating river sections, multiple river profiles may be output based on different
chainage systems and treatment of skew sections. These are as follows:

Centre line chainage
Each point on the profile for any given section is given the chainage of the point where the
section cuts the centre line. Thus for each section, all the points are lined up on the profile
at that chainage.

Point chainage
Each point on any given section on the profile will have its chainage computed from the
centre line / alignment. Thus for skew sections, multiple points will occur on the profile for
each section, highlighting the range of chainages covered by the skew section.
Note that care should be taken when copying and pasting structures and pipes from plan
onto river profiles, as the chainage used will be computed from the alignment rather any
given section. Thus where skew sections are being used, copying and pasting will typically
provide best results when used in conjunction with the profiles based around point
chainage. SCC gives a message to this effect when creating multiple profiles.

ISIS chainage
This is the same as the centre line chainage, except the chainage used is the chainage
where the surveyed line, rather than the section line, cuts the centre line.

MIKE chainage
This is the same as the centre line chainage, except the chainage used is the MIKE
chainage, which typically runs in the opposite direction as the centerline and ISIS
chainage.

Reverse Profile(s)
This options allows the reversal of profile directions.

Cross Section drawing style
This option allows the user to select a predefined section style.

Profile drawing style
This option allows the user to select a predefined section style.

Feature >>
This option links to the Extended Field Code table.

See also River sections tutorials for more details on typical work flows pertaining to river
surveying

32.6.11 Live Section (Model Section Menu)
This options supports real time creation and display of long sections, cross sections and string
profiles. It operates in split screen mode, with the section view being updated as you move the
cursor in plan view.
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Live sections support multiple models. To show more than one model on live sections, the
additional models should be attached to the main model using 'FILE > Attach/Detach > Attach
Model'.

32.6.12 Vertical Tunnel Cross Sections Through Cloud (Model Section Menu)
This option allows the user to create vertical tunnel cross sections through cloud data. This
option requires a single mouse click for the vertical centre point. This is effectively the same as
isolating sets of points close to a plane, and tracing the outlines of those points. In this
instance, the planes are horizontal and the interval is the vertical interval.

32.6.13 Oblique Tunnel Cross Sections Through Cloud (Model Section Menu)
This option allows the user to create oblique tunnel cross sections through cloud data. Two
mouse clicks are used to define an oblique base line. This is effectively the same as isolating
sets of points close to a plane, and tracing the outlines of those points. The planes are normal
to the 3d line defined by the two points selected. The active cloud area is sectioned, so to limit
the analysis to a given area, isolate those cloud points.

32.6.14 Edit Section Coding (Model Section Menu)
This option allows the user to specify additional annotation options be feature. Using a value of
'Level on Surface' annotates the level of any given point on the surface in addition to the
annotation boxes. A code and feature value of ~BLANK may be used for triangle cuts that do
not relate to a string.
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32.6.15 Non-surface String Cutting Options (Model Section Menu)
This option determines the strings that are used to generate a section. When selected within a
model, the above rules will apply to all newly cut sections created using long or cross sections,
created using the cursor, existing strings or alignment. The following options are available:

Input model is only used when the option is used from within an existing section
Output surface name is the same given to the surface annotation line within the
sections

Cut all strings in the input model is only used when calling the option from an
existing section, and causes all cut strings to be added to the section

Only cut Non-DTM points (Approx and Elevation) will cut all strings that are not
part of the DTM surface in the input model and add the cut positions as single points to
the section.

Only cut Elevation strings does the same but is restricted to strings with a DTM code
of Elevation.

Only use the following features (comma separated) cuts all string with the
nominated features. For example, a value of TB,BB,RL,RR would only cut strings with
one of these feature names.

None indicates that this function will not be used when creating new section.
Cut data does not have valid levels forces the cut points output to assume the level
of the sections datum.
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32.7

Model Volumes Menu
In SCC there are 3 methods by which volumes may be calculated.
· Prismoidal method
· Grid method
· Cross Sectional End Areas method
When calculating volumes all three methods should be performed, as each is independent of
the other, and hence each provides a check on the other. Differences of more than one or two
percent indicate possible errors.

Things to look out for when calculating volumes;
It is important that there be a common boundary between the two surfaces, defining a
common area about which volumes will be measured. Accurate volumes cannot be
calculated between two surfaces where a common boundary is not defined. Poor
boundary definitions are probably the most common cause of gross error in volume
calculations. The boundary string should have a DTM status of Clip Polygon. The
boundary will normally take the form of a string line, either surveyed or added manually to
the model. Most modelling packages will automatically determine a boundary, using a
convex hull or similar algorithm, if one is not provided. Such boundaries rarely reflect
conditions on site, as can be evidenced by contours appearing outside the surveyed
areas. In any case, such a boundary is ambiguous as it is dependent on the algorithm
selected by the software package rather than the judgment / agreement of the engineers
and surveyors on site. Weeding may also be used to define plan areas although use of a
boundary string is superior.
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Check the plan area of both surfaces.

If we have two surfaces, for example, surface A, shown here in red and surface B shown
in green. Areas A and B do not overlap exactly. Where they do overlap they form the
area C. Volumes will be calculated for the area C and not for the whole of A and B (i.e.
volumes will be calculated only where two areas overlap).

Check that both surfaces overlap by;
1 Creating a model of both surfaces in SCC. Open one of the models in SCC. Go to
'TOOLS > Merge two Model'. Select the existing and proposed models. The smaller
model will be inserted into the larger model.
2 Exporting both surfaces to CAD. Make one surface into a BLOCK and INSERT it on
top of the other. They should overlap exactly.
3 Defining the boundary line of both areas by drawing a POLYLINE around the area of
interest. Use the LIST command to find the area. Compare both areas, they should
correspond.
This method is not as accurate as using the INSERT command.
Discrete points do not provide enough information to accurately define a triangulated
surface that contains significant grade changes such as embankments. The accepted
method of triangulating a surface is the Delaunay method, which takes no account of
elevation when configuring triangles. This method is always modified in surface modelling
applications, such as SCC, to allow for the introduction of breaklines or strings. These
strings are used to define such linear discontinuities such as embankments. Without
using such strings / breaklines a surface that contains significant grade changes will be
inaccurate and may lead to inaccurate computation of volumes, sections and contours.
Check that the same surface is referred to as the Existing model each time and it is not
called the Proposed model when recalculating volumes using a different method of
calculation.

See also Volume tutorials

32.7.1 Volumes between surfaces by area (Model Volumes Menu)
This method allows the user to compute volumes broken down by areas, and further broken
down by ground type.
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If processing using areas an extra areas model is needed, which in simple terms is a set of 2D
polygons outlining individual areas to be measured.
The reports generated includes graphics of the areas based on the contouring and grid options
specified in the dialog, as well as an overview.
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32.7.2 Volumes to a Datum (Prismoidal) (Model Volumes Menu)
This method allows the user to calculate volumes using the prismoidal method between a
model and a specific datum set within the 'Prismoidal Volumes to a Datum' dialog.
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See Also
Prismoidal volumes tutorial

32.7.3 Volumes to a Datum (Grid) (Model Volumes Menu)
This method allows the user to calculate volumes using the grid method between a model and
a specific datum set within the 'Grid Volumes to a Datum' dialog.

32.7.4 Volumes Between Surfaces (Prismoidal) (Model Volumes Menu)
This option allows the user to calculate volumes between two surfaces using Prismoidal
method and produces a detail volumes report

See Also
Prismoidal volumes tutorial

32.7.5 Volumes Between Surfaces (Grid) (Model Volumes Menu)
This option allows the user to calculate volumes between two surfaces using Grid method and
produces a detail volumes report
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32.7.6 Volumes of Spoil Heaps / Pits (Model Volumes Menu)
This option allows the user to calculate volumes for all spoil heaps or pits contained in the
model at one time. That is, any boundary defined by a clip polygon will be used in the
calculations and a separate boundary and isopachyte model generated for each one. The
method used for computing the volumes is the prismodial method, which is potentially the most
accurate method of volume calculation between surfaces.
Once this option has been selected, the user will be presented with a dialog and the following
options:

Keep intermediate isopachyte models
This option means that each isopachyte model generated during the volume calculation
process will be kept and named according to the spoil heap number.

Keep intermediate boundary models
This option means that all boundary models used to calculate the spoil heap volumes will
be saved and named according to the spoil heap number.

Annotate volumes on model
This option means that each spoil heap in the model will be annotated with a number, the
area and the amount of cut and fill it contains.

Edit report file
This option allows the user to view and edit the volume report file.

See also Spoil heap volumes tutorial

32.7.7 Volumes And Areas by Depth (Model Volumes Menu)
This option allows the user to calculate material volumes by areas and depth, using a horizontal
section end-areas method of calculation. It is often most appropriate to perform this calculation
on an isopachyte model, in which the horizontal sections are representative of thickness or
depth of material between two other surfaces.

32.7.8 Volumes by Ground Type to a Datum (Model Volumes Menu)
This option computes separate volumes for each ground type in the model, to a datum that
may be separately specified for each ground type. To use this option, first use the Add/
Remove Triangles option to allocate ground types., and enter a value in the datum field for
each record in the ground type library. This option is similar to calculating a prismoidal volume
to a datum for each ground type.
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32.7.9 Volumes by Ground Type to a Depth (Model Volumes Menu)
This option computes separate volumes for each ground type in the model, to a given depth
that may be separately specified for each ground type. To use this option, first use the Add/
Remove Triangles option to allocate ground types., and enter a value in the depth field for each
record in the ground type library. This option is useful for calculations such as the effect of
stripping top-soil, and equates to the plan area under each ground type multiplied by the plan
area under that ground type.

32.7.10 Areas by Ground Type (Model Volumes Menu)
This option reports the total plan and slope areas of the triangulation, broken down by ground
type. To use this option you must first assign ground types to the triangulated surface, using
the Add / Remove triangles option.

32.7.11 Areas by Gradient (Model Volumes Menu)
This option reports the total plan and slope areas of the triangulation, broken down by ground
type. On selecting this option, you will be presented with the slope analysis dialog, which
allows you to enter the gradients between which areas will be measured.

You also have the option of colouring the triangulation by gradient or displaying the slope
vectors as this point. Note that the gradient of any given triangle is given by the steepest grade
across that triangle, and the slope vector is the direction in which this gradient occurs.

32.8

Model ZVI & Flow Menu
ZVI (Zone of Visual Intrusion) or viewshed analysis, otherwise known as intervisibility analysis
is an analysis that determines all the points on a surface at which a given object or set of
objects is visible. This is accomplished by projecting a series of polar rays (view sections) at
even horizontal angular intervals from each object (view station) being analysed. These rays
are coloured, based on whether the object is visible either from the ground or at a defined eye
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level.

32.8.1 Create ZVI Stations with Cursor (Model ZVI & Flow Menu)
The areas where the view station is visible at ground level and above are shown in yellow. The
areas where the view station is not visible at ground level but is visible at eye level and above
are shown in magenta. The areas where the view station is hidden at eye level and below are
shown in grey. Note the shadowing effects caused by the buildings for example above and
below the view station on the left of the picture. Everything behind these such buildings is
hidden from view. It is essential for all objects to be surveyed fully in 3D if you intend to use
viewshed analysis. In the example above, the trees have not been surveyed as 3D objects and
as such will not be used in the viewshed analysis. Concave or hollow areas may distinguished
as being hidden from view while not casting any shadows. Use of SCC viewshed analysis does
not have any overhead in terms of memory or disk storage space required.

Height of View Station
This field contains the height of the view station above the ground. A value of zero will
place the view station at ground level.

Height of Viewer
This field contains the eye level or height of the viewer above the ground.

Number of View Sections
This is the number of radiating view sections that will be cast from each view station. The
view sections will be cast at a regular angular interval from each view station. A value of
360 would cause a view section to be generated every sexagesimal degree, 400 every
metric degree.

Length of View Section
This is the maximum length to which views sections will be cast. It is assumed that view
stations will not be visible at greater distances than the entered value.
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Display Hidden Areas
This switch defines whether to highlight areas hidden to the station point.

Display Viewer Visible Areas
This switch defines whether to highlight areas visible from the viewer station point.

Display Ground Visible Areas
This switch defines whether to highlight areas visible from the station point.

Overwrite old View Points
This allows old view station co-ordinates to be retained or overwritten with new station
co-ordinates.

Shortcuts
Toolbar:

32.8.2 Edit ZVI Station Coordinates (Model ZVI & Flow Menu)
The co-ordinate data sheet containing the co-ordinates of the view stations is presented for
viewing or editing. It may be saved as a SURVEY file.

Shortcuts
Toolbar:

32.8.3 View ZVI (Model ZVI & Flow Menu)
This option allows the user to view current ZVI.

See Also
Create ZVI stations for more information
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32.8.4 Flow Lines With Cursor (Model ZVI & Flow Menu)
This allows you to select flow line source points interactively with the mouse.

See Also
Flow lines tutorial

32.8.5 Flow Lines From Dataset (Model ZVI & Flow Menu)
This creates flow line source points from a SCC coordinate file.

See Also
Flow lines tutorial

32.8.6 Flow Lines From Grid (Model ZVI & Flow Menu)
This creates a regular grid of flow line source points across the entire model.

See Also
Flow lines tutorial

32.8.7 Flow Lines Options (Model ZVI & Flow Menu)
This allows you to control the features used to control flow lines based on the number of
incoming flow lines. It is also used to specify the grid interval used when creating flow lines
from a grid, and control whether sink points are annotated.

Flow Grid Interval
The grid interval used when creating flow line source points at a regular interval.

Compute Cumulative Flows
This controls whether the number of lines that pass through a given point are counted.
This is required is compound flow lines are to be drawn using different features, but is
slower when generating flow lines.

Local Sink Feature
The feature code used to draw flow line sink points.

Annotate Sinks
This controls whether sink points are annotated with an index number and counter.

Minimum Line Count To Display
Flow lines that have less than this number of input lines passing through them will not be
displayed.

Minimum Sink Count to Display
Sink points that have less than this number of input lines reaching them will not be
displayed.
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See Also
Flow lines tutorial

32.9

Model Tools Menu
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32.9.1 Measure (Model Tools Menu)

The following options are available within 'TOOLS > Measure':

Line Bearing, Distance & Gradient
This option allows the user to compute bearing, distances and gradients between two
points. Coordinates can be manually entered or chosen with the cursor.

Triangle Areas. Centres & Gradient
This option allows the user to compute the in-centre, circum-centre, radius, area (plan and
slope), length (2D and 3D) and bearing between three points. Coordinates can be
manually entered or chosen with the cursor.
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Intersect Lines
This option allows the user to calculate the intersection between two strings. Coordinates
can be manually entered or chosen with the cursor.
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Midpoint on Line
This option allows the user to calculate the midpoint on a line. Coordinates can be
manually entered or chosen with the cursor.

Distance from a Point to a String
This option allows the user to calculate the distance from a point to a string, selected
using the 'Pick>>' button.
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32.9.2 Densify the Triangulation (Model Tools Menu)
This field specifies whether additional points will be inserted in each breakline at a given
interval.

Densifying breaklines increases the overall model size while improving the quality of
triangulation around breaklines. Densification may be used in situations where long breaklines
have been surveyed, and additional triangles are required on these breaklines N.B. Breakline
post-processing will ensure that a minimum number of points will be added to breaklines in
order that those breaklines are honoured in the model.

Max. segment length
This field specifies the maximum length that a breakline segment will be. If a segment is
longer than this it will be broken down into a series of smaller segments. It is only used if
the 'Densify breaklines' switch is turned on.

32.9.3 Merge Two Models (Model Tools Menu)
This option allows the user to merge an existing survey model with a proposed design model to
achieve an overall representation of the area after the design has been constructed. For
example, a proposed model of a building may be merged into a model of the existing green
field site to achieve a model representing the completed project after construction.
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32.9.4 Rebuild The Triangulation (Model Tools Menu)
This option forces the triangulation to be recomputed.

32.9.5 Display Model Information (Model Tools Menu)
This options details model information in a screen dialog box, for example:

32.9.6 Add Ground Levels to a Dataset (Model Tools Menu)
This option allows the user to strip out ground levels from an open model for each point (x, y
position) present in the dataset.

32.9.7 Extract A Grid of Levels (Model Tools Menu)
This option allows the user to extract a defined grid from a model.
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32.9.8 Add Strings From File (Model Tools Menu)
This option allows the user to add additional data to an existing Model.

The following options are available:
SCC Dataset, DWG/DXF File, X,Y,Z ASCII file, AutoGrad/MSMM 'As Set-Out' file, AutoGrad/
MSMM levelling file, AutoGrad/MSMM GDS printout, DOER Husky file, MX GENIO File, MX
992 Report, MX 994 Report, Steanne MIDAS file, SDRMAP ASCII file, Ecllipse report file and
ESBI Vectors file.

See Also
Detail Coordinate
Import DWG/DXF File
Import Fixed format ASCII file (File Menu)
Import X,Y,Z ASCII file (File Menu)
Import AutoGrad/MSMM ‘As Set-Out File’ (File Menu)
Import AutoGrad/MSMM Levelling File (File Menu)
Import AutoGrad/MSMM GDS Printout (File Menu)
Import DOER Husky File (File Menu)
Import MOSS GENIO File (File Menu)
Import MOSS 992 Report (File Menu)
Import MOSS 994 Report (File Menu)
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Import Steanne MIDAS File (File Menu)
Import SDRMAP ASCII File (File Menu)
Import Eclipse Report File (File Menu)
Import ESBI Vectors File (File menu)

32.9.9 Join Adjacent Strings (Same Feature)(Model Tools Menu)
This option is used to join all strings together in the model, within a specified tolerance, that
have the same feature name. This is particularly useful when processing polylines from CAD
that were exploded into lines for editing purposes.

Add String Links
This option will convert strings into closed polygons if there start and end points lie within
the stated tolerance.

Joining strings with the same partial feature name
This option ignores the numeric part of the feature name when performing the
comparison. For example, KB01 and KB02 would be considered to have the same
feature name in this case, if the feature KB was in the feature library, and the features
KB01 and KB02 were not. In this case the edited string will be given the name KB.

32.9.10 Join Adjacent Strings (Any Feature) (Model Tools Menu)
This option is used to search for groups of proximate points that are within a given horizontal
and vertical distance from one another, and edit them such that they are all snapped to the
same point. This function is available in the model via ‘TOOLS > Join Adjacent Points (any
feature)’. On selecting the tool you are first prompted for your horizontal and vertical tolerances
.

On entering your tolerances, SCC searches for all groups of proximate points, and displays the
dialog shown below. To continue, you should ideally be zoomed in close enough that millimetre
distances are visible on screen. The screen will be centred on the first group of proximate
points, and these points will be highlighted in plan. The next and last buttons may be used to
pan between all the groups of proximate points, and other editing buttons are available to
resolve those points. The position to which points will be snapped may also either be selected
or entered directly. The various editing options are appropriate to the different model
conditions shown below;
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If the group is made up of string end points that have the same feature name, select the ‘Join
adjacent strings with same feature’ option.

This will also close polygons with links where appropriate.
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32.9.11 Resolve Crossing Breaklines (Model Tools Menu)
This option allows the user to quickly resolve breaklines such as a Gully with a Road Marking
on top. That is, if the contractor has surveyed a gully with an elevation of 10m and
subsequently a Double Yellow line with elevation of 10.5m which crosses over the gully, a 'red
cross' highlights the 3D error where both intersect. With this tool, the user has the option to
create an intersection point at the correct level on either string.
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32.9.12 Set Preferred String Direction (Model Tools Menu)
This option allows the to globally re-orient either selected strings, or all strings in the model,
such that they all have the same general orientation. This is particularly useful for annotation
purposes, and when creating long sections or profiles from existing survey strings. When run,
this option reverses any strings, over the specified length, whose average orientation is away
from the selected orientation. Polygonal strings will be given an clockwise orientation. This
option also allows the user to set string direction based on an active alignment attached to the
model, which is beneficial for river section generation.

32.9.13 Transform Coordinates (Model Tools Menu)
This option permits the user to create or edit a transformation from one co-ordinate system to
another.

See Also
Transform Coordinates

©2015 Atlas Computers Ltd

883

32.9.14 Extract Elevation (Model Tools Menu)
This option is used to extract an elevation of façade model from a plan model. This is carried
out by selecting two points on a line parallel to the façade required. A new model will be
generated, with the coordinate system aligned to the selected line, and the Y and Z axes
swapped. If there is any data selected prior to choosing the base line, only that data will be
placed in the elevation model, otherwise the entire plan model will be used.
Note that the elevation model will have a different coordinate system (grid) to the original
survey model. If ‘Snap 3d’ is NOT selected when generating the base line, that is either ‘Snap
point’ or ‘No Snap’ is used, the elevation will have an X axis corresponding to the chainage
along the base line, a Y axis corresponding to the model height, and a Z axis corresponding to
the offset distance from the base line. If snap 3D is selected, these axes are also used, but the
Y axis corresponds to the vertical distance from the base line rather than the absolute
elevation.

32.9.15 Extract Levels from Text Nodes (Model Tools Menu)
This option allows the user to convert 2d drawings to 3d models using the text nodes in that
model. This is primarily aimed at creating models from 2D DXF file. This option searches for
text nodes within a given distance from each point and sets the level of that point accordingly.
Filters are provided for given text prefixes (for example, IL), elevation ranges, and feature name
matching. Where levels are not found for given points, they can be interpolated either from
surrounding string points or the rest of the surface.

Entering minimum and maximum level values can be useful for excluding numeric text that
does not relate to surface height, such as tree dimensions, station coordinates, etc…

32.9.16 Create Tree Lines From Canopies (Model Tools Menu)
This option allows the user to create tree canopy outlines lines from select tree symbols. The
user can choose to either keep or remove the trunk, and allow use of one or more tree
features.
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Example of drawing after canopy outlining, and the original model beforehand. Note that the
canopies are stored as polygonal strings, suitable for area measurement and ground type
analysis and viewing.

32.9.17 Search for Model Noise (Model Tools Menu)
This option is used to remove noise from surface models, typically those created using
scanning technology, such as scanners or LIDAR. The noise in this case is defined as
anomalous local low or high points that have been inadvertently been included in the model, but
are not representative of the typical surface. Examples of such noise include street furniture or
vehicles in a road model. The picture below illustrates an example model including noise.
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When the Search for Model Noise option is selected, the find scanner noise dialog is
presented, which contains the following fields;

Delete all local high / low points not surrounded by break-lines
Selecting this option only considers local high points and local low points for deletion. A
local high or low point, in this case, is a point that is higher or lower than all of its
neighbours, and is not surrounded by a break-line

Delete all high / low points vertically seperated from a given number of
their nearest neighbours
Selecting this option only considers any points with a given number of neighbours higher
or lower than the point in question for deletion. Neighbouring points lying on break-lines
are not counted in this computation.

Min nearest neighbours
This field controls the number of higher or lower neighbours required to meet the above
criterion.
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Vertical range
These min and max values represent the allowable range of level differences that are
considered to constitute model noise.

Horizontal range
These min and max values represent the allowable range of horizontal distances between
any two points that allows them to be considered as neighbours.
Note that after running this option, all of the points meeting the entered noise criteria will be
selected. Use the ‘Delete points’ option to delete them from the model entirely, or pick a DTM
code of ‘Elevation’ or ‘Approx’ to remove the from the triangulation.

32.9.18 Apply Ground Types (Model Tools Menu)
This options applies textures to the current model previously set up within the Ground Type
Library. This uses the Ground type field in the feature library to ascertain the preferred ground
type for each string. It works by filling closed polygons with the right ground type, and using
points as seeds to fill remaining triangles.

See Also
Ground Type Library (View Menu)

32.9.19 Report String Names (Model Tools Menu)
This options reports all string names present in a model.
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32.9.20 Report String Details (Model Tools Menu)
This option reports string details of all string in the model. For example, feature Name, MX
code number of points on string and length

32.9.21 Report Intersecting Strings (Model Tools Menu)
This option allows the user to report string intersections (denoted in model graphically by red
crosses) and duplicate points.

32.9.22 Report Triangle Coodinates (Model Tools Menu)
This option report coordinates of triangle within a model.

32.9.23 Report Polygon Point Density (Model Tools Menu)
This option allows the user to automatically establish the number of points in a polygon.
The point density report will deselect a number of points during the course of its operation, this
is true of many operations using pre-selected data, and does not affect the validity of the report.
Note that using an existing string to generate the polygon is not advisable if you wish to include
all the points on the polygon in the report, as points on the polygon may not be considered to be
in the polygon. This is particularly true when using geometries such as circle fitting, as the
survey points will not lie exactly on the modelled circle where more than three points have been
used.

32.9.24 Report String Lengths by Feature (Model Tools Menu)
This option reports the cumulative length of selected strings, or all strings in the model if no
strings are selected, broken down by feature. It is typically used in asset and utility surveys
where the total length of given types of pipes or cables is required. To ascertain the lengths of
individual strings use the Report String Names, or Report String Details option.

32.9.25 Compare Model Revisions (Model Tools Menu)
This tool is used to compare two models for any differences.

These differences are broken down as follows;

©2015 Atlas Computers Ltd

888

Compare Point and Line Information
Point and line changes, which indicate a significant change in model, probably relating to
model editing.
· Point Moved

· Point Deleted

· Point Added

· Point connects to a
different point

· Point number changed

· Point feature changed

· Point links to a different
observation

Compare Text Nodes
Text nodes, which can indicate text or model editing.
· Text Contents changed

· Text Appears Different

· Text Moved

· Text Deleted

· Text Added

· Text Rotation Changed

· Text Size Changed

· Text Alignment Changed

· Text Justification Changed

· Text Refers to a Different
Point

· Text Feature Changed

Compare Triangulation Details
Triangulation changes, which will typically be present if there are any point and line
changes.
· Vertex Status Changed

· Triangle Coordinates
Different

· Triangle Area Different

· Surface Height Different

· Surface Height Different

· Triangle Deleted

Compare All Graphical Differences
Graphic differences, which will typically be present if there are any point and line changes.
They will also be present if there are feature library changes.
· Graphics Appear Different · Graphics Colour Different

· Graphics Weight Different

Stations
· Station Deleted

· Station Plan Position

· Station Height Position
Changed

When using this option, the user will typically not search for graphic and triangulation
changes, as they will usually have been created as a consequence of model editing, which
is shown more succinctly under point and line changes.

32.9.26 Delete Duplicate Points (Model Tools Menu)
This option allows the user to delete all duplicate points in the model, based on horizontal and
vertical tolerances, whether the points are on strings or are discrete points, and whether or not
they have the same feature name.
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Note that deleting all string points with different feature names is generally not a good idea, as
these are common and correct in many surveys, as they indicate the position of a junction
between two features; for example, the common point between a gate and a fence.

32.9.27 Combine LandScape Models (Model Tools Menu)
This option is used when transferring model data from LandScape into SCC. This operation
may be carried out as follows;
1.

Export your model from LandScape as GENIO

2.

Export your model from LandScape as 3DDXF

3.

Export trees from LandScape using the print option

4.

Export stations from LandScape using the print option

5.

Import the trees into SCC using 'File / Import / LandScape ASCII Text Notes' from
the project control screen, and save this trees dataset.

6.

Import the stations into SCC using 'File / Import / LandScape ASCII Stations' from
the project control screen

7.

Model and save the 3D DXF file, selecting the appropriate model scale

8.

Model and save the Genio file, selecting the appropriate model scale

9.

From the model select Tools / Combine LandScape Models, and pick the saved
DXF and GENIO models.

10.

In the new combined model, select Tools / Add strings from file / SCC Dataset, and
select the saved tree file.

11.

Use Copy and Paste to copy the project stations into the model

12.

Save the combined model

Using this sequence of events leaves you with an SCC model that contains the following;
1.

All the reduced line work from the DXF file, with the feature names taken from the
Genio file

2.

All the text from the DXF file with the feature name based on the DXF layer name.

3.

All the stations, annotated from the DXF file, with values in the station file.

4.

All the trees with correct survey dimensions

32.9.28 Search for Orphan Points (Model Tools Menu)
This option searches for, and highlights, all orphaned points in the mode. An 'orphaned' point,
is a single point that, due to editing, is the only point on what otherwise should be a line-string,
such as a kerb or building. Orphan points can cause labelling problems when exporting in
GENIO format to MX/MX or LSS.
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32.9.29 Purge Unused Data (Model Tools Menu)
This option removes unused symbols and feature library entries from the model.

32.10 Model Cloud Menu

32.10.1 Select Data (Model Cloud Menu)
This option allows the user to control how data is selected (i.e. points in a window, points in a
polygon, using a horizontal or vertical section / slice, relative to an alignment, points similar to a
given reference point, points close to another SCC surface) and what to do with picked data.
This includes selecting and deselecting data as per typical SCC usage, locking and unlocking
data which hides the data and prohibits it from being used in future operations, and isloting data
which is the same as locking everything except the picked points.

32.10.2 Edit Selected Points (Model Cloud Menu)
This option provides edit options for selected data: deleting, change feature to another group
available from the drop down list or changing the colour of selected points.
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32.10.3 Copy To New Cloud (Model Cloud Menu)
This option allows the user to easily copy selected data to a new model.

32.10.4 Triangulate Points (Model Cloud Menu)
This option provides a method of producing an optimized triangulation of selected data. This
reduces the amount of points used from the selected points in the cloud to just those required
to achieve the stated vertical tolerance, in this case 10mm.

Note, this option can be slow depending on the parameters and the number of points selected.
To improve performance and final result remove or isolate noisy features such as grass, trees,
cars, street furniture and overhead cables prior to running this option. Only selected points
whose features have an analysis type of Ground are considered when running this option, so
simply changing the feature of such points to any other feature will accomplish this.

32.10.5 Export Points (Model Cloud Menu)
Two export options are available: LAS or PTS files.

32.10.5.1Export LAS
This option exports a LAZ file.

32.10.5.2Export PTS
This option exports a binary format PTS file.
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32.10.6 Point Cloud features (Model Cloud Menu)
This option lists all point cloud features, surface, analysis options (display only, ground, other
surface, other 3d), colour, colour by point (feature, intensity, elevation, feature and intensity or
feature and elevation), visibility (Opaque, Hidden, Transparent), Lock (Yes/No), Size (Small/
Large), Sect Width, Max Dist, Trace Dist, Min Length, Fit Tol., Spike Angle and Spike Distance.

Additional option allow the feature to be easily edited; Add, Delete, Delete All, Global Edit,
Replace, Export, Import. Also, a Cloud Feature file can be customised, save and later
reloaded.

The point cloud feature library is used to break down the cloud into groups of points on similar
feature, e.g. all points corresponding to vegetation, all points corresponding to the road surface
etc… This allows us to fine tune how analysis operations work, as this will change significantly
based on the type of feature. E.g. how we cut sections through the ground will be different to
how we cut sections through more complex 3d features such as buildings.
The point cloud feature fields are as follows;
· Feature – The name of the feature
· Surface – The surface on which the feature is placed. Note that you can have multiple
features placed on the same surface, e.g. trees and bushes might both go on a vegetation
surface
· Analysis – This controls how SCC interprets these points for surface analysis purposes.
Options are
o Display only – The points are displayed only, but not subject to analysis
o Ground – The points are treated in the same way as the triangulation surface in a normal
SCC model, from the point of view of sections, volumes, draping points, extracting levels,
etc…
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o Other surface – The points are treated in a similar manner as an additional triangular
surface, such as a reference model.
o Other 3d – The points are treated as a non-mappable 3d surface, not suitable for surface
analysis operations. Sectioning through 3d surfaces will be considerably slower than
ground / mappable surfaces.
· Colour – The default colour of this feature when not coloured by point
· By – Point clouds can be selectively coloured by point (e.g. RGB as given on input), feature,
intensity, elevation, feature and intensity or feature and elevation. Colour schemes for height
and intensity are as per relief contouring.
· Visibility – Controls whether or not these points are displayed, and if they are displayed
whether they are considered opaque or transparent.
· Lock – Whether or not these points are included in analysis
· Size – The size of displayed points
· Sect. Width – The search corridor width used when cutting sections through this feature.
Note this will typically be small for ground surfaces, e.g. 10mm, and larger for 3d surfaces,
e.g. 100mm – 500mm. The larger this value, the more 3d data will get projected onto a
section and analysed. This in turn can slow down processing and significantly increase the
size of sections produced.
· Max Dist. – For 3d features, the maximum distance to which points will be connected.
· Trace Dist. – For 2d features extracted by tracing selected points, the maximum distance
between adjacent points
· Min. Length – For all traced output, the minimum total string length allowed for a string to be
included in the output.

32.10.7 Point Cloud Options (Model Cloud Menu)
This dialog provides snap tools, section facilities, clipping and depth viewing options and
inactive point methods.

Most SCC options can interact with the cloud in a similar manner to the TIN surface generated
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from a traditional total station or GPS survey. This is largely controlled by use of the point
snapping and sections mechanisms in 'Cloud > Cloud options'. The following snaps are
available;
· Do not snap to cloud – The cloud is not used with other SCC string creation functions.
· Snap to cloud for levels only – The cloud is used in plan view for interpolating elevations only.
· Snap to cloud in 3d – The cloud is snapped to in full 3d, regardless of the viewpoint.
When using could snaps, and interpolating from the cloud as a surface in general, a search
radius is used. If a cloud point is not found within this radius, the cloud snap fails. When
interpolating levels, the underlying TIN is used in place of the cloud in this circumstance. This
allows us to seamlessly mix TIN and cloud interpolation in a single model.
Given that we’re searching for cloud points in a given radius, we can also control how the
selected point or points are determined and used as follows;
· Nearest point – The nearest point to the desired position, e.g. mouse cursor position, is used
· Lowest point – The point with the lowest elevation of the points in range is used. This can be
very useful for manually tracing lines such as bottom of kerb, where bottom of kerb and top
of kerb are very close and difficult to distinguish. If is also very useful for extracting grids of
elevations over ground that may include vegetation and other spurious high points on the
ground such as lamp posts. Note that this option is best selected with small search radii, and
used judiciously.
· High point - The point with the lowest elevation of the points in range is used. This can be
very useful for manually tracing lines such as top of kerb.
· Median point – The point nearest the mean position of all the points in the selection radius is
picked. This can be useful for drawing strings represented by dense linear groups of points
in the cloud, such as walls shown in the slice taken from the cathedral model previously.
· Mean point - The mean position of all the points in the selection radius is picked. This will not
correspond to any one point.
· Nearest 2d (Screen) – The point drawn on screen nearest the mouse cursor is picked.
For options such as sectioning, volumes, extraction of grids, draping of 2d data to extract
levels, etc… the option to Cut sections through the point cloud must be selected. This allows
the cloud to be used in a similar manner to a TIN surface for most SCC surface analysis
operations. Interpolation is limited to points with a feature Analysis set to Ground, so it is very
important to change the feature of all other cloud data, such as vegetation, buildings and
overhead lines, prior to interpolating from the cloud in this manner.
For sectional analysis, we can also specify a level tolerance for smoothing, and horizontal and
vertical tolerances for removing spikes from the section. This is necessary as cloud data is far
denser than conventional survey data and is prone to include a significant amount of noise.
Smoothing and spike removal also greatly reduces the size of the data extracted, which is also
typically beneficial.
Other options on the same dialog control how the point cloud is visualized. These control
whether the display is clipped behind and in front of the viewing plane, typically when using two
point elevations, and how isolated points are displayed. Note that clipping the view has no
effect on point selection in the way that isolating or disabling points would. Displaying Inactive
points allows you to see where your active points are in relation to the rest of the cloud.
Inactive points are always transparent and typically drawn in a lighter colour. Displaying a
reduced number or outline of isolated points will reduce display clutter and improve display
speed on larger clouds.
An additional option allows for multiple processors / cores use when available, which greatly
improves speed of most cloud operations on multi-core PCs.
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32.10.8 Trace Linear features (Model Cloud Menu)
The option 'CLOUD > Trace Linear Features' allows the user to trace linear features contained
in a point cloud by matching points on a section template to points in the cloud at regular
chainages along an alignment.

32.10.9 Trace Outlines From Slice (Model Cloud Menu)
This option will draw outlines based on an isolated sectional area. This can be either from plan,
elevation or based on an oblique viewpoint.

This option has been enhanced to create mean centre lines through cut objects rather than
outlines. Automatic line and arc fitting, and line work tidying, has also been improved as a
result and is considerably faster than in other versions. This applies to any point cloud features
with an Analysis type set to 3D surface, and also to all traces around selected points. Setting
Analysis type set to 3D outline creates an outline rather than a mean line, and is suitable for
smaller cut strings such as rails and cables in cross sections.
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32.10.10Trace Selected Points (Model Cloud Menu)
This option draws outlines based on an isolated sectional area. This can be either from plan,
elevation or based on an oblique viewpoint. The results can then be exported to other
packages, such as CAD, in 2d or 3d, and multiple slices can be used to build-up a wire frame
model from your cloud. The cloud feature library determines how the data is analyses, where
the centre of the displayed section or slice is used as the centre-line for sectioning.
This option has been enhanced to create mean centre lines through cut objects rather than
outlines. Automatic line and arc fitting, and line work tidying, has also been improved as a
result and is considerably faster than in other versions. This applies to any point cloud features
with an Analysis type set to 3D surface, and also to all traces around selected points. Setting
Analysis type set to 3D outline creates an outline rather than a mean line, and is suitable for
smaller cut strings such as rails and cables in cross sections.

32.10.11Search For Model Noise (Model Cloud Menu)
This option automates the remove of model noise whilst allowing the use to define minimum
nearest neighbour, vertical and horizontal ranges when needed.

32.10.12Optimise Triangulation (Model Cloud Menu)
This tool reduces the size of a DTM significantly based on a desired vertical resolution.

Thus if we have a 20k x 20k OS tile of points every 10m, in its raw form it will be made up of 4
million points. If we optimise it,say based on a 0.5m tolerance, this might reduce the size of the
dataset to around 1 million points. The actual size of the final data set is based to a large
degree on the flatness of the terrain in question as well as the vertical resolution required. Our
initial tests show the following;
Vertical resolution Approx. data size reduction:
0.01m

10%

0.05m

18%

0.1m

30%

0.2m

50%

0.5m

70%

1m

85%

2m

93%

©2015 Atlas Computers Ltd

897
The optimisation in use guarantees that no point in the initial data set will be more than the
specified vertical tolerance away from the optimised triangulated surface. Optimised data can
be provided in a variety of point or TIN outputs, such as ASCII, LandXML, DXF, DWG and
GENIO. The following sample shows an original contoured model and optimised TIN model for
the Turlough hill area in Wicklow. Note the removal of points from the optimised TIN model
wherever planar areas were detected in the original:
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In addition large OS tiles, this appears to be a good method of reducing LIDAR data sets that
include a significant amount of largely flat areas such as roads, bodies of water, etc…

32.10.13Point Cloud Properties (Model Cloud Menu)
This option summaries point cloud properties.

32.10.14Smooth (Model Cloud Menu)
This option allows the user to set maximum distance for smooth and tidying the model.

32.11 Model Windows Menu

32.11.1 New Window (Model Windows Menu)
This command to open a new window with the same contents as the active window. The user
can open multiple document windows to display different parts or views of a document at the
same time. If the user changes the contents in one window, all other windows containing the
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same document reflect those changes. When the user opens a new window, it becomes the
active window and is displayed on top of all other open windows.

32.11.2 Cascade (Model Windows Menu)
Use this command to arrange multiple opened windows in an overlapped fashion.

Shortcuts
Toolbar:

Keys:

ALT + W, C

32.11.3 Tile Horizontal (Model Windows Menu)
Use this command to horizontally arrange multiple opened windows in a non-overlapped
fashion.

Shortcuts
Toolbar:

Keys:

ALT + W, H
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32.11.4 Tile Vertical (Model Windows Menu)
Use this command to arrange multiple opened windows vertically side by side.

Shortcuts
Toolbar:

Keys:
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32.11.5 Arrange Icons (Model Windows Menu)
Use this command to arrange the icons for minimized windows at the bottom of the main
window. If there is an open document window at the bottom of the main window, then some or
all of the icons may not be visible because they will be underneath this document window.

32.11.6 Split (Model Windows Menu)
Use this command to split the active window into panes. The user may then use the mouse or
the keyboard arrows to move the splitter bars. When you are finished, press the mouse button
or enter to leave the splitter bars in their new location. Pressing escape keeps the splitter bars
in their original location.
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32.11.7 Zoom Window (Model Windows Menu)
Zooms to a rectangular window defined by two opposite corner points selected by the mouse.

Shortcuts
Toolbar:

Keys:

ALT + W, W

32.11.8 Zoom In (Model Windows Menu)
Increases the apparent size of the model on screen, centred on the section of model where the
mouse is pointed.

Shortcuts
Toolbar:

Keys:
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32.11.9 Zoom Out (Model Windows Menu)
Decreases the apparent size of the model on screen.

Shortcuts
Toolbar:

Keys:

Page Up

32.11.10Zoom Extent (Model Windows Menu)
Zooms to display the extent of the model.

Shortcuts
Toolbar:

Keys:

Home

32.11.11Zoom Previous (Model Windows Menu)
Zooms to the previous display.

Shortcuts
Toolbar:

Keys:

End

32.11.12Zoom Centre (Model Windows Menu)
The current window is centred on the mouse position.

Shortcuts
Keys:

Space

32.11.13Zoom to Scale (Model Windows Menu)
Zooms to the scale specified in the Titles and Grid option

Shortcuts
Toolbar:
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32.11.14Zoom to X, Y Position (Model Windows Menu)
On selecting this option the user will be asked to type in X,Y co-ordinates of the point you wish
to find. This point will be displayed in the centre of the screen at the zoom scale the position
the user was at prior to selecting this option. Therefore if the user zooms in more and then
select this option it will be easier to identify the requested point.

33

Sections
Sections in SCC can be cut from a model, created directly from coordinate or chainage offset
source, or created by searching for all points in a model within a given bandwidth. Cross
sections may be generated with references to an alignment or simple string. Skew cross
sections may also be taken with references to an alignment. Sections may include multiple
surfaces, or may be used to show multiple strings in the same model side by side in elevation.
All section drawing, layout and annotation settings are fully user definable in SCC.

See Also
Section
Section Editing

33.1

Data Selection Dialog (Section)

The following selection options are available within the Sections Data Selection Dialog:

Interactive selection method
Individual points
All points in a window
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Surface lines
Sections

Mark or clear points
Mark selected points
Clear selected points
Mark or clear all sections

Apply Section number range
First Section No.
Last Section No.

Apply Chainage/Offset/Level
Minimum
Maximum

Apply Coordinates range to selection
Minimum
Maximum

Apply Feature range
First Feature
Last Feature

Apply surface range
First Feature
Last Feature
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33.2

Sections File Menu

33.2.1 XML (Section File Menu)
Section data can be loaded and saved in the industry standard XML format, in addition to its
native formats. The following options are available:

Open XML
Save XML
Save As XML
See Also
LandXML (Project File Menu)
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33.2.2 Export Sections (Section File Menu)
The following options are available:

CAD Drawing
See Also
Export CAD drawing (Model & Section File Menu)

Survey Data Set
The following options are available:

Export all surface points
Export all annotated points
Use surface name for feature name
Use cut string feature for feature name
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User Defined ASCII Format
This option allows the user to output sections in a specific format.

Bitmap
This option allows the user to export each section as a bitmap.
For instance, in a section file containing 20 sections at chainage intervals of 10 each
section can be exported as a bitmap and the file name will contain the section file name,
no of section and the chainage value of the specific section 'RiverL,18 of 20, Ch+18.BMP'

HEC-RAS
SCC supports the export of river sections to Hydrological Engineering Centres River
Analysis System (HEC-RAS) software.

ISIS
SCC supports the export of river sections to ISIS software. On export the user can
choose to reverse section order, output coordinates, specify Mannings factors, and specify
whether chainage is output as chainage, distance to next section or distance to last
section.

MIKE
SCC supports the export of river sections to MIKE 11 format.

33.2.3 Attach Feature Library (Section File Menu)
This option attaches a feature library. The library attached will overwrite the current feature
library.
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33.2.4 Load / Save Section Styles (Section File Menu)
This option can be used to load or save all current section drawing parameters to or from a file.
This includes all the parameters listed in the 'VIEW > Scales titles and grids', 'VIEW > Section
sheet layout' and 'VIEW > Annotation settings dialogs.

This allows the user to maintain and distribute multiple section drawing standards. Section
styles are stored with the extension ‘.SectionStyle’ in the SCC executable files directory,
normally C:\SCC.

33.2.5 Import Sections (Sections File Menu)

A new function has been added to import SC0 and SCN files as sections, where the sections
also include all the SC0 and SCN header information. The release includes a new section
style, SC0 SCC.SectionStyle, for drawing these sections to show structure and rail information.
Extra header information is available by querying the section.
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33.3

Sections Edit Menu

33.3.1 Undo (Section Edit Menu)
Use this command to reverse the last editing action, if possible. The name of the command
changes, depending on what the last action was. The Undo command changes to Can't Undo
on the menu if you cannot reverse your last action.

Shortcuts
Toolbar:

Keys:

Ctrl + Z or
ALT + BACKSPACE

33.3.2 Redo (Section Edit Menu)
Redo the last option that was undone.

Shortcuts
Toolbar:
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Keys:

Ctrl + Y

33.3.3 Copy (Section Edit Menu)
Use this command to copy selected data onto the clipboard. This command is unavailable if
there is no data currently selected.
Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar

Keys

CTRL + C

33.3.4 Copy Bitmap to Clipboard (Section Edit Menu)
Use this command to copy the current section to the clipboard.

33.3.5 Paste (Section Edit Menu)
This command is used to paste data present on the clipboard into the opened or existing model
.

See Also
Adding Surface String & Point Data To An Existing Section

33.3.6 Paste Special (Section Edit Menu)
This option is used to paste OLE objects, such as office documents, into your model file.

33.3.7 Add Points (Section Edit Mentu)

Surface
The user can enter a new surfaces name on which to place data being added to the
created section.

Disable annotation for new strings
This options turns off all annotation for new strings being added to the section
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See Also
Adding Surface String & Point Data To An Existing Section

33.3.8 Delete Points (Section Edit Menu)

Delete Points
This option allows the user to delete individual points from a section.

33.3.9 Move Points (Section Edit Menu)
This option allows points in a section to be moved by the user. Select the surveyed point the
user wishes to move using the mouse. The point is now attached to the mouse pointer. Click
the mouse a second time to place the point in its position. To quit this option hit the Escape
key.
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33.3.10 Text (Section Edit Menu)

The following text options are available: Create Text (Section Edit Menu), Delete Text (Section
Edit Menu), Move Text (Section Edit Menu), Rotate Text (Section Edit Menu), Move and Rotate
Text (Section Edit Menu), Resize Text (Section Edit Menu), Copy Text (Section Edit Menu),
Edit Existing Text (Section Edit Menu) and Show / Hide Macro Text (Section Edit Menu)

Create Text
This option presents the Create / Edit text dialog box.

Type in the text to add to the model. Then click on the model to insert the text. The user
may set the height, width, rotation and justification of the text in the dialog or interactively
when the text is inserted into the model. Font information for the text will be determined
by the current text style.
There is also the option of adding X,Y and Z co-ordinates (in text form) to the model using
the nearest and interpolation macros available. To do this, select X,Y or Z from either ‘Get

©2015 Atlas Computers Ltd

914
the nearest point’ or ‘Interpolate from model’. As the user moves the cursor about the
model, the text will be automatically updated, giving either the interpolated co-ordinates of
the point at the end of the cursor of the co-ordinates of the nearest point, depending on
the option selected. Left click mouse to position text. Ticking the ‘enable dynamic update’
option means that if at a later stage you have to move the text, it will be updated
automatically to display the co-ordinates of the new position.

Shortcuts

33.3.11 Symbols (Section Edit Menu)

The following symbol options are available: Insert Symbol (Section Edit Menu), Delete Inserted
Symbol (Section Edit Menu), Move Inserted Symbol (Section Edit Menu), Rotate Inserted
Symbol (Section Edit Menu), Resize Inserted Symbol (Section Edit Menu), Edit Inserted Symbol
Details (Section Edit Menu), Delete Symbol From Library (Section Edit Menu), Import Symbol
Form File (Section Edit Menu), Import Symbol From DXF (Section Edit Menu), Export Symbol
To File (Section Edit Menu) and Edit Symbol Insert Points (Section Edit Menu)

Insert Symbol
This option allows the user to insert a symbol in the model and to specify its size, position
and rotation. Selecting the option displays the ‘Create/Edit Symbol’ Dialog. Selecting any
of the ‘Apply..’ boxes allows you to edit this value with the mouse, otherwise values may
be entered directly into the dialog box. Pressing Apply, or the left mouse button inserts
the symbol in the model. Press Escape to finish this option.
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Shortcuts

33.3.12 Hatch between strings (Section Edit Menu)
This option allows the user to hatch between two strings. The 'Create polygon hatch' dialog is
present to allow you to specify the angle, spacing and hatch type before selecting the specific
strings to hatch between.
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33.3.13 Descender Annotation (Seciton Edit Menu)

Add extra descenders
This option allows the user to add extra descenders to the section graph by defining a
specific chainage range and interval value. The user can select ‘all’ to define all sections
and between all chainages, otherwise a value must be entered.

The dialog above shows that the user has defined that extra descenders are to be added
to all graphs (in this case, one) at 5m intervals along the entire length of the profile.

Delete descenders
This option allows the user to delete descenders from the section graph between a
specific chainage range. The user must enter the number of the graph to be edited
(selecting ‘all’ for all graphs) and also the chainage range.
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Remove Text
This option allows the user to hide/replace text along the section graph by specifying the
row, graph number, chainage range and the surface the user wishes it applied to.

Edit Annotation Mask
This option allows the user to edit any of the annotation masks already specified on the
section graph. The user may also use this dialog to delete any of the existing changes and
add new ones.

33.3.14 Query and Edit Points (Section Edit Menu)
The Query and Edit function can be utilised to obtain specific information in relation to a point
on the section:
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This option supports editing of all river specific information, including position of banks, low
water points, section type and ID, and MIKE-11 and ISIS specific chainages. This enables any
cross sections to be easily manually converted to river sections for output to packages such as
ISIS, MIKE-11 and HEC-RAS.

See Also
Query Points (Section Edit Menu)

33.3.15 Subdivide Profiles (Section Edit Menu)
This option allows the user to sub-divide the profile either at a specified chainage or at regular
intervals along the section.
This makes for easier layout design where profiles can be spilt at specific sections along the
graph so as to fit on particular sheet sizes.

33.3.16 Append Surfaces (Section Edit Menu)
This option adds data from another surface, whether comprising of long sections or cross
sections. This allows sections depicting graphs with a number of ground profiles lines, taken
from multiple surfaces. For example, top soil strip, unsuitable material, rockhead etc. Data is
added in the form of new surface ground profile line for the current surface, on the existing
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graphs. An extra annotation box is added to each graph to annotate elevations for this surface.
The Open dialog is presented to allow the extra model to be selected

Shortcuts
Toolbar:

33.3.17 Append Other Model Data (Section Edit Menu)
This options allows for addition specific data to be added to a section.

33.3.18 Reverse Sections (Section Edit Menu)
This option support reverses the direction of all river sections in a file, while also giving the
option to renumber the offsets to zero form the left hand edge. It does not affect the Chainage.
This option gives the user the ability to convert sections from up river orientation to a down
river orientation without having to re-edit the sections, thus allowing the user to output the
sections in multiple formats with differing orientation requirements. Note that the reverse
section option supports multiple surfaces and section string detail, but does not currently work
on sections with colour coded volumes.

33.3.19 Volumes (Sections Edit Menu)
This option allows the user to calculate and display cut and fill volumes between any two
surfaces shown in the section graph using an end areas method. Volume is displayed and
calculated incrementally by chainage along the long section or string. To use this option the
section graph must contain two surfaces. The total area and volume of cut and/or fill is
calculated at each cross section.

Volumetrics Report File Name
The name given to the report name. This file will contain either full or abbreviated
volumetric analysis report.

Existing Surface
This is the name of the existing ground model. As such it must have been created with
the create TIN model option and added to the section file. The existing ground model will
normally be your surveyed model.
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Proposed Surface
This is the name of the proposed or design surface. As such it must have been created
with the create TIN model option and added to the section file. The proposed ground
model will normally be a design model or previous surveyed model.

Annotate Areas and Volumes
This option specifies whether areas and cumulative volumes of cut and fill will be
annotated at each cross section.

Highlight Cut/Fill Areas
This switch defines whether areas of cut/fill will be displayed on the cross section graph.

The effect of curvature on cross section volumes
It is usually assumed when calculating prismoidal and end-area volumes, that the cross
sections are parallel. When this is not the case, and the excavation is curved, the sections
are radial and a curvature correction must be applied.
Pappus’s Theorem states that the correct volume is where the distance between the
cross sections is taken along the path of the centroid.
SCC calculates a center of gravity or centroid for the cut and fill area of each section.
Where sections are likely to include multiple cut and fill areas, the curvature correction
should not be applied, as the center of gravity may not be appropriate.
It must be noted also that curvature corrected values are NOT typically applied to
earthworks in practice. For more accurate volumes, it is best to use isopachyte and grid
methods.

Shortcuts
Toolbar:

33.3.20 Optimise Section Volumes (Section Edit Menu)
The optimise section volumes function allows the user to optimise a design centreline to
minimise the amount of cut required in a dredging or similar situation where excavation is
required, it does this by shifting the design section in relation to the survey section for every
section in a set of sections such that the cut volume is minimised.

Offset Interval
Offset Interval is the value, which the design section is iteratively shifted with respect to
the survey river section. The larger the offset interval value the quicker the optimisation
©2015 Atlas Computers Ltd

921
processes. The smaller offset interval value the slower but more accurate the
optimisation process. For example, the default value is 0.1 means that the design section
will be placed within 0.1m of the optimum position.

Maximum Additional Shift per Section
This parameter controls the amount the design section may be shifted in position relative
to the position of the previous design section. The value controls the maximum deviation
of the optimised centre line from the original centre line. For example, a value of 2m
would mean that the centreline position of the current design section could only deviate a
maximum of 2 m from the design centreline. A large value can potential allow the
optimum design centreline to zig zag across the river in order to optimise or to minimized
the dredged volume. A smaller value prevents the optimum centreline from deviating
sharply away from the design centreline.

33.3.21 Renumber River Chainage (Section Edit Menu)
This tool can be used to renumbering of MIKE-11 and ISIS chainages, in both forward and
backward directions.

33.3.22 Transform Coordinates (Section Edit Menu)
This option permits the user to create or edit a transformation from one co-ordinate system to
another.

See Also
Transform Coordinates

33.3.23 Insert New Object (Section Edit Menu)
Inserts and embeds an object, such as a chart or an equation in a document.

See Also
Insert New Object (Model Edit Menu)

33.3.24 Links (Section Edit Menu)
This option list and edit links to embedded documents.

33.3.25 Object (Section Edit Menu)
The option allows the user to Select the object by clicking on it and the following options are
activated.
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Display Content
Display the object in its original format. This option is used if the object is currently
displayed as an icon.

Display Icon
Displays the object as its source program icon. This option is used if the contents of the
object are currently displayed in the active SCC document.

Reset Size
Change the size of the object or the icon representing the object in the current document.

Clone
Make a copy of the current object

Delete
Delete the object from the current document
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33.4

Section View Menu

33.4.1 Scales, Titles And Grids (Section View Menu)
This option allows the user to set the scales, titles and grids to be drawn in relation to the
section graph. Selecting this option presents you with a dialogue containing the following
parameters;

Horizontal Scale
This value is the plot scale that is used when determining text and symbol sizes for
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section graph annotation.

Vertical Exaggeration
This is the vertical exaggeration multiplier used when forming the profile graph. This
allows grade changes to be more easily identified. The vertical scale is equal to the
horizontal scale divided by the vertical exaggeration, for example, if the horizontal scale is
1:1000 and the vertical exaggeration is 4 the vertical scale would be 1:250.

First Chainage
This value is a constant that will be added to all chainages for the purposes of output. If
the first point on the section is chainage 0 then this value will be 0. This facilitate is
particularly useful when dealing with partial or incomplete surveyed long sections.

First Offset
This value is a constant that will be added to all offsets for the purposes of output. If the
centre point on the cross section is offset 0 then this value will be 0.

Section Graph Titles
This option allows you to modify the titles that are displayed with each section. You can
add titles, deletes existing titles or even change the order in which they appear on the
section. There is also the option to define the colour, size, orientation and position of each
piece of text independently by entering values in the relevant fields and then selecting the
‘OK’ button.

This option also allow inclusion of user defined attribute information, such as SC0
headers, in the section title. These are implemented as text macros, where the macro
[ATTR:<Attr Name>] can be used for a section specific attribute and [USER:<Attr Name>]
for a global attribute. For example, [Attr:DIST] would be used to annotate the distance
from an SC0 file.
SCC will default to using the annotation specified in the ‘Title’ field unless text is otherwise
entered in the ‘User Title’ field. Default titles can be accessed by clicking on any box in the
‘title’ column and selecting a title from the pull down menu.

Text Sizes
Graph Title
This is the text size used for the graph title, it requires that the plot scale be entered to
operate.

Descender Annotation
This is the text size used when annotating graph descenders, it requires that the plot scale
be entered to operate.
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Default colours and styles
Title and grid
This field contains the colour used for the profile construction grid.

First surface profile
This field contains the colour used for the ground profile line for the first surface. Profile
lines for other surfaces are given other colours.

Areas in cut
This field contains the colour filling areas of cut in a cross section graph.

Areas in fill
This field contains the colour filling areas of fill in a cross section graph.

Section Line Thickness
This field allows the thickness of the surface lines on the profile or sections to be set.
When this option is changed select the option Apply Defaults to sections.

Apply Defaults to sections
This option applies any changes made in this dialog to the section file before closing the
dialog. This option must be selected to apply any changes made in this section of the
dialog.

Horizontal grid interval
This is the distance, in meters, at which horizontal construction lines are drawn.

Annotate areas & volumes
This option specifies whether areas and cumulative volumes of cut and fill will be
annotated at each cross section.

Highlight cut/fill areas
This switch defines whether areas of cut/fill will be displayed on the cross section graph.

Sheet Titles
This title box is used to enter information about the current section drawing. When a sheet
template is inserted into the section, the relevant data is atuomatically updated to the
sheet.
This option only works if the sheet macros have been used to create the sheet template.

Title box width
This option allows you to control the width of the title box, and whether or not it is drawn.
Selecting a value of ‘auto compute width’ will compute the width base on the width of the
title items, and draw the title box. Selecting any other value will use the entered width for
positioning the title text and drawing the box.

Section width calculation
This option controls how the width of an individual sections is calculated. This may be
base on the 2d template width or the extents of the 3d surface cut. For example, if the
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section was specified as having a 25m left and right offset, and the former option was
selected, all graphs will be generated with a width of 50m. If the latter option is selected,
individual graphs may be narrower than this, based on the width of the model cut.

Shortcuts
Toolbar:

33.4.2 Section Sheet Layout (Section View Menu)
This option allows the user to insert a sheet and control the layout of the sections on that sheet.
Selecting this option presents a dialogue containing the following parameters;

Sheet Type
This option allows you to select your sheet type from the list.

Organisations of Sections on sheet
This option allows you to select the way in which you want your sections displayed on the
sheet.

‘Fixed number of sections per sheet’ allows you to fix the amount of sections you
want displayed on a sheet, by rows and columns.

‘Variable number of sections per sheet’ ‘allows you to display variable amounts of
sections on a sheet by entering specific values for spacing between rows and columns.

Order in which Sections are drawn
This option allows the user to set the order for the sections to appear on the sheet. The
four options are:
· columns in ascending order of chainage
· rows in ascending order of chainage
· columns in descending order of chainage
· rows in descending order of chainage
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Graph Datum
This option allows the user two options:
· To enter a datum value which is used as the datum on all sections.
· To compute a relevant datum for individual sections. This value is computed as the next
lowest grid interval below the lowest point on the graph. The horizontal grid interval may
be specified in the scale,titles and grids menu.
For example, if the lowest point on the section graph is 45.000m and the horizontal grid
interval is 10m, then the computed datum is 40.000m.

33.4.3 Annotation Settings (Section View Menu)
This option determines the annotation of section descenders and allows the user to select
descender placement, text, style and colours for example.

Predefined Descender types can be selected.
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Additional descenders have been include to support river section functionality and required
exports to HEC-RAS, ISIS and MIKE formats: Chainage/Offset, Elevation, Plan X, Plan Y,
Gradient, Feature Name, Height Difference, Slope Distance, Partial Chainage, Culm. Slope
Distance, Culm. Horizontal Distance, Right Culm. Horizontal Distance, Offset to river low point,
R. Ofs to river low point, Offset to left bank, R. Ofs to right bank, Offset to lowest point, Offset
to highest point, R. Ofs to lowest point, R. Ofs to highest point, H. Distance to lowest point, H.
Distance to highest point.
Level (All surfaces), has been added to annotate levels from all surfaces and features in a
single row rather than by surface.

33.4.4 Radial Annotation (Section View Menu)
This options allows for extra annotators at specific angles as well as offsets.
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33.4.5 Next Section Sheet (Section View Menu)
This option allows the user to scroll through the section sheets from the current sheet back to
sheet 1.

Shortcuts
Toolbar:

Keys:

+

33.4.6 Previous Section (Section View Menu)
This option allows the user to scroll through the section sheets from the current sheet onwards
.

Shortcuts
Toolbar:

Keys:

-

33.4.7 Snap Controls (Section View Menu)
The following snap controls are available within a section file:

33.4.8 Feature Library (Section View Menu)
Feature names in sections are automatically generated as follows;
The first character is the surface number, starting at 0 for the first surface. For grid lines and
annotation the first character is set to 'G', for title blocks 'T', for cut area polygons 'C' and for fill
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area polygons 'F'. The second character corresponds to the annotator or title text number ,
starting with 0. The third character corresponds to the descender type, i.e. surface intersection,
change of direction, string intersection or end point. The remaining characters contain the first
four characters of the cut string feature name.
This naming convention has been used such that entire blocks of related information can be
easily manipulated in SCC sections that have been exported to CAD.

33.4.9 Status Bar (Section View Menu)
The status bar is displayed at the bottom of the SCC window.

See Also
Status Bar (Model View Menu)

33.4.10 Customise (Section View Menu)
This option allows the user to select the toolbars which SCC displays and to create new users
defined toolbars.

See Also
Customised (Model View Menu)

33.4.11 Extended Styles (Section View Menu)
This option defines how the toolbars appear.

33.4.12 Keyboard short-cuts (Section View Menu)
This option allows the user to select a combination of keystrokes which may be used as
shortcuts for any menu command in SCC. Keyboard shortcuts will generally only be defined on
commands that are used very often. There is an option in the General Options to disable this
option. The option Disable user Defined keyboard shortcuts is in the Directories and Files
section of the General Options.
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33.5

Section Window Menu

33.5.1 New Window (Section Window Menu)
This command to open a new window with the same contents as the active window. The user
can open multiple document windows to display different parts or views of a document at the
same time. If the user changes the contents in one window, all other windows containing the
same document reflect those changes. When the user opens a new window, it becomes the
active window and is displayed on top of all other open windows.

33.5.2 Cascade (Section Window Menu)
Use this command to arrange multiple opened windows in an overlapped fashion.

See Also
Cascade (Model Windows Menu)

33.5.3 Tile Horizontal (Section Window Menu)
Use this command to horizontally arrange multiple opened windows in a non-overlapped
fashion.

See Also
Tile Horizontal (Model Windows Menu)

33.5.4 Arrange Icons (Section Window Menu)
Use this command to arrange the icons for minimized windows at the bottom of the main
window. If there is an open document window at the bottom of the main window, then some or
all of the icons may not be visible because they will be underneath this document window.
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33.5.5 Split (Section Window Menu)
Use this command to split the active window into panes.

See Also
Split (Model Windows Menu)

33.5.6 Zoom Window (Section Window Menu)
Zooms to a rectangular window defined by two opposite corner points selected by the mouse.

Shortcuts
Toolbar:

Keys:

ALT + W, W

33.5.7 Zoom In (Section Window Menu)
Increases the apparent size of the model on screen, centred on the section of model where the
mouse is pointed.

Shortcuts
Toolbar:

Keys:

Page Down

33.5.8 Zoom Out (Section Window Menu)
Decreases the apparent size of the model on screen.

Shortcuts
Toolbar:

Keys:

Page Up

33.5.9 Zoom Extents (Section Window Menu)
Zooms to display the extent of the model.

Shortcuts
Toolbar:
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Keys:

Home

33.5.10 Zoom Previous (Section Window Menu)
Zooms to the previous display.

Shortcuts
Toolbar:

Keys:

End

33.5.11 Zoom Centre (Section Window Menu)
The current window is centred on the mouse position.

Shortcuts
Keys:

Space
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